HTTP Сервисы: Путь к своему сервису. Часть 2

Публикация № 885287 13.08.18

Приемы и методы разработки - Инструментарий разработчика

HTTP-сервис API JSON IIS http web apache сервис Публикатор Линк PAPI Pretty API atom-xml XML oData Код состояния Get Post Patch

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 1». В этой части будет "Микс" из OData+HTTP-Сервис(Get)+СКД. Наш пример будет работать как в браузере, так и в написанной нами обработке. Работать будем с разными версиями платформ.

В первой части мы создали каркас для Get метода в расширении конфигурации. Как Вы помните, мы получали через один метод список или конкретный документ, давайте рассмотрим еще один инструмент, позволяющий без особого труда и без доработок конфигурации получать те же данные. Как Вы догадались, начнем разговор с OData, далее смиксуем OData с нашим сервисом который будет возвращать данные на основе СКД. 

Как и в предыдущей статье http-сервис будет в расширении конфигурации ERP 2.4.3.145 на платформе 8.3.10.2650, а вот посылать запросы и получать ответы будем в Демо конфигурации БСП 3.0.1.231 на платформе 8.3.12.1567. Специально чтобы версии платформы отличались.

Начнем.

Немножко про OData.

Для начала дам ссылки, где можно почитать про использование OData в 1с:

  1. Глава 17.2.1. Cтандартный интерфейс OData
  2. Приложение 12. Описание сущностей, предоставляемых через стандартный интерфейс OData
  3. Способы интеграции с 1С

Давайте кратенько пройдем по основным пунктам.

 
1 Как опубликовать OData? 

 В конфигураторе Администрирование/Публикация на веб-сервере...

 
2 Из чего складывается URL OData? 

http://host/base/odata/standard.odata/ПрефиксИмени_ИмяОбъектаКонфигурации_СуффиксИмени/Параметры?Параметры&УсловияОтбора

host – IP адрес или доменное имя веб сервера.

base – Имя базы. Указывается при публикации.

odata/standard.odata - Признак обращения к стандартному интерфейсу OData.

ПрефиксИмени - Представление объекта конфигурации для указания в URL (Объекты доступные в OData и их префиксы описаны в главе 17.2.1.4. Правила формирования имени ресурса, а так же можно посмотреть с помощью обработки Доступный состав стандартного интерфейса OData).

ИмяОбъектаКонфигурации - свойство Имя объекта конфигурации, как оно задано при разработке прикладного решения в конфигураторе.

СуффиксИмени - предназначено для уточнения имени ресурса и является необязательной частью имени. В качестве суффикса имени могут выступать следующие выражения:

  • Имя табличной части объекта;
  • Имя реквизита табличной части или набора записей;
  • Имя виртуальной таблицы регистра;
  • RowType;
  • RecordType.

Праметры и УсловияОтбора – В качестве параметров обращения выступают параметры в виде, принятом для HTTP-запросов: ?ключ=значение&ключ2=значение2.
При обращении к ресурсу могут использоваться специальные ключевые слова, имеющие специальное назначение:

  • $format - указывает, в каком формате необходимо получить данные. Если ключевое слово не указано, данные получаются в формате atom-xml.
  • $format=atom - возвращает данные в формате atom-xml.
  • $format=json - возвращает данные в формате json. Для указания того, что данные должны возвращаться в формате json, можно указать MIME-тип application/json в заголовке Accept HTTP-запроса на получение данных.
  • $metadata - указывает, что требуется получить описание стандартного интерфейса OData.
  • $filter - описывает отбор, применяемый при получении данных.
  • $select - описывает перечень свойств сущности, которые получаются при обращении к стандартному интерфейсу OData. 
 
 3 Какие HTTP-методы используется в OData?
  • GET - Получение данных;
  • POST - Создание объекта;

Обновление данных:

  • PATCH - в этом случае можно указывать только те свойств, которые необходимо обновить;
  • PUT - в этом случае необходимо указывать все свойства сущности;
  • DELETE - Удаление данных.

Лично я использую только GET, так как изменение, добавление и тем более удаление данных через OData считаю неправильным (потенциально опасным) для Учетных систем. Данные методы могут быть хороши для конфигурации разработанной например под мобильный клиент, ну или под сайт.

Давайте узнаем, сколько элементов в справочнике Склады в Демо конфигурации ERP 2.4.3.145.

Для этого мы будем использовать параметр $count. Наш запрос: 

http://127.0.0.1/DemoEnterprise2_4_3_145/odata/standard.odata/Catalog_Склады/$count

Как мы видим, получить данные не удалось. В чем же дело?

Дело в том, что начиная с версии платформы 8.3.5.1068 необходимо использовать метод УстановитьСоставСтандартногоИнтерфейсаOData для того чтобы объекты конфигурации были доступны для использования в OData. Давайте воспользуемся обработкой Доступный состав стандартного интерфейса OData и дадим доступ к нужному нам справочнику.

Проверяем наш запрос еще раз.

Как мы видим в конфигурации 49 элементов справочника Склады.

 

Давайте нарисуем сервис по получению остатков на складе, при этом в ЕРП мы будем брать за основу отчет «ОстаткиИДоступностьТоваров» и на основании СКД макета будем получать данные и возвращать их в формате JSON (Реализовано в версии 8.3.6.1977). Обращаться к сервису будем с помощью обработки из конфигурации на платформе 8.3.12.

Хочу сразу сказать json выбран из-за своей компактности, удобочитаемости и легкости работы с данным форматом.

 
Для примера сравните atom-xml и json, я вывел один и тот же элемент в этих форматах. 

Для начала нам нужно получить в обработку перечень складов (наименование и идентификатор), при этом склады должны быть элементами, не помеченными на удаление.

Проверим сколько таких элементов: http://127.0.0.1/DemoEnterprise2_4_3_145/odata/standard.odata/Catalog_Склады/$count?$select=Ref_Key,Description&$filter=DeletionMark eq false and IsFolder eq false&$format=json;odata=nometadata

38 это немного, нас это вполне устраивает, будем создавать на форме реквизит cклад, и заполнять список данными полученными по OData.

Создаем обработку «ПолучитьОстаткиИДоступностьТоваров.epf», добавляем форму и добавляем на нее реквизит «Склад» с типом строка и команду ЗагрузитьСклады

 
 Текст команды ЗагрузитьСклады
&НаКлиенте
Процедура ЗагрузитьСклады(Команда)
	ПолучитьСписокСкладовНаСервере();	
КонецПроцедуры
&НаСервере
Процедура ПолучитьСписокСкладовНаСервере()
	//Чистим список
	Элементы.Склад.СписокВыбора.Очистить();
	
	//В тестовых обработках так делать можно, но когда делаете в рабочей такие вещи НЕДОПУСТИМЫ!
	//Храните логины и пароли в недоступных для глаз местах! (https://its.1c.ru/db/v8std#content:2149184389:hdoc) 
	перПорт = 0;
	перСервер = "127.0.0.1";
	перПользователь = "Администратор (ОрловАВ)";
	перПароль = "";

	//Формируем запрос для OData
	перРесурсНаСервере = "/DemoEnterprise2_4_3_145/odata/standard.odata/";	
	перРесурсНаСервереФин = перРесурсНаСервере + 
	"Catalog_Склады?$select=Ref_Key,Description&$filter=DeletionMark eq false and IsFolder eq false&$format=json;odata=nometadata";
	
	Попытка
		Если перПорт <= 0 Тогда 
			HTTPСоединение = Новый HTTPСоединение(перСервер,,перПользователь,перПароль);
		Иначе 
			HTTPСоединение = Новый HTTPСоединение(перСервер,перПорт,перПользователь,перПароль);
		КонецЕсли;
		
		HTTPЗапрос= Новый HTTPЗапрос(перРесурсНаСервереФин);
		HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
		
		РезультатМассив = Новый СписокЗначений;	
		Если HTTPОтвет.КодСостояния = 200 Тогда 
			Ответочка = HTTPОтвет.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);	
					
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(Ответочка);
			Попытка
				ДопДанные = ПрочитатьJSON(ЧтениеJSON);
			Исключение
				ДопДанные = "";
			КонецПопытки;
				
			Если ТипЗнч(ДопДанные) = Тип("Структура") Тогда
				//Заполняем список Складов
				Если ДопДанные.Свойство("Ref_Key") и ДопДанные.Свойство("Description") Тогда 
					Элементы.Склад.СписокВыбора.Добавить(ДопДанные.Ref_Key,ДопДанные.Description);
				ИначеЕсли ДопДанные.Свойство("value") Тогда
					ДопДанные = ДопДанные.value;
					
					Если ТипЗнч(ДопДанные) = Тип("Массив") Тогда	
						Для Каждого элМассива из ДопДанные Цикл 
							Если ТипЗнч(элМассива) = Тип("Структура") Тогда
								Если элМассива.Свойство("Ref_Key") и элМассива.Свойство("Description") Тогда 
									Элементы.Склад.СписокВыбора.Добавить(элМассива.Ref_Key,элМассива.Description);	
								Иначе
									//Нет Ref_Key
								КонецЕсли;
							КонецЕсли
						КонецЦикла;
					КонецЕсли;
				Иначе
					//Нет Ref_Key
				КонецЕсли;	
			Иначе 
				//не смогли прочитать
			КонецЕсли;	

		КонецЕсли;
	Исключение
		Сообщить("Подключится к ERP не получилось: "+ОписаниеОшибки());	
	КонецПопытки;
	
	HTTPСоединение = Неопределено;

КонецПроцедуры

 

У реквизита Склад делаем РежимВыбораИзСписка

Первая часть сделана, давайте перейдем к нашему отчету в ЕРП.

Мы видим следующую картину:

Это значит, что при попытке программно получить данные из СКД в ДеревоЗначений мы получим ошибку.

 
 Ошибка при вызове метода контекста (Выполнить)

        МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновки, НастройкиКомпоновки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));

по причине:

Ошибка компоновки макета

по причине:

Ошибка генерации макета

по причине:

Не поддерживается вывод таблиц и диаграмм в универсальную коллекцию значений

Есть несколько путей решения данной проблемы, я пойду самым простым. В расширение добавлю отчет и создам в нем нужный мне макет.

Теперь можно создать новый метод «ОстаткиИДоступностьТоваровПоСкладу». Подготовлю почву под следующую часть данного цикла статей и создам модуль «PAPI_ОбработкаУниверсальныхМетодов»

 
 Код модуля PAPI_ОбработкаУниверсальныхМетодов
#Область Методы
Процедура ПолучитьОстаткиИДоступностьТоваровПоСкладу(СтруктураОтвет,СтруктураВхПараметров) Экспорт 
	//ПраметрыЗапроса - number
	Склад_Key = СтруктураВхПараметров.ПараметрыЗапроса.Получить("Ref_Key");

	Если не Склад_Key = Неопределено Тогда
		//Получаем Склад
		Попытка
			Склад = XMLЗначение(Тип("СправочникСсылка.Склады"), Склад_Key); 
		Исключение
			Склад = Неопределено;
		КонецПопытки;
		
		Если ЗначениеЗаполнено(Склад) Тогда 
			//Получаем схему компоновки и вариант отчета
			//СхемаКомпоновки = Отчеты.ОстаткиИДоступностьТоваров.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
			//ВариантНастроеки = СхемаКомпоновки.ВариантыНастроек.Найти("ОстаткиИДоступностьТоваров");	
			СхемаКомпоновки = Отчеты.PAPI_ХранилищеМакетов.ПолучитьМакет("СКД_ОстаткиИДоступностьТоваров_HTTP");
			ВариантНастроеки = СхемаКомпоновки.ВариантыНастроек.Найти("ОстаткиИДоступностьТоваровНеТаблица");
			НастройкиКомпоновки = ВариантНастроеки.Настройки;	
				
			//Взято из модуля отчета.ОстаткиИДоступностьТоваров "ПриКомпоновкеРезультата"++	
			ТекстЗапроса = СхемаКомпоновки.НаборыДанных.Основной.Запрос;

			ТекстЗапроса = СтрЗаменить(
				ТекстЗапроса, 
				"&ТекстЗапросаВесНоменклатуры", 
				Справочники.УпаковкиЕдиницыИзмерения.ТекстЗапросаВесУпаковки("Набор.Номенклатура.ЕдиницаИзмерения", "Набор.Номенклатура"));
					
			ТекстЗапроса = СтрЗаменить(
				ТекстЗапроса, 
				"&ТекстЗапросаОбъемНоменклатуры", 
				Справочники.УпаковкиЕдиницыИзмерения.ТекстЗапросаОбъемУпаковки("Набор.Номенклатура.ЕдиницаИзмерения", "Набор.Номенклатура"));

			СхемаКомпоновки.НаборыДанных.Основной.Запрос = ТекстЗапроса;
			//Взято из модуля отчета.ОстаткиИДоступностьТоваров "ПриКомпоновкеРезультата"--                           	
					
			ПрараметрОтбора = НастройкиКомпоновки.Отбор.Элементы;
			СкладПолеКомпоновки = Новый ПолеКомпоновкиДанных("Склад");
			Для Каждого СтрокаОтбора из ПрараметрОтбора Цикл 
				Если СтрокаОтбора.ЛевоеЗначение = СкладПолеКомпоновки  Тогда
					СтрокаОтбора.Использование 	= Истина;
					СтрокаОтбора.ВидСравнения 	= ВидСравненияКомпоновкиДанных.Равно;
					СтрокаОтбора.ПравоеЗначение = Склад; 	
				КонецЕсли;
			КонецЦикла;	
						
			КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
			
			МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновки, НастройкиКомпоновки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
				
			ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;     
			ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,,,Истина);
			
			ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;     
			ДеревоЗначений = Новый ДеревоЗначений;     
			ПроцессорВывода.УстановитьОбъект(ДеревоЗначений);         	
			ПроцессорВывода.Вывести(ПроцессорКомпоновки);
				
			//Обходим дерево и формируем РезультатОтвет
			РезультатОтвет = Новый Массив;
			Для Каждого ВерхнийУровеньДерева Из ДеревоЗначений.Строки Цикл	
				Для Каждого ПодчиненныйУровеньДерева Из ВерхнийУровеньДерева.Строки Цикл	
					Если ЗначениеЗаполнено(ПодчиненныйУровеньДерева.Номенклатура) 
						И ТипЗнч(ПодчиненныйУровеньДерева.Номенклатура) = Тип("СправочникСсылка.Номенклатура") 
					Тогда 
						РезультатОтвет.Добавить(Новый Структура("ИмяЗначение,Артикул,Guid,ДоступноСейчас,Остаток",
						ПодчиненныйУровеньДерева.Номенклатура.Наименование +
							?(ЗначениеЗаполнено(ПодчиненныйУровеньДерева.Характеристика),
								","+Строка(ПодчиненныйУровеньДерева.Характеристика),""),
						ПодчиненныйУровеньДерева.НоменклатураАртикул,
						XMLСтрока(ПодчиненныйУровеньДерева.Номенклатура),
						ПодчиненныйУровеньДерева.ДоступноСейчас,
						ПодчиненныйУровеньДерева.ВНаличии));
					КонецЕсли;	
				КонецЦикла;
			КонецЦикла;
				
			//РезультатОтвет в JSON
			ПараметрыJSON	= Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " " , Истина, ЭкранированиеСимволовJSON.Нет, Ложь, Ложь, Ложь, Ложь);
			ЗаписьJSON		= Новый ЗаписьJSON;
			ЗаписьJSON.ПроверятьСтруктуру = Истина;
			ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);

			ЗаписатьJSON(ЗаписьJSON, РезультатОтвет);
			Результат = ЗаписьJSON.Закрыть();
				
			СтруктураОтвет.ДанныеОтвета = Результат;
			
			СтруктураОтвет.Вставить("ФорматОтвета",PAPI_ОбщиеПроцедурыИФункции.ФорматОтветаJSON());
		Иначе
			PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Не заполнен или неверно заполнен параметр ""Ref_Key""",ложь,"");	
		КонецЕсли;	
	Иначе
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Отсутствует параметр ""Ref_Key""",ложь,"");	
	КонецЕсли;	
КонецПроцедуры	
#КонецОбласти

 

Так же добавим модуль PAPI_ОбщиеПроцедурыИФункции

 
 Код модуля PAPI_ОбщиеПроцедурыИФункции
//Заполняем структуру ответа
Процедура ЗаполнитьСтруктуруОтвета(СтруктураОтвет,КодОтвета,ТекстОшибки,Отработало,ДанныеОтвета) Экспорт
	СтруктураОтвет.КодОтвета 	= КодОтвета;
	СтруктураОтвет.ТекстОшибки	= ТекстОшибки;
	СтруктураОтвет.Отработало	= Отработало;
	СтруктураОтвет.ДанныеОтвета = ДанныеОтвета;	
КонецПроцедуры


#Область ФорматыОтвета
Процедура ВозвращаемНужныйФорматОтвета(Ответ,СтруктураОтвет) Экспорт
	
	Если СтруктураОтвет.Свойство("ФорматОтвета") Тогда 
		ФорматОтвета = СтруктураОтвет.ФорматОтвета;
	Иначе
		ФорматОтвета = "";
	КонецЕсли;	

	Если ВРег(ФорматОтвета) = Врег(ФорматОтветаJSON()) Тогда 
		Ответ.Заголовки.Вставить("Content-Type","application/json; charset=utf-8");
	Иначе 	
		Ответ.Заголовки.Вставить("Content-Type","text/html; charset=utf-8");
	КонецЕсли;
КонецПроцедуры

Функция ФорматОтветаJSON() Экспорт 
	Возврат "JSON";	
КонецФункции
#КонецОбласти

 

Подредактируем модуль PAPI_ОбработкаМетодовGET, добавим в него новый метод "ОстаткиИДоступностьТоваровПоСкладу" и уберем процедуру "ЗаполнитьСтруктуруОтвета"

 
 Код модуля PAPI_ОбработкаМетодовGET
//Функция экспортная, специально чтобы можно было отлаживать как по HTTP(https://its.1c.ru/db/metod8dev#content:5756:hdoc)
//Так и через внешнюю обработку
Функция PAPI_ОбработкаМетодовGET(СтруктураВхПараметров) Экспорт
	//структура ответа. Собственна нужна для формирования ответа
	СтруктураОтвет = Новый Структура("ДанныеОтвета,Отработало,ТекстОшибки,КодОтвета","",Истина,"",200);
	
	//Переправляем на нужный метод
	Если ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("Список") Тогда
		
		ПолучитьСписок(СтруктураОтвет,СтруктураВхПараметров);	
		
	ИначеЕсли ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("Документ") Тогда

		ПолучитьДокумент(СтруктураОтвет,СтруктураВхПараметров);
		
//Получаем доступные остатки по складу в формате JSON	
	ИначеЕсли ВРег(СтруктураВхПараметров.ИмяМетода) = ВРег("ОстаткиИДоступностьТоваровПоСкладу") Тогда
		
		PAPI_ОбработкаУниверсальныхМетодов.ПолучитьОстаткиИДоступностьТоваровПоСкладу(СтруктураОтвет,СтруктураВхПараметров);	
		
	Иначе
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,501,"Отсутствует Метод " + ?(СтруктураВхПараметров.ИмяМетода=Неопределено,"",СтруктураВхПараметров.ИмяМетода),ложь,"");
	КонецЕсли;
	Возврат СтруктураОтвет;	
КонецФункции

#Область Методы
Процедура ПолучитьСписок(СтруктураОтвет,СтруктураВхПараметров)
	Результат = "Расходная накладная, 1, 01.01.2014
	|Расходная накладная, 2, 01.01.2014";
	СтруктураОтвет.ДанныеОтвета = Результат;
КонецПроцедуры	

Процедура ПолучитьДокумент(СтруктураОтвет,СтруктураВхПараметров)
	//ПраметрыЗапроса - number
	ПарНомер = СтруктураВхПараметров.ПараметрыЗапроса.Получить("number");

	Номер = Число(?(ПарНомер=Неопределено,0,ПарНомер));
	Если Номер > 2 Тогда
		PAPI_ОбщиеПроцедурыИФункции.ЗаполнитьСтруктуруОтвета(СтруктураОтвет,404,"Отсутствует документ с номером: " + Номер,ложь,"");
	Иначе	
		Если Номер = 1 Тогда
			Результат = "Расходная накладная, 1, 01.01.2014";
		Иначе
			Результат = "Расходная накладная, 2, 01.01.2014";
		КонецЕсли;
		СтруктураОтвет.ДанныеОтвета = Результат;	
	КонецЕсли;
КонецПроцедуры	

#КонецОбласти

 

Добавим одну строчку в обработчик метода Get.

 
 Код PrettyAPIGET
Функция PrettyAPIGET(Запрос)
	СтруктураВхПараметров = Новый Структура;
	//Получаем имя метода
	перИмяМетода  = Запрос.ПараметрыURL["ИмяМетода"];    
	//Помещаем имя метода в структуру
	СтруктураВхПараметров.Вставить("ИмяМетода",перИмяМетода);  
	
	//Забираем параметры из запроса
	ВхПараметрыЗапроса = Новый Соответствие;
	Для каждого Параметр Из Запрос.ПараметрыЗапроса Цикл
        ВхПараметрыЗапроса.Вставить(Параметр.Ключ,Параметр.Значение);
    КонецЦикла;
	СтруктураВхПараметров.Вставить("ПараметрыЗапроса",ВхПараметрыЗапроса);
	
	//Передаем входящие параметры (Модуль для метода GET)
	СтруктураОтвет = PAPI_ОбработкаМетодовGET.PAPI_ОбработкаМетодовGET(СтруктураВхПараметров);
	
	//Создаем ответ с кодом состояния
	Ответ = Новый HTTPСервисОтвет(СтруктураОтвет.КодОтвета);
	Если СтруктураОтвет.Отработало Тогда 
	    Ответ.УстановитьТелоИзСтроки(СтруктураОтвет.ДанныеОтвета,КодировкаТекста.UTF8);
	Иначе
		Ответ.УстановитьТелоИзСтроки(СтруктураОтвет.ТекстОшибки,КодировкаТекста.UTF8);
	КонецЕсли;	
	
	//В зависимости от формата меняем "Content-Type"
	PAPI_ОбщиеПроцедурыИФункции.ВозвращаемНужныйФорматОтвета(Ответ,СтруктураОтвет);
	
	Возврат Ответ;
КонецФункции

 

На этом подготовка ЕРП окончена. Проверим через браузер результат, выполним следующий запрос:

http://127.0.0.1/DemoEnterprise2_4_3_145/hs/PrettyAPI/V1/ОстаткиИДоступностьТоваровПоСкладу?Ref_Key=3ae74af9-e911-11e6-b7b5-bcaec56cc144

Наш сервис готов! Давайте теперь дорисуем обработку и будем подводить итоги.

Добавим в обработку реквизит "Результат" с типом строка. В него мы просто будем выводить текст ответа.

Добавим ТаблицуЗначений "ОстаткиИДоступность":

  • Наименование (Строка)
  • Артикул (Строка)
  • Доступно (Число(15,3))
  • Остаток (Число(15,3))
  • Идентификатор (Строка)

Добавим команду "ПолучитьРезультат"

 
 Код команды ПолучитьРезультат
&НаКлиенте
Процедура ПолучитьРезультат(Команда)
	ОчиститьСообщения();
	Если Не ЗначениеЗаполнено(Склад) Тогда 
		Сообщить("Склад не заполнен!");
		Возврат;
	КонецЕсли;	
	
	ОстаткиИДоступность.Очистить();
	ПолучитьРезультатНаСервере();
КонецПроцедуры
&НаСервере
Процедура ПолучитьРезультатНаСервере()
	перПорт = 0;
	перСервер = "127.0.0.1";
	перПользователь = "Администратор (ОрловАВ)";
	перПароль = "";

	//Формируем запрос для OData
	перРесурсНаСервере = "/DemoEnterprise2_4_3_145/hs/PrettyAPI/V1/";	
	перРесурсНаСервереФин = перРесурсНаСервере + 
	"ОстаткиИДоступностьТоваровПоСкладу?Ref_Key="+Склад;
	
	Попытка
		Если перПорт <= 0 Тогда 
			HTTPСоединение = Новый HTTPСоединение(перСервер,,перПользователь,перПароль);
		Иначе 
			HTTPСоединение = Новый HTTPСоединение(перСервер,перПорт,перПользователь,перПароль);
		КонецЕсли;
		
		HTTPЗапрос= Новый HTTPЗапрос(перРесурсНаСервереФин);
		HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
		
		РезультатМассив = Новый СписокЗначений;	
		Если HTTPОтвет.КодСостояния = 200 Тогда 
			Ответочка = HTTPОтвет.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);	
			Результат = Ответочка;	
			
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(Ответочка);
			Попытка
				//ДопДанные = ПрочитатьJSON(ЧтениеJSON, Ложь);
				МасДопДанные = ПрочитатьJSON(ЧтениеJSON);
			Исключение
				МасДопДанные = "";
			КонецПопытки;
				
			Если ТипЗнч(МасДопДанные) = Тип("Массив") Тогда
				Для Каждого ДопДанные из МасДопДанные Цикл 
					//"ИмяЗначение","Артикул","Guid","ДоступноСейчас","Остаток"
					Если ДопДанные.Свойство("ИмяЗначение") 
						И ДопДанные.Свойство("Guid") 
						И ДопДанные.Свойство("ДоступноСейчас") 
						И ДопДанные.Свойство("Остаток") Тогда
						новСтрока = ОстаткиИДоступность.Добавить();
						
						новСтрока.Наименование 		= ДопДанные.ИмяЗначение;
						новСтрока.Идентификатор		= ДопДанные.Guid;
						новСтрока.Доступно		 	= ДопДанные.ДоступноСейчас;
						новСтрока.Остаток		 	= ДопДанные.Остаток;
						новСтрока.Артикул           = ?(ДопДанные.Свойство("Артикул"),ДопДанные.Артикул,"");
					КонецЕсли;
				КонецЦикла;	
			Иначе 
				//не смогли прочитать
			КонецЕсли;	

		КонецЕсли;
	Исключение
		Сообщить("Подключится к ERP не получилось: "+ОписаниеОшибки());	
	КонецПопытки;
	
	HTTPСоединение = Неопределено;
КонецПроцедуры

 

Внешний вид формы:

Проверяем результат:

Вторую часть заканчиваю. Мы рассмотрели с Вами как можно смешивать разные технологии. Я думал, в этой части поговорить про другие методы, но вышло громоздко, поэтому в следующей части поговорим о других методах и длительных операциях.

Статьи из данного цикла:

HTTP Сервисы: Путь к своему сервису. Часть 1

HTTP Сервисы: Путь к своему сервису. Часть 3

HTTP Сервисы: Путь к своему сервису. Часть 4

Скачать файлы

Наименование Файл Версия Размер
Расширение с http-сервисами из примера

.cfe 23,20Kb
30
.cfe 0.0.2 23,20Kb 30 Скачать
Обработка из примера: ПолучитьОстаткиИДоступностьТоваров.epf

.epf 8,65Kb
37
.epf 1.0.0 8,65Kb 37 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. konyavka 27 16.05.22 15:16 Сейчас в теме
Добрый день.
При получении в тексте обработки возвращает все время HTTPОтвет.КодСостояния = 401.

При вводе той же строки в браузере возвращает список складов:
перРесурсНаСервере = "/DemoEnterprise2_4_3_145/odata/standard.odata/";
перРесурсНаСервереФин = перРесурсНаСервере + "Catalog_Склады?$select=Ref_Key,Description&$filter=DeletionMark eq false and IsFolder eq false&$format=json;odata=nometadata";

Не подскажите в чем может быть дело?
2. dsdred 2102 16.05.22 15:47 Сейчас в теме
(1) 401 ошибка авторизации.
Как вариант возможно логин и пароль сделать на английском.

Или вы не поправили то что было у меня приведено под себя

Процедура ПолучитьРезультатНаСервере()
перПорт = 0;
перСервер = "127.0.0.1";
перПользователь = "Администратор (ОрловАВ)";
перПароль = "";
Оставьте свое сообщение

См. также

Работа со схемой запроса Промо

Инструментарий разработчика v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    55495    kalyaka    41    

Автоматический перезапуск рабочих процессов (rphost) кластера 1С

Инструментарий разработчика v8 Абонемент ($m)

Служба Windows, которая выполняет автоматический перезапуск рабочих процессов (rphost) кластера 1С по заданным настройкам. Перезапуск выполняется по превышению настроенного лимита, используемой одним рабочим процессом памяти. Настройка лимита памяти может быть задана, как общая для всех рабочих серверов кластера 1С, так и индивидуально для каждого рабочего сервера по отдельности.

10 стартмани

08.07.2021    2864    zhichkin    0    

Библиотека программного изменения формы (УФ)

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Нам часто приходится дорабатывать различные управляемые формы. Проще внести изменения непосредственно на самой форме, но, для дальнейшего поддержания конфигурации, удобнее вносить все изменения на форме программно. Предлагаю Вам библиотеку для программного изменения управляемых форм, которую можно внедрить в конфигурацию либо совсем бесшовно, либо практически бесшовно.

1 стартмани

07.08.2020    8407    BuriyLesha    20    

Запуск фонового задания во внешней обработке без регистрации в справочнике "Дополнительные отчеты и обработки"

Инструментарий разработчика v8::УФ ЗУП3.x Россия Абонемент ($m)

Описал, как показать прогресс выполнения длительной операции во внешней обработке, и при этом не регистрировать обработку в справочнике "ДополнительныеОтчетыИОбработки". Проверял на БСП версии "3.1.2.264".

1 стартмани

09.03.2020    10533    VinnieThePOOH    6    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Универсальные функции HighLoad оптимизация Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    52710    DarkAn    87    

Вывод сообщений в HTML поле средствами 1С

Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    19672    burni4    16    

Массовое изменение режима поддержки объектов конфигурации

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Что делать, если при сравнении/объединении конфигураций нужно изменить режим поддержки для большого количества объектов? Штатного механизма для выполнения подобной задачи в Платформе нет. Изменять режим для всей конфигурации? Описывается способ, позволяющий выполнить изменение режима только для нужных объектов.

05.11.2019    5705    VKislitsin    12    

Многопоточная обработка данных на примере перепроведения документов

Инструментарий разработчика v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    14895    ids79    46    

Hello world на metadata.js Промо

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Про браузерные offline-first приложения можно написать миллионы слов. Сэкономлю своё и ваше время и перейду сразу к делу. В статье не будет рекламы и агитации за новые технологии, не будет критики традиционных или попсовых решений. Рассмотрим по шагам разработку простейшей программы на metadata.js. Постараюсь сделать акцент не на том «как это сделано», а «почему сделано именно так»

1 стартмани

11.08.2016    70791    unpete    209    

Хороший заказчик - плохой заказчик

О жизни Россия Бесплатно (free)

Лайфхак о том, как стать легендарным клиентом.

13.09.2019    8623    dsdred    24    

Самый примитивный HTTP-сервис в мире

WEB v8 Бесплатно (free)

Пошаговый пример создания простейшего HTTP-сервиса, который генерирует HTML-страницу для поиска товара, а также реализует асинхронное получение данных из базы.

12.09.2019    27612    YPermitin    27    

Централизованное управление кластером 1С Предприятия, состоящим из нескольких рабочих серверов, работающих на платформе GNU/Linux

Инструментарий разработчика v8 Абонемент ($m)

При эксплуатации крупных информационных систем, в состав которых могут входить десятки серверов 1С Предприятия, зачастую возникают ситуации, требующие однотипных действий на всех серверах кластера 1С Предприятия или на всех серверах контура. В настоящей статье представлен способ централизованного управления серверами 1С Предприятия, работающими на платформе GNU/Linux. Подобный подход может быть использован и для других задач, возникающих в процессе эксплуатации крупных систем, с целью сокращения как временных затрат специалистов, так и времени простоя системы.

1 стартмани

26.08.2019    4534    Sloth    0    

Создание внешних печатных форм под управляемым приложением с нуля Промо

Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Когда мне пришлось создавать внешние печатные формы под приложения на БСП ("1С: Бухгалтерия предприятия 3.0", "1С: Управление торговлей 11"), я обнаружил, что нет грамотных инструкций. Те, что имелись, использовали так называемые шаблоны: готовые обработки, в которых необходимо выполнять определенные корректировки. Но как создать сам шаблон, конкретных мануалов не было, справочную информацию я нашел на сайте ИТС и, обработав ее, написал статью, где подробно и понятно объясняются все этапы создания внешней печатной формы для управляемого приложения на примере конфигурации "1С: Бухгалтерия предприятия 3.0"

1 стартмани

05.06.2014    342466    signum2009    133    

Менеджер потоков: реализация "любой" задачи в потоках

Инструментарий разработчика v8 Абонемент ($m)

Менеджер потоков – один их новых инструментов, который упрощает работу разработчиков. Насколько легко с ним, на конференции Infostart Event 2018 Education показал начальник отдела автоматизации 1С Иван Филимонов компании «Трансстроймеханизация».

01.08.2019    12282    DarkAn    7    

Просто комбо, два в одном, или как напечатать два макета (стандартный и измененный) одной печатной формы

Инструментарий разработчика v8 БП3.0 БУ Абонемент ($m)

Алгоритм и расширение (как пример) демонстрируют механизм одновременного использования двух макетов (стандартного и измененного), принадлежащих одной записи регистра «Макеты печатных форм» («ПользовательскиеМакетыПечати») в конфигурации «1С:Бухгалтерия предприятия, редакция 3.0».

1 стартмани

26.06.2019    5128    delta    0    

Использование фреймворка "Тестирование 3.0" (https://testingtool.ru) для тестирования веб-приложений

Инструментарий разработчика v8 Абонемент ($m)

Рассматривается использование фреймворка "Тестирование 3.0" (https://testingtool.ru) для тестирования веб-приложений.

1 стартмани

24.12.2018    5805    AlexKo    9    

HTTP Сервисы: Путь к своему сервису. Часть 4

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 3». В предыдущих частях мы уже о многом поговорили. В этой части поговорим про размер сообщений, о файлах, о порциях и немножко, о регламентах.

1 стартмани

28.09.2018    35948    dsdred    18    

Сортировка метаданных с учетом объектов на замке

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Порой одна конфигурация находится на поддержке нескольких поставщиков (со своими префиксами). Зачастую при обновлении отдельных поставок происходит "перемешивание" объектов с различными префиксами. Работать с такой конфигурацией не очень удобно, но есть способ для сортировки метаданных (в том числе объектов на замке), а также быстрого восстановления сортировки, если случайно очередное обновление было выполнено с взятием порядка метаданных из файла (которое устанавливается по умолчанию).

1 стартмани

16.08.2018    4546    Olenevod    1    

Мониторинг журнала регистрации при помощи Powershell

Инструментарий разработчика v8 Абонемент ($m)

Работа с журналом регистрации в формате SQLite внешними средствами на примере мониторинга изменений в конфигурации базы данных.

1 стартмани

12.07.2018    13960    user768334    7    

Заполнение документа Word без ComОбъект

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Идея написать публикацию пришла после прочтения очередного рассказа о том, как файл Word заполнялся через COM-объект в клиент-серверном варианте. При этом падал Сервер 1С. Зачем в принципе использовать файлы Word как шаблоны? Ну, допустим, в организации используется некая внутренняя отчетность, выполнения в корпоративном стиле, и переделать ее на привычные табличные документы нет возможности.

1 стартмани

08.07.2018    19961    nbeliaev    36    

Tool1CD: отрежем донорскую почку

Инструментарий разработчика v8 Розница Абонемент ($m)

Ваша база мертва? Что ж, кое-что в ней ещё теплится.

1 стартмани

15.05.2018    19674    dmpas    13    

Использование регулярных выражений (RegExp) в Linux

Инструментарий разработчика v8 Абонемент ($m)

Описывается способ использования регулярных выражений (RegExp) в Linux с использованием тех же компонентов, что и в Windows (COM-объекты VBScript.RegExp).

1 стартмани

20.04.2018    9604    vsbronnikov    12    

Тестирование: пример создания сценарного UI теста для платформы 1С

Инструментарий разработчика v8 ERP2 УТ11 Абонемент ($m)

В этой статье мы расскажем, как создать сценарный UI-тест. Опишем последовательность действий и покажем, как это сделать с использованием инструментария. Рассмотрим пример, максимально приближенный к боевому, покажем на примере конфигураций УТ11/ERP проверку бизнес-процесса "Продажа". Вы сможете убедиться, что создание сценарных тестов для платформы 1С на самом деле относительно быстрый и простой процесс.

1 стартмани

17.04.2018    24537    ivanov660    11    

Внешняя печатная форма с вводом параметров через дополнительную форму

Инструментарий разработчика Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Удобный ввод параметров в печатную форму с помощью дополнительной формы

1 стартмани

23.03.2018    34221    Margo462    23    

Обработка печатной формы WORD клиент-сервер УФ

Инструментарий разработчика v8::УФ 1cv8.cf Абонемент ($m)

Это моя первая статья на данном портале, но попытаюсь изложить все понятно и подробно. Долгое время у меня заняло создание такой вот внешней обработки. Есть очень много примеров, как сделать подобное на неуправляемых формах (2.0) и очень мало информации касательно управляемых(3.0), по крайней мере я многого найти не смог в доступе. Создание подобное обработки выглядит вполне несложно, если производить все действия на сервере, как это было с 2.0, но в нашем случае необходимо инициализировать открытие документа на клиенте, чему сильно мешает отсутствие возможности передать макет Active Document с сервера на клиент.

2 стартмани

14.03.2018    30906    LeoKeyn    43    

Мониторинг изменений рабочих конфигураций. Часть 1. Сохранение конфигураций из базы SQL без конфигуратора

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Выгружаем исходники из SQL напрямую скриптом, собираем CF и контролируем реальные изменения в рабочих базах из браузера.

1 стартмани

28.02.2018    21024    user768334    25    

Консоль запросов со встроенным Конструктором запросов для 1с8.3 (8.2) своими руками

Инструментарий разработчика v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Мы можем сами создать свою консоль запросов - именно такую, которая подходит для наших нужд. Кроме того, создав собственную Консоль запросов, Вы не только получаете удобный для себя инструмент, а также получаете навык программирования в среде 1с8, что очень полезно будет начинающим программистам 1С.

1 стартмани

21.12.2017    25610    jan-pechka    24    

Практика доступа в базу 1С через протокол oData. Чтение данных

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    134941    Dementor    73    

Полезный код для программистов 1С (часть 1). Управление свойствами элементов формы. Хранение копии данных реквизитов

Инструментарий разработчика v8 Абонемент ($m)

У каждого программиста за время работы накапливается полезный инструментарий, которым он привык пользоваться. Естественно и у меня он тоже имеется. И вот решено было немного поделиться с сообществом. Возможно идеи не новые. Более того, допускаю, что реализованы они не самым оптимальным образом. Но ведь для этого сообщество и существует, чтобы делиться с ним, получая обратную связь.

1 стартмани

24.09.2017    45368    vandalsvq    80    

Интеграция сценарного тестирования в процесс разработки

Инструментарий разработчика v8::УФ Абонемент ($m)

Эта статья является практическим пособием по внедрению тестирования на основе сценариев в процесс разработки программного обеспечения на базе платформы 1С:Предприятие 8.3. Документ отличает прикладная направленность, в нем содержится много кода, подходов и конкретики. Все рассмотренные примеры основаны на использовании бесплатной конфигурации Тестер

1 стартмани

04.07.2017    32134    grumagargler    30    

Передача параметра из формы документа в форму выбора. 1С: 8.2, обычные формы

Инструментарий разработчика v8 УТ10 Абонемент ($m)

Установить принудительный отбор по номенклатуре в форме выбора при добавлении из определенного вида документа. В моем примере ограничение к номенклатуре только из документа Установка цен номенклатуры.

1 стартмани

18.05.2017    9673    Sanek32    6    

Перехват методов серверных (x64) контекстов с использованием DynamicWrapperX

Инструментарий разработчика v8 Абонемент ($m)

Применение COM-объекта DynamicWrapperX на x64-сервере приложений.

1 стартмани

23.03.2017    12211    chessman    7    

1С:Предприятие 8.2. Управляемая Форма. Меняем иконку рабочего стола.

Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Для конфигураций имеющих свой дизайн важно иметь возможность сменить не только картинки разделов для созданных подсистем, но и картинку рабочего стола, но менять ее нет возможности. Сама 1С объясняет это тем что интерфейс любой конфигурации должен быть унифицирован: "Дело не в одной картинке, а в общей стилистике для любых конфигураций. Важно чтобы пользователи привыкали к общему стилю и одинаково воспринимали одинаковые элементы в разных конфигурациях - это ускорит и освоение конфигураций и повседневную работу пользователей с ними." Но все же можно попытаться ее сменить.

1 стартмани

28.09.2012    31221    ghostaz    39    

Как написать COM-объект для 1С на Visual Studio C# 2008

Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Расширяем функционал 1С с помощью разработки подключаемого COM-объекта! Пишем код на Visual C# 2008 для открытия CD-ROM'а, получения списка процессов и использования возможностей системы text-to-speech.

5 стартмани

11.09.2012    86591    RainyAugust22    57    

Пример печатной формы "с выбором" без формы выбора

Взаиморасчеты Инструментарий разработчика v8 БП2.0 Россия БУ Абонемент ($m)

Пример реализации внешней печатной формы с выбором ответственного лица без формы выбора

1 стартмани

13.06.2012    13599    Dasty    8    

Подсветка синтаксиса 1C (в том числе языка запросов) в Notepad++

Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Конфигуратор 1С как редактор кода не всегда удовлетворяет потребностям программиста в управлении кода. Я зачастую с завистью вспоминаю другие среды разработки программ, и нередко копировал куски 1С кода в стороннюю программу для каких-либо манипуляций - например, Notepad++. К сожалению, в нём нет встроенной поддержки синтаксиса кода 1С, из-за чего пришлось определять свой. Вот об этом я и расскажу.

1 стартмани

27.03.2012    38168    CratosX    35    

Текстовые экспандеры - в помощь программисту 1С

Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Каждый человек старается по возможности облегчить себе труд. Программисты не исключение. Каждый день мы сталкиваемся с необходимостью писать однотипные фрагменты программного кода. Для автоматизации этого процесса система 1С:Предприятие позволяет использовать шаблоны текста (как стандартные, так и созданные пользователем). Казалось бы, что еще нужно разработчику? Однако, в некоторых случаях, стандартных средств разработки все-таки бывает недостаточно. Например, разрабатывая правила обмена в конфигурации 1С:Конвертация данных, приходится писать довольно большие тексты, не имея при этом возможности воспользоваться ни автоподстановкой, ни шаблонами. Либо, приходя к очередному клиенту, Вы обнаруживаете, что нужно написать, допустим, самую обычную печатную форму, которую Вы писали тысячу раз, но процесс ее создания может занять продолжительное время. Как раз в этом случае и могут помочь программы для вставки часто используемых выражений – текстовые экспандеры.

1 стартмани

27.07.2011    27212    tomvlad    44