Набор функций, возвращающих данные из истории версий объекта или "Кто виноват?" оптом

Публикация № 966166

Разработка - Практика программирования

Отчеты историяизменения версии объектов СКД ВерсииОбъектов ЖурналРегистрации журнал регистрации разработка

В рамках одного проекта понадобился функционал который бы сообщал ответ на так интересующий вопрос - "КТО ПОСЛЕДНИЙ МЕНЯЛ?!?" в отчете для большого количества объектов сразу. Найти решения не удалось на просторах интернета и по этому было принято решение сделать "Своё". Задумка очень проста - на входе ссылка на объект и интересующий нас реквизит, а на выходе все подноготная (кто, когда, из какого значения в какое). Хотел бы поделиться данными функциями с сообществом.

Хотелось бы отметить, что программирование в наше время, призвано облегчить работу пользователям и уменьшить количество кликов совершаемых ими до минимума, это и может послужить ответом на вопрос "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза".

Всё таки стоит отметить, что данные функции предназначены для применения в отчетах и формах с целью сокращения времени затраченного пользователями на анализ вручную отчета по версиям объектов.

Итак начнём с самого простого -

Первая функция ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизита)

// функция определяет кто, когда и как последний изменял реквизит переданной ссылки до указанной даты//
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяРеквизита  - имя реквизитакоторое проверяется изменение
// Возвращаемое значение:
//   Структура   - Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле
//
Функция ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизита) экспорт

	МетаданныеОбъекта = СсылкаПоиска.ПолучитьОбъект().Метаданные();
	Если МетаданныеОбъекта.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
	КонецЕсли; 
	Запр = новый Запрос("ВЫБРАТЬ
	                  
	                    |	ВерсииОбъектов.ТабличныеДокументы КАК ТабличныеДокументы,
	                    |	ВерсииОбъектов.НомерВерсии КАК Версия,
	                    |	ВерсииОбъектов.АвторВерсии КАК АвторВерсии,
	                    |	ВерсииОбъектов.ДатаВерсии КАК ДатаВерсии
	                    |ИЗ
	                    |	РегистрСведений.ВерсииОбъектов КАК ВерсииОбъектов
	                    |ГДЕ
	                    |	ВерсииОбъектов.ДатаВерсии <= &ДатаВерсии
	                    |	И ВерсииОбъектов.Объект = &Объект
	                    |
	                    |УПОРЯДОЧИТЬ ПО
	                    |	Версия");
	Запр.УстановитьПараметр("Объект",СсылкаПоиска);
	Запр.УстановитьПараметр("ДатаВерсии",Дата);
	ВыполненныйЗапрос = Запр.Выполнить();
	Если ВыполненныйЗапрос.Пустой() Тогда
	
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");	
	
	КонецЕсли; 
	Результат = ВыполненныйЗапрос.Выгрузить();
	ПоследняяВерсия=неопределено;
	Для каждого РезультатСтрока Из Результат Цикл
		
		ДвоичныеДанные = ВерсионированиеОбъектов.СведенияОВерсииОбъекта(СсылкаПоиска, РезультатСтрока.Версия).ВерсияОбъекта;
		
		Если ДвоичныеДанные = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		
		Объект = ВосстановитьОбъектПоXML(ДвоичныеДанные,"");
		
		Если ПоследняяВерсия=неопределено Тогда
			
		    ПоследняяВерсия = новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект=Объект;	
			ПоследняяВерсия.ЗначениеДо = "";
			ПоследняяВерсия.ЗначениеПосле = Объект[ИмяРеквизита];
			продолжить;
			
		КонецЕсли; 
		Если Объект[ИмяРеквизита] <> ПоследняяВерсия.Объект[ИмяРеквизита] Тогда
			
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект = Объект;
			ПоследняяВерсия.ЗначениеДо = ПоследняяВерсия.ЗначениеПосле;
			ПоследняяВерсия.ЗначениеПосле = Объект[ИмяРеквизита];
			
		КонецЕсли; 
	КонецЦикла;
	Если ПоследняяВерсия=неопределено Тогда
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
	иначе
		Возврат ПоследняяВерсия;
	КонецЕсли;
КонецФункции // ПолучитьИзменившегоРеквизитОбъектаНаДату()

Это простая функция которая просто вернёт нам необходимые данные структурой. И тут, я считаю, комментарии дополнительные излишни.

Казалось бы - задача выполнена и можно остановиться, но как быть с табличными частями? Ответом на этот вопрос и послжит

Вторая функция ПолучитьИзменившегоСтрокуТЧОбъектаНаДату

// функция определяет кто, когда и как последний изменял реквизит строки табличной части переданной ссылки до указанной даты//
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяТЧ  - имя табличной части проверяется изменение
//  ИмяРеквизитаТЧ - имя колонки значение которой проверяется
//  СтруктураОтбораСтрокиТЧ - структура с параметрами ИменаКолонок - имя колонки по которой будет поиск, Значение - искомое значение. 
//                            К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки.
// Возвращаемое значение:
//   Структура   - Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ
//
Функция ПолучитьИзменившегоСтрокуТЧОбъектаНаДату(СсылкаПоиска,Дата,ИмяТЧ,ИмяРеквизитаТЧ,СтруктураОтбораСтрокиТЧ)экспорт 	
	Если 	СсылкаПоиска.ПолучитьОбъект().Метаданные().ТабличныеЧасти.Найти(ИмяТЧ) 	= Неопределено
			или СсылкаПоиска.ПолучитьОбъект().Метаданные().ТабличныеЧасти[ИмяТЧ].реквизиты.найти(ИмяРеквизитаТЧ)  = неопределено
			или	СтруктураОтбораСтрокиТЧ.Свойство("ИменаКолонок") 				= ложь 
			или СтруктураОтбораСтрокиТЧ.Свойство("Значение") 					= ложь Тогда
			
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
		
	КонецЕсли; 
	Запр = новый Запрос("ВЫБРАТЬ
	                  
	                    |	ВерсииОбъектов.ТабличныеДокументы КАК ТабличныеДокументы,
	                    |	ВерсииОбъектов.НомерВерсии КАК Версия,
	                    |	ВерсииОбъектов.АвторВерсии КАК АвторВерсии,
	                    |	ВерсииОбъектов.ДатаВерсии КАК ДатаВерсии
	                    |ИЗ
	                    |	РегистрСведений.ВерсииОбъектов КАК ВерсииОбъектов
	                    |ГДЕ
	                    |	ВерсииОбъектов.ДатаВерсии <= &ДатаВерсии
	                    |	И ВерсииОбъектов.Объект = &Объект
	                    |
	                    |УПОРЯДОЧИТЬ ПО
	                    |	Версия");
	Запр.УстановитьПараметр("Объект",СсылкаПоиска);
	Запр.УстановитьПараметр("ДатаВерсии",Дата);
	ВыполненныйЗапрос = Запр.Выполнить();
	Если ВыполненныйЗапрос.Пустой() Тогда
	
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");	
	
	КонецЕсли; 
	Результат = ВыполненныйЗапрос.Выгрузить();
	
	ПоследняяВерсия=неопределено;
	
	Для каждого РезультатСтрока Из Результат Цикл
		
		ДвоичныеДанные = ВерсионированиеОбъектов.СведенияОВерсииОбъекта(СсылкаПоиска, РезультатСтрока.Версия).ВерсияОбъекта;
		
		Если ДвоичныеДанные = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		
		Объект = ВосстановитьОбъектПоXML(ДвоичныеДанные,"");
		Попытка
		
			СтрокаТЧ = Объект[ИмяТЧ].найти(СтруктураОтбораСтрокиТЧ.Значение,СтруктураОтбораСтрокиТЧ.ИменаКолонок);	
		
		Исключение
		    Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
		КонецПопытки; 
		Если СтрокаТЧ = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		ЗначениеСтроки = СтрокаТЧ[ИмяРеквизитаТЧ];
		
		Если ПоследняяВерсия	=	неопределено Тогда
			
		    ПоследняяВерсия = новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект=Объект;	
			ПоследняяВерсия.ЗначениеДо = "";
			ПоследняяВерсия.ЗначениеПосле = ЗначениеСтроки;
			ПоследняяВерсия.ИндексСтрокиТЧ = СтрокаТЧ.НомерСтроки;
			продолжить;
			
		КонецЕсли; 
		Если ЗначениеСтроки <> ПоследняяВерсия.ЗначениеПосле Тогда
			
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект = Объект;
			ПоследняяВерсия.ЗначениеДо = ПоследняяВерсия.ЗначениеПосле;
			ПоследняяВерсия.ЗначениеПосле = ЗначениеСтроки;
			ПоследняяВерсия.ИндексСтрокиТЧ = СтрокаТЧ.НомерСтроки;
			
		КонецЕсли; 
	КонецЦикла;
	Если ПоследняяВерсия	=	неопределено Тогда
			
		    Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");	
			
	КонецЕсли;
	Возврат ПоследняяВерсия;
КонецФункции // ПолучитьИзменившегоРеквизитОбъектаНаДату()

Тут может возникнуть ряд вопросов на которые я постараюсь ответить сразу:

Из описания функции становится понятно, что работать будем именно со строкой данных, а не с таблицей в целом, так сделано для упрощения получения данных в отчете, у нескольких строк могут быть разные авторы версии, что пагубно скажется на группировке в иерархии, для определения конкретной строки я использовал именно функцию Найти, а не НайтиСтроки  - потому, что найти возвращает конкретную строку, тогда как другая функция - массив строк, пришлось бы ещё выбирать, что не есть удобно. 

Теперь нам понадобится функция которая вернет одно конкретное значение, до текущего момента мы получали обратно структуры данных, а её использовать в обращении через СКД не очень то и удобно. Для этого есть 

Третья функция ПолучитьУказанныеДанныеПоИзменениямРеквизитаИзИсторииОбъекта

// функция определяет кто или когда или как последний изменял реквизит строки табличной части или реквизита переданной ссылки до указанной даты 
// если не задано имя ТЧ то ищится реквизит ссылки
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяРеквизитаПроверки  - имя реквизитакоторое проверяется изменение  или имя колонки значение которой проверяется
//  РеквизитВозврата  - Имя того, что нужно получить: "Объект","ДатаВерсии","АвторВерсии","ЗначениеДо","ЗначениеПосле","ИндексСтрокиТЧ"
//  ИмяТЧ  - имя табличной части проверяется изменение
//  ИменаКолонокПоиска - имя колонки по которой будет поиск. К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки. 
//  ЗначениеПоиска - искомое значение. К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки.                           
// Возвращаемое значение:
//   Зависит от переданного параметра РеквизитВозврата.
функция ПолучитьУказанныеДанныеПоИзменениямРеквизитаИзИсторииОбъекта(СсылкаПоиска,Дата,ИмяРеквизитаПроверки,РеквизитВозврата,ИмяТЧ = "",ИменаКолонокПоиска = "", ЗначениеПоиска = "")экспорт
	
	Если ИмяТЧ = "" Тогда
	
		ПолученнаяСтруктура = ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизитаПроверки);	
	
	Иначе
	
		ПолученнаяСтруктура = ПолучитьИзменившегоСтрокуТЧОбъектаНаДату(СсылкаПоиска,Дата,ИмяТЧ,ИмяРеквизитаПроверки,Новый Структура("ИменаКолонок, Значение",ИменаКолонокПоиска,ЗначениеПоиска));		
	
	КонецЕсли;
	НеобходимоеЗначение = "";
	Если ТипЗнч(ПолученнаяСтруктура) = тип("Структура") и ПолученнаяСтруктура.Свойство(РеквизитВозврата,НеобходимоеЗначение) Тогда
	
		возврат НеобходимоеЗначение;	
	
	КонецЕсли; 
КонецФункции

Данная функция добавляет универсальности всему механизму, так-как позволяет обращаться в одну точку и в зависимости от набора параметров возвращает конкретное значение, это будет удобно для использования в СКД. 

Все это строится на БСП и будет работать на актуальных релизах программ поддерживающих версионирование объектов. Единственный "прокол" в БСП это то что их функция ВосстановитьОбъектПоXML (код см. ниже) не является экспортно, что несколько усложняет нам жизнь по этому нам понадобится добавить её в наш модуль где будут располагаться пред идущие три красавицы. 

Функция ВосстановитьОбъектПоXML(ДанныеОбъекта, ТекстСообщенияОбОшибке = "")экспорт
	
	УстановитьПривилегированныйРежим(Истина);
	
	ДвоичныеДанные = ДанныеОбъекта;
	Если ТипЗнч(ДанныеОбъекта) = Тип("Структура") Тогда
		ДвоичныеДанные = ДанныеОбъекта.Объект;
	КонецЕсли;
	
	ЧтениеFastInfoSet = Новый ЧтениеFastInfoSet;
	ЧтениеFastInfoSet.УстановитьДвоичныеДанные(ДвоичныеДанные);
	
	Попытка
		Объект = ПрочитатьXML(ЧтениеFastInfoSet);
	Исключение
		ЗаписьЖурналаРегистрации(НСтр("ru = 'Версионирование'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
			УровеньЖурналаРегистрации.Ошибка,,, ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
		ТекстСообщенияОбОшибке = НСтр("ru = 'Не удалось перейти на выбранную версию.
											|Возможная причина: версия объекта была записана в другой версии программы.
											|Техническая информация об ошибке: %1'");
		ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщенияОбОшибке, КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
		Возврат Неопределено;
	КонецПопытки;
	
	Возврат Объект;
	
КонецФункции

Как разработчик этого всего заявляю, что метод довольно варварский, и работает "со скрипом", это связанно с тем, что у 1с всё хранится в хранилище данных в виде двоичного кода и метод получить всё это - развернуть через XML что в цикле даст огромный труд, а если сложить это всё с тем, что у нас будут корячиться запросы в цикле - то можно смело ставить два на экзамене, но в защиту хотелось бы сказать, что это расширяет функционал СКД и позволит получать сведения о интересующих нас негодяях пользователях в отчетах и "давать по рукам" в режиме online и оптом.

Данный функционал можно так же прикрутить к кнопке на форме документа, которая будет возвращать вам информацию о том, кто последний изменял скидки в заказе по которому сделана реализация или к примеру того, кто изменил условия оплаты договора перед тем, как провести реализацию и т.д.

Разработка и тестирование велись на 1С:Предприятие 8.3 (8.3.13.1644) в конфигурации 1С:ERP Управление предприятием 2 (2.4.5.143)

Для функционирования необходимо подключенная к конфигурации БСП Версионирования объетков и включенная в использовании.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. zeegin 91 19.12.18 15:34 Сейчас в теме
Разве это не типовой функционал БСП?
Документация:
https://its.1c.ru/db/bsp302doc#content:1858:1:issogl1_%D0%BF%D1%80%D0%BE%D1%81%D0%BC%D0%BE%D1%82%D1%80_%D0­%B8%D1%81%D1%82%D0%BE%D1%80%D0%B8%D0%B8_%D0%B8%D0%B7%D0%BC%D­0%B5%D0%BD%D0%B5%D0%BD%D0%B8%D0%B9_%D0%BE%D0%B1%D1%8A%D0%B5%­D0%BA%D1%82%D0%B0

Можно перейти к отчету по всем версиям объектов и отобрать в каких версиях конкретные интересующие реквизиты менялись...
Прикрепленные файлы:
andrvyst; ktb; user633533_encantado; Rustig; +4 Ответить
3. Rustig 1636 19.12.18 15:45 Сейчас в теме
(1) круто придумали!
что еще я не знаю?
7. feva 431 19.12.18 16:50 Сейчас в теме
(1) Абсолютно верно, именно об этом и и писал в самом начале статьи, рад что вы "Внимательно" прочитали
8. feva 431 19.12.18 16:51 Сейчас в теме
(1)
Хотелось бы отметить, что программирование в наше время, призвано облегчить работу пользователям и уменьшить количество кликов совершаемых ими до минимума, это и может послужить ответом на вопрос "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза"
2. user633533_encantado 8 19.12.18 15:44 Сейчас в теме
"Найти решения не удалось" - садись, два. Идите учить БСП и на пересдачу.
4. Rustig 1636 19.12.18 15:46 Сейчас в теме
(2) не кидайте камнями - это легче всего, покажите путь и дайте фонарь
5. user633533_encantado 8 19.12.18 15:58 Сейчас в теме
(4) Открываем конфигурацию "Библиотека стандартных подсистем" и изучаем подсистему "Версионирование объектов".
Что же вы там за "проекты" делаете с такими знаниями типовых подсистем ?
6. feva 431 19.12.18 16:49 Сейчас в теме
(5) Хорошо, простой вопрос - какая функция мне вернет одно значение - кто изменил реквизит?
9. feva 431 19.12.18 16:54 Сейчас в теме
(2) Товарищ магистр БСП, подскажите неучу каким образом можно получить в отчет на СКД кто изменил тот или иной реквизит
10. user633533_encantado 8 19.12.18 17:09 Сейчас в теме
(9) Не подскажу, так как это нафиг никому не нужная вещь , есть типовой отчет сравнения версий вызываемый из любого объекта подключенного к подсистеме.

Но вы всегда можете изобрести велосипед под хотелку заказчика, ваше право.
11. feva 431 19.12.18 17:13 Сейчас в теме
(10)т.е. нет такого функционала в БСП? Или Вы плохо знаете БСП?
Про типовой отчет сравнения версий написано ещё в начале статьи, и почему он не используется в некоторых случаях.
12. zeegin 91 19.12.18 17:25 Сейчас в теме
(11) Т.е. заполнить левую форму отбора набором параметров проще, чем пару раз ткнуть?
Ответ на вопрос-то где? "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза". Что улучшено? Как было, как сейчас? Почему это лучше в вашем сценарии? Почему в общем случае лучше БСП, а не ваш сценарий?

Где ответы на вопросы? Я вижу портянку текста кода и поноса мыслей, простите, а ответа на то почему стало лучше решать главный вопрос "КТО ПОСЛЕДНИЙ МЕНЯЛ?!?" не вижу.
andrvyst; +1 Ответить
13. feva 431 19.12.18 17:35 Сейчас в теме
(12)Левая форма была как пример использования функций.
Для анализа изменений одного реквизита одной реализации пользователю нужно сделать 5 действий и проанализировать портяночный отчет, что бы посмотреть кто сделал последним изменение.
Вопрос - сколько нужно действий что бы проверить 1000 реализаций?
16. zeegin 91 19.12.18 18:26 Сейчас в теме
(13) Зачем проверять 1000 реализаций? Какая проблема решается?
19. muskul 20.12.18 07:06 Сейчас в теме
(16)Например проблема кто и когда менял документы за определенный период. Этого отчета очень нехватает в типовых конфигурациях. Клиент хочет знать простой ответ, кто менял какие документы.
24. zeegin 91 20.12.18 18:54 Сейчас в теме
27. muskul 21.12.18 04:36 Сейчас в теме
(24) можешь пример отчета из такого журнала привести.Период месяц показать все реализации которые менялись в этом месяце.
28. zeegin 91 21.12.18 09:19 Сейчас в теме
(27) Администрирование, Обслуживание, Журнал регистрации, Установить отбор: Интервал, События, Метаданные.
Прикрепленные файлы:
32. muskul 23.12.18 05:21 Сейчас в теме
(28)И он тебе покажет все документы которые записывал менеджер за месяц. а нужны только дважды записанные.
21. feva 431 20.12.18 08:43 Сейчас в теме
(16) Допустим отдел аналитики хочет понять, кто из ответственных обособленных подразделений выставляет больше скидок, а кто больше наценок за прошедший год для премирования.
25. zeegin 91 20.12.18 18:58 Сейчас в теме
(21) Зачем для такого отчета версии? Для премирования надо использовать реальные продажи и реальные полученные деньги, а не скидку, которая потом была отменена. Да и вообще строить отчет с аналитикой для принятия управленческого решения по данным из документа, а не из регистра, это моветон.
30. feva 431 21.12.18 17:21 Сейчас в теме
(25) Это как пример и причины могут быть использовать именно версии.
На местах могут работать команды которые заводят и редактируют данные в хаотичном порядке. Менеджером продажи выступает один человек, о ценах договаривался другой человек, отгрузку и логистику рассчитывал третий человек, и если изначально не реализовано техническим, что фиксируется кто последний менял, а потом за год хотят получить эти данные, то журнал регистрации не несёт в себе ни какие были данные, ни когда их устанавливали. А когда штат работающий с 1с переваливает за 1к пользователей с каждой обособкой разбираться никто не захочет, но данные требуют уже вчера. По этому и приходится делать варварские решения (почему они не эффективны тоже описано в статье), но предоставляющие необходимые данные. Бывают и другие жизненные ситуации когда данные можно получить из регистра версий, но как правило приходилось отказывать клиентам.
31. feva 431 21.12.18 17:27 Сейчас в теме
(25) С опытом, и в Вашей практике появятся задачи требующие решения, пусть и не самого рационального на первый взгляд и это не единственный случай.
14. feva 431 19.12.18 17:51 Сейчас в теме
(12) все ответы в конце статьи, зачем использовать эти функции, их минусы и плюсы.
это расширяет функционал СКД и позволит получать сведения о интересующих нас пользователях в отчетах и "давать по рукам" в режиме online и оптом.

Данный функционал можно так же прикрутить к кнопке на форме документа, которая будет возвращать вам информацию о том, кто последний изменял скидки в заказе по которому сделана реализация или к примеру того, кто изменил условия оплаты договора перед тем, как провести реализацию и т.д.
15. zeegin 91 19.12.18 18:25 Сейчас в теме
(14) т.е. это не общее решение, а точечно, да еще и программировать надо...

и это вместо того, чтобы, считаем:
1. перейти на вкладку
2. открыть форму отбора реквизита по которому надо найти изменения
3. применить отбор
4. нажать кнопку сравнения версий

Вот если выбирать что проще, написать отчет или сделать кнопку с выводом или это же сделать в форме отчета бсп в режиме пользователя, что проще?
23. feva 431 20.12.18 09:10 Сейчас в теме
(15) С точки зрения программирования - проще отправить пользователя в типовой. Это не замена ему, а расширение. Для решения локальной задачи в рамках одного объекта, в большинстве случаев, лучше использовать типовой вариант. Данное решение имеет место быть если нужно получать информацию по большому объему объектов.
17. bulpi 179 19.12.18 18:45 Сейчас в теме
Не понял. Что это за регистр ВерсииОбъектов ?
Разве в новой платформе версионирование не встроено ?
20. feva 431 20.12.18 08:41 Сейчас в теме
(17) Да, все верно! Есть типовое решение которое позволяет в рамках одного документа посмотреть его версии (если включено версионирование), но порой не хватает отчета который покажет массово объекты и пользователей их изменяющие.
18. Rustig 1636 19.12.18 21:33 Сейчас в теме
в любом случае, какая ни была статья, обсуждение полезно
triviumfan; +1 Ответить
22. feva 431 20.12.18 08:47 Сейчас в теме
26. acanta 20.12.18 22:58 Сейчас в теме
Можно ли по регистру сведений получить срез последних и показать отдельной колонкой к примеру в справочнике контрагенты (форма списка) дату и автора последних изменений (и вообще имеет ли смысл записывать признак изменения и авторство в элемент справочника партнеры при модификации к примеру соглашения или условий договора) вместо/по аналогии с типовой датой создания и менеджером?
29. feva 431 21.12.18 17:13 Сейчас в теме
(26) В том и проблема, что нельзя напрямую, т.к. данные (дата и автор версии) хранятся в регистре в хранилище значений как двоичные данные и запросом пока нет технической возможности получить, для этого нужны данные функции.
Мог зайти человек создать контрагента и записать его номер телефона. Следом зашёл другой человек и изменил номер, но допустил ошибку, вот можно использовать эти функции, что бы рядом с номером указывать того, кто этот номер ввёл и какой он был раньше.
33. androgin 17.01.19 14:31 Сейчас в теме
Устарело.
В текущих версиях можно использовать ИсториюДанных.
Ну или журнал регистрации будет интересней, чем версионирование.
Надеюсь в скором будущем 1С откажется от этой подсистемы в пользу ИсторииДанных
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    3504    comol    20    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    9504    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    30024    user5300    16    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    34463    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38191    unichkin    74    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    28647    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    21714    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18354    YPermitin    58    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31606    tormozit    104    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9241    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    32255    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    38086    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78941    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    13714    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    61301    rpgshnik    67    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    55538    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49599    tormozit    48    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    31599    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26738    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    34040    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46158    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    99494    ids79    56    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    41559    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    27379    json    15    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16329    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    70807    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    38685    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    27680    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20810    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20199    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    55125    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    57935    ids79    26    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31789    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    26627    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    47436    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37127    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28704    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28248    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    33517    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    45420    Смешной 1С    30    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77870    Serginio    110    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    23567    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    36654    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    44183    ids79    11    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    28487    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29888    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    44237    ids79    72