Набор функций, возвращающих данные из истории версий объекта или "Кто виноват?" оптом

Публикация № 966166

Разработка - Практика программирования

Отчеты историяизменения версии объектов СКД ВерсииОбъектов ЖурналРегистрации журнал регистрации разработка

10
В рамках одного проекта понадобился функционал который бы сообщал ответ на так интересующий вопрос - "КТО ПОСЛЕДНИЙ МЕНЯЛ?!?" в отчете для большого количества объектов сразу. Найти решения не удалось на просторах интернета и по этому было принято решение сделать "Своё". Задумка очень проста - на входе ссылка на объект и интересующий нас реквизит, а на выходе все подноготная (кто, когда, из какого значения в какое). Хотел бы поделиться данными функциями с сообществом.

Хотелось бы отметить, что программирование в наше время, призвано облегчить работу пользователям и уменьшить количество кликов совершаемых ими до минимума, это и может послужить ответом на вопрос "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза".

Всё таки стоит отметить, что данные функции предназначены для применения в отчетах и формах с целью сокращения времени затраченного пользователями на анализ вручную отчета по версиям объектов.

Итак начнём с самого простого -

Первая функция ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизита)

// функция определяет кто, когда и как последний изменял реквизит переданной ссылки до указанной даты//
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяРеквизита  - имя реквизитакоторое проверяется изменение
// Возвращаемое значение:
//   Структура   - Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле
//
Функция ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизита) экспорт

	МетаданныеОбъекта = СсылкаПоиска.ПолучитьОбъект().Метаданные();
	Если МетаданныеОбъекта.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
	КонецЕсли; 
	Запр = новый Запрос("ВЫБРАТЬ
	                  
	                    |	ВерсииОбъектов.ТабличныеДокументы КАК ТабличныеДокументы,
	                    |	ВерсииОбъектов.НомерВерсии КАК Версия,
	                    |	ВерсииОбъектов.АвторВерсии КАК АвторВерсии,
	                    |	ВерсииОбъектов.ДатаВерсии КАК ДатаВерсии
	                    |ИЗ
	                    |	РегистрСведений.ВерсииОбъектов КАК ВерсииОбъектов
	                    |ГДЕ
	                    |	ВерсииОбъектов.ДатаВерсии <= &ДатаВерсии
	                    |	И ВерсииОбъектов.Объект = &Объект
	                    |
	                    |УПОРЯДОЧИТЬ ПО
	                    |	Версия");
	Запр.УстановитьПараметр("Объект",СсылкаПоиска);
	Запр.УстановитьПараметр("ДатаВерсии",Дата);
	ВыполненныйЗапрос = Запр.Выполнить();
	Если ВыполненныйЗапрос.Пустой() Тогда
	
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");	
	
	КонецЕсли; 
	Результат = ВыполненныйЗапрос.Выгрузить();
	ПоследняяВерсия=неопределено;
	Для каждого РезультатСтрока Из Результат Цикл
		
		ДвоичныеДанные = ВерсионированиеОбъектов.СведенияОВерсииОбъекта(СсылкаПоиска, РезультатСтрока.Версия).ВерсияОбъекта;
		
		Если ДвоичныеДанные = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		
		Объект = ВосстановитьОбъектПоXML(ДвоичныеДанные,"");
		
		Если ПоследняяВерсия=неопределено Тогда
			
		    ПоследняяВерсия = новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект=Объект;	
			ПоследняяВерсия.ЗначениеДо = "";
			ПоследняяВерсия.ЗначениеПосле = Объект[ИмяРеквизита];
			продолжить;
			
		КонецЕсли; 
		Если Объект[ИмяРеквизита] <> ПоследняяВерсия.Объект[ИмяРеквизита] Тогда
			
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект = Объект;
			ПоследняяВерсия.ЗначениеДо = ПоследняяВерсия.ЗначениеПосле;
			ПоследняяВерсия.ЗначениеПосле = Объект[ИмяРеквизита];
			
		КонецЕсли; 
	КонецЦикла;
	Если ПоследняяВерсия=неопределено Тогда
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле");
	иначе
		Возврат ПоследняяВерсия;
	КонецЕсли;
КонецФункции // ПолучитьИзменившегоРеквизитОбъектаНаДату()

Это простая функция которая просто вернёт нам необходимые данные структурой. И тут, я считаю, комментарии дополнительные излишни.

Казалось бы - задача выполнена и можно остановиться, но как быть с табличными частями? Ответом на этот вопрос и послжит

Вторая функция ПолучитьИзменившегоСтрокуТЧОбъектаНаДату

// функция определяет кто, когда и как последний изменял реквизит строки табличной части переданной ссылки до указанной даты//
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяТЧ  - имя табличной части проверяется изменение
//  ИмяРеквизитаТЧ - имя колонки значение которой проверяется
//  СтруктураОтбораСтрокиТЧ - структура с параметрами ИменаКолонок - имя колонки по которой будет поиск, Значение - искомое значение. 
//                            К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки.
// Возвращаемое значение:
//   Структура   - Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ
//
Функция ПолучитьИзменившегоСтрокуТЧОбъектаНаДату(СсылкаПоиска,Дата,ИмяТЧ,ИмяРеквизитаТЧ,СтруктураОтбораСтрокиТЧ)экспорт 	
	Если 	СсылкаПоиска.ПолучитьОбъект().Метаданные().ТабличныеЧасти.Найти(ИмяТЧ) 	= Неопределено
			или СсылкаПоиска.ПолучитьОбъект().Метаданные().ТабличныеЧасти[ИмяТЧ].реквизиты.найти(ИмяРеквизитаТЧ)  = неопределено
			или	СтруктураОтбораСтрокиТЧ.Свойство("ИменаКолонок") 				= ложь 
			или СтруктураОтбораСтрокиТЧ.Свойство("Значение") 					= ложь Тогда
			
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
		
	КонецЕсли; 
	Запр = новый Запрос("ВЫБРАТЬ
	                  
	                    |	ВерсииОбъектов.ТабличныеДокументы КАК ТабличныеДокументы,
	                    |	ВерсииОбъектов.НомерВерсии КАК Версия,
	                    |	ВерсииОбъектов.АвторВерсии КАК АвторВерсии,
	                    |	ВерсииОбъектов.ДатаВерсии КАК ДатаВерсии
	                    |ИЗ
	                    |	РегистрСведений.ВерсииОбъектов КАК ВерсииОбъектов
	                    |ГДЕ
	                    |	ВерсииОбъектов.ДатаВерсии <= &ДатаВерсии
	                    |	И ВерсииОбъектов.Объект = &Объект
	                    |
	                    |УПОРЯДОЧИТЬ ПО
	                    |	Версия");
	Запр.УстановитьПараметр("Объект",СсылкаПоиска);
	Запр.УстановитьПараметр("ДатаВерсии",Дата);
	ВыполненныйЗапрос = Запр.Выполнить();
	Если ВыполненныйЗапрос.Пустой() Тогда
	
		Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");	
	
	КонецЕсли; 
	Результат = ВыполненныйЗапрос.Выгрузить();
	
	ПоследняяВерсия=неопределено;
	
	Для каждого РезультатСтрока Из Результат Цикл
		
		ДвоичныеДанные = ВерсионированиеОбъектов.СведенияОВерсииОбъекта(СсылкаПоиска, РезультатСтрока.Версия).ВерсияОбъекта;
		
		Если ДвоичныеДанные = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		
		Объект = ВосстановитьОбъектПоXML(ДвоичныеДанные,"");
		Попытка
		
			СтрокаТЧ = Объект[ИмяТЧ].найти(СтруктураОтбораСтрокиТЧ.Значение,СтруктураОтбораСтрокиТЧ.ИменаКолонок);	
		
		Исключение
		    Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
		КонецПопытки; 
		Если СтрокаТЧ = неопределено Тогда
		
			продолжить;
		
		КонецЕсли; 
		ЗначениеСтроки = СтрокаТЧ[ИмяРеквизитаТЧ];
		
		Если ПоследняяВерсия	=	неопределено Тогда
			
		    ПоследняяВерсия = новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект=Объект;	
			ПоследняяВерсия.ЗначениеДо = "";
			ПоследняяВерсия.ЗначениеПосле = ЗначениеСтроки;
			ПоследняяВерсия.ИндексСтрокиТЧ = СтрокаТЧ.НомерСтроки;
			продолжить;
			
		КонецЕсли; 
		Если ЗначениеСтроки <> ПоследняяВерсия.ЗначениеПосле Тогда
			
			ЗаполнитьЗначенияСвойств(ПоследняяВерсия,РезультатСтрока);
			ПоследняяВерсия.Объект = Объект;
			ПоследняяВерсия.ЗначениеДо = ПоследняяВерсия.ЗначениеПосле;
			ПоследняяВерсия.ЗначениеПосле = ЗначениеСтроки;
			ПоследняяВерсия.ИндексСтрокиТЧ = СтрокаТЧ.НомерСтроки;
			
		КонецЕсли; 
	КонецЦикла;
	Если ПоследняяВерсия	=	неопределено Тогда
			
		    Возврат новый Структура("Объект,ДатаВерсии,АвторВерсии,ЗначениеДо,ЗначениеПосле,ИндексСтрокиТЧ");	
			
	КонецЕсли;
	Возврат ПоследняяВерсия;
КонецФункции // ПолучитьИзменившегоРеквизитОбъектаНаДату()

Тут может возникнуть ряд вопросов на которые я постараюсь ответить сразу:

Из описания функции становится понятно, что работать будем именно со строкой данных, а не с таблицей в целом, так сделано для упрощения получения данных в отчете, у нескольких строк могут быть разные авторы версии, что пагубно скажется на группировке в иерархии, для определения конкретной строки я использовал именно функцию Найти, а не НайтиСтроки  - потому, что найти возвращает конкретную строку, тогда как другая функция - массив строк, пришлось бы ещё выбирать, что не есть удобно. 

Теперь нам понадобится функция которая вернет одно конкретное значение, до текущего момента мы получали обратно структуры данных, а её использовать в обращении через СКД не очень то и удобно. Для этого есть 

Третья функция ПолучитьУказанныеДанныеПоИзменениямРеквизитаИзИсторииОбъекта

// функция определяет кто или когда или как последний изменял реквизит строки табличной части или реквизита переданной ссылки до указанной даты 
// если не задано имя ТЧ то ищится реквизит ссылки
// Параметры:
//  СсылкаПоиска  - ссылка для которой необходимо определить 
//  Дата  - Дата по которую проверяются версии объектов
//  ИмяРеквизитаПроверки  - имя реквизитакоторое проверяется изменение  или имя колонки значение которой проверяется
//  РеквизитВозврата  - Имя того, что нужно получить: "Объект","ДатаВерсии","АвторВерсии","ЗначениеДо","ЗначениеПосле","ИндексСтрокиТЧ"
//  ИмяТЧ  - имя табличной части проверяется изменение
//  ИменаКолонокПоиска - имя колонки по которой будет поиск. К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки. 
//  ЗначениеПоиска - искомое значение. К табличной части по этим данным применится функция Найти(<Значение>, <Колонки>) для определения строки.                           
// Возвращаемое значение:
//   Зависит от переданного параметра РеквизитВозврата.
функция ПолучитьУказанныеДанныеПоИзменениямРеквизитаИзИсторииОбъекта(СсылкаПоиска,Дата,ИмяРеквизитаПроверки,РеквизитВозврата,ИмяТЧ = "",ИменаКолонокПоиска = "", ЗначениеПоиска = "")экспорт
	
	Если ИмяТЧ = "" Тогда
	
		ПолученнаяСтруктура = ПолучитьИзменившегоРеквизитОбъектаНаДату(СсылкаПоиска,Дата,ИмяРеквизитаПроверки);	
	
	Иначе
	
		ПолученнаяСтруктура = ПолучитьИзменившегоСтрокуТЧОбъектаНаДату(СсылкаПоиска,Дата,ИмяТЧ,ИмяРеквизитаПроверки,Новый Структура("ИменаКолонок, Значение",ИменаКолонокПоиска,ЗначениеПоиска));		
	
	КонецЕсли;
	НеобходимоеЗначение = "";
	Если ТипЗнч(ПолученнаяСтруктура) = тип("Структура") и ПолученнаяСтруктура.Свойство(РеквизитВозврата,НеобходимоеЗначение) Тогда
	
		возврат НеобходимоеЗначение;	
	
	КонецЕсли; 
КонецФункции

Данная функция добавляет универсальности всему механизму, так-как позволяет обращаться в одну точку и в зависимости от набора параметров возвращает конкретное значение, это будет удобно для использования в СКД. 

Все это строится на БСП и будет работать на актуальных релизах программ поддерживающих версионирование объектов. Единственный "прокол" в БСП это то что их функция ВосстановитьОбъектПоXML (код см. ниже) не является экспортно, что несколько усложняет нам жизнь по этому нам понадобится добавить её в наш модуль где будут располагаться пред идущие три красавицы. 

Функция ВосстановитьОбъектПоXML(ДанныеОбъекта, ТекстСообщенияОбОшибке = "")экспорт
	
	УстановитьПривилегированныйРежим(Истина);
	
	ДвоичныеДанные = ДанныеОбъекта;
	Если ТипЗнч(ДанныеОбъекта) = Тип("Структура") Тогда
		ДвоичныеДанные = ДанныеОбъекта.Объект;
	КонецЕсли;
	
	ЧтениеFastInfoSet = Новый ЧтениеFastInfoSet;
	ЧтениеFastInfoSet.УстановитьДвоичныеДанные(ДвоичныеДанные);
	
	Попытка
		Объект = ПрочитатьXML(ЧтениеFastInfoSet);
	Исключение
		ЗаписьЖурналаРегистрации(НСтр("ru = 'Версионирование'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
			УровеньЖурналаРегистрации.Ошибка,,, ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
		ТекстСообщенияОбОшибке = НСтр("ru = 'Не удалось перейти на выбранную версию.
											|Возможная причина: версия объекта была записана в другой версии программы.
											|Техническая информация об ошибке: %1'");
		ТекстСообщенияОбОшибке = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщенияОбОшибке, КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
		Возврат Неопределено;
	КонецПопытки;
	
	Возврат Объект;
	
КонецФункции

Как разработчик этого всего заявляю, что метод довольно варварский, и работает "со скрипом", это связанно с тем, что у 1с всё хранится в хранилище данных в виде двоичного кода и метод получить всё это - развернуть через XML что в цикле даст огромный труд, а если сложить это всё с тем, что у нас будут корячиться запросы в цикле - то можно смело ставить два на экзамене, но в защиту хотелось бы сказать, что это расширяет функционал СКД и позволит получать сведения о интересующих нас негодяях пользователях в отчетах и "давать по рукам" в режиме online и оптом.

Данный функционал можно так же прикрутить к кнопке на форме документа, которая будет возвращать вам информацию о том, кто последний изменял скидки в заказе по которому сделана реализация или к примеру того, кто изменил условия оплаты договора перед тем, как провести реализацию и т.д.

Разработка и тестирование велись на 1С:Предприятие 8.3 (8.3.13.1644) в конфигурации 1С:ERP Управление предприятием 2 (2.4.5.143)

Для функционирования необходимо подключенная к конфигурации БСП Версионирования объетков и включенная в использовании.

10

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. zeegin 45 19.12.18 15:34 Сейчас в теме
Разве это не типовой функционал БСП?
Документация:
https://its.1c.ru/db/bsp302doc#content:1858:1:issogl1_%D0%BF%D1%80%D0%BE%D1%81%D0%BC%D0%BE%D1%82%D1%80_%D0­%B8%D1%81%D1%82%D0%BE%D1%80%D0%B8%D0%B8_%D0%B8%D0%B7%D0%BC%D­0%B5%D0%BD%D0%B5%D0%BD%D0%B8%D0%B9_%D0%BE%D0%B1%D1%8A%D0%B5%­D0%BA%D1%82%D0%B0

Можно перейти к отчету по всем версиям объектов и отобрать в каких версиях конкретные интересующие реквизиты менялись...
Прикрепленные файлы:
andrvyst; ktb; user633533_encantado; Rustig; +4 Ответить
3. Rustig 1207 19.12.18 15:45 Сейчас в теме
(1) круто придумали!
что еще я не знаю?
7. feva 295 19.12.18 16:50 Сейчас в теме
(1) Абсолютно верно, именно об этом и и писал в самом начале статьи, рад что вы "Внимательно" прочитали
8. feva 295 19.12.18 16:51 Сейчас в теме
(1)
Хотелось бы отметить, что программирование в наше время, призвано облегчить работу пользователям и уменьшить количество кликов совершаемых ими до минимума, это и может послужить ответом на вопрос "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза"
2. user633533_encantado 5 19.12.18 15:44 Сейчас в теме
"Найти решения не удалось" - садись, два. Идите учить БСП и на пересдачу.
4. Rustig 1207 19.12.18 15:46 Сейчас в теме
(2) не кидайте камнями - это легче всего, покажите путь и дайте фонарь
5. user633533_encantado 5 19.12.18 15:58 Сейчас в теме
(4) Открываем конфигурацию "Библиотека стандартных подсистем" и изучаем подсистему "Версионирование объектов".
Что же вы там за "проекты" делаете с такими знаниями типовых подсистем ?
6. feva 295 19.12.18 16:49 Сейчас в теме
(5) Хорошо, простой вопрос - какая функция мне вернет одно значение - кто изменил реквизит?
9. feva 295 19.12.18 16:54 Сейчас в теме
(2) Товарищ магистр БСП, подскажите неучу каким образом можно получить в отчет на СКД кто изменил тот или иной реквизит
10. user633533_encantado 5 19.12.18 17:09 Сейчас в теме
(9) Не подскажу, так как это нафиг никому не нужная вещь , есть типовой отчет сравнения версий вызываемый из любого объекта подключенного к подсистеме.

Но вы всегда можете изобрести велосипед под хотелку заказчика, ваше право.
11. feva 295 19.12.18 17:13 Сейчас в теме
(10)т.е. нет такого функционала в БСП? Или Вы плохо знаете БСП?
Про типовой отчет сравнения версий написано ещё в начале статьи, и почему он не используется в некоторых случаях.
12. zeegin 45 19.12.18 17:25 Сейчас в теме
(11) Т.е. заполнить левую форму отбора набором параметров проще, чем пару раз ткнуть?
Ответ на вопрос-то где? "Почему нельзя просто посмотреть сравнение версий объектов ткнув туда, потом туда, затем туда и потом ещё два раза". Что улучшено? Как было, как сейчас? Почему это лучше в вашем сценарии? Почему в общем случае лучше БСП, а не ваш сценарий?

Где ответы на вопросы? Я вижу портянку текста кода и поноса мыслей, простите, а ответа на то почему стало лучше решать главный вопрос "КТО ПОСЛЕДНИЙ МЕНЯЛ?!?" не вижу.
andrvyst; +1 Ответить
13. feva 295 19.12.18 17:35 Сейчас в теме
(12)Левая форма была как пример использования функций.
Для анализа изменений одного реквизита одной реализации пользователю нужно сделать 5 действий и проанализировать портяночный отчет, что бы посмотреть кто сделал последним изменение.
Вопрос - сколько нужно действий что бы проверить 1000 реализаций?
16. zeegin 45 19.12.18 18:26 Сейчас в теме
(13) Зачем проверять 1000 реализаций? Какая проблема решается?
19. muskul 20.12.18 07:06 Сейчас в теме
(16)Например проблема кто и когда менял документы за определенный период. Этого отчета очень нехватает в типовых конфигурациях. Клиент хочет знать простой ответ, кто менял какие документы.
24. zeegin 45 20.12.18 18:54 Сейчас в теме
27. muskul 21.12.18 04:36 Сейчас в теме
(24) можешь пример отчета из такого журнала привести.Период месяц показать все реализации которые менялись в этом месяце.
28. zeegin 45 21.12.18 09:19 Сейчас в теме
(27) Администрирование, Обслуживание, Журнал регистрации, Установить отбор: Интервал, События, Метаданные.
Прикрепленные файлы:
32. muskul 23.12.18 05:21 Сейчас в теме
(28)И он тебе покажет все документы которые записывал менеджер за месяц. а нужны только дважды записанные.
21. feva 295 20.12.18 08:43 Сейчас в теме
(16) Допустим отдел аналитики хочет понять, кто из ответственных обособленных подразделений выставляет больше скидок, а кто больше наценок за прошедший год для премирования.
25. zeegin 45 20.12.18 18:58 Сейчас в теме
(21) Зачем для такого отчета версии? Для премирования надо использовать реальные продажи и реальные полученные деньги, а не скидку, которая потом была отменена. Да и вообще строить отчет с аналитикой для принятия управленческого решения по данным из документа, а не из регистра, это моветон.
30. feva 295 21.12.18 17:21 Сейчас в теме
(25) Это как пример и причины могут быть использовать именно версии.
На местах могут работать команды которые заводят и редактируют данные в хаотичном порядке. Менеджером продажи выступает один человек, о ценах договаривался другой человек, отгрузку и логистику рассчитывал третий человек, и если изначально не реализовано техническим, что фиксируется кто последний менял, а потом за год хотят получить эти данные, то журнал регистрации не несёт в себе ни какие были данные, ни когда их устанавливали. А когда штат работающий с 1с переваливает за 1к пользователей с каждой обособкой разбираться никто не захочет, но данные требуют уже вчера. По этому и приходится делать варварские решения (почему они не эффективны тоже описано в статье), но предоставляющие необходимые данные. Бывают и другие жизненные ситуации когда данные можно получить из регистра версий, но как правило приходилось отказывать клиентам.
31. feva 295 21.12.18 17:27 Сейчас в теме
(25) С опытом, и в Вашей практике появятся задачи требующие решения, пусть и не самого рационального на первый взгляд и это не единственный случай.
14. feva 295 19.12.18 17:51 Сейчас в теме
(12) все ответы в конце статьи, зачем использовать эти функции, их минусы и плюсы.
это расширяет функционал СКД и позволит получать сведения о интересующих нас пользователях в отчетах и "давать по рукам" в режиме online и оптом.

Данный функционал можно так же прикрутить к кнопке на форме документа, которая будет возвращать вам информацию о том, кто последний изменял скидки в заказе по которому сделана реализация или к примеру того, кто изменил условия оплаты договора перед тем, как провести реализацию и т.д.
15. zeegin 45 19.12.18 18:25 Сейчас в теме
(14) т.е. это не общее решение, а точечно, да еще и программировать надо...

и это вместо того, чтобы, считаем:
1. перейти на вкладку
2. открыть форму отбора реквизита по которому надо найти изменения
3. применить отбор
4. нажать кнопку сравнения версий

Вот если выбирать что проще, написать отчет или сделать кнопку с выводом или это же сделать в форме отчета бсп в режиме пользователя, что проще?
23. feva 295 20.12.18 09:10 Сейчас в теме
(15) С точки зрения программирования - проще отправить пользователя в типовой. Это не замена ему, а расширение. Для решения локальной задачи в рамках одного объекта, в большинстве случаев, лучше использовать типовой вариант. Данное решение имеет место быть если нужно получать информацию по большому объему объектов.
17. bulpi 157 19.12.18 18:45 Сейчас в теме
Не понял. Что это за регистр ВерсииОбъектов ?
Разве в новой платформе версионирование не встроено ?
20. feva 295 20.12.18 08:41 Сейчас в теме
(17) Да, все верно! Есть типовое решение которое позволяет в рамках одного документа посмотреть его версии (если включено версионирование), но порой не хватает отчета который покажет массово объекты и пользователей их изменяющие.
18. Rustig 1207 19.12.18 21:33 Сейчас в теме
в любом случае, какая ни была статья, обсуждение полезно
triviumfan; +1 Ответить
22. feva 295 20.12.18 08:47 Сейчас в теме
26. acanta 74 20.12.18 22:58 Сейчас в теме
Можно ли по регистру сведений получить срез последних и показать отдельной колонкой к примеру в справочнике контрагенты (форма списка) дату и автора последних изменений (и вообще имеет ли смысл записывать признак изменения и авторство в элемент справочника партнеры при модификации к примеру соглашения или условий договора) вместо/по аналогии с типовой датой создания и менеджером?
29. feva 295 21.12.18 17:13 Сейчас в теме
(26) В том и проблема, что нельзя напрямую, т.к. данные (дата и автор версии) хранятся в регистре в хранилище значений как двоичные данные и запросом пока нет технической возможности получить, для этого нужны данные функции.
Мог зайти человек создать контрагента и записать его номер телефона. Следом зашёл другой человек и изменил номер, но допустил ошибку, вот можно использовать эти функции, что бы рядом с номером указывать того, кто этот номер ввёл и какой он был раньше.
33. androgin 17.01.19 14:31 Сейчас в теме
Устарело.
В текущих версиях можно использовать ИсториюДанных.
Ну или журнал регистрации будет интересней, чем версионирование.
Надеюсь в скором будущем 1С откажется от этой подсистемы в пользу ИсторииДанных
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 142

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    9231    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 343

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    13367    ids79    44       

Три костыля. Сказ про фокусы в коде 123

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    9376    YPermitin    68       

Отслеживание выполнения фонового задания 141

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    10772    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 254

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    14548    ids79    30       

Фоновое выполнение кода в 1С - это просто 120

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    11566    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 131

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    13181    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 149

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    11547    ids79    27       

Регистры сведений. За кулисами 129

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    9005    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал 183

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    8182    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 209

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    21360    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 179

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12832    dmurk    134       

Регистры накопления. Структура хранения в базе данных 176

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    19313    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    11462    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    6296    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    8939    m-rv    16       

О расширениях замолвите слово... 193

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    17963    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    14128    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    14494    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 166

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    17552    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    13965    ids79    27       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    23386    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 119

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    20555    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    22407    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22437    ids79    40       

Вспомогательные инструкции в коде 1С 106

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21629    tormozit    100       

Произвольный код в фоновом режиме 165

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    15886    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    23074    Rain88    42       

Повышаем эффективность разработки правил обмена 125

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    20362    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 156

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25757    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    22325    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    18115    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    12152    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 129

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    26739    avfed@rambler.ru    19       

Минимализмы 3 356

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    37287    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26665    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    22091    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 738

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    143261    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    23914    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    22186    unichkin    18       

Разбираемся с настройками компоновки данных 161

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    25287    json    9       

Работа с Excel 299

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    27348    arakelyan    39