Бухучет Украина.Начислении износа по полностью изношенному элементу

Публикация № 97595 08.11.11

Бухгалтерский учет - Учет ОС и НМА

Небольшая проблема при начислении износа по полностью изношенному элементу. В проводки идут рассчитанные суммы предыдущего элемента.

// ===============================
// рассчитывает износ по конкретному ОС, НМА, необоротному активу
// по установленному для него методу

Процедура РассчитатьИзносПоЭлементу(Элемент, ПервСтоимость, ПервКво, ОстСтоимость, СчИзноса, Сч, ПервСтоимостьНУ, ОстСтоимостьНУ, СчИзносаНУ, СчНУ)
    Элемент.ИспользоватьДату(НачМесяца(ДатаДок),1);
    Если Элемент.МетодРасчетаИзноса.Выбран() = 0 Тогда
        глКомментарий(Строка(Элемент)+": не задан метод расчета износа. Износ не начислен!",0,,"!");
        Возврат;
    КонецЕсли;
    Если ПервКво = 0 Тогда
        Если ОстСтоимость > 0 Тогда
            глКомментарий(Строка(Элемент)+": Первоначальное количество равно 0. Износ не начислен!",0,,"!");
        КонецЕсли; 
        СуммаИзноса = 0;   // нужно вставить
        СуммаИзносаНУ = 0;  // нужно вставить
       
        Возврат;
    КонецЕсли;

............................................  далее по тексту ............................................

Полный текст модуля документа - в файле вложения

Скачать файлы

Наименование Файл Версия Размер
МодульДокумента_НачислениеИзноса.rar

.rar 3,84Kb
1
.rar 3,84Kb 1 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Исправление ошибки в отчете "Журнал счетов-фактур по Постановлению № 1137" в 1С Бухгалтерии 7.7 537-7.7.538 релиз

Адаптация типовых решений v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

В отчете "Журнал счетов-фактур по Постановлению № 1137" в печатной форме не выводятся суммы НДС по ставке 10%, внесенные вручную в документе "Счет-фактура полученный"

1 стартмани

12.04.2012    11891    ksv74    1    

Исправление ошибки вычисления суммы удержанного НДФЛ в ЗиК 320-322

Зарплата Адаптация типовых решений v77::Расчет 1С7:ЗиК Россия БУ НДФЛ Абонемент ($m)

При заполнении таблицы ДоходыВычетыНалогиСотрудников в функции глобального модуля глСобратьДанныеДляНДФЛ2011() есть ошибка при вычислении колонки "НУ1" (суммы удержанного НДФЛ для целей налогового учёта). Данная статься посвящена её исправлению.

1 стартмани

18.03.2012    17575    andrewks    33    

Исправление серии ошибок при сохранении/восстановлении множественного фильтра (МФ) в отчётах и обработках в ТиС 9.2

Адаптация типовых решений v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Исправление серии ошибок при сохранении/восстановлении множественного фильтра (МФ) в отчётах и обработках в ТиС 9.2 (утеря сохранённых значений и/или некорректное восстановление некоторых параметров МФ при различных вариантах активных элементов формы перед сохранением настройки)

1 стартмани

08.05.2011    15975    andrewks    12    

Загогулина (с) "не моё" - 2

Адаптация типовых решений v77::Расчет 1С7:ЗиК Россия Абонемент ($m)

Еще один глюк ЗиК 300 в отчете по перс. учету 2010

1 стартмани

27.09.2010    2072    pvk78    3