Где деньги?

22.10.09

Учетные задачи - Взаиморасчеты

Отчет написан для себя и под свою конфигурацию. Думаю, что кому будет интересно, тот подправит его под себя. В отчете можно наглядно увидеть, куда (в какого поставщика и в какой конкретно товар) вложены деньги или на чьих деньгах работает фирма. Удобен при расчетах с поставщиками. ВЕСЬМА чувствителен к границе последовательности. При сбитой последовательности может выдавать нелогичные значения, но в целом - понять можно.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
where money
.ert 36,50Kb
147
147
1 SM
Скачать Купить за 1 850 руб.

Работает при партионном учете товара.

На полные авторские права не претендую.

См. также

Взаиморасчеты Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Управленческий учет Абонемент ($m)

Обработка для конфигурации Торговля и Склад 7.7, которая поможет рассчитать пени на просроченные платежы ваших Покупателей за выбранный период, с применением нескольких ставок рефинансирования по датам.

1 стартмани

12.10.2017    13738    7    torgstar    0    

3

Печатные формы Взаиморасчеты Бухгалтер Пользователь Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Внешняя печатная форма счет-фактуры с 01.07.2017 г. для Конфигурации 1С:Бухгалтерия 7.7.

1 стартмани

23.06.2017    50335    254    Perm1C    17    

5

Взаиморасчеты Акт сверки Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет Абонемент ($m)

Акт сверки для 1С:Бухгалтерии 7.7 И УСН 7.7 (начиная с версии файла 1.0.1) Тестировался на релизах (бухгалтерии от 594 и выше, упрощенки от 250 и выше). Добавлена возможность группировать операции по договорам контрагента и формировать обороты по ним. Добавил (начиная с версии 1.0.3) и вывод (опционально) счетов-фактур В версии 1.05 добавил множественный фильтр ( по контрагентам и договорам). Для чего это нужно. Ну к примеру, когда юрлицо реорганизуется или когда есть холдинг. 18.10.2022 Сделал как БП 3.0 в акте сверке выводится сальдо по каждому договору 10.11.2022 Сделал как Сверки как БП 3.0 (убрал все фильтры, они не понятны бухгалтеру), только добавил флажок "разбивать по договорам" и в таком случае логика отчета аналогична логике отчета в БП 3.0 ( т.е движения и сальдо разбиваются по договорам). Отчет так и называется Акт сверки как в БП3_0

1 стартмани

24.01.2017    17335    30    AndKovalchuk    3    

3

Взаиморасчеты Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Сортировка 62 счета по субсчетам Обработка сама закрывает авансы, при этом она позволяет работать с кореспонденцией любого типа по 62 счету, например схлопнуть 62,4 на 62,1 , а затем 62,1 на 62,2 или сразу 62,2 на 62,1 ,т.е. сколько раз хотите столько и запустите с различными вариациями.

1 стартмани

18.10.2013    29748    30    zavsom    3    

3

Взаиморасчеты Оптовая торговля Учет доходов и расходов Розничная торговля Программист Бизнес-аналитик Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Абонемент ($m)

Раньше этот отчет распространялся платно и только по нашим клиентам. Сегодня выкладываем его в общее пользование, в память о золотом веке семерки. Впрочем, уверен, что и сейчас скачиваний будет немало, ведь семерка жива, и на "1С:Торговле и склад" многие торговые компании предпочитают до сих пор вести учет продаж.

1 стартмани

31.07.2013    42063    148    O-Planet    15    

14

Взаиморасчеты Акт сверки Бухгалтер Оперативный учет 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Формирование и печать акта сверки взаиморасчетов с контрагентами по данным учета конфигурации "Торговля и склад" 7.7.

1 стартмани

10.07.2013    18612    66    АннаШ    3    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. assa 61 30.10.09 00:34 Сейчас в теме
Пришло письмо такого содержания:
Добрый вечер! По поводу отчета "где деньги" (понимаю что делали под себя, поэтому подправьте под меня :) ) выдает сообщение:
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(41)}: Переменная не определена (глПустаяФирма)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(62)}: Функция не обнаружена (глФРМКоличествоВОтчете)
СуммаДокумента=глФрм(Запрос.ПрихДокумент.Итог("Сумма"),Рубли<<?>>,1);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(72)}: Переменная не определена (Рубли)
НаимТовара=глТоварВОтчете<<?>>(Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(82)}: Функция не обнаружена (глТоварВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(83)}: Функция не обнаружена (глФРМКоличествоВОтчете)
НаимТовара=глТоварВОтчете<<?>>(Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(179)}: Функция не обнаружена (глТоварВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(180)}: Функция не обнаружена (глФРМКоличествоВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(185)}: Функция не обнаружена (глФРМКоличествоВОтчете)
Каковы должны быть мои действия?
со ссылкой для ответа http://infostart.ru/club/messages/chat/83200/ Не знаю, как у кого, а у меня выдает 404 поэтому отвечу здесь.
В глобальном модуле или прямо в обработке добавить:
Перем глПустаяФирма Экспорт;
Перем Рубли Экспорт;
Процедура ПриОткрытии()
глПустаяФирма = ПолучитьПустоеЗначение("Справочник.Фирмы");
Рубли = Константа.БазоваяВалюта;
КонецПроцедуры

//=================================================/
// по количеству в базовых единицах и товару возвращает кол-во, показываемое в отчете,
// т.е. кол-во в единицах по умолчанию
Функция глФРМКоличествоВОтчете(КолВБазовыхЕдИзм,Товар) Экспорт
Если Товар.ЕдиницаПоУмолчанию.Выбран()=0 Тогда
Возврат КолВБазовыхЕдИзм;
ИначеЕсли Товар.ЕдиницаПоУмолчанию.Коэффициент=0 Тогда
Возврат КолВБазовыхЕдИзм;
Иначе
Возврат (КолВБазовыхЕдИзм/Товар.ЕдиницаПоУмолчанию.Коэффициент);
КонецЕсли;
КонецФункции

//=================================================
Функция глТоварВОтчете(Товар) Экспорт

Если Товар.Выбран()=0 Тогда
Возврат "";
ИначеЕсли Товар.ЭтоГруппа()>0 Тогда
Возврат СокрЛП(Товар.Наименование);
Иначе
Возврат СокрЛП(Товар.Наименование)+
?(ПустаяСтрока(Товар.Артикул)=0,", арт. "+СокрЛП(Товар.Артикул),"")+
?(Товар.ЕдиницаПоУмолчанию.Выбран()>0," ("+СокрЛП(Товар.ЕдиницаПоУмолчанию.Наименование)+")","");
КонецЕсли;

Возврат "";

КонецФункции

//=================================================/
Функция глФРМ(ЧислЗнач,Вал,Реж) Экспорт
Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч015.0.")),СокрЛ(Формат(ЧислЗнач,"Ч015.2.")));
Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
Возврат Стр;
Иначе
Возврат Стр+" "+СокрП(Вал.Наименование);
КонецЕсли;
КонецФункции

или же вместо этих функций использовать для количества - Запрос.ОстатокТовараКонОст, для товара - СокрЛП(Запрос.Товар.Наименование), для сумм - Запрос.ПрихДокумент.Итог("Сумма")
Оставьте свое сообщение