Карпов Андрей | Программист 1С | ООО Сибинтек

«Как заработать миллион или история успешного сотрудничества»

В данном докладе я хочу пройтись по теме заработка с компанией Инфостарт, с точки зрения самостоятельного разработчика: Основные тезисы: - Прибыльна ли продажа собственных программ. - Какой заключить договор как физ лицо, или как юр лицо, стоит ли оформлять ИП. - Какую тему для разработки выбрать. Нужно ли разбираться в предметной области. - Как оформить публикацию на сайте, хитрости и приемы оформления, как вывести публикацию в поисковых запросах. - Какой выбрать способ распространения своей программы, плюс и минусы разработок с открытым кодом, и закрытым, продаж по тех поддержке и по лицензии. - Реклама собственного программного продукта: какие ресурсы можно использовать для рекламы, как помогает в этом Инфостарт - продажа сопутствующих услуг - Организация времени работы, какие средства автоматизации использую лично я, как максимально сэкономить свое время на общении с пользователями. - Организация работы с клиентами, как помогает в этом Инфостарт, как работать с возвратами.

Где деньги?

Отчеты - Управленческие

Отчет написан для себя и под свою конфигурацию. Думаю, что кому будет интересно, тот подправит его под себя. В отчете можно наглядно увидеть, куда (в какого поставщика и в какой конкретно товар) вложены деньги или на чьих деньгах работает фирма. Удобен при расчетах с поставщиками. ВЕСЬМА чувствителен к границе последовательности. При сбитой последовательности может выдавать нелогичные значения, но в целом - понять можно.

Работает при партионном учете товара.

На полные авторские права не претендую.

Скачать файлы

Наименование Файл Версия Размер
where money
.ert 36,50Kb
22.10.09
148
.ert 36,50Kb 148 Скачать

См. также

Комментарии
Сортировка: Древо
1. assa 56 30.10.09 00:34 Сейчас в теме
Пришло письмо такого содержания:
Добрый вечер! По поводу отчета "где деньги" (понимаю что делали под себя, поэтому подправьте под меня :) ) выдает сообщение:
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(41)}: Переменная не определена (глПустаяФирма)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(62)}: Функция не обнаружена (глФРМКоличествоВОтчете)
СуммаДокумента=глФрм(Запрос.ПрихДокумент.Итог("Сумма"),Рубли<<?>>,1);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(72)}: Переменная не определена (Рубли)
НаимТовара=глТоварВОтчете<<?>>(Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(82)}: Функция не обнаружена (глТоварВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(83)}: Функция не обнаружена (глФРМКоличествоВОтчете)
НаимТовара=глТоварВОтчете<<?>>(Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(179)}: Функция не обнаружена (глТоварВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(180)}: Функция не обнаружена (глФРМКоличествоВОтчете)
ПечКол=глФРМКоличествоВОтчете<<?>>(Запрос.ОстатокТовараКонОст,Запрос.Товар);
{C:\DOWNLOADS\1C\ОБРАБОТКИ И ОТЧЕТЫ ДЛЯ 7.7\ARCHIVES\GDE DENJGI.ERT(185)}: Функция не обнаружена (глФРМКоличествоВОтчете)
Каковы должны быть мои действия?
со ссылкой для ответа http://infostart.ru/club/messages/chat/83200/ Не знаю, как у кого, а у меня выдает 404 поэтому отвечу здесь.
В глобальном модуле или прямо в обработке добавить:
Перем глПустаяФирма Экспорт;
Перем Рубли Экспорт;
Процедура ПриОткрытии()
глПустаяФирма = ПолучитьПустоеЗначение("Справочник.Фирмы");
Рубли = Константа.БазоваяВалюта;
КонецПроцедуры

//=================================================/
// по количеству в базовых единицах и товару возвращает кол-во, показываемое в отчете,
// т.е. кол-во в единицах по умолчанию
Функция глФРМКоличествоВОтчете(КолВБазовыхЕдИзм,Товар) Экспорт
Если Товар.ЕдиницаПоУмолчанию.Выбран()=0 Тогда
Возврат КолВБазовыхЕдИзм;
ИначеЕсли Товар.ЕдиницаПоУмолчанию.Коэффициент=0 Тогда
Возврат КолВБазовыхЕдИзм;
Иначе
Возврат (КолВБазовыхЕдИзм/Товар.ЕдиницаПоУмолчанию.Коэффициент);
КонецЕсли;
КонецФункции

//=================================================
Функция глТоварВОтчете(Товар) Экспорт

Если Товар.Выбран()=0 Тогда
Возврат "";
ИначеЕсли Товар.ЭтоГруппа()>0 Тогда
Возврат СокрЛП(Товар.Наименование);
Иначе
Возврат СокрЛП(Товар.Наименование)+
?(ПустаяСтрока(Товар.Артикул)=0,", арт. "+СокрЛП(Товар.Артикул),"")+
?(Товар.ЕдиницаПоУмолчанию.Выбран()>0," ("+СокрЛП(Товар.ЕдиницаПоУмолчанию.Наименование)+")","");
КонецЕсли;

Возврат "";

КонецФункции

//=================================================/
Функция глФРМ(ЧислЗнач,Вал,Реж) Экспорт
Стр=?(Вал=Константа.СтараяБазоваяВалюта,СокрЛ(Формат(ЧислЗнач,"Ч015.0.")),СокрЛ(Формат(ЧислЗнач,"Ч015.2.")));
Если (Реж=0) ИЛИ (ПустаяСтрока(Стр)=1) Тогда
Возврат Стр;
Иначе
Возврат Стр+" "+СокрП(Вал.Наименование);
КонецЕсли;
КонецФункции

или же вместо этих функций использовать для количества - Запрос.ОстатокТовараКонОст, для товара - СокрЛП(Запрос.Товар.Наименование), для сумм - Запрос.ПрихДокумент.Итог("Сумма")
Оставьте свое сообщение