Пример печатной формы в Word для УТ 11.4, ERP. КА 2.4, подложка и колонтитулы

30.05.19

Разработка - Инструментарий разработчика

Пример внешней печатной формы с выводом в MS Word для УТ 11.4, КА 2, ERP 2.4, печатная форма печатается из документа "Заказ клиента". Для примера разобрано програмнное заполнение верхнего и нижнего колонтитулов, а также печать в качестве подложки - логотипа организации (печать картинки на заднем фоне, при этом у логотипа уменьшена яркость и он повернут на 45 градусов).

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
Пример печатной формы в Word для УТ 11.4, ERP. КА 2.4, подложка и колонтитулы:
.epf 25,74Kb
33
33
1 SM
Скачать Купить за 1 850 руб.

В качестве примера рассматривается печать в Word из заказа клиента.

Шаблон в формате *.doc хранится как двоичные данные в макете, при этом внутри шаблона необходимые для заполнения поля указывается в знак решетки: #Организация#, #Контрагент# и т.п. Это сделано и в основном теле документа, и в колонтитулах.

В сведениях о внешней обработке указывается, что это "ВызовКлиентскогоМетода":

строкаКоманды = тзКоманд.Добавить();
строкаКоманды.Идентификатор = Идентификатор;
строкаКоманды.Представление = Наименование;
строкаКоманды.ПоказыватьОповещение = Истина;
строкаКоманды.Использование = "ВызовКлиентскогоМетода";
строкаКоманды.ПоказыватьОповещение = "Истина";

 

Далее, непосредственно в модуле формы в процедуре Печать получаем макет (на клиенте), и обращаемся к нему:

Процедура Печать(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
	
	Для Каждого ОбъектНазначения Из ОбъектыНазначения Цикл 
		MSWord 	= ПолучитьИзВременногоХранилища(МакетСервер("ЗаказКлиентаМакет"));
		ИмяВрем = ПолучитьИмяВременногоФайла(".doc");
		MSWord.Записать(ИмяВрем);

		// выводим данные 
		Попытка
			//получаем объект - документ. Это OLE объект, с ним можно работать используя все методы, которые существуют в VBA
			//Документ = ПолучитьCOMОбъект(ИмяВрем);
			COMОбъект = Новый COMОбъект("Word.Application");
			//COMОбъект.Documents.Add();
			COMОбъект.WordBasic.DisableAutoMacros(1);
			COMОбъект.Documents.Open(ИмяВрем);
			
			
			Документ = COMОбъект.ActiveDocument;


......

 

Все заполнение документа происходит на клиенте (предварительно необходимо получить нужные данные).

 

Ну и отдельно, заполнение колонтитулов:

&НаКлиенте
Процедура ВыполнитьЗаменуКолонтитула(СтруктураДанных, Документ, ЭтоВерхнийКолонититул = Ложь)
	
	Для Каждого КлючЗначение Из СтруктураДанных Цикл
		ТекстЧтоЗаменять = "#" + КлючЗначение.Ключ + "#";
		ТекстНаЧтоЗаменять = КлючЗначение.Значение;
		
		Если ЭтоВерхнийКолонититул ТОгда
			Документ.Sections(1).Headers(1).Range.Find.Execute(ТекстЧтоЗаменять, Ложь, Истина, Ложь, , , Истина, , Ложь, ТекстНаЧтоЗаменять, 2);
		Иначе
			Документ.Sections(1).Footers(1).Range.Find.Execute(ТекстЧтоЗаменять, Ложь, Истина, Ложь, , , Истина, , Ложь, ТекстНаЧтоЗаменять, 2);
		КонецЕсли;
	КонецЦикла;
		
КонецПроцедуры

 

и вставка подложки:

&НаКлиенте
Процедура ВставитьРисунокКакПодложку(COMОбъект,АдресВхранилищеРисунок, Расширение)
	
	ИмяФайла = ПолучитьИмяВременногоФайла(Расширение);
	ПолучитьФайл(АдресВхранилищеРисунок, ИмяФайла, Ложь);
	
	Документ = COMОбъект.ActiveDocument;
    Рис = Документ.Sections(1).Headers(1).Shapes.AddPicture(ИмяФайла,Ложь,Истина);
	
	Рис.PictureFormat.Brightness = 0.85; //уменьшаем яркость и контрастность
	Рис.PictureFormat.Contrast = 0.25;
	Рис.WrapFormat.AllowOverlap = True;
	Рис.WrapFormat.Type = 3;
	Рис.LockAspectRatio = True;
	
	Рис.Left = -999995;
	Рис.RelativeHorizontalPosition = 1;
	Рис.RelativeVerticalPosition = 1;
	Рис.Top = -999995;
	Рис.Rotation = 315; //поворачиваем под углом
	
КонецПроцедуры

 

В примере выводится в качестве подложки логотип организации, под углом 45 градусов, с уменьшенной яркостью. Эта подложка будет выводиться на всех листах документа.

 

Тестировалось на платформе 8.3.13.1690 на УТ 11.4.7.114 и ERP 2.4.7.141

Печать Word УТ 11.4 ERP колонтитулы подложка

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    136379    755    391    

781

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    10813    26    6    

55

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    6727    19    2    

44

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    8196    21    14    

53

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 руб.

14.01.2013    180963    1102    0    

874

Инструментарий разработчика Программист 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    15766    3    12    

38

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    100803    241    97    

300

Инструментарий разработчика Перенос данных 1C Программист Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы.  Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    24271    17    15    

34
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. TerveRus 07.06.19 09:12 Сейчас в теме
Жаль примера печати в скриншотах нет.
2. DarkPinch222 141 07.06.19 09:51 Сейчас в теме
(1) Последний скришот показывает как выглядит сформированный Word, с подложкой.
3. TerveRus 10.06.19 07:58 Сейчас в теме
(2) а где подложка? Вроде только колонтитул вижу...
4. DarkPinch222 141 10.06.19 09:42 Сейчас в теме
(3)на скриншоте - надпись "Москва", с красной звездой - это подложка, выполнена с понижением контрастности, и под углом 45 градусов. Эта картинка берется из логотипа организации
5. TerveRus 10.06.19 11:20 Сейчас в теме
(4) и где эта надпись на скриншоте? Контрастность видимо совсем на нуле, раз подложки совсем не видно.
6. taasha25 13 28.06.23 10:36 Сейчас в теме
Спасибо за обработку! А как выводить табличную часть?
Оставьте свое сообщение