Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором)

18.04.24

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

В работе постоянно приходится разделять в различные базы или объединять несколько организаций в одну базу, долгое время пользовался стандартной обработкой выгрузка-загрузка из UNIREPS 8.2, в режиме обычного приложения, но, к сожалению, для управляемого приложения стандартная обработка из UNIREPS 8.3 (Диск ИТС) не позволяет нормально сделать выгрузку с отбором, поэтому ей никогда не воспользовался. Решил что напишу обработку, которая позволит делать отборы в различных вариациях, кроме того, в обработках из UNIREPS (8.2 и 8.3) существенно отличается процесс загрузки предопределенных, что не всегда удобно при больших объемах данных. Обработка написана на базе UNIREPS 8.3, но есть существенные изменения. Но интерфейс доработан так, чтобы обработка была похожа на старую добрую обработку из UNIREPS 8.2, к которой все так привыкли.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором): 1С:Предприятие 8.3 (8.3.23.1865) кардинально переработан отбор с учетом возможностей СКД, добавлены новые кнопки для выбора объектов выгрузки
.epf 82,78Kb
309
309
1 SM
Скачать Купить за 1 850 руб.
Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором): 1С:Предприятие 8.3 (8.3.15.1565)
.epf 75,03Kb
103
103
1 SM
Скачать Купить за 1 850 руб.
Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором): для версии 1С:Предприятие 8.3 (8.3.15.1778) , на платформе этой версии некоторые функции работы с файлами работают уже несколько по другому.
.epf 75,38Kb
165
165
1 SM
Скачать Купить за 1 850 руб.

Обработка "Выгрузка и загрузка данных XML"  Управляемые формы

Режимы работы

Обработка реализует 2 режима работы: Выгрузки (создание файла выгрузки указанных пользователем данных) и Загрузки (чтение файла выгрузки, созданного одноименным режимом, и запись имеющихся в нем данных). Установка режима осуществляется выбором в поле Режим. Кроме того режим загрузки разделен на три различных режима по типу загрузки предопределенных данных.

Перед запуском того или иного режима (нажатие кнопки Выполнить) нужно указать имя файла выгрузки либо введя его вручную в поле "Имя файла", либо воспользовавшись кнопкой выбора этого поля и стандартным диалогом выбора файла.

В режиме загрузки имеется возможность редактирования использования итогов при записи регистров, что может повлиять на скорость загрузки.
Кнопки "Отключить итоги" и "Включить итоги" доступны при установленном флаге "Включить возможность редактирования использования итогов во время загрузки данных" и используются для ручного управления режимом использования итогов при загрузке данных. 

Условия применимости обработки

Обработка может использоваться только в тех случаях, когда информационная база, в которой осуществлялась выгрузка данных, и та, в которой данные загружаются, являются однородными (конфигурации идентичны, данные могут различаться), либо все выгружаемые объекты практически полностью идентичны по составу и типам реквизитов и табличных частей, свойствам "ведущего" объекта метаданных и т.д. Следует отметить, что, в связи с указанными ограничениями, обработка главным образом предназначена для обмена между однородными ИБ.

Формат файла выгрузки отличается от формата файла, создаваемого при выгрузке по плану обмена, заголовочной частью. Для выгрузки данных (элементов справочников, наборов записей регистров и т.д.) обработкой используется тот же механизм XML-сериализации, что и выгрузкой по планам обмена, в этой части форматы файлов идентичны.

Определение состава выгрузки

Обработка позволяет осуществить как полную, так и частичную выгрузку данных информационной базы в файл. Настройка состава выгружаемых данных производится в диалоге путем установки флажков в колонке дерева, отображающего объекты метаданных, данные по которым могут быть выгружены. Дополнительная колонка флажков, "При необходимости", устанавливает необходимость выгрузки объектов данного типа "по ссылке". То есть, если флажок установлен только в колонке "При необходимости", то данные по такому объекту будут выгружаться не полностью, а только в том объеме, который необходим для поддержания ссылочной целостности в информационной базе, которая будет загружать файл выгрузки.

При открытии формы обработка устанавливает признак выгрузки по ссылке всем объектам, что гарантирует ссылочную целостность выгруженного фрагмента информационной базы. 

При нажатии на кнопку "Определить данные, выгружаемые по ссылке" обработка анализирует, ссылки на какие данные могут содержаться в объектах, у которых установлен признак полной выгрузки, и автоматически заполняет колонку флажков, индицирующих необходимость выгрузки по ссылке. Если объект уже имеет установленный флажок полной выгрузки, в таком случае флажок выгрузки по ссылке не устанавливается.

В составе выгрузки имеется возможность произвести различные многоуровневые отборы в том числе по раскрываемым ссылкам, скопировать отборы, сделать индивидуальные отборы для определенных элементов конфигурации.

Режим загрузки - для предопределенных данных

Режим загрузки разделен на три типа:

1. Подменяем ссылки на преодопределенные элементы теми которые уже существуют в базе.  (Стандартный режим) Алгоритм работы  при выборе данного режима следующий -  Обрабатывается файл загрузки и базы данных, в которую производится загрузка, формируется таблица соответствия предопределенных элементов старой и новой базы, делается копия исходного файла загрузки (временный файл) и в нем производится замена идентификаторов предопределенных элементов, далее уже этот временный файл загружается в базу данных. Главным условием корректной работы является наличие самих предопределенных элементов в выгрузке (Режим выгружать при необходимости).

2. Удаление предопределенных  и загрузка новых из файла источника. В данном режиме позмены идетификаторов предопределенных элементов не производится, но производится непосредственное удаление  выгружаемого предопределенного элемента и создание нового с идентификатором из базы выгрузки. Этим режимом можно пользоваться если вы производите выгрузку в пустую базу, а не в ту в которой ведется учет, так как имеется возможность возникновения битых ссылок "<Объект не найден>". Этот режим загрузки требует модификации типовых конфигураций для разрешения удалять предопределенные.  Режим создан для необходимости в некоторых случаях совместить идентификаторы различных баз.

3. Быстрая загрузка без удаления предопределенных. (Возможно возникновение дублирования предопределенных).

Возможные применения

Использование этой обработки возможно, например, для создания полной или частичной резервной копии данных, осуществления обмена данными между информационными базами, а также как вспомогательный инструмент при восстановлении проблемных информационных баз.

Проверено на 1С:Предприятие 8.3 (8.3.15.1565).

Проверено на следующих конфигурациях и релизах:

  • Бухгалтерия предприятия, редакция 3.0, релизы 3.0.151.27, 3.0.146.31

Выгрузка загрузка XML UNIREPS 82 83 1C Управляемые формы

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138042    760    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70331    173    146    

116

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21754    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62319    51    27    

80

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184477    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48381    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    69123    46    126    

49

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192389    141    241    

272
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 06.11.19 10:22
Сообщение было скрыто модератором.
...
2. S_VA 11.12.19 03:06 Сейчас в теме
Необходимо объединить две организации в одну. на базе УНФ 1.6, конфигурации идентичны, но коды справочников и номера документов есть одинаковые, как в этом случае будет выполнена загрузка? Проводятся ли документы при загрузке?
6. o.kovalev 116 11.12.19 10:15 Сейчас в теме
(2) Документы при загрузке не проводятся, загружается набор записей
3. o.kovalev 116 11.12.19 08:32 Сейчас в теме
Я бы заранее установил префиксы в одной из баз источнике всем объектам, а потом уже выгружал
но все равно придется воспользоваться обработкой поиск и замена значений чтобы потом убрать дубли справочников.
4. S_VA 11.12.19 10:12 Сейчас в теме
(3)
Я бы заранее установил префиксы в одной из баз источнике всем объектам, а потом уже выгружал

Это как? В групповой обработке нет такого
5. o.kovalev 116 11.12.19 10:15 Сейчас в теме
(4) этого нет, это надо писать
7. o.kovalev 116 11.12.19 10:29 Сейчас в теме
(4) на Инфостарте есть обработки такие
https://infostart.ru/public/684868/
8. пользователь 11.12.19 11:48
Сообщение было скрыто модератором.
...
9. o.kovalev 116 11.12.19 11:54 Сейчас в теме
(8) у меня нет такой, я обычно пишу руками, могу пример кода накидать, после обеда пришлю
10. пользователь 11.12.19 12:18
Сообщение было скрыто модератором.
...
11. S_VA 12.12.19 06:07 Сейчас в теме
Ошибка Преобразование к типу число не может быть выполнено
12. пользователь 12.12.19 15:27
Сообщение было скрыто модератором.
...
13. Pavean 21.12.19 08:27 Сейчас в теме
При выгрузке при активации строки с задачами ошибка в строке 952.
Вместо
Для каждого ОбъектМетаданных Из Метаданные[ОбъектВыбора.Значение][ОбъектВыбора.Значение].РеквизитыАдресации Цикл

мне кажется должно быть
Для каждого ОбъектМетаданных Из Метаданные[ОбъектВыбора.Значение][Строка(ОбъектВыбора)].РеквизитыАдресации Цикл
.
Прикрепленные файлы:
14. o.kovalev 116 21.12.19 11:37 Сейчас в теме
15. o.kovalev 116 21.12.19 21:49 Сейчас в теме
(13) обработку исправил, там цикл нужен еще один строка 952 модуль формы

Для каждого ОбъектМетаданных Из Метаданные[ОбъектВыбора.Значение] Цикл
			Для каждого ОбъектМетаданных1 Из ОбъектМетаданных.РеквизитыАдресации Цикл
				
				НоваяСтрока = ТаблицаМетаданных.Добавить();
				
				НоваяСтрока.ИмяРеквизита = ОбъектМетаданных1.Имя;
				НоваяСтрока.СинонимРеквизита = ОбъектМетаданных1.Синоним;
				НоваяСтрока.ОписаниеТипов = ИсключитьНедопустимыеТипы(ОбъектМетаданных1.Тип); 
				НоваяСтрока.ОбъектМетаданных = ОбъектВыбора.Значение;
				
			КонецЦикла;
	КонецЦикла;
Показать
16. cprit 889 11.01.20 13:37 Сейчас в теме
Добрый день!
Для обычных форм есть замечательный набор инструментов "Инструменты разработчика 1С", но его невозможно использовать в линуксе и в тонком и веб клиенте.

Поэтому мы решили собрать подобный пакет, но который будет работать только на платформенных механизмах или с использованием кроссплатформенных компонент.

Использование этого пакета инструментов хотим сделать общедоступным(OpenSource), разработку вести через гитхаб с использованием EDT.

Можем ли мы включить в этот набор обработки(или часть идей и функционала) вашей обработки?

На текущий момент нашли основные инструменты (консоль запросов, консоль кода, редактор реквизитов, консоль компоновки и др.) для включения в инструментарий. Сейчас занимаемся получением одобрения авторов. Часть включаем свои- редактор предопределенных, редактор констант, Групповая обработка

Ссылка на репозиторий с новыми инструментами https://github.com/cpr1c/tools_ui_1c
17. o.kovalev 116 27.01.20 11:37 Сейчас в теме
(16)
Включайте, обработка не зря с открытым кодом
18. cprit 889 27.01.20 12:28 Сейчас в теме
(17) можете ее скинуть на почту levkin_s@cprit.ru или в задачу на гите приложить? Или скажите где ее можно скачать
19. alexbur 28 24.11.20 12:34 Сейчас в теме
Добрый день.
При добавлении отбора к регистру бухгалтерии Хозрасчетный отсутствует отбор по счетам.
20. alexbur 28 25.11.20 12:05 Сейчас в теме
(19), собственно, сам себе отвечаю. Для добавления отбора по счетам в регистре бухгалтерии нужно в процедуре
ИнициализироватьСКД()
после строчки

Если ОбъектВыбора.Значение="РегистрыСведений" или ОбъектВыбора.Значение="РегистрыНакопления" или ОбъектВыбора.Значение="РегистрыБухгалтерии" Тогда


вставить кусок кода:

			// {Начало изменений [25.11.2020 15:47:53] Причина: Добавление фильтра по счетам учета для регистра бухгалтерии. 
			Если ОбъектВыбора.Значение="РегистрыБухгалтерии"  И Метаданные[ОбъектВыбора.Значение][Строка(ОбъектВыбора)].Корреспонденция Тогда
				НоваяСтрока = ТаблицаМетаданных.Добавить();
				НоваяСтрока.ИмяРеквизита = "СчетДТ";
				НоваяСтрока.СинонимРеквизита = "СчетДТ";
				НоваяСтрока.ОписаниеТипов = ПланыСчетов.ТипВсеСсылки(); 
				НоваяСтрока.ОбъектМетаданных = ОбъектВыбора.Значение;
				
				НоваяСтрока = ТаблицаМетаданных.Добавить();
				НоваяСтрока.ИмяРеквизита = "СчетКТ";
				НоваяСтрока.СинонимРеквизита = "СчетКТ";
				НоваяСтрока.ОписаниеТипов = ПланыСчетов.ТипВсеСсылки(); 
				НоваяСтрока.ОбъектМетаданных = ОбъектВыбора.Значение;
			КонецЕсли;
			// }  Конец изменений [25.11.2020 15:48:46]

Показать
21. o.kovalev 116 25.11.20 13:23 Сейчас в теме
(20) Хорошо спасибо, посмотрю
22. o.kovalev 116 25.11.20 13:40 Сейчас в теме
(20) Внес изменение в версию 1.02, еще раз спасибо !
23. ИНТЕГРА 25 20.01.21 20:56 Сейчас в теме
Че за...
Прикрепленные файлы:
24. o.kovalev 116 21.01.21 08:41 Сейчас в теме
(23) Какая версия обработки ?
27. ИНТЕГРА 25 21.01.21 20:07 Сейчас в теме
25. o.kovalev 116 21.01.21 14:09 Сейчас в теме
(23) Ошибка исправлена в версии 1.02

Изменения:
стр 16997 -1759 - исправления в участке кода

Запрос= Новый Запрос();
	
	Если ДляЗапроса = "РегистрБухгалтерии." Тогда
		
		УсловиеЗапроса="";
		//  ограничения
		Для Каждого Строка ИЗ ТаблицаОтбора1 Цикл
			Если  ИмяОбъекта=Строка.имяреквизита И СтрокаДереваМетаданных.ИмяОбъектаМетаданных=Строка.ИмяОбъектаМетаданных Тогда
				Для Каждого СтрокаЭлементы ИЗ Строка.Отбор.Элементы Цикл
					Если СтрокаЭлементы.Использование Тогда
						ЛевоеЗначение=СтрЗаменить(Строка(СтрокаЭлементы.ЛевоеЗначение), ".", "_");
						
						Если Строка(ТипЗнч(СтрокаЭлементы.ПравоеЗначение))="Стандартная дата начала" Тогда
							Запрос.УстановитьПараметр(ЛевоеЗначение,СтрокаЭлементы.ПравоеЗначение.Дата);
						Иначе
							Запрос.УстановитьПараметр(ЛевоеЗначение,СтрокаЭлементы.ПравоеЗначение);
						КонецЕсли;
												
						Если Не Первая Тогда
							УсловиеЗапроса = УсловиеЗапроса + Символы.ПС+" И "+ ПолучитьВидСравненияВЗапросРегистр(Строка,СтрокаЭлементы,СтрокаЭлементы.ВидСравнения);
						Иначе
							УсловиеЗапроса = УсловиеЗапроса + Символы.ПС+" "+ ПолучитьВидСравненияВЗапросРегистр(Строка,СтрокаЭлементы,СтрокаЭлементы.ВидСравнения);
						КонецЕсли;
						Первая=Ложь;
					КонецЕсли;
				КонецЦикла;
				Прервать;	
			КонецЕсли;
		КонецЦикла;
		
		
		ТекстЗапроса="ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ  1 * ИЗ " + ИмяТаблицыДляЗапроса+"(, , "+УсловиеЗапроса+", ,  )  КАК ТаблицаОбъекта_" + ИмяОбъекта;
		
	Иначе
		
		ТекстЗапроса = "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ  1 *   ИЗ " + ИмяТаблицыДляЗапроса+ " КАК ТаблицаОбъекта_"+ИмяОбъекта;
		
		Для Каждого Строка ИЗ ТаблицаОтбора1 Цикл
			Если  ИмяОбъекта=Строка.имяреквизита И СтрокаДереваМетаданных.ИмяОбъектаМетаданных=Строка.ИмяОбъектаМетаданных Тогда
				Для Каждого СтрокаЭлементы ИЗ Строка.Отбор.Элементы Цикл
					Если СтрокаЭлементы.Использование Тогда
						ЛевоеЗначение=СтрЗаменить(Строка(СтрокаЭлементы.ЛевоеЗначение), ".", "_");
						Если Строка(ТипЗнч(СтрокаЭлементы.ПравоеЗначение))="Стандартная дата начала" Тогда
							Запрос.УстановитьПараметр(ЛевоеЗначение,СтрокаЭлементы.ПравоеЗначение.Дата);
						Иначе
							Запрос.УстановитьПараметр(ЛевоеЗначение,СтрокаЭлементы.ПравоеЗначение);
						КонецЕсли;
						
						Если Не Первая Тогда
							ТекстЗапроса = ТекстЗапроса + Символы.ПС+" И "+ ПолучитьВидСравненияВЗапрос(Строка,СтрокаЭлементы,СтрокаЭлементы.ВидСравнения);
						Иначе
							ТекстЗапроса = ТекстЗапроса + Символы.ПС+" ГДЕ "+ ПолучитьВидСравненияВЗапрос(Строка,СтрокаЭлементы,СтрокаЭлементы.ВидСравнения);
						КонецЕсли;
						Первая=Ложь;
					КонецЕсли;
				КонецЦикла;
				Прервать;	
			КонецЕсли;
		КонецЦикла;
		
	КонецЕсли;
Показать
28. ИНТЕГРА 25 23.01.21 01:06 Сейчас в теме
(25)
исправления в участке кода

Посмотрите какую версию я у Вас приобрел, если сомневаетесь. В статистике скачиваний должно быть. Именно 1.02 я и качал.
Боюсь приведенные куски кода никому ни о чем не говорят кроме Вас)

Мне нужно перегрузить записи регистра накопления по фильтру. Самому писать не пристало такие универсальные штуки :) Качать поделки других инфостартовцев - себе дороже, как показывает практика (ибо везде говнокод только попадается, уж простите за откровенность), если есть возможность - исправьте, если нет - ну и шут с ним моим стартманей, зато выговорился :)
29. o.kovalev 116 23.01.21 20:29 Сейчас в теме
(28) пришлите мне свой email , я пришлю вам последнюю версию,
26. o.kovalev 116 21.01.21 14:56 Сейчас в теме
(23) При проверке на разных типах вылезла еще одна ошибка при выгрузке регистра, в ближайшее время будет исправлено, отпишусь
30. o.kovalev 116 09.04.21 16:49 Сейчас в теме
Переработал весь механизм , теперь отборы при выгрузке работают по другому.
31. petrova_lena@mail.ru 13 23.04.21 13:34 Сейчас в теме
Очень помогло для восстановления предопределенных элементов справочника "виды контактной информации" в обычной типовой бухне 3.
5 минут и все готово. Спасибо!
o.kovalev; +1 Ответить
32. PovAndy 28.04.21 15:18 Сейчас в теме
Можно ли использовать обработку для загрузки поступления товаров в УТ 11.4 из XML-файла?
33. o.kovalev 116 29.04.21 08:00 Сейчас в теме
(32) Обработка универсальная, как Unireps но на конкретной версии УТ 11.4 я не тестировал (нет под рукой чтобы сейчас сказать) скорее всего проблем не будет.
34. user1668831 30.09.21 15:34 Сейчас в теме
Добрый день. При загрузке БП 3.0 типовая 3.0.98.11. база выгрузки БП 3.0 типовая 3.0.98.11
Как справиться с ошибкой?
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.1/data/enterprise/current-config}Я_ДатаВвода Форма: Элемент Тип: {http://www.w3.org/2001/XMLSchema}anyType
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_4.МодульОбъекта(287)}: ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_4.Форма.Форма.Форма(574)}: РеквизитФормыВЗначение("Объект").ВыполнитьЗагрузку(ИмяВременногоФайла);
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_4.Форма.Форма.Форма(239)}: ЗагрузитьДанныеНаСервере(Параметр1.Адрес);

по причине:
Ошибка преобразования данных XDTO:
35. user1668831 30.09.21 15:50 Сейчас в теме
Извините. Все работает (не заметила наличие разных расширений в базах). Спасибо. Супер!!!
Вопрос
можно ли установить сложный отбор? Мне нужно выгрузить ПоступленияТиУ Услуги И Товары с определенного склада
36. o.kovalev 116 01.10.21 11:10 Сейчас в теме
Вам придется делать две выгрузки в два файла, - одну документы в видом операции "Услуги" другую для всех документов (для товаров) с отбором по складу.
37. Scroudge 4 24.01.22 16:07 Сейчас в теме
использовал для переноса доков между идентичными БП 3.0.93.
мне обработка помогла.
спасибо!
o.kovalev; +1 Ответить
38. Safron 6 19.04.22 15:42 Сейчас в теме
Добрый день. Версия 1.0.4. Загружал данные по первому варианту с подменой уникального идентификатора в файле (в случае предопределенных элементов, в данном случае бух счетов.. Проблема в том, что идентификатор элемента в файле он подменил, а в реквизитах этого элемента уникальные идентификаторы остались от старого элемента. В результате элемент не задвоился, но в реквизитах его записались <Объект не найден....>. В случае бух счетов записались битые ссылки в реквизите группа счета, т.е. родитель, в виды субконто тоже записались битые ссылки. Загружаемую базу пришлось исправлять. Как можно загрузить данные без проблем в базе-получателе?
39. o.kovalev 116 21.04.22 16:17 Сейчас в теме
(38) Попробуйте при выгрузке на элементы ссылочного типа, которые у вас устанавливаются как Обьект не найден установить флажок "Выгружать при необходимости" Пример: Выгружаете план счетов и ставите этот флажок на план видов характеристик "Виды субконто хозрасчетные".
40. karakymi4 11 22.07.22 08:16 Сейчас в теме
Так и не увидел возможность добавлять в отбор сразу список текстовых полей, например номеров.
41. o.kovalev 116 22.07.22 13:14 Сейчас в теме
(40) Только вот так как на снимке можно.
Прикрепленные файлы:
42. Mikolka 63 11.03.23 09:59 Сейчас в теме
Не работает выгрузка при групповом условии ИЛИ, печально
Прикрепленные файлы:
43. o.kovalev 116 12.03.23 21:13 Сейчас в теме
(42) даже не предполагал что такое кому то понадобится, посмотрю
44. o.kovalev 116 13.03.23 09:39 Сейчас в теме
(42) Доработал, теперь и с группой выгружается
45. Mobile888 28.03.23 19:35 Сейчас в теме
Здравствуйте.
С помощью вашей программы возможно выгрузить составы наборов у товаров с типом "набор"?. В простых товарах и с характеристиками есть составы наборов. УТ 11.5
46. o.kovalev 116 29.03.23 14:11 Сейчас в теме
(45)
у товаров с типом "набор"?


К сожалению нет УТ под рукой чтобы увидеть, проверить и сказать вам точно, поэтому не совсем понимаю вопрос, но если набор хранится в регистре сведений, то можно, но выгружать надо не элемент справочника а непосредственно этот регистр сведений,
47. Merkalov 9 09.08.23 03:00 Сейчас в теме
Поиск сломан. Если ввести строку поиска с ошибкой (т.е такие метаданные отсутствуют) то валится.
Прикрепленные файлы:
48. o.kovalev 116 09.08.23 13:45 Сейчас в теме
49. o.kovalev 116 17.08.23 21:54 Сейчас в теме
50. mart-artur 8 28.08.23 13:12 Сейчас в теме
Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.27.23)
При загрузке ошибка
Ошибка при вызове метода контекста (ПрочитатьXML)
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.МодульОбъекта(287)}:ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.Форма.Форма.Форма(573)}:РеквизитФормыВЗначение("Объект").ВыполнитьЗагрузку(ИмяВременногоФайла);
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.Форма.Форма.Форма(239)}:ЗагрузитьДанныеНаСервере(Параметр1.Адрес);

[ОшибкаВоВремяВыполненияВстроенногоЯзыка]
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.1/data/enterprise/current-config}CatalogObject.ВидыКонтактнойИнформации Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/enterprise/current-config}CatalogObject.ВидыКонтактнойИнформации
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: {http://v8.1c.ru/8.1/data/enterprise/current-config}ПроверятьПоФИАС Форма: Элемент Тип: {http://www.w3.org/2001/XMLSchema}anyType
51. o.kovalev 116 28.08.23 13:57 Сейчас в теме
(50)
3.1.27.23

обмен только идентичных конфигураций

скорее всего отличаются наименования реквизитов, или их тип
например реквизит в (3.1.27.51) называется УдалитьПроверятьПоФИАС
Сравните конфигурации
52. mart-artur 8 28.08.23 14:01 Сейчас в теме
53. 1cNBL 01.09.23 09:59 Сейчас в теме
Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.140.29)
Что только не делал, выдается ошибка:
Ошибка при вызове метода контекста (Записать)
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.МодульОбъекта(303)}:ЗаписанноеЗначение.Записать();
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.Форма.Форма.Форма(573)}:РеквизитФормыВЗначение("Объект").ВыполнитьЗагрузку(ИмяВременногоФайла);
{ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML_1_0_6.Форма.Форма.Форма(239)}:ЗагрузитьДанныеНаСервере(Параметр1.Адрес);

по причине:
Запись не верна!
54. o.kovalev 116 01.09.23 13:09 Сейчас в теме
(53)
(53)

{ВнешняяОбработка.ВыгрузкаЗа


Проверяю, какие именно объекты грузите ?
55. пользователь 01.09.23 13:41
Сообщение было скрыто модератором.
...
56. 1cNBL 01.09.23 14:34 Сейчас в теме
(54)
Выгружал документы с движениями.
Всегда спотыкается на справочнике ВидыКонтактнойИнформации.

Решил проблему отключением загрузки справочника ВидыКонтактнойИнформации, потом загрузкой, сначала документы без движений, потом отдельно каждый тип регистров.
И в конце очистил справочник ВидыКонтактнойИнформации, и снова его загрузил.
Была беда с планом счетов и его субконто. Субконто были битые, а субсчета выпрыгнули из своих групп, хотя визуально все норм. После загрузки их пришлось обрабатывать отдельно.
А в целом все ок. Спасибо.
59. o.kovalev 116 01.09.23 14:53 Сейчас в теме
(56)

Когда мне надо выделить организацию из базы в отдельную базу со всеми движениями (для аудиторов к примеру)
я обычно создаю новую пустую базу, включаю в ней возможность удалять предопределенные, (изменяю роли и в одном месте в коде программы) удаляю все предопределенные - по кнопке "удалить предопределенные" и загружаю все предопределенные элементы из исходной базы, так получается быстрее и нет дубляжа предопределенных, конечно после удаления предопределенных и до загрузки предопределенных перезаходить в новую базу нельзя.
57. 1cNBL 01.09.23 14:40 Сейчас в теме
Было бы не плохо в обработке сделать возможность выбора по кнопке только те данные для выгрузки, на которые скопирован отбор.
58. o.kovalev 116 01.09.23 14:44 Сейчас в теме
(57) Кнопка "Скопировать и отметить"
60. 1cNBL 01.09.23 14:55 Сейчас в теме
(58)
Точно, спасибо, был не внимателен, и сделал свою рядом с кнопками отметок ))
61. Sun_AIG 93 28.12.23 20:58 Сейчас в теме
При установке курсора на регистры расчета в дереве вываливается с ошибка. В модуле про регистры расчета нет ничего. Приходится дописывать.
62. o.kovalev 116 29.12.23 13:47 Сейчас в теме
(61)
Добавьте в строку 812 модуля формы

ИначеЕсли Элементобъектов.Значение = "РегистрыРасчета" Тогда
СтрокаТипа = "РегистрРасчетаМенеджер.";
КонецЕсли;

и исправьте строку 823 на


Если ОбъектВыбора.Значение="РегистрыСведений" или ОбъектВыбора.Значение="РегистрыНакопления"
или ОбъектВыбора.Значение="РегистрыБухгалтерии" или ОбъектВыбора.Значение="РегистрыРасчета" Тогда


Обновлена обработка версии 1.6 (Основная)
63. Sun_AIG 93 29.12.23 17:44 Сейчас в теме
(62)
Я в модуле везде, где встречается РегистрыНакопления, поправил по логике. Там три или четрые таких места.
64. vitalchikkk 02.02.24 16:22 Сейчас в теме
Добрый день. Необходимо перенести из базы БП ПРОФ в БП КОРП: 1) база проф будет предварительно свернута на нужную дату; 2) перенос будет операций по нужным счетам учета. У вас обработка сможет сделать выбор операций, например по полю "комментарий" и выгрузить из БП ПРОФ в БП КОРП?
65. o.kovalev 116 13.02.24 17:21 Сейчас в теме
(64) По полю Комментарий работает отбор документов, но выгрузится весь документ с проводками если выверите "вместе с документом выгружать движения"


ПРОФ в КОРП я переносил но конфигурации немного разные, планы видов характеристик и счета учета немного отличаются, добавлено изменение Подразделения

По содержанию проводки тоже работает отбор

Я бы сначала свернул базу, выгрузил в идентичную конфигурацию и затем уже переходил на КОРП.
там изменения есть но они не сильно критичны , может только счета перебросить
66. vitalchikkk 13.02.24 17:30 Сейчас в теме
Благодарю вас, за ответ!
67. dexon_pro 1 06.03.24 08:18 Сейчас в теме
Не выгружаются поля ХранилищеЗначений :(
68. o.kovalev 116 19.04.24 10:31 Сейчас в теме
(67) А на сколько правильно вообще хранить изображения напрямую в базе ? Перенести можно просто сбросив эти данные на диск, а обработка перенесет ссылку.

По опыту работы наличие изображений документов в базе очень сильно тормозит работу базы.

Подумаю над отдельным режимом переноса.
69. dexon_pro 1 22.04.24 06:32 Сейчас в теме
(68) Это далеко не всегда связано с изображениями.
Переносил цепочку ЭДО между базами.
Обработка с ИТС хранилища переносит.
70. o.kovalev 116 22.04.24 14:47 Сейчас в теме
(69) Уже выгружает, исправлена ошибка в версии 1.06
71. VDO1988 2 02.06.24 14:18 Сейчас в теме
При попытке загрузки данных, всегда выдает сообщение "Неверный формат файла выгрузки". Что я делаю не так?
72. VDO1988 2 02.06.24 14:39 Сейчас в теме
(71) Отвечу сам себе, не только конфигурации должны быть идентичны, но и Расширения.
73. uazik20071 20.06.24 10:42 Сейчас в теме
Добрый день, скачала обработку версия 1.06. У меня предприятие 8.3.23.2157. Через файл открыть - не видит обработку
74. uazik20071 20.06.24 10:45 Сейчас в теме
Извините, все хорошо. Сама ошиблась
75. uazik20071 21.06.24 13:41 Сейчас в теме
при загрузке выдает ошибку -неверный формат выгрузки
user1879275; +1 Ответить
76. uazik20071 21.06.24 14:11 Сейчас в теме
расширения идентичны
Оставьте свое сообщение