Обнуление сальдо по зарплате в ЗУП

22.02.12

Задачи пользователя - Закрытие периода

Обработка обнуления сальдо по заработной плате сотрудников на начало месяца

Скачать исходный код

Наименование Файл Версия Размер
ОбнулениеCальдо
.epf 9,58Kb
374
.epf 9,58Kb 374 Скачать

Обработка обнуляет сальдо по заработной плате сотрудников на начало месяца, корректируя регистры накопления ВзаиморасчетыСРаботникамиОрганизаций, ЗарплатаЗаМесяцОрганизаций, НДФЛКЗачету. Написана для конфигурации ЗУП платформы 8.2 релиз 2.5.45.3. Возможна доработка для других релизов.

Порядок работы:
1. Необходимо выбрать месяц, на начало которого необходимо обнулить сальдо
2. Выбрать организацию
3. В поле Корректировка, нажав на кнопку Выбрать (три точки), создать новый документ (нужно нажать на зеленый плюс) и выбрать его двойным щелчком.
(Важно) При повторном использовании обработки для корректировки того же периода нужно использовать документ, созданный ранее.


Бонус. Есть возможность автоматического пересчета НДФЛ во всех проведенных документах выбранного периода "Начисление заработной платы работникам организаций", нажав на кнопку меню "Действия", выбрав пункт "Пересчитать НДФЛ в документах начисление ЗП"

(Тоже важно) Перед любыми действия с обработкой рекомендуется сделать копию базы и сформировать отчетность для сравнения результата.

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141814    666    352    

233

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22816    19    1    

22

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Перенос данных 1C Зарплата Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57621    143    141    

120

Устранение начислений прошлых периодов из ведомостей: в банк, в кассу, на счета в ЗУП 3.1, КА, ЗиКГУ 3.1

Зарплата Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13347    64    26    

66

Ускоренное проведение документов (x4), устранение ошибок 60/62 счетов и зачет авансов (Бухгалтерия 3.0)

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    28773    86    149    

61

Помощник закрытия месяца

Закрытие периода Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

В современных конфигурациях УТ 11, КА 2, ERP 2 и их аналогах присутствует механизм закрытия периода. Но при ошибках учета закрыть период корректно становится практически невозможно! Давайте попробуем разобраться, как можно устранить ошибки и закрыть корректно месяц!

9000 руб.

20.03.2018    70926    269    58    

295

Перенос данных из Парус 7.хх в ЗГУ ред.3

Внешние источники данных Зарплата Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49051    97    163    

87
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. extralook 23 27.02.12 16:04 Сейчас в теме
Обработка обнуления сальдо по заработной плате сотрудников на начало месяца

Перейти к публикации

1. Модератор раздела 27.02.12 16:04 Сейчас в теме
Про бонус совсем непонятно :( что за автоматический пересчет НДФЛ?
2. extralook 23 28.02.12 08:30 Сейчас в теме
Автоматический пересчет данных на вкладке НДФЛ во всех проведенных документах "Начисление ЗП" за период, выбранный в обработке.
3. OleGazz 13 29.02.12 07:17 Сейчас в теме
спасибо большое, надо опробовать конечно же!
4. sevipa 29.02.12 22:45 Сейчас в теме
Поможет ли он беде расчетчика которая кажный месяц корректирует док ЗП к выплате по причине неверно перенесенных из зик 77 и не отрегулированных вводом остатков данных по части сотрудников?
18. extralook 23 02.03.12 08:14 Сейчас в теме
6. пользователь 05.03.12 23:05
Сообщение было скрыто модератором.
...
7. Надежда_ 09.03.12 12:10 Сейчас в теме
А для ЗБУ подойдёт эта обработка?
8. extralook 23 11.03.12 08:53 Сейчас в теме
(7) Надежда_, не могу ответить, но можно попробовать, предварительно сделав копию базы
9. svk2007 6 12.03.12 14:42 Сейчас в теме
Для ЗБУ эта обработка не походит. Жаль...
11. Oskol_st 13.03.12 23:18 Сейчас в теме
10. Oskol_st 13.03.12 23:16 Сейчас в теме
12. infostar81 14.03.12 16:56 Сейчас в теме
13. kuza_87 28 20.11.13 12:47 Сейчас в теме
Спасибо, дружище! Очень помог
14. ivnik 587 22.11.13 00:12 Сейчас в теме
Спасибо, замечательная вещь! Сработала прекрасно, только я не понял, где были сделаны записи корректировки?
15. Leanna 10.01.14 19:13 Сейчас в теме
Большое спасибо, очень полезная обработка
16. Anthon 230 05.02.14 19:07 Сейчас в теме
спасибо, сэкономили мне время на написание обработки для ЗиКБУ, а всего лишь надо поправить одну функцию.
так что можете модифицировать обработку, чтобы она автоматом определяла наличие измерений в регистрах (я добавил СтатьяФинансирования и КОСГУ), и она будет более универсальна. желательно добавить автоматическое создание документа, если он не выбран.


Функция ПолучитьОстатки(ИмяРегистра)
Если ИмяРегистра = "ВзаиморасчетыСРаботникамиОрганизаций" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СтатьяФинансирования,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.КОСГУ,
| СУММА(ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Период, ) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки
|ГДЕ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.КОСГУ,
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СтатьяФинансирования
|
|ИМЕЮЩИЕ
| СУММА(ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток) <> 0");

ИначеЕсли ИмяРегистра = "ЗарплатаЗаМесяцОрганизаций" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| ЗарплатаЗаМесяцОрганизацийОстатки.Физлицо,
| ЗарплатаЗаМесяцОрганизацийОстатки.СтатьяФинансирования,
| ЗарплатаЗаМесяцОрганизацийОстатки.КОСГУ,
| СУММА(ЗарплатаЗаМесяцОрганизацийОстатки.СуммаВзаиморасчетовОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.ЗарплатаЗаМесяцОрганизаций.Остатки(&Период, ) КАК ЗарплатаЗаМесяцОрганизацийОстатки
|ГДЕ
| ЗарплатаЗаМесяцОрганизацийОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| ЗарплатаЗаМесяцОрганизацийОстатки.Физлицо,
| ЗарплатаЗаМесяцОрганизацийОстатки.СтатьяФинансирования,
| ЗарплатаЗаМесяцОрганизацийОстатки.КОСГУ,
| ЗарплатаЗаМесяцОрганизацийОстатки.ПериодВзаиморасчетов
|
|ИМЕЮЩИЕ
| СУММА(ЗарплатаЗаМесяцОрганизацийОстатки.СуммаВзаиморасчетовОстаток) <> 0");

ИначеЕсли ИмяРегистра = "НДФЛКЗачету" Тогда
Запрос =
Новый Запрос("ВЫБРАТЬ
| НДФЛКЗачетуОстатки.ФизЛицо,
| НДФЛКЗачетуОстатки.СтатьяФинансирования,
| НДФЛКЗачетуОстатки.КОСГУ,
| НДФЛКЗачетуОстатки.СтавкаНалогообложенияРезидента,
| СУММА(НДФЛКЗачетуОстатки.СуммаНДФЛКЗачетуОстаток) КАК Сумма
|ИЗ
| РегистрНакопления.НДФЛКЗачету.Остатки(&Период, ) КАК НДФЛКЗачетуОстатки
|ГДЕ
| НДФЛКЗачетуОстатки.Организация = &Организация
|
|СГРУППИРОВАТЬ ПО
| НДФЛКЗачетуОстатки.ФизЛицо,
| НДФЛКЗачетуОстатки.СтатьяФинансирования,
| НДФЛКЗачетуОстатки.КОСГУ,
| НДФЛКЗачетуОстатки.СтавкаНалогообложенияРезидента
|ИМЕЮЩИЕ
| СУММА(НДФЛКЗачетуОстатки.СуммаНДФЛКЗачетуОстаток) <> 0");
Иначе
Возврат Неопределено;
КонецЕсли;

Запрос.УстановитьПараметр("Период", НачалоМесяца(Период));
Запрос.УстановитьПараметр("Организация", Организация);
Возврат Запрос.Выполнить().Выбрать();
КонецФункции


и бонус

Процедура ПриОткрытии()
Если Период = '00010101' Тогда
Период = РабочаяДата;
МесяцСтрока = РаботаСДиалогами.ДатаКакМесяцПредставление(Период);
Выборка = Справочники.Организации.Выбрать();
Пока Выборка.Следующий() Цикл
Если Организация.Пустая() Тогда
Организация = Выборка.Ссылка;
Иначе
Организация = "";
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
17. Margaritaya 4 02.12.14 08:56 Сейчас в теме
Очень полезная вещь.!!!!!
Оставьте свое сообщение