Загрузка товаров из внешних файлов в произвольный документ (УТ11, КА2, ERP; Розница 2)

13.01.23

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Речь пойдет о том, как типовой механизм "Загрузки из внешнего файла" прикрутить к, по сути, любому документу, где есть табличная часть Товары. Пример приведен на Перемещении товаров, и с каждым документом может быть своя специфика, но общий механизм совпадет. В приложенном готовом варианте расширения механизм подключен еще к двум документам - Списаниям и Оприходованиям.

Скачать файлы

Наименование Файл Версия Размер
Загрузка из внешнего файла (Перемещение,Списание, Оприходование) - УТ 11.5.10,ERP 2.5.10, KA 2.5.10
.cfe 86,31Kb
14
.cfe УТ 11.5.10,ERP 2.5.10, KA 2.5.10 86,31Kb 14 Скачать
Загрузка товаров из внешних файлов в произвольный документ (УТ11.5, КА2.5, ERP2.5):
.cfe 83,88Kb
30
.cfe УТ11.5, КА2.5, ERP2.5 83,88Kb 30 Скачать
Загрузка из внешнего файла (Оприходование) - ( Розница 2):
.cfe 24,57Kb
5
.cfe v 09 01 2022 24,57Kb 5 Скачать
Загрузка из внешнего файла (Перемещение,Списание, Оприходование) - УТ 11.4,ERP 2.4, KA 2.4
.cfe 59,86Kb
63
.cfe УТ 11.4,ERP 2.4, KA 2.4 59,86Kb 63 Скачать

На Инфостарте (да и в интернете) предлагают различные способы загрузки из внешних файлов. Это действительно часто помогает пользователям (если, конечно, файл имеет какую-то повторяющуюся структуру).

И - иногда люди хотят видеть именно загрузку из Excel-файла, а иногда .. привыкают к тому механизму, который уже реализовала 1с (но, почему-то, далеко не во всех документах).

Так случилось и в этот раз - пользователи обратились с пожеланием, чтобы в "Перемещении товаров" был такой же механизм, как и в поступлении ("Заполнить - Загрузить из внешнего файла").

 

Итак.

Механизм задействует две ключевые вещи:

1. Запуск обработки с формы документа - "Обработка.ЗагрузкаДанныхИзВнешнихФайлов";

2. Заполнение документа по данным обработки через событие формы "Обработка выбора".

**Обновлено 25.04.2020

Протестировано на 1С:Комплексная автоматизация 2 (2.4.11.65)

Код подходит для документов Оприходование Излишков Товаров и Списание Недостач Товаров, кроме вот этой строки

//специфика перемещения ++
   СтрокаТЧТовары.КодСтроки=0;//код строки заказа
//специфика перемещения --

**Обновлено 23.12.2020

1. Протестировано на УТ 11.4.13

2. Убрано несколько зависимостей (не должно проверяться значение основного языка конфигурации, удалено обращение к картинке, которую удалили из актуальных релизов конфигурации)

**Обновлено 09.01.2022

1. Для Розницы тоже подходит (но листинг несколько отличается). Добавлено отдельное расширение под Розницу.
2. Протестировано на Розница 8, редакция 2.3 (2.3.10.36)

**Обновлено 28 .07.2022

Протестировано на 1С:Комплексная автоматизация 2 (2.5.8.232)

**Обновлено 24.08.2022

Внесена небольшая правка в Перемещение (Версии для КА,УТ,ERP)

**Обновлено 13.01.2023

Внесена небольшая правка во "Внутреннее потребление" (Версии для КА 2.5.10,УТ,ERP) [изменено имя метаданных в поставке]

Протестировано на  1С:Комплексная автоматизация 2 (2.5.10.52) 

Реализация

1. Забираем в расширение форму документа "Перемещение товаров".

2. Создаем новую команду - "ЗагрузитьИзВнешнегоФайла", и создаем такой обработчик

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайла(Команда)
	
    ОтборТовар = Новый Массив(1);
    ОтборТовар[0] = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Товар");
    
    ПараметрыФормы = Новый Структура();
    ПараметрыФормы.Вставить("ЗагружатьКоличество", Истина);
    ПараметрыФормы.Вставить("ЗагружатьЦены", Ложь);
    ПараметрыФормы.Вставить("ЗагружатьСуммы", Ложь);
    ПараметрыФормы.Вставить("ЦенаВключаетНДС", ложь);
    //ПараметрыФормы.Вставить("Партнер", Объект.Партнер);
    //ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);
    ПараметрыФормы.Вставить("ЗагружатьГТД", Ложь);
    
    ПараметрыФормы.Вставить("ЗагружатьЗапасы",           Ложь);
    ПараметрыФормы.Вставить("ЗагружатьСкидки",           Ложь);
    ПараметрыФормы.Вставить("ЗагружатьУпаковочныеЛисты", Ложь);
    
    ПараметрыФормы.Вставить("ПересчитыватьСуммы", Истина);
    ПараметрыФормы.Вставить("ЦенаВключаетНДС",    Истина);
    ПараметрыФормы.Вставить("Организация",        Неопределено);
    ПараметрыФормы.Вставить("НалогообложениеНДС",
        ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС"));
    
    ПараметрыФормы.Вставить("ОтборПоТипуНоменклатуры", Новый ФиксированныйМассив(ОтборТовар));
    ПараметрыФормы.Вставить("ИмяТЧ", "Товары");
    ПараметрыФормы.Вставить("ЗагружатьСкидки", Ложь);
    ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Загрузка товаров из внешних файлов'"));
    ПараметрыФормы.Вставить("ПараметрыОтбора", Новый Структура);
    ПараметрыФормы.Вставить("ДатаЗаполнения",     '00010101');
    
    
    Оповещение = Новый ОписаниеОповещения("ЗагрузитьИзВнешнегоФайлаЗавершение", ЭтотОбъект, "Товары");
    РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры(ПараметрыФормы, Оповещение);

	
КонецПроцедуры

3. Создаем оповещение, на которое мы сослались в предпоследней строке

4. Из него вызовем функцию "ПолучитьЗагруженныеТоварыИзХранилища", которую тут же и опишем. Сделано по аналогии с функцией в "Приобретении товаров и услуг", но выброшена часть кода.

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайлаЗавершение(АдресЗагруженныхДанных, ДополнительныеПараметры) Экспорт

    Если ЗначениеЗаполнено(АдресЗагруженныхДанных) Тогда
        ПолучитьЗагруженныеТоварыИзХранилища(АдресЗагруженныхДанных, ДополнительныеПараметры);
    КонецЕсли;

КонецПроцедуры


&НаСервере
Процедура ПолучитьЗагруженныеТоварыИзХранилища(АдресТоваровВХранилище, ИмяТЧ)

	ТоварыИзХранилища = ПолучитьИзВременногоХранилища(АдресТоваровВХранилище);
    
    КэшированныеЗначения = ОбработкаТабличнойЧастиКлиентСервер.ПолучитьСтруктуруКэшируемыеЗначения();
    
    СтруктураДействий = Новый Структура;
    //СтруктураДействий.Вставить("ЗаполнитьНоменклатуруПоставщикаПоНоменклатуре", Объект.Партнер);
        
    Для Каждого СтрокаТоваров Из ТоварыИзХранилища Цикл
        СтрокаТЧТовары = Объект[ИмяТЧ].Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТЧТовары, СтрокаТоваров);
        Если ИмяТЧ = "Товары" Тогда
            ОбработкаТабличнойЧастиСервер.ОбработатьСтрокуТЧ(СтрокаТЧТовары, СтруктураДействий, КэшированныеЗначения);
        КонецЕсли;
                //специфика перемещения ++
                СтрокаТЧТовары.КодСтроки=0;//код строки заказа
                //специфика перемещения --
    КонецЦикла;


КонецПроцедуры

Если есть желание поскорее окунуться в работу (и доработку механизма для своих задач), во вложении - готовое расширение.

обработка загрузка excel таблица табличный внешний файл

См. также

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Перенос данных осуществляется из 1С:ERP 2 / 1С:КА 2 / 1С:УТ 11 в 1С:БП 3.0. Правила обмена оперативно обновляются при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

38500 34650 руб.

15.04.2019    67709    176    136    

107

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила тестировались на конфигурациях УПП 1.3 (1.3.220.x) и БП 3.0 (3.0.147.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    19537    129    38    

85

SALE! 10%

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    133497    712    291    

383

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет не только перенести все документы, справочную информацию и начальные остатки из ERP 2 или КА 2 в ЗУП 3, но и организовать регулярный перенос данных между программами 1С:ERP 2 / КА 2 и 1С:ЗУП 3. Вы можете выбрать период отбора данных и установить фильтр по организациям, чтобы выгружать только необходимую информацию. Более того, перенос оперативно обновляется при выходе новых релизов программы 1С, так что вы всегда будете иметь самую актуальную версию обработки.

48278 43450 руб.

03.12.2020    33641    79    57    

76

SALE! 10%

Перенос данных из УПП 1.3 / КА 1.1 в БП 3.0

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Перенос данных из УПП 1.3 в БП 3.0 (или из КА 1.1 в БП 3.0). Переносятся документы, начальные остатки и вся справочная информация. Есть фильтр по организации и множество других параметров выгрузки. Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов. Перенос данных возможен в 1С: Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую. Переход с "1С: Управление производственным предприятием 1.3" / "1С:Комплексная автоматизация 1.1" на "1С:Бухгалтерия предприятия 3.0" с помощью наших правил конвертации будет максимально комфортным!

43889 39500 руб.

25.02.2015    167966    286    240    

370

SALE! 10%

Перенос данных из УПП 1.3 в ЗУП 3.1 или из КА 1.1 в ЗУП 3.1

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Перенос кадровых и расчетных данных и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" или "1С:Управление производственным предприятием, ред.1.3" в "1С:Зарплата и управление персоналом", ред. 3.1. Правила позволяют перенести кадровые данные сотрудников за весь период ведения учета в КА 1.1 / УПП 1.3 и расчетные данные за выбранный период (минимально необходимый - 2 года). Позволяют осуществить переход на ведение учета зарплаты и кадров в программе 1С:Зарплата и управление персоналом, ред. 3.1.

50722 45650 руб.

29.10.2018    53932    52    97    

55

Загрузка номенклатуры из Excel в УТ11, КА 2, ERP 2, Розница 2. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка из файлов xls, xlsx, ods, csv, mxl в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    208137    607    524    

434

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. За основу были взяты стандартные правила переноса остатков и справочной информации. Правила тестировались на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.15.x).

28000 руб.

23.07.2020    45234    192    63    

149
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. klaus38 01.06.20 09:17 Сейчас в теме
Вот спасибо. Я изначально такие сложные конструкции сваял, а вот как надо было.
2. ooliyah 03.06.20 01:34 Сейчас в теме
Здравствуйте! В УТ 11.4.6.230 и Рознице 2.2. при подключении расширения выдает ошибку (на скриншоте). Подскажите пожалуйста, в чем может быть проблема.
Прикрепленные файлы:
3. erutan 101 03.06.20 15:36 Сейчас в теме
(2)Здравствуйте!
Попробуйте, пожалуйста, снять вот эту галку (см скриншот)

Если так и не поможет, напишите, пожалуйста, личное сообщение

ps можно еще вот этот объект удалить
Прикрепленные файлы:
4. user1281106 30.11.20 12:17 Сейчас в теме
Здравствуйте. Скачал расширение, но не могу установить. выскакивает ошибка
Прикрепленные файлы:
5. erutan 101 30.11.20 17:59 Сейчас в теме
(4) Здравствуйте! Попробуйте, пожалуйста, снять проверку с этого свойства (скриншот выше).
Умеете с конфигуратором работать?

Если вдруг совсем нет, могу попробовать подключиться по энидеск, в личку только напишите, и время надо будет согласовать.
6. Горыныч_Злой 21.12.20 09:17 Сейчас в теме
Добрый день, по наследству от предыдущего коллеги досталась и ваша работа. :)

Сейчас после обновления до 11.4.13 не стыковка не только по языку, но и потерялась картинка (что-то с «…Вид цены»)
7. erutan 101 22.12.20 10:06 Сейчас в теме
(6) здравствуйте!
Жду от Вас уточнения в личных сообщениях
8. user626746_sportleader_z 18.01.21 14:39 Сейчас в теме
Добрый день! Возможно ли использовать эту доработку в 1С:Предприятие 8.3 (8.3.16.1063). Конфигурация Розница 8. Магазин одежды и обуви, редакция 2.3 (2.3.6.17) ?
9. erutan 101 18.01.21 20:01 Сейчас в теме
(8) на 100% не скажу, но\

>>Так случилось и в этот раз - пользователи обратились с пожеланием, чтобы в "Перемещении товаров" был такой же механизм, как и в >>поступлении ("Заполнить - Загрузить из внешнего файла").

если в Поступлении есть такая команда ("Заполнить - Загрузить из внешнего файла").

то должно сработать
10. simuljakr 201 10.04.21 18:15 Сейчас в теме
Отлично! Спасибо! Зделал по-аналогии загрузку комплектующих в справочник "варианты комплектаций" - все работает!
11. 12345sponche 28.12.21 12:27 Сейчас в теме
Спасибо за статью, по аналогии добавил возможность загрузки из файла в документ "Перемещение" 1с УТ.
Только я еще в командную панель добавил кнопку "Загрузить из файла" и на эту кнопку привязал команду "ЗагрузитьИзВнешнегоФайла"
12. 12345sponche 28.12.21 12:47 Сейчас в теме
13. sponchebob 20 28.12.21 12:51 Сейчас в теме
Спасибо! Получается в любой документ, в котором есть табличная часть товаров, можно интегрировать данный функционал?
14. erutan 101 28.12.21 16:41 Сейчас в теме
(13) Здравствуйте! По сути, да (но может немного меняться код - если появится какой-то обязательный реквизит, и тд)
sponchebob; +1 Ответить
15. sponchebob 20 28.12.21 19:48 Сейчас в теме
(14) Статья реально полезная, надо 1с интегрировать возможность загрузки из файла в каждый документ!
16. user1237931 14.04.22 17:53 Сейчас в теме
В УТ 11.5 убрали из конфигурации обработку ЗагрузкаДанныхИзВнешнихФайлов
Теперь ее заменяет обработка ЗагрузкаТоваровИзВнешнихФайлов которая должна вызываться из процедуры общего модуля РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры и описанный выше метод уже не работает...
17. erutan 101 18.04.22 18:02 Сейчас в теме
(16) спасибо!
Пока не обновлялись на эту ветку. Постараюсь на майских праздниках посмотреть , что можно сделать ..
19. euch 14.06.22 17:39 Сейчас в теме
(16) У меня заработало после правок и копипасты кода из других документов:

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайла(Команда)
	
	ОтборТовар = Новый Массив(1);
	ОтборТовар[0] = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Товар");
	
	ПараметрыФормы = Новый Структура();
	ПараметрыФормы.Вставить("ЗагружатьКоличество", Истина);
	ПараметрыФормы.Вставить("ЗагружатьЦены", Ложь);
	ПараметрыФормы.Вставить("ЗагружатьСуммы", Ложь);
	ПараметрыФормы.Вставить("ЦенаВключаетНДС", ложь);
	//ПараметрыФормы.Вставить("НалогообложениеНДС", Объект.НалогообложениеНДС);
	//ПараметрыФормы.Вставить("Партнер", Объект.Партнер);
	//ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);
	ПараметрыФормы.Вставить("ЗагружатьГТД", Ложь);
	
	ПараметрыФормы.Вставить("ЗагружатьЗапасы",           Ложь);
	ПараметрыФормы.Вставить("ЗагружатьСкидки",           Ложь);
	ПараметрыФормы.Вставить("ЗагружатьУпаковочныеЛисты", Ложь);
	
	ПараметрыФормы.Вставить("ПересчитыватьСуммы", Истина);
	ПараметрыФормы.Вставить("ЦенаВключаетНДС",    Истина);
	ПараметрыФормы.Вставить("Организация",        Неопределено);
	ПараметрыФормы.Вставить("НалогообложениеНДС",
		ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС"));
	
	ПараметрыФормы.Вставить("ОтборПоТипуНоменклатуры", Новый ФиксированныйМассив(ОтборТовар));
	ПараметрыФормы.Вставить("ИмяТЧ", "Товары");
	ПараметрыФормы.Вставить("ЗагружатьСкидки", Ложь);
	ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Загрузка товаров из внешних файлов'"));
    ПараметрыФормы.Вставить("ПараметрыОтбора", Новый Структура);
    ПараметрыФормы.Вставить("ДатаЗаполнения",     '00010101');
	
	
	Оповещение = Новый ОписаниеОповещения("ЗагрузитьИзВнешнегоФайлаЗавершение", ЭтотОбъект, "Товары");
    РаботаСТабличнымиЧастямиКлиент.ПоказатьФормуЗагрузкиНоменклатуры(ПараметрыФормы, Оповещение);
	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьИзВнешнегоФайлаЗавершение(АдресЗагруженныхДанных, ДополнительныеПараметры) Экспорт

	Если ЗначениеЗаполнено(АдресЗагруженныхДанных) Тогда
		ПолучитьЗагруженныеТоварыИзХранилища(АдресЗагруженныхДанных, ДополнительныеПараметры);
	КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура Расш_Загр_ОбработкаВыбораПеред(ВыбранноеЗначение, ИсточникВыбора)
	Если ИсточникВыбора.ИмяФормы = "Обработка.ЗагрузкаТоваровИзВнешнихФайлов.Форма.Форма" Тогда
		
		ПолучитьЗагруженныеТоварыИзХранилища(ВыбранноеЗначение, ИсточникВыбора);
		
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПолучитьЗагруженныеТоварыИзХранилища(АдресТоваровВХранилище, ИмяТЧ)
//Процедура ПолучитьЗагруженныеТоварыИзХранилища(РезультатВыбора, ИмяТЧ)
	
	//ТоварыИзХранилища = ПолучитьИзВременногоХранилища(РезультатВыбора.АдресТоваровВХранилище);
	ТоварыИзХранилища = ПолучитьИзВременногоХранилища(АдресТоваровВХранилище);
	//ИмяТЧ = РезультатВыбора.ИмяТЧ;
	
	КэшированныеЗначения = ОбработкаТабличнойЧастиКлиентСервер.ПолучитьСтруктуруКэшируемыеЗначения();
	
	СтруктураДействий = Новый Структура;
	//СтруктураДействий.Вставить("ЗаполнитьНоменклатуруПоставщикаПоНоменклатуре", Объект.Партнер);
	
	Если ИмяТЧ = "Товары" Тогда
		//НаправленияДеятельностиКлиентСервер.СтруктураДействийВставитьПриДобавленииСтроки(ЭтаФорма, СтруктураДействий);
	КонецЕсли;
	
	Для Каждого СтрокаТоваров Из ТоварыИзХранилища Цикл
		СтрокаТЧТовары = Объект[ИмяТЧ].Добавить();
		ЗаполнитьЗначенияСвойств(СтрокаТЧТовары, СтрокаТоваров);
		Если ИмяТЧ = "Товары" Тогда
			ОбработкаТабличнойЧастиСервер.ОбработатьСтрокуТЧ(СтрокаТЧТовары, СтруктураДействий, КэшированныеЗначения);
		КонецЕсли;
                //специфика перемещения ++
                СтрокаТЧТовары.КодСтроки=0;//код строки заказа
                //специфика перемещения --
	КонецЦикла;
	
	Если ИмяТЧ = "Товары" Тогда
		//ЗаполнитьСтатусыУказанияСерийСервер();
	КонецЕсли;

КонецПроцедуры
Показать
user1237931; erutan; +2 Ответить
18. Adilgeriy 25 28.04.22 01:44 Сейчас в теме
может подскажете почему не отображается колонка номенклатура партнера в типовой загрузке
23. erutan 101 28.07.22 11:38 Сейчас в теме
(18) возможно, надо поэкспериментировать со св-м "ПараметрыФормы.Вставить("СопоставлятьПоНоменклатуреПоставщиков", Истина);"
В данном примере оно вообще закомментировано
20. user1811910 08.07.22 20:12 Сейчас в теме
можно ли каким-то образом не заполнять данные для поиска номенклатуры (штрихкод, код, Артикул, Номенклатура), а поиск выполнялся только по характеристики?
21. erutan 101 11.07.22 10:09 Сейчас в теме
(20) боюсь, что не подскажу. Все никак не доберусь до функционала сам, чтобы проверить.
22. erutan 101 28.07.22 11:37 Сейчас в теме
(20)
характеристики

Вообще, с точки зрения 1с, Характеристика - это всегда нечто, подчиненное номенклатуре. Так что без допила вряд ли получится.
Одни и те же хар-ки могут быть у разных номенклатур (например, "размер 42" у разной обуви)
24. Горыныч_Злой 08.08.22 13:14 Сейчас в теме
(22)
Вообще, с точки зрения 1с, Характеристика - это всегда нечто, подчиненное номенклатуре. Так что без допила вряд ли получится.
Одни и те же хар-ки могут быть у разных номенклатур (например, "размер 42" у разной обуви)


А если взять что Характеристика уникальна? раельно заделать загрузку по Характеристикам (Характеристика + колл.) ?
25. Горыныч_Злой 24.08.22 15:41 Сейчас в теме
Доработки ожидаются ?
В 11.4 работало, в 11.5.7.402 в документе перемещение кнопа появилась но не работает ;(

По характеристикам да :( без переделки в самой конфе не обойтись :(
26. erutan 101 24.08.22 20:42 Сейчас в теме
(25) Здравствуйте. Проверю сегодня.
27. erutan 101 24.08.22 20:48 Сейчас в теме
(25) Стоп. А вы версию под ERP 2.5 / УТ 11.5 пробовали? Я отдельно выложил
28. Горыныч_Злой 24.08.22 23:22 Сейчас в теме
29. erutan 101 25.08.22 07:30 Сейчас в теме
(28)проверьте, пожалуйста, личные сообщения. Сейчас должно все работать (ну и в шапке обновил версию)
30. Горыныч_Злой 25.08.22 09:31 Сейчас в теме
(29) Да, всё, теперь красота.. Спасибо
Задумка, работа нужная,..
почему 1С_ки не думают о тех кто работает на их продукте... мля...
31. suhoi 25 14.12.22 20:28 Сейчас в теме
ERP 2.5.9.143
При загрузке расширения выдает ошибку ((
Прикрепленные файлы:
32. erutan 101 15.12.22 12:46 Сейчас в теме
(31) видимо, переименован документ.
Мы пока на ветке 2.5.8 (версия длительной поддержки)

Можете обратиться в личных сообщениях, договоримся - подключусь и посмотрю конкретно в вашей системе.
33. erutan 101 17.12.22 12:19 Сейчас в теме
(31) документ «внутреннееПотреблениеТоваров» переименован во «внутреннееПотребление».

При загрузки расширения (в данный момент) необходимо исправить соответствие (в конфигураторе).

Буду выкладывать доработанное расширение, но несколько позже
34. user1332620 27.12.22 07:28 Сейчас в теме
Здравствуйте. Работает ли в установке цен на УТ 11.5?
35. erutan 101 27.12.22 10:24 Сейчас в теме
(34) Здравствуйте.
"Установка цен" сильно другая внутри, "как есть" не подойдет.
Требуется специальная доработка конкретно под этот тип документа.
36. ooogammapro 31.05.23 13:33 Сейчас в теме
Здравствуйте! Будет ли работать расширение на последней версии КА 2.5.12?
В документах: "Заказ на перемещение" и "Оприходование товаров"? Спасибо!
37. ooogammapro 02.06.23 00:11 Сейчас в теме
(36) Все прекрасно работает на КА 2.5.11.96.
Устанавливал расширение: "Загрузка из внешнего файла (Перемещение,Списание, Оприходование) - УТ 11.5.10,ERP 2.5.10, KA 2.5.10"
Спасибо!
Вот только в заказе на перемещение нет кнопки. Можете добавить?
38. erutan 101 02.06.23 08:11 Сейчас в теме
(37)здравствуйте!
Прошу прощения, что сразу не ответил - к сожалению, пока много задач.(но я и не знал, у нас релиз постарше вроде пока)


На второй вопрос - думаю, можно, но пока не успеваю.

Если у вас есть навыки разработки в 1с - можете прямо у себя добавить, в этом и суть статьи)

В общем, если надо-надо, но сами не сможете - напишите под этим сообщением, через неделю - полторы постараюсь сделать.
39. user1372345 11.07.23 14:46 Сейчас в теме
Доброго дня!
отличный вариант загрузки !!!
испробовал на версии 11.5.12.64 работает на УРА!!!
прошу прощения за наглость ))
есть вариант загрузки похожим методом, но только в простой регистр сведений ( созданный лично нами )

Регистр- TRE_НастройкаПоддержанияЗапасов
Измерения - номенкл и склад
ресурс- остаток
40. erutan 101 11.07.23 17:09 Сейчас в теме
(39) добрый день. Потребуется совершенно иной механизм (технически). Хотя визуально (то есть для использования) его можно сделать почти аналогичным.
К сожалению, пока нет времени таким позаниматься(
41. user978501 05.12.23 09:55 Сейчас в теме
Встроенный механизм 1С неудобен, колонки ненужные ещё можно удалить, но переставить их невозможно. Для разных поставщиков свой шаблон не создать. Все такие решения требуют доработки.
42. citytop 25.12.23 15:13 Сейчас в теме
Добрый день. При попытке установить в 1С:Комплексная автоматизация 2 (2.5.14.74)
ошибка (см. скрин)
Прикрепленные файлы:
43. erutan 101 25.12.23 16:12 Сейчас в теме
(42) Скорее всего, требуется поменять документ на "Внутреннее потребление".
Это возможно сделать при добавлении расширения в конфигураторе
44. citytop 25.12.23 16:38 Сейчас в теме
(43)Расширение добавил, но возможности заполнить заказ на перемещение не появилось (
Можно как-то добавить?
46. erutan 101 25.12.23 16:41 Сейчас в теме
(44) можете попробовать доработать (суть статьи - описание процесса, чтобы прикрутить к каждому/почти каждому док-ту)
45. erutan 101 25.12.23 16:39 Сейчас в теме
(43) ... я попробую обновить расширение, но это будет несколько позже. Сейчас есть некоторые вопросы с переходом на новые версии ERP/KA
Оставьте свое сообщение