Рассылка SMS через GSM-шлюзы

25.04.12

Интеграция - WEB-интеграция

Программа предназначена для организации массовой рассылки SMS произвольному списку получателей.

Представляет собой внешнюю обработку для конфигураций «1С: Розница» в редакции 2 и «1C: Управление торговлей» в редакции 11. Платформа — «1С Предприятие» версии 8.2. Поддерживается толстый, тонкий и веб-клиенты.

Рассылка осуществляется через GSM-шлюзы gatesms.ru и smsc.ru.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Рассылка SMS
.epf 27,81Kb
115
115
1 SM
Скачать Купить за 1 850 руб.

Управление обработкой распределено по трём вкладкам. На вкладке «Сообщение» вводится текст SMS, на вкладке «Получатели» формируется список получателей этого сообщения. Вкладка «Настройка» используется для выбора шлюза отправки сообщений и настройки дополнительных параметров рассылки.
 

Настройка обработки


Основные параметры обработки находятся на вкладке «Настройка».

  • Шлюз. GSM-шлюз, через который будет осуществляться рассылка.
  • Логин. Имя пользователя GSM-шлюза. Если у вас его нет, зарегистрируйтесь на сайте выбранного шлюза.
  • Пароль. Пароль пользователя GSM-шлюза.

После заполнения свойств провайдера вы можете воспользоваться командой «Проверить баланс», которая выводит текущее состояние счета указанной учетной записи.

Помимо перечисленных настроек, на этой вкладке содержатся два дополнительных поля:

  • Отправитель. Определяет имя автора SMS, которое отображается на экране мобильного телефона получателя. Следует понимать, что значение этой настройки, скорее всего, потребует первоначального одобрения администрацией шлюза на сайте сервиса.
  • Отправлять срочные сообщения (flash SMS) вместо обычных? Позволяет вместо обычных SMS посылать так называемые «Flash SMS» — сообщения, которые сразу появляются на экране телефона и, в большинстве случаев, не сохраняются в памяти устройства.

Все данные вкладки «Настройка» автоматически сохраняются и восстанавливаются при открытии обработки. Вместе с тем, вы можете пользоваться стандартным функционалом сохранения и восстановления значений настроек, который доступен в меню «Все действия» формы.


Список получателей

На вкладке «Получатели» заполняется список адресатов, которым будет направлены сообщения. Ими могут выступать контрагенты и физические лица, занесенные в информационную базу, либо просто произвольно сформированный список телефонов.

Список может быть заполнен как вручную, так и с помощью форм подбора контрагентов и физических лиц, нажав на выпадающий список «Заполнить» и выбрав соответствующий пункт. Формы работают в режиме множественного выбора и не закрываются автоматически при выборе, что позволяет быстро формировать списки получателей даже по большой базе получателей.

Кроме форм подбора, в выпадающем списке «Заполнить» доступны команды «Выгрузить в файл» и «Загрузить из файла», которые соответственно позволяют сохранять сформированный список получателей в виде текстового файла с разделителями и загружать список получателей из сформированного файла.

При заполнении списка вручную заполнять колонку «Получатель» необязательно: она носит исключительно информативный характер и никак не влияет на процесс формирования сообщений.

Отправка сообщения


После ввода списка получателей следует перейти на вкладку «Сообщение», ввести его текст и выполнить команду «Отправить сообщение».

Состояние отправки выводится стандартными сообщениями. При возникновении какой-либо ошибки (например, недостатке средств на счету для отправки очередного сообщения) процесс остановится и программа сообщит о возникшей проблеме.

Программный интерфейс


Все основные механизмы, обеспечивающие взаимодействие обработки с GSM-шлюзами, вынесены в модуль объекта обработки и могут вызываться программистом извне для снижения затрат времени на самостоятельную разработку подобного решения.

Точки входа для отправки сообщений:

  • ОтправитьРассылкуЧерезGateSMS( Рассылка )
  • ОтправитьРассылкуЧерезSMSC( Рассылка )

В качестве параметра в обоих случаях выступает структура со следующими элементами:

  • ЛогинШлюза (строка; имя пользователя GSM-шлюза)
  • ПарольШлюза (строка; пароль пользователя GSM-шлюза)
  • ИмяОтправителя (строка; имя автора SMS)
  • ТелефонПолучателя (строка; один или несколько телефонов через запятую)
  • ТекстСообщения (строка; содержимое SMS)
  • Срочное (булево; определяет необходимость посылать Flash-SMS вместо обычных SMS)
  • ЗапросСтоимости (булево; определяет, нужно ли запросить стоимость рассылки вместо собственно рассылки)

В качестве результата в обеих случаях возвращается структура. Обязательные элементы:

  • Успешно (булево; индикатор успешного завершения операции)
  • Сообщение (строка; текст ошибки, если она возникла)

Если операция успешна, структура ответа дополняется. В случаяе запроса стоимости появляются элементы:

  • КоличествоСообщений (строка; количество SMS, которые будут посланы в ходе этой рассылки)
  • СтоимостьРассылки (строка; стоимость рассылки в валюте сервиса)

Если запроса стоимости не было (то есть, была выполнена обычная рассылка) к структуре ответа добавляется параметр БалансШлюза (строка), который содержит баланс GSM-шлюза на момент завершения рассылки.

Пример рассылки:

    Рассылка = Новый Структура;
    
    Рассылка.Вставить( "ЛогинШлюза"         , "МойЛогин" );
    Рассылка.Вставить( "ПарольШлюза"        , "МойПароль" );
    Рассылка.Вставить( "ИмяОтправителя"     , "МойПсевдоним" );
    Рассылка.Вставить( "ТелефонПолучателя"  , "79133100000" );
    Рассылка.Вставить( "ТекстСообщения"     , "Привет, мир!" );
    Рассылка.Вставить( "Срочное"            , Ложь );
    Рассылка.Вставить( "ЗапросСтоимости"    , Ложь );

    Результат = Обработки.РассылкаSMS.Создать().ОтправитьРассылкуЧерезSMSC( Запрос );
    
    Если Результат.Успешно Тогда
        Сообщить( "Баланс: " + Результат.БалансШлюза );
    Иначе
        Сообщить( Результат.Сообщение );
    КонецЕсли;

Пример оценки стоимости:

    Рассылка = Новый Структура;
    
    Рассылка.Вставить( "ЛогинШлюза"         , "МойЛогин" );
    Рассылка.Вставить( "ПарольШлюза"        , "МойПароль" );
    Рассылка.Вставить( "ИмяОтправителя"     , "МойПсевдоним" );
    Рассылка.Вставить( "ТелефонПолучателя"  , "79133100000" );
    Рассылка.Вставить( "ТекстСообщения"     , "Привет, мир!" );
    Рассылка.Вставить( "Срочное"            , Ложь );
    Рассылка.Вставить( "ЗапросСтоимости"    , Истина);

    Результат = Обработки.РассылкаSMS.Создать().ОтправитьРассылкуЧерезSMSC( Запрос );
    
    Если Результат.Успешно Тогда
        Сообщить( "Количество сообщений: " + Результат.КоличествоСообщений );
        Сообщить( "Стоимость отправки: " + Результат.СтоимостьРассылки );
    Иначе
        Сообщить( Результат.Сообщение );<
    КонецЕсли;

Точки входа для определения баланса на GSM-шлюзах:

  • ОпределитьБалансНаGateSMS( Запрос )
  • ОпределитьБалансНаSMSC( Запрос )

В качестве параметра в обеих случаях выступает структура со следующими элементами:

  • ЛогинШлюза (строка; имя пользователя GSM-шлюза)
  • ПарольШлюза (строка; пароль пользователя GSM-шлюза)

В качестве результата в обеих случаях возвращается структура. Обязательные элементы:

  • Успешно (булево; индикатор успешного завершения операции)
  • Сообщение (строка; текст ошибки, если она возникла)

Если операция успешна, к структуре добавляется элемент БалансШлюза (строка), который содержит текущий баланс GSM-шлюза.

Пример определения баланса:

    Рассылка = Новый Структура;
    
    Рассылка.Вставить( "ЛогинШлюза"         , "МойЛогин" );
    Рассылка.Вставить( "ПарольШлюза"        , "МойПароль" );

    Результат = Обработки.РассылкаSMS.Создать().ОпределитьБалансНаGateSMS( Запрос );
    
    Если Результат.Успешно Тогда
        Сообщить( "Баланс: " + Результат.БалансШлюза );
    Иначе
        Сообщить( Результат.Сообщение );
    КонецЕсли;

См. также

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс 24. Разработка имеет двухстороннюю синхронизацию 1С и Bitrix24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18977    10    16    

17

Управление взаимоотношениями с клиентами (CRM) WEB-интеграция Анализ продаж Системный администратор Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Подсистема интеграции Amo CRM с 1С: технические требования, порядок работы, возможности, доработки и обновления. Бесплатный период техподдержки - 1 месяц.

60000 руб.

07.05.2019    31839    62    40    

23

Сайты и интернет-магазины WEB-интеграция Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16714    15    19    

15

SALE! 50%

Управление взаимоотношениями с клиентами (CRM) Мессенджеры и боты SMS рассылки Email рассылки Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Управленческий учет Платные (руб)

Расширение 1С с полным набором инструментов для качественных транзакционных, триггерных и маркетинговых рассылок Email, SMS, WhatsApp, Telegram. Даже простые уведомления об оплате счетов способны существенно упростить сбор дебиторской задолженности. Применение всех возможностей прямого маркетинга выводит коммуникацию с клиентами, уровень сервиса и лояльность на новый уровень.

600 300 руб.

07.04.2014    84969    47    193    

133

WEB-интеграция Программист Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бытовые услуги, сервис Платные (руб)

Внешняя обработка разрабатывалась для загрузки документов из Ветменеджер в 1С: Бухгалтерия 3.0

12000 руб.

02.02.2021    16987    45    49    

26
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. veer1234 3 13.06.15 18:12 Сейчас в теме
Здравствуйте. Сможете добавить в обработку шлюз - epochtasms ?
2. bytecoded 26 14.06.15 09:51 Сейчас в теме
(1) veer1234, к сожалению, сейчас нет на это времени. Разве что подсказать что-то или проконсультировать по доработке, это всегда пожалуйста.
3. demonrik 08.09.21 10:51 Сейчас в теме
Доброго. А можно списочек GSM-шлюза с которыми это обработка работает ? Вернее это железо или онлайн сервис ?
4. bytecoded 26 09.09.21 13:03 Сейчас в теме
(3) Онлайн-сервис.

Рассылка осуществляется через GSM-шлюзы gatesms.ru и smsc.ru.
Оставьте свое сообщение