Ошибка с буквой "Й" и "Ё". Исправление пути файла в 1С: Документообороте 2.1

17.09.21

Задачи пользователя - Корректировка данных

При переносе файлов Документооборота из тома с WS 2008 на том WS 2019 через архив некоторые файлы перестали открываться в документообороте.

Скачать исходный код

Наименование Файл Версия Размер
Ошибка с буквой "Й" и "Ё". Исправление пути файла в 1С: Документообороте 2.1:
.epf 6,14Kb
0
.epf 6,14Kb Скачать

Документооборот 2.1.27.1. Платформа 8.3.17.1851.

Нужно было перенести файлы из тома c windows server 2008 на windows server 2019. Объем Архива 40Гб

Чтобы не нагружать сеть, решил через zip архив перекинуть файлы. После переноса некоторые файлы не открывались.

Запустил проверку целостности файлов в томе. Вывалился список из 300 файлов.

Проверил путь и название файлов, все визуально сходится.

Написал простой код, который сравнивает каждый символ, и выяснил, что проблема в русских буквах Й и Ё. Эти буквы содержат два символа, при попытке удаления это можно обнаружить.

стр1= "Приложение № 1– СМЕТНЫИM4 РАСЧЕТ (КАЛЬКУЛЯЦИЯ).pdf";
стр2= "Приложение № 1– СМЕТНЫЙ РАСЧЕТ (КАЛЬКУЛЯЦИЯ).pdf";
ДлСтроки1 = СтрДлина(стр1);
ДлСтроки2 = СтрДлина(стр2);
Если ДлСтроки1 <> ДлСтроки2 Тогда
Сообщить("Строки различаются:"+ДлСтроки1+ " и "+ДлСтроки2);
КонецЕсли;
МинКолСимволов = 0;
Если ДлСтроки1 > ДлСтроки2 Тогда
 МинКолСимволов = ДлСтроки2;
ИначеЕсли ДлСтроки1 < ДлСтроки2 Тогда
МинКолСимволов = ДлСтроки1;
 КонецЕсли; 
Если МинКолСимволов>0 Тогда
    

  Для сч=0 По МинКолСимволов-1 Цикл
      сим1 = Сред(стр1,сч,1);
      сим2 = Сред(стр2,сч,1);
      Если сим1<> сим2 Тогда
         Сообщить("Символы отличаются: "+ Сим1 +" и "+ Сим2); 
         Прервать;
      КонецЕсли;
  КонецЦикла;
КонецЕсли;

//для проверки "иM4;", состоит из двух символов
Сообщить(НАйти(стр1,"иM4;"));

Написал простую обработку, которая исправила все версии файлов.

Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗЛИЧНЫЕ
		|	ВерсииФайлов.Ссылка КАК Ссылка,
		|	ВерсииФайлов.Владелец КАК Владелец
		|ИЗ
		|	Справочник.ВерсииФайлов КАК ВерсииФайлов
		|ГДЕ
		|	ВерсииФайлов.ПутьКФайлу ПОДОБНО ""%иM4;%""
		|
		|ОБЪЕДИНИТЬ ВСЕ
		|
		|ВЫБРАТЬ
		|	ВерсииФайлов.Ссылка,
		|	ВерсииФайлов.Владелец
		|ИЗ
		|	Справочник.ВерсииФайлов КАК ВерсииФайлов
		|ГДЕ
		|	ВерсииФайлов.ПутьКФайлу ПОДОБНО ""%еM6;%""";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		об=ВыборкаДетальныеЗаписи.ссылка.получитьобъект();
		об.ПутьКФайлу=СтрЗаменить(об.ПутьКФайлу,"иM4;","й");
		об.ПутьКФайлу=СтрЗаменить(об.ПутьКФайлу,"ИM4;","й");
		об.ПутьКФайлу=СтрЗаменить(об.ПутьКФайлу,"еM6;","ё");
		об.ПутьКФайлу=СтрЗаменить(об.ПутьКФайлу,"ЕM6;","Ё");
		об.Записать();
	КонецЦикла;

Может, кому-то пригодится.

См. также

1С:Документооборот - цена на лицензии КОРП, ПРОФ и ДГУ

Документооборот и делопроизводство (СЭД) Типовые Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107483    106    5    

87

RayCon® Foreign Trade - Документооборот валютного контроля и международных платежей для участников ВЭД

Операции по ВЭД Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Программа предназначена для автоматизации внешнеторговых компаний и обеспечивает документооборот валютного контроля: присвоение Уникального номера контракта (УНК), формирований сведений о валютных операциях (СВО) и справок о подтверждающих документах (СПД), прочих необходимых форм учета и отчетности по валютным операциям согласно действующему валютному законодательству Российской Федерации, документооборот валютных платежей согласно международным стандартам и документооборот купли-продажи валюты, а также выгрузку любых документов 1С в любую систему клиент-банк.

30000 руб.

13.05.2009    67139    3    29    

42

Таймлист (1С:Совещание, Таймлист Лайт)

Документооборот и делопроизводство (СЭД) Конфигурации 1cv8

«Таймлист» – экосистема сервисов («Таймлист Лайт», «1C:Совещание», «Таймлист Recorder»), основанная на искусственном интеллекте Таймлист, который позволяет эффективно работать с легкими поручениями за счет фиксации всех важных идей при расшифровке и последующем формировании автопротокола встречи. Сервисы, в которые интегрирован ИИ, позволяют работать с задачами (поручениями), полученными из автопротокола.

10000 руб.

06.12.2023    1644    0    0    

8

1С:Архив

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5022    5    1    

5

Ускоренное проведение документов (x4), устранение ошибок 60/62 счетов и зачет авансов (Бухгалтерия 3.0)

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    28832    86    149    

61

Исправление в 1С:ЗУП/ЗКГУ ошибок по НДФЛ и взаиморасчетам с сотрудниками на начало расчетного года.

Корректировка данных Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    2933    31    15    

38

Тестирование и исправление ключей аналитики ERP, УТ11, КА

Корректировка данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Незаменимая обработка для сопровождения конфигураций: ERP, УТ, КА. Позволяет вычистить многие ошибки в ключах аналитики, в ключевых справочниках конфигурации.

3600 руб.

10.02.2017    107880    639    173    

681

ЭДО: организация архива оригиналов первичных документов, комплексный отчет по ошибкам

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44658    60    51    

74
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. SerVer1C 775 17.09.21 12:07 Сейчас в теме
Можете в хексе написать, что было и что стало после переноса? Из статьи не понятно, что это за добавки такие M4 и M6 - возможно, это сайт исказил кодировку.
4. Kostt 24 18.09.21 18:21 Сейчас в теме
(1)Это редактор инфостарта так его представил. Если это Вам поможет Вот HEX этого символа "Й" d0 98 cc 86 , а это HEX Буквы "Й" d0 99
2. RustIG 1631 17.09.21 13:03 Сейчас в теме
когда работаешь под действием терафлю - хотел плюс поставить, и нажал на увеличение фото....
Прикрепленные файлы:
3. user1647001 18.09.21 11:37 Сейчас в теме
Оставьте свое сообщение