Групповая корректировка назначения

03.11.22

Задачи пользователя - Корректировка данных

При заказе товара с обособленным обеспечением возможны ситуации, когда заказ отменили или сняли с товара галку "Обособлено", а товар остался зарезервированным под этот заказ. Обработка находит весь не обеспеченный товар и снимает резерв по лишним назначениям.

Скачать исходный код

Наименование Файл Версия Размер
Групповая корректировка назначения
.epf 11,20Kb
13
.epf 11,20Kb 13 Скачать

В отличие от типового механизма заполнения документа "Корректировка назначения" учитывается количество товара на всех складах. То есть если товар заказали со склада 1, а назначение закрепили на складе 2, тогда товар останется зарезервированным, и его можно будет переместить под обеспечение заказа.

Проверено на релизе Управление торговлей, редакция 11 (11.5.9.131).
Платформа: 8.3.22.1672.

Обработку можно использовать как внешний файл или подключить через систему доп. обработок как регламентное задание.

При работе в режиме регламентного задания, при наличии ошибок выполнения пользователю, от имени которого выполняется задание, будет создано напоминание с информацией об ошибке.

На релизе УТ НИЖЕ 11.5.9 работать НЕ БУДЕТ.

Запрос по излишкам товара:

"ВЫБРАТЬ
	|	Остатки.Назначение КАК Назначение,
	|	Остатки.Номенклатура КАК Номенклатура,
	|	СУММА(Остатки.ВНаличииОстаток) - СУММА(Остатки.КОбеспечениюОстаток) - СУММА(Остатки.РезервироватьНаСкладеОстаток) КАК Освободить
	|ПОМЕСТИТЬ НазначенияКОтмене
	|ИЗ
	|	РегистрНакопления.ЗапасыИПотребности.Остатки(
	|			,
	|			Назначение <> ЗНАЧЕНИЕ(Справочник.Назначения.ПустаяСсылка)
	|				И Склад ССЫЛКА Справочник.Склады) КАК Остатки
	|
	|СГРУППИРОВАТЬ ПО
	|	Остатки.Назначение,
	|	Остатки.Номенклатура
	|
	|ИМЕЮЩИЕ
	|	СУММА(Остатки.ВНаличииОстаток) - СУММА(Остатки.КОбеспечениюОстаток) - СУММА(Остатки.РезервироватьНаСкладеОстаток) > 0
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	Остатки.Назначение КАК Назначение,
	|	Остатки.Номенклатура КАК Номенклатура,
	|	СУММА(Остатки.КОбеспечениюОстаток) + СУММА(Остатки.РезервироватьНаСкладеОстаток) КАК Заказано,
	|	СУММА(Остатки.ВНаличииОстаток) - СУММА(Остатки.КОбеспечениюОстаток) - СУММА(Остатки.РезервироватьНаСкладеОстаток) КАК Склад,
	|	НазначенияКОтмене.Освободить КАК Освободить
	|ИЗ
	|	РегистрНакопления.ЗапасыИПотребности.Остатки(
	|			,
	|			Назначение <> ЗНАЧЕНИЕ(Справочник.Назначения.ПустаяСсылка)
	|				И Склад ССЫЛКА Справочник.Склады) КАК Остатки
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ НазначенияКОтмене КАК НазначенияКОтмене
	|		ПО Остатки.Номенклатура = НазначенияКОтмене.Номенклатура
	|			И Остатки.Назначение = НазначенияКОтмене.Назначение
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказКлиента.Товары КАК ЗаказКлиентаТовары
	|		ПО (ЗаказКлиентаТовары.Ссылка.Назначение = Остатки.Назначение)
	|			И (ЗаказКлиентаТовары.Обособленно)
	|			И (ЗаказКлиентаТовары.Номенклатура = Остатки.Номенклатура)
	|
	|СГРУППИРОВАТЬ ПО
	|	Остатки.Номенклатура,
	|	Остатки.Назначение,
	|	НазначенияКОтмене.Освободить
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	НазначенияКОтмене.Назначение.Заказ.Организация КАК Организация,
	|	Остатки.Назначение КАК Назначение,
	|	Остатки.Номенклатура КАК Номенклатура,
	|	Остатки.Склад КАК Склад,
	|	СУММА(Остатки.КОбеспечениюОстаток) + СУММА(Остатки.РезервироватьНаСкладеОстаток) КАК Заказано,
	|	СУММА(Остатки.ВНаличииОстаток) - СУММА(Остатки.КОбеспечениюОстаток) - СУММА(Остатки.РезервироватьНаСкладеОстаток) КАК Разница,
	|	ВЫБОР
	|		КОГДА Остатки.Склад = ЗаказКлиентаТовары.Склад
	|			ТОГДА 1
	|		КОГДА Остатки.Склад = ЗаказКлиентаТовары.Ссылка.Склад
	|			ТОГДА 2
	|		ИНАЧЕ 3
	|	КОНЕЦ КАК ПорядокСКлада,
	|	НазначенияКОтмене.Освободить КАК Освободить
	|ИЗ
	|	РегистрНакопления.ЗапасыИПотребности.Остатки(
	|			,
	|			Назначение <> ЗНАЧЕНИЕ(Справочник.Назначения.ПустаяСсылка)
	|				И Склад ССЫЛКА Справочник.Склады) КАК Остатки
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ НазначенияКОтмене КАК НазначенияКОтмене
	|		ПО Остатки.Номенклатура = НазначенияКОтмене.Номенклатура
	|			И Остатки.Назначение = НазначенияКОтмене.Назначение
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказКлиента.Товары КАК ЗаказКлиентаТовары
	|		ПО (ЗаказКлиентаТовары.Ссылка.Назначение = Остатки.Назначение)
	|			И (ЗаказКлиентаТовары.Обособленно)
	|			И (ЗаказКлиентаТовары.Номенклатура = Остатки.Номенклатура)
	|
	|СГРУППИРОВАТЬ ПО
	|	Остатки.Номенклатура,
	|	Остатки.Назначение,
	|	Остатки.Склад,
	|	ЗаказКлиентаТовары.Склад,
	|	ВЫБОР
	|		КОГДА Остатки.Склад = ЗаказКлиентаТовары.Склад
	|			ТОГДА 1
	|		КОГДА Остатки.Склад = ЗаказКлиентаТовары.Ссылка.Склад
	|			ТОГДА 2
	|		ИНАЧЕ 3
	|	КОНЕЦ,
	|	НазначенияКОтмене.Назначение.Заказ.Организация,
	|	НазначенияКОтмене.Освободить
	|
	|УПОРЯДОЧИТЬ ПО
	|	ПорядокСКлада
	|ИТОГИ
	|	СУММА(Разница),
	|	СУММА(Освободить)
	|ПО
	|	Организация,
	|	Назначение,
	|	Номенклатура"

Второй запрос в пакете - для отображения информации на форме обработки в пользовательском режиме.

Процедура снятия лишних резервов:


Процедура СнятьЛишниеНазначения(РезультатЗапроса) Экспорт
	
	ВыборкаОрганизации = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Организация");
	Пока ВыборкаОрганизации.Следующий() Цикл
		ВыборкаНазначения = ВыборкаОрганизации.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Назначение");
		
		ДокКорНаз = Документы.КорректировкаНазначенияТоваров.СоздатьДокумент();
		ДокКорНаз.Дата = ТекущаяДата();
		ДокКорНаз.Комментарий 	= "Автоматическая отмена избыточных резервов";
		ДокКорНаз.Организация 	= ВыборкаОрганизации.Организация;
		ДокКорНаз.ВидОперации 	= Перечисления.ВидыОперацийКорректировкиНазначения.СнятьРезервПоМногимНазначениям;
		ДокКорНаз.Автор       	= ПараметрыСеанса.АвторизованныйПользователь;
		ДокКорНаз.Ответственный = ПараметрыСеанса.АвторизованныйПользователь;
		
		Пока ВыборкаНазначения.Следующий() Цикл //снять сверх свободного остатка
			ВыборкаНом = ВыборкаНазначения.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Номенклатура");
			Пока ВыборкаНом.Следующий() Цикл         
				
				ВсегоПоТовару = ВыборкаНом.Освободить;
				
				Выборка = ВыборкаНом.Выбрать();
				Пока Выборка.Следующий() Цикл         
					Если Выборка.Разница > 0 Тогда 
						
						СтрДок = ДокКорНаз.Товары.Добавить(); 
						Освободить = Мин(Выборка.Освободить,Выборка.Разница);
						СтрДок.Количество 			= Освободить;
						СтрДок.КоличествоУпаковок 	= Освободить;
						СтрДок.Номенклатура 		= Выборка.Номенклатура;
						СтрДок.Склад 				= Выборка.Склад;
						СтрДок.ИсходноеНазначение	= Выборка.Назначение;
						СтрДок.ИсходныйЗаказ		= Выборка.Назначение.Заказ;
						
						ВсегоПоТовару = ВсегоПоТовару - Освободить;
					КонецЕсли;	
				КонецЦикла;
			КонецЦикла;
		КонецЦикла;
		
		Ошибки = "";
		Ошибка = Не ДокКорНаз.ПроверитьЗаполнение();
		
		Если Не Ошибка Тогда
			Попытка
				ДокКорНаз.Записать(РежимЗаписиДокумента.Проведение);
				Ошибки = "Проведен документ "+ДокКорНаз;
			Исключение
				//ДокКорНаз.Записать(РежимЗаписиДокумента.Запись);
				Ошибки = ПолучитьСообщенияПользователю(Истина);
				Ошибка = Истина;
			КонецПопытки;
		Иначе
			Ошибки = ПолучитьСообщенияПользователю(Истина);
		КонецЕсли;
		
		Если ТипЗнч(Ошибки) = Тип("ФиксированныйМассив") Тогда
			Для Каждого Сообщение Из Ошибки Цикл
				ОповеститьОРезультате(Сообщение.Текст, Ошибка);
			КонецЦикла;                                              
		Иначе
			ОповеститьОРезультате(Ошибки, Ошибка);
		КонецЕсли; 
	КонецЦикла;
	
КонецПроцедуры

 

Назначение резервы запасы резервирование регламентное задание обособление

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    92148    116    40    

206

Программа для фулфилмента (FBS / FBO): модуль "Ответственное хранение" в 1С:УТ 11.5, КА 2.5, ERP 2.5

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа для фулфилмента: модуль "Ответственное хранение" для 1С (УТ 11.5, КА 2.5, ERP 2.5) позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    35685    28    59    

58

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212987    635    526    

449

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Бухгалтер Пользователь Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    152669    370    376    

505

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191717    135    239    

270

Автоматизированная система управления складом AS WMS: автоматизация склада с адресным хранением с помощью ТСД

Логистика, склад и ТМЦ Платформа 1С v8.3 Россия Платные (руб)

Подсистема автоматизированного управления складом AS WMS для конфигураций на платформе 1С 8. AS WMS – готовое решение для эффективного управления, хранения и учета на адресном складе. Внедрение системы AS WMS способствует быстрому отбору товара, ускорению инвентаризации, снижению зависимости от персонала, исключению пересорта. AS WMS встраивается в любую конфигурацию на платформе 1С 8 и работает как единая система без обменов. В учетной системе нет необходимости менять процессы под AS WMS (например, вводить ордерную схему), AS WMS использует стандартные документы по товародвижению вашей учетной системы.

40000 руб.

26.07.2023    4154    14    0    

11
Отзывы
1. Pira 147 09.02.23 16:36 Сейчас в теме
Аналогичная обработка для корректировки назначения по этапам производства в ERP: https://infostart.ru/public/1805833/
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Pira 147 09.02.23 16:36 Сейчас в теме
Аналогичная обработка для корректировки назначения по этапам производства в ERP: https://infostart.ru/public/1805833/
Оставьте свое сообщение