Отправка сообщений пользователям 1С

14.10.13

База данных - Инструменты администратора БД

Отправка сообщений активным пользователям! Обработка крайне проста, и не нужно вносить изменения в конфигурацию.

Скачать исходный код

Наименование Файл Версия Размер
Сообщение пользователям 1С
.epf 11,47Kb
157
.epf 1,02 11,47Kb 157 Скачать

Отправка сообщений активным пользователям! Обработка крайне проста, и не нужно вносить изменения в конфигурацию.

Суть работы обработки заключается в:

1. получение списка активных пользователей,

2. отметить пользователя или пользователей, для которых будем отправлять сообщение,

3. дальше создается текстовое сообщение, названием которого будет имя получателя.

4. Дальше есть кнопка получить сообщение, над которой находится окно самого сообщения входящего.

Для корректной работы обработки в модуле формы нужно прописать каталог, в котором будут сохраняться файлы сообщений.

 

Процедура ОтправитьНажатие(Элемент)
    
    Для Каждого СтрП из ИтогСписокСоединений Цикл
        
        Если СтрП.ОтправитьСообщение = Истина Тогда
            
            ТексДок = Новый ТекстовыйДокумент;
            
            ТексДок.ДобавитьСтроку(СтрП.Пользователь);
            ТексДок.ДобавитьСтроку(ТекстСообщения);
            
            ТексДок.Записать("ПутьКаталога"+СтрП.Пользователь+".txt");
        КонецЕсли;    
    КонецЦикла;
    
    ТекстСообщения = Неопределено;
    
КонецПроцедуры

Процедура ПолучитьНажатие(Элемент)
    
     ТекстСообщенияВходящее = Неопределено;

     Путь = "ПутьКаталога"+ПараметрыСеанса.ТекущийПользователь.Наименование+".txt";
    
     Файл = Новый Файл(Путь);
    
     Если Файл.Существует() Тогда
    
         Текс = Новый ТекстовыйДокумент;
         Текс.Прочитать(Путь);
         Письмо = Текс.ПолучитьТекст();
        
         Если Письмо = Неопределено Тогда
             ТекстСообщенияВходящее = "Нових повідомлень нема!";
         Иначе
             ТекстСообщенияВходящее = Письмо;
             УдалитьФайлы("ПутьКаталога"+ПараметрыСеанса.ТекущийПользователь.Наименование+".txt");
         КонецЕсли;
     Иначе
     ТекстСообщенияВходящее = "Нових повідомлень нема!";    
    КонецЕсли;    
        
КонецПроцедуры

Сообщение пользователям

См. также

Автоподбор ролей для профилей и групп доступа в любых типовых базах 1С УТ 11, КА 2, ERP2, Розница 2/3, УНФ 16/3, БП 3, ЗУП 3 и подобных (УФ, Платформа 8.3.14+)

Инструменты администратора БД Роли и права Системный администратор Программист Пользователь 8.3.14 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Документооборот 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Роли… Вы тратите много времени и сил на подбор ролей среди около 2400 в ERP или 1500 в Рознице 2, пытаясь понять какими правами они обладают? Вы все время смотрите права в конфигураторе или отчетах чтоб создать нормальные профили доступа? Вы хотите наглядно видеть какие права дает профиль и редактировать все в простом виде? А может хотите просто указать подсистему и дать права на просмотр и добавление на объекты и не лезть в дебри прав и чтоб обработка сама подобрала нужные роли? Все это теперь стало возможно! Обновление от 15.12.2023, версия 1.1.

14400 руб.

06.12.2023    4667    21    1    

47

Infostart УДиФ: Управление данными и формами 1С

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    5642    15    2    

39

SALE! %

PowerTools

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    180163    1096    0    

871

Ускоренное проведение документов в 1С (x4), устранение ошибок 60/62 счетов и зачет авансов (Бухгалтерия 3.0)

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтер Пользователь Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    29037    86    149    

61

Система хранения присоединенных файлов в томах на диске

Инструменты администратора БД Системный администратор Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием Платные (руб)

Конфигурация Комплексная автоматизация 1.1 (и УПП 1.3 тоже) хранит файлы и изображения в справочнике Хранилище дополнительной информации в реквизите Хранилище типа ХранилищеЗначений. Та же история с ВложениямиЭлектроннойПочты. Но при этом присоединенные файлы в Электронном документообороте хранит в томах на диске. Эта доработка позволяет использовать стандартный механизм хранения файлов, изображений и вложений электронных писем в томах на диске. При этом можно разделить тома хранения по объектам конфигурации.

4200 руб.

10.11.2015    61832    90    59    

74

Конфигурация Session Monitor

Мониторинг Инструменты администратора БД Системный администратор Платформа 1С v8.3 Россия Платные (руб)

Конфигурация Session Monitor предназначена для мониторинга сервера 1С с целью отслеживания чрезмерной нагрузки от конкретных сеансов и скорости реакции рабочих процессов.

1500 руб.

01.12.2020    14689    36    0    

51

Хранилище файлов на SQL

Инструменты администратора БД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Управленческий учет Платные (руб)

Привязка файлов / сканов к объектам 1С с сохранением их на SQL-сервере

12000 руб.

09.10.2019    11518    5    8    

9

Автоматическое резервное копирование любой клиент-серверной базы 1С в формате DT с удалением сеансов, архивацией, изменением расширения (8.3.14+, расширение)

Архивирование (backup) Инструменты администратора БД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Данная разработка позволит решить вопрос с резервным копированием Ваших баз в автоматическом режиме, расположенных на сервере 1С. Система умеет ставить блокировки на вход, блокировать фоновые задания, принудительно отключать сеансы пользователей. И все это система делает в автоматически при создании бэкапа (или через команду). Выгрузка происходит в родной формат 1С - .dt. Так же система умеет архивировать данные выгрузки с установкой пароля. Умеет менять расширение файла zip или dt на любое указанное вами, что позволит сохранить выгрузки от шифровальщика. Может удалять старые копии выгрузок, оставляя указанное количество резервных копий, начиная с самой поздней.

6000 руб.

06.11.2012    70715    622    44    

80
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. MarSeN 984 22.08.13 18:09 Сейчас в теме
По неопытности не знаю, как правильно сделать, чтобы обработка сама забирала документы, поэтому сделана кнопка .

Особо не вчитывался в проблему но, возможно, стоит посмотреть в сторону метода "ПодключитьОбработчикОжидания"
Этим способом http://infostart.ru/public/179185/ можно вообще чтоб формы не было видно и появлялась только когда есть сообщение
2. Vovus 3 22.08.13 18:53 Сейчас в теме
(1) MarSeN, Можете на почту обработку скинуть? bot1c@outlook.com
3. MarSeN 984 22.08.13 19:41 Сейчас в теме
4. Vovus 3 23.08.13 11:05 Сейчас в теме
5. grey_yes 12 23.08.13 17:45 Сейчас в теме
ФИГНЯ какая-то....
...писать "ТексДок.Записать("D:\Instal\Work1C\Сообщения\"+СтрП.Пользователь+".txt");"
что за жесткая привязка пути?!!!!!!

и у получателя должна быть запущена та же обработка
и он должен постоянно тыкать - а не послал ли мне меня кто-нить....

мне даже "минус" поставить жалко... не то что плюсануть
6. Vovus 3 23.08.13 18:12 Сейчас в теме
(5) grey_yes, Если знаете как сделать чтоб не нажимал пользователь на кнопку буду благодарен за подсказку А привязку к пути можно убрать с модуля и сделать панель настроек но пока так!
7. MarSeN 984 25.08.13 22:27 Сейчас в теме
(6)
Обработка, которую я скинул, демонстрирует как подключить "глобальный обработчик" без видимой формы.
Используй этот метод у себя. повесь на процедуру обработчика проверку на новое сообщение. если оно есть то выполни ЭтаФорма.Открыть() или Открыть() и твоя форма обработки чудесным образом откроется.
Когда пользователь прочтет сообщение можно послать команду "Закрыть()". Форма скроется из виду но будет продолжать висеть невидимой для пользователя. Конечно если ты не остановишь обработчик ожидания.

Успехов
8. Vovus 3 27.08.13 10:42 Сейчас в теме
9. chmv 28.08.13 09:33 Сейчас в теме
10. Abadonna 3961 12.10.13 08:40 Сейчас в теме
(0) Пользователи в ГРУ работают или ФСБ? Замазаны как особо секретные на картинке?
Имена компов тоже, видимо, особо секретные...
13. Vovus 3 17.10.13 12:03 Сейчас в теме
11. ves.Parnas 16.10.13 09:26 Сейчас в теме
а Ч.Д. если у пользователя открыто 5 баз, а сообщение приходит в то окно, которое у него не активно?
14. Vovus 3 17.10.13 12:06 Сейчас в теме
(11) ves.Parnas, Пока вопрос всплывающего окна не решен
12. smir 53 16.10.13 10:28 Сейчас в теме
Не до конца понятно из описания, как это работает.
15. Vovus 3 17.10.13 12:06 Сейчас в теме
(12) smir, Что именно не ясно?
16. dock 44 25.01.14 06:41 Сейчас в теме
Нда... ценность обработки пока не высока...
Ведь что бы пользователь увидел сообщение, ему нужно явно нажать на какую-то кнопку.

(15) Не совсем понятны действия пользователя.
Алгоритм работы:

Администратор/программист:
1. Запустить внешнюю обработку.
2. Выбрать пользователя/пользователей из списка активных. Список пользователей формируется при запуске обработки.
3. Ввести текст сообщения в окно редактирования.
4. Нажать кнопку "Отправить".
Пользователь:
1. Запустить внешнюю обработку.
2. Нажать кнопку "Получить сообщение".

Если ошибся - поправьте меня.
17. Vovus 3 29.01.14 16:51 Сейчас в теме
(16) dock, Если Вам интересно есть новая версия в которой нужно наживать только отправить все остальное делается в автоматическом режиме!
20. dock 44 07.02.14 11:30 Сейчас в теме
(17) Ссылка ?
Зачем интриговать человека... лучше сразу ссылку давать на новую версию ;)
21. Vovus 3 07.02.14 11:51 Сейчас в теме
(20) dock, Нигде не выложена обработка напишите почту и вышлю Вам
22. ben19791010 06.03.15 10:39 Сейчас в теме
(21) киньте мне если не сложно для тонкоклиента на УФ файловая база
18. roadman 05.02.14 09:21 Сейчас в теме
Насколько я помню, в каких-то стандартных конфигурациях ведь есть рассылка сообщение пользователям...
19. roadman 05.02.14 09:22 Сейчас в теме
Если кто-то помнит, напомните - в каких?
23. andadra 07.07.16 15:04 Сейчас в теме
Здравствуйте!andadra@yandex.ru.Скиньте на УФ пожалуйста
24. Vovus 3 10.07.16 17:02 Сейчас в теме
(23) andadra, На УФ нет пока, если нужно могу сделать пишите на bot1c@outlook.com!
25. Voblhned 58 26.12.16 10:36 Сейчас в теме
(24) думаю, что на 8.2 уже давно не актуально, было бы круто на 8.3 УФ увидеть такую реализацию.
26. Vovus 3 26.12.16 15:35 Сейчас в теме
Я думаю в скором сделаю и на УФ
27. merlin1975 2 02.05.17 18:57 Сейчас в теме
Здравия!
Наткнулся на Вашу обработку. Интересно, на УФ пойдет? Интересна реализация именно на ЗУП 2.5. Она идет и на 8.2 и на 8.3. Если можно, для пробы посмотреть обработку?
28. VmvLer 02.05.17 23:09 Сейчас в теме
в 8.3.10 или далее отправка сообщений пользователям уже штатный механизм.

Полгода-год и обработки на эту тему станут антиквариатом
29. siggoron 03.05.17 04:58 Сейчас в теме
1C has been released the massage mechanism since 8.3.10.
I think it will be so helpful in this situation.
30. merlin1975 2 03.05.17 18:01 Сейчас в теме
Да, но пока сам на 8.2 - интересно попробовать
Оставьте свое сообщение