Программное создание таблицы в WORD с использованием разметки Office Open XML. Через сервер с использованием БСП

09.02.24

Разработка - Инструментарий разработчика

Пример как можно программно создать таблицу в ворде на основе Табличного документа. С использованием разметки Office Open XML на сервере с использованием функций БСП для печати.

Скачать файлы

Наименование Файл Версия Размер
Таблица программно в WORD
.epf 21,67Kb
4
.epf 21,67Kb 4 Скачать

Создаем макет, где вставляем тег, который далее заместим на сгенерированную xml разметку с таблицей.

 

Далее после кода, где определяется область с таблицей

Область = УправлениеПечатью.ОбластьМакета(Макет, Области[ИмяМакета].Документ); 

Добавляем следующий код. 

	ТекстОбласти = Область.Текст;
		ИмяТаблицы = "Таблица"; 
		НомерТаблицы = 1;
		
		Таблица = ЗначениеИзСтрокиВнутр(ТаблицаСтрока);				
		НомерТаблицы = НомерТаблицы + 1;
		
		СтрокаПоиска = "{v8 " + ИмяТаблицы + "}"; 
		НачалоТаблицы = СтрНайти(ТекстОбласти, СтрокаПоиска);    
		
		Если НачалоТаблицы = 0 Тогда
			
			Возврат "";	
			
		КонецЕсли;  
		
		КонецПараграфа = СтрНайти(ТекстОбласти, "</w:p>",, НачалоТаблицы);  
		НачалоПараграфа = СтрНайти(ТекстОбласти, "<w:p ", НаправлениеПоиска.СКонца, НачалоТаблицы);
		СтрокаЗамены = Сред(ТекстОбласти, НачалоПараграфа, КонецПараграфа - НачалоПараграфа +6 );
		//СтрокаБезТегаТаблица = СтрЗаменить(СтрокаЗамены, СтрокаПоиска, "");
		ТабДокумент = Таблица;	
		ПоследняяСтрока = ТабДокумент.ВысотаТаблицы;  
		ПоследняяКолонка = ТабДокумент.ШиринаТаблицы;   
		
		ТаблицаХМЛ = "";  
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("<w:tbl>"));  // начало таблицы
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("<w:tblPr>"));  // начало свойств
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("<w:tblW w:w=""0"" w:type=""auto""/>"));  // начало свойств
		
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("<w:tblBorders>"));  // Границы   
		ТекстГраница = "<w:%1 w:val=""single"" w:sz=""4"" w:space=""0"" w:color=""auto""/>";
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "top")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "left")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "bottom")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "right")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "insideH")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, СтрШаблон(ТекстГраница, "insideV")); 
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("</w:tblBorders>")); 
		
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("</w:tblPr>"));
		
		// перебор столбцов
		НомерСтолбца = 1;
		Пока НомерСтолбца <= ПоследняяКолонка Цикл   
			Ячейка = ТабДокумент.Область("R1C" + НомерСтолбца); 
			НомерСтолбца = НомерСтолбца + 1;  			
		КонецЦикла;

		НомерСтр = 1; 
		Пока НомерСтр <= ПоследняяСтрока Цикл
			ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:tr>"); //начало описание строки
			Для Счетчик = 1 По НомерСтолбца - 1 Цикл
				
				Ячейка = ТабДокумент.Область("R" + Строка(НомерСтр) + "C"+Счетчик);  
				
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:tc>"); //начало ячейки
				
				Если НомерСтр = 1 Тогда
					ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:tcPr><w:tcW w:w=""0"" w:type=""auto""/><w:shd w:val=""clear"" w:color=""auto"" w:fill=""366091""/></w:tcPr>");
				Иначе	
					ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:tcPr><w:tcW w:w=""0"" w:type=""auto""/></w:tcPr>");
				КонецЕсли;   
				
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:p>");
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:r>"); 
				Если НомерСтр = 1  Тогда
					ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:rPr><w:color w:val=""#FFFFFF"" /></w:rPr>)");	
				КонецЕсли;
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "<w:t>");
				
				ТекстЯчейки = Ячейка.Текст;
				
				Если СтрНайти(ТекстЯчейки, ">") > 0 Тогда
					ТекстЯчейки = СтрЗаменить(ТекстЯчейки, ">", "&gt;")	
				КонецЕсли; 
				
				Если СтрНайти(ТекстЯчейки, "<") > 0 Тогда
					ТекстЯчейки = СтрЗаменить(ТекстЯчейки, "<", "&lt;")	
				КонецЕсли; 
								
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ТекстЯчейки);
				
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "</w:t>");
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "</w:r>");
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "</w:p>");
				ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "</w:tc>"); // 
				
			КонецЦикла;  
			
			НомерСтр = НомерСтр + 1; 
			ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, "</w:tr>");
			
		КонецЦикла;  
		
		ТаблицаХМЛ = ДобавитьТекст(ТаблицаХМЛ, ("</w:tbl>"));
		
		ТекстОбласти = СтрЗаменить(ТекстОбласти, СтрокаЗамены, ТаблицаХМЛ);
		
		
		Область.Текст = ТекстОбласти;
		
		УправлениеПечатью.ПрисоединитьОбластьИЗаполнитьПараметры(ПечатнаяФорма, Область, ДанныеОбъекта);

В коде идет раскрашивание первой строки таблицы, в итоге получаем на печать следующее.

Если надо что-то новое добавить в таблицу, пользуемся разметкой Office Open xml тут - http://datypic.com/sc/ooxml/ss.html

А вот тут есть подробнее про таблицы - http://officeopenxml.com/WPtable.php

Тестировалось на "Библиотека стандартных подсистем", редакция 3.1 (3.1.9.104).

Проверено на следующих конфигурациях и релизах:

  • 1С:ERP Управление предприятием 2, релизы 2.5.14.74

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

12000 руб.

02.09.2020    117010    637    389    

689

Infostart PrintWizard

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    6525    13    4    

35

PowerTools

Инструментарий разработчика Инструменты администратора БД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 руб.

14.01.2013    176551    1064    0    

840

Infostart УДиФ: Управление данными и формами

Инструменты администратора БД Инструментарий разработчика Администрирование Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    2743    4    1    

26

Многопоточность. Универсальный «Менеджер потоков» 2.1

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    98663    238    97    

292

Выполнение произвольного кода или запроса с параметрами через Web-сервис (замена COM-подключений)

Инструментарий разработчика Обмен между базами 1C Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы.  Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    23298    15    15    

31

Менеджер конфигураций 1С

Инструментарий разработчика Платные (руб)

Менеджер конфигураций 1С — альтернативный стартер информационных баз 1С:Предприятие.

1800 руб.

21.02.2023    6360    4    34    

16

Программное формирование существующих печатных форм

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Получение списка печатных форм, формирование выбранной печатной формы и сохранение ее в файл.

1 стартмани

17.12.2021    15539    42    RocKeR_13    5    

50
Отзывы
2. Wilka 73 12.02.24 10:41 Сейчас в теме
(1)да, но в данном случае можно сделать любую таблицу и вывести ее. А в варианте бсп нужно точно знать количество столбцов и шапка делается фиксировано. Данное решение, только для из-за чего-то динамически меняющихся таблиц, которые надо вывести.
Aleskey_K; +1 Ответить
1. Aleskey_K 30 12.02.24 08:27 Сейчас в теме
Спасибо за публикацию.
Можно сделать проще: настроить таблицу в нужном стиле и размерах, а затем построчно вывести методами БСП.
Прикрепленные файлы:
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Aleskey_K 30 12.02.24 08:27 Сейчас в теме
Спасибо за публикацию.
Можно сделать проще: настроить таблицу в нужном стиле и размерах, а затем построчно вывести методами БСП.
Прикрепленные файлы:
2. Wilka 73 12.02.24 10:41 Сейчас в теме
(1)да, но в данном случае можно сделать любую таблицу и вывести ее. А в варианте бсп нужно точно знать количество столбцов и шапка делается фиксировано. Данное решение, только для из-за чего-то динамически меняющихся таблиц, которые надо вывести.
Aleskey_K; +1 Ответить
Оставьте свое сообщение