Просмотрщик файлов DBF (DBFViewer), переделанный для управляемых форм

15.12.14

Разработка - Разработка внешних компонент

Просмотр содержимого DBF файла с возможностью печати его структуры.
Поддержка как DOS, так и Windows кодировки.

Скачать исходный код

Наименование Файл Версия Размер
DBFViewer8_3
.erf 10,55Kb
41
.erf 10,55Kb 41 Скачать

По роду своей деятельности часто приходится иметь дело с форматом "DBF". Причем работа ведется на управляемых формах.

Т.к. для модального режима внешний отчет уже написан, то чтобы каждый раз не менять режим, я переделал его для управляемых форм.

Надеюсь, кому - либо пригодится.

Отчет в прикреплении.

Исходный код:

&НаКлиенте
Перем База;

&НаКлиенте
Функция ДиалогОткрытияФайлаDBF()
	СтандартнаяОбработка = Ложь;
	ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогОткрытияФайла.Фильтр = "Файлы DBF(*.dbf)|*.dbf|";
	ДиалогОткрытияФайла.ПроверятьСуществованиеФайла = Истина;
	ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
	ДиалогОткрытияФайла.Заголовок = "Выберите файл dbf (Формат - Data Base III)";
 
	Если ДиалогОткрытияФайла.Выбрать() Тогда
		Возврат ДиалогОткрытияФайла.ПолноеИмяФайла;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ДиалогСВопросом(ТекстВопроса, ЗаголовокВопроса, РежимДиалога)
    Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЭтотОбъект);
 
    ПоказатьВопрос(Оповещение,
        ТекстВопроса,
        РежимДиалога,
        0,
        КодВозвратаДиалога.Да,
        ЗаголовокВопроса
    );
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт		
    Если Результат = КодВозвратаДиалога.Да Тогда
        ЗагрузкаДанных();
    КонецЕсли;	
КонецПроцедуры

&НаСервере
Процедура ДобавитьПоляВТЗ(МассивСтруктур)
	/////////////////////////////////////////////////////////
	//Преобразуем массив структур в исходную таблицу значений	
	ИсхТЗ = Новый ТаблицаЗначений;
	Для Каждого ЭлементМассива Из МассивСтруктур Цикл
	    //Если еще не добавили, добавляем колонки
	    Если ИсхТЗ.Колонки.Количество() = 0 Тогда
	        Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
	            ИсхТЗ.Колонки.Добавить(ЗначениеСтруктуры.Ключ);
	        КонецЦикла;
	    КонецЕсли;
	    //Добавляем данные в таблицу
	    НоваяСтрока = ИсхТЗ.Добавить();
	    Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
	        НоваяСтрока[ЗначениеСтруктуры.Ключ] = ЗначениеСтруктуры.Значение;
	    КонецЦикла;
	КонецЦикла;
	/////////////////////////////////////////////////////////
	
	/////////////////////////////////////////////////////////
	//Почистим таблицу на форме
	ТЗНаФорме.Очистить();
	МассивУдаляемыхРеквизитов = Новый Массив;
    РеквизитыТЗ = ПолучитьРеквизиты("ТЗНаФорме");
	Если РеквизитыТЗ.Количество() > 0 Тогда
		Для Каждого Реквизит Из РеквизитыТЗ Цикл
	 		МассивУдаляемыхРеквизитов.Добавить("ТЗНаФорме." + Реквизит.Имя);
		КонецЦикла;
		ЭтаФорма.ИзменитьРеквизиты(,МассивУдаляемыхРеквизитов);
		
		Для Каждого Реквизит Из РеквизитыТЗ Цикл
			УдаляемыйЭлемент = Элементы.Найти("ТЗНаФорме_" + Реквизит.Имя);
			Если УдаляемыйЭлемент <> Неопределено Тогда
				Элементы.Удалить(УдаляемыйЭлемент);
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	/////////////////////////////////////////////////////////
	
	/////////////////////////////////////////////////////////
	//Создаем массив реквизитов - колонок для таблицы значений на форме
	МассивРеквизитов = Новый Массив;
	Для Каждого Колонка Из ИсхТЗ.Колонки Цикл
    	МассивРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "ТЗНаФорме", Колонка.Заголовок)); 
	КонецЦикла;
	/////////////////////////////////////////////////////////
	
	/////////////////////////////////////////////////////////
	//Выводим добавленные колонки на форму
	ЭтаФорма.ИзменитьРеквизиты(МассивРеквизитов);
    ЗначениеВРеквизитФормы(ИсхТЗ, "ТЗНаФорме");
	Таблица = Элементы.ТЗНаФорме;
	Таблица.Отображение = ОтображениеТаблицы.Список;
    Для Каждого Колонка Из ИсхТЗ.Колонки Цикл
       НовыйЭлемент = Элементы.Добавить("ТЗНаФорме_" + Колонка.Имя, Тип("ПолеФормы"), Таблица); 
       НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода; 
       НовыйЭлемент.ПутьКДанным = "ТЗНаФорме." + Колонка.Имя;
   КонецЦикла;
   /////////////////////////////////////////////////////////
КонецПроцедуры

&НаКлиенте
Процедура ОсновныеДействияФормыОткрыть(Кнопка)	
	ИмяФайла = ДиалогОткрытияФайлаDBF();
	Если ИмяФайла = Неопределено Тогда
		Возврат;
	КонецЕсли;
	База = Новый XBase;
	Попытка
    	База.ОткрытьФайл(ИмяФайла);
    Исключение
        Сообщить("Произошла ошибка при обращение к файлу dbf:" + Символы.ПС + ОписаниеОшибки());
        Возврат;
	КонецПопытки;
		
	Если ФДОС=Истина Тогда
		База.Кодировка=КодировкаXBase.OEM;
	Иначе
		База.Кодировка=КодировкаXBase.ANSI;
	КонецЕсли;
		
	База.ОтображатьУдаленные = Истина;	
	Записей = База.КоличествоЗаписей();
	
	Если (Записей > 10000) И (Ф100 = Ложь) Тогда
		Режим = РежимДиалогаВопрос.ДаНет;
		ТекстВопроса = "Количество записей в файле " + Записей + ". Продолжить?";
		ДиалогСВопросом(ТекстВопроса, "Длительная загрузка данных!", РежимДиалогаВопрос.ДаНет);
	Иначе
		ЗагрузкаДанных();
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузкаДанных()
	Записей = База.КоличествоЗаписей();
	МассивСтруктур = Новый Массив;
	Для А=1 По Записей Цикл		
		Состояние("Выводится запись "+А+" из "+Записей, Цел(А/Записей*100));
		Если Ф100 И (А>100) Тогда
			Прервать;
		КонецЕсли;
		База.Перейти(А); 
		
		СтруктураКолонок = Новый Структура;
		
		Если База.ЗаписьУдалена()=Истина Тогда
			СтруктураКолонок.Вставить("Удален","•");
		Иначе
			СтруктураКолонок.Вставить("Удален"," ");
		КонецЕсли;
		СтруктураКолонок.Вставить("N", А);
		Для Каждого Поле из База.Поля Цикл
			СтруктураКолонок.Вставить(Поле.Имя, База.ПолучитьЗначениеПоля(Поле.Имя));
		КонецЦикла;
		МассивСтруктур.Добавить(СтруктураКолонок);
	КонецЦикла;
	ДобавитьПоляВТЗ(МассивСтруктур);
	База.ЗакрытьФайл();
КонецПроцедуры

&НаСервере
Функция ПолучитьМакетНаСервере(ИмяМакета)
	ТекОбъект = РеквизитФормыВЗначение("Отчет");
	Возврат ТекОбъект.ПолучитьМакет(ИмяМакета);
КонецФункции

&НаКлиенте
Процедура ОсновныеДействияФормыСтруктура(Кнопка)	
	Если ИмяФайла = "" Тогда 
		Возврат;
	КонецЕсли;	
	База = Новый XBase;		
    База.ОткрытьФайл(ИмяФайла);
	МассивПолей = Новый Массив;
	Для Каждого Поле Из База.Поля Цикл
		МассивПолей.Добавить(Новый Структура("Имя, Тип, Длина, Точность", Поле.Имя, Поле.Тип, Поле.Длина, Поле.Точность));
	КонецЦикла;
	Таб = Новый ТабличныйДокумент;
	ОсновныеДействияФормыНаСервере(МассивПолей, Таб);
	База.ЗакрытьФайл();
	Таб.Показать("Структура файла DBF");
КонецПроцедуры

&НаСервере
Процедура ОсновныеДействияФормыНаСервере(МассивПолей, Таб)	
	Макет  = ПолучитьМакетНаСервере("Структура");
	Секция = Макет.ПолучитьОбласть("Шапка");
	Секция.Параметры.ИмяФайла = ИмяФайла;
	Таб.Вывести(Секция);
	Секция = Макет.ПолучитьОбласть("Повтор");	
	Для Каждого Поле Из МассивПолей Цикл
		Секция.Параметры.Заполнить(Поле);
		Таб.Вывести(Секция);
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ЗакрытьФорму(Команда)
	ЭтаФорма.Закрыть();
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ИмяФайла="";
	ФДОС = Истина;
КонецПроцедуры

DBF

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 22572 руб.

12.06.2017    136387    732    291    

393

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47411    202    64    

163

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69422    166    141    

112

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.226.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    20993    137    38    

96

SALE! 10%

Перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61618    44    27    

75

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34761    83    58    

81

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183543    564    508    

509

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    68337    41    124    

46
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. AleksSF 223 17.12.14 08:12 Сейчас в теме
Было бы хорошо, чтобы можно было редактировать и сохранять. Просто смотреть можно и в Excel.
2. cheiser1982 221 17.12.14 12:40 Сейчас в теме
(1) AleksSF, спасибо за совет, я думаю в ближайшее время добавлю и сохранение. Просто пока со временем туго.
3. ufedor 58 23.12.14 13:50 Сейчас в теме
Есть несколько комментариев:

1. Загрузка всего файла в память не всегда может быть нужна (и не всегда возможна). Особенно для отображения в управляемой форме. Нужно копать в сторону загрузки частями.
2. Всю обработку можно (и нужно) выполнять на клиенте. Зачем нужна передача на сервер, зачем массив структур?
3. Почему табличный документ? Вывод в виде таблицы на форму был бы логичнее.
4. Не проверяли скорость работы через ADO?
4. cheiser1982 221 24.12.14 06:14 Сейчас в теме
(3) ufedor, вся проблема в использовании таблицы значений - ее создание и редактирование полей на клиенте не поддерживается, так-же из-за этого я использую передачу массива структур. Насчет способов вывода (в качестве табличного документа или в виде таблицы), признаюсь, особо не заморачивался - что первым пришло в голову, то и применил.
По поводу загрузки частями полностью с Вами согласен.
Скорость не проверял.
Оставьте свое сообщение