1С Прогресс-бар "на сервере" для управляемого приложения в 9 строк кода

29.01.15

Разработка - Инструментарий разработчика

9 строчек кода, и можно следить за ходом выполнения длительных процедур на сервере, например загрузка из Excel.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
1СПрогресБарНаСервере
.epf 6,59Kb
22
22
1 SM
Скачать Купить за 1 850 руб.

Кто пытался определить - как долго будет отрабатывать процедура "на сервере" и "что вообще там происходит" - знает, что 1С не позволяет выводить сообщения, индикаторы, состояния во время выполнения процедуры. Все вываливается только после завершения процедуры.

Тут есть предложения по распаралеливанию, по использованию регламентных заданий. но это все очень громоздко!

 При загрузке больших объемов данных через управляемый интерфейс я пользуюсь индикацией текущего состояния заливки основанную на другом принципе.

Принцип основан на возможности в процедуре "на сервере" сохранить текстовый файл и существования мета - тега, который заставляет html страничку автоматически обновляться с определенной частотой. Главное, чтобы клиент имел доступ к html файлу.

Итак, нам надо :

- Записать информацию, которую хотим вывести пользователю, в текстовый файл с расширением html

- Инициировать запуск браузера с нашей сформированной html страничкой

- Заставить ее обновляться с определенной частотой

 

Все это можно сделать очень просто :

 

ПутьHTML         = "c:\idicator.html";
ОбновлениеСекунд = 1;
Текст = Новый ТекстовыйДокумент;
Текст.ДобавитьСтроку("<meta http-equiv=""refresh"" content="""+ОбновлениеСекунд+""">");
Текст.ДобавитьСтроку("Начало цикла");
Попытка
	Текст.Записать(ПутьHTML);
	ЗапуститьПриложение(ПутьHTML);
Исключение КонецПопытки;

 

Выжный момент! Записывать в файл текущее состояния нужно порциями, а не каждую итерацию, ибо это достаточно медленная операция, вот пример текста работающей обработки :

 

&НаСервере
Процедура ОповеститьПользователя(ТекстСообщения,ОбновлятьСообщение,ОбновлениеСекунд,ОткрытьHTML = Ложь)
	ПутьHTML         = "c:\idicator.html";
	Текст = Новый ТекстовыйДокумент;
	Если ОбновлятьСообщение Тогда
		Текст.ДобавитьСтроку("<meta http-equiv=""refresh"" content="""+ОбновлениеСекунд+""">");
	КонецЕсли;
	Текст.ДобавитьСтроку(ТекстСообщения);
	Попытка
		// может не быть доступа к файлу на запись
		// что-бы не вылетать по исключению использую попытку
		Текст.Записать(ПутьHTML);
	Исключение КонецПопытки;
	Если ОткрытьHTML Тогда
		ЗапуститьПриложение(ПутьHTML);
	КонецЕсли;	
КонецПроцедуры	

&НаСервере
Процедура НачатьДлительнуюПроцедуруНаСервереНаСервере()
	ВремяНачала      = ТекущаяДата();
	КвоВПорции       = 1000;// через сколько итераций сохранять текущее состояние в файл
	Счетчик          = 0;
	ОбновлениеСекунд = 1;
	КоличествоИтераций = 600000;

	ОповеститьПользователя("Начало цикла", Истина, ОбновлениеСекунд, Истина);

	Для Итератор = 1 По КоличествоИтераций Цикл
		Счетчик = Счетчик + 1;
		Если Счетчик >= КвоВПорции Тогда
			Счетчик = 0;
			ОповеститьПользователя("Обработано "+СокрЛП(Итератор)+" из "+СокрЛП(КоличествоИтераций),Истина,ОбновлениеСекунд);
		 КонецЕсли;
	КонецЦикла;	

	ОповеститьПользователя("Обработка завершена за "+СокрЛП(ТекущаяДата()-ВремяНачала)+" секунд!",Ложь,ОбновлениеСекунд);
КонецПроцедуры

&НаКлиенте
Процедура НачатьДлительнуюПроцедуруНаСервере(Команда)
	НачатьДлительнуюПроцедуруНаСервереНаСервере();
КонецПроцедуры

Прогресс Progress Индикатор

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    141018    774    391    

803

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    11648    31    6    

61

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    14171    35    27    

78

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    7338    27    4    

51

SALE! %

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    182024    1104    0    

876

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    101193    243    97    

304

Инструментарий разработчика Перенос данных 1C Программист Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы. Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение для 1С, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    24535    17    15    

34

Инструментарий разработчика Программист Платформа 1С v8.3 Управляемые формы Платные (руб)

"Фреймворк для Расширений 1С" это универсальное и многофункциональное решение, упрощающее разработку и поддержку создаваемых Расширений. Поставляется в виде комплекта из нескольких Расширений с открытым исходным кодом. Работает в любых Конфигурациях в режиме Управляемого приложения с режимом совместимости 8.3.12 и выше без необходимости внесения изменений в Конфигурацию.

3000 руб.

27.08.2019    19478    7    8    

42
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. caponid 29.01.15 10:42 Сейчас в теме
+
Только надо помнить, что запуск будет от имени пользователя, под которым выполняется сервер 1С
2. alexinzaz 29.01.15 12:27 Сейчас в теме
И файл, собственно, тоже на сервере.
Идея интересная, но, к сожалению, запись в файл не добавляет быстродействия((
KhromovA; delete; +2 Ответить
6. algol.ua 43 29.01.15 17:27 Сейчас в теме
(2) alexinzaz, да, но писать файл можно с интервалами по времени, количеству
3. ATA 2 29.01.15 12:34 Сейчас в теме
Очень прикольно... Спасибо! Пригодицца ))
4. pbazeliuk 1964 29.01.15 17:10 Сейчас в теме
Вероятнее всего, автор не сталкивался в работе с компаниями в которых онлайн в базе больше 250 человек. Запись в файл плохое решение, при высокой нагрузке серверов клиентов переводят на тонкий клиент (веб-сервер), а доступ к серверной службе 1С и серверам закрывают.
mixelx; delete; dj_serega; +3 Ответить
5. algol.ua 43 29.01.15 17:25 Сейчас в теме
(4) pbazeliuk, 250 человек из экселя грузить ничего не будут. и да - я написал, что нужно иметь доступ к этому файлу, а так это не панацея.
7. spec8s 837 29.01.15 19:31 Сейчас в теме
Интересно, думали ли Вы, как этот код будет работать в клиент-серверном варианте? И где должен будет открыться браузер.
Aleks_Antonuk; delete; +2 Ответить
8. algol.ua 43 29.01.15 21:53 Сейчас в теме
(7) spec8s, в клиент-серверном варианте можно не использовать ЗапуститьПриложение(ПутьHTML); а открывать его самостоятельно, из предварительно расширенной папки. Лично я так и делал. Вообще делано для себя, для того, чтобы мог понимать масштабы временных затрат
9. нормальный такой 93 30.01.15 11:02 Сейчас в теме
ну что за ерунда...
учитесь пользоваться 1С а не изобретать костыли!


Кто пытался определить - как долго будет отрабатывать процедура "на сервере" и "что вообще там происходит" - знает, что 1С не позволяет выводить сообщения, индикаторы, состояния во время выполнения процедуры. Все вываливается только после завершения процедуры.

Тут есть предложения по распаралеливанию, по использованию регламентных заданий. но это все очень громоздко!


Все 1с вам позволяет, это вы ленитесь. покурите про фоновые задания и про метод ПолучитьСообщенияПользователю()
Не надо хаять платформу и прятать за этими обвинениями свою некомпетенцию.
Deslime; AneJIbcuH; SkyJack; for_sale; gradi; Shkalar; e.a.afanasyev; Aleks_Antonuk; 2man; Puk2; zqzq; PrinzOfMunchen; CSiER; delete; biz-intel; MrUnnamed; Yashazz; JesteR; dj_serega; +19 Ответить
10. dj_serega 393 30.01.15 15:10 Сейчас в теме
(9) нормальный такой, Полностью согласен. Правда тут нюанс, по-крайней мере у меня. Я не смог получить НЕ выведенные сообщения. Всегда получаю все :(
Результаты от "МассивЗаданий[0].ПолучитьСообщенияПользователю(Ложь)" и "МассивЗаданий[0].ПолучитьСообщенияПользователю(Истина)" один. В массиве все сообщения.

upd: Нашел причину. Те сообщения которые мы получим в процессе работы фонового задания удаляются. Сообщения которые получаем после не удаляются.
11. нормальный такой 93 30.01.15 16:10 Сейчас в теме
(10) dj_serega, и это плохо?
пример моего использования

получать процент обработки данных:
в фоновоом задании через Сообщить() передаю процент обработанных данных
через обработчик ожидания дергаю моё фоновое задание и получаю массив сообщений
ПолучитьСообщенияПользователю(Ложь)
- использование флага Ложь, не очистит накопленные сообщения.
ПолучитьСообщенияПользователю(Истина)
- использование флага Истина, очистит накопленные сообщения.

Есть массив сообщений где содержатся строки (проценты выполнения), получаем последнее сообщение - больше для нас не нужно, и выводим этот процент через
Состояние(<ТекстСообщения>, <Прогресс>, <Пояснение>, <Картинка>)
12. dj_serega 393 30.01.15 16:24 Сейчас в теме
(11) нормальный такой, Опишу что меня смутило.
Было 20 сообщений. 10 получили в процессе выполнения. 10 осталось.
После выполнения мы всегда будем получать последнюю 10-ку.
Если мы, после выполнения, нажмем 10 раз на получить НЕ полученные сообщения то получим 10 раз по 10 дублей сообщений :(
- использование флага Истина, очистит накопленные сообщения.

Получается что он (флаг истина) очистит накопленные прочитанные в процессе выполнения. Какие не успели прочитать в процессе будут в массиве.
28. Gaster 23.10.23 16:29 Сейчас в теме
(11) Я так понимаю если в процедуре мы уже используем информативные сообщения через Сообщить(), то они также очистятся. Ими надо пожертвовать?
14. algol.ua 43 31.01.15 01:24 Сейчас в теме
(9) нормальный такой, конечно ленюсь, от того идеи и рождаются. а метод на фоновых заданиях не работает с файловым вариантом, а смотреть за процессом нужно, а открывать в обычном приложении не удобно, если конфа на управляемых формах, а времени мало, а тут количество кода минимум, и в основной конфигурации добавлять никаких процедур не нужно

Платформу не хаял, потому как понятно для чего так сделано, за обвинение в некомпетентности особое спасибо ) хамите, батенька
17. dj_serega 393 31.01.15 13:32 Сейчас в теме
(14) algol.ua,
а метод на фоновых заданиях не работает с файловым вариантом
как это не работает?
18. algol.ua 43 31.01.15 13:54 Сейчас в теме
(17) dj_serega, сорри, я имел ввиду не работает как нам надо, цитирую комментарий из http://infostart.ru/public/159607/
"В файловом варианте задания всегда выполняются последовательно одно за другим, в отличие от клиент-серверного варианта, где несколько заданий могут выполняться параллельно в одном и том же рабочем процессе или в разных рабочих процессах и даже на разных компьютерах. Поэтому, выделенного клиента, занимающегося обработкой заданий, не рекомендуется использовать для других целей, т.к. это может негативно повлиять на производительность выполнения заданий.

Клиенты в файловом варианте не имеют прямой связи с планировщиком заданий и взаимодействуют с ним через файл обмена, который находится в каталоге информационной базы (в клиент-серверном варианте клиенты соединены с планировщиком по TCP/IP, что позволяет избежать задержек при назначении заданий на выполнение). Поэтому при обработке заданий возможны небольшие задержки, связанные с тем, что планировщик читает файл обмена и получает очередную порцию заданий на выполнение только после того, как завершит выполнение полученных ранее заданий.

www.bit.ly/TO6csq"
13. fishca 1256 30.01.15 22:19 Сейчас в теме
В многосерверном кластере как этот метод будет работать ;) ?
15. algol.ua 43 31.01.15 01:28 Сейчас в теме
(13) fishca, отлично будет работать, если имя файла будет к примеру "smb:\\192.168......\\share\indicator.html" ;)
16. Aleksey.Bochkov 3671 31.01.15 08:22 Сейчас в теме
Как вариант можно еще хранилище настроек использовать.
Клиент запускает длительную процедуру в виде фонового задания, фоновое задание периодически пишет статус в хранилище настроек, а клиент в обработчике ожидания читает и отображает результат.
Из плюсов - передавать можно любые типы данных, а не только строки.
Из минусов - статус пишется в СУБД. Но всего одна строка, и в таблицу, которая есть во всех базах 1С независимо от конфигурации.
Через временное хранилище также можно обмениваться любыми данными с фоновыми заданиями, но там значение передается в родительский сеанс только по завершению процедуры.

Вроде работает неплохо :).

Клиент:
&НаСервере
Процедура ЗапуститьДлительнуюПроцедуруНаСервере()
	
	ФоновыеЗадания.Выполнить("ОбщегоНазначения.ДлительнаяПроцедура");
	
КонецПроцедуры

&НаКлиенте
Процедура ЗапуститьДлительнуюПроцедуру(Команда)
	
	ЗапуститьДлительнуюПроцедуруНаСервере();
	
	ПодключитьОбработчикОжидания("ПоказатьСтатус", 2);
	
КонецПроцедуры

&НаКлиенте
Процедура ПоказатьСтатус()
	
	Результат = ДанныеИзХранилищаНастроек();
	
	Если ТипЗнч(Результат) = Тип("Структура") Тогда
		
		Строка = Результат.Строка;
		Число = Результат.Число;
		
	КонецЕсли;	
	
КонецПроцедуры


&НаСервере
Функция ДанныеИзХранилищаНастроек()
	
	Возврат ХранилищеОбщихНастроек.Загрузить("ДлительнаяПроцедура");
	
КонецФункции
Показать


Задание:
Процедура ДлительнаяПроцедура() Экспорт  	
	
	Для Сч = 1 По 100000 Цикл
		
		Об = Справочники.Номенклатура.СоздатьЭлемент();
		Об.Наименование = Сч;
		Об.Записать();		
		
		Если Сч % 500 = 0 Тогда
			ХранилищеОбщихНастроек.Сохранить("ДлительнаяПроцедура",, Новый Структура("Строка,Число", "Обработано: " + Сч, Сч));	
		КонецЕсли;
		
	КонецЦикла;	
	
КонецПроцедуры
Показать
Прикрепленные файлы:
1Cv8.dt
19. algol.ua 43 31.01.15 13:59 Сейчас в теме
кстати, исходя из этого, нивелируется огрехи в сторону записи информации для вывода в файл. Получается в файловом варианте мой метод будет быстрее. т.к. и пишу я меньше в файл, и часть ресурса переносим на браузер для отображения информации. Если я правильно все понимаю.
20. Shkalar 04.02.15 13:23 Сейчас в теме
1. Имя файла для каждого задания должно генерироваться, т.к. запускаться может несколько процессов и у нескольких пользователей, а позволять себе такое в рабочей многопользовательской базе - бред.

2. Даже если папка будет сетевой то еще необходимо вывести шару наружу, что зачастую запрещено.


P.S. Писать на "c:\\" не комильфо, т.к. обычно доступ программе урезается по самое немогу.

А вообще метод-как метод, даже несмотря на некоторые особенности реализации, ведь меняется только метод доставка статуса - либо мы это делаем "кошерно" через сообщения/бд либо общедоступные для всех файлы.
algol.ua; +1 Ответить
21. Yashazz 4762 08.02.15 19:38 Сейчас в теме
Вот так в очередной раз мы сталкиваемся с недоработкой или явным косяком 1С, после чего начинается изобретение обходных костылей разной степени извратности, а годика через два 1С снисходит к нашим нуждам и, вуаля, однажды наступает щастье. Я это к чему - к тому, что и способ, предлагаемой самой 1С, процитированный выше, он тоже работает криво, а иногда и вовсе не. Как показывают эксперименты, на 8.2 вообще всё с этим криво, на 8.3 чуть лучше.
22. dj_serega 393 12.02.15 18:10 Сейчас в теме
(21) Yashazz, Не согласен что в 1С это криво. Вполне удобно и работоспособно.
23. Yashazz 4762 03.03.15 17:16 Сейчас в теме
(22) dj_serega, значит, вы просто не сталкивались. На 8.2. это просто шоу, фильм ужасов. Проверено, увы, неоднократно.
24. independ 1542 07.06.19 04:39 Сейчас в теме
Попробовал вместо HTML использовать HTA получилось очень неплохо
Прикрепленные файлы:
indicator.hta
algol.ua; D.B.Sokolov; +2 Ответить
25. D.B.Sokolov 74 07.06.19 10:11 Сейчас в теме
(24) Как работает кнопка "Прервать"?
26. independ 1542 07.06.19 10:44 Сейчас в теме
(25) Она просто закрывает hta-окно, а так можно что угодно сделать, например создать файл-флаг, и в 1с проверять его наличие и прерывать работу
D.B.Sokolov; +1 Ответить
27. 1cprogr_nsk 108 08.06.20 14:08 Сейчас в теме
Добрый день. Кто-нибудь пробовал сделать прогресс-бар получения файла-сообщения в подчинённом узле РИБ? например: В Подчинённом узле запускаем синхронизацию данных, 1С читает каталог (или FTP) и скачивает файл-сообщение, потом его читает и показывается стандартный прогресс бао "Обработано 1000 записей из 10000000" и т.д, но проблема в том, что файл этот может быть очень большой (например долго не выполнялся обмен и файл > 50МБайт и канал не очень быстрый), тогда для пользователя стандартный прогресс-бар выглядит на 0%, пока идет скачивание файла, п скачиваться он может и 10 минут, июзер может не выдержать и отменить задание. У кого какие мысли?
Оставьте свое сообщение