Скидка (наценка) процентом на самые дешевые позиции в чеке

11.11.18

Задачи пользователя - Прайсы

Внешняя обработка для УТ11, добавляющая скидку (наценку) процентом на самые дешевые позиции в чеке кратно условиям.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
СкидкаНаценкаПроцентНаСамыеДешевые.epf
.epf 9,10Kb
69
69
1 SM
Скачать Купить за 1 850 руб.

Данная обработка позволяет вводить скидки процентом не на все позиции в чеке, а на самые дешевые позиции, кратно выполнению условий скидки. Данный тип скидок позволяет увеличить количество позиций в чеке. Пример условий для скидки: Сумма в документе не менее 2 000 руб., Количество в документе не менее 2 ед.. В результате на каждый второй товар при условии, что сумма чека не менне 2000 будет выдана скидка (например 20 %).

Обработка сделана на основе примера из поставки УТ 11. Основной кусок кода отвечающий за расчет скидки.

// Выполняет расчет скидки (наценки)
//
// Параметры:
//	СкидкаНаценка - Строка дерева скидок (наценок). Включает результаты проверки условий, способы совместного применения
//	Настройки - Структура - Настройки, заданные пользователем в форме настроек внешней обработки
//	Товары - Коллекция товаров, для которых требуется применить скидку (наценку)
//	ПараметрыРасчета - Структура - Параметры расчета скидок (наценок)
//
// Возвращаемое значение:
//	РезультатРасчета - ТаблицаЗначений - результат расчета
//
Функция Рассчитать(СкидкаНаценка, Настройки, Товары, ПараметрыРасчета) Экспорт
	
	РезультатРасчета = СкидкиНаценкиСервер.ПустаяТаблицаСкидокСРасшифровкой();
	СкидкаНаценка.ИспользоватьКратность = Истина;
	ТаблицаСтоимостейТоваров = Новый ТаблицаЗначений;
	ТаблицаСтоимостейТоваров.Колонки.Добавить("Цена", Новый ОписаниеТипов("Число"));
	ТаблицаСтоимостейТоваров.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число"));
	ТаблицаСтоимостейТоваров.Колонки.Добавить("КлючСвязи", Новый ОписаниеТипов("Число"));
	
	Для Каждого Товар Из Товары Цикл
		
		Если Товар.Количество = 0 Тогда
			Продолжить;
		КонецЕсли;
		
		НоваяСтрока = ТаблицаСтоимостейТоваров.Добавить();
		НоваяСтрока.Цена       = Товар.Сумма / Товар.Количество;
		НоваяСтрока.Количество = Товар.Количество;
		НоваяСтрока.КлючСвязи = Товар.КлючСвязи;
		
		
	КонецЦикла;
	ТаблицаСтоимостейТоваров.Сортировать("Цена Возр");
	
	ЧислоСкидок = СкидкиНаценкиСервер.КратностьВыполнения(СкидкаНаценка);
	ЧислоСкидокИсх = ЧислоСкидок;	
	ЗначениеСкидки = 0;
	Если Настройки <> Неопределено Тогда
		Попытка
		  	ЗначениеСкидки = Настройки.ЗначениеСкидки;
		Исключение
		КонецПопытки; 
	КонецЕсли;
	МассивТоваровДляСкидок = новый Массив;
	а = 0;
	Пока ЧислоСкидок > 0 Цикл
		ЧислоСкидок = ЧислоСкидок -1;
		КлючСвязи = ТаблицаСтоимостейТоваров[а].КлючСвязи;
		Для Каждого Товар Из Товары Цикл
			Если Товар.КлючСвязи = КлючСвязи Тогда
				Если МассивТоваровДляСкидок.Найти(Товар) = неопределено Тогда
					ЧислоСкидок = ЧислоСкидок - (Товар.Количество - 1);
					МассивТоваровДляСкидок.Добавить(Товар);
				КонецЕсли;
				
			КонецЕсли;
		КонецЦикла;
		а = а+1;
		
	КонецЦикла;	
	
	ЭтоУмножение = СкидкаНаценка.ПрименятьУмножениеВРамкахВышестоящейГруппы;
	
	
	Для Каждого Товар Из МассивТоваровДляСкидок Цикл
		
		Сумма =  ЗначениеСкидки / 100 * СкидкиНаценкиСервер.ОстатокСуммыПоСтроке(СкидкаНаценка, Товар, ПараметрыРасчета, ЭтоУмножение) * Мин(ЧислоСкидокИсх, Товар.Количество) / Товар.Количество;
		
		СкидкиНаценкиСервер.ПрименитьЗначениеСкидкиКТовару(СкидкаНаценка, Сумма, Товар, РезультатРасчета, ПараметрыРасчета);
		ЧислоСкидокИсх = ЧислоСкидокИсх - Мин(ЧислоСкидокИсх,Товар.Количество);
	КонецЦикла;
	
	Возврат РезультатРасчета;
	
КонецФункции

Обработка добавляется как обычно в справочник "Дополнительные отчеты и обработки". После добавления обработки, в справочнике "Скидки (наценки)" появится новый тип скидки "Процент на самые дешевые товары". Установка размера скидки производится с помощью кнопки "Настроить", все остальное стандартно.

Обработка разрабатывалась и тестировать на УТ 11.4.3.126. Платформа 8.3.12.1616

Скидки Наценки Розница УТ 11 Управление торговлей Внешняя обработка

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    92854    118    40    

209

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    167901    738    364    

393

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    779656    4727    9507    

2809

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

25000 руб.

14.10.2022    8320    10    13    

8

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111412    28    114    

181

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    325364    1870    3029    

1011
Оставьте свое сообщение