Альтернативная обработка "Выбор периода"

Публикация № 1029378

Разработка - Работа с интерфейсом

обработка ввод периода

Альтернативная обработка ввода периода для 1С 7.7.

Альтернативная обработка ввода периода.

Необходимые условия: 

1. 1с 7.7

2. Внешняя компонента Formex

Внедрение:

1. Встроить в раздел "Обработки" скачанную обработку и настроить на нее права

2. В начале глобального модуля:

Перем глНачДатаПериода Экспорт;  
Перем глКонДатаПериода Экспорт; 

3. В глобальном модуле:

Процедура глВвестиПериод(локНачДата,локКонДата) Экспорт 
	
	спПар = СоздатьОбъект("СписокЗначений");   
	спПар.ДобавитьЗначение(локНачДата);  
	спПар.ДобавитьЗначение(локКонДата);  
	
	ОткрытьФормуМодально("Обработка.ВыборПериода",спПар);
	
	Если (ПустоеЗначение(глНачДатаПериода)=0) и (ПустоеЗначение(глКонДатаПериода)=0) Тогда
		локНачДата = глНачДатаПериода; 
		локКонДата = глКонДатаПериода;
	КонецЕсли;
	глНачДатаПериода = "";
	глКонДатаПериода = "";
	
КонецПроцедуры //глВвестиПериод()

//**************************************************************************
Процедура глПроверкаДаты(ДатаНачала,ДатаКонца,локТА=1,локОДНО=1) Экспорт
	
	Если ПустоеЗначение(ДатаНачала)=1 Тогда
		ДатаНачала = ?(локТА=1,ПолучитьДатуТА(),ТекущаяДата());
	КонецЕсли;
	Если ПустоеЗначение(ДатаКонца)=1 Тогда
		ДатаКонца = ?(локТА=1,ПолучитьДатуТА(),ТекущаяДата());
	КонецЕсли; 
	
	Если (ДатаНачала>ПолучитьДатуТА()) и (локТА=1) Тогда
		ДатаНачала = ПолучитьДатуТА();	
	КонецЕсли;	
	Если (ДатаКонца>ПолучитьДатуТА()) и (локТА=1) Тогда
		ДатаКонца = ПолучитьДатуТА();	
	КонецЕсли;
	
	Если (ДатаНачала<=Константа.ДатаПоследнегоЗавершенияПериода) и (локОДНО=1) Тогда
		ДатаНачала = Константа.ОсновнаяДатаНачалаОтчета;
	КонецЕсли;  
	
	Если ДатаНачала>ДатаКонца Тогда 
		ДатаНачала = ДатаКонца; 
	КонецЕсли;
	
КонецПроцедуры //глПроверкаДаты()

Вызов:

глВвестиПериод(ДатаНачала,ДатаКонца);

где ДатаНачала и ДатаКонца - реквизиты формы типа "Дата" или переменные модуля формы для значений типа "Дата"

Особенности:

Используется Константа.ОсновнаяДатаНачалаОтчета, хранящая начальную дату действующего периода базы

Используется Константа.ДатаПоследнегоЗавершенияПериода

Шрифт на табло выбранных дат "wst_engl.fon"

Скачать файлы

Наименование Файл Версия Размер
Альтернативная обработка "Выбор периода":

.ert 216,00Kb
27.03.19
3
.ert 216,00Kb 3 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. wer_alex 28.03.19 16:25 Сейчас в теме
Не заработало . Дополнительно объявил пременные Перем глКрасный,глСиний,глТемноСерый,глЧерный,глБелый;
Обработка на них ругается. Нет функции глПадежП. При запуске обработка зациклилась и и ответ системы " Не хватает оперативной памяти." Автору просьба сделать обработку работоспособной
2. v.a.n- 2 28.03.19 20:52 Сейчас в теме
Прошу прощения.
Не все связи со своей базой увидел.
Высылаю исправленную обработку. Глобальные переменные цветов не нужны. Я их в обработку поместил.
И напоминаю, без Formex работать не будет (у меня версия 2.0.5.109 beta).
Если что не так, пишите.
Прикрепленные файлы:
Выбор периода.ert
3. v.a.n- 2 28.03.19 21:09 Сейчас в теме
Снял небольшое видео, как это работает
Прикрепленные файлы:
Пример использования.mp4
4. CheBurator 3430 30.03.19 01:30 Сейчас в теме
а что мешало автору описание этой обработки поместить в само описание обработки? (дада! есть такая закладочка в форме обработки) - здоровый похренизм?
5. v.a.n- 2 30.03.19 10:49 Сейчас в теме
Ничего не мешало. И про закладочку знаю. Привык описание делать для пользователей, т.е. объяснять, как пользоваться обработкой. А что здесь то описывать? Как в переключатели тыкать или кнопки "вверх"/"вниз" нажимать? А вкладывать в описание процесс внедрения в конфигурацию? Не знаю. Вообще у меня это первый опыт выкладывания 1с обработок, хотя понаписано очень много интересного. Может я и не прав. Строго не судите, лучше подскажите :)
6. CheBurator 3430 30.03.19 13:19 Сейчас в теме
"А вкладывать в описание процесс внедрения в конфигурацию? "
именно. как минимум.
а то ты видать исходишь что кроме твоей обработки никаких других в информационном пространстве - нет...
.
в итоге сдернул твою обработку сеюе.
скопипастил описание в описание.
скопипастил УРЛ ЭТОЙ СТРАНИЦЫ В ОПИСАНИЕ
.
потом пришлось это все повторить для повторно сгруженной исправленной из коментов.
7. v.a.n- 2 30.03.19 16:56 Сейчас в теме
Понятно. Буду знать. Спасибо за разъяснение. Жалко, что нельзя обновлять обработку изначальную. Приходится выкладывать дополнительно. Неудобно.
8. obmanOZ 23 10.04.19 14:52 Сейчас в теме
Добрый день! А ваша разработка подходит только для отчетов? или в журналах также можно пользоваться?
9. v.a.n- 2 10.04.19 21:23 Сейчас в теме
Конечно можно. И в журналах, и в документах, и в отчетах.
10. v.a.n- 2 10.04.19 21:37 Сейчас в теме
Хотя в журналах я поторопился. В журналах своя тачанка. Сам использую в документах, отчетах и обработках
11. v.a.n- 2 11.04.19 11:17 Сейчас в теме
В журналах обработку можно использовать только по отдельной кнопке.
Формула кнопки: ВыборИнтервала()
В модуле формы журнала:

Процедура ВыборИнтервала() 
	
	ДатаН = НачалоИнтервала();
	ДатаК = КонецИнтервала();
	глВвестиПериод(ДатаН,ДатаК);
        УстановитьИнтервал(ДатаН,ДатаК,1);                          
	
КонецПроцедуры //ВыборИнтервала()
Оставьте свое сообщение

См. также

Картинки и дополнительное описание в номенклатуре

Работа с интерфейсом Обработка справочников Оптовая торговля Оптовая торговля Обработки v7.7 1С7:ТиС Абонемент ($m)

Картинки и дополнительное описание в номенклатуре ТиС (без изменения конфигурации).

1 стартмани

16.02.2018    9614    0    Jill    0