Экспорт налоговых накладных в XML (Украина). Импорт даты внесения в реестр ДПА из системы документооборота М.E.Doc

Публикация № 103817 06.01.12

Задачи пользователя - Обработка документов

Обработка (для 1С 7.7. АБТ 3.5.5 и выше)  позволяет сделать экспорт проведенных налоговых накладных указанной Организации за выбранный период по указанному пути с последующим импортом в OPZ или М.E.Doc.
Также выполняется импорт результатов внесения в реестр ДПА (даты занесения в реестр) из М.E.Doc в 1С.

Данная обработка позволяет экспортировать Ваши налоговые накладные за указанный период и сохраняет по пути, встроенному в отчет, в формате XML OPZ или BEST(последний неупакован и до конца не изучен - поля кирпичного цвета - пользоваться им рекомендуется осторожно)  в файлах, имена которых выглядят следующим образом:

[номер из цифр, начиная с  с 5-й  - впереди, обычно, идет разделитель учета и тире]_[месяц]_[год].xml

Путь для сохранения "спрятан". чтобы рядовой бух не сохранял где попало. Другие параметры настройки экспорта минимальны, но необходимы -
- диапазон дат, за который будет проводиться экспорт;
- предельная сумма НДС неподакцизных товаров, которые не обязательно включать в реестр;
- флажок, отвечающий за выгрузку НН неплательщиков НДС;
- флажок, отвечающий за повторную выгрузку уже выгруженных ранее документов;
- флажок, отвечающий за повторное вычисление признака подакцизного товара;
- фирма, по которой собственно и будет проводится выгрузка документов;
- формат вывода - OPZ или BEST.

Перед экспортом Вы можете создать список НН для просмотра на экране и ручного снятия/установки флажка - признака выгрузки.


Особенности экспорта

При смене "Даты С" автоматически идет присвоение такого же значения "Дате По" - обычно, экспортируют за 1 день. При открытии программы "Дате С" автоматически назначается предыдущий день.


Экспортирование

В ходе экспора получаете сообщения в окне уведомлений о номерах и общем количестве выгруженных документов.


Импортирование в М.E.Doc

Открываете М.E.Doc, переходите в раздел "Главное меню" -> "Податкові накладні". Выбираете необходимый период отчетности - месяц, год.
Далее - "Файл" -> "Импорт XML"-> открываете вашу папку с только что экспортированными накладными и выделяете все необходимые. Если не знаете, какие именно Вам нужны - отсортируйте список файлов по дата создания и выберите те, которые только что создались - они должны быть самыми первыми.  В системе OPZ Вам придется импортировать их по одной. Или изменить процедуру присвоения имени файла,  присвоив ему имя в стандарте ДПА, и путь. заменим его на папку "OPZ / XML". Затем выполнить через пункт меню команду "Синхронизация".
Обе программы задумаются на какое-то время. Список импортированных/сбойных НН в МеДОС Вам покажут в виде всплывающего экранного сообщения, а в OPZ Вы самостоятельно должны будете отследить их количество по пунктам в меню открываемых документов.

В М.E.Doc все импортированные НН хранятся в одноименной папке, отображающей их статус. После того, как Вы их проверите, подпишете (скопом получится только в случае занесенных Контрагентов во внутреннюю базу М.E.Doc) и отправите в ДПА, можете отдохнуть до получения ответных сообщений. Описывать процедуры проверки/исправления ошибок  я не вижу смысла.

Импортирование принятых НН из М.E.Doc

Открываете М.E.Doc и  переходите к НН в папке  "Зарєестровані". Выбираете пукнт меню "Файл" -> "Експортувати в DBF дату реєстрації  в ЄРПН". Выбираете папку и интервал экспорта и получаете там файл примерно такого имени     "OUTNAKLKVT.dbf"

Зайдя в программу 1С вы открываете отчет и перейдя на вкладку "Загрузка" выбираете это файл как параметр импорта. При импорте, в случае его успешного окончания, в поле НН, отведенное для хранения даты внесения в ЄРПН, будет загружена дата внесения в реестр.


Настройки

Для корректной работы необходим справочник "НалоговыеИнспекции". Если его у Вас нет  -  занесите ее код вручную в соответствующее поле. Также проверьте правильность имен полей - признаков выгрузки и поля для загрузи даты регистрации в ДПА.


Особенности

Замечено, что М.E.Doc не позволяет скопом подписать импортированные накладные, если клиентов нет в его справочнике. БЭСТ

Формат XML-отчета MeDoc'а отличается от стандарта (OPZ) наличием 6-ти "лишних" полей.

Необходимости в изменении имен СправочниковФирмы, Клиентов и Документа.НалоговаяНакладная на полный перечень с возможностью выбора я не вижу  смысла - это не универсальная обработка для любого документа и любой конфигурации.


Планы       

Расшифровать окончательно формат БЭСТА и найти способ упаковки отчета в формат Packed_XML.
Убрать ошибку 1С с программным сбоем переключения закладки.
 
 
 P.S.

Утилита распаковки Packed_XML найдена. Путь - opz.org.ua/forum/viewtopic.php?f=1&t=933#p6428. А вот упаковки пока нет...


 

17/01/2012

Добавлена отдельная утилита импорта даты внесения в реестр из М.E.Doc

С ее помощью Вы можете внести из М.E.Doc в Реквизит типа "Дата" НалоговойНакладнуой  1С (АБТ 3.5.5 и выше) дату внесения в реестр ДПА.

 

Как пользоваться

Открываете М.E.Doc и  переходите к НН в папке  "Зарєестровані". Выбираете пукнт меню "Файл" -> "Експортувати в DBF дату реєстрації  в ЄРПН". Выбираете папку и интервал экспорта и получаете там файл примерно такого имени    

                         "OUTNAKLKVT.dbf"

Зайдя в программу 1С вы открываете отчет, выбираете этот файл как параметр импорта.
При импорте, в случае его успешного окончания, в поле НН, отведенное для хранения даты внесения в ЄРПН, будет загружена дата внесения в реестр.


Настройки

Правильно укажите диапазон знаков, по  которым будет сверяться номер НН.
Не используйте длинные имена файлов.

Скачать файлы

Наименование Файл Версия Размер
EPRN.ert (+БЕСТ)

.ert 250,00Kb
51
.ert 250,00Kb 51 Скачать
Packed XML Extractor

.exe 11,00Kb
23
.exe 11,00Kb 23 Скачать
Импорт_даты_ЄРПН

.ert 33,50Kb
9
.ert 33,50Kb 9 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. kompas-dm 781 07.01.12 12:11 Сейчас в теме
(0) Все-таки нужно усложнить:
1.Сначала заполнить таблицу на форме, пусть посмотрят и пометят документы для выгрузки.
2.Дать переменные для дозаполнения : свои коды по организации, налоговой инсп. и т.д.
И будет в шоколаде. Нужная Обработка, "+"
seidametov-a; +1 Ответить
2. Sykoku 101 07.01.12 21:56 Сейчас в теме
(1) kompas-dm,
Не вопрос, сделаю - оглашайте весь список. Моей "конфе" больше 10-ти лет. За это время она раза в три "толще" стала. У других - аналогично, я думаю.
30. Sykoku 101 17.01.12 12:54 Сейчас в теме
(1) kompas-dm,

Усложнил, почти до безобразия...
59. seidametov-a 13.02.12 17:40 Сейчас в теме
(1) kompas-dm, Хорошая выгрузка, удобная, к своей нестандартной базе прикрутил на УРА!!! Только много мелких недоработок, например точки в датах. Но в общем работает отлично. Спасибо +
3. Sykoku 101 07.01.12 21:56 Сейчас в теме
Сделал в черновом виде выброс в БЭСТ-формате - не все поля пока ясно, как заполнять. Скажу откровенно - ИнтеллектСервисовцы структуру создавали явно на скорую руку ...
4. smitti911 10.01.12 12:05 Сейчас в теме
5. Sykoku 101 10.01.12 12:44 Сейчас в теме
(4) smitti911,

Уточняем.
1. Релизы 1С разные
2. Ваш требует дополнительных "телодвижений" - проверки наличия шаблона, ВК, настройки.
3. Нумерация НН, согласно описания к обработке, может не совпасть с номером документа.
4. Если это экспорт только НН, зачем там с полсотни шаблонов OPZ, которые отношения к НН не имеют никакого, тем более, если они не актуальны...
5. Ну и, наконец, просто выдает с десяток ошибок при работе.
6. Sykoku 101 10.01.12 14:45 Сейчас в теме
Дополнения.

1. В талице XML
<HORIG1>[?(Число(КлиентНалогНомер)<>0," ","1")]</HORIG1>
<HTYPR>[?(Число(КлиентНалогНомер)<>0," ","02")]</HTYPR>


2. Во вложении - для БУ Украины, проверено на 7.70.259

P.S.
Форму БЭСТ для БУУ не переделывал - по заявкам.
Прикрепленные файлы:
EPRN.ert
10. Noy 1074 12.01.12 11:07 Сейчас в теме
(6) На всякий случай уточню:
Если Число(КлиентНалогНомер)=0 то такие налоговые вообще не надо регистрировать
11. Sykoku 101 12.01.12 11:28 Сейчас в теме
(10) Noy,
В законе сказано ВСЕ, в которых есть импортный товар. То, что клиент не обратится за возмещением НДС не означает, что я ее не обязан регистрировать. Лучше "перебдеть".
А вот что достойно воспевания потомками, так это список ответов налоговой, представившей форму заполнения с кодами ТНВЕД, разделенными по классам (пробелы), но указавшей в комментарии, что заполнение должно быть без пробелов.
Кстати, вчера один бух был жутко перепуган, когда после 19-00 в МЕДОС вернулась квитанция с требованием до полуночи срочно зарегистрировать коригування по 2-м накладным. И еще с десяток пришли с милым сообщением что "Продавець не є платником ПДВ станом на 05.01.2012". Оказалось, что это просто их сервер был слегка перегружен...
12. Noy 1074 12.01.12 12:41 Сейчас в теме
(11) Вы не правы, в законе четко описаны критерии. И будет правильно их учитывать при написании ПО.
13. Sykoku 101 12.01.12 15:49 Сейчас в теме
(12) Noy,

1. Вот разъяснение ДПА (взято с их сайта)

Про обов’язкову реєстрацію в ЄРПН податкових накладних

ДО УВАГИ ПЛАТНИКІВ ПОДАТКІВ!

З 1 січня 2012 року згідно з вимогами Податкового кодексу України обов’язковій реєстрації в ЄРПН підлягають податкові накладні із сумою ПДВ понад 10 тис. грн. в одній накладній, а також податкові накладні, виписані при здійсненні операцій з постачання підакцизних товарів та товарів, ввезених на митну територію України, незалежно від розміру ПДВ в одній податковій накладній.
Звертаємо увагу: що факт виписування податкових накладних без реєстрації їх у Єдиному реєстрі податкових накладних позбавляє покупця права формування податкового кредиту.

2. А теперь задача на одно неизвестное.
Порядок НН должен быть сквозной за месяц. И выписываться они должны неплательщикам также. Просто не отдаются в руки. Ну и как соблюсти сквозную нумерацию при регистрации НН в ЄЦРПН, если их не все туда отправлять? Другой номер присваивать? - До первой проверки. Не все регистрировать - пропуски делать - нарушение способа ведения отчетности. Как по мне - второе дешевле. предложите ваш вариант решения - без обязательных штрафов. С удовольствием применю.

А на Закон ссылаться не надо - вон Фокса задним числом НДС-а лишили, а они об этом узнали через 2 недели -законно?
Прикрепленные файлы:
ERPN.ert
7. rus128 2 11.01.12 11:30 Сейчас в теме
Хорошая идея.
Жаль, что БУ Украины 7.70.259 уже не актуально.
9. Sykoku 101 11.01.12 14:00 Сейчас в теме
(7) rus128,

Верю.

С учетом того, какие сейчас "сопровожденцы", лучше я сам корпеть буду.
Предновогодний пример. Киевский филиал "БИТа". 02/11/2011 заключен договор на перенос справочников и остатков до 6-го класса включительно за 14 рабочих дней. В декабре уже все все поняли и потребовали денег взад. До сих 2,500$ не вернули...
8. Sykoku 101 11.01.12 12:46 Сейчас в теме
Маленькое дополнение - проверка необходимости включать НН в реестр. Признак проверки - наличие кода ТНВЕД в Товаре.

Для хранения в системе 1С рекомендуется дополнить Реквизиты НН переменной ЄПРН.
(Для обновленных конфигураций БУУ это поле ТребуетВклВЕдРеестрНН)
Также рекомендуется хранить признак выгруженности (для БУУ это Реквизит ЕРНН).

Процедура Проверка_ЄРПН()

ЄРПН=0;

ВыбратьСтроки();

Пока ( ПолучитьСтроку() > 0 ) Цикл
Если ТМЦ.ТВЕД<>0 Тогда
ЄРПН=1;
Прервать;
КонецЕсли;
КонецЦикла;

КонецПроцедуры
14. maddy 19 12.01.12 18:59 Сейчас в теме
Я наверно чего-то пропустил. Где озвученно требование о непрерывности нумерации в ЕРПН? Раньше было "в реестрах выданных/полученных"? Хотя непрерывность нумерации в реестр полученных это отдельный хит.
15. Noy 1074 12.01.12 19:22 Сейчас в теме
(14) да нет такого требования. Просто в схеме файла есть такой реквизит как номер документа в периоде, который только сбивает с толку людей. В частночти в ОПЗ эти номера присваиваются по порядку (в пределах отчетного периода) для каждого вида документа по мере их ввода.

Теоретически можно при отправке формировать номер для каждой отправляемой накладной. Лично я просто номер налоговой в это поле вбиваю. Никакого контроля нумерации со стороны ДПА нет.
16. Sykoku 101 12.01.12 20:33 Сейчас в теме
(14) maddy,
Не помню, где. Найду - скажу.
Пока могу только сказать, что есть коллизия в п.п.3 и 4 Порядка ведення Єдиного реєстру податкових накладних
(КМУ №1246):
п.3
регистрировать необходимо ВСЕ корректировки. Если НН не была зарегистрирована, ее регистрируют независимо от того, когда она была создана (я так понимаю, и независимо от того на кого - плательщика или нет).
п.4.
Регистрации не подлежит то, что не выдается.

Ну и что делать - если командир не прав, смотрим п.№1?


(15) Noy,
Если номер документа совпадет с уже отправленным - в пределах отчетного периода - старая информация заменится новой.
17. teleport7 13.01.12 04:40 Сейчас в теме
Очень выручила обработка. +
Пришлось прикрутить ее сильно модифицированную на АБТ 3.6.5
Все получилось!

В процессе внес несколько косметических изменений в оригинальную обработку:

1) В XML файле в числах сохраняются группы разрядов для больших сумм. Может вызвать неоднозначную реакцию проверяющего ПО. Можно, например, формат чисел “#N017.2.,” заменить на “#N017.2.”

2) Если в НН предусмотрено отдельно поле код УТК ВЭД товара, вероятно, лучше брать из табличной части НН, а не из справочника ТМЦ.
Пока ( ТекДок.ПолучитьСтроку() > 0 ) Цикл
УКТВЭД = СтрЗаменить(ТекДок.ПолучитьАтрибут("КодУКТВЭД"), " ", "");
......
3) При выгрузке не убираются дефисы и пр. в телефоне контрагента, хотя это предусмотрено обработкой.
18. Sykoku 101 13.01.12 15:35 Сейчас в теме
(17) teleport7,
Рад, что Вам пригодилось.

XML формат плохо относится к символам, типа &.

1C 7.7.27 не всегда адекватно форматирует большие числа. Неоднократно получал значения типа "9,999.99", когда что-то не складывалось у нее в голове - например, если заменить в строке формата "N" на "Ч".

Если Вам необходимо использовать откорректированный номер, то Ваша переменная "Клиент_Телефоны", а не реквизит из справочника. Просто у меня давным давно разнесены код города, телефон. индекс. улица и т.д. - примерно, как сейчас в 8-ке додумались.

Ну а свой номер телефона подкорректировать уже и самому можно...




Мало ли, вдруг пригодится - я при выгрузке Реестра НН использую

Функция Акронимы(Имя)

Имя = СтрЗаменить(Имя,"Приватне підприємство","ПП");
Имя = СтрЗаменить(Имя,"Товариство з обмеженою відповідальністю","ТзОВ");
Имя = СтрЗаменить(Имя,"науково-виробниче підприємство","НВП");
Имя = СтрЗаменить(Имя,"Суб'єкт підприємницької діяльності","СПД");
Имя = СтрЗаменить(Имя,"Науково-Виробничий комплекс","НВК");
Имя = СтрЗаменить(Имя,"Рекламне Агентство","РА");
Имя = СтрЗаменить(Имя,"Фізична особа-підприємець","ФО-П");
Имя = СтрЗаменить(Имя,"&","&");
Имя = СтрЗаменить(Имя,"Акціонерне товариство","АТ;");
Возврат(Имя);

КонецФункции

// ===============================
19. teleport7 13.01.12 16:10 Сейчас в теме
(18)
С телефонами разобрался. Спасибо. Больше переживал за числа "9,999.99" - у вас они нормально до этого выгружались? (У меня 1C 7.7.27, Win 2003 rus)
Просто незнакомая конфигурация, да еще завалы с этой отчетностью.
С 1С знакомлюсь только по необходимости. Поддерживаю сейчас экспорт из базы SQL в УТП 8.2

P.S. Все таки придется на выходных предусмотреть какую-ту простейшую схему учета зарегистрированных накладных.
Видел что в последней версии обработки это предусмотрено, но не разбирался еще как работает.
20. Sykoku 101 13.01.12 17:57 Сейчас в теме
(19) teleport7,

Если формат изначально работает правильно, потом сбои будут только при глобальных (виндосовских) проблемах - типа "Ошибка чтения по адресу", "Недостаточно памяти" и т.д. Хотя были случаи, если память дешевая - типа ГудРам - когда в 1С пущает, но дальше при попытке открыть БОЛЬШОЙ справочник или провести документ получаешь вылет.

Насчет учета в документах признаков необходимости выгрузки - комментарий №8 - проверка наличия кодов + проверку на сумму можете в конце добавить -

Если Итог("НДС")>10000 Тогда
ЄРПН=1;
КонецЕсли;

В Конфигурации в Реквизитах документа НН добавьте 2 числовых поля длиной 1 разряд , например ЄПРН - признак выгружаемости и Звіт - было ли экспортирование. И в документе на процедуры "Печать" и "ПриЗаписи" включаете проверку/расчет поля ЄПРН.

А в обработке выгрузки заполняете поле Звіт. Как это сделать - скачайте версию отчета из комментария №13 - строки "Документ.Записать" и чуть выше.

P.S.
Можно обойтись и одной переменной - только тогда запомнить, что в ней должно быть
Например
0 - Не установлено
1 - Меньше 10 000
2 - есть подакцизные товары
3 - не плательщик НДС

И с состоянием выгрузки (+4 к начальному значению)

4 - выгружали, но непонятно зачем
5 - выгружали, но меньше 10 000
6 - выгружали и так надо
7 - выгружали, хоть и неплательщик


На самой рабочей форме документа где-то поставьте пару нередактируемых Флажков с присвоением им значений в процедуре "ПриОткрытии" - если для 2-х переменных -

Флаг_Звіт =Звіт;
Флаг_ЄРПН=ЄРПН;

Если для одной

Если ЄРПН=2 Тогда
Флаг_ЄРПН =1;
КонецЕсли;

Если ЄРПН>3 Тогда
Флаг_Звіт =1;
КонецЕсли;
21. teleport7 13.01.12 20:08 Сейчас в теме
(20)
По поводу флага ЄРПН, то его заполнение я ранее взял с Бухгалтерии для Украины:
Процедура ПроверкаТребуетВклВЕдРеестрНН()
	// поставим флаг "Требует регистрация в реестре"
	Если Оставляем = 1 Тогда
		// мы не управляем флажком ТребуетВключенияВЕдиныйРеестрНалоговыхНакладных
		// для налоговых накладных, которые не выдаются покупателю
		// согласно разъяснению ЕБНЗ такие налоговые не должны регистрироваться в Едином реестре
	Иначе	
		ТребуетВклВЕдРеестрНН = 0;
		Если Валюта = Гривня Тогда
			НДСРегл = Итог("НДС");
		//Иначе
		//	НДСРегл = глПересчет(Итог("НДС"),Валюта,Гривня,Курс,ДатаДок);
		КонецЕсли;
		Если ДатаДок >= '01.01.12' Тогда
			// или сумма НДС в документе больше 10 000 грн
			Если НДСРегл > 10000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
				
			// или имеются подакцизные/импортированные товары
			// этот факт определим так - если в строке указан код УКТЗЭД - считаем что условие выполняется.
			Иначе   
				ВыбратьСтроки();
				Пока ПолучитьСтроку() = 1 Цикл
					Если ПустоеЗначение(КодУКТВЭД) = 0 Тогда
						ТребуетВклВЕдРеестрНН = 1;
						Прервать;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.07.11' Тогда
			// сумма НДС в документе больше 100 000 грн
			Если НДСРегл > 100000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.04.11' Тогда
			// сумма НДС в документе больше 500 000 грн
			Если НДСРегл > 500000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		ИначеЕсли ДатаДок >= '01.01.11' Тогда
			// сумма НДС в документе больше 1 000 000 грн
			Если НДСРегл > 1000000 Тогда
				ТребуетВклВЕдРеестрНН = 1;
			КонецЕсли;
		КонецЕсли;
		Если (ТребуетВклВЕдРеестрНН = 1) И (ЕРНН = 0) Тогда
			Сообщить("Требуется включение документа Налоговая накладная № "+ СокрЛП(НомерДок)+" от "+ ДатаДок  + " в единый реестр налоговых накладных!", "!"); 
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры 
Показать

Немаленький, но вполне приятный код.
А за варианты со статусов - спасибо. Еще думаю нужно добавить статус "Успешно зарегистрировано ЕРПН". Только ради него и думал делать контроль.
22. Sykoku 101 13.01.12 20:25 Сейчас в теме
(21) teleport7,
Тогда уже не флажок, а поле типа "Дата" - Дата регистрации в ДПА.
МеДОС позволяет выбросить любой реестр за период (в том числе и НН - зарегистрированных, например) в файл формата DBF. Его структура достаточно и процедура чтения из-под 1С будет несложной. Надо - сделаю и выложу.
23. teleport7 13.01.12 23:21 Сейчас в теме
(22)
МеДОС еще не смотрел, но информация полезная.

Подожду месяц - может устаканится процедура регистрации НН.
Для неподдерживаемой никем АБТ 3.5 не уверен что буду делать обратную связь, а вот для УТП - думаю попробую.
Посмотрю еще как АББИ реализует обработку квитанций с 1С-звит. Может и делать ничего не придется.

А так обратная связь должна быть. Задача так и просится на автоматизацию.
24. пользователь 14.01.12 01:16
Сообщение было скрыто модератором.
...
25. пользователь 14.01.12 20:05
Сообщение было скрыто модератором.
...
26. пользователь 14.01.12 22:53
Сообщение было скрыто модератором.
...
27. пользователь 14.01.12 23:16
Сообщение было скрыто модератором.
...
28. пользователь 16.01.12 17:41
Сообщение было скрыто модератором.
...
29. пользователь 16.01.12 17:52
Сообщение было скрыто модератором.
...
31. Sykoku 101 17.01.12 20:46 Сейчас в теме
Замечено, что МеДОС сообщает об ошибке, если нумерация строк в исходном документе XML непоследовательна, например, "1","3","4" . Такое возникает, если 1) брать нумерацию из самого документа. а не использовать свой счетчик строк;
2) при редактировании НН или ее документа-основания какие-то строки удалялись, а перенумерация не была выполнена.
32. Amel2010 42 18.01.12 11:18 Сейчас в теме
Спасибо за обработку!
Будем разбираться...
Не знаете, как формируется имя файла для документа в стандарте OPZ?
Хочется, чтобы автоматом втягивало из папки XML.
33. Sykoku 101 18.01.12 11:46 Сейчас в теме
(32) Amel2010,


Имена файлов формируются в соответствии с значения элементов заголовка документа (DECLARHEAD) по такому принципу:

· Позиции с 1 по 4 включительно содержат код ГНИ получателя, в которую подается оригинал или копия документа (4 символа), состоящий из кода области, на территории которой располагается налоговая инспекция (отделения) (значение элемента C_REG, дополненного слева нулем до 2 символов ), и кода административного района, на территории которого располагается налоговая инспекция (отделения) (значение элемента C_RAJ, дополненного слева нулем до 2 символов);

Вот как формируется имя файла:

· Позиции с 5 по 14 включительно содержат код плательщика согласно ЕГРПОУ (Регистрационный (учетный) номер из Временного реестра ГНА Украины) или регистрационный номер учетной карточки плательщика (номер паспорта) (значение элемента TIN, дополненного слева нулями до 10 символов);

· Позиции с 15 по 17 включительно содержат код документа (значение элемента C_DOC);

· Позиции с 18 по 20 содержат подтип документа (значение элемента C_DOC_SUB);

· Позиции с 21 по 22 содержат номер версии документа (значение элемента C_DOC_VER, дополненного слева нулем до 2 символов);

· Позиции 23 содержит признак состояния документа (значение элемента C_DOC_STAN);

· Позиции с 24 по 25 содержат номер нового отчетного (уточняющего) документа в отчетном периоде (значение элемента C_DOC_TYPE, дополненного слева нулем до 2 символов). Для отчетного документа Позиции 24 ... 25 содержать значение 00;

· Позиции с 26 по 32 содержат порядковый номер документа, может подаваться несколько раз в одном отчетном периоде (значение элемента C_DOC_CNT, дополненного слева нулями до 7 символов). Если отчет подается только один раз, то позиции 26 ... 32 содержать значение 0000001;

· Позиция 33 содержит числовой код типа отчетного периода (1-месяц, 2-квартал, 3-полугодие, 4-девять месяцев, 5-год) (значение элемента PERIOD_TYPE);

· Позиции с 34 по 35 содержат значения отчетного месяца (значение элемента PERIOD_MONTH дополненного слева нулем до 2 символов);

· Позиции с 36 по 39 содержат значения отчетного года (значение элемента PERIOD_YEAR);

· Позиции с 40 по 43 содержат код налоговой инспекции, в которую подается оригинал документа (значение элемента C_STI_ORIG, дополненного слева нулями до 4 символов). Если документ является оригиналом, а не копией, то позицию 40 ... 43 будут соответствовать позициям 1 ... 4;

· Файл имеет расширение xml.


Картинка тут
http://www.sta.gov.ua/control/uk/publish/article?art_id=308728&cat_id=249256&showHidden=1
34. Amel2010 42 18.01.12 12:25 Сейчас в теме
Спасибо за подсказку и ссылку!

На закладке "Настройки" очепятка: "Поле признака поризошедшей..."
А нужно: "Поле признака произошедшей..."
36. Sykoku 101 18.01.12 12:40 Сейчас в теме
(34) Amel2010,

Спасибо, исправлю. Просто у меня в помещении +14 самая высокая температура - тетя Клава не всегда корректно воспринимает нажатия. Я когда описание прочел - штук 10 орфографических ошибок нашел...
Хотя можно было бы и проверить чем-нибудь перед отправкой ...
37. Amel2010 42 18.01.12 13:06 Сейчас в теме
(36)
Сочувствую по поводу климата...

Дорабатываю под свою конфигурацию...
Не работает при льготах на НДС - неправильно выгружаются реквизиты (не в те колонки суммы и т.п.).
35. Amel2010 42 18.01.12 12:38 Сейчас в теме
Не сохраняются в настройках поля признака. Только их значения
39. Sykoku 101 18.01.12 13:32 Сейчас в теме
(35) Amel2010,
В смысле - поля из реквизитов НН?
Предполагается их самостоятельная замена на предустановленные в Вашей конфигурации - строки 528, 538, 548 Модуля.
Точно так же, как и не сохраняется параметр выбора строки кода Налоговой Инспекции.

Хотя, согласен, можно было и сохранить.
41. Amel2010 42 18.01.12 13:35 Сейчас в теме
(39)
да там просто галочку нужно было поставить "Сохранять при сохранении настройки"
43. Sykoku 101 18.01.12 13:46 Сейчас в теме
(41) Amel2010,

Ни один из моих бухов про возможность сохранять настройки ни сном ни духом. А записывать за мной и учиться им лень....

А по ссылке - там для БухУчет для Украины. Я выкладывал адаптированную обработку для этой конфигурации отдельным файлом в комментариях - модераторы прибили - типа так теперь нельзя.

Надо адаптировать - скажите, для чего. Файлообменники и личную переписку еще никто не отменял.
40. Sykoku 101 18.01.12 13:34 Сейчас в теме
(35) Amel2010,

Если очень надо - вот измененные процедуры кода

// ===============================
Процедура ВыборРеквизитов(Наше_Поле, Его_Тип, Имя_по_Умолчанию)


СменитьФирму();

Док = СоздатьОбъект("Документ.НалоговаяНакладная");
ДокНН = Метаданные.Документ(Док.Вид());

// реквизиты шапки документа
Для Сч=1 по ДокНН.РеквизитШапки() Цикл

Реквизит=ДокНН.РеквизитШапки(Сч);
Значение=Реквизит.Идентификатор;
ТипРекв=Реквизит.Тип;

Если (ТипРекв=Его_Тип) Тогда
Наше_Поле.ДобавитьЗначение(Реквизит.Идентификатор + "/" + Сч); //+"/" + ТипРекв
КонецЕсли;

КонецЦикла;

Для Сч=1 по Наше_Поле.РазмерСписка() Цикл
ТекСтрока = Наше_Поле.ПолучитьЗначение(Сч);
Если Найти(ТекСтрока,Имя_по_Умолчанию)<>0 Тогда
Наше_Поле.УдалитьВсе();
Наше_Поле.ДобавитьЗначение(ТекСтрока);
Прервать;
КонецЕсли;
КонецЦикла;


КонецПроцедуры


// ===============================

Процедура ПриОткрытии()

Фирма=Константа.БазФирма.Получить(ТекущаяДата());

ДатаС = ТекущаяДата()-1;
ДатаПо = ДатаС;


ВосстановитьЗначение("ЕПРН_Предел",Предел);
Если ПустоеЗначение(Предел)=1 Тогда
Предел =10000; // Предельная сумма НДС не включения в отчет не акцизного товара
КонецЕсли;

ВосстановитьЗначение("ЕПРН_НДС",НДС_Х);
Если ПустоеЗначение(НДС_Х)=1 Тогда
НДС_Х = 1; // Включать ли в экспорт неплательщиков НДС
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Экспорт",Экспортировано);
Если ПустоеЗначение(Экспортировано)=1 Тогда
Экспортировано = 0; // Учитывать ли экспортированные
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Старт",СтартНН);
Если ПустоеЗначение(СтартНН)=1 Тогда
СтартНН = 5;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Стоп",СтопНН);
Если ПустоеЗначение( СтопНН)=1 Тогда
СтопНН = 10;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_OPZ",OPZ);
Если ПустоеЗначение(OPZ)=1 Тогда
OPZ =1;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Признак",Признак);
Если ПустоеЗначение(Признак)=1 Тогда
Признак=0;
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Файл",Файл);
Если ПустоеЗначение(Файл)=1 Тогда
Файл="OUTNAKLKVT20120113.dbf";
КонецЕсли;

ВосстановитьЗначение("ЕПРН_Каталог",Каталог);
Если ПустоеЗначение(Каталог)=1 Тогда
Каталог="\\trodat-ua\1cv77\medoc\report\dpa\";
КонецЕсли;

ВосстановитьЗначение("Поле_ЕРПН",Поле_ЕРПН);
Если ПустоеЗначение(Поле_ЕРПН)=1 Тогда
ВыборРеквизитов(Поле_ЕРПН,"Число","ЄРПН");
КонецЕсли;

ВосстановитьЗначение("Знач_ЕРПН",Знач_ЕРПН);
Если ПустоеЗначение(Знач_ЕРПН)=1 Тогда
Знач_ЕРПН=0;
КонецЕсли;

ВосстановитьЗначение("Поле_Звит",Поле_Звит);
Если ПустоеЗначение(Поле_Звит)=1 Тогда
ВыборРеквизитов(Поле_Звит,"Число","Звіт");
КонецЕсли;

ВосстановитьЗначение("Знач_Звит",Знач_Звит);
Если ПустоеЗначение(Знач_Звит)=1 Тогда
Знач_Звит=1;
КонецЕсли;

ВосстановитьЗначение("Поле_ДПА",Поле_ДПА);
Если ПустоеЗначение(Поле_ДПА)=1 Тогда
ВыборРеквизитов(Поле_ДПА,"Дата","ДПА");
КонецЕсли;


ИмяФайлаЗагрузки = Каталог + Файл;

Форма.ИспользоватьЗакладки(1);
Форма.Закладки.ДобавитьЗначение(1,"Выгрузка");
Форма.Закладки.ДобавитьЗначение(2,"Загрузка");
Форма.Закладки.ДобавитьЗначение(3,"Настройки");
Форма.Закладки.ДобавитьЗначение(4,"Списки_НН");
Форма.ИспользоватьСлой("Основной, Выгрузка",2);


КонецПроцедуры

// ===============================

Процедура ПриЗакрытии()

СохранитьЗначение("ЕПРН_Предел",Предел);

СохранитьЗначение("ЕПРН_НДС",НДС_Х);

СохранитьЗначение("ЕПРН_Экспорт",Экспортировано);

СохранитьЗначение("ЕПРН_Старт",СтартНН);

СохранитьЗначение("ЕПРН_Стоп",СтопНН);

СохранитьЗначение("ЕПРН_OPZ",OPZ);

СохранитьЗначение("ЕПРН_Признак",Признак);

СохранитьЗначение("ЕПРН_Файл",Файл);

СохранитьЗначение("ЕПРН_Каталог",каталог);

СохранитьЗначение("Поле_ЕРПН",Поле_ЕРПН);

СохранитьЗначение("Знач_ЕРПН",Знач_ЕРПН);

СохранитьЗначение("Поле_Звит",Поле_Звит);

СохранитьЗначение("Знач_Звит",Знач_Звит);

СохранитьЗначение("Поле_ДПА",Поле_ДПА);



КонецПроцедуры
38. Amel2010 42 18.01.12 13:25 Сейчас в теме
В итоге все-таки мне лучше подошла для выгрузки эта разработка: http://infostart.ru/public/104504/
Завелось сразу и правильно выгружает как с НДС так и без.

А вот импорт дат регистрации сейчас попробуем...

А Вы не планируете случайно автоматизировать проверку входящих налоговых накладных на предмет регистрации в ЕРНН?
Вот было бы здорово!
42. Sykoku 101 18.01.12 13:43 Сейчас в теме
(38) Amel2010,

Буду, конечно, но со входящими есть засада - для того, чтобы их проверить, их требуется сначала внести ручками. В тот же МеДОС, например. Или экспортировать из 1С. Автоматический запрос в налоговую с пустыми полями реквизитов входящих НН возвращает пустой же ответ. Вот и вся сказка про электронный документооборот.
А отправлять партнеру - опять же заносить его в справочник, корректно указывать адрес электронной почты и дай бог, чтобы там это письмо открылось в МеДОСе, а не секретаршей. Через Сервер ДПА не получится....
44. Amel2010 42 18.01.12 15:32 Сейчас в теме
(42)
Я себе представляю такую схему.
Бухи на участках вносят приходные документы (в т.ч. налоговую накладную).
Ставят галку типа "Должно быть зарегистрировано в ЕРНН".
Обработка выгружает их в запрос в виде файла XML для ДПА.
Медос или что-то типа того импортирует запрос, отправляет в ДПА, получает ответ.
Бух, который работает с Медос разносит в 1С галки типа "Зарегистрировано в ЕРНН".
45. Sykoku 101 18.01.12 16:16 Сейчас в теме
(44) Amel2010,
МеДОС не умеет импортировать "Отримані" налоговые накладные.
Зато он умеет импортировать весь реестр "Отриманих та виданих" - вот при его отправке, по идее, и можно будет искать дату внесения в реестр ДПА входящей НН. (Предпоследнее поле - Реєстрація).
Только вот сохраняет их МеДОС по одной в фомате OPZ J1201505, да еще и с ошибками - вместе с данными идет и мусор

....
<TAB1><![CDATA[]]></TAB1>
....
<TAB2><![CDATA[<Дата_НН>|<Дата_еще_раз>||<код НН> - ПН|<Поставщик>|<его_ИНН>|<Сумма_С_НДС>|<Сумма_Без_НДС>|<НДС>|||||||1]]></TAB2>
....

Рез-т удручает.
46. Amel2010 42 18.01.12 17:01 Сейчас в теме
(45)
Для определения статуса регистрации в ЕРНН в Медос (как и в Арт-Звите) есть специальный бланк запроса к реестру, в котором перечисляются номера/даты накладных, по которым хочешь получить справку.
Потом этот документ (бланк запроса) пересылается в ДПА.
На него приходит ответ - какие зарегистрированы, а какие нет.

Я об этом механизме писал.
47. Sykoku 101 18.01.12 17:50 Сейчас в теме
(46) Amel2010,
Я знаю, только в этот бланк как заносятся данные?
А хотелось бы как?
48. Amel2010 42 18.01.12 18:02 Сейчас в теме
(47)
Заносятся данные (номера и даты накладных) вручную.
А хотелось бы формировать в 1С автоматически.
В Медос только импортировать готовый документ XML для отправки в ДПА.
49. Sykoku 101 18.01.12 18:10 Сейчас в теме
(48) Amel2010,
Если не сложно - дайте ссылку на Вашу статью-описание МеДОСа (или сообщите код этого XML-документа - я что-то не припомню, чтобы в МеДОСе был именно импорт "Отриманих"...)
50. Amel2010 42 18.01.12 18:18 Сейчас в теме
ща качну, поставлю Медос, сделаю пару скриншотов - станет понятно, о чем я говорю.
Речь идет не об импорте накладных, а об импорте документа-запроса к ДПА, если такое вообще возможно.

Вот, кстати, пока нашел в руководстве пользователя Медос:
http://screencast.com/t/blkEQGnZfnXx

в OPZ эта справка про регистрацию накладной в ЕРНН имеет код F1300101

Вот для примера, что сформировал ОПЗ:
<?xml version="1.0" encoding="windows-1251" ?>
- <DECLAR xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="F1300101.xsd">
- <DECLARHEAD>
<TIN>43287687</TIN>
<C_DOC>F13</C_DOC>
<C_DOC_SUB>001</C_DOC_SUB>
<C_DOC_VER>1</C_DOC_VER>
<C_DOC_TYPE>0</C_DOC_TYPE>
<C_DOC_CNT>2</C_DOC_CNT>
<C_REG>23</C_REG>
<C_RAJ>1</C_RAJ>
<PERIOD_MONTH>1</PERIOD_MONTH>
<PERIOD_TYPE>1</PERIOD_TYPE>
<PERIOD_YEAR>2012</PERIOD_YEAR>
<C_STI_ORIG>2301</C_STI_ORIG>
<C_DOC_STAN>1</C_DOC_STAN>
<LINKED_DOCS xsi:nil="true" />
<D_FILL>18012012</D_FILL>
<SOFTWARE>OPZ 1.29.20</SOFTWARE>
</DECLARHEAD>
- <DECLARBODY>
<HNUM />
<HNAME>Добро, ООО</HNAME>
<HTIN>43287687</HTIN>
<HNPDV />
<HKSTI />
<HSTI>2301 ДПI У М.ЧЕРКАСИ</HSTI>
<HEMAIL />
<T1RXXXXG21 ROWNUM="1">1111111111</T1RXXXXG21>
<T1RXXXXG3D ROWNUM="1">01012012</T1RXXXXG3D>
<T1RXXXXG5 ROWNUM="1">4398098045</T1RXXXXG5>
<HFILL>18012012</HFILL>
<HKBOS>4398098045</HKBOS>
<HBOS>Іванов І.І.</HBOS>
</DECLARBODY>
</DECLAR>
Показать
51. Sykoku 101 18.01.12 19:32 Сейчас в теме
(50) Amel2010,

Этот документ я знаю. Я думал что-то еще появилось.

У меня он делается на основании документа СтраницаКнигиПриобретений. Выложить могу, только у меня АБТ. А там его отродясь не было. Я его создавал для заполнения раз в месяц.

Под БУУ можно попытаться адаптировать.
52. yuyu1 5 25.01.12 11:53 Сейчас в теме
а вот импорт налоговой накладной формата XML В 1С никто не написал.... прийдется самому
53. teleport7 25.01.12 12:16 Сейчас в теме
(52) yuyu1,
вероятно от того что это слишком нетиповая задача.
Подскажите для чего это Вам? Интересно настолько ли это необходимо. Может есть более простые способы решения Вашей задачи.
54. Sykoky 6 25.01.12 13:27 Сейчас в теме
(52) yuyu1,
Для какой версии 7-ки?

Еще пара вопросов
- поиск Фирмы / Клиента - по ИНН или ЭДРПОУ ? - Если реквизит периодический - фигвам.
- поиск ТМЦ по Наименованию - еще один фигвам.

А в остальном - очень даже несложно:


// ===============================


Процедура Парсинг(Стр)

НовСтр=СтрЗаменить(Стр," ", "");
Если Найти(НовСтр,"<C_DOC>")=1 Тогда
Если СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<C_DOC>",""),"</C_DOC>",""))<>"J12" Тогда
Сообщить("Это не документ J12 НН !");
Стоп=1;
КонецЕсли;
КонецЕсли;

Если Найти(НовСтр,"<C_DOC_SUB>")=1 Тогда
Если Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<C_DOC_SUB>",""),"</C_DOC_SUB>","")))<>10 Тогда
Сообщить("Это не документ J12010 НН !");
Стоп=1;
КонецЕсли;
КонецЕсли;

Если Найти(НовСтр,"<HFILL>")=1 Тогда
HFILL=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HFILL>",""),"</HFILL>",""));
ТекДок.ДатаДок=Дата(Сред(HFILL,5,4),Сред(HFILL,3,2),Сред(HFILL,1,2));
КонецЕсли;

Если Найти(НовСтр,"<HNUM>")=1 Тогда
ТекДок.НомерДок=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HNUM>",""),"</HNUM>",""));
КонецЕсли;

Если Найти(НовСтр,"<H02G1S>")=1 Тогда
ТекДок.Умова=СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<H02G1S>",""),"</H02G1S>",""));
КонецЕсли;

Если Найти(НовСтр,"<HKSEL>")=1 Тогда
HKSEL=Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HKSEL>",""),"</HKSEL>","")));
Фирмы=СоздатьОбъект("Справочник.Фирмы");
Если Фирмы.НайтиПоРеквизиту("ИНН",HKSEL,1)=0 Тогда
Сообщить("Не найден продавец !");
Стоп=1;
Иначе
ТекДок.Фирма=Фирмы.ТекущийЭлемент();
КонецЕсли;
Фирма=0;
КонецЕсли;

Если Найти(НовСтр,"<HKBUY>")=1 Тогда
HKBUY=Число(СокрЛП(СтрЗаменить(СтрЗаменить(НовСтр,"<HKBUY>",""),"</HKBUY>","")));
Клиент=СоздатьОбъект("Справочник.Клиенты");
Если Клиент.НайтиПоРеквизиту("ИНН",HKBUY,1)=0 Тогда
Сообщить("Не найден покупатель !");
Стоп=1;
Иначе
ТекДок.Клиент=Клиент.ТекущийЭлемент();
КонецЕсли;
Клиент=0;
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG3SROWNUM=")=1 Тогда
ТМЦ=СтрЗаменить(СтрЗаменить(Стр,"<RXXXXG3S ROWNUM=>",""),"</RXXXXG3S>","");
ТМЦ=СокрЛП(Сред(ТМЦ,Найти(ТМЦ,">")+1));

ТекДок.НоваяСтрока();

Товар=СоздатьОбъект("Справочник.ТМЦ");
Если Товар.НайтиПоНаименованию(ТМЦ,0,1)=0 Тогда
Сообщить("Не найден ТМЦ "+ ТМЦ +"!");
Стоп=1;
Иначе
ТекДок.ТМЦ=Товар.ТекущийЭлемент();
КонецЕсли;
ТМЦ=0;
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG5ROWNUM=")=1 Тогда
Кво=СтрЗаменить(СтрЗаменить(Стр,"<RXXXXG5 ROWNUM=>",""),"</RXXXXG5>","");
ТекДок.Кво=Число(СокрЛП(Сред(Кво,Найти(Кво,">")+1)));
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG6ROWNUM=")=1 Тогда
Цена=СтрЗаменить(СтрЗаменить(НовСтр,"<RXXXXG6ROWNUM=>",""),"</RXXXXG6>","");
ТекДок.Цена=Число(СокрЛП(СтрЗаменить(СтрЗаменить(Сред(Кво,Найти(Кво,">")+1),",",""),".",","))); // убираем триады и заменяем точку на запятую
КонецЕсли;

Если Найти(НовСтр,"<RXXXXG7ROWNUM=")=1 Тогда
Сумма=СтрЗаменить(СтрЗаменить(НовСтр,"<RXXXXG7ROWNUM=>",""),"</RXXXXG7>","");
ТекДок.СуммаБезНДС=Число(СокрЛП(СтрЗаменить(СтрЗаменить(Сред(Сумма,Найти(Сумма,">")+1),",",""),".",","))); // убираем триады и заменяем точку на запятую
КонецЕсли;

КонецПроцедуры



// ===============================
Процедура ЗагрузитьНН()


Стоп=-1;

Если ФС.СуществуетФайл(ИмяФайлаЗагрузки)=0 Тогда
Предупреждение("Указанный файл не существует!", 5);
Стоп=0;
Возврат ;
Иначе

Стоп=0;

ТекДок = СоздатьОбъект("Документ.НалоговаяНакладная");
ТекДок.Новый();

Попытка

Т=СоздатьОбъект("Текст");
Т.Открыть(ИмяФайлаЗагрузки);

Если Т.КоличествоСтрок()=0 Тогда
Сообщить("Файл пустой: "+ИмяФайлаЗагрузки, "!");
Возврат;
КонецЕсли;


Для Сч=1 По Т.КоличествоСтрок() Цикл

Стр=Т.ПолучитьСтроку(Сч);

Если ПустаяСтрока(Стр)=1 Тогда
Продолжить;
КонецЕсли;

//перекодировка
Если ДОС=1 Тогда
Стр=OemToAnsi(Стр);
// Стр=СтрЗаменить(Стр,"\"+Симв(34),Симв(34));
КонецЕсли;

Парсинг(Стр);

Если Стоп=1 Тогда
Сообщить("Ошибка содержимого файла!");
Стоп=0;
Возврат;
КонецЕсли;

КонецЦикла;

Исключение

Сообщить("Загрузка не выполнена. Длинное имя файла?");

КонецПопытки;


КонецЕсли;

ТекДок.Записать();

Стоп=0;

КонецПроцедуры



Строчку с именем файла сами вставите в окно формы?
Я-бы с радостью - но меня забанили на 4-ре недели без объявления войны (2 дня на форуме вообще не появлялся...)
55. teleport7 25.01.12 20:06 Сейчас в теме
(54) Sykoky,
Хотя да, возможность загружать из унифицированной формы налоговой сразу приходы в базу - достаточно перспективна.
Больше всего смущает отсутствие артикулов, но можно как-то решить этот вопрос организационно в большинстве компаний.
Думаю на сайте стоит ожидать появления отдельной, универсальной под все конфигурации, разработки на эту тему. Вероятно - будет популярна.
Все зависит от продуманности работы с номенклатурой.
56. Sykoky 6 25.01.12 21:13 Сейчас в теме
57. MIXOH 01.02.12 12:58 Сейчас в теме
Да уж.....у самого самописная (как и конфа) обработка по выгрузке на регистрацию в Медок, так же разобрался и с импортом даты регистрации из медка в обратку. По существу этой обработки могу пожелать дальнейших успехов и добавить пару комментов:
Действительно пока сам не нашел нормального решения по импорту в медок номеров НН для формирования запроса о регистрации а соответственно и вытяга с реестра данных по входящим НН от поставщиков.....единственное пока более менее решение это импорт номеров в OPZ затем переброска из него-же в медок....прямого импорта к сожалению пока не реализовали в медке.
И еще один комментарий....(регулярно сталкиваюсь) некоторые НН при регистрации отклоняются по причине некорректного кода УКТЗЕД, его проверка осуществляется медком при регистрации, беда в том что частенько поставщики ошибаются с этим кодом, приходится потом его уточнять и направлять НН на регистрацию повторно, встречал в сети как справочник (выгруженный из медка кстати) так и обработку по актуализации этих данных в самой 1С, (у себя еще не реализовал но планирую, и Вам советую) логично было-бы делать попутную проверку кодов в НН выгружаемых этой обработкой на валидность сверяя с данным справочником, дабы избежать возможных ошибок при регистрации медком (на самой выгрузке это не отражается, т.к. обработка пишет в xml все что не подсунешь).
З.Ы. Да.....еще тут проскакивал вопрос о необходимости регистрации НН неплательщикам....так вот их выгружать, а следовательно и регистрировать (ставить галочку в печатной форме) не нужно.
58. Sykoky 6 01.02.12 13:55 Сейчас в теме
(57) MIXOH,
По проверке кодов.
Занятие бесполезное, т.к. коды таможенной службы и ДПА не совпадают. Нарывался неоднократно. Периодически сервер ДПА посылает контрагентов с моим кодом, хотя у меня с этим же кодом НН зарегистрирована.

По неплательщикам.
Можно пока и не выгружать, пока он не запросит корректировку или не захочет вернуть. Тогда - обязательно.

По импорту запроса входящих НН.
Каждому буху все равно придется вносить в программу входящие НН. Сделать отчет за период по журналу этих документов и сохранить его в виде XML для последующего импорта в MEDOC несложно. В OPZ J1400101
60. Sykoku 101 17.02.12 16:27 Сейчас в теме
Вышли новые версии документов XML - Додатка №1 и Додатка №5.
Всех изменений - сменить номера версий документов - это строки
<C_DOC_VER>9</C_DOC_VER> и
<C_DOC_VER>2</C_DOC_VER> соответственно надо заменить на

<C_DOC_VER>10</C_DOC_VER> и
<C_DOC_VER>3</C_DOC_VER>.
61. Sykoku 101 15.03.12 11:57 Сейчас в теме
Изменен формат экспорта даты внесения в реестр - поля переставлены местами.

Старый порядок -
DATE_REG NUMBER DATEDOC EDRPOU INN NUM_SVD TYPE

Новый порядок -
KVTIMPDT REGNUM TYPE NUM_SVD INN EDRPOU DATEDOC NUMBER DATE_REG + возможность экспортироватьне все их них.

Это идет с обновлением Медка 10.00.59 + дается возможность выбора полей для экспорта (без возможности сохранения настройки по завершению программы).

Так как у нас поля выбирались по имени, а не по номеру столбца (а оные не изменились), то программа продолжает работать.
НО.
Медос как формировал дату внесения в реестр НН ДО 29-го февраля, так и продолжает игнорировать мартовские документы. Ошибка не исправлена. Ждем-с.
62. Sykoku 101 31.03.12 16:10 Сейчас в теме
Через 3 недели ИтеллектСервисовские программеры нашли баг. Обещали в 63-й версии исправить. Причем - на мой страх и риск. М-да... Меня, кстати, туда звали на работу лет 20-ть назад. Может оно и хорошо, что не согласился.
63. stagov 11 01.12.12 03:58 Сейчас в теме
...(для 1С 7.7. АБТ 3.5.5 и выше).... за 10 лет с 1С раза 2 сталкивался с этим чудом. Конфа не супер распространенная, ну и громоздкая
Оставьте свое сообщение

См. также

Выгрузка книги продаж и книги покупок для декларации НДС 2015-2021 из 1С 7.7 в "Налогоплательщик ЮЛ"

Регламентированный учет и отчетность Оптовая торговля Производство готовой продукции (работ, услуг) Файловый обмен (TXT, XML, DBF), FTP Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет НДС Платные (руб)

Обработка для переноса выставленных и полученных счетов-фактур из "Бухгалтерии 7.7", "Подрядчик Строительства", “Производство+Услуги+Бухгалтерия 7.7”, "Торговля и Склад 7.7", "Комплексной 7.7", еФарма в "Налогоплательщик ЮЛ" (программа с сайта nalog.ru ФНС), СБИС, Контур-Экстерн, Такском (формат 5.04, 5.06 в 2019 году). В новой декларации НДС добавлены, в числе прочих, разделы 8 и 9, которые содержат данные книги покупок и книги продаж соответственно. Ручной ввод большого количества информации не всегда оправдан, поэтому с помощью этой обработки можно выгрузить счет-фактуры из существующей базы, а для сдачи декларации использовать программу от ФНС “Налогоплательщик ЮЛ” или напрямую выгружать в СБИС или онлайн-сервисы (Такском, Контур и т.п.).

7200 руб.

02.03.2015    127963    28    56    

106

Распределение товаров между складами (подразделениями) для 1С: УТ 11, УНФ, УТ 10.3, УПП, и 1С 7.7 ТиС

Обработка документов Розничная торговля Учет ТМЦ Оперативный учет 7.7 Оперативный учет 1С:Управление торговлей 10 1С:Торговля и склад 7.7 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Данная обработка служит помощником для распределения товарных запасов между различными складами. В качестве необходимой информации для анализа, руководитель в отчете может наблюдать: 1. Остатки по выбранным складам 2. Продажи с каждого из складов за выбранный период 3. Возможна группировка по свойствам номенклатуры (для УТ10.3)

5900 руб.

08.07.2011    49624    58    1    

32

Загрузка банковской выписки для 1С 7.7 любой конфигурации

Обработка документов Банковские операции Загрузка и выгрузка в Excel Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет Платные (руб)

Решение предоставляет комплексную загрузку банковской выписки из CSV, XLS, TXT файла в 1С 7.7 любой конфигурации. Позволяет создавать документы выбранного вида, например "Строка выписки банка (приход/расход)", или многострочный табличный документ, например Выписка, для каждой операции из загружаемого файла банковской выписки. Загружает реквизиты документа, а также создаёт контрагентов и другие необходимые элементы справочников.

4200 руб.

29.07.2021    16485    8    21    

10

SALE! 10%

Перенос данных из 1С:Бухгалтерия 7.7 в БП 3.0

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 1С:Бухгалтерия 7.7 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Стандартная обработка перехода с 1С:Бухгалтерии 7.7 на 1С:Бухгалтерия предприятия 8, ред.3.0 достаточно сложна в использовании. При ее запуске и попытке выполнения перехода можно встретить большое количество ошибок (примеры ниже). Наша разработка содержит исправление этих ошибок. Также при приобретении нашего переноса данных из 1С:Бухгалтерии 7.7 в БП 3.0 вы получите техническую поддержку наших специалистов по любым вопросам, связанным с этой задачей.

43889 39500 руб.

26.05.2020    31051    9    57    

16

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv7 Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    61666    66    ksnik    5    

40

Универсальный конвертер XML в Таблицу значений + вывод XML в печатную форму (v 7.7)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 Конфигурации 1cv7 Платные (руб)

Универсальная обработка для 1С 7.7 по конвертации XML-файла заранее неизвестной структуры в Таблицу значений с возможностью вывода наглядной печатной формы формата MXL (с возможностью свёртки узлов XML) и/или наглядной печатной формы формата Excel (с возможностью свёртки узлов XML).

1000 руб.

16.01.2018    24466    8    0    

12

ФИАС для 7.7

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 Конфигурации 1cv7 Россия Платные (руб)

Класс 1С++ для подключения ФИАС (Федеральная информационная адресная система) к любой конфигурации 1С 7.7. Опционально доступно геокодирование адресов и хранение географических координат адресных элементов ФИАС в отдельной БД. В конфигурации, где для ведения адресов используется типовой интерфейс по работе с КЛАДР, встраивается за пару минут.

6000 руб.

15.11.2017    24879    30    71    

28

Подключение классификатора ФИАС формата DBF к 1С 7.7

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 Конфигурации 1cv7 Россия Абонемент ($m)

Обработка позволяет вводить адрес из внешнего классификатора ФИАС формата dbf, возвращает значения выбранных объектов: ГУИД, Наименование, ОКТМО, ОКАТО, почтовый индекс, ГУИД владельца, флаг актуальности, ГУИД замещающего объекта (при выборе неактуального объекта), Кадастровый номер (если есть в классификаторе)

1 стартмани

10.10.2017    24339    29    DimanZ    17    

1

Загрузка документов "Поступление", "Отгрузка", "Счет на оплату" из Excel в Бухгалтерию 7.7

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Бухгалтерский учет Платные (руб)

Обработка загружает из файла Excel документы "Поступление", "Отгрузка", "Счет на оплату". Возможно сохранение настройки соответствия полей. Есть демоверсия. Есть интересная функция загрузки сразу и поступления, и отгрузки (цены в отгрузке будут установлены больше на выбранный процент). Элементы номенклатуры ищутся по полям поиска и могут создаваться новые, если не найдены.

9360 руб.

02.06.2015    41411    3    5    

5

Загрузка номенклатуры в справочник и документ из файла Excel и CSV, обновление цен и реквизитов (адаптируется под разные конфигурации 1С: 7.7)

Загрузка и выгрузка в Excel Обработка справочников Обработка документов Оптовая торговля Розничная торговля Ценообразование, анализ цен Прайсы Платформа 1С v7.7 Конфигурации 1cv7 Управленческий учет Платные (руб)

Загрузка номенклатуры в справочник и документ, обновление цен, реквизитов, подчинённых справочников из файла Excel и CSV в 1С7.7. Формирует структуру групп (иерархию), создаёт полностью готовый справочник. Выгружает товары прайс-листа в документы Поступление, Реализация, Заказ, Оприходование, Отчет ККМ и другие. Автоматически адаптируется под разные конфигурации 1С7.7, в которых есть справочник номенклатуры.

2400 руб.

04.12.2014    76341    39    56    

56

Оптимизация выгрузки из 1С 7.7 по правилам обмена большого объема данных

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Конфигурации 1cv7 Бесплатно (free)

При выгрузке из 1С 7.7. большого справочника программа завершалась примерно с таким сообщением: "msxml6.dll: Недостаточно памяти для завершения операции". Вариант выгрузки порциями меня не устраивал. Поэтому немного оптимизировал обработку выгрузки. Возможно кому-то сэкономит время.

24.09.2014    33225    Just4Fun    33    

27

Копирование прайс-листов для ТиС, Комплексной 7.7

Прайсы Оптовая торговля Ценообразование, анализ цен Обработка документов Оперативный учет 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Абонемент ($m)

Обработка предназначена для копирования прайс-листов (типов цен), с возможностью изменения и установки только части из них.

3 стартмани

21.03.2014    25738    25    Krasnyj    4    

30

Работа с 62 счетом в бухгалтерии

Обработка документов Взаиморасчеты Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Сортировка 62 счета по субсчетам Обработка сама закрывает авансы, при этом она позволяет работать с кореспонденцией любого типа по 62 счету, например схлопнуть 62,4 на 62,1 , а затем 62,1 на 62,2 или сразу 62,2 на 62,1 ,т.е. сколько раз хотите столько и запустите с различными вариациями.

1 стартмани

18.10.2013    29460    30    zavsom    3    

3

"Конвертер деклараций (XLS) от поставщиков для загрузки в Декларант Алко (XML), 11/12 форма" для 7.7

Внешние источники данных Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 Конфигурации 1cv7 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Акцизы Бесплатно (free)

"Конвертер деклараций (XLS) для загрузки в Декларант Алко (XML)" Конвертирует 11/12 форму декларации полученную от поставщиков (в экселе) в файлы импорта (xml) для загрузки в Декларант Алко.

07.10.2013    49443    303    Ёпрст    4    

19

Обработка формирования файлов обмена «Дистрибьютор-Поставщик» для ОАО «Компания «Арнест»».

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v7.7 1С:Комплексная 7.7 Россия Абонемент ($m)

Это обработка выгрузки данных о движении товаров, продажах, номенклатуре, складах, торговых точках, контрагентах для производителя ОАО Компания Арнест в формате XML, которые формируются по оборотному регистру и документам Реализации Koмплeкcной кoнфигуpaции "Буxгaлтepия+Topгoвля+Cклaд+Зapплaтa+Kaдpы", peдaкция 4.2 (7.70.424) в соответствии со следующей инструкцией обмена "Дистрибьютор - Поставщик" фирмы ОАО Компания Арнест. (ВНИМАНИЕ: используем компоненту 1С++)

1 стартмани

14.03.2013    24464    6    ksnik    3    

0

Обмен данными между 1С:ТиС 7.7 и Bitrix

Внешние источники данных WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Оперативный учет 7.7 1С:Торговля и склад 7.7 Абонемент ($m)

Недавно понадобилось сделать интеграцию между 1С:Торговля и Склад 7.7 и 1С:Битрикс. В сети Интернет имеются готовые решения, но все они платные. Поэтому решил сделать собственное бесплатное решение.

1 стартмани

13.03.2013    37595    290    Nicholas    20    

27

Загрузка поступлений из Excel

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Управленческий учет Абонемент ($m)

Обработка для загрузки документов поступлений из накладных в формате Excel.

5 стартмани

19.12.2012    37864    191    @lexandr    11    

10

Пакетный ввод документов при продаже через посредника - Интеркампани

Обработка документов Оптовая торговля Платформа 1С v8.3 Оперативный учет 7.7 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет Платные (руб)

Для уменьшения налогооблагаемой базы, частенько общества с ограниченной ответственностью (ООО и ЗАО, ОАО) продают изначально товар собственному ИП-шнику. Который в свою очередь реализует товар физическим лицам по ЕНВД.

3000 руб.

23.11.2012    26772    7    1    

11

Универсальный конвертер DBF -> CSV (dbf2csv)

Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Загрузка и выгрузка в Excel Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

В данной обработке "dbf2csv" представлена переведенная мной на платформу 1С:Предприятие 7.7 Обработка "Экспорт ТЗ в CSV формат (пратформа 8.0/8.1)", и созданая мной функция ЭкспортТЗвCSV() для 1С:Предприятие 7.7

1 стартмани

08.09.2012    118172    29    ksnik    2    

6

Acc77: Зачет авансов по счету 76.АВ для «1С: Бухгалтерия 7.7 редакция 4.5»

Обработка документов Закрытие периода Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Внешняя обработка "Зачет авансов по счету 76.АВ" для «1С: Бухгалтерия 7.7 редакция 4.5». Отличительной особенностью данной разработки является полностью автоматизированное программное создание комплекта документов "Запись книги покупок" и "Счет-фактура выданный (на аванс)" за произвольный период по данным бухгалтерского учета с возможностью неоднократной обработки рабочего периода. Таким образом, после проверки корректности взаиморасчетов с покупателями для закрытия периода по разделу "НДС с авансов полученных" бухгалтеру будет достаточно самостоятельно запустить обработку нужного периода.

3 стартмани

29.07.2012    40021    49    Chastiser    12    

3

Универсальная загрузка табличных частей для 7.7 (из Excel)

Обработка документов Загрузка и выгрузка в Excel Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Универсальная загрузка табличных частей из табличных документов Excel для 1С 7.7

1 стартмани

15.05.2012    35790    406    sanches2    27    

30

НДФЛ как на ладони

Обработка документов Зарплата Расчет 7.7 1С:Зарплата и кадры 7.7 1С:Комплексная 7.7 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

НДФЛ посчитали... А когда, как и куда уплатили? А за кого и сколько еще надо уплатить? А почему столько? А можно документ создать автоматически?

1 стартмани

27.03.2012    31323    326    DarkAn    41    

37

Правила переноса документов Заявка на кассовый расход, Доверенность и Платежное поручение из 7.7 в 8.2 от 02.04.2012 (правила проверены на Бухгалтерия бюджетного учреждения 7.70.646 в Бухгалтерия государственного учреждения 1.0.10.2)

Обработка документов Банковские операции Кассовые операции Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Бухгалтерский учет 7.7 1С:Бухгалтерия для бюджетных учреждений 7.7 1С:Бухгалтерия государственного учреждения Россия Бюджетный учет Абонемент ($m)

Правила переноса документов Заявка на кассовый расход, Доверенность и Платежное поручение из 7.7 в 8.2 от 02.04.2012 (правила проверены при переносе из Бухгалтерия бюджетного учреждения 7.70.646 в Бухгалтерия государственного учреждения 1.0.10.2), доработанные из правил переноса в ББУ 1.0.22.1 из http://infostart.ru/public/85835/

1 стартмани

15.03.2012    27808    278    Anthon    63    

32

Заполнение документа Перечисление НДФЛ 2013 в бюджет по улучшенному алгоритму

Обработка документов Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Обработка меняет суммы в документах Перечисление НДФЛ в бюджет по улучшенному алгоритму на заданный период.

1 стартмани

13.03.2012    13207    11    berezin    27    

30

Распределение и контроль перечисленного НДФЛ в ЗиК 7.7

Обработка документов Зарплата Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Исправленный алгоритм распределения сумм уплаченного НДФЛ для конфигурации "Зарплата+Кадры" релизов 7.70.321-322 Предлагаемый алгоритм учитывает следующие ситуации, возникающие у налоговых агентов: 1. Корректное распределение уплаты по НДФЛ в разрезе ставок и ОКАТО/КПП 2. Правильное распределение сумм уплаченного НДФЛ по сотрудникам, для которых за расчётный месяц были ведены промежуточные документы уплаты (уволенные, отпускники, и т.п.) 3. Возможность отражения отрицательного исчисленного НДФЛ (опционально, настраивается интерактивно и автоматически) 4. Возможность контроля наличия излишней уплаты по НДФЛ, а также возможность распределения данной излишней уплаты по сотрудникам (опционально, настраивается интерактивно и автоматически)

1 стартмани

10.03.2012    28637    224    andrewks    29    

26

Автоматическое создание документов "Перечисление НДФЛ в бюджет" для ЗиК 7.7

Обработка документов Зарплата Оперативный учет 7.7 Бухгалтерский учет 7.7 Расчет 7.7 1С:Бухгалтерия 7.7 1С:Зарплата и кадры 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Уж недалек отчет, а документы распределения НДФЛ по работникам за 2011 год не введены. Можно ввести их вручную, а можно воспользоваться обработкой, выгрузить их в MS Excel и сформировать автоматически. Для этого подготовлен данный комплекс обработок.

1 стартмани

05.03.2012    31936    95    Krasnyj    43    

27

Алгоритм распределения перечисленного НДФЛ в ЗиК 7.7 и вариант его улучшения

Зарплата Обработка документов Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет НДФЛ Абонемент ($m)

Доработка конфигурации ЗиК 7.7 релизы 320-322 с целью улучшить распределение сумм перечисленного НДФЛ по сотрудникам. Полезна, если Вы хотите видеть "красивые" регистры налогового учета по НДФЛ - с подробной расшифровкой перечисленных налогов до даты платежа и номера платежки. Ну и разумеется годовую отчетность по НДФЛ в полном соответствии с этими регистрами. Внимание! Если Вам просто надо показать в справке/отчете 2-НДФЛ перечисленную сумму равной начисленной и удержанной, - можно дальше не читать, а сразу идти сюда: http://infostart.ru/public/115064/

1 стартмани

28.02.2012    25031    243    sam41    75    

46

Расчет компенсации за неиспользованный отпуск при увольнении, а также расчет причитающегося сотруднику отпуска на выбранную дату

Зарплата Обработка документов Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет Абонемент ($m)

Обработка позволяет рассчитывать количество дней компенсации за неиспользованный отпуск при увольнении, а также причитающийся сотруднику отпуск на определенную дату. Теперь с возможностью ввода дополнительных данных!!!!

3 стартмани

23.02.2012    35175    224    Krasnyj    38    

104

Универсальный документ "Движение регистров" (опер.учёт)

Обработка документов Оперативный учет 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет Абонемент ($m)

Документ предоставляет функционал для визуального редактирования произвольных движений любых имеющихся в конфигурации регистров, как с нуля, так и на основе движений уже имеющегося документа (можно скопировать движения этого документа). Есть режим "Сторно".

1 стартмани

04.02.2012    32440    105    andrewks    16    

13

КД: Передача параметров из 7.7 в 8.x

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 1С:Конвертация данных Абонемент ($m)

В «Конвертации Данных» заложен удобный механизм передачи параметров – по сути переменных конвертации – между базами. Одна проблема: передача эта работает только если обмен происходит между двумя «восьмерками». По какой-то причине «семерочная» сторона обмена вообще обделена всякими интересными плюшками КД. Тем не менее, если нельзя, но очень хочется, всегда можно найти выход. Обработка загрузки читает файлы из семерки и из восьмерки одинаково, не проверяя версию платформы-источника, так что никто не мешает нам создать нужную структуру тегов для «параметров» своими силами!

1 стартмани

04.01.2012    33718    88    Филин    28    

69

Обработка «Изменение времени документа» для 1С:Предприятие 7.7

Обработка документов Оперативный учет 7.7 Бухгалтерский учет 7.7 Расчет 7.7 Конфигурации 1cv7 Абонемент ($m)

Обработка позволяет из одного диалога сразу изменить дату-время документа, как не проведенного, ТАК И ПРОВЕДЕННОГО. В остальном она полностью имитирует действия системной обработки. Обработка может использоваться как самостоятельно, так и открываться для изменения документа при исполнении кода, например, в обработчике расшифровки значения ячейки табличного документа.

1 стартмани

09.11.2011    57925    173    yuraos    43    

32

Обмен данными через DBF-файлы для 1С 7.7 - методика и практика (версия 3)

Файловый обмен (TXT, XML, DBF), FTP Обработка документов Обмен между базами 1C Платформа 1С v8.3 Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Торговля и склад 7.7 1С:Производство+Услуги+Бухгалтерия Абонемент ($m)

Предлагается методика обмена данными через DBF-файлы между практически любыми конфигурациями 1С 7.7, а также (в определенных случаях) между конфигурациями 1С 8.х, между 7.7 и 8.х и даже между 1С и не-1С системами...

1 стартмани

02.11.2011    57358    576    vkr    107    

62

Переход с упрощенной системы налогообложения на общую (или наоборот) (1c v7.x)

Свертка базы Обработка документов Обмен между базами 1C Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Налоговый учет Налог на прибыль УСН Абонемент ($m)

Предлагаю опробованную методику перехода с УСН на ОСН (или наоборот) и инструментарий для её реализации. Переход можно выполнить на любую дату (актуально при вынужденной смене системы налогообложения из за превышения лимита выручки или численного состава (как правило это выясняется, когда очередной квартал уже завершён...)). Конфигурации могут быть не типовыми, более того предлагаемые обработки пригодны для переноса справочников и документов между любыми конфигурациями 1C v7.Х.

1 стартмани

31.10.2011    27763    396    БоНН    18    

26