Компонента аутентификации и шифрования с помощью биометрической информации для Андроид

Публикация № 1120028

Разработка - Разработка внешних компонент

биометрическая информация внешняя компонента

Компонента для мобильной платформы, позволяющая идентифицировать пользователя и шифровать данные с помощью биометрических сканеров.

В мобильных приложениях часто бывает необходимо хранить секретную информацию, например пароли. Если записывать ее в базу данных, всегда нужно учитывать риск утери устройства и, соответственно, возможность доступа к ней посторонних лиц. В мобильных операционных системах существуют механизмы защиты ключей шифрования паролями, порождаемыми биометрическими сканерами. Если подробнее, информация шифруется ключом с паролем из хеша, полученного из сканера. Для расшифровки извлеченный из хранилища ключ должен быть "подписан" тем же отпечатком. Данная компонента позволяет воспользоваться такими механизмами ОС Андроид.

Стандартный диалог запроса биометрии введен в 28-ю версию Андроид, именно для этой или более высокой версии предназначена компонента. В меньших версиях она загружается, но метод Подключить возвращает Ложь. Использование стандартного диалога гарантирует поддержку других средств аутентификации (например сканера сетчатки или лица), которые появятся в Андроид позже.

Примечание: Начиная с 23й версии, Андроид имеет другой набор классов для использования сканера отпечатка - fingerprint. Он не содержит визуальных элементов, чтобы им воспользоваться, необходимо самостоятельно делать активность (или форму 1С). Автор этой статьи, его клиенты и коллеги уже два года успешно используют компоненту, выполненную на основе этого, ныне устаревшего, механизма.

Примечание: В 15-й версии платформы 1С объявила о внедрении биометрии в мобильной платформе, но мне не удалось найти способы ее использования и узнать "идеологию" работы ни в справочной информации, ни на сайте ИТС. Возможно, я не проявил необходимой настойчивости в поиске.

Компонента реализована как устройство ввода из данного стандарта. Имя объекта - BiometricDialog:

ПодключитьВнешнююКомпоненту("ОбщийМакет.Компонента", "IKSoftWare", ТипВнешнейКомпоненты.Native);
Компонента = Новый("AddIn.IKSoftWare.BiometricDialog");

Она имеет следующие параметры:

  • KeyName - строка без пробелов. Должен быть обязательно установлен. Он определяет имя контейнера ключа. Если Вы зашифровали информацию с определенным именем ключа, для ее расшифровки необходимо использовать точно такое же имя. Конечно же, вы можете использовать сколько угодно ключей.
  • Action - целое число равное 0 для шифрования или 1 для расшифровки
  • Data - данные для шифрования (строка) или для расшифровки
  • DecodeKey - открытый ключ для расшифровки. Параметр необходимо задать, если Action = 1. Он возвращается во внешнем событии после успешного шифрования (см. ниже)
  • DialogTitle - строка-заголовок диалога, необходимо обязательно установить
  • CancelText - текст на кнопке отмены, необходимо обязательно установить
  • DialogSubtitle - строка-подзаголовок диалога
  • DialogDescription - строка описания, отображаемая на диалоге

После подключения и инициализации параметров, необходимо вызвать метод Подключить. Если все условия вывода диалога выполнены (кроме соответствующего релиза ОС необходима регистрация в системе хотя бы одного отпечатка), он вернет Истину и отобразит всплывающий диалог:

Его закрытие вызывает в платформе такие внешние события:

  • DriverError - ошибка драйвера, аргумент события "Данные" содержит текст описания ошибки
  • AuthenticationFailed - ошибка проверки (приложен чужой или другой палец). Данные пустые.
  • AuthenticationHelp - прочие ошибки распознавания, "Данные" содержит текст
  • AuthenticationCanceled - отмена
  • BiometricData - успешное распознавание. Данные содержат строку xml следующей структуры:
<BiometricTouch>
 <Data>...</Data>
 <DecodeKey>...</DecodeKey>
</BiometricTouch>

Тэг Data содержит зашифрованную строку при шифровании или результат расшифровки, а DecodeKey - открытый ключ в кодировке base64.

Компонента предназначена для релиза мобильной платформы 8.3.15.62.

Скачать файлы

Наименование Файл Версия Размер
Компонента аутентификации и шифрования с помощью биометрической информации для Андроид:

.cf 1,57Mb
16.09.19
2
.cf 1.0.1 1,57Mb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. McLer 109 12.11.19 10:06 Сейчас в теме
На iOS нет такой?

Начиная с 23й версии, Андроид имеет другой набор классов для использования сканера отпечатка - fingerprint.

планируете ли обновлять компоненту?
2. IgorKissil 295 13.11.19 08:02 Сейчас в теме
(1)
На iOS нет такой?

На iOS пока нет
(1)
планируете ли обновлять компоненту?

Непонятно про обновление. Если Вы прочитали, компонента, использующая fingerprint у меня есть. Она отдельная с этой никак не связана. Выкладывать в общий доступ не планирую.
4. vsesam80 07.02.20 21:42 Сейчас в теме
(2)
&НаКлиенте 
перем  КлючПароля Экспорт ;
//модуль формы
&НаКлиенте
Процедура Зашифровать(Команда)
    #Если МобильноеПриложениеКлиент Тогда
        ПоддерживаетсяЗащитаДоступа = БезопасноеХранилище.ПоддерживаетсяЗащитаДоступа(СпособЗащитыДоступаБезопасногоХранилища.Нет);
        Если ПоддерживаетсяЗащитаДоступа Тогда
            ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеПомещенияБХ", ЭтотОбъект);
            КлючПароля = Строка(Новый УникальныйИдентификатор); // здесь можно любую строку передать
            БезопасноеХранилище.НачатьПомещениеДанных(КлючПароля, "Ключ у прораба!", СпособЗащитыДоступаБезопасногоХранилища.ТребуетсяДополнительнаяПроверкаПользователя,СпособДополнительнойПроверкиПользователя.БиометрическаяИлиВводПароля, ОписаниеОповещения);  
        Иначе
            Сообщить("на вашем устройстве не поддерживается работа безопасного хранилища!");
        КонецЕсли
        #КонецЕсли
КонецПроцедуры
    
&НаКлиенте
Процедура Расшифровать(Команда)
    #Если МобильноеПриложениеКлиент Тогда 
        ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
        БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения); 
    #КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПомещенияБХ(Результат, Ключ, ДополнительныеПараметры) Экспорт
а = 0;
КонецПроцедуры     


&НаКлиенте
Процедура ПолучитьПароль(КлючПароля)
#Если МобильноеПриложениеКлиент Тогда
ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения);  
#КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПолученияЗначения(Результат, Ключ, Значение, ДополнительныеПараметры) Экспорт
а= 0;
Сообщить(Значение);
КонецПроцедуры  

КлючПароля = "555"; 
Показать

Биометрии нет на телефоне, но интересно было бы проверить. А так пинкод работает
В синтаксис помощнике нет описания этой магии. Но, подсказки работают.
3. vsesam80 07.02.20 20:47 Сейчас в теме
В 15-й версии платформы 1С объявила о внедрении биометрии в мобильной платформе, но мне не удалось найти способы ее использования и узнать "идеологию" работы ни в справочной информации, ни на сайте ИТС.

Игорь, вы не про это писали?
&НаКлиенте
Процедура СохранитьПарольВБезопасноеХранилище(ПарольСтрока)
    
    #Если МобильноеПриложениеКлиент Тогда
        ПоддерживаетсяЗащитаДоступа = БезопасноеХранилище.ПоддерживаетсяЗащитаДоступа(СпособЗащитыДоступаБезопасногоХранилища.Нет);
        Если ПоддерживаетсяЗащитаДоступа Тогда
        ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеПомещенияБХ", ЭтотОбъект);
        КлючПароля = Строка(Новый УникальныйИдентификатор); // здесь можно любую строку передать
        БезопасноеХранилище.НачатьПомещениеДанных(КлючПароля, ПарольСтрока, СпособЗащитыДоступаБезопасногоХранилища.Нет,, ОписаниеОповещения);    
    #КонецЕсли
    
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПомещенияБХ(Результат, Ключ, ДополнительныеПараметры) Экспорт

КонецПроцедуры


ПОЛУЧЕНИЕ:

&НаКлиенте
Процедура ПолучитьПароль(КлючПароля)

ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения);

КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПолученияЗначения(Результат, Ключ, Значение, ДополнительныеПараметры) Экспорт

КонецПроцедуры
Показать


Если на мобильном устройстве используется биометрическая идентификация пользователя, то узнать, какой способ используется в данный момент, можно с помощью метода ТекущийСпособБиометрическойПроверки(). Результат работы данного метода можно использовать в разных целях, например:

● Для формирования сообщения, которое передается в метод НачатьПроверку().

● Для определения, что надежность используемого способа проверки устраивает разработчика приложения.

В общем случае, пример дополнительной проверки пользователя мобильного приложения может выглядеть следующим образом:

Процедура ПроверитьПользователя()
СпособПроверки = СпособДополнительнойПроверкиПользователя.ТолькоБиометрическая;
Если Не ДополнительнаяПроверкаПользователя.ПоддерживаетсяПроверка(СпособПроверки) Тогда
Возврат;
КонецЕсли;
ТекущаяБиометрия = ДополнительнаяПроверкаПользователя.ТекущийСпособБиометрическойПроверки();
Если ТекущаяБиометрия <> СпособБиометрическойПроверки.РаспознаваниеОтпечаткаПальца Тогда
Возврат;
КонецЕсли;
Сообщение = "Отсканируйте отпечаток пальца";
Обработчик = Новый ОписаниеОповещения();
ДополнительнаяПроверкаПользователя.НачатьПроверку(СпособПроверки, Сообщение, Обработчик);
КонецПроцедуры
Процедура ОбработкаРезультатовПроверки(ОтмененоПользователем, ДополнительныеПараметры) Экспорт
Если Не ОтмененоПользователем Тогда
// пользователь подтвержден
КонецЕсли;
КонецПроцедуры
5. IgorKissil 295 07.02.20 22:02 Сейчас в теме
(3) Похоже - это оно. На момент написания статья последним был 15-й релиз и там описания большинста методов в синтаксис помошнике нет! (Проверил только что) А в 16-м добавили.
6. madonov 155 12.02.20 05:57 Сейчас в теме
(5)
Перепробовал все версии мобильного клиент 8.3.15 - не работает, вылетает клиент без каких-либо ошибок.
Сервер 8.3.15.1778.

Что интересно - конфа сохраняется без ошибок, а вот подсказки через точку при наборе кода нет. Режим совместимости не используется.
7. IgorKissil 295 15.02.20 19:51 Сейчас в теме
(6) Тот же результат. Любое обращение к "ДополнительнаяПроверкаПользователя" приводит к падению приложенния. Мобильная платформа последняя 8.3.15.86. Так что разработка пока актуальна.
8. user1465376 18.09.20 16:30 Сейчас в теме
(3) В коде ошибка
Нужно Обработчик = Новый ОписаниеОповещения("ОбработкаРезультатовПроверки",ЭтаФорма);
Спасибо за код, у меня получилось!
9. user1465376 18.09.20 16:39 Сейчас в теме
(3) В коде ошибка
Нужно Обработчик = Новый ОписаниеОповещения("ОбработкаРезультатовПроверки",ЭтаФорма);
Спасибо за код, у меня получилось !
Оставьте свое сообщение

См. также

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    27158    40    Ditron    83    

Быстрый алгоритм шифрования AES ECB 128/192/256

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Реализация существенно оптимизированного алгоритма симметричного шифрования AES (Advanced Encryption Standard) в режиме ECB (Electronic codebook) с различной длиной ключа 128/192/256 без использования внешних компонент, zip-файлов, обращения к диску или БД и без привязки к ОС.

1 стартмани

30.10.2020    1932    9    1div0    34    

Программа расчёта питательной ценности ежедневной диеты по тридцати восьми нутриентам (мобильное приложение 1С для Андроид), APK + исходная конфигурация

Мобильная разработка v8::Mobile Домашние учет и финансы Абонемент ($m)

Мобильное приложение на платформе 1С с исходной конфигурацией. Пример решения задач по интерфейсу и первичному заполнению базы.

5 стартмани

12.10.2020    844    0    ovasiliev    3    

Использование встроенного сканера ТСД на Android в мобильном клиенте и мобильном приложении (драйвер сканера Android для 1С)

Разработка внешних компонент Мобильная разработка v8 Абонемент ($m)

Используя данный драйвер, можно без единой строки кода, просто установив на ТСД мобильный клиент 1С, сразу начать подбирать товары в документах вашей учётной системы. А, адаптировав нужные формы под небольшой размер экрана ТСД, можно просто создать полноценное рабочее место для выполнения операций с помощью ТСД, не прибегая к стороннему софту. Если же на складе плохая связь (или её нет вовсе), то можно использовать возможности мобильного клиента в автономном режиме (потребуется доработка вашей конфигурации). Драйвер также можно использовать и для Android приложения на мобильной платформе. В результате чего можно обойтись без ненужных полей ввода и клавиатуры «на пол-экрана».

3 стартмани

09.10.2020    3542    28    ltfriend    40    

Цифровая подпись Cades-BES для XML средствами 1С с помощью КриптоПро Промо

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка иллюстрирует возможность подписания XML SOAP-конверта по стандарту Cades-BES средствами 1С с помощью внешней компоненты КриптоПРО "CAdESCOM" с учетом ГОСТ 2001 и ГОСТ 2012. Стандарт используется в различных механизмах государственных сайтов России, в том числе в СМЭВ и ГИС ЖКХ. Код не привязан к прикладному решению может быть встроен куда угодно, но только на платформе Windows.

1 стартмани

13.05.2019    12006    45    PythonJ    41    

Обфускатор операционного кода 1с

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Защита обработок 1С от восстановления исходного кода awa-ким декомпилятором. Протестировано 1С:Предприятие 8.3 (8.3.16.1502)

2 стартмани

18.09.2020    3737    16    m1cr0sh    27    

Мобильная платформа. Штрихкоды в Android.

Разработка внешних компонент Мобильная разработка Сканер штрих-кода v8::Mobile Абонемент ($m)

Пример конфигурации, содержащей внешнюю компоненту для мобильной платформы, выводящую изображение штрихкода в интерфейсе мобильного приложения.

3 стартмани

14.09.2020    1336    1    kinan    13    

Инструменты отладки Web-страниц в приложении на устройстве Android

Мобильная разработка WEB Инструментарий разработчика Разработка внешних компонент v8::Mobile Абонемент ($m)

При разработке сложных интерфейсов на базе HTML часто возникает необходимость отладки стилей CSS и скриптов непосредственно на устройстве. Статья описывает способ отладки web-содержимого приложения мобильной платформы 1С на Андроид устройстве с помощью Chrome Development Tools.

7 стартмани

26.08.2020    1598    2    ingeneerz@gmail.com    2    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    45581    253    informa1555    232    

Мусорная корзина, или удаление помеченных объектов для мобильной платформы

Мобильная разработка Чистка базы v8 v8::Mobile 1cv8.cf Абонемент ($m)

Обработка удаления помеченных объектов для встраивания в Ваши мобильные приложения.

2 стартмани

18.08.2020    1280    2    GAMLET    0    

Расширение "PUSH уведомления для мобильного клиента".

Мобильная разработка v8::Mobile КА1 ERP2 УТ11 1С:CRM Россия Абонемент ($m)

Расширение для отправки PUSH уведомлений в мобильный клиент на Android. Подходит для типовых конфигураций, протестирована на конфигурации КА 2.4.

1 стартмани

04.08.2020    1670    4    romanpolyashov@yandex.ru    0    

Диагностика контекста выполнения (внешняя компонента)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Небольшая экспериментальная внешняя компонента для получения дополнительной информации о контексте выполнения.

1 стартмани

24.07.2020    4370    2    YPermitin    14    

TextRadar - нечеткий поиск в тексте Промо

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    17844    27    TSSV    18    

Нано HTTP сервер - внешняя компонента для мобильного приложения 1C, на Android

Разработка внешних компонент Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Нано HTTP сервер на терминале сбора данных "ATOL Smart.Lite android 7.0". Работает только с GET и POST запросами. Аутентификация BASE64. Не поддерживает HTTPS и не передает файлы. В прикрепленном архиве исходники на компоненту (С++ и java для Android Studio 3.6.2), ЦФ - мобильного приложения и тестовая обработка.

1 стартмани

22.06.2020    2730    7    SanyMaga    19    

Простое мобильное приложение, информирующее об остатках на складах и ценах по штрихкоду, для 1С: УНФ, Розница, УТ 11

Розничная торговля Учет ТМЦ Ценообразование, анализ цен Торговое оборудование Управленческий учет (прочее) Мобильная разработка v8::ОУ v8::Mobile Розница УТ11 УУ Абонемент ($m)

Для различных торговых предприятий(магазинов, супермаркетов, торговых баз и т.п.) крайне необходимо персоналу, быстро уточнять наличие на складе или цену продаваемой номенклатуры. Что может быть проще взять свой смартфон навести камеру, и все выяснить. Но не тут то было, в стандартном функционале 1С Розницы, УНФ, Торговли и т.п., ничего для быстрой обработки штрихкодов нет. На инфостарте ничего нужного, я также не нашел. В итоге пришлось разработать данное решение.

2 стартмани

03.06.2020    2879    12    Romyl01    21    

Перехват сканирования Android Native API

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Native компонента для перехвата сканирования шк и передачу в мобильную 1С.

1 стартмани

29.04.2020    4866    34    evgeny43    40    

Беспроводные метки NFC Промо

Мобильная разработка v8::Mobile Абонемент ($m)

Технический прогресс не стоит на месте, появляющиеся новые технологии со временем дешевеют и становятся доступны практически всем желающим. Как пример можно привести мобильные телефоны. Середина 80-ых - начало 90-ых были переносные таксофоны с ручками или кирпичи стоимостью несколько тысяч $, конец 90-ых - большого размера трубки, с торчащими антеннами со стоимостью от 100$ Такую же аналогию можно провести с NFC метками, используемыми в учетных целях.

1 стартмани

16.05.2017    21996    57    PloAl    18    

Мобильная платформа. Уникальный идентификатор устройства Android при помощи внешней компоненты. Не IMEI

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Идентифицируем устройства, на которых установлены копии нашего приложения.

3 стартмани

23.04.2020    3281    3    kinan    15    

Мобильная платформа. Шифрование строк в Android при помощи внешней компоненты

Разработка внешних компонент Защита и шифрование v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Шифруем строки.

3 стартмани

15.04.2020    2645    0    kinan    0    

Android Java и NativAPI C++ внешняя компонента для широковещательных сообщений (отправка и прием). Подключаем сканер ШК и клавиатуру к "1С мобильное приложение"

Оптовая торговля Розничная торговля Сканер штрих-кода Разработка внешних компонент Мобильная разработка v8::Mobile Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Подключаем сканер ШК и клавиатуру к "1С мобильное приложение", на терминале сбора данных "ATOL Smart.Lite android 7.0". Работаем с буфером обмена. В архиве к теме; 1. исходник компоненты (папка package готовый zip); 2. исходник "AccessibilityService" для перехвата клавиатуры (папка package готовый apk); 3. cf - тестовая конфигурация

1 стартмани

15.04.2020    4080    38    SanyMaga    84    

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    83823    238    Serginio    71    

Мобильная платформа. Реакция на внешнее событие в Android при помощи внешней компоненты

Мобильная разработка Разработка внешних компонент v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Пришиваем платформе уши, чтобы лучше слышать.

3 стартмани

06.04.2020    4224    7    kinan    17    

Обработка голосового ввода текста с использованием (intent)

Мобильная разработка v8::Mobile 1cv8.cf Абонемент ($m)

Обработка для голосового ввода текста с использованием дополнительных возможностей ОС Android.

1 стартмани

26.02.2020    3029    2    algabas    7    

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    6877    32    Johny_v    12    

Приложение Android для идентификации/распознавания образов (с обучением с одного раза, One-Shot Learning) с возможностью работы с 1С через веб-сервис Промо

Мобильная разработка v8 Абонемент ($m)

В данной статье описано приложение, алгоритм и методика распознавания изображений, предоставляющее посредством http-запросов информацию о распознанных объектах в 1С. В качестве примера интеграции прилагается конфигурация, реализующая веб-сервис для приема запросов от приложения.

1 стартмани

19.06.2018    15576    4    informa1555    15    

Simple UI: простой конструктор мобильных приложений для устройств на Android. Самый быстрый способ создания рабочего места на смартфоне или ТСД. Обновление от 07.11.2020: ноябрьский и ранее сентябрьский пакеты

Мобильная разработка v8 УУ Абонемент ($m)

Simple UI – это полностью бесплатная платформа для создания мобильных рабочих мест на Android. Конструктор позволяет создавать мобильные клиенты для учетных систем и самостоятельные приложения на телефонах, ТСД (терминалах сбора данных), планшетах, электронных киосках и других устройствах. При этом не нужно разбираться в мобильной разработке, Android SDK ведь основная цель платформы – максимально упростить процесс разработки и поддержки, сделать его визуальным, собирать приложения из готовых блоков с минимумом кода. Причем код обработчиков можно писать на языке учетной системы либо задавать логику обработки событий с помощью команд REST, SQL и визуального конструктора. Проект постоянно развивается изыскивая новые способы упрощения разработки и повышения функционала и является пожалуй самым быстрым способом как создать MVP-проект так и продакшн-систему под конкретное внедрение или тиражный продукт.Тестировалось на 1С: Предприятие 8.3 релиз 8.3.13.1865.

1 стартмани

14.11.2019    16232    160    informa1555    100    

Получение AndroidID в мобильном приложении

Мобильная разработка v8::Mobile Россия Абонемент ($m)

Получаем Android DeviceID в мобильном приложении/клиенте, используя стороннее приложение.

1 стартмани

05.11.2019    7944    4    sam441    11    

ODa - Android приложение для подключения к любой конфигурации 1С, используя OData протокол

Мобильная разработка v8 1cv8.cf Абонемент ($m)

В платформе 1С реализована прекрасная возможность работы с открытым веб-протоколом OData, который предоставляет любой другой платформе интерфейс доступа - возможность запрашивать и обновлять данные из базы 1С. Далее в статье будут описаны особенности работы мобильного приложения ODa, которое без программировании на стороне Android'a позволит разработчикам публиковать базы 1С, что даст возможность обычным пользователям взаимодействовать с объектами метаданных, используя нативные элементы интерфейса платформы Android.

1 стартмани

22.10.2019    10026    8    Kosigo    11    

Tool1CD Beta в деле Промо

Разработка внешних компонент v8 Абонемент ($m)

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    25958    28    baton_pk    26    

Native внешняя компонента для оповещения по UDP или TCP

Разработка внешних компонент v8 Абонемент ($m)

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    9897    19    vdv2701    31    

Запутывание кода 1С

Защита и шифрование v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка запутывания (обфускации) исходного кода 1С с помощью регулярных выражений.

2 стартмани

02.09.2019    11286    53    leoxz    66    

Защищаем конфигурацию. Один ключ СЛК для всех клиентов

Защита и шифрование v8 Абонемент ($m)

Пользователь защищенной конфигурации вводит регистрационный номер и код доступа. Установка сервера СЛК у пользователя не требуется. Управляем лицензиями удаленно.

1 стартмани

30.08.2019    12725    15    mvxyz    63    

Мобильное приложение "Отчет по проделанной работе" Промо

Мобильная разработка Учет рабочего времени Учет рабочего времени v8 Россия УУ Абонемент ($m)

Приложение выполняет фиксацию рабочего времени у клиентов, а также заявок на работы, пригодится как шаблон для разработки своего или как готовое решение для работников в сфере услуг, которые фиксируют время у клиентов. В приложении 2 документа: первый "отчет за день", второй "заявка" и полезный инструмент "Отчет задачи", который в свою очередь создан для просмотра, анализа и закрытия заявок. Тестировал на Iphone 6s.

10 стартмани

01.12.2017    22847    10    olejnikov_m    6    

Внешняя компонента Sundries: несколько полезных системных функций

Разработка внешних компонент v8 Абонемент ($m)

Звук, пауза, буфер обмена, раскладки клавиатуры и т.д.

4 стартмани

30.08.2019    5889    5    sivin-alexey    10    

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции

Терминал сбора данных Мобильная разработка Розничная торговля Розничная торговля v8::Mobile Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции на ТСД под Android. Получение данных марок (штрихкодов), используя БПО для мобильного приложения. Разработка на платформе 8.3.13.1809. Мобильная платформа 8.3.13.64. Версия сборщика 2.0.8.19.

1 стартмани

18.07.2019    7811    21    savostin.alex    5    

Внешняя компонента для принтеров Bixolon

Разработка внешних компонент v8::Mobile Абонемент ($m)

Представлена компонента мобильной платформы 1С для ОС Android, поддерживающая принтеры этикеток и чеков семейства Bixolon. Тестировалась на релизе мобильной платформы 8.3.14.53.

5 стартмани

08.07.2019    4256    2    IgorKissil    4    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    47582    428    ПерваяСистема    147    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. Для автоматизации склада нужен только телефон

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    13057    34    informa1555    27    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    19795    76    MarkoSokolov    47    

Проверка пинкода для мобильного приложения

Защита и шифрование v8::Mobile Абонемент ($m)

Простая проверка с помощью пинкода на вход в мобильное приложение.

3 стартмани

16.04.2019    3910    2    bashinsky    2    

Компоненты распознавания и печати штрих-кодов Промо

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    69818    85    igorberezhnov    95    

Управление ТСД Zebra с помощью внешней компоненты для мобильной платформы

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Представлена внешняя компонента для управления сканерами терминалов Zebra из мобильных приложений 1С.

2 стартмани

15.04.2019    9558    30    IgorKissil    17    

Обработка нажатия аппаратных кнопок на ТСД в мобильной платформе

Разработка внешних компонент Терминал сбора данных Розничная торговля Розничная торговля v8::Mobile Абонемент ($m)

Обработка и передача события нажатия аппаратных клавиш на Android в мобильную платформу 1С.

1 стартмани

11.04.2019    10971    44    dewersia    33    

Андроид активити, разработанное для запуска и сбора информации из мобильного приложения 1С 8.3

Мобильная разработка v8::Mobile 1cv8.cf Автомобили, автосервисы Абонемент ($m)

Активити доступно из кода мобильного приложения 1С 8.3. Может использоваться как часть приложения при приемке автомобиля на предприятиях автосервиса. По сути является модальным диалогом, для внесения данных по осмотру автомобиля при приемке/передаче.

1 стартмани

10.04.2019    5700    1    hiEnergy    1    

Полезные приемы при работе с Excel из 1С (Версия 3.1) Промо

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    203303    445    Zerocl    70    

Подкасты сайта "Эхо Москвы" в мобильном приложении 1С

Мобильная разработка v8::Mobile Россия Абонемент ($m)

Данная разработка показывает возможности мобильного приложения от 1С на примере получения данных с сайта радиостанции "Эхо Москвы" и последующего проигрывания мультимедиа.

1 стартмани

09.03.2019    5564    2    NovPas    6    

Альтернатива для "ПоказатьВыборИзСписка" и "ПоказатьВопрос" для приложений на Мобильной Платформе (УФ)

Мобильная разработка v8::УФ v8::Mobile 1cv8.cf Абонемент ($m)

Внешняя обработка, которая может быть интегрирована в вашу мобильную конфигурацию, если вы собираетесь уделить внимание интерфейсу программы в объеме отличном от нуля. Позволяет организовать выбор пользователем одного элемента из массива или спискаЗначений с возможностью управления цветом, размером и положением как текста вопроса, так и вариантов ответов.

1 стартмани

04.02.2019    6893    1    HorusTheOne    0    

Инструкция по применению мобильного приложения 1С:Штрихкоды

Мобильная разработка Практика программирования Сканер штрих-кода v8::Mobile Абонемент ($m)

После выпуска обзора на настраиваемое мобильное приложение для сканирования штрихкодов у заинтересованных лиц появилось множество вопросов о том, как этим пользоваться.

1 стартмани

18.01.2019    8969    3    inord777    1    

Telemonitor - объединяем Telegram и 1С Промо

Сервисные утилиты Администрирование данных 1С Мобильная разработка v8 1cv8.cf Абонемент ($m)

Не так давно Telegram предоставил API для создания ботов. Telemonitor - программа, позволяющая легко настроить собственного бота для работы с 1С.

1 стартмани

09.08.2015    78150    210    salexdv    178    

Сканер штрих-кодов Сервер + Клиент

Мобильная разработка Сканер штрих-кода Розничная торговля Розничная торговля v8::Mobile 1cv8.cf Россия Абонемент ($m)

Мобильное приложение для магазинов одежды, продавец сканирует товар, и ему мобилка выдает остаток +сумму+ склад+ цвет+ размер+ свойство товара.

1 стартмани

18.01.2019    6625    1    enot_tut    0    

Управление сканером "Beluga" из мобильного приложения 1С

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Внешняя компонента для терминалов сбора данных MT65.

5 стартмани

26.11.2018    7237    9    IgorKissil    3