Консоль запросов для ЗУП 3.х

Публикация № 1149456 Дата создания: 05.11.19 14:10

Разработка - Инструментарий разработчика - Консоль запросов

Консоль запросов ЗУП Представления

Доработка стандартной консоли запросов для работы с механизмом представлений из ЗУП 3.х.

За основу взята стандартная консоль для управляемого приложения с https://its.1c.ru/db/metod8dev/content/4500/hdoc для версии 8.3. Цель доработки - возможность редактирования (создания) отчетов из ЗУП 3.х с использованием механизма представлений в консоли.

Для примера стандартный отчет График Отпусков,  в запросе 3 пакета. При попытке выполнить данный запрос в консоли, он возвратит пустой результат, т.к. механизм представлений ЗУП 3.х преобразует временную таблицу Представления_КадровыеДанныеСотрудников в несколько таблиц. Идея доработки - при обращении к конструктору консоли передать текст запроса в ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);

Собственно на этом все :). Ниже детали моей реализации:

В консоли запросов добавил реквизит УчестьПредставленияЗУП(булево) и табличную часть ПараметрыЗУП(реквизиты Ключ и Значение)

 

В процедуру ОткрытьКонструкторЗапроса(Команда) в модуле формы консоли добавил вызов преобразования запроса из общего модуля путем копирования целиком ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме) плюс обработка параметров и удаление пакетов на уничтожение таблиц. Также изменил немного код в процедуре ДобавитьПараметрВФорму(ПараметрыВФорме, ПараметрСтруктуры)

 

&НаКлиенте
////
Процедура ОткрытьКонструкторЗапроса(Команда)

   
ИндексТекущегоЗапроса = ИндексТекущегоВопроса();
    Если
ИндексТекущегоЗапроса = Неопределено Тогда
       
ТекстСообщения = НСтр("ru = 'Выберите запрос.'");
       
СообщитьПользователю(ТекстСообщения, "Объект");
        Возврат;
    КонецЕсли;

   
ТекстЗапросаВФорме = СокрЛП(ТекстЗапроса.ПолучитьТекст());
   
//// + Механизм представлений
   
Если УчестьПредставленияЗУП И СтрНайти(ТекстЗапросаВФорме, "Представления_") > 0 Тогда
       
ТекстЗапросаВФорме = ПолучитьТекстНаСервере(ТекстЗапросаВФорме);
    КонецЕсли;
   
//// - Механизм представлений
   
КонструкторЗапроса = Новый КонструкторЗапроса(ТекстЗапросаВФорме);
   
Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияКонструктораЗапроса", ЭтотОбъект, ИндексТекущегоЗапроса);
   
КонструкторЗапроса.Показать(Оповещение);

КонецПроцедуры

 

 

 

#Область ДляОбработкиПредставленийЗУП
&НаСервере

Функция ПолучитьТекстНаСервере(ТекстЗапросаВФорме)
   
//ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);
   
ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);
    Возврат
ТекстЗапросаВФорме;
КонецФункции


&НаСервере
Процедура ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаПриемник, СхемаКомпоновкиДанных = Неопределено) Экспорт

   
СоответствиеПараметров = Новый Структура;

   
МассивЗапросов = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(ТекстЗапросаПриемник, ";");


    Для Каждого
ТекстЗапроса1 Из МассивЗапросов Цикл

       
ТекстЗапросаВРег = ВРег(ТекстЗапроса1);

       
ПозицияСловаПоместить = СтрНайти(ТекстЗапросаВРег, "ПОМЕСТИТЬ ");

        Если
ПозицияСловаПоместить > 0 Тогда

           
ПозицияСловаПредставления = СтрНайти(ТекстЗапросаВРег, "ПРЕДСТАВЛЕНИЯ_");

           
ЭтоОписаниеПредставления = Ложь;

            Если
ПозицияСловаПредставления > 0
               
И ПозицияСловаПредставления > ПозицияСловаПоместить Тогда

               
ЭтоОписаниеПредставления = ПустаяСтрока(Сред(ТекстЗапросаВРег, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ"), ПозицияСловаПредставления - ПозицияСловаПоместить - СтрДлина("ПОМЕСТИТЬ")));

            КонецЕсли;

            Если
ЭтоОписаниеПредставления Тогда

               
//Запрос = ПолучитьЗапросПоПредставлению(ТекстЗапроса1, СоответствиеПараметров);
               
Запрос = ЗарплатаКадрыОбщиеНаборыДанных.ПолучитьЗапросПоПредставлению(ТекстЗапроса1, СоответствиеПараметров);

                Если
Запрос <> Неопределено Тогда

                   
ТекстЗапросаИсточник = Запрос.Текст;

                   
ИмяИсточникаДанных = ЗарплатаКадрыОбщиеНаборыДанных.ПервоеСловоНачинаяСПозицииВТексте(ТекстЗапроса1, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ "));
                   
ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьИмяСоздаваемойВременнойТаблицы(ТекстЗапросаИсточник, ИмяИсточникаДанных, СтрЗаменить(ИмяИсточникаДанных, "Представления_", "Представления"));

                   
//ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаИсточник, СхемаКомпоновкиДанных);
                   
ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаИсточник, СхемаКомпоновкиДанных);

                   
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекстЗапроса1, ТекстЗапросаИсточник);

                    Если
СхемаКомпоновкиДанных <> Неопределено И Запрос.Параметры.Количество() > 0 Тогда

                       
УдаляемыеПараметры = Новый Массив;
                        Для Каждого
КлючИЗначение Из Запрос.Параметры Цикл
                           
ИмяПараметра = КлючИЗначение.Ключ;
                            Если
СтрНайти(ИмяПараметра, "Представления_") = 0 Тогда
                                Продолжить;
                            КонецЕсли;
                           
НовоеИмяПараметра = СтрЗаменить(ИмяПараметра, "Представления_", "Представления");
                           
Запрос.Параметры.Вставить(НовоеИмяПараметра, КлючИЗначение.Значение);
                           
УдаляемыеПараметры.Добавить(ИмяПараметра);
                        КонецЦикла;

                        Для Каждого
УдаляемыйПараметр Из УдаляемыеПараметры Цикл
                           
Запрос.Параметры.Удалить(УдаляемыйПараметр);
                        КонецЦикла;

                        Если
ТипЗнч(СхемаКомпоновкиДанных) = Тип("Запрос") Тогда
                           
//СкопироватьПараметрыЗапроса(СхемаКомпоновкиДанных, Запрос);
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапроса(СхемаКомпоновкиДанных, Запрос);
                        ИначеЕсли
ТипЗнч(СхемаКомпоновкиДанных) = Тип("ДинамическийСписок") Тогда
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапросаВДинамическийСписок(СхемаКомпоновкиДанных, Запрос);
                        Иначе
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапросаВСКД(СхемаКомпоновкиДанных, Запрос);
                        КонецЕсли;

                    КонецЕсли;

                КонецЕсли;

            Иначе

               
ИмяИсточникаДанных = ЗарплатаКадрыОбщиеНаборыДанных.ПервоеСловоНачинаяСПозицииВТексте(ТекстЗапроса1, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ "));
               
СоответствиеПараметров.Вставить(ИмяИсточникаДанных, Лев(ТекстЗапроса1, ПозицияСловаПоместить - 1));

            КонецЕсли;

        КонецЕсли;

    КонецЦикла;

   
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, "Представления_", "Представления");

   
//// Параметры представлений
   
Если Строка(ТипЗнч(Запрос.Параметры)) = "Структура" И Не Запрос.Параметры.Количество() = 0 Тогда
       
Объект.ПараметрыЗУП.Очистить();
        Для Каждого
Стр Из Запрос.Параметры Цикл

           
ТекЭлемент = Объект.ПараметрыЗУП.Добавить();
           
ТекЭлемент.Ключ = Стр.Ключ;
           
ТекЭлемент.Значение = Стр.Значение;

        КонецЦикла;
    КонецЕсли;

   
//// Удалить запрос уничтожения
   
ЧислоСтрок = СтрЧислоСтрок(ТекстЗапросаПриемник);
    Для
Стр = 1 По ЧислоСтрок Цикл
       
ТекСтрока = СтрПолучитьСтроку(ТекстЗапросаПриемник, Стр);
        Если
СтрНачинаетсяС(ТекСтрока, "УНИЧТОЖИТЬ ") Тогда
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока + Символы.ПС + ";", "//");
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока + Символы.ПС + Символы.ПС +";", "//");
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока, "//");
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры



#КонецОбласти

 

Процедура ДобавитьПараметрВФорму(ПараметрыВФорме, ПараметрСтруктуры)
   
Значение    = ПараметрСтруктуры.Значение;
   
Тип         = ОбъектОбработки().ИмяТипаИзЗначения(Значение);

   
// Основные реквизиты.
   
Элемент                         = ПараметрыВФорме.Добавить();
   
Элемент.Идентификатор           = Новый УникальныйИдентификатор;
   
Элемент.ИдентификаторЗапроса    = ПараметрСтруктуры.ИдентификаторЗапроса;
   
Элемент.Имя                     = ПараметрСтруктуры.Имя;
   
Элемент.Тип                     = Тип;
   
//////
   
Если УчестьПредставленияЗУП И СтрНайти(ПараметрСтруктуры.Имя, "Периоды") <> 0 Тогда
       
Значение = "{""D"",00010101000000}";
    КонецЕсли;
   
//////
   
Элемент.Значение                = Значение;

   
Значение = ЗначениеИзСтрокиВнутр(Значение);

   
// Форменные реквизиты.
   
Элемент.ТипВФорме               = Строка(ТипЗнч(Значение));
   
//Элемент.ЗначениеВФорме            = Значение;
    ////
   
Если УчестьПредставленияЗУП Тогда
       
ОбъектФормы = РеквизитФормыВЗначение("Объект");
       
НайденнаяСтрока = ОбъектФормы.ПараметрыЗУП.Найти(Элемент.Имя, "Ключ");
        Если
НайденнаяСтрока <> Неопределено Тогда
           
Элемент.ЗначениеВФорме = НайденнаяСтрока.Значение;
        Иначе
           
Элемент.ЗначениеВФорме = Значение;
        КонецЕсли;
    Иначе
       
Элемент.ЗначениеВФорме = Значение;
    КонецЕсли;
   
////

КонецПроцедуры

 

 

Вернемся к запросу из отчета График отпусков. На рисунке ниже запрос до и после обработки представлений:

 

Параметры подхватываются автоматически:

 

Получившийся результат в консоли:

 

В заключение: тестировал в Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.9.159), тонкий клиент.  К сожалению, формат публикации не позволяет выложить бесплатно. Надеюсь, приведенное описание позволит легко повторить идею. 

Скачать файлы

Наименование Файл Версия Размер
Консоль запросов для ЗУП 3.х:

.epf 98,52Kb
44
.epf 98,52Kb 44 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
8. Muhin555 20 24.07.20 18:02 Сейчас в теме
Спасибо. Хорошая подсказка для трансформации запросов!!!
Только реквизит УчестьПредставленияЗУП(булево) судя по тексту Процедур расположен на форме а не в реквизитах обработки.
И в самом описании как-то не четко описано, что данная функция меняет текст самого запроса заменяя одну ВТ Представления_КадровыеДанныеСотрудников на несколько Временных таблиц.
Вернее даже описать, что данная примочка дополняет запрос временными таблицами для дальнейшего заполнения таблицы "Представления"
11. alon 171 27.10.20 16:55 Сейчас в теме
12. German_Tagil 27 11.11.20 11:25 Сейчас в теме
скачал попытался выполнить простой запрос с представлениями
и ничего не получилось - хотелось бы разобраться в чем причина
Зарплата и управление персоналом, редакция 3.1 (3.1.15.67)
1С:Предприятие 8.3 (8.3.15.1830)
Alien_RS_Forever; +1 Ответить
13. Alien_RS_Forever 434 10.06.21 15:45 Сейчас в теме
Разработчик, ау, не работает ваша консолька.
Оставьте свое сообщение

См. также

Консоль запросов с графом (Анализатор сложных запросов) Промо

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9.1 от 18.10.2019 (поддержка WebKit).

10 стартмани

03.05.2017    102706    472    manuel    288    

Доработка стандартной консоли запросов с ИТС (для 8.2, обычные формы) для возможности получения данных запросом из внешних файлов (.xls, .xlsx, .mxl)

Консоль запросов v8 Платформа 1C v8.2 1cv8.cf Абонемент ($m)

Пример доработки стандартной консоли запросов 8.2, по шагам с описанием и скриншотами + окончательный вариант.

1 стартмани

04.04.2021    1642    3    mrmr    0    

Консоль SQL запросов на клиенте/сервере

Консоль запросов v8 1cv8.cf Абонемент ($m)

Быстрый старт по написанию обработки запроса из SQL таблицы: 1) указать параметры подключения к базе SQL 2) написать запрос (в Предприятии или Конфигураторе) и обработчик запроса (в Конфигураторе) 3) встроить как внешнюю обработку - profit

2 стартмани

13.01.2021    2131    4    user785225    0    

Отладчик запроса 1С 8.3 (управляемые формы), бета-версия

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

По просьбам некоторых своих коллег и пользователей Инфостарта, выкладываю первую версию обработки "Отладчик запросов by Акулов А.С.", переделанной под управляемые формы. Реализованы почти все возможности из отладчика запросов, которые присутствовали в версии под обычные формы, а также добавлено немного нового.

1 стартмани

28.09.2020    10976    119    DrAku1a    29    

Управляемая консоль запросов, отчетов 3.8.9 (расширение, внешняя обработка) Промо

Консоль запросов v8 v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Работа с запросом и СКД, Полная поддержка пакетных запросов, временных таблиц, Сравнение результатов, текстов, Разбор структуры запроса в виде дерева, Анализ плана запроса, Групповая обработка

5 стартмани

14.08.2018    115784    2847    Evg-Lylyk    734    

Генератор внешних печатных форм

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Консоль запросов Прочие инструменты разработчика Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Генератор печатных форм - инструмент для создания внешних печатных форм в режиме предприятия с минимальным написанием кода

3 стартмани

18.09.2020    4440    17    andy_zhav    7    

Консоль запросов с перехватом открытых отчетов СКД для получения реального текста запроса

Консоль запросов v8::УФ v8::Запросы v8::СКД ERP2 УТ11 КА2 Абонемент ($m)

Обработка Консоль запросов с перехватом отчётов позволяет выбрать открытый отчёт СКД и получить реальный текст запроса с учётом наложенных пользователем параметров и отборов.

1 стартмани

28.08.2020    4162    28    kran    0    

Консоль запросов (толстый и тонкий клиент) (управляемое приложение)

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Конструктор запросов в управляемом приложении в 1С (толстый и тонкий клиент)

1 стартмани

12.08.2020    4292    14    Denr83    0    

Консоль запросов + ТЗ как параметры Промо

Консоль запросов v8 1cv8.cf Украина Абонемент ($m)

Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

2 стартмани

12.11.2010    41176    448    Kashemir    24    

"Запросник 3.0" с раскраской кода в WebKit

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Развитие легендарного "Запросника" при работе с платформами 8.3.14.1565 и выше с webkit.

1 стартмани

02.03.2020    7863    79    Gmix    7    

Консоль запросов 9000

Консоль запросов v8 v8::Запросы 1cv8.cf Абонемент ($m)

Простая и удобная консоль запросов 1С для управляемых форм 8.3, работает на любой конфигурации без ее модификации. Возможность использования как внешней обработки или в составе расширения. С перехватом любых запросов и поддержкой всех типов данных во временных таблицах. Анализ плана запроса, запроса на уровне СУБД. Обработка результата кодом.

1 стартмани

24.02.2020    20023    381    kuza2000    139    

Консоль запросов к базам SQL

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Консоль запросов к базе MS SQL из 1С 8.3.

1 стартмани

18.02.2020    5180    14    nikolasx    5    

Exec - Выполнение кода, консоль запросов и не только! Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Незаменимый инструмент администратора БД и программиста: Выполняйте произвольный код из режима 1С Предприятие; сохраняйте/загружайте часто используемые скрипты; выполняйте запросы с замером производительности запроса в целом и каждой из временных таблиц в частности, а также с просмотром содержимого временных таблиц; произвольным образом изменяйте любые объекты БД, редактируя даже не вынесенные на формы реквизиты и записывая изменения в режиме "ОбменДанными.Загрузка = Истина"; легко узнавайте ИД объектов БД; выполняйте прямые запросы к SQL с замером производительности и не только!

5 стартмани

10.11.2015    44137    76    catsam    11    

Конструктор запросов при внешнем подключении

Консоль запросов Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Конструктор запроса при внешнем подключении (с возможностью выборки по табличным частям объектов конфигурации). Управляемые формы, тонкий клиент.

1 стартмани

23.01.2020    6061    7    falcon_wild    2    

Универсальная выгрузка данных и анализ

Обработки Универсальные обработки Обмен данными 1С Загрузка и выгрузка в Excel Обмен через XML Перенос данных из 1C8 в 1C8 Консоль запросов v8 1cv8.cf Абонемент ($m)

Обработка предназначена для выгрузки результатов выполнения запросов в различных форматах, а также анализа данных.

1 стартмани

27.11.2019    8243    24    kozusenok    7    

Консоль запросов управляемая с конструктором

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка Консоль запросов позволяет использовать полноценный функционал конструктора и получать план выполнения запроса. Так же главная отличительная особенность от аналогов - то что она работает.

1 стартмани

17.10.2019    6840    6    Indgo    27    

КонЗап - консоль запросов с улучшенным интерфейсом и дополнительными функциями Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Консоль запросов (Платформа 8.х режим - обычное приложение) с улучшенным интерфейсом и дополнительными функциями (загрузка параметров запроса из файла, работа с временными таблицами, замер времени выполнения, групповая обработка результатов запроса). Часть функций позаимствованы из других обработок, часть разработаны "с нуля".

1 стартмани

16.07.2014    17138    112    serjpsv    18    

Консоль запросов с перехватом отчетов СКД (для получения реального текста запроса) и запросов

Консоль запросов v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m)

Доработанная консоль запросов с автоматическим заполнением текста запроса и всех параметров на основании объекта Запрос, полученного в "Конфигураторе" или перехваченного встроенного/внешнего отчёта СКД.

1 стартмани

29.09.2019    11995    50    strek_ivan    4    

Консоль запросов с перехватом открытых отчетов СКД для получения реального текста запроса

Консоль запросов v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m)

Доработанная консоль запросов для получения реального текста запроса.

1 стартмани

30.08.2019    14604    60    strek_ivan    29    

Консоль запросов с возможностью сравнения данных между базами (управляемые формы)

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Данная консоль позволяет сравнивать любые данные полученные произвольными запросами между текущей базой и внешней базой данных как файловой, так и клиент-серверной.

3 стартмани

26.08.2019    10108    39    Dadriel619960    9    

Модифицированная консоль запросов от Ярославцева для Управляемых форм в 8.2 Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

По просьбам участников форума доработал консоль запросов для управляемых форм, добавил возможность исполнения кода. В текущем варианте код исполняется только на сервере. В продолжение темы: http://infostart.ru/public/117157/

1 стартмани

14.03.2012    20681    124    black_doctor    6    

Сравнение запросов

Консоль запросов v8 v8::Запросы 1cv8.cf Абонемент ($m)

На входе - два разных запроса и две выборки с одинаковыми полями. На выходе - итоговая таблица показывает расхождения между полученными результатами запросов.

1 стартмани

16.03.2019    12984    15    Rustig    31    

Встраиваем консоль запросов для отбора в стандартные обработки 1С

Консоль запросов v8 1cv8.cf Абонемент ($m)

Данное руководство поможет встроить форму отбора в стандартные обработки 1С, например "Групповое изменение реквизитов" или "Поиск и удаление дублей". Бывает случаи, что нужно сделать сложный отбор элементов, который невозможно реализовать через стандартный отбор или, в случае поиска и удаления дублей, справочник имеет тысячи элементов и поиск по нему дублей может знять даже не один день. Тут на помощь приходит консоль запросов, которая встраивается в обработки и помогает отобрать нужные элементы для дальнейших с ними действий.

1 стартмани

01.03.2019    7263    3    w.r.    3    

Консоль запросов с их сохранением в базе

Консоль запросов v8 1cv8.cf Казахстан Абонемент ($m)

Консоль запросов стандартная, предназначена для создания и выполнения запросов в режиме предприятия с помощью конструктора запросов или вручную. Долгое время использовал эту стандартную консоль запросов и даже научил нескольких бухгалтеров пользоваться ею, и понял, что основное неудобство - это хранение запросов во внешних файлах, когда копии запросов расползаются по рабочим столам, и бухгалтера (да и я ) должны помнить, где лежит последняя версия запроса. И тогда мне пришла мысль хранить их в самой базе, что я и реализовал. При этом возможности штатного сохранения\чтения в/из внешних файлов осталась неизменной.

1 стартмани

26.02.2019    7125    0    makfromkz    9    

Консоль запросов "Запросник" для управляемых форм с подсветкой синтаксиса Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Вот уже много лет я использую замечательный инструмент для работы с запросами - Запросник. Однако, с переходом на управляемые формы для его использования пришлось запускать базы в устаревшем толстом клиенте, да еще и разрешать в свойствах конфигурации использование обычных форм. В 2014 году появился запросник на управляемых формах, который, к сожалению, оказался несовершенен из за ограничений платформы. Самое неприятное из них - отсутствие подсветки синтаксиса. Мне кажется, что я нашел решение этой проблемы.

1 стартмани

19.04.2016    41425    261    1С_Мастер    42    

Консоль запросов для управляемого интерфейса

Консоль запросов v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Данная обработка — предназначена для отладки запросов.

1 стартмани

04.02.2019    7869    16    Xapac    3    

Консоль запросов (управляемые формы) + возможность работы в толстом клиенте

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Одна обработка для Толстого и тонкого клиента. Работает как на управляемых, так и не управляемых формах. Заброс получился большой и громоздкий - ГДЕ ТОРМОЗИТ? Нужно писать в консоли для обработки и часть параметров не используется? 1С зависла при выполнения запроса и текст запроса потерян, а авто сохранение не любите, т.к. он при ошибке не оставляет вам вариантов - ошибка уже вписалась?! Тестируете обработку Табличных Частей документа? Толстый клиент проверен на 8.2.19.130, Управл. формы на 8.3.10.2580. УФ Оптимизация под такси, но нормально под простой интерфейс.

1 стартмани

17.01.2019    8358    8    Sevg    0    

Выгрузка запроса из отладки в консоль запросов (Управляемые формы)

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Помощник в отладке и доработке запросов использующих менеджер временных таблиц.

1 стартмани

13.11.2018    9919    8    redtram    2    

Консоль запросов, СКД, ADODB. Управляемое приложение. Промо

Консоль запросов v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Консоль запросов/отчетов, СКД, ADODB. Ввывод в таблицу значений, дерево или табличный документ(только для СКД)), обработка результата, произвольные обработчики расшифровки и прочие плюшки. Написана с нуля для платформы 8.3.х. На платформе 8.3.5 доступен Конструктор запросов в тонком клиенте.

1 стартмани

21.02.2014    35219    545    unknownDaemon    67    

Консоль запросов для управляемых форм 8.3

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Универсальная внешняя обработка для создания, редактирования и отладки запросов, с возможностью обработки таблицы результатов произвольными алгоритмами на языке 1С. Выгрузка результатов запроса в таблицу или дерево значений, включая временные таблицы и запросы пакета. Формирование запроса для консоли в отладчике, включая временные таблицы и параметры. Версия 1.1.0.71 от 24.06.2021

3 стартмани

08.11.2018    29662    356    ROL32    30    

Консоль Внедренца v.3.6.2

Консоль запросов Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Идея данной обработки заключается в создании простого, функционального и универсального инструментария для внедренцев и программистов 1С, который будет работать как в толстом клиенте на обычных и на управляемых формах, так и в тонком клиенте. Интерфейс и логика работы максимально идентичны у обычных форм и управляемых. Инструментарий включает в себя: Консоль кода, Консоль запросов, Консоль отчетов (СКД), Универсальную обработку объектов, Средства для работы с таблицами базы данных 1С, Редактирование регистров сведений базы, Инструмент по работе с табличными документами - загрузка данных из табличного документа.

1 стартмани

27.08.2018    27112    425    evvakra    42    

Консоль запросов

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Консоль запросов для УФ. Внешне похожа на консоль для обычного приложения. Но есть ряд новых возможностей.

1 стартмани

25.06.2018    11792    15    17808849    10    

Консоль запросов для тонкого клиента с просмотром временных таблиц и импортом запросов из конфигуратора Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Теперь можно в табло посмотреть произвольные ВТ, сделанные в других запросах и переданные через МенеджерВременныхТаблиц. И также посмотреть их в пользовательском режиме.

1 стартмани

28.11.2014    14637    37    Boris-Leleko    3    

Консоль HTTP-запросов с генерацией кода

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Консоль HTTP-запросов, которая не только выполняет запросы и получает результат их выполнения, но и генерирует необходимый код. Использую на 8.3.11.2899.

1 стартмани

25.05.2018    29773    316    leongl    19    

Униформальная консоль запросов

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Минималистичная и функциональная консоль запросов, которая выглядит и работает одинаково, как в обычных формах, так и в управляемых.

1 стартмани

23.05.2018    26626    325    Synoecium    58    

Групповая обработка реквизитов + консоль запросов

Консоль запросов v8 v8::УФ v8::Запросы Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m)

Расширение конфигурации, которое в типовую обработку "Групповое изменение реквизитов" добавляет возможность отбирать объекты для обработки запросом. Необходимо наличие обработки "Консоль запросов" с ИТС.

2 стартмани

20.03.2018    20027    55    Kutuzov    6    

Консоль запросов для платформы 1С 8.2-8.3 (Управляемое приложение, Такси) Промо

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Данная консоль запросов является доработанной версией стандартной консоли с сайта ИТС т.к. нужного и удобного функционала не было найдено. Для модернизации были взяты наработки из консоли http://infostart.ru/public/126781/ (большое спасибо автору). Консоль протестирована и готова к работе. Обновление от 13.04.2014, версия 1.1

2 стартмани

09.04.2014    51804    398    hakerxp    13    

Консоль запросов: работа с временными таблицами

Консоль запросов v8 v8::Запросы 1cv8.cf Россия Абонемент ($m)

Консоль запросов помогает сэкономить время при работе со сложными запросами со временными таблицами.

1 стартмани

12.12.2017    11951    20    lapa_kn    1    

Консоль запросов OData

Консоль запросов v8 1cv8.cf Абонемент ($m)

Консоль запросов по протоколу OData.

1 стартмани

30.08.2017    23213    84    vlsv    7    

Консоль запросов 8.3 (обычное приложение) с возможностью переноса параметров запроса через строку (из отладки). А также с возможностью очень быстрой выгрузки больших объемов данных в Excel(CSV) исключительно мощностями сервера

Консоль запросов v8 1cv8.cf Россия Казахстан Абонемент ($m)

Доработанная консоль запросов для 1С 8.3. Доработанные функции: 1. Загрузка параметров запроса из строки, полученной в отладке методом ЗначениеВСтрокуВнутр(Запрос.Параметры) 2. Выгрузка результата запроса в CSV файл на сервере и передача его на клиент. Быстрее в 10 раз чем стандартное "Сохранить Как" 3. Получение на основание запроса кода для выполнения обработки. При этом в коде уже прописаны все установленные для запроса параметры, а так же типизировано основное поле результата. 4. Конвертация текста запроса из вложенных запросов, во временные таблицы

1 стартмани

09.07.2017    16664    38    matveev.andrey.v    0    

Консоль отладки сложных запросов с временными таблицами, оптимизированная (1.4 / 22.11.13 / ЧИА) Промо

Консоль запросов v8 Абонемент ($m)

Реализована возможность работы с временными таблицами по названиям таблиц. Добавлена нумерация строк в ВТ. Добавлена автосортировка строк в ВТ. Список параметров оптимизирован для работы со списком значений.

1 стартмани

15.11.2013    22352    100    ЧИА    8    

Консоль запросов к mySQL

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Простенькая консоль на УФ для выполнения запросов к БД MySQL.

1 стартмани

14.03.2017    12710    11    dim_zal    1    

Консолька (версия 6.0.44)

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Беларусь Абонемент ($m)

Обработка Консолька предназначена для выполнения запросов к информационной базе 1С в режиме управляемого приложения, выполнения запросов к базам данных SQL, выполнения произвольного кода 1С.

1 стартмани

27.02.2017    23099    73    sertak    42    

Консоль запросов SQL

Консоль запросов v8 1cv8.cf Абонемент ($m)

Иногда возникает желание посмотреть, как информация 1С уложена в базе данных. Данная обработка позволяет показать структуру базы данных, а так же обычными SQL-запросами просмотреть содержимое таблиц MsSQL.

1 стартмани

21.10.2016    11987    47    igel9780    8    

Консоль запросов 1С "consquery.ru" Промо

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Удобная и функциональная консоль запросов со своей историей.

1 стартмани

05.07.2006    45890    267    zenechka    148    

"Консоль запросов" с возможностью вывода UID справочников и документов

Консоль запросов v8 1cv8.cf Абонемент ($m)

Доработанная обработка "Консоль запросов" с возможностью вывода UID справочников и документов.

10 стартмани

11.07.2016    8906    7    graysvd    4    

Консоль запросов для больших баз данных (БД)

Консоль запросов v8 1cv8.cf Абонемент ($m)

Самая обычная консоль запросов для толстого клиента, но обладающая некоторыми специальными возможностями для отладки и сверки сложных запросов, которые выбирают большие объёмы данных. А именно: -Сохранение результата запроса в файл; -Возможность выборки из сохраненного файла; -Замеры времени выполнения отдельных временных таблиц в запросе; -Подготовка текста запроса к помещению в модуль; -Проверка запроса на не уничтоженные временные таблицы;

1 стартмани

28.06.2016    12404    19    ixilimuse    9    

Доработанная консоль запросов 1С 8.3

Консоль запросов v8 1cv8.cf Абонемент ($m)

После многих дней доработок, консоль стала более совершенной. Поменялся интерфейс, добавились новые возможности.

1 стартмани

28.03.2016    19791    126    Раис910    10    

Гламурная консоль запросов "СуперСтар" (толстый клиент) Промо

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Инструменты разработчика бывают разного назначения. Бывает технологическая инструментальная консоль для всяких выгрузок и исполнения фрагментов кода. Ну а бывает любимая консоль - нечто более сокровенное, как для меня эта консоль - можно сказать мой "рабочий орган", в котором проводишь большую часть рабочего дня и который самое главное должен быть красивый, удобный и поднимающий настроение. С эстетической точки зрения мне не нравится интерфейс управляемых форм, мне кажется старые формы красивее. Надеюсь прелести рисованных неуправляемых форм со всякими фишечками и рюшечками толстого клиента помогут мне доставить всем программистам удовольствие от работы с данной версией консоли, которое получаю от нее я сам. Огромное уважение автору оригинальной разработки Hobi (http://infostart.ru/profile/132974/), с разрешения которого я занимаюсь доработкой этой формы консоли для толстого клиента обычного приложения 8.2 (устаревшая версия http://infostart.ru/public/125225/).

1 стартмани

21.09.2012    22026    150    ksnik    10    

Консоль запросов для УФ с подсветкой синтаксиса и обработкой результата

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Самая быстрая консоль запросов для управляемых форм с подсветкой синтаксиса и обработкой результата

1 стартмани

08.01.2016    36068    516    BurningChrome    82