Консоль запросов для ЗУП 3.х

Публикация № 1149456

Разработка - Инструментарий разработчика - Консоль запросов

Консоль запросов ЗУП Представления

24
Доработка стандартной консоли запросов для работы с механизмом представлений из ЗУП 3.х.

За основу взята стандартная консоль для управляемого приложения с https://its.1c.ru/db/metod8dev/content/4500/hdoc для версии 8.3. Цель доработки - возможность редактирования (создания) отчетов из ЗУП 3.х с использованием механизма представлений в консоли.

Для примера стандартный отчет График Отпусков,  в запросе 3 пакета. При попытке выполнить данный запрос в консоли, он возвратит пустой результат, т.к. механизм представлений ЗУП 3.х преобразует временную таблицу Представления_КадровыеДанныеСотрудников в несколько таблиц. Идея доработки - при обращении к конструктору консоли передать текст запроса в ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);

Собственно на этом все :). Ниже детали моей реализации:

В консоли запросов добавил реквизит УчестьПредставленияЗУП(булево) и табличную часть ПараметрыЗУП(реквизиты Ключ и Значение)

 

В процедуру ОткрытьКонструкторЗапроса(Команда) в модуле формы консоли добавил вызов преобразования запроса из общего модуля путем копирования целиком ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме) плюс обработка параметров и удаление пакетов на уничтожение таблиц. Также изменил немного код в процедуре ДобавитьПараметрВФорму(ПараметрыВФорме, ПараметрСтруктуры)

 

&НаКлиенте
////
Процедура ОткрытьКонструкторЗапроса(Команда)

   
ИндексТекущегоЗапроса = ИндексТекущегоВопроса();
    Если
ИндексТекущегоЗапроса = Неопределено Тогда
       
ТекстСообщения = НСтр("ru = 'Выберите запрос.'");
       
СообщитьПользователю(ТекстСообщения, "Объект");
        Возврат;
    КонецЕсли;

   
ТекстЗапросаВФорме = СокрЛП(ТекстЗапроса.ПолучитьТекст());
   
//// + Механизм представлений
   
Если УчестьПредставленияЗУП И СтрНайти(ТекстЗапросаВФорме, "Представления_") > 0 Тогда
       
ТекстЗапросаВФорме = ПолучитьТекстНаСервере(ТекстЗапросаВФорме);
    КонецЕсли;
   
//// - Механизм представлений
   
КонструкторЗапроса = Новый КонструкторЗапроса(ТекстЗапросаВФорме);
   
Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияКонструктораЗапроса", ЭтотОбъект, ИндексТекущегоЗапроса);
   
КонструкторЗапроса.Показать(Оповещение);

КонецПроцедуры

 

 

 

#Область ДляОбработкиПредставленийЗУП
&НаСервере

Функция ПолучитьТекстНаСервере(ТекстЗапросаВФорме)
   
//ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);
   
ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаВФорме);
    Возврат
ТекстЗапросаВФорме;
КонецФункции


&НаСервере
Процедура ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаПриемник, СхемаКомпоновкиДанных = Неопределено) Экспорт

   
СоответствиеПараметров = Новый Структура;

   
МассивЗапросов = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(ТекстЗапросаПриемник, ";");


    Для Каждого
ТекстЗапроса1 Из МассивЗапросов Цикл

       
ТекстЗапросаВРег = ВРег(ТекстЗапроса1);

       
ПозицияСловаПоместить = СтрНайти(ТекстЗапросаВРег, "ПОМЕСТИТЬ ");

        Если
ПозицияСловаПоместить > 0 Тогда

           
ПозицияСловаПредставления = СтрНайти(ТекстЗапросаВРег, "ПРЕДСТАВЛЕНИЯ_");

           
ЭтоОписаниеПредставления = Ложь;

            Если
ПозицияСловаПредставления > 0
               
И ПозицияСловаПредставления > ПозицияСловаПоместить Тогда

               
ЭтоОписаниеПредставления = ПустаяСтрока(Сред(ТекстЗапросаВРег, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ"), ПозицияСловаПредставления - ПозицияСловаПоместить - СтрДлина("ПОМЕСТИТЬ")));

            КонецЕсли;

            Если
ЭтоОписаниеПредставления Тогда

               
//Запрос = ПолучитьЗапросПоПредставлению(ТекстЗапроса1, СоответствиеПараметров);
               
Запрос = ЗарплатаКадрыОбщиеНаборыДанных.ПолучитьЗапросПоПредставлению(ТекстЗапроса1, СоответствиеПараметров);

                Если
Запрос <> Неопределено Тогда

                   
ТекстЗапросаИсточник = Запрос.Текст;

                   
ИмяИсточникаДанных = ЗарплатаКадрыОбщиеНаборыДанных.ПервоеСловоНачинаяСПозицииВТексте(ТекстЗапроса1, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ "));
                   
ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьИмяСоздаваемойВременнойТаблицы(ТекстЗапросаИсточник, ИмяИсточникаДанных, СтрЗаменить(ИмяИсточникаДанных, "Представления_", "Представления"));

                   
//ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаИсточник, СхемаКомпоновкиДанных);
                   
ЗарплатаКадрыОбщиеНаборыДанных.ЗаменитьЗапросыКПредставлениямВиртуальныхТаблиц(ТекстЗапросаИсточник, СхемаКомпоновкиДанных);

                   
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекстЗапроса1, ТекстЗапросаИсточник);

                    Если
СхемаКомпоновкиДанных <> Неопределено И Запрос.Параметры.Количество() > 0 Тогда

                       
УдаляемыеПараметры = Новый Массив;
                        Для Каждого
КлючИЗначение Из Запрос.Параметры Цикл
                           
ИмяПараметра = КлючИЗначение.Ключ;
                            Если
СтрНайти(ИмяПараметра, "Представления_") = 0 Тогда
                                Продолжить;
                            КонецЕсли;
                           
НовоеИмяПараметра = СтрЗаменить(ИмяПараметра, "Представления_", "Представления");
                           
Запрос.Параметры.Вставить(НовоеИмяПараметра, КлючИЗначение.Значение);
                           
УдаляемыеПараметры.Добавить(ИмяПараметра);
                        КонецЦикла;

                        Для Каждого
УдаляемыйПараметр Из УдаляемыеПараметры Цикл
                           
Запрос.Параметры.Удалить(УдаляемыйПараметр);
                        КонецЦикла;

                        Если
ТипЗнч(СхемаКомпоновкиДанных) = Тип("Запрос") Тогда
                           
//СкопироватьПараметрыЗапроса(СхемаКомпоновкиДанных, Запрос);
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапроса(СхемаКомпоновкиДанных, Запрос);
                        ИначеЕсли
ТипЗнч(СхемаКомпоновкиДанных) = Тип("ДинамическийСписок") Тогда
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапросаВДинамическийСписок(СхемаКомпоновкиДанных, Запрос);
                        Иначе
                           
ЗарплатаКадрыОбщиеНаборыДанных.СкопироватьПараметрыЗапросаВСКД(СхемаКомпоновкиДанных, Запрос);
                        КонецЕсли;

                    КонецЕсли;

                КонецЕсли;

            Иначе

               
ИмяИсточникаДанных = ЗарплатаКадрыОбщиеНаборыДанных.ПервоеСловоНачинаяСПозицииВТексте(ТекстЗапроса1, ПозицияСловаПоместить + СтрДлина("ПОМЕСТИТЬ "));
               
СоответствиеПараметров.Вставить(ИмяИсточникаДанных, Лев(ТекстЗапроса1, ПозицияСловаПоместить - 1));

            КонецЕсли;

        КонецЕсли;

    КонецЦикла;

   
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, "Представления_", "Представления");

   
//// Параметры представлений
   
Если Строка(ТипЗнч(Запрос.Параметры)) = "Структура" И Не Запрос.Параметры.Количество() = 0 Тогда
       
Объект.ПараметрыЗУП.Очистить();
        Для Каждого
Стр Из Запрос.Параметры Цикл

           
ТекЭлемент = Объект.ПараметрыЗУП.Добавить();
           
ТекЭлемент.Ключ = Стр.Ключ;
           
ТекЭлемент.Значение = Стр.Значение;

        КонецЦикла;
    КонецЕсли;

   
//// Удалить запрос уничтожения
   
ЧислоСтрок = СтрЧислоСтрок(ТекстЗапросаПриемник);
    Для
Стр = 1 По ЧислоСтрок Цикл
       
ТекСтрока = СтрПолучитьСтроку(ТекстЗапросаПриемник, Стр);
        Если
СтрНачинаетсяС(ТекСтрока, "УНИЧТОЖИТЬ ") Тогда
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока + Символы.ПС + ";", "//");
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока + Символы.ПС + Символы.ПС +";", "//");
           
ТекстЗапросаПриемник = СтрЗаменить(ТекстЗапросаПриемник, ТекСтрока, "//");
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры



#КонецОбласти

 

Процедура ДобавитьПараметрВФорму(ПараметрыВФорме, ПараметрСтруктуры)
   
Значение    = ПараметрСтруктуры.Значение;
   
Тип         = ОбъектОбработки().ИмяТипаИзЗначения(Значение);

   
// Основные реквизиты.
   
Элемент                         = ПараметрыВФорме.Добавить();
   
Элемент.Идентификатор           = Новый УникальныйИдентификатор;
   
Элемент.ИдентификаторЗапроса    = ПараметрСтруктуры.ИдентификаторЗапроса;
   
Элемент.Имя                     = ПараметрСтруктуры.Имя;
   
Элемент.Тип                     = Тип;
   
//////
   
Если УчестьПредставленияЗУП И СтрНайти(ПараметрСтруктуры.Имя, "Периоды") <> 0 Тогда
       
Значение = "{""D"",00010101000000}";
    КонецЕсли;
   
//////
   
Элемент.Значение                = Значение;

   
Значение = ЗначениеИзСтрокиВнутр(Значение);

   
// Форменные реквизиты.
   
Элемент.ТипВФорме               = Строка(ТипЗнч(Значение));
   
//Элемент.ЗначениеВФорме            = Значение;
    ////
   
Если УчестьПредставленияЗУП Тогда
       
ОбъектФормы = РеквизитФормыВЗначение("Объект");
       
НайденнаяСтрока = ОбъектФормы.ПараметрыЗУП.Найти(Элемент.Имя, "Ключ");
        Если
НайденнаяСтрока <> Неопределено Тогда
           
Элемент.ЗначениеВФорме = НайденнаяСтрока.Значение;
        Иначе
           
Элемент.ЗначениеВФорме = Значение;
        КонецЕсли;
    Иначе
       
Элемент.ЗначениеВФорме = Значение;
    КонецЕсли;
   
////

КонецПроцедуры

 

 

Вернемся к запросу из отчета График отпусков. На рисунке ниже запрос до и после обработки представлений:

 

Параметры подхватываются автоматически:

 

Получившийся результат в консоли:

 

В заключение: тестировал в Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.9.159), тонкий клиент.  К сожалению, формат публикации не позволяет выложить бесплатно. Надеюсь, приведенное описание позволит легко повторить идею. 

24

Скачать файлы

Наименование Файл Версия Размер
Консоль запросов для ЗУП 3.х:
.epf 98,52Kb
05.11.19
11
.epf 98,52Kb 11 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. gull22 87 06.11.19 10:30 Сейчас в теме
Для реализации Вашего желания о бесплатности ответьте на мое сообщение и прикрепите свой файл :)
jONES1979; Dmitri93; +2 Ответить
2. evgeni-red 42 07.11.19 07:39 Сейчас в теме
(1)
Ваша публикация "Консоль запросов для ЗУП 3.х" была отклонена модератором по причине: Файл необходимо добавить в раздел Файлы. Прочие варианты распространения файлов запрещены, в том числе через личные сообщения. Выставляйте за стартмани.
3. akim2040 13 07.11.19 08:46 Сейчас в теме
(2) Я вот упустил, в какой момент политика инфостарта стала против бесплатной раздачи наработок и как следствие знаний? Ведь раньше было много бесплатных публикаций
4. evgeni-red 42 07.11.19 10:51 Сейчас в теме
(3) Боюсь не отвечу на ваш вопрос, но могу предположить, что Инфостарт не против распространения знаний, но с раздачи наработок( в виде вложений) хочет получить свой процент.
Оставьте свое сообщение

См. также

Консоль запросов управляемая с конструктором 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Обработка Консоль запросов позволяет использовать полноценный функционал конструктора и получать план выполнения запроса. Так же главная отличительная особенность от аналогов - то что она работает.

1 стартмани

17.10.2019    1238    3    ogidni    27       

Консоль запросов с перехватом отчетов СКД и запросов 14

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m) Консоль запросов

Доработанная консоль запросов с автоматическим заполнением текста запроса и всех параметров на основании объекта Запрос, полученного в "Конфигураторе" или перехваченного встроенного/внешнего отчёта СКД.

2 стартмани

29.09.2019    1977    7    strek_ivan    3       

Консоль запросов с возможностью сравнения данных между базами (управляемые формы) 17

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Данная консоль позволяет сравнивать любые данные полученные произвольными запросами между текущей базой и внешней базой данных как файловой, так и клиент-серверной.

2 стартмани

26.08.2019    1739    14    Dadriel619960    9       

Встраиваем консоль запросов для отбора в стандартные обработки 1С 10

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Данное руководство поможет встроить форму отбора в стандартные обработки 1С, например "Групповое изменение реквизитов" или "Поиск и удаление дублей". Бывает случаи, что нужно сделать сложный отбор элементов, который невозможно реализовать через стандартный отбор или, в случае поиска и удаления дублей, справочник имеет тысячи элементов и поиск по нему дублей может знять даже не один день. Тут на помощь приходит консоль запросов, которая встраивается в обработки и помогает отобрать нужные элементы для дальнейших с ними действий.

1 стартмани

01.03.2019    2497    2    w.r.    3       

Консоль запросов с их сохранением в базе 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Казахстан Абонемент ($m) Консоль запросов

Консоль запросов стандартная, предназначена для создания и выполнения запросов в режиме предприятия с помощью конструктора запросов или вручную. Долгое время использовал эту стандартную консоль запросов и даже научил нескольких бухгалтеров пользоваться ею, и понял, что основное неудобство - это хранение запросов во внешних файлах, когда копии запросов расползаются по рабочим столам, и бухгалтера (да и я ) должны помнить, где лежит последняя версия запроса. И тогда мне пришла мысль хранить их в самой базе, что я и реализовал. При этом возможности штатного сохранения\чтения в/из внешних файлов осталась неизменной.

1 стартмани

26.02.2019    2078    makfromkz    9       

Консоль запросов (управляемые формы) + возможность работы в толстом клиенте 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Одна обработка для Толстого и тонкого клиента. Работает как на управляемых, так и не управляемых формах. Заброс получился большой и громоздкий - ГДЕ ТОРМОЗИТ? Нужно писать в консоли для обработки и часть параметров не используется? 1С зависла при выполнения запроса и текст запроса потерян, а авто сохранение не любите, т.к. он при ошибке не оставляет вам вариантов - ошибка уже вписалась?! Тестируете обработку Табличных Частей документа? Толстый клиент проверен на 8.2.19.130, Управл. формы на 8.3.10.2580. УФ Оптимизация под такси, но нормально под простой интерфейс.

1 стартмани

17.01.2019    2479    7    Sevg    0       

Выгрузка запроса из отладки в консоль запросов (Управляемые формы) 5

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Помощник в отладке и доработке запросов использующих менеджер временных таблиц.

1 стартмани

13.11.2018    3964    4    redtram    2       

Консоль запросов для управляемых форм 8.3 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Универсальная внешняя обработка (СДРКонсольЗапросовХ) для создания, редактирования и отладки запросов, с возможностью обработки таблицы результатов произвольными алгоритмами на языке 1С. Выгрузка результатов запроса в таблицу или дерево значений, включая временные таблицы и запросы пакета. Формирование запроса для консоли в отладчике, включая временные таблицы и параметры. Версия 1.1.0.39 от 14.10.2019

3 стартмани

08.11.2018    7426    72    ROL32    8       

Консоль запросов 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов для УФ. Внешне похожа на консоль для обычного приложения. Но есть ряд новых возможностей.

1 стартмани

25.06.2018    6364    16    17808849    10       

Консоль HTTP-запросов с генерацией кода 165

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Консоль запросов

Консоль HTTP-запросов, которая не только выполняет запросы и получает результат их выполнения, но и генерирует необходимый код. Использую на 8.3.11.2899.

1 стартмани

25.05.2018    15541    219    leongl    15       

Униформальная консоль запросов 107

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Минималистичная и функциональная консоль запросов, которая выглядит и работает одинаково, как в обычных формах, так и в управляемых.

1 стартмани

23.05.2018    17228    273    Synoecium    50       

Групповая обработка реквизитов + консоль запросов 13

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ v8::Запросы Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m) Консоль запросов

Расширение конфигурации, которое в типовую обработку "Групповое изменение реквизитов" добавляет возможность отбирать объекты для обработки запросом. Необходимо наличие обработки "Консоль запросов" с ИТС.

2 стартмани

20.03.2018    12280    42    Kutuzov    6       

Консоль запросов со встроенным Конструктором запросов для 1с8.3 (8.2) своими руками 12

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m) Консоль запросов

Мы можем сами создать свою консоль запросов - именно такую, которая подходит для наших нужд. Кроме того, создав собственную Консоль запросов, Вы не только получаете удобный для себя инструмент, а также получаете навык программирования в среде 1с8, что очень полезно будет начинающим программистам 1С.

1 стартмани

21.12.2017    16053    51    jan-pechka    23       

Консоль запросов: работа с временными таблицами 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Россия Абонемент ($m) Консоль запросов

Консоль запросов помогает сэкономить время при работе со сложными запросами со временными таблицами.

1 стартмани

12.12.2017    6334    9    lapa_kn    1       

Консоль запросов OData 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов по протоколу OData.

1 стартмани

30.08.2017    14144    67    vlsv    6       

Консоль запросов 8.3 (обычное приложение) с возможностью переноса параметров запроса через строку (из отладки). А также с возможностью очень быстрой выгрузки больших объемов данных в Excel(CSV) исключительно мощностями сервера 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Казахстан Абонемент ($m) Консоль запросов

Доработанная консоль запросов для 1С 8.3. Доработанные функции: 1. Загрузка параметров запроса из строки, полученной в отладке методом ЗначениеВСтрокуВнутр(Запрос.Параметры) 2. Выгрузка результата запроса в CSV файл на сервере и передача его на клиент. Быстрее в 10 раз чем стандартное "Сохранить Как" 3. Получение на основание запроса кода для выполнения обработки. При этом в коде уже прописаны все установленные для запроса параметры, а так же типизировано основное поле результата. 4. Конвертация текста запроса из вложенных запросов, во временные таблицы

1 стартмани

09.07.2017    10372    28    matveev.andrey.v    0       

Консоль запросов с графом (Анализатор сложных запросов) 341

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9.1 от 18.10.2019 (поддержка WebKit).

10 стартмани

03.05.2017    87136    376    manuel    225       

Консоль запросов 1С 8 / SQL (версия 5.3.42) 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Беларусь Абонемент ($m) Консоль запросов

Обработка Консоль запросов 1С 8 / SQL предназначена для создания и выполнения запросов в режиме управляемого приложения к информационным базам 1С 8 и базам данных SQL.

1 стартмани

27.02.2017    16212    67    sertak    26       

Консоль запросов EX (внешние данные) 15

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Работа с внешними данными в консоли запросов (1С 7.7, 8.x, XBase, Excel, ADO)

1 стартмани

30.10.2016    5463    25    Cерый    0       

Консоль запросов SQL 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Иногда возникает желание посмотреть, как информация 1С уложена в базе данных. Данная обработка позволяет показать структуру базы данных, а так же обычными SQL-запросами просмотреть содержимое таблиц MsSQL.

1 стартмани

21.10.2016    7494    44    igel9780    8       

"Консоль запросов" с возможностью вывода UID справочников и документов 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Доработанная обработка "Консоль запросов" с возможностью вывода UID справочников и документов.

10 стартмани

11.07.2016    4402    6    graysvd    4       

Консоль запросов для больших баз данных (БД) 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Самая обычная консоль запросов для толстого клиента, но обладающая некоторыми специальными возможностями для отладки и сверки сложных запросов, которые выбирают большие объёмы данных. А именно: -Сохранение результата запроса в файл; -Возможность выборки из сохраненного файла; -Замеры времени выполнения отдельных временных таблиц в запросе; -Подготовка текста запроса к помещению в модуль; -Проверка запроса на не уничтоженные временные таблицы;

1 стартмани

28.06.2016    8490    21    ixilimuse    9       

Консоль запросов "Запросник" для управляемых форм с подсветкой синтаксиса 35

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Вот уже много лет я использую замечательный инструмент для работы с запросами - Запросник. Однако, с переходом на управляемые формы для его использования пришлось запускать базы в устаревшем толстом клиенте, да еще и разрешать в свойствах конфигурации использование обычных форм. В 2014 году появился запросник на управляемых формах, который, к сожалению, оказался несовершенен из за ограничений платформы. Самое неприятное из них - отсутствие подсветки синтаксиса. Мне кажется, что я нашел решение этой проблемы.

1 стартмани

19.04.2016    31432    263    1С_Мастер    42       

Доработанная консоль запросов 1С 8.3 32

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

После многих дней доработок, консоль стала более совершенной. Поменялся интерфейс, добавились новые возможности.

1 стартмани

28.03.2016    14756    127    Раис910    10       

Консоль запросов для УФ с подсветкой синтаксиса и обработкой результата 119

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Самая быстрая консоль запросов для управляемых форм с подсветкой синтаксиса и обработкой результата

1 стартмани

08.01.2016    28696    488    BurningChrome    81       

Консоль запросов для управляемого приложения с возможностью вывода в таблицу значений 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Часто при отладке запросов на базах с большим объемом информации возникают ситуации, когда вывод большого количества строк результатов запроса в табличный документ занимает много времени. Представленная обработка позволяет выводить результат запроса в таблицу значений, что практически исключает время ожидания результата.

1 стартмани

20.11.2015    5913    14    merabn    11       

ADO Консоль запросов с конструктором для управляемого приложения (8.3.6+) 124

Инструменты и обработки Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Обработка "Консоль запросов" для управляемого приложения с возможностью строить запросы к внешним источникам данных по интерфейсу ADO. Имеет встроенный конструктор запросов с типовым интерфейсом для управляемого приложения. В одном пакете можно обращаться к нескольким внешним источникам. В результате ADO запроса можно получить как обычную выборку данных, так и ВременнуюТаблицу, которую можно использовать в других запросах 1С или в контексте ADO... Управляемые формы, платформа не ниже 8.3.6.

1 стартмани

13.11.2015    19750    231    DC    41       

Exec - Выполнение кода, консоль запросов и не только! 70

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Незаменимый инструмент администратора БД и программиста: Выполняйте произвольный код из режима 1С Предприятие; сохраняйте/загружайте часто используемые скрипты; выполняйте запросы с замером производительности запроса в целом и каждой из временных таблиц в частности, а также с просмотром содержимого временных таблиц; произвольным образом изменяйте любые объекты БД, редактируя даже не вынесенные на формы реквизиты и записывая изменения в режиме "ОбменДанными.Загрузка = Истина"; легко узнавайте ИД объектов БД; выполняйте прямые запросы к SQL с замером производительности и не только!

5 стартмани

10.11.2015    36305    173    catsam    11       

Консоль запросов с временными таблицами 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Предназначена для отладки запросов с временными таблицами. На базе обработки с ИТС (обычное приложение). Похожа на разработку http://infostart.ru/public/19577/, но предлагает более простой сценарий использования.

1 стартмани

30.09.2015    10227    13    Mleg    9       

Консоль запросов RLS 57

Инструменты и обработки Программист Приложение (exe) v8 Windows Абонемент ($m) Консоль запросов

Поставка включает в себя конфигурацию, внешнюю обработку и файл описания в формате pdf (приведенный ниже). Консоль можно использовать при анализе текста запроса RLS, который будет выполнен к данным под конкретным пользователем.

1 стартмани

22.08.2015    13578    68    Rioneri    16       

Консоль запросов (Такси) 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для технологических платформ версии 8.3 адаптированная для интерфейса "Такси".

1 стартмани

10.07.2015    9097    54    vdusaev    10       

Консоль запросов продвинутая 8.3 (с возможностью обработки результата запроса) 23

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

В 8.2 был очень удобный инструмент для выборки данных запросом и их обработки с помощью кода. Нечто подобное теперь можно сделать и в 8.3. Обработка открывает конструктор запросов в тонком клиенте, позволяет вывести результат в виде списка или дерева, обработать полученный результат нужным Вам образом с помощью кода, получить замер времени выполнения запросов, хранить тексты запросов в удобной форме, выводить GUID'ы ссылок.

1 стартмани

25.06.2015    10610    222    zyama    16       

Консоль запросов для обычного приложения с расширенным функционалом 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Консоль запросов с удобным просмотром временных таблиц, сортировкой и отбором строк как во временных таблицах, так и в результате запроса.

1 стартмани

19.05.2015    3235    22    Kharcha    2       

Простейшая консоль ADO-запросов 7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Данная обработка пригодится, если вам надо быстро проверить работоспособность и результат запроса или хранимой процедуры во внешней базе данных.

1 стартмани

08.04.2015    12821    21    Synoecium    6       

Универсальный подбор и обработка объекта + Консоль запросов 12

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Доработанная универсальная обработка "Универсальный подбор и обработка объекта" с возможностью отбирать данные по запросу и обработкой регистров сведений.

1 стартмани

27.03.2015    8909    48    vowg    6       

Консоль запросов для УФ универсальная 8.3.7.3 694

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ v8::Запросы 1cv8.cf Windows Абонемент ($m) Консоль запросов

Реализован программный вызов консоли для захвата "рваного" запроса, МВТ и параметров. В консоли реализована полная поддержка работы с таблицами значений. Выборочный просмотр пакетов и временных таблиц. Возможность выборочной выгрузки пакета запроса в ТЗ, с последующим её редактированием, сохранением на диск. Использование сохранённой ТЗ в качестве параметра для других запросов. Возможность обхода ТЗ в цикле с выполнением кода. Отсутствуют ошибки при наличии уничтожения временных таблиц. Замер времени выполнения каждого пакета запроса. Приличное окно настройки типа (только для параметров запроса), лёгкое преобразование в список значений и обратно. Поддержка дополнительных типов: ТЗ, Граница, Момент времени, Вид счёта, Вид движения и т.д. Форматирование типа значения при выводе запроса (NULL, пустая ссылка, пустая строка и т.п.). Наверное, самый лучший подбор ширины колонок. Возможность добавлять листы для вывода результатов запросов. Генерируется текст для конфигуратора с учётом количества результирующих пакетов, для каждого пакета можно настроить выборку или выгрузку и пересоздать текст.... Короче, лучше один раз увидеть ...

5 стартмани

12.03.2015    125525    4026    akor77    695       

Консоль запросов 8.3 @AlexxSys 155

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов 8.3 - это более продвинутая версия консоли запросов, как по функциям, так и по интерфейсу. Имеет полностью переработанный интерфейс, с более понятным расположением панелей кнопок. Также добавлен нужный функционал - структура конфигурации, с возможностью добавления в запрос таблиц и полей и справка по синтаксису запросов.

1 стартмани

20.02.2015    23550    559    AlexxSys    107       

Простая консоль запросов для обычного и управляемого приложения 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Консоль запросов

Настоящая консоль запросов предназначена для разработки и отладки запросов. Работает в режимах: управляемое приложение и обычное приложение. Отличия от встроенной консоли (УТ, УПП,): 1) Возможность работы в управляемом приложении. 2) Возможность задавать в параметрах таблицы значений, списки значений, массивы, моменты времени. 3) Более удобное нахождение ошибок. 4) Вывод в таблицу значений. 5) Возможность перевести результат в параметр. 6) Быстро загружать и сохранять текст запроса и параметры. 7) Замер времени исполнения.

1 стартмани

17.02.2015    4978    32    BalyunovVV    19       

Консоль запросов для управляемого приложения для запуска в "1С:Предприятии" 8.2 с планом выполнения запроса 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Обработка представляет собой "ремейк" консоли запросов с диска ИТС для управляемого приложения для запуска в "1С:Предприятии" 8.3 с планом выполнения запроса.

2 стартмани

07.02.2015    12339    63    cargobird    4       

Консоль запросов 1с 8.2 для отладки больших запросов с множеством временных таблиц (толстый клиент) 11

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Собственно обычная консоль, в которую добавлены 2 инструмента: 1. Показывать список временных таблиц запроса (закладка "таблицы"). Если кликнуть по наименованию временной таблицы, то курсор в теле запроса перейдет к ее определению. Также в теле запроса можно горячими клавишами переходить к определению временных таблиц. 2. Можно просматривать содержимое каждой временной таблицы Консолью так же удобно пользоваться и для небольших запросов :)

1 стартмани

03.02.2015    5306    114    tofff    5       

Консоль запросов к базе Oracle в 1С 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Консоль помогает проверить оракловский запрос из 1С, не используя PL/SQL developer.

1 стартмани

23.01.2015    6236    22    байт    1       

Консоль запросов для управляемых форм 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Консоль запросов для управляемого приложения с обработкой результата и выводом в табличный документ.

1 стартмани

14.12.2014    7723    46    mvsemenov    13       

Консоль запросов для тонкого клиента с просмотром временных таблиц и импортом запросов из конфигуратора 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Консоль запросов

Теперь можно в табло посмотреть произвольные ВТ, сделанные в других запросах и переданные через МенеджерВременныхТаблиц. И также посмотреть их в пользовательском режиме.

1 стартмани

28.11.2014    10222    36    Boris-Leleko    3       

Консоль запросов (обычное приложение) 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Обработка "Консоль запросов" предназначена для составления и исполнения запросов 1С:Предприятия 8.2. Данная обработка предназначена, в основном, для специалистов по внедрению и опытных пользователей.

1 стартмани

01.09.2014    5712    77    DISAoner    9       

Консоль запросов для управляемого приложения 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Консоль запросов

Полноценная консоль запросов для управляемого приложения с вызовом конструктора

1 стартмани

14.08.2014    3678    55    SmAlex    9       

КонЗап - консоль запросов с улучшенным интерфейсом и дополнительными функциями 16

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Консоль запросов

Консоль запросов (Платформа 8.х режим - обычное приложение) с улучшенным интерфейсом и дополнительными функциями (загрузка параметров запроса из файла, работа с временными таблицами, замер времени выполнения, групповая обработка результатов запроса). Часть функций позаимствованы из других обработок, часть разработаны "с нуля".

1 стартмани

16.07.2014    12188    108    serjpsv    18