Соответствие пользователей Информационной базы и Актив директория

Публикация № 1184427

Разработка - Системная интеграция - Интеграция

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Эта обработка предназначена для сопоставления пользователей в Информационной базе и пользователей в Актив директории. Пользователи в Информационной базе должны быть прописаны в Актив директории, но иногда получается так, что либо пользователь в Актив директории отсутствует вообще, либо введен в Информационную базу с ошибкой (что равнозначно).

Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. 

Работает в режиме внешней обработки. 

Перейдем к рассмотрению программного кода.

    Обработка небольшая и состоит из нескольких функций и одной процедуры, коды которых я коротко опишу.

1. Процедура запуска , она последовательно запускает на выполнение функции и процедуры обработки.

Код процедуры:
    

&НаКлиенте
Процедура ПолучитьПользователейИБ(Команда)
	МассивЛогинов=Новый Массив;
	МассивДоменов=Новый Массив;
	
	МассивЛогинов=ПолучитьПользователейИБ1();
	МассивДоменов=ПолучитьДоменыИБ1();
	ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов);
	ЗаполнениеОтличиеИБотАД();
КонецПроцедуры


2. Процедура ИнструкцияПоЭксплуатации при нажатии соответствующей кнопки выводит текст инструкции.

Код процедуры:
    

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации	 
	Инструкция="          Инструкция на обработку ПользователиИБвАД ."+Символы.ПС+" 
	|Обработка проверяет наличие всех пользователей Информационной Базы в Актив Директории."+Символы.ПС+"
	|1. Закладка ""ПользователиИБ"" отобпажает всех пользователей ИБ."+Символы.ПС+"
	|2. Закладка ""ПользователиАД"" отображает пользователей ИБ найденных в АД"+Символы.ПС+"
	|3. Закладка ""Отличие ИБ от АД"" отображает пользователей ИБ которых нет в АД и отличие пользователей ИБ и АД.";

	Предупреждение(Инструкция);

КонецПроцедуры

3. Функция ПолучитьПользователейИБ1 выбирает всех пользователей Информационной Базы, заполняет таблицу Пользователи и 
Возвращаемый массив МассивЛогинов1. Данные таблицы используются на закладке формы ПользователиИБ.
 


Код Функции:
    

&НаСервере
Функция ПолучитьПользователейИБ1()
//Выбираем всех пользователей ИБ, заполняем таблицу Пользователи и Возвращаемый массив МассивЛогинов1************************************************
	МассивЛогинов1=Новый Массив;
	ИмяДоменаАД="";                                        
	ЛогинАД="" ;
	ПолноеИмяПользователяАД="";

	Буква="";
	ЛогинИБ="";                                     
	Домен="";
	НомерПользователя=1;
	ПредидущийДомен="";
	СчетчикБукв=3;
	СчетчикДоменов=1;
	МассивПользователей= ПользователиИнформационнойБазы.ПолучитьПользователей();   //Встроенной функцией получаем массив пользователей Выборка
	Для Каждого ЭлементМассива Из МассивПользователей Цикл                         //Через цикл просматриваем массив Выборка по ключевому параметру Логин
		СчетчикБукв=3;
		ФлагДоменЛогин="Домен";
		ДоменЛогин=ЭлементМассива.ПользовательОС;                                  //Выбираем из массива пользователей значение ПользовательОС это ДоменЛогин
		ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                            //Выбираем из массива пользователей значение ПолноеИмя
		ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор; //Выбираем из массива пользователей значение УникальныйИдентификатор
		
		Запрос = Новый Запрос;                                                     //Определяем текущего пользователя в справочнике Пользователи 
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	Пользователи.Наименование КАК Наименование,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	Справочник.Пользователи КАК Пользователи
		|ГДЕ
		|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
		;
		Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл
			НаименованиеВСправочнике=Выборка.Наименование;
			Если Выборка.ПометкаУдаления=Ложь Тогда
				ПометкаУдаленияПользователя = "Действует";                          //Записываем результат ПометкаУдаления
			Иначе
				ПометкаУдаленияПользователя = "Удален";
			КонецЕсли;		
		КонецЦикла; 
		
		Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		Пока НЕ	Буква="" Цикл                                                       //В цикле преобразуем в необходимый вид Домен, ЛогинИБ, ПолноеИмяПользователя 
			Если НЕ Буква="\" Тогда
				Если ФлагДоменЛогин="Домен" Тогда
					Домен=Домен+Буква;
				КонецЕсли;
				
				Если ФлагДоменЛогин="Логин" Тогда
					ЛогинИБ=ЛогинИБ+Буква;                            
				КонецЕсли;
				
			Иначе
				ФлагДоменЛогин="Логин";	
			КонецЕсли;
			СчетчикБукв=СчетчикБукв+1;
			Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		КонецЦикла;
		Строка=Пользователи.Добавить();                                            //Добавляем в таблицу Пользователи строку с параметрами пользователя
		Строка.Номер=НомерПользователя;
		Строка.Домен=Домен;                                        
		Строка.Логин =ЛогинИБ ;
		Строка.ФИО=ПолноеИмяПользователя;
		Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		Строка.НаименованиеВСправочникеПользователи=НаименованиеВСправочнике;
		
		МассивЛогинов1.Добавить(ЛогинИБ);                                         //Добавляем в возвращаемый массив логин пользователя в Информационной базе
		
		НомерПользователя=НомерПользователя+1;
		
		ПредидущийДомен=Домен;
		
		ФлагДоменЛогин="Домен";
		ЛогинИБ="";                                 
		Домен="";
	КонецЦикла;
	Возврат МассивЛогинов1;

КонецФункции


4. Функция ПолучитьДоменыИБ1 получает список доменов в МассивДоменов1, это необходимо для просмотра пользователей
в Актив Директории.

Код Функции:
            

&НаСервере
Функция ПолучитьДоменыИБ1()
//Заполняем возвращаемый массив	МассивДоменов********************************************************************************************************
	МассивДоменов1=Новый Массив;
	ПустойДомен="";
	СчетчикДоменов=1;
	Запрос = Новый Запрос;
	ПИБ = РеквизитФормыВЗначение("Пользователи",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
	МВТ=Новый МенеджерВременныхТаблиц;                                             //Создаем МенеджерВременныхТаблиц
	Запрос.МенеджерВременныхТаблиц=МВТ;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ПИБ1.Домен КАК Домен
	|ПОМЕСТИТЬ ВТДанные
	|ИЗ
	|	&ПИБ1 КАК ПИБ1
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ВТДанные.Домен КАК Домен
	|ИЗ
	|	ВТДанные КАК ВТДанные
	|ГДЕ
	|	ВТДанные.Домен <> &ПустойДомен
	|
	|СГРУППИРОВАТЬ ПО
	|	ВТДанные.Домен"
	;
	Запрос.УстановитьПараметр("ПустойДомен",ПустойДомен);
	Запрос.УстановитьПараметр("ПИБ1",ПИБ);
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();                                
	Пока Выборка.Следующий() Цикл                                                 //Выбираем результат запроса в возвращаемый массив МассивДоменов1
		МассивДоменов1.Добавить(Выборка.Домен);
	КонецЦикла;   
	Возврат МассивДоменов1;
				
  КонецФункции
 

5. Процедура ПолучитьПользователяИзАД1 получает пользователей в Актив Директории и помещает их в таблицу ПользователиАД .
Данные таблицы используются на закладке формы ПользователиАД.
 


Код процедуры:
 

&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

6. Процедура ЗаполнениеОтличиеИБотАД заполняет таблицу ОтличиеИБотАД, которая используются на закладке формы ОтличиеИБотАД.
 


Код процедуры:
 


&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

Обработка особенно актуальна для случая когда пользователи имеют аутентификацию 
операционной системы и работают через консоль.

Скачать файлы

Наименование Файл Версия Размер
Соответствие пользователей Информационной Базы и Актив Директория.:
.epf 12,02Kb
23.01.20
1
.epf 12,02Kb 1 Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Пример связи с API Диадок через сертификат

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::ОУ v8::УФ УТ11 Россия Абонемент ($m) Интеграция

Обработка для связи с API Диадок через сертификат формата X.509 - пример подключение при двухфазной аутентификации по сертификату+получение организаций.

1 стартмани

вчера в 16:05    122    1    2vadmaster    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Redmine 1C - почти коробка

Инструменты и обработки Программист Пользователь Руководитель проекта Подсистема v8 Абонемент ($m) Управление командой Управление задачами Интеграция

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с системой Redmine.

10 стартмани

10.02.2020    1477    1    zfilin    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Интеграция 1С с мессенджером WhatsApp через chat-api

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Интеграция

Это не готовое решение для использования (разве что необходимо будет только массово отправлять сообщения получателям), данная разработка поможет быстрее понять, каким образом необходимо делать интеграцию 1С с мессенджером WhatsApp.

1 стартмани

23.01.2020    821    4    Hawk_sib    1       

Внешние источники данных: создание таблиц в MS SQL с помощью скриптов *.sql

Инструменты и обработки Программист Архив с данными v8 MS SQL Абонемент ($m) Внешние источники данных Интеграция

Как быть программисту 1С, если для интеграции базы 1С: Предприятие 8.3 есть техническое задание со стороны разработчика внешней базы данных. Но самой базы данных нет ? А она уже нужна: для отладки выгрузки данных. В тех.задании коллегами описана структура таблиц внешней базы данных. Тогда Вам можно создать такую базу данных самостоятельно. С помощью скрипта для MS SQL.

1 стартмани

21.01.2020    527    Designer1C    5       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Таймер Redmine. Учет времени по задачам

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Учет рабочего времени Интеграция Управление задачами

Таймер для учета времени в redmine. Быстрый выбор последних задач с активностью, ручной и автоматический ввод данных. Обработка для платформы 8.3, управляемые формы.

2 стартмани

09.01.2020    1326    5    kraynev-navi    1       

Разбираемся с web-kit в 1С, на примере интеграции TinyMCE в управляемую форму в УТ 11.4. Допиливаем обмен с сайтом в УТ 11.4

Статья Программист Расширение (cfe) v8 v8::УФ УТ11 Абонемент ($m) Обмен данными 1С Интеграция Адаптация типовых решений

Многие уже знают, что в релизе платформы 8.3.14.1565, браузер Internet Explorer был заменен на Web-Kit, это на самом деле большой шаг вперед, но я уверен, многим, как и мне, пока не совсем понятно, что к чему. Возник опыт использования web-kit в 1С, вызова JS из 1С и вызова 1С из JS. Давайте вместе попробуем понять, чем одно отличается от другого, и заодно сделаем, что-нибудь полезное. Да и наверняка многим придется переписывать свои подобные поделки после обновления на новую платформу, так что надеюсь мой опыт окажется полезным.

2 стартмани

08.12.2019    4712    6    Бэнни    25       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Пример взаимодействия 1С и Oracle Primavera

Инструменты и обработки no Внешняя обработка (ert,epf) v8 ERP2 Абонемент ($m) Обмен через XML Интеграция

Эта разработка демонстрирует возможность связи 1С:ERP+PM Управление проектной организацией 2 и Oralce Primavera с использованием механизма веб-сервисов со стороны Primavera.

2 стартмани

04.11.2019    1920    2    user687955_adm    0       

Интеграция с InSales. Обновление цен и остатков товаров

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m) WEB Интеграция Ценообразование, прайсы

Подсистема для интеграции с InSales. Реализация обновления цен и остатков товаров в каталоге на сайте через API. Данный пример реализован на конфигурации Альфа-Авто.

1 стартмани

18.10.2019    2253    2    leobrn    1       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Вебхук. Путь Телеграма

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Внешние источники данных Интеграция

Долгое (на самом деле нет) и нелегкое путешествие телеграма к неведомым (из за РКН) конфигурациям 1С. Памятка себе.

1 стартмани

03.10.2019    8722    6    platonov.e    14       

Медовая стыковка с поддержкой входящих налоговых накладных (Украина)

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Украина БУ Абонемент ($m) Обмен данными 1С Интеграция

Доработка стандартного модуля интеграции 1С с Медком для возможности загрузки входящих налоговых накладных и расчетов корректировки.

1 стартмани

01.10.2019    1556    Gorus    0       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Совместное использование 1С:Сервер взаимодействия и Документооборот 8 КОРП, редакция 2.1.13 - Уведомления для рабочего стола

Статья no Архив с данными v8 ДО УУ Документооборот и делопроизводство Абонемент ($m) Пользователю системы Работа с интерфейсом Интеграция

С версии ДО 2.1.13 в программу встроена подсистема Обсуждения. Данная подсистема позволяет производить уведомление пользователей без необходимости открытия программы.

1 стартмани

18.06.2019    8218    2    ilya.rudziak    9       

Универсальная очередь интеграций 1С

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Интеграция

"Универсальная очередь" это подсистема, которая позволяет осуществлять достоверную доотправку в случае неуспешно выполненной интеграции, а также выполнять интеграции в фоновом режиме. Очередь может иметь настройки расписания для каждой интеграции отдельно, хранит параметры отправки для каждого элемента очереди. Очередь можно использовать не только для интеграций, но и для выполнения любой процедуры в вашей конфигурации. В приложенном файле конфигурации содержится сама подсистема, а также примеры её использования.

1 стартмани

11.03.2019    4723    5    NovPas    6       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 Абонемент ($m) Загрузка и выгрузка в Excel Внешние источники данных Интеграция

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    36520    7    milkers    2       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) Внешние источники данных WEB Интеграция

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    35678    84    lunjio    15       

[dotPRICE.ru] Свой интернет-магазин - каждому!

Инструменты и обработки no Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ БГУ Windows Оптовая торговля Розничная торговля Абонемент ($m) Универсальные обработки WEB Интеграция

Внешняя обработка позволяет любому пользователю 1С быстро создать собственный интернет-магазин (сервис онлайн-заказов, интернет-каталог продукции...)

1 стартмани

10.01.2016    22784    58    dotPRICE.ru    36       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Внешние источники данных Интеграция Мобильная разработка

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    51131    47    pbazeliuk    18       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Выгрузка маршрута в навигационную программу Navitel

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Интеграция

Предлагаю вашему вниманию процедуру выгрузки маршрута для навигационной программы Navitel (тестировалось на устройставх android), что может быть полезно например для того чтоб облегчить работу водителей доставки или торговых представителей.

1 стартмани

13.07.2014    21352    30    axilab    3       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Парсер веб-сайтов для 1С:Предприятие 8.3

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB Интеграция

Данная конфигурация является 1С-оберткой над проектом Abot, и тесно связанным с ним проектом: Html Agility Pack.

1 стартмани

22.02.2014    47022    215    Elisy    49