Соответствие пользователей Информационной базы и Актив директория

Публикация № 1184427 23.01.20

Разработка - Системная интеграция - Интеграция

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Эта обработка предназначена для сопоставления пользователей в Информационной базе и пользователей в Актив директории. Пользователи в Информационной базе должны быть прописаны в Актив директории, но иногда получается так, что либо пользователь в Актив директории отсутствует вообще, либо введен в Информационную базу с ошибкой (что равнозначно).

Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. 

Работает в режиме внешней обработки. 

Перейдем к рассмотрению программного кода.

    Обработка небольшая и состоит из нескольких функций и одной процедуры, коды которых я коротко опишу.

1. Процедура запуска , она последовательно запускает на выполнение функции и процедуры обработки.

Код процедуры:
    

&НаКлиенте
Процедура ПолучитьПользователейИБ(Команда)
	МассивЛогинов=Новый Массив;
	МассивДоменов=Новый Массив;
	
	МассивЛогинов=ПолучитьПользователейИБ1();
	МассивДоменов=ПолучитьДоменыИБ1();
	ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов);
	ЗаполнениеОтличиеИБотАД();
КонецПроцедуры


2. Процедура ИнструкцияПоЭксплуатации при нажатии соответствующей кнопки выводит текст инструкции.

Код процедуры:
    

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации	 
	Инструкция="          Инструкция на обработку ПользователиИБвАД ."+Символы.ПС+" 
	|Обработка проверяет наличие всех пользователей Информационной Базы в Актив Директории."+Символы.ПС+"
	|1. Закладка ""ПользователиИБ"" отобпажает всех пользователей ИБ."+Символы.ПС+"
	|2. Закладка ""ПользователиАД"" отображает пользователей ИБ найденных в АД"+Символы.ПС+"
	|3. Закладка ""Отличие ИБ от АД"" отображает пользователей ИБ которых нет в АД и отличие пользователей ИБ и АД.";

	Предупреждение(Инструкция);

КонецПроцедуры

3. Функция ПолучитьПользователейИБ1 выбирает всех пользователей Информационной Базы, заполняет таблицу Пользователи и 
Возвращаемый массив МассивЛогинов1. Данные таблицы используются на закладке формы ПользователиИБ.
 


Код Функции:
    

&НаСервере
Функция ПолучитьПользователейИБ1()
//Выбираем всех пользователей ИБ, заполняем таблицу Пользователи и Возвращаемый массив МассивЛогинов1************************************************
	МассивЛогинов1=Новый Массив;
	ИмяДоменаАД="";                                        
	ЛогинАД="" ;
	ПолноеИмяПользователяАД="";

	Буква="";
	ЛогинИБ="";                                     
	Домен="";
	НомерПользователя=1;
	ПредидущийДомен="";
	СчетчикБукв=3;
	СчетчикДоменов=1;
	МассивПользователей= ПользователиИнформационнойБазы.ПолучитьПользователей();   //Встроенной функцией получаем массив пользователей Выборка
	Для Каждого ЭлементМассива Из МассивПользователей Цикл                         //Через цикл просматриваем массив Выборка по ключевому параметру Логин
		СчетчикБукв=3;
		ФлагДоменЛогин="Домен";
		ДоменЛогин=ЭлементМассива.ПользовательОС;                                  //Выбираем из массива пользователей значение ПользовательОС это ДоменЛогин
		ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                            //Выбираем из массива пользователей значение ПолноеИмя
		ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор; //Выбираем из массива пользователей значение УникальныйИдентификатор
		
		Запрос = Новый Запрос;                                                     //Определяем текущего пользователя в справочнике Пользователи 
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	Пользователи.Наименование КАК Наименование,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	Справочник.Пользователи КАК Пользователи
		|ГДЕ
		|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
		;
		Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл
			НаименованиеВСправочнике=Выборка.Наименование;
			Если Выборка.ПометкаУдаления=Ложь Тогда
				ПометкаУдаленияПользователя = "Действует";                          //Записываем результат ПометкаУдаления
			Иначе
				ПометкаУдаленияПользователя = "Удален";
			КонецЕсли;		
		КонецЦикла; 
		
		Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		Пока НЕ	Буква="" Цикл                                                       //В цикле преобразуем в необходимый вид Домен, ЛогинИБ, ПолноеИмяПользователя 
			Если НЕ Буква="\" Тогда
				Если ФлагДоменЛогин="Домен" Тогда
					Домен=Домен+Буква;
				КонецЕсли;
				
				Если ФлагДоменЛогин="Логин" Тогда
					ЛогинИБ=ЛогинИБ+Буква;                            
				КонецЕсли;
				
			Иначе
				ФлагДоменЛогин="Логин";	
			КонецЕсли;
			СчетчикБукв=СчетчикБукв+1;
			Буква=Сред(ДоменЛогин,СчетчикБукв,1);
		КонецЦикла;
		Строка=Пользователи.Добавить();                                            //Добавляем в таблицу Пользователи строку с параметрами пользователя
		Строка.Номер=НомерПользователя;
		Строка.Домен=Домен;                                        
		Строка.Логин =ЛогинИБ ;
		Строка.ФИО=ПолноеИмяПользователя;
		Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		Строка.НаименованиеВСправочникеПользователи=НаименованиеВСправочнике;
		
		МассивЛогинов1.Добавить(ЛогинИБ);                                         //Добавляем в возвращаемый массив логин пользователя в Информационной базе
		
		НомерПользователя=НомерПользователя+1;
		
		ПредидущийДомен=Домен;
		
		ФлагДоменЛогин="Домен";
		ЛогинИБ="";                                 
		Домен="";
	КонецЦикла;
	Возврат МассивЛогинов1;

КонецФункции


4. Функция ПолучитьДоменыИБ1 получает список доменов в МассивДоменов1, это необходимо для просмотра пользователей
в Актив Директории.

Код Функции:
            

&НаСервере
Функция ПолучитьДоменыИБ1()
//Заполняем возвращаемый массив	МассивДоменов********************************************************************************************************
	МассивДоменов1=Новый Массив;
	ПустойДомен="";
	СчетчикДоменов=1;
	Запрос = Новый Запрос;
	ПИБ = РеквизитФормыВЗначение("Пользователи",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
	МВТ=Новый МенеджерВременныхТаблиц;                                             //Создаем МенеджерВременныхТаблиц
	Запрос.МенеджерВременныхТаблиц=МВТ;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ПИБ1.Домен КАК Домен
	|ПОМЕСТИТЬ ВТДанные
	|ИЗ
	|	&ПИБ1 КАК ПИБ1
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ВТДанные.Домен КАК Домен
	|ИЗ
	|	ВТДанные КАК ВТДанные
	|ГДЕ
	|	ВТДанные.Домен <> &ПустойДомен
	|
	|СГРУППИРОВАТЬ ПО
	|	ВТДанные.Домен"
	;
	Запрос.УстановитьПараметр("ПустойДомен",ПустойДомен);
	Запрос.УстановитьПараметр("ПИБ1",ПИБ);
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();                                
	Пока Выборка.Следующий() Цикл                                                 //Выбираем результат запроса в возвращаемый массив МассивДоменов1
		МассивДоменов1.Добавить(Выборка.Домен);
	КонецЦикла;   
	Возврат МассивДоменов1;
				
  КонецФункции
 

5. Процедура ПолучитьПользователяИзАД1 получает пользователей в Актив Директории и помещает их в таблицу ПользователиАД .
Данные таблицы используются на закладке формы ПользователиАД.
 


Код процедуры:
 

&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

6. Процедура ЗаполнениеОтличиеИБотАД заполняет таблицу ОтличиеИБотАД, которая используются на закладке формы ОтличиеИБотАД.
 


Код процедуры:
 


&НаКлиенте
Процедура ПолучитьПользователяИзАД1(МассивЛогинов,МассивДоменов)
//Процедура заполняет таблицу ПользователиАД, из АД заносим ФИО, Логин*******************************************************************************	
//Достаем значение Логина
НомерПользователя=0;

Для Каждого ЭлементМассива из МассивЛогинов Цикл
	ЛогинИБ=ЭлементМассива; 
	Если НЕ ЛогинИБ="" Тогда		
		ЛогинПользователя=СокрЛП(ЛогинИБ);
//Комутирум Active Directory для извлечения данных о пользователе
		КомандаАДО    = Новый COMОбъект("ADODB.Command");
		СоединениеАДО = Новый COMОбъект("ADODB.Connection");
		СоединениеАДО.Provider = "ADSDSOObject";
		Попытка
			СоединениеАДО.Open("Active Directory Provider");    
		Исключение
			Сообщить("Ошибка при открытии Active Directory Provider: " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		КомандаАДО.ActiveConnection = СоединениеАДО;
		
//Получаем имя домена к которому принадлежит данный компьютер 
		Попытка
			RootDSE = ПолучитьCOMОбъект("LDAP://RootDSE");
		Исключение
			Сообщить("Ошибка ПолучитьCOMОбъект(LDAP://RootDSE): " + ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		СчетчикДоменов=0;
		ПолноеИмяПользователя="";
		ИндексДомена=0;
		ФлагЦиклаДомена=0;
		ФлагПользователя=0;
		Для Каждого ЭлементМассива из МассивДоменов Цикл
			ТекущийДомен=ЭлементМассива;
//			Если ВРег(ТекущийДомен)="KRG" Тогда
//				ТекущийДомен="DC=krg,DC=mrg,DC=ru";
//			Иначе
				ТекущийДомен=ТекущийДомен+".local";
//			КонецЕсли;
			
			CommandText = " 
			|SELECT 
			|    AdsPath
			|FROM 'LDAP://" +ТекущийДомен + "'
			|WHERE 
			|    objectCategory = 'user'
			|    and objectClass = 'person'
			|    and SAMAccountName = '" + ЛогинПользователя + "'
			|";
			
			Попытка
				ВыборкаАДО = СоединениеАДО.Execute( CommandText); 
				ПутьОбъекта = ВыборкаАДО.Fields("AdsPath").Value;
				ОбъектАД = ПолучитьCOMОбъект(ПутьОбъекта);
				ЛогинАД= ОбъектАД.sAMAccountName;
				ПолноеИмяПользователя=ОбъектАД.cn;
				Если ЛогинАД=""  Тогда                                                  //Проверяем выборку на пустое значение , если ЛогинАД пуст пропускаем эту строку 
					ФлагЦиклаДомена=1;
				КонецЕсли;
			Исключение
				ФлагЦиклаДомена=1;
			КонецПопытки;
			Если  ФлагЦиклаДомена=0 Тогда                                               //Проверяем был ли найден пользователь в домене 
				
				НомерПользователя=НомерПользователя+1;
						
				Строка=ПользователиАД.Добавить();
				Строка.ЛогинИБ =ЛогинИБ ;
				Строка.Номер=НомерПользователя;
				Строка.Домен=ТекущийДомен;                                        
				Строка.Логин =ЛогинАД ;
				Строка.ФИО=ПолноеИмяПользователя;
				
				Сообщить("Пользователь"+ПолноеИмяПользователя+" найден в АД."); 
				
				
				ИмяДомена="";
				ЛогинАД="";
				ПолноеИмяПользователя="";
				ВыборкаАДО.Close();
				Прервать;
			КонецЕсли;	
			ФлагЦиклаДомена=0;
			ИндексДомена=ИндексДомена+1;
		КонецЦикла;		
		ФлагПользователя=0;
		СоединениеАДО.Close();
	КонецЕсли;	
КонецЦикла;

КонецПроцедуры

 

Обработка особенно актуальна для случая когда пользователи имеют аутентификацию 
операционной системы и работают через консоль.

Скачать файлы

Наименование Файл Версия Размер
Соответствие пользователей Информационной Базы и Актив Директория.:

.epf 12,02Kb
5
.epf 12,02Kb 5 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Тикеты - система учета задач/Help Desk в 1С (интеграция с Trello, мобильное приложение) Промо

Интеграция Управление бизнес-процессами (BPM) v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

Система предназначена для учета задач в 1С как между пользователем — разработчиком, так и для внутренних нужд организаций в качестве обслуживания бизнес-процессов. Основное преимущество разработки - это подключение клиентской части в виде внешней обработки или расширения к базе любой конфигурации 1С и обмен в задачах сущностями данных: печатные формы, отчеты, ссылки. Серверная часть представляет собой конфигурацию "Тикеты" с опубликованным web-сервисом.

1 стартмани

18.01.2019    22603    197    Andreyyy    63    

Интеграция с OneDrive через Microsoft Graph

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Подключение к Microsoft Live через приложение. Настройка приложения и разрешений.

2 стартмани

24.09.2021    307    1    Tony_Medvedos    0    

Полноценная работа с COM портом через библиотеку MSComm

Интеграция v8 1cv8.cf Абонемент ($m)

Чтение и запись в COM порт через библиотеку MSComm. Без бесконечных циклов и прочих костылей.

1 стартмани

15.09.2021    1231    12    vadnevzorov    1    

Формирование мэппинга между конфигурациями при использовании формата EnterpriseData

Интеграция Проектирование Перенос данных из 1C8 в 1C8 v8 КД 1С:Франчайзи, автоматизация бизнеса Россия Абонемент ($m)

В данной статье я привожу подход к формированию мэппинга объектов при использовании универсального формата обмена EnterpriseData, используя при этом как инструмент конфигурацию Конвертация 3. Будет полезно для разработчиков, которые проектируют или планируют дорабатывать обмен с использованием универсального формата.

1 стартмани

26.08.2021    681    1    maraty    2    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    53247    5    milkers    2    

Подключение эквайрингового терминала ПриватБанка к 1С по протоколу JSON

Интеграция Эквайринг v8 1cv8.cf Украина Абонемент ($m)

Подключение Ээквайрингового терминала ПриватБанка к 1С по протоколу JSON с помощью WebSocket. Все тестирование проводил на 1С:Предприятие 8.3 (8.3.10.2561).

1 стартмани

28.07.2021    1344    6    Pervuy    0    

Интеграция YCLIENTS с 1С: Бухгалтерией

Интеграция v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка данных из системы YCLIENTS в 1С: Бухгалтерию 3.0 через API.

2 стартмани

22.07.2021    1116    2    Vatabine    3    

Загрузка данных о поступлении наличных из программы Algoritm-S (Алгоритм-С) АВТОМАТИЗАЦИЯ АПТЕК

Обмен через XML Интеграция v8 БП3.0 Абонемент ($m)

Загрузка в 1с Бух данных о поступлении наличных выгруженных в XML из программы Алгоритм-С

10 стартмани

21.06.2021    998    1    ah7777777    0    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами Промо

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    43799    85    lunjio    15    

Автоматическая синхронизация данных в Active Directory из 1С: ЗУП

Интеграция Внешние источники данных v8 v8::СПР ЗУП3.x Абонемент ($m)

Была задача настроить автоматическую синхронизацию данных в Active Directory из 1С: ЗУП, делюсь результатами.

2 стартмани

13.04.2021    1697    8    77dream77    0    

Интеграция 1С:Автосервис с мобильным приложением "Buromotors" для информирования клиентов о произведенных ТО автомобилей

Производство готовой продукции (работ, услуг) Интеграция v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m)

Заказчик ремонта автомобиля получает информацию о произведенном техническом обслуживании в мобильном приложении своего смартфона.

1 стартмани

24.03.2021    1527    0    sergei40    1    

Учет рабочего времени (интеграция с оборудованием ZKTeco)

Интеграция Учет рабочего времени v8 Казахстан УУ Абонемент ($m)

Автоматизация учета рабочего времени. Цель - получение данных о посещении сотрудников с устройства сканера отпечатка пальцев в 1С.

1 стартмани

23.03.2021    2593    6    Almaz    6    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    61764    48    pbazeliuk    23    

Добавляем в Конвертацию данных 2.1 средства для работы с GIT

Интеграция Git (GitHub, GitLab, BitBucket) Обмен данными 1С v8 КД Абонемент ($m)

В КД2 добавлен функционал для простой работы с GIT, а также с плагином GitRules, при помощи которого единый XML файл раскладывается на "исходники". В результате получаем решение для совместной работы с правилами обмена. В то же время разработчикам не нужно изучать консольные команды GIT, достаточно иметь общее представление о его работе.

1 стартмани

11.03.2021    3183    8    tambu    11    

Интеграция сервиса проверки идентификационных реквизитов юридических лиц по данным ЕГРН и 1С:Предприятие 8

Практика программирования WEB Интеграция v8 1cv8.cf Россия БУ Госбюджет НУ Налог на прибыль Абонемент ($m)

Целью данной работы является автоматизация проверки идентификационных реквизитов юридических и физических лиц. Для достижения поставленной цели квалификационного исследования необходимо решить следующие задачи: • выбрать средства автоматизации • провести интеграцию • внедрить разработанный инструментарий. В статье я описываю, как именно разрабатывала базу, где и какой код использовала и для чего. Данная интеграция эффективна, она позволяет сотруднику значительно сократить время выполнения проверки контрагентов,в добавок она рассчитана на безграничное количество проверок контрагента, следовательно, не придется покупать пакеты с ограниченным количеством проверок.

1 стартмани

10.03.2021    2247    1    RinaKate97    3    

Пример обмена данными через XDTO

Внешние источники данных Интеграция v8 УНФ БП3.0 УТ11 КА2 Абонемент ($m)

Пример обмена данными между 1С и сторонним приложением посредством механизма XDTO.

1 стартмани

01.03.2021    4230    7    user925427    2    

1C + jabber + python Промо

Сервисные утилиты Практика программирования Интеграция v8 1cv8.cf ДО Абонемент ($m)

Отправка сообщений в jabber из 1С [Документооборота] при помощи python-скрипта.

1 стартмани

14.04.2014    28423    15    Mogidin    2    

Экспорт данных в csv

Внешние источники данных Интеграция v8 v8::УФ 1cv8.cf Украина Абонемент ($m)

Шаблон обработки для выгрузки справочников/регистров в файл csv.

1 стартмани

18.02.2021    2104    5    Tamplier    2    

Интеграция 1С и Trello

Интеграция v8 1cv8.cf Абонемент ($m)

В публикации и приложенной обработке описываются методы взаимодействий между 1С и облачным сервисом Trello по API.

1 стартмани

11.01.2021    2889    3    Andreyyy    0    

Получение скриншота с камеры Hikvision при digest-аутентификации

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Имея подключенную ip-камеру, требуется по нажатию кнопки в документе 1С получать изображение. Может быть полезна при организации рабочих мест на проходных, весовых и т.п.

1 стартмани

30.12.2020    2269    6    garagauto    4    

Пример работы с API СБИС ЭДО

Интеграция Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Пример авторизации, получения информации по документам, закрытия сессии. Обработка подойдет для тех, у кого возникли проблемы с подключением к сервису из 1С.

2 стартмани

08.12.2020    3833    24    winapi    3    

Загрузка данных в 1С:Бухгалтерию ред. 3.0 из файла (DBF) СмартАптека.

Обработка документов Файловые протоколы обмена, FTP Внешние источники данных Интеграция v8 БП3.0 Фармацевтика, аптеки Россия Абонемент ($m)

Загрузка данных в 1С:Бухгалтерию ред. 3.0 из файла (DBF) СмартАптека. Возможность переноса прихода - Поступление товаров, реализации - Отчет о розничных продажах, Реализация товаров, перемещение между складами - Перемещение товаров. Товар свернут, суммовой учет. Автоматический формирует КО, себестоимость устанавливает из СмартАптеки для КУДиР.

2 стартмани

04.12.2020    2925    18    art-nv    8    

Интеграция UDS и УНФ

Розничная торговля Интеграция v8::УФ УНФ Россия УУ Абонемент ($m)

Расширение позволяет при продаже через РМК накапливать и списывать баллы UDS, соблюдены все требования 1С к разработке облачных расширений - можно подключать к облаку.

2 стартмани

25.10.2020    3081    8    viktor_and_ko    11    

Формирование файла загрузки реализаций для сайта sti.gov.kg

Интеграция Налоговые v8 БП1.6 Кыргызстан НУ НДС Абонемент ($m)

Обработка предназначена для старых версий БП для Кыргызстана 1.6 и 1.7

1 стартмани

18.09.2020    2819    0    Fox-trot    0    

Загрузка выручек касс по API с 1-ОФД (1-OFD.RU)

Обработка документов Кассовые операции ККМ Интеграция v8 Розница Абонемент ($m)

Обработка позволяет формировать отчеты о розничных продажах средствами API с 1-ОФД (1-OFD.RU)

2 стартмани

18.09.2020    3429    8    ketr    4    

Загрузка из Frontol. Расширение для БП (КОРП)

Интеграция ККМ Адаптация типовых решений v8 v8::БУ БП3.0 Абонемент ($m)

Простое расширение для загрузки продаж и кассовых операций из систем Frontol. Может использоваться как основа для более полной интеграции

3 стартмани

10.09.2020    3142    1    pbabincev    3    

Конструктор Json Schema с функцией валидации JSON

Обмен данными 1С WEB Интеграция Языки и среды v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Абонемент ($m)

Инструмент для создания Json-схем по формату 4 драфта. В современном мире модно пользоваться Http-сервисами и Json, но если для старого доброго xml все уже придумано и xsd схемы можно рисовать в 1С из коробки, то с json и его форматом Json schema все не так хорошо. Зачастую нужно стандартизировать формат сообщений обмена json и для этого можно воспользоваться Конструктором. Есть возможность проверить свой Json на соответствие схеме. Схемы после выгрузки проходят валидацию в Liquid studio 2020. Стандартизируйте обмен Json с комфортом и удобством.

1 стартмани

16.07.2020    6825    22    Segate    6    

IoT (Internet of Things) в 1С или как подружить 1С с ESP32 при помощи MQTT-брокера

WEB Интеграция Интернет вещей (IIoT) Системная интеграция v8 Абонемент ($m)

Что делать, если надо подключить удалённое устройство к серверу 1С, но ни устройство, ни сервер 1С нельзя "светить" наружу? А если таких устройств десятки или сотни по всей стране? Ответ: Использовать промежуточный сервис, который будет пересылать данные между сервером 1С и устройствами. Такие функции замечательно выполняет MQTT-брокер, но вот не задача, 1С не умеет с ним работать.

1 стартмани

25.06.2020    7900    10    frutty    19    

Интеграция АЗС ТОПАЗ и Штрих-М Магазин

Внешние источники данных Интеграция v8 1cv8.cf Россия Абонемент ($m)

Обмен данными между АЗС Топаз 3.14 и 1С на примере Штрих-М: Магазин, редакция 5.1 (5.1.6.8).

1 стартмани

17.06.2020    3596    2    Ignatov_mu    0    

1С:Деньги: Загрузка выписки банка из личного кабинета Тинькофф Банка

Обмен с банком Учет доходов и расходов WEB Интеграция v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги и пользуется услугами Тинькофф Банка. Расширение позволяет загружать операции из личного кабинета Тинькофф Банка напрямую, без промежуточных файлов.

1 стартмани

18.05.2020    6821    23    Bazil    26    

Автоматическая загрузка накладных от поставщиков из электронной почты (Розница 2.2)

Обработка документов Розничная торговля Учет ТМЦ Интеграция Email v8 Розница Россия УУ Абонемент ($m)

Данная обработка предназначена для получения файлов (*.xls;*.xlsx;*.ods;*.dbf) с почтового сервера вашей электронной почты и загрузки прочитанных данных в документы «Поступление товаров». Так же присутствует возможность распаковки архивов, если поставщик шлет вам в письме архивированные файлы (RAR; ZIP; 7Z). Наличие установленного MS Office и Open Office не требуется.

5 стартмани

18.05.2020    5658    8    StiVitS    6    

Загрузка электронного больничного из файла в ЗУП 3.1. Исправление ошибки

Зарплата Внешние источники данных Интеграция v8 v8::СПР ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

При попытке загрузки электронного больничного пишет: Не заполнено поле LN_HASH или Не заполнено поле LN_STATE. Готовое расширение, исправление для типовой конфигурации ЗУП 3.1.

1 стартмани

08.05.2020    13269    29    Sergeevich    11    

Сканирование магнитных карт (python) и миграция данных в 1С (http - сервис)

Практика программирования Интеграция v8 1cv8.cf Абонемент ($m)

Скрипт чтения com порта (python) и расширение (*.cfe) для приема пакета сообщений в json.

1 стартмани

06.05.2020    3558    1    Legavaz    0    

Интеграция системы Mikbill и 1С:Бухгалтерия 3.0

Интеграция Внешние источники данных v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработки позволяют настроить интеграцию биллинговой системы Mikbill и 1С:Бухгалтерия3.0.

1 стартмани

29.04.2020    5959    0    z_d_v    0    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    7514    8    zavsom    2    

Примеры запросов с календарем Outlook через EWS

Интеграция v8 v8::УФ 1cv8.cf Абонемент ($m)

Примеры создания/изменения/получения/удаления событий календаря Outlook пользователя из 1С через EWS.

2 стартмани

23.04.2020    4361    22    77dream77    1    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    12335    12    zhichkin    19    

Включение и выключение электроприборов из 1С

Интеграция v8 Абонемент ($m)

В публикации я постараюсь описать, как в случае необходимости можно расширить возможности 1С при помощи доступного внешнего оборудования. Рассмотрим, каким образом можно легко включать и выключать электроприборы программно из 1С или имитировать нажатие кнопок.

1 стартмани

02.04.2020    8023    4    bobreks    66    

Все параметры интеграции в одном справочнике

Интеграция v8 Абонемент ($m)

Демо-база для удобного хранения всех параметров интеграции в одном месте и быстрой их замены тестовыми в тестовых базах автоматически. Идея избавляет от ручной смены параметров в тестовых базах; особенно упрощает работу, когда таких параметров значительно много.

3 стартмани

05.03.2020    3244    1    info1i    0    

Выгрузка кодов маркировки обуви в json (для формирования этикетки)

Розничная торговля Интеграция v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Обработка позволяет выгрузить данные о маркируемом товаре в файл json. Проверялась на Управление торговлей, редакция 11 (11.4.11.71) Может понадобиться для реализации печати этикеток для маркировки обуви. Обработку можно подключить как внешнюю обработку в конфигурацию и разместить в определенной подсистеме.

1 стартмани

03.03.2020    5131    9    maksal    3    

Пример связи с API Диадок через сертификат

Интеграция v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Обработка для связи с API Диадок через сертификат формата X.509 - пример подключение при двухфазной аутентификации по сертификату+получение организаций.

1 стартмани

17.02.2020    3910    13    2vadmaster    0    

Интеграция ЗУП с порталом обучения TeachBase

WEB Интеграция v8 ЗУП3.x Россия УУ Абонемент ($m)

Расширение-заготовка для интеграции с TeachBase.

1 стартмани

17.02.2020    3721    2    maksip    0    

Пример http-интеграции ЗУП и HR-портала

Интеграция WEB Расширения v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Расширение для ЗУПа с http-сервисами для интеграции с HR-порталом.

1 стартмани

12.02.2020    5093    3    maksip    5    

Redmine 1C - почти коробка

Управление командой Интеграция Управление задачами v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с системой Redmine.

10 стартмани

10.02.2020    8270    12    zfilin    13    

Интеграция с API Remonline

Обмен данными 1С WEB Интеграция Облачные сервисы, хостинг Расширения v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение для работы с веб-сервисом Remonline.

2 стартмани

05.02.2020    4802    6    Johny_v    6