Очистка кэша 1С из 1С

Публикация № 121383

Разработка - Практика программирования

173
Очистка кэша 1С из 1С.
Простенькая доработка конфигурации для автоматической чистки пользовательского кэша.

Часто, при использовании динамического обновления конфигурации, у пользователей забивается кэш и программма не работает так, как надо. Проблема устраняется путем чистки пользовательского кэша. Но основновная загвоздка в том, что не возможно определить у какого пользователя (особенно если их больше 100) кэшированные модули соотвествуют текущей версии конфигурации, а у какого нет. Программист понимает это только тогда, когда у пользователя возникла ошибка и он присылает в отдел 1С письмо с руганью, принт-скринами и матами. 

Подумав, как можно очищать кэш автоматом, было решено вызывать всем известный скрипт очистки кэша непосредственно из 1С.

В типовых конфигурациях уже предусмотрен обработчик оповещения, который проверяет не изменена ли конфигурация динамически. Если изменена, то пользователю предлагается перезапустить 1С, для того чтобы изменения вступли в силу. 

Суть метода в том, чтобы при завершении работы проверить изменена ли конфигурация динамически еще раз, собрать скрипт, записать его и вызвать в момент закрытия программы. Скрипт сначала засыпает на 5 секунд, ожидая, пока закроется процесс 1С. После этого, смотрит есть ли запущенные процессы 1С, если есть, то убивает их. Затем, удаляет папки кэша и, в случае, если пользователь выбрал перезапуск сеанса, перезапускает 1С.

Т.к. мы пока не написали ничего на управляемом приложении, все описанное ниже, предназначено только для обычного.

В модуле обычного приложения есть процедура ОбработчикОповещения(), в ней периодически вызывается еще одна процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ () 

// Проверяет в конфигурации ИБ наличие изменений появившихся после старта сеанса
//
Процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() Экспорт

    // Если в конфигурации после старта текущего сеанса что-то изменилось
    Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда

        // Завершим проверку обновления
        ЗавершитьПроверкуДинамическогоОбновленияИБ();

        // Спросим пользователя о его желании перезапустить сеанс
        ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
                                "Для работы с ними рекомендуется перезапустить программу." + Символы.ПС +
                                "Перезапустить?";
        РезультатВопроса = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);

        // Если пользователь не хочет перезапускать сеанс
        Если РезультатВопроса = КодВозвратаДиалога.Нет Тогда
            // Запустим проверку обновления опять
            НачатьПроверкуДинамическогоОбновленияИБ();
            Возврат;
         КонецЕсли;

         глЗначениеПеременнойУстановить("глПерезапускатьСеансРаботыСПрограммой", Истина);

        // Попробуем перезапустить
        ПерезапуститьСеансРаботыСПрограммой();

    КонецЕсли;

КонецПроцедуры 

// Процедура перезапуска сеанса работы с программой
Процедура ПерезапуститьСеансРаботыСПрограммой() Экспорт
    глЗначениеПеременнойУстановить("глЗапрашиватьПодтверждениеПриЗакрытии", Ложь);

    ЗавершитьРаботуСистемы(Истина);
КонецПроцедуры

 

При перезапуске используется метод  ЗавершитьРаботуСистемы(Истина, Истина), в нем необходимо поправить второй параметр на Ложь (или опустить ео вообще), вследствие чего 1С не будет перезапускаться. Запуск 1С будет осуществлен непосредственно из скрипта.

 

Далее в модуле обычного приложения  в процедуре ПриЗавершенииРаботыСистемы() необходимо прописать следующий код

Процедура ПриЗавершенииРаботыСистемы()

    //...

    Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда

        // у всех кроме программистов, т.к. у нас слишком часто открыты как рабочие базы так и конфигуратор.
        Если НЕ РольДоступна("Администрирование") Тогда
            ОчиститьКэшИПерезапуститьПрограмму();
        КонецЕсли;
     КонецЕсли;

 
КонецПроцедуры

Процедура ОчиститьКэшИПерезапуститьПрограмму() находится в глобальном модуле.

// Процедура создает и запускает vbs файл, который производит очистку кэша.
// 1С и презапускает программу
//
Процедура ОчиститьКэшИПерезапуститьПрограмму() Экспорт

     СкриптФайл = Новый ТекстовыйДокумент;

     СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();
     СтрокаЗапускаПрограммы = КаталогПрограммы();

     ПутьКФайлуСкрипта = КаталогВременныхФайлов() + "CacheCleaning.vbs";
     ПутьКФайлу1С = СтрокаЗапускаПрограммы + "1cv8.exe";

     ИмяСервера = "";
     ИмяБазы = "";
     Путь = "";
     КомандаЗапуска = "";

     Один = """";
     Два = """""";
     Три = """""""";  

    Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
          Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
          Путь = Лев(Путь, СтрДлина(Путь)-1);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
     Иначе
          МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
          МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
          ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
          МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
          ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
     КонецЕсли;

     // Если пользователь не хочет перезапускать сеанс 1С, то после выполнения скрипта ничего не делаем. 

     Если Не глЗначениеПеременной("глПерезапускатьСеансРаботыСПрограммой")  Тогда
          КомандаЗапуска = ""
     КонецЕсли; 

     СкриптФайл.УстановитьТекст("WScript.Sleep(5000)
     |
     |Dim FSO
     |Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
     |Set WshShell = WScript.CreateObject(""WScript.Shell"")
     |Set colEnvVars = WshShell.Environment(""Process"")
     |
     |strComputer = "".""
     |Set objWMIService = GetObject(""winmgmts:"" _
     |& ""{impersonationLevel=impersonate}!\\"" _
     |& strComputer & ""\root\cimv2"")
     |
     |Set colProcesses = objWMIService.ExecQuery( _
     |""Select * From Win32_Process "" _
     |& ""Where Name = '1cv8.exe'"")
     |
     |For Each objProcess In colProcesses
     | objProcess.Terminate
     |Next
     |
     |WScript.Sleep(1000)
     |
     |FolderName1 = ""\Local Settings\Application Data\1C\1Cv82""
     |FolderName2 = ""\Local Settings\Application Data\1C\1Cv81""
     |FolderName3 = ""\appdata\Local\1C\1Cv82""
     |FolderName4 = ""\appdata\Local\1C\1Cv81""
     |
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName1) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName1
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName2) Then
     |GoSubFolders colEnvVars(""userprofile"") & FolderName2
     | End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName3) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName3
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName4) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName4
     |End If
     |
     |" + КомандаЗапуска + "
     |Set WshShell = Nothing
     |
     |Sub DelFile(sFILE)
     | On Error Resume Next
     | FSO.DeleteFile sFILE, True
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error deleting file: "" & sFILE
     | End If
     |End sub
     |
     |Function GetFolder(sFOLDER)
     | On Error Resume Next
     | Set GetFolder = FSO.GetFolder(sFOLDER)
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
     | Wscript.Quit Err.Number
     | End If
     |End Function
     |
     |Sub GoSubFolders (objDIR)
     | ProcessFilesInFolder objDIR
     | Set sFolder = GetFolder(objDIR)
     | For Each eFolder in sFolder.SubFolders
     | GoSubFolders eFolder
     | Next
     | FSO.DeleteFolder sFolder, True
     |End Sub
     |
     |Sub ProcessFilesInFolder (objDIR)
     |Set sFolder = GetFolder(objDIR)
     |For Each objFile in sFolder.Files
     | DelFile objFile
     |Next
     |End Sub");

     Попытка
            СкриптФайл.Записать(ПутьКФайлуСкрипта, КодировкаТекста.Системная);
            ЗапуститьПриложение(ПутьКФайлуСкрипта);
     Исключение

     КонецПопытки;

КонецПроцедуры

 

Ну вот как-то так.

Я не знаю, может быть кто-то скажет, что постоянная чистка кэша сильно замедляет работу 1С (и это правда, первый запуск после чистки идет довольно таки долго), может быть это не оптимально и не правильно,  но у нас значительно поубавилось недовольных пользователей у которых ошибки возникали по вине досадного глюка динамического обновления системы.

 

Развитие темы.

Я тут подумал как развитие данной темы можно сделать следующее:

Создать регистр сведений, в котором можно будет указать дату очистки кэша, пользователя и флаг того что кэш очищен.

В процедуре ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ(), если конфигурация изменена динамически, то добавлять запись с текущей датой по текущему пользователю. Флаг оставить как ложь.

В процедуре ПриЗавершенииРаботыСистемы() можно проверять не на то что конфигурация изменена динамически, а на наличие записи в регистре сведений без флага.

Если такая запись имеется, то чистим кэш и пишем в регистр флаг - истина.

Что это даст?

Например, возникла следующая ситуация. Конфигурация была изменена динамически, но пользователь сам не закрыл 1С, ее вырубил админ на сервере или сам пользователь убил процесс. Таким образом, кэш не будет очищен ни при этом закрытии ни при следующем запуске - при следующем запуске конфигурация уже не будет изменена динамически. Но у нас в регистре же есть запись без флага. Система при следующем закрытии (да хоть после отпуска) все равно очистит кэш пользователя. Да к тому же программисту можно выборочно назначать счастливчиков. 

173

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
0. Belkin_Sergey 249 26.03.12 13:31 Сейчас в теме
Очистка кэша 1С из 1С.
Простенькая доработка конфигурации для автоматической чистки пользовательского кэша.

Перейти к публикации

1. Nio 59 26.03.12 13:31 Сейчас в теме
Класс. Сейчас прикручу на кнопку и когда у пользователя будет появляться ошибка буду просить давить на эту кнопку.
2. system-3000 27.03.12 10:22 Сейчас в теме
Зачем кнопка. Все и так прекрасно работает. Как только клиент узнал о том что конфига изменена динамически, запускается сценарий на VB убивает процессы 1с и чистит кеш.
15. Stamper 37 28.03.12 10:39 Сейчас в теме
(2) system-3000, опубликуйте, пожалуйста :)
3. владимирп 25 27.03.12 11:40 Сейчас в теме
Здорово! Главное работает в клиент-сервере.
Вопрос такой: А как будет в терминале?
4. Belkin_Sergey 27.03.12 12:11 Сейчас в теме
в терминале так же. Будет чиститься кэш текущего пользователя.
83. AlexO 127 27.07.13 15:39 Сейчас в теме
(4)
Написали много тут всего. Но не все знают, что кэш бьется не только и не столько при динамическом обновлении, и чистить его надо строго у определенных пользователей.
А вот почему бьется кэш в 1С - тут и интенсивность работы, и обновления, и еще куча всего вплоть до состояния жесткого и коллизий в сети.
Наверное, 1С могла бы дать более четкое определение причин, но не дала и не исправила до сих пор.
84. Belkin_Sergey 28.07.13 12:20 Сейчас в теме
(83) AlexO,
и чистить его надо строго у определенных пользователей.
- true story.
Такая задумка была.
85. AlexO 127 28.07.13 13:45 Сейчас в теме
(84)
Такая задумка была.

Алгоритм сам не определит таковых, а указать можно и скриптом вручную. Без изысков.
5. Spartan 338 27.03.12 13:26 Сейчас в теме
(0) К сожалению будет корректно работать, только если пользователи работают с одной ИБ :(
Если на момент динамического обновления будет открыто несколько баз, то скрипт убьет все процессы, в том числе и те, которые трогать не нужно - соответственно могут быть потеряны данные.
sanfoto; Aleskey_K; adhocprog; MasterTonLab; i_lo; Stamper; Belkin_Sergey; +7 Ответить
7. Belkin_Sergey 27.03.12 14:00 Сейчас в теме
(5) Spartan,
Вы правы насчет всех процессов и данных. Я думаю, что в тексте вопроса, который задается пользователю, его надо просто предупредить о том, что будут закрыты все экземпляры 1С и ему перед перезапуском надо сохранить все данные в других базах.
14. kereo 55 28.03.12 10:30 Сейчас в теме
(7) или найти guid базы в списке баз(файл в расширением .v8i, который лежит там же где и кэш) по строке соединения(метод глобального контекста СтрокаСоединенияИнформационнойБазы()) и удалять не все, а только необходимое.

И еще зачем вот это все
     |FolderName1 = ""\Local Settings\Application Data\1C\1Cv82""
     |FolderName2 = ""\Local Settings\Application Data\1C\1Cv81""
     |FolderName3 = ""\appdata\Local\1C\1Cv82""
     |FolderName4 = ""\appdata\Local\1C\1Cv81""
     | 
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName1) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName1
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName2) Then
     |GoSubFolders colEnvVars(""userprofile"") & FolderName2
     | End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName3) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName3
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName4) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName4
     |End If
     
Показать

Если есть переменная windows %appdata%, а версию программы можно узнать у самой 1С-ки (ВерсияПриложения).
Spartan; Stamper; +2 Ответить
17. Belkin_Sergey 28.03.12 10:51 Сейчас в теме
(14) kereo,
Я писал все быстро, пришла идея, взял готовый скрипт, дописал убиение процессов, а остальное оставил как было. Можно конечно и версию 1С определять. Даже нужно. Тут уже на ваше усмотрение.
27. i_lo 198 29.03.12 08:01 Сейчас в теме
(5) Spartan, мои коллеги лепят батник с очисткой кэша в автозапуск. От подобной ошибки спасает. Но попадаются на терминалках, где нет принудительного завершения отключенных сессий, а пользователи не выходят по правилам...
6. Belkin_Sergey 27.03.12 13:58 Сейчас в теме
Вы правы насчет всех процессов и данных. Я думаю, что в тексте вопроса, который задается пользователю, его надо просто предупредить о том, что будут закрыты все экземпляры 1С и ему перед перезапуском надо сохранить все данные в других базах.
63. adhocprog 1169 11.12.12 13:33 Сейчас в теме
(6) а зачем грохать все, если глючит одна база? :)
8. CaSH_2004 354 27.03.12 16:27 Сейчас в теме
Отличный подход чтобы упростить жизнь программисту! Полностью одобряю!
Маленькое замечание по эргономике текста: я обычно записываю скрипт в макет, и вместо склеивания кусков текста ("кусок скрипат 1" + хх + "кусок скрипат 2") использую переменные которые потом передаю в скрипт или просто заменяю их как кусок текста (главное чтобы они были уникальные), в итоге удобства:
- текст легко просматривается и редактируется, т.е. структура использования становиться удобной
- более того текст скрипта легко записать в файл-скрипт и выполнить его для проверки результата
а иначе очень сложно такие вещи модифицируются или переносятся в другие места
9. Belkin_Sergey 27.03.12 16:49 Сейчас в теме
(8) CaSH_2004,
Была такая идея - создать макет с текстом скрипта. Но что-то как-то при написании увлекся, а переделывать уже не хотелось.
10. Magister 133 27.03.12 16:51 Сейчас в теме
Одобряю!
Надо будет поставить в базу, а то достали уже глюки с этим кэшем...
11. Stamper 37 28.03.12 01:04 Сейчас в теме
1С 8.2.15.301 Новое в версии:
http://downloads.v8.1c.ru/content/Platform/8_2_15_301/V8Update.htm
Вызов метода "ОбновитьИнтерфейс()" приводит к очистке кэшей: представления ссылок, данных объектов, данных быстрого выбора, форм выбора, ограничений по типу.

Идея автора очень полезная, спору нет! Сам уже устал постоянно переподключать ИБ'ы.
Но кажется, в ту же сторону задумались и разрабы 1С.

Что скажете?
AndrewVVS; daho; MasterTonLab; reboot234; i_lo; Spartan; +6 Ответить
16. Belkin_Sergey 28.03.12 10:47 Сейчас в теме
(11) Stamper,
Если они что-нибудь сделают в этом направлении, я думаю все вздохнут спокойно и не надо будет уже ничего придумывать.
18. Stamper 37 28.03.12 10:58 Сейчас в теме
(16) осталось только протестить работоспособность этого нового функционала метода :)
34. sstar90 29.03.12 13:02 Сейчас в теме
(11) Stamper, очистка кэша при обновлении системной информации присутствовала уже и в версии 8.1
39. Stamper 37 30.03.12 10:39 Сейчас в теме
(34) sstar90, а как это можно было сделать, например, программно?
40. sstar90 30.03.12 14:05 Сейчас в теме
(39) Stamper, честно говоря вопросом, как это сделать программно, не задавался, но и в Вашем комментарии (11) Вы тоже не поднимаете этот вопрос, а только даете сообщение, что данная возможность появилась в 8.2.15, я же указал что она появилась гораздо раньше. С другой стороны, все процедуры и функции, описанные в данной публикации в 8.1 присутствуют, т.ч. программно этот вопрос может быть решен в 8.1 аналогично.
41. Stamper 37 30.03.12 17:29 Сейчас в теме
(40) sstar90, видимо, мы не поняли друг-друга :)
я исходил из того, что раз эта функция описана в "новшествах" версии 8.2.15.301, то в предыдущих версиях её не было. сам метод реализован, видимо, давно. но, как я понял, его выполнение не совершало именно очистку кэшей.
прочитав (34) я подумал, что речь идёт о каком-то другом способе.
итак, в (34) имелось в виду что в 8.1 этот же метод ОбновитьИнтерфейс() осуществлял очистку кэшей???
42. sstar90 31.03.12 14:28 Сейчас в теме
(41) Stamper, в (34) я хотел сказать, что и в 8.1 и 8.2 ОбновитьИнтерфейс() выполняются одинаково
12. ivn75 28.03.12 08:56 Сейчас в теме
Актуальная тема, но лучше бы разработчики допилили динамическое обновление баз без глюков. А то возможность придумали хорошую, но реализация глючная.
13. Evrepid 28.03.12 10:11 Сейчас в теме
19. владимирп 25 28.03.12 14:57 Сейчас в теме
Попробовал на УПП конф 1.3.23 платформа 8.2.533
Говорит что не определена переменная глЗапрашиватьПодтверждениеПриЗакрытии в модуле "РаботаСобщимиПеременнымиПовтИсп"
Или ее прописывать в модуле "РаботаСОбщимиПеременными"
21. Belkin_Sergey 28.03.12 16:37 Сейчас в теме
(19) владимирп, можете код "глЗначениеПеременнойУстановить("глЗапрашиватьПодтверждениеПриЗакрытии", Ложь);" вообще опустить. Для успешной чистки кэша значение данной переменной не важно. Просто пользователю, если у него в настройках "Спрашивать подтверждение при закрытии" задано значение Истина, после нажатия на кнопку "Да" (вопрос о перезапуске из-за динамического обновления) будет еще раз задан вопрос, о подтверждении закрытия 1С.
20. Belkin_Sergey 28.03.12 16:33 Сейчас в теме
Переменная глЗапрашиватьПодтверждениеПриЗакрытии объявлена в модуле обычного приложения. Она используется в процедуре ПередЗавершениемРаботыСистемы() модуля обычного приложения.
22. владимирп 25 28.03.12 20:34 Сейчас в теме
geterosser, спасибо за ответ попробую убить эту строку
23. the1 388 28.03.12 23:43 Сейчас в теме
юзаю батник из ТоталКоммандер 1С Эдишн

@echo off
set cache_dir="%userprofile%\Local Settings\Application Data\1c\1Cv82"
FOR /D %%i IN (%cache_dir%\*) DO rd /s /q "%%i
25. Belkin_Sergey 29.03.12 07:10 Сейчас в теме
24. i_lo 198 29.03.12 02:16 Сейчас в теме
(0) Я так понял, что убивается все. А не проще чистить только файлы кэшей?

erase /s "%UserProfile%\cache.1c?"
erase /s "%UserProfile%\cacheData."
erase /s "%UserProfile%\cacheStorage."
erase /s "%UserProfile%\cacheVersions."
MasterTonLab; +1 Ответить
26. Belkin_Sergey 29.03.12 07:12 Сейчас в теме
(24) i_lo, проще.
Прошу воспринимать данную статью как идею. Если поставите плюсик - вообще замечательно будет. Вариации на тему приветствуются. Сейчас соберу все предложения, сделаю версию 2.0 )
28. 7o2uYXg 38 29.03.12 10:32 Сейчас в теме
а вот этого разве недостаточно:
ЗавершитьРаботуСистемы(Истина,Истина,"/ClearCache");
?
30. Belkin_Sergey 29.03.12 10:56 Сейчас в теме
(28) 7o2uYXg, смысл доработки в том, чтобы очистить кэш у пользователя в любом случае, если у него была открыта база в момент динамического обновления. А что если пользователь не захотел перезапускать сеанс и закрыл 1С в конце рабочего дня? При использовании ЗавершитьРаботуСистемы(Истина,Истина,"/ClearCache"), дополнительный параметр /ClearCache будет актуален, если только пользователь на вопрос о перезапуске сказал да, и при вызове ЗавершитьРаботуСистемы второй параметр указан как Истина. Если вы заметили в моем коде, второго параметра нет.
43. Spartan 338 02.04.12 17:07 Сейчас в теме
(30) В дополнение идеи с сохранением статуса очистки кэша для пользователя...
Есть такая мысль: вместо использования регистра, можно применить функции СохранитьЗначение(), ВосстановитьЗначение() - они как раз работают в разрезе комбинации Пользователь - ИБ.
Произошло динамическое обновление, в процедуре ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() пишем флаг:
СохранитьЗначение("НеобходимоОчиститьКэш", Истина);

Если пользователь ответил утвердительно на вопрос о перезапуске, вызываем метод ЗавершитьРаботуСистемы() с параметром "/ClearCache" в процедуре ПерезапуститьСеансРаботыСПрограммой() и снимаем флаг, т.к. кэш будет очищен при повторном запуске, а заодно запоминаем в текущем сеансе, что действия по очистке кэша уже выполнены:
	глКэшОчищен = Истина;
	СохранитьЗначение("НеобходимоОчиститьКэш", Ложь);
	ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache");

Если же пользователь отказался, и закрыл программу сам или сделал это раньше, чем сработал обрабочик ожидания, то в процедуре ПриЗавершенииРаботыСистемы() проверяем дополнительно, нужно ли чистить кэш при следующем запуске:
Если глКэшОчищен <> Истина И КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		СохранитьЗначение("НеобходимоОчиститьКэш", Истина);
	КонецЕсли;
Ну и при каждом запуске в процедуре ПриНачалеРаботыСистемы() проверяем флаг очистки кэша. Если кэш не был ощищен - выполняем перезагрузку с параметром:
Если ВосстановитьЗначение("НеобходимоОчиститьКэш") = Истина Тогда
		ПерезапуститьСеансРаботыСПрограммой();
		Возврат;
	КонецЕсли; 

Будет работать или нет - надо проверять, но на первый взгляд должно прокатить...
45. Belkin_Sergey 03.04.12 07:26 Сейчас в теме
(43) Spartan, с одной стороны этот вариант лучше, чем регистр сведений. Но с другой, как назначить пользователю регламентную очистку кэша? С регистром сведений - это просто.
46. Spartan 338 03.04.12 10:11 Сейчас в теме
(45) Да, согласен. Но зато тут минимум доработок - только пара дописок в модуль. С регистром конечно можно сделать более продвинутую систему.
47. Magister 133 03.04.12 11:13 Сейчас в теме
(43) не будет работать, если пользователь заходит с разных компьютеров. кэш нужно чистить на каждом компе.
sanfoto; Spartan; +2 Ответить
48. Spartan 338 03.04.12 11:52 Сейчас в теме
(47) Тут и регистр не поможет, разве что хранить в нем еще имя компьютера... Ну и плюс ко всему, можно сделать кнопку в общем интерфейсе, на которую повесить процедуру перезапуска с очисткой кэша для разного рода случаев - пусть вручную давит на кнопку, когда нужно.
49. Spartan 338 03.04.12 12:00 Сейчас в теме
+(48) Можно, в общем, и с СохранитьЗначение выкрутиться - писать соответствие, а не просто флаг.
50. Magister 133 04.04.12 10:23 Сейчас в теме
(48) Я пока что на каждом компе в автозапуск поставил скрипт очистки кэша. Минус - утром всегда 1С запускается медленнее. Зато, если что-то глючит, можно пользователю сказать: перезагрузи компьютер. Никакой мороки :)
29. rus128 2 29.03.12 10:36 Сейчас в теме
(0) Хорошая идея!
(23) а кто батник запускает?
(27) Принудительно? Тогда запуск 1С идет медленнее, а здесь очистка кеша выполняется только при необходимости.
31. Belkin_Sergey 29.03.12 10:58 Сейчас в теме
(29) rus128, такая идея тоже была. 1С запускается в два раза медленнее. Пользователи не довольны.
32. i_lo 198 29.03.12 12:42 Сейчас в теме
(31) тогда лучше бы при обнаружении обновления какой-то конфигурации, в укромное предопределенное место записывался фиксированный файл, наличие которого при повторном входе, вызывало очистку кэша. Количество замедленных запусков сократится! Может куда-то в этом направлении подумать?
33. Belkin_Sergey 29.03.12 13:01 Сейчас в теме
(32) i_lo, получается тоже самое, но через другую дверь. Можно и так.
35. rus128 2 29.03.12 14:53 Сейчас в теме
(31) так и я говорю (защищая ваше решение), что не принудительно нужно кеш чистить, а только в случае необходимости.
37. Belkin_Sergey 29.03.12 21:27 Сейчас в теме
(36) yaidiot123, классный никнэйм!
38. MultiLexx 20 30.03.12 10:28 Сейчас в теме
Очень полезная вещь! Частенько приходится клиентам обновлять динамически, и потом начинаются чудеса. То у всех пользователей работает с обновлениями, а у одного-двух нет, то еще чего нибудь.
44. Spartan 338 02.04.12 17:14 Сейчас в теме
Конечно чуть дольше будет выполняться загрузка с повторным перезапуском, но, думаю, не критично.
51. Spartan 338 10.04.12 12:38 Сейчас в теме
ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache") ни хрена не работает - после перезапуска глюки остаются... а после ручной чистки - пропадают
52. Belkin_Sergey 10.04.12 13:06 Сейчас в теме
(51) Spartan, значит все не зря писалось тут.
54. hulio 56 18.04.12 14:56 Сейчас в теме
56. Spartan 338 19.04.12 20:09 Сейчас в теме
(54) Периодически обращаются пользователи с проблемами, которые решаются очисткой кэша: неработающие пункты меню и пр. Попробовал перезапустить с параметром - ничего не изменилось. Очистка файлов кэша вручную помогла как и раньше.
57. hulio 56 27.04.12 14:02 Сейчас в теме
(56) Spartan, действительно, ничего не очищается ...
Я сделал кнопку, по нажатию на которую вызывается небольшая процедурка с таким кодом:

#Если Клиент Тогда
Процедура ОчиститьКэш() Экспорт 
	
	Текст = "Ваш сеанс работы с 1С будет перезапущен, все несохраненные данные при этом будут утеряны. Продолжить?";
	Ответ = Вопрос(Текст, РежимДиалогаВопрос.ОКОтмена, 30, КодВозвратаДиалога.ОК, "Очистка кэша", КодВозвратаДиалога.Отмена);
	
	Если Ответ = КодВозвратаДиалога.ОК Тогда 
		ПрекратитьРаботуСистемы(Истина, "/ClearCache");
	КонецЕсли;
	
КонецПроцедуры
#КонецЕсли
Показать

Работоспособность проверил следующим образом:
Зашел в 1С, в интерфейс добавил себе кнопку для открытия какой-то формы, пооткрывал разные окна и побаловался с ними (менял размеры, перемещал). Затем я закрыл 1С, чтобы настройки окон и интерфейса сохранились, открыл снова, проверил, что все настройки восстановились, и нажал на кнопку, по которой вызывается указанная мной процедура. Настройки форм и интерфейса остались прежними :)
Версия платформы: 8.2.15.310
53. fred20002 13.04.12 15:51 Сейчас в теме
В чем проблема ЗавершитьРаботуСистемы(Истина, Истина, "/ClearCache")?
55. jsmith 18.04.12 14:58 Сейчас в теме
Очень полезная штука, щас скачаю
58. zShamaNz 48 15.05.12 20:55 Сейчас в теме
Скидываю свой вариант: кэш чиститься только в одной базе, т.к.баз много и закрывать все и чистить их при динамическом обновлении одной нерационально... Сделан регистр сведений для фиксации пользователей, которые работали в момент обновления, их кэш очищаем.

// Проверяет в конфигурации ИБ наличие изменений появившихся после старта сеанса
//
Процедура ОбработчикОжиданияПроверкиДинамическогоИзмененияИБ() Экспорт
	
	//Очиска Кэша
	НаборОчискаКэша					= РегистрыСведений.ОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	
	Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		НовыйНабор						= НаборОчискаКэша.Добавить();
		НовыйНабор.Пользователь			= ПараметрыСеанса.ТекущийПользователь;
		НовыйНабор.ОбновленаДинамически	= Истина;
		НаборОчискаКэша.Записать();
		
	КонецЕсли;
	
	НаборОчискаКэша.Прочитать();
	// Если в конфигурации после старта текущего сеанса что-то изменилось
	Если НЕ НаборОчискаКэша.Количество() = 0 И НаборОчискаКэша[0].ОбновленаДинамически Тогда

		// Завершим проверку обновления
		ЗавершитьПроверкуДинамическогоОбновленияИБ();

		// Спросим пользователя о его желании перезапустить сеанс
		ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
						"Для работы с ними рекомендуется перезапустить программу." + Символы.ПС +
						"Перезапустить?";
		РезультатВопроса = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);

		// Если пользователь не хочет перезапускать сеанс
		Если РезультатВопроса = КодВозвратаДиалога.Нет Тогда
			// Запустим проверку обновления опять
			НачатьПроверкуДинамическогоОбновленияИБ();
			Возврат;
		КонецЕсли;

	
		// Попробуем перезапустить
		глЗапрашиватьПодтверждениеПриЗакрытии = Ложь;
		
		ЗавершитьРаботуСистемы(Истина, Ложь);

	КонецЕсли;

КонецПроцедуры

// Процедура создает и запускает vbs файл, который производит очистку кэша.
// 1С и презапускает программу
//
Процедура ОчиститьКэшИПерезапуститьПрограмму() Экспорт
	
	НаборОчискаКэша							= РегистрыСведений.ОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	
	НаборОчискаКэша.Прочитать();
	Если НЕ НаборОчискаКэша.Количество()	= 0 И НаборОчискаКэша[0].ОбновленаДинамически Тогда
		НаборОчискаКэша[0].ОбновленаДинамически	= Ложь;
		НаборОчискаКэша.Записать();
	Иначе
		Возврат;	
	КонецЕсли;   
	
	WshShell	= Новый COMОбъект("wscript.shell");
	СкриптФайл	= Новый ТекстовыйДокумент;
	
	СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();
	СтрокаЗапускаПрограммы = КаталогПрограммы();
	
	AppData	= WshShell.SpecialFolders.Item("AppData");
	ПутьКФайлуСИДБаз = AppData + "\1C\1CEStart\ibases.v8i";
	ПутьКФайлу1С = СтрокаЗапускаПрограммы + "1cv8.exe";
	
	НазваниеПапки	= "";
	Текст = Новый ЧтениеТекста(ПутьКФайлуСИДБаз, КодировкаТекста.ANSI);
	Стр = Текст.ПрочитатьСтроку();
	Пока Стр <> Неопределено Цикл // строки читаются до символа перевода строки
	    Стр = Текст.ПрочитатьСтроку();
		Если Найти(Стр, СтрокаСоединенияСБД)>0 Тогда
		    Стр = Текст.ПрочитатьСтроку();
			НазваниеПапки	= СокрЛП(СтрЗаменить(Стр, "ID=", ""));
			Прервать;
		КонецЕсли; 
	КонецЦикла;	
	
	ИмяКаталогаСКэшем	= СтрЗаменить(AppData,"Roaming","Local") + "\1C\1Cv82\" + НазваниеПапки;	
	КаталогСКэшем = Новый Файл(ИмяКаталогаСКэшем);
	Если НЕ НазваниеПапки = "" И КаталогСКэшем.Существует()  Тогда
	Иначе
		Сообщить("Каталог с кэшем не найден.");
		Возврат;
	КонецЕсли; 
	
	ИмяСервера = "";
	ИмяБазы = "";
	Путь = "";
	КомандаЗапуска = "";
	
	Один = """";
	Два = """""";
	Три = """""""";  
	
	Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
		Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
		Путь = Лев(Путь, СтрДлина(Путь)-1);
		КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
	Иначе
		МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
		МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
		ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
		МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
		ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
		КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
	КонецЕсли;
	
	СкриптФайл.УстановитьТекст
	(" WScript.Sleep(5000)
	|Dim FSO
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|If FSO.FolderExists(""" + ИмяКаталогаСКэшем + """) Then
	| GoSubFolders """ + ИмяКаталогаСКэшем + """
	|End If
	|" + КомандаЗапуска+ "
	|Set WshShell = Nothing
	|Sub DelFile(sFILE)
	| On Error Resume Next
	| FSO.DeleteFile sFILE, True
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error deleting file: "" & sFILE
	| End If
	|End sub
	|
	|Function GetFolder(sFOLDER)
	| On Error Resume Next
	| Set GetFolder = FSO.GetFolder(sFOLDER)
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
	| Wscript.Quit Err.Number
	| End If
	|End Function
	|
	|Sub GoSubFolders (objDIR)
	| ProcessFilesInFolder objDIR
	| Set sFolder = GetFolder(objDIR)
	| For Each eFolder in sFolder.SubFolders
	| GoSubFolders eFolder
	| Next
	| FSO.DeleteFolder sFolder, True
	|End Sub
	|
	|Sub ProcessFilesInFolder (objDIR)
	|Set sFolder = GetFolder(objDIR)
	|For Each objFile in sFolder.Files
	| DelFile objFile
	|Next
	|End Sub");
	Попытка
		СкриптФайл.Записать(КаталогВременныхФайлов()+"clean.vbs",КодировкаТекста.Системная);
                ЗапуститьПриложение(""""+КаталогВременныхФайлов()+"clean.vbs""");
		WshShell	= Неопределено;
	Исключение
		
	КонецПопытки;
	
КонецПроцедуры
Показать
7OH; Belkin_Sergey; +2 Ответить
59. Belkin_Sergey 16.05.12 07:39 Сейчас в теме
(58) zShamaNz,

Кул. Это именно тот вариант, до которого все тут дошли во время обсуждения, но никто не решился сделать. Спасибо.
60. Belkin_Sergey 16.05.12 07:43 Сейчас в теме
(58) zShamaNz,

В регистре сведений еще можно добавить флаг "Принудительно". Например, для того, чтобы не ждать от пользователя утвердительного ответа, а тупо дать ему минуту на сохранение данных и все убить.
94. ksnik 358 08.03.18 16:09 Сейчас в теме
(58) Денис Шарабоков (zShamaNz),
Здравствуйте! Спасибо за публикацию!
1Ска почему-то не запускается указанным скриптом опубликованным Автором публикации (а так же в посте Денис Шарабоков (zShamaNz) после завершения работы пользователя. Где порыть?
95. ksnik 358 09.03.18 01:13 Сейчас в теме
(94) Извините что поднял тему, не сразу стал запускаться скрипт, проверено - у Автора и Денис Шарабоков (zShamaNz) все работает.
п.с. "начать проверку динамического обновления" и "завершить проверку динамического обновления" и т.д. на древней конфе без глобальных переменных реализовал через сохранить - восстановить значение.
СохранитьЗначение(ИмяПользователя()+"глПерезапускатьСеансРаботыСПрограммой",Истина);
глПерезапускатьСеансРаботыСПрограммой = ВосстановитьЗначение(ИмяПользователя()+"глПерезапускатьСеансРаботыСПрограммой");
61. daho 8 12.10.12 11:37 Сейчас в теме
Есть еще вариант, но он самый убийственный.. :)
rmdir "%AppData%\1C\1Cv82" /S /Q
rmdir "%LOCALAPPDATA%\1C\1Cv82" /S /Q
Где-то здесь же и нарыл...
62. fedotochevm 12.10.12 11:42 Сейчас в теме
64. @vk 12 08.02.13 10:28 Сейчас в теме
А чем отличается этот вариант очистки от варианта с помощью батника?
67. Belkin_Sergey 30.04.13 13:35 Сейчас в теме
(64) @vk, это тот же самый батник, но генерится он из 1С при закрытии программы. А отличие в том что вам не надо идти к пользователю (или высылать файл по почте), можно просто поставить признак необходимости очистки кэша в 1С.
65. besometr 29.04.13 10:19 Сейчас в теме
Спасибо большое! Решает множество проблем.
Интересно, а будет работать в домене? Там же временные файлы хранятся на сервере.
66. 1985Alex1985 30.04.13 11:42 Сейчас в теме
Спасибо. Из всех вариантов очистки кеша этот самый интересный.
Belkin_Sergey; +1 Ответить
68. 1985Alex1985 13.05.13 18:27 Сейчас в теме
Пытаюсь такую штуку встроить в конфу.
И глазами и поиском и глобальным поиском искал - не могу найти "ОбработчикОповещения" впринципе в конфе. (ППЦ я слепоглазое днище наверное). Конфа УТП 1.2.13.2 Подскажите, что я делаю не так?
69. 1985Alex1985 13.05.13 20:14 Сейчас в теме
Олилуя!!! нашел я эту штуку. Это не процедура модуля обычного приложения ОбработчикОповещения(), а стандартная функция ПодключитьОбработчикОжидания(). С ее помощью получилось добиться, что бы при динамическом изменении пользователи получали сообщение о необходимости перезапуска 1С.
70. 1985Alex1985 14.05.13 11:58 Сейчас в теме
Посоветуйте пожалуйста литературу или может хелп какой, что бы в тексте скрипта помог разобраться (что бы понять ЧТО ИМЕННО он делает и при необходимости его модифицировать), а то так то вроде все работает, но клиентам сцыкотно внедрять "шаманский код" до конца не понимая его.
71. 1985Alex1985 15.05.13 16:02 Сейчас в теме
Еще такой вопрос: Если произошло ДО, пользователь не вышел из базы, сеанс грохнули, кэш НА ЭТОМ компе не очистился.
Пользователь "обиделся" и сменил терминал. Зашел там, поработал, нажал завершение работы. В регистре записано, что надо пичистить ему кэш. Но! Кэш то почистить надо НА ДРУГОМ компе. В таком случае пострадает "невинный" кэш, а нужный не очистится. Мне кажется, что в регистр надо кроме измерения "Пользователь" добавить имя ПК, что бы чистился "тот самый... испорченный кэш", а не первый попавшийся. Сильно бредовое предположение или нормальное?
maratimus; +1 Ответить
72. Belkin_Sergey 16.05.13 07:16 Сейчас в теме
(71) 1985Alex1985, предложение отличное.
73. 1985Alex1985 16.05.13 14:54 Сейчас в теме
ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
	ТекКомпьютер = ИмяКомпьютера();
	СтруктураОтбора = Новый Структура;
	СтруктураОтбора.Вставить("Пользователь",ТекПользователь);
	СтруктураОтбора.Вставить("ИмяПК",ТекКомпьютер);
	ПараметрыОчисткиКэша = РегистрыСведений.hiДинамическиеОбновления.ПолучитьПоследнее(ТекущаяДата(),СтруктураОтбора);
	ПараметрыОчисткиКэша.КэшОчищен = ?(ПараметрыОчисткиКэша.КэшОчищен = Неопределено,Истина,ПараметрыОчисткиКэша.КэшОчищен);

Написал такой код. Думал, что
ПараметрыОчисткиКэша.КэшОчищен = Неопределено
будет в то случае, если по отбору не будет записи. А вот и нет. Возвращает "ложь" для измерения типа булево, если не найдена запись.

И далее
Если НЕ ПараметрыОчисткиКэша.КэшОчищен Тогда
первый раз для всех пользователей система будет считать что надо перегрузиться. вижу два выхода - использовать не булево а другой тип, или получать данные запросом(там результат будет пустой если нет записи по такому отбору). Может кто нить предложить третий вариант? (Вариант подогнать Ложь\Истина так, что бы мне для первого запуска подходила ложь - не рассматриваю).

Вот такой вариант пока буду использовать как конечный(если подскажете, что в нем улучшить, пожелаю вам здоровья):
  ТекПользователь = ПараметрыСеанса.ТекущийПользователь;
	ТекКомпьютер = ИмяКомпьютера();
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	hiДинамическиеОбновленияСрезПоследних.Период,
		|	hiДинамическиеОбновленияСрезПоследних.Пользователь,
		|	hiДинамическиеОбновленияСрезПоследних.ИмяПК,
		|	hiДинамическиеОбновленияСрезПоследних.КэшОчищен
		|ИЗ
		|	РегистрСведений.hiДинамическиеОбновления.СрезПоследних(
		|			,
		|			Пользователь = &Пользователь
		|				И ИмяПК = &ИмяПК) КАК hiДинамическиеОбновленияСрезПоследних";

	Запрос.УстановитьПараметр("ИмяПК", ТекКомпьютер);
	Запрос.УстановитьПараметр("Пользователь", ТекПользователь);

	Результат = Запрос.Выполнить();

	Выборка= Результат.Выбрать();
	
	Если Выборка.Количество() = 0 Тогда
	
		КэшОчищен = Истина;
	Иначе
		Выборка.Следующий();
		КэшОчищен = Выборка.КэшОчищен;
	
	КонецЕсли;
	
	Если НЕ КэшОчищен Тогда
Показать
74. Belkin_Sergey 17.05.13 08:07 Сейчас в теме
(73) 1985Alex1985, зачем делать регистр сведений периодическим?
У меня регистр не периодический.
Делается отбор по текущему пользователю, если есть записи, то читается признак необходимости очистки кеша, если их нет, то происходит выход из процедуры. В вашем случае, нужно просто дополнительный отбор сделать по имени ПК.

вот мой код.
	НаборОчискаКэша = РегистрыСведений.бссОчискаКэша.СоздатьНаборЗаписей();
	НаборОчискаКэша.Отбор.Пользователь.Установить(ПараметрыСеанса.ТекущийПользователь);
	// отбор по имени ПК
	НаборОчискаКэша.Отбор.ИмяПК .Установить(ИмяКомпьютера());

	НаборОчискаКэша.Прочитать();
	
	ЕстьЗаписи = (НаборОчискаКэша.Количество() > 0);
	
	Если НЕ ЕстьЗаписи Тогда
		Возврат;   
	КонецЕсли;   
	
	// У нас всегда 1 пользователь, 1 ПК - 1 запись.
	ТребуетсяПерезапуск 	= НаборОчискаКэша[0].ТребуетсяПерезапуск;
	ОбновленаДинамически 	= НаборОчискаКэша[0].ОбновленаДинамически;
	НеОчищатьНикогда 	= НаборОчискаКэша[0].НеОчищатьНикогда;
	
	Если НЕ ОбновленаДинамически Тогда
		Возврат;
	КонецЕсли;
	
	Если НеОчищатьНикогда Тогда
		НаборОчискаКэша[0].ОбновленаДинамически = Ложь;
		НаборОчискаКэша[0].ТребуетсяПерезапуск = Ложь;
		НаборОчискаКэша.Записать();
		Возврат;
	КонецЕсли;
		
	WshShell   	= Новый COMОбъект("wscript.shell");
	СкриптФайл  = Новый ТекстовыйДокумент;
	
	СтрокаСоединенияСБД 	= СтрокаСоединенияИнформационнойБазы();
	СтрокаЗапускаПрограммы 	= КаталогПрограммы();
	
	AppData   		= WshShell.SpecialFolders.Item("AppData");
	ПутьКФайлуСИДБаз 	= AppData + "\1C\1CEStart\ibases.v8i";
	ПутьКФайлу1С 		= СтрокаЗапускаПрограммы + "1cv8.exe";
	
	НазваниеПапки   = "";
	Текст = Новый ЧтениеТекста(ПутьКФайлуСИДБаз, КодировкаТекста.ANSI);
	Стр = Текст.ПрочитатьСтроку();
	Пока Стр <> Неопределено Цикл // строки читаются до символа перевода строки
		Стр = Текст.ПрочитатьСтроку();
		Если Найти(Стр, СтрокаСоединенияСБД)>0 Тогда
			Стр = Текст.ПрочитатьСтроку();
			НазваниеПапки = СокрЛП(СтрЗаменить(Стр, "ID=", ""));
			Прервать;
		КонецЕсли; 
	КонецЦикла;   
	
	ИмяКаталогаСКэшем = СтрЗаменить(AppData,"Roaming","Local") + "\1C\1Cv82\" + НазваниеПапки;   
	КаталогСКэшем = Новый Файл(ИмяКаталогаСКэшем);
	Если НЕ НазваниеПапки = "" И КаталогСКэшем.Существует()  Тогда
	Иначе
		//Сообщить("Каталог с кэшем не найден.");
		Возврат;
	КонецЕсли; 
	
	ИмяСервера = "";
	ИмяБазы = "";
	Путь = "";
	КомандаЗапуска = "";
	
	Один = """";
	Два = """""";
	Три = """""""";  
	
	Если ТребуетсяПерезапуск Тогда
		Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
			Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
			Путь = Лев(Путь, СтрДлина(Путь)-1);
			КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
		Иначе
			МассивПараметровСоединения = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
			МассивПараметровСервера = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
			ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
			МассивПараметровБазы = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
			ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
			КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
		КонецЕсли;
	КонецЕсли;
	
	ТекстСкрипта = "WScript.Sleep(5000)
	|Dim FSO
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|If FSO.FolderExists(""" + ИмяКаталогаСКэшем + """) Then
	| GoSubFolders """ + ИмяКаталогаСКэшем + """
	|End If
	|" + КомандаЗапуска+ "
	|Set WshShell = Nothing
	|Sub DelFile(sFILE)
	| On Error Resume Next
	| FSO.DeleteFile sFILE, True
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error deleting file: "" & sFILE
	| End If
	|End sub
	|
	|Function GetFolder(sFOLDER)
	| On Error Resume Next
	| Set GetFolder = FSO.GetFolder(sFOLDER)
	| If Err.Number <> 0 Then
	| Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
	| Wscript.Quit Err.Number
	| End If
	|End Function
	|
	|Sub GoSubFolders (objDIR)
	| ProcessFilesInFolder objDIR
	| Set sFolder = GetFolder(objDIR)
	| For Each eFolder in sFolder.SubFolders
	| GoSubFolders eFolder
	| Next
	| FSO.DeleteFolder sFolder, True
	|End Sub
	|
	|Sub ProcessFilesInFolder (objDIR)
	|Set sFolder = GetFolder(objDIR)
	|For Each objFile in sFolder.Files
	| DelFile objFile
	|Next
	|End Sub";
	
	СкриптФайл.УстановитьТекст(ТекстСкрипта);
	
	Если НЕ РольДоступна("ПравоАдминистрирования") Тогда // у нас кеш чистится всем кроме программистов

		Попытка
			СкриптФайл.Записать(КаталогВременныхФайлов()+"clean.vbs",КодировкаТекста.Системная);
			ЗапуститьПриложение(""""+КаталогВременныхФайлов()+"clean.vbs""");
			WshShell = Неопределено;
		Исключение
			МассивПолучателей = Новый Массив;
			МассивПолучателей.Добавить("Sergey@kss.com");
			ПроцедурыДляЗапускаНаСервере.ВыполнитьОтправкуПочты(МассивПолучателей, Новый Массив, "Ошибка автоматической очистки 1С кэша у пользователя " + КодПользователя, ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
	КонецЕсли;
	
	НаборОчискаКэша[0].ОбновленаДинамически = Ложь;
	НаборОчискаКэша[0].ТребуетсяПерезапуск = Ложь;
	НаборОчискаКэша.Записать();
Показать
75. 1985Alex1985 17.05.13 09:15 Сейчас в теме
(74) Ну может я со временем придумаю что нибудь еще что добавить в этот регистр. Думаю период не повредит. Я бы еще добавил очистку кэша ОПРЕДЕЛЕННОЙ базы, а не всех подряд (как я понял из названий папок с кэшем у самой базы тоже есть гуид). Даже погуглил на эту тему, но ничего определенного пока не нашел. Доработка интересная в любом случае, и просто так я ее оставлять не буду.

П.С. в локалсетингс\аппдата находится кэш, в просто \аппдата находятся настройки... а еще где может быть кэш который портится? Или какие ситуации динамического обновления может не учесть эта доработка? Как то все не сложно получилось, аж не верится что 1С сами не впихнули что то такое во все конфы.
76. Evil Beaver 6292 18.07.13 10:12 Сейчас в теме
Столько комментариев, не осилил все, возможно выше уже что-то такое предложили.
Идея:
1.У каждого пользователя есть файл со списком ИБ - лежит в %APPDATA%\1Cestart
2.На сетевой шаре создается реестр баз, для которых нужно очистить кеш. В файле написаны строки подключения к базам (пути или адреса серверов)
3.На пользовательских машинах в планировщике задач ставится этот скрипт, который смотрит на сетевую шару и для заданных ИБ (если у пользователя они есть в списке баз) очищает кеш.
5.На Скрипт можно повесить ярлык и научить пользователей запускать принудительно

Плюсы:
Не модифицируем конфигурации
Управляем удаленно необходимостью чистки
Скрипт пускается автоматически, скажем каждую ночь и проверяет не надо ли чего почистить
Возможно ошибаюсь, по-моему в домене можно настроить планировку заданий на каждой машине удаленно, т.е. не надо ходить к каждому и настраивать расписание.
77. 26178_mail.ru 18.07.13 13:51 Сейчас в теме
Да кэш это беда 1с, иногда даже не понятночто такое а все дело в кэше
78. tiniji 154 18.07.13 15:24 Сейчас в теме
Помнится мне, сам Нуралиев писал на партнерском форуме, что проблема кэша будет решена в 8.3.
79. ZLENKO 23.07.13 15:49 Сейчас в теме
(78) Они уже столько раз обещали ее решить в 8.2 ... и так и не решили. А в 8.3 у них Такси :-) приехало. Теперь уж точно не исправят. Просили ж их сделать тупую настройку в базе чтоб при запуске очищало кеш. А они что сделали - ключ запуска. Спасибо им конечно, но вот как мне его на практике использовать ?
81. sanfoto 495 25.07.13 11:43 Сейчас в теме
(79) ZLENKO.PRO,

делаем общий для всех файл списка инф.баз ibases.v8i на расшареном ресурсе

пример
------------------
[WEB_Управление_Персоналом]
Connect=Srvr="server1c";Ref="WEB_Управление_Персоналом";
ID=c43ff957-1669-435e-be37-6eb729ee45bc
OrderInList=16384
Folder=/
OrderInTree=16384
External=0
App=Auto
WA=1
AdditionalParameters=/ClearCache

ПС:
Да всегда будет при запуске чистится кэш, но время запуска увеличивается таки не критично, зато нет гемора с кэшем.
82. AlexO 127 27.07.13 15:35 Сейчас в теме
(81) sanfoto,
делаем общий для всех файл списка инф.баз ibases.v8i на расшареном ресурсе

Можно, но совсем не обязательно, так как все решается проще: в Параметры на вкладке "Запуск 1С Предприятия" в "Параметр запуска" базы указывается этот ключ.
И у всех пользователей при старте идет очистка кэша (если ключ сработает). А файл загрузки забивать различными параметрами - их там и так много :)
88. нормальный такой 90 06.08.14 12:25 Сейчас в теме
(81) sanfoto, с этим флагом чистится только СЕРВЕРНЫЙ кеш.
на сколько я понял, в данной статье скрипт чистит локальный кеш пользователя, причем со всеми корнями. заполнениями форм и прочими настройками, некоторые пользователи будут ругаться что им всё приходится "забивать" заново.
80. maxopik2 53 24.07.13 10:00 Сейчас в теме
( Помнится мне, сам Нуралиев писал на партнерском форуме, что проблема кэша будет решена в 8.3.

Изменено: tiniji - 18.07.13 15:25 )

Наверное Нуралиев сам мало работает в 1с и не знает как это сидеть, смотреть в монитор и удивляться непонятным цифрам в отчете.
86. dock 35 20.12.13 12:01 Сейчас в теме
по теме КЕШа... судя по работе, в 8.3 не решена эта проблема.
работаем с ЗУП 2.5, уже столкнулся с проблемами...
87. unknownDaemon 43 11.04.14 14:06 Сейчас в теме
$DirLocal = "$env:LOCALAPPDATA\1C"
$DirRoaming = "$env:APPDATA\1C"

function _ClearCache {
        #
        $Dir = $args[0]
        #
        gci $Dir -rec -include *cache* | where { $_.psiscontainer } | gci -include *cache* | where { ! $_.psiscontainer } | foreach ($_) {remove-item $_.fullname}
        gci $Dir -rec -include *cache* | where { ! $_.psiscontainer } | foreach ($_) {remove-item $_.fullname}
        #
    }
Показать
89. 1Service2 26.11.14 16:53 Сейчас в теме
90. ya.Avoronov 108 18.12.14 13:26 Сейчас в теме
Полезная статья, а пробовал кто-то соединить все это в одной обработке и доступно предоставить нам пользователям? Что удивительно с ошибками кЭша при динамическом обновлении я начал сталкиваться только в последних релизах 1С. Не припомню такого на 8.0 и 8.1, или я был занят чем-то другим!
91. le_ 201 20.05.16 12:35 Сейчас в теме
А я вызов вот такой процедуры поместил в ПриЗавершенииРаботыСистемы():

Процедура ЗапуститьСкриптДляОчисткиКэша() Экспорт
	
	Если НЕ РольДоступна("ОчисткаКэшаПриЗавершенииРаботы")	 Тогда
		Возврат;
	КонецЕсли;

	ПутьКФайлуСкрипта = КаталогВременныхФайлов() + "Cache.vbs";
	
	Скрипт = Новый ТекстовыйДокумент;
	Скрипт.УстановитьТекст("
	|On Error Resume Next
	|Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
	|Set WshShell = WScript.CreateObject(""WScript.Shell"")
	|Set objWMIService = GetObject(""winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2"") 
    |
	|'логин, под которым работает пользователь
	|CurrentUserName = wshShell.ExpandEnvironmentStrings(""%USERNAME%"")
    |
	|'Если запущенных процесов 1cv8.exe больше 1, завершаем скрипт; если 1, ждем пока процесс завершится, чтобы продолжить работу скрипта
	|UserProcessesCount = GetUserProcessesCount(CurrentUserName)
	|If UserProcessesCount > 1 Then
  	|	WScript.quit
	|End If
	|Do While UserProcessesCount > 0
    |	WScript.Sleep(1000)'1 sek
    |	UserProcessesCount = GetUserProcessesCount(CurrentUserName)
	|Loop
    |
	|'удаление папок с кэшем целиком
	|UserProfileFolder = wshShell.ExpandEnvironmentStrings(""%USERPROFILE%"")
	|Set Folder = FSO.GetFolder(UserProfileFolder & ""\AppData\Local\1C\1Cv82"")
	|Folder.Delete
	|Set Folder = FSO.GetFolder(UserProfileFolder & ""\AppData\Roaming\1C\1Cv82"")
	|Folder.Delete
    |
	|Function GetUserProcessesCount(CurrentUserName)
    |
	|  GetUserProcessesCount = 0
	|  strNameOfUser = """"
	|  
	|  Set colProcesses = objWMIService.ExecQuery(""Select Name From Win32_Process Where Name = '1cv8.exe'"") 
    |
	|  For Each objProcess In colProcesses 
	|    Return = objProcess.GetOwner(strNameOfUser)
	|      If Return <> 0 Then
	|         'Wscript.Echo ""Could not get owner info for process "" & objProcess.Name & VBNewLine & ""Error = "" & Return
	|      Else
	|        If strNameOfUser = CurrentUserName Then
	|          GetUserProcessesCount = GetUserProcessesCount + 1 
	|        End If  
	|      End If
	|  Next
    |
	|End Function
	|	
	|");
	 
    Скрипт.Записать(ПутьКФайлуСкрипта, КодировкаТекста.Системная);
	ЗапуститьПриложение(ПутьКФайлуСкрипта);
КонецПроцедуры
Показать
92. jamirza 27.05.16 18:28 Сейчас в теме
Вот уж спасибо. Отличная идея.
93. jamirza 27.05.16 18:34 Сейчас в теме
Вот такую вещь разместил в обработчик ожидания. В параметрах сеанса в нашей конфе есть справочник компьютеры, туда добавил реквизит ДинамическоеОбновлениеИБ. В УТшке есть похожий параметр сеанса рабочее место.

	Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда
		
		Комп = ПараметрыСеанса.Компьютер.ПолучитьОбъект();
		Комп.ДинамическоеОбновлениеИБ = Истина;
		Комп.Записать();
		
		ТекстВопроса = "В конфигурацию ИБ внесены изменения." + Символы.ПС +
		"Настоятельно рекомендуется перезапустить программу." + Символы.ПС +
		"Сделать это сейчас?";
		Кнопки = Новый СписокЗначений;
		Кнопки.Добавить(1,"Да");
		Кнопки.Добавить(2,"Нет");
		Кнопки.Добавить(3,"Не уверен(а)");
		Кнопки.Добавить(4,"Воздержусь");
		
		РезультатВопроса = Вопрос(ТекстВопроса, Кнопки, 10);
		Если РезультатВопроса = 2 Тогда
			Возврат;
		КонецЕсли;
		
		ЗавершитьРаботуСистемы(Истина);
		
	КонецЕсли;
Показать


А перед завершением работы вот так
	Если ПараметрыСеанса.Компьютер.ДинамическоеОбновлениеИБ Тогда
	Комп = ПараметрыСеанса.Компьютер.ПолучитьОбъект();
		Комп.ДинамическоеОбновлениеИБ = Ложь;
		Комп.Записать();
		ОчиститьКэшИПерезапуститьПрограмму();
	КонецЕсли;


Процедуру со скриптом позаимстовал из статьи.
Теперь в любом случае при динамическом обновлении кэш почистится.
Еще раз спасибо за статью. Столько гемора у меня было с этим.
arakelyan; +1 Ответить
96. ksnik 358 09.03.18 14:13 Сейчас в теме
выложу ка и я свой вариант скрипта :-)
// Процедура создает и запускает vbs файл, который производит очистку кэша.
// 1С и презапускает программу
//
Процедура ОчиститьКэшИПерезапуститьПрограмму() Экспорт

ОбновитьИнтерфейс();
	
     СкриптФайл = Новый ТекстовыйДокумент;

     СтрокаСоединенияСБД = СтрокаСоединенияИнформационнойБазы();
     СтрокаЗапускаПрограммы = Константы.КаталогПрограммы1С.Получить();
	 Если СтрокаЗапускаПрограммы = "" Тогда
		 СтрокаЗапускаПрограммы = "8.3.11.2899\bin\";
	 КонецЕсли;
	 ПутьЗапуска = "C:\Program Files (x86)\1cv8\"+СтрокаЗапускаПрограммы;
	 ПроверкаФайла = Новый Файл (ПутьЗапуска);
	 Если ПроверкаФайла.Существует() Тогда
		 СтрокаЗапускаПрограммы = ПутьЗапуска;
	 Иначе	
		 ПутьЗапуска = "C:\Program Files\1cv8\"+СтрокаЗапускаПрограммы;
		 ПроверкаФайла = Новый Файл (ПутьЗапуска);
		 Если ПроверкаФайла.Существует() Тогда
			 СтрокаЗапускаПрограммы = ПутьЗапуска;
		 КонецЕсли;
	 КонецЕсли;
	 ПроверкаФайла = "";
     ПутьКФайлуСкрипта = КаталогВременныхФайлов() + "CacheCleaning.vbs";
     ПутьКФайлу1С = СтрокаЗапускаПрограммы + "1cv8.exe";

     ИмяСервера = "";
     ИмяБазы = "";
     Путь = "";
     КомандаЗапуска = "";

     Один = """";
     Два = """""";
     Три = """""""";  

    Если (Найти(СтрокаСоединенияСБД, "File=") <> 0) Тогда
          Путь = СтрЗаменить(СтрокаСоединенияСБД, "File=", "");
          Путь = Лев(Путь, СтрДлина(Путь)-1);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /F" + Путь + Один + ", 1, true";
     Иначе
          МассивПараметровСоединения = РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(), ";");
          МассивПараметровСервера = РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[0], """");
          ИмяСервера = СокрЛП(МассивПараметровСервера[1]);
          МассивПараметровБазы = РазложитьСтрокуВМассивПодстрок(МассивПараметровСоединения[1], """");
          ИмяБазы = СокрЛП(МассивПараметровБазы[1]);
          КомандаЗапуска = "WshShell.Run " + Три + ПутьКФайлу1С + Два + " ENTERPRISE /S" + ИмяСервера + "\" + ИмяБазы + Один + ", 1, true";
     КонецЕсли;

     // Если пользователь не хочет перезапускать сеанс 1С, то после выполнения скрипта ничего не делаем. 

	 глПерезапускатьСеансРаботыСПрограммой = ВосстановитьЗначение(ИмяПользователя()+"глПерезапускатьСеансРаботыСПрограммой");
	 Если глПерезапускатьСеансРаботыСПрограммой = Ложь Тогда
	      КомандаЗапуска = ""; 
	 Иначе
	 КонецЕсли; 
     СкриптФайл.УстановитьТекст("WScript.Sleep(5000)
     |
     |Dim FSO
     |Set FSO = WScript.CreateObject(""Scripting.FileSystemObject"")
     |Set WshShell = WScript.CreateObject(""WScript.Shell"")
     |Set colEnvVars = WshShell.Environment(""Process"")
     |
     |strComputer = "".""
     |Set objWMIService = GetObject(""winmgmts:"" _
     |& ""{impersonationLevel=impersonate}!\\"" _
     |& strComputer & ""\root\cimv2"")
     |
     |Set colProcesses = objWMIService.ExecQuery( _
     |""Sel ect * Fr om Win32_Process "" _
     |& ""Where Name = '1cv8.exe'"")
     |
     |For Each objProcess In colProcesses
     | objProcess.Terminate
     |Next
     |
     |WScript.Sleep(1000)
     |
     |FolderName1 = ""\Local Settings\Application Data\1C\1Cv82""
     |FolderName2 = ""\Local Settings\Application Data\1C\1Cv8""
     |FolderName3 = ""\AppData\Local\1C\1Cv82""
     |FolderName4 = ""\AppData\Local\1C\1Cv8""
     |FolderName5 = ""\AppData\Roaming\1C\1Cv82""
     |FolderName6 = ""\AppData\Roaming\1C\1Cv8""
     |
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName1) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName1
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName2) Then
     |GoSubFolders colEnvVars(""userprofile"") & FolderName2
     | End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName3) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName3
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName4) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName4
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName5) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName5
     |End If
     |If FSO.FolderExists(colEnvVars(""userprofile"") & FolderName6) Then
     | GoSubFolders colEnvVars(""userprofile"") & FolderName6
     |End If
     |
     |" + КомандаЗапуска + "
     |Set WshShell = Nothing
     |
     |Sub DelFile(sFILE)
     | On Error Resume Next
     | FSO.DeleteFile sFILE, True
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error deleting file: "" & sFILE
     | End If
     |End sub
     |
     |Function GetFolder(sFOLDER)
     | On Error Resume Next
     | Set GetFolder = FSO.GetFolder(sFOLDER)
     | If Err.Number <> 0 Then
     | Wscript.Echo ""Error connecting to folder:"" & sFOLDER & VBlf & ""["" & Err.Number & ""]"" & Err.Description
     | Wscript.Quit Err.Number
     | End If
     |End Function
     |
     |Sub GoSubFolders (objDIR)
     | ProcessFilesInFolder objDIR
     | Set sFolder = GetFolder(objDIR)
     | For Each eFolder in sFolder.SubFolders
     | GoSubFolders eFolder
     | Next
     | FSO.DeleteFolder sFolder, True
     |End Sub
     |
     |Sub ProcessFilesInFolder (objDIR)
     |Set sFolder = GetFolder(objDIR)
     |For Each objFile in sFolder.Files
     | DelFile objFile
     |Next
     |End Sub");

     Попытка
            СкриптФайл.Записать(ПутьКФайлуСкрипта, КодировкаТекста.Системная);
            ЗапуститьПриложение(ПутьКФайлуСкрипта);
     Исключение

     КонецПопытки;

КонецПроцедуры
Показать
97. Kalam 105 28.04.18 14:27 Сейчас в теме
Простыни кода...
Делюсь своим!

Процедура Кнопка1Нажатие(Элемент)

	файл = Новый ТекстовыйДокумент;
	scr = КаталогВременныхФайлов()+"clear1c.ps1";
	файл.УстановитьТекст("echo 'Подготовка к запуску, дождитесь окончания работы этого скрипта.'
	|timeout.exe /T 4 /NOBREAK
	|echo 'Не запускайте 1С.'
	|Get-childitem -Path $ENV:Userprofile\appdata\Roaming\1c\1cv8*\* -Exclude *.pfl,def.usr,tmplts | Remove-item -recurse
	|Get-childitem -Path $ENV:Userprofile\appdata\Local\1c\1cv8*\* -Exclude *.pfl,tmplts | Remove-item -recurse
	|echo 'КОНЕЦ!'
	|echo 'Если не пробегало красное, значит все нормально. Можно запускать 1С.'
	|timeout.exe /T 5 /NOBREAK");
	файл.Записать(scr,КодировкаТекста.Системная);
	Сообщить(scr);
	ЗапуститьПриложение("powershell -executionpolicy unrestricted -command "+scr,,Ложь);
	ПрекратитьРаботуСистемы(Ложь, "/ClearCache");
	
КонецПроцедуры
Показать
Belkin_Sergey; +1 Ответить
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 318

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    10026    ids79    42       

Три костыля. Сказ про фокусы в коде 122

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7799    YPermitin    68       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8284    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 242

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10404    ids79    24       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9824    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9310    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 135

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8725    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6228    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 192

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17444    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11538    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17243    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9851    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4832    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7369    m-rv    16       

О расширениях замолвите слово... 191

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16348    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12734    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12828    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 163

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15472    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12707    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21420    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 118

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18896    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19632    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20849    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20453    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14581    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21259    Rain88    42       

Повышаем эффективность разработки правил обмена 123

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19312    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 153

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24374    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21185    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16960    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11341    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24356    avfed@rambler.ru    19       

Минимализмы 3 351

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35568    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25842    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21316    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137561    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22684    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21067    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24032    json    9       

Работа с Excel 289

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24703    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46766    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18224    vardeg    31