IE 2017

Альтернативная реализация функции Сигнал(Beep)

Программирование - Внешние компоненты

Реализация функции Beep, она же Сигнал. Позволяет задавать частоту и длительность сигнала.

Реализация функции Beep она же Сигнал. Позволяет задавать частоту и длительность сигнала. Различные реализации подобного функционала уже мелькали на этом сайте, но они все как правило под платформу 7.7. Я же предлагаю реализацию под 8.2.

В поставку входит zip архив который может быть подключен в качестве общего макета в конфигурацию, в этом случае подключение компоненты может выглядеть так:

ПодключитьВнешнююКомпоненту("ОбщийМакет.Beeper", "Beeper", AddInType.Native);

В архиве лежит файл beeper.dll который можно скопировать в любой удобный каталог и подключать так:

ПодключитьВнешнююКомпоненту("C:\beeper.dll", "Beeper", AddInType.Native);

 

Компонента хороша тем, что не требует регистрации в системе (благодаря технологии Native API).

Пример использования:

    ПодключитьВнешнююКомпоненту("C:\beeper.dll", "Beeper", AddInType.Native);
    Бипер = Новый("AddIn.Beeper.BeepEx");
    Бипер.Сигнал(300, 500);



Скачать файлы

Наименование Файл Версия Размер
Beeper
.zip 26,81Kb
30.05.12
40
.zip 26,81Kb 40 Скачать

См. также

Комментарии
1. Аркадий Кучер (Abadonna) 3687 30.05.12 20:13 Сейчас в теме
WinAPI BOOL Beep(DWORD dwFreq,DWORD dwDuration) предназначена для вывода звука через системный динамик.
В современных компьютерах он наличествует далеко не всегда (хоть внешний, хоть встроенный на материнской плате).
А в терминальном режиме кто будет слушать писк динамика на сервере? Уборщица в серверной?
2. Игорь Дайнеко (Dnki) 11.06.12 22:45 Сейчас в теме
А! динамик.. Я надеялся найти для звуковых файлов. Та, что я пользуюсь, сбоит в терминале.
3. Геннадий Северный (Avalanche) 176 18.06.12 09:48 Сейчас в теме
(2) Dnki, если вы хотите проигрывать звуковые файлы, то можно подключить ActiveX mediaplayer. Или вам нужно что бы это делала именно ВК?)
4. Игорь Дайнеко (Dnki) 19.06.12 23:37 Сейчас в теме
(3) Avalanche, Да, как говорится, попалась под руку ВК (Miracle) - использовал. Благо знаю как.
А Activ пока не употреблял. Это пример надо поискать.
5. Сергей Артюхов (Serg3141) 8 21.05.15 15:12 Сейчас в теме
еле нашел подходящую мне компоненту. Нужно сигнал выводить именно на спикер. Спасибо за разработку.
6. Латыпов (RinGo) 90 08.12.16 08:38 Сейчас в теме
Добрый день, Сергей! Прочитал Ваш комент к beeper.dll - "еле нашел подходящую мне компоненту. Нужно сигнал выводить именно на спикер. Спасибо за разработку..." ==> просьба: не могли бы Вы скинуть ее мне в личку? Ну не у меня этих монетов(sm), а очень нуно юзеров звуком предупреждать!... Заранее благодарен!

(5)
7. _ Ya, Ti, On, Ona, Vmeste celaya strana (agent00mouse) 151 20.12.16 21:54 Сейчас в теме
В терминале на работает. Грусть.
8. Ilya (ivisor_fil) 9 08.04.17 16:17 Сейчас в теме
Искал себе как сделать звуковую индикацию ошибочного ввода в 1с через спикер (потому как может не быть колонок, или выключен звук, или использоваться схема без звука)

Вот посылка звукового сигнала на спикер:

Процедура глБиип(КолЗвуков=0)
	Если КолЗвуков=0 Тогда Возврат; КонецЕсли;
	
	Shell = Новый COMОбъект("WScript.Shell");
	Команда = "%comspec% /c @echo ";
	Для Ном = 1 по КолЗвуков Цикл
		Команда = Команда + Символ(7);
	КонецЦикла;
	Shell.Run(Команда,0,0);
КонецПроцедуры
...Показать Скрыть
9. Ilya (ivisor_fil) 9 08.04.17 16:25 Сейчас в теме
(6)
Искал себе как сделать звуковую индикацию ошибочного ввода в 1с через спикер (потому как может не быть колонок, или выключен звук, или использоваться схема без звука)

Вот в итоге получиась такая небольшая процедурина:
Процедура глБиип(КолЗвуков=0)
    Если КолЗвуков=0 Тогда Возврат; КонецЕсли;
    
    Shell = Новый COMОбъект("WScript.Shell");
    Команда = "%comspec% /c @echo ";
    Для Ном = 1 по КолЗвуков Цикл
        Команда = Команда + Символ(7);
    КонецЦикла;
    Shell.Run(Команда,0,0);
КонецПроцедуры
...Показать Скрыть
10. _ Ya, Ti, On, Ona, Vmeste celaya strana (agent00mouse) 151 09.04.17 10:51 Сейчас в теме
Хочется звук иметь асинхронно. сказал компьютеру: - пищи. и дальше своими делами занимаешься, особенно актуально при работе со сканером ШК.

и немного лирики.:

По загадочным причинам, в сфере вычислительной техники слово «асинхронный» означает «синхронный». Например, «асинхронный запрос» — это когда синхронно (т. е. одновременно) с ним может выполняться другой. А вот если синхронность в выполнении отсутствует, и запросы выполняются последовательно друг за другом, то их с какого-то бодуна называют «синхронными».

стырено из интернета.
Оставьте свое сообщение