IE2017

Перенос справочников, документов и проводок БУ и НУ между двумя бухгалтерскими базами

Обработки - Обработка документов

Обработка позволяет переносить данные между бухгалтерскими базами версии 1.6 в версию 2.0. Осуществляется перенос справочников, документов, движений регистра и проводок по выбору пользователя посредством OLE

Обработка позволяет переносить данные между бухгалтерскими базами версии 1.6 в версию 2.0. Осуществляется перенос справочников, документов, движений регистра и проводок по выбору пользователя посредством OLE.

Вначале должны быть заполнены поля : путь к базе ред. 1.6, имя пользователя и пароль и нажата кнопка "Подключить" - для соединения с OLE базой приемника.

Далее Заполнены поля : 1) поле период - дата начала и конца

                                  2) Документ в базе бух 1.6 (вид документа источника - для переноса)

                                  3) Флаг "по конкретному документу " (Если включен - то переносится один документ)

                                 4) Флаг "пропускать помеченные на удаление" (Если включен - то не обрабатывается документ помеченный на удаление)

                                  5) Флаг "пропускать непроведенные" (Если включен - то не обрабатывается документ непроведенный)

                                   6) Флаг "изменять данные документа" (Если включен - осуществляется перезапись существующего документа, если нет то документ остается неизменным)

                                   7) Флаг "Переносить проводки БУ" ( Если включен то - переносятся проводки по бухгалтерскому учету)

                                   8) Флаг "Переносить проводки НУ (Если включен то -  переносятся проводки по налговому учету)

                                    9) Поле Отбирать по IDD -  если включено - служит для переноса одного документа по внутреннему уникальному идентификатору.  

 При нажатии кнопки "Перенести" - переносятся документы с видом из поля "Документы в базе 1.6" за выбранный период

При нажатии кнопки "Перенос проводок" - переносятся проводки в зависимости от выбранных флагов Переносить проводки БУ, Переносить проводки НУ.

При нажатии Кнопки "Перенести проводки субконто подразделение" - переносит в проводки субконто подразделение

Скачать файлы

Наименование Файл Версия Размер
Перенос документов, проводок и субконто подразделения в измерение Регистра Бух 20.epf
.epf 25,13Kb
12.07.12
19
.epf 25,13Kb 19 Скачать

См. также

Комментарии
0. Макс Хухлаев (maximvh) 7 12.07.12 21:59 Сейчас в теме
Обработка позволяет переносить данные между бухгалтерскими базами версии 1.6 в версию 2.0. Осуществляется перенос справочников, документов, движений регистра и проводок по выбору пользователя посредством OLE

Перейти к публикации

1. Владимир Кравчук (Power Team) (krava_vlad) 129 06.07.17 04:26 Сейчас в теме
Почему при нажатии файловый вариант прописывается

ПутьКБазе = "D:\Конфигурации_1С\v82\Бухгалтерия предприятия (демо) 2.0.17.7 (10.12.2010)";
Пользователь = "Хухлаев";
Пароль = "";
2. Владимир Кравчук (Power Team) (krava_vlad) 129 06.07.17 04:30 Сейчас в теме
Почему при выборе пути прописан поиск вооще базы 77

Процедура ПутьНачалоВыбора(Элемент, СтандартнаяОбработка)
	СтандартнаяОбработка = ложь;
	ПутьНеВыбран = истина;
	Пока ПутьНеВыбран Цикл
		Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
		Диалог = Новый ДиалогВыбораФайла(Режим);
		Диалог.Заголовок = "Выберите каталог с базой данных Закупки";
		Диалог.МножественныйВыбор = ложь;
		Диалог.Каталог = Путь;
		Если Диалог.Выбрать() Тогда
			Массив = НайтиФайлы(Диалог.Каталог,"1cv7.md");
			Если Массив.Количество()=0 Тогда
				Предупреждение("В выбранном каталоге база данных не найдена! Пожалуйста, выберите путь!");
			Иначе
				Путь = Диалог.Каталог;
				Если Прав(СокрЛП(Путь),1)<>"\" Тогда
					Путь = СокрЛП(Путь+"\");
				КонецЕсли;	
				ПутьКБазе = Путь;
				ПутьНеВыбран = ложь;
			КонецЕсли;
		Иначе
			ПутьНеВыбран=Ложь;
		КонецЕсли;	
	КонецЦикла;
КонецПроцедуры
...Показать Скрыть
Оставьте свое сообщение