IE 2017

Установка наценки на группу товаров для Управление торговлей 10.3

Обработки - Ценообразование, прайсы

Столкнулся с такой-же проблемой, как и автор этой темы на форуме: http://forum.infostart.ru/forum42/topic61194/
Клиенту хотелось иметь возможность установить определенную наценку на определенную группу товаров. В архиве две несложные обработки, которые помогут это сделать. За основу взят справочник «Ценовые группы». По прямому назначению этот справочник клиентом не использовался, потому и использовал его для решения этой проблемы.

В поле «Наименование» в справочнике «Ценовые группы» необходимо внести цифровое значение наценки (процент). Далее он попадет в Установку цен номенклатуры.

Первая обработка устанавливает наценку на группу товаров. Выбираем ценовую группу, выбираем группу товаров, если требуется перезаполнить уже введенные наценки ставим соответствующий флажок, и далее выполнить. Наценка установлена.

Вторая обработка вытягивает эту наценку в документ Установка цен номенклатуры, и прикрепляется как обработка табличных частей через Сервис/Внешние печ.формы и обр. Заполняем документ «Установка цен номенклатуры», сохраняем, вызываем обработку из меню «Заполнить» и далее «Рассчитать по базовым ценам»

Скачать файлы

Наименование Файл Версия Размер
UT10-3.zip
.zip 9,42Kb
30.07.12
124
.zip 9,42Kb 124 Скачать

См. также

Комментарии
0. Петр Петров (Adoms) 165 30.07.12 09:13 Сейчас в теме
Столкнулся с такой-же проблемой, как и автор этой темы на форуме: http://forum.infostart.ru/forum42/topic61194/
Клиенту хотелось иметь возможность установить определенную наценку на определенную группу товаров. В архиве две несложные обработки, которые помогут это сделать. За основу взят справочник «Ценовые группы». По прямому назначению этот справочник клиентом не использовался, потому и использовал его для решения этой проблемы.


Перейти к публикации

1. Александр МАН (1977) 2 04.09.12 19:05 Сейчас в теме
Не подскажите как можно подобрать товар, по которому били обороты? (Есть цена закупки)
2. Петр Петров (Adoms) 165 05.09.12 11:14 Сейчас в теме
(1) Надо в обработку заполнения наценки еще один фильтр добавить, например через запрос:
ВЫБРАТЬ
ТоварыНаСкладахОбороты.Номенклатура
ИЗ
РегистрНакопления.ТоварыНаСкладах.Обороты КАК ТоварыНаСкладахОбороты


или по другому какнить посмотреть, есть ли текущая номенклатурная позиция в регистре с оборотами
3. Александр МАН (1977) 2 05.09.12 13:07 Сейчас в теме
4. Алексей (kanalya) 110 17.12.12 23:17 Сейчас в теме
Сама идея правильная, но в Вашем варианте обрабатываются уже сохранённые данные, т.е. если создать новый документ, заполнить его и запустить алгоритм - документ будет очищен. Предлагаю так:
Функция Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта = Неопределено) экспорт
	
ФормаОбъекта = Объект.ПолучитьФорму("ФормаДокумента");
Для каждого СтрокаТЧ из ФормаОбъекта[ИмяТабличнойЧасти] Цикл
  Для НомерСоответствияЦены=0 по ФормаОбъекта.мСоответствиеТиповЦен.Количество()-1 цикл
    Если СтрокаТЧ["СпособРасчета"+НомерСоответствияЦены] = Перечисления.СпособыРасчетаЦены.ПоПроцентнойНаценкеНаБазовыйТип тогда 
      Попытка
        СтрокаТЧ["Процент"+НомерСоответствияЦены] = Число(СтрокаТЧ.Номенклатура.ЦеноваяГруппа.Наименование);
      Исключение	
        Сообщить("Для товара """ + СтрокаТЧ.Номенклатура + """ не задана ценовая группа");
      КонецПопытки;
    КонецЕсли;
  КонецЦикла;
КонецЦикла;

КонецФункции
...Показать Скрыть
l-Rain; Adoms; +2 Ответить
5. Людмила Артемьева (l-Rain) 05.01.13 17:19 Сейчас в теме
Все отлично работает, правда с дополнением kanalya корректнее будет. Спасибо.
6. Виктор Фролов (luckardo) 9 23.01.13 00:27 Сейчас в теме
это все интересно но все же ручками, а вот к динамический изменения от базового типа цен в разрезе номенклатурных групп реализована покамест стандартно только в рос. УТ11
7. Алексей Роза (DoctorRoza) 30.01.13 14:34 Сейчас в теме
Запомню, может и пригодиться!
8. makaorel 54 05.10.14 11:06 Сейчас в теме
спасибо, пригодилось- взяла за основу
Оставьте свое сообщение