Пример загрузки данных с помощью COMObject в 1С 8.2

Публикация № 147600

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

5
Данный алгоритм помогает универсализировать процесс загрузки данных в БД 1С.
В отличие от 1С 7.7 возможно использование таких полезных объектов и свойств: «ДеревоЗначений», «ЗаполнитьЗначенияСвойств()», а также вынести повторяющиеся части процедур в Общий модуль, что упрощает читаемость кода  и исключает дублирующиеся записи. Кроме того, если понадобится внести какие-либо изменения, то это необходимо будет сделать всего в одном месте.

Задача: Компания ООО «Альфа» занимается реализацией  различной бытовой техники. Логистический учет производится в ПО на «С Sharp» собственной разработки. Необходимо вытягивать информацию о продажах в 1С8.2.

Решение:

Для подключения к базам использовать COMObject.

Создаем обработку «ЗагрузкиИзЛогистическойСистемы».

Реквизиты формы: «СписокБаз» - если несколько систем учета (Например, для разных видов товара)[Справочник «БДПредприятия»], «ВыборПериода»[СтандартныйПериод], "ЗагруженныеДанные" [ДеревоЗначений].

 


 **********************************************************************

**************  Модуль Формы Обработки:  *********************************

 

Создаем команду «ЗагрузитьПродажуИзЛогистическойСистемы», создаем к ней обработчикДействия:

&НаКлиенте
Процедура ЗагрузитьПродажуИзЛогистическойСистемы (Команда)
    НачДата=ВыборПериода.ДатаНачала;
    КонДата=ВыборПериода.ДатаОкончания;
    // Процедура, которая с сервера запускает Модуль Менеджера Обработки
    ЗагрузкиИзЛогистическойСистемыСервер(НачДата,КонДата,Режим, СписокБаз);
КонецПроцедуры

&НаСервере
Процедура ВызовПроцМенеджераОбработкиССервераЗагрузить(НачДата,КонДата,Режим,ТекущееИмяБазы)
    ЗагруженныеДанные =0;
    Обработки.ЗагрузкиИзЛогистическойСистемы. ЗагрузитьПродажуИзЛогистическойСистемы(НачДата,КонДата, ЗагруженныеДанные, СписокБаз);
КонецПроцедуры

**********************************************************************

**********************************************************************


**********************************************************************

****** Общий модуль «ДляОбработокЗагрузкиСервер»  *************************

Галочки: Сервер, Вызов Сервера

// Данная функция возвращает дату для получения данных из БД в нужном формате
Функция ДатаДлязапроса(Дата) ЭКСПОРТ
    Возврат ""+фДата(УПВЗ(Год(Дата)))+"-"+фДата(Месяц(Дата))+"-"+фДата(День(Дата));
КонецФункции // ДатаДлязапроса()

Функция фДата(Д)    ЭКСПОРТ        
    Если СтрДлина(Д) < 2 Тогда
        Д = Строка("0"+Д)  
    КонецЕсли;
    Возврат Д;
КонецФункции

//Данная функция открывает доступ к Объекту COMObject, выполняет запрос
Функция ПолучитьИсточник(Source,Источник,db) ЭКСПОРТ
    db = Новый COMObject ("ADODB.Connection");
    db.ConnectionString = источник;
    db.Mode = 1;
    db.CommandTimeout = 0;
    попытка
        db.Open();
        Сообщить("db.Open() прошло");
    Исключение
        Сообщить("db.Open()не прошло:"+ОписаниеОшибки())
    КонецПопытки;
    Сообщить(Source );
    Возврат db.Execute(Source);
КонецФункции // ПолучитьИсточник()

//Функция  удаляет пробелы внутри значения
//Пробелы возникают из-за того, что восьмерка определяет некое значение как числовое
Функция УПВЗ(Д)      ЭКСПОРТ   
    //Ищем пробел в каждой позиции
    А="";
    Для сч=1 по StrLen(Д) Цикл
        А=А+trimall(Right(left(Д,Сч),1));        
    КонецЦикла;
    Возврат А;
КонецФункции

//Функция ПолучитьСсылкуНоменклатуры возвращает
Функция ПолучитьСсылкуНоменклатуры(КодЗЧ,НаименЗЧ,ПартНомер) ЭКСПОРТ
    НоменклатураСсылка=Справочники.Номенклатура.НайтиПоКоду(Trimall(КодЗЧ));
    Если  НоменклатураСсылка.Пустая() Тогда
        Номенклатура=Справочники.Номенклатура.СоздатьЭлемент(); 
        Номенклатура.Код=Trimall(КодЗЧ);
        Номенклатура.Наименование=Trimall(НаименЗЧ);
        Номенклатура.ПартНомер=trimall(ПартНомер);
        Номенклатура.Записать();
        НоменклатураСсылка=Номенклатура.Ссылка;
    КонецЕсли;           
    Возврат НоменклатураСсылка;
КонецФункции // ПолучитьСсылкуНоменклатуры()

Процедура ЗаполнениеДокументовИзДереваЗначений(ВидДокумента,НазваниеТабличнойЧасти,ДеревоЗначений)  ЭКСПОРТ
    Для каждого Строка Из ДеревоЗначений.Строки Цикл 
        Док=Документы[ВидДокумента].НайтиПоНомеру(Строка.Номер,Строка.дата);
        Если Док.Пустая() Тогда
            ДокОбъект       = Документы[ВидДокумента].СоздатьДокумент();
            ДокОбъект.Номер = Строка.Номер;
        Иначе
            ДокОбъект       = Док.ПолучитьОбъект(); 
        КонецЕсли;
        // РучныеИзменения – это булевый реквизит шапки документа, если он Истина, тогда система при загрузке данных НЕ заменяет документ.
        // все остальные документы, у которых данный флаг = ЛОЖЬ, полностью обновляются.
        Если НЕ ДокОбъект.РучныеИзменения Тогда
            ЗаполнитьЗначенияСвойств(ДокОбъект,Строка);
            Если ЗначениеЗаполнено(НазваниеТабличнойЧасти) ТОгда
                ТЧ=ДокОбъект[НазваниеТабличнойЧасти];
                ТЧ.Очистить();
                Для каждого Подстрока  Из Строка.Строки  Цикл
                    ТекТЧ=ТЧ.Добавить();   
                    ЗаполнитьЗначенияСвойств(ТекТЧ ,Подстрока) ;
                КонецЦикла;
            КонецЕсли;
            Попытка                
                ДокОбъект.Записать();
            Исключение
                Сообщить("Документ "+ВидДокумента+" "+Строка.Номер+" "+Строка.дата+" "+ОписаниеОшибки());
            КонецПопытки;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

**********************************************************************

**********************************************************************


**********************************************************************

**************** Модуль Менеджера Обработки *****************************


Процедура  ЗагрузитьПродажуИзЛогистическойСистемы (НачДата,КонДата,ДЗ,ТекущееИмяБазы) Экспорт
    Сообщить("Начали: "+Формат(ТекущаяДата(), "ДЛФ=В"));
    Источник="DRIVER=SQL Server;SERVER=ИМЯСЕРВЕРА;UID=ЛОГИН;PWD=ПАРОЛЬ;DATABASE="+ТекущееИмяБазы;

    //Пример запроса
    Source="SELECT *
    |FROM TABLE1 as T1
    |INNER JOIN TABLE2 as T2 on (T2.Реквизит1='0') and  Т2.Реквизит2=T1.Реквизит1
    |LEFT OUTER JOIN TABLE3  as T3 ON T2.Реквизит3=Т3.Реквизит1
    |WHERE   (Т1.OpenDate BETWEEN '"+ДляОбработокЗагрузкиСервер.ДатаДлязапроса(НачДата)+" 00:00:00' and '"+ДляОбработокЗагрузкиСервер.ДатаДлязапроса(КонДата)+" 23:59:59')
    |order by T1.OpenDate";

    db="";
    rs=ДляОбработокЗагрузкиСервер.ПолучитьИсточник(Source,Источник,db);

    // это колонки, которые будут выгружены в Дерево значений на форму
    // кроме того в самом реквизите формы «ЗагруженныеДанные» необходимо создать такие же реквизиты.
    ДЗ=Новый ДеревоЗначений;
    ДЗ.Колонки.Добавить("Номер");
    ДЗ.Колонки.Добавить("Дата");
    ДЗ.Колонки.Добавить("Контрагент");
    ДЗ.Колонки.Добавить("Договор");
    ДЗ.Колонки.Добавить("Подразделение");
    ДЗ.Колонки.Добавить("Сумма");
    //И т.д. по необходимости.
    ТекНомер="";
    Пока rs.eof()=0  Цикл
        //Получаем данные из выборки
        Номер =  rs.Fields("Номер").Value;
        Если ТекНомер<>Номер   Тогда
            Реквизит1  =  rs.Fields("Реквизит1").Value;
            Реквизит2  =  ДляОбработокЗагрузкиСервер.УПВЗ(rs.Fields("Реквизит2").Value);
            Реквизит3  =  ДляОбработокЗагрузкиСервер.УПВЗ(rs.Fields("Реквизит3").Value);
            //Заполняем ДеревоЗначений 1 уровень
            НоваяСтрока=ДЗ.Строки.Добавить();
            НоваяСтрока.Дата  =  Реквизит1;
            НоваяСтрока.Номер =  Реквизит2;                                              
        КонецЕсли;
        //Заполняем ДеревоЗначений 2 уровень
        ПодчиненнаяСтрока  =  НоваяСтрока.Строки.Добавить();
        ПодчиненнаяСтрока.Номенклатура   = ДляОбработокЗагрузкиСервер.ПолучитьСсылкуНоменклатуры(Реквизит3);
        ТекНомер  = Номер;
        //Следующая Запись
        rs.movenext();
    КонецЦикла;
    //Закрываем выборку
    db.Close();
    //тут указываем свои наименования
    ВидДокумента="Продажа";
    НазваниеТабличнойЧасти="Товары";
    ДляОбработокЗагрузкиСервер.ЗаполнениеДокументовИзДереваЗначений(ВидДокумента,НазваниеТабличнойЧасти,ДЗ);
    Сообщить("Все!   "+Формат(ТекущаяДата(), "ДЛФ=В"));
КонецПроцедуры

**********************************************************************

**********************************************************************

 


После загрузки данных на Форме будет сформирован список в виде дерева значений из загруженных документов.

Я надеюсь, что для Вас была интересна и познавательна данная заметка.

5

Специальные предложения

Автор запретил комментарии

См. также

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1 9

Статья Программист Нет файла v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free) Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    697    Neti    0       

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    1585    handscenter    11       

Дозагрузка измененных данных при помощи КД2 6

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Иногда во время каких-то регламентных действий по обслуживанию базы(например, при обновлении измененной базы на много релизов) требуется обеспечить бесперебойность работы пользователей. Если конфигурации баз до и после идентичны, то тут сам Бог велел воспользоваться обработкой "ВыгрузкаЗагрузкаДанныхXML", либо такой же но с отбором(на Инфостарте есть такая). Но что если конфигурации баз различаются/значительно различаются? Ниже опишу, как вышел из положения я.

12.09.2019    1179    al_zzz    2       

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке" 28

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    1949    ivanek    21       

Обмен данными через Web Сервисы 80

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    4069    user5300    27       

Выгрузка и загрузка документов с движениями 13

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла задача перенести документы с движениями, но подменив организацию. Наткнулся на проблему с выгрузкой движений, опишу свой опыт.

02.09.2019    1370    human_new    7       

EnterpriseData – часть 3. Загрузка данных, идентификация объектов 61

Статья Программист Нет файла v8 v8::УФ 1cv8.cf ОС Бесплатно (free) Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    3305    ids79    7       

Перенос дополнительных реквизитов в Конвертации данных 2.0 16

Статья Программист Нет файла v8 КД Россия УУ Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    1859    vikulinamari    3       

Синхронизация данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл 1

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Публикация описывает последовательность синхронизации данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл.

23.04.2019    3027    saveliev    3       

Полезные приемы при работе с Конвертацией данных 2.1. Логирование, интерактивное управление, дозаполнение и постпроведение документов 43

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Некоторые полезные приемы для КД 2.1, которые могут пригодиться как при доработке типовых правил, так и самописных.

22.04.2019    4058    maks_20    9       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7270    m-rv    16       

Работа с ComОбъектом 1С 8.2; 8.3 100

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Определение типов и значений через COM соединение между конфигурациями.

15.04.2019    10460    vik070777    12       

Обмен данными между УПП 1.3.64.х и БП 3.0 по расписанию через Универсальный обмен данными + План обмена 2

Статья Программист Нет файла v8 УПП1 Россия Windows Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

Описание доработки конфигурации УПП 1.3.64.х для выполнения обмена данными по расписанию в БП 3.0. через обработку Универсальный Обмен Данными XML и План Обмена.

09.04.2019    2124    mrcamomile    0       

RabbitMQ + Конвертация Данных 3.0 178

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    13694    barelpro    82       

Конвертация данных 2.1: поиск по условию 18

Статья Программист Нет файла v8 КД ERP2 Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Задача. При обмене документами "Реализация товаров и услуг", поиск контрагента осуществлять по полям "ИНН", "КПП". Если вид договора с комиссионером, то поиск осуществлять по полям "ИНН", "КПП", "Наименование".

15.01.2019    5662    wowik    13       

Заметки КД 2.1: Как передать файл, динамически создаваемый в источнике, в справочник присоединенных файлов приемника 25

Статья Программист Нет файла v8 КД Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

В БП 3.0 есть документ "Книга Продаж Для Передачи В ЭлектронномВиде" из которого выгружается XML файл. Задача: Нужно из БП 3.0 посредством правил обмена, вместе с документом книга продаж сформировать и перенести XML файл в базу приемник. В приемнике файл будет храниться в справочнике "Книга Продаж Присоединенные Файлы".

10.10.2018    5292    Viktor_Ermakov    6       

Практические рекомендации по настройке бесшовной интеграции 1С:ERP и 1С:Документооборот КОРП 37

Статья Системный администратор Программист Нет файла v8::Бизнес-процессы ERP2 Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

В настоящей статье мы пошагово рассмотрим, как настроить бесшовную интеграцию 1С:Документооброт КОРП (1С:ДО) с 1С:ERP.

28.09.2018    10499    Апрель-С    6       

Планы обмена 1С 158

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    30030    zhichkin    4       

Конвертация 2.0. Обмен данными между справочниками по сопоставлению артикулов с помощью регистра сведений (пример). 13

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример обмена данными между справочниками по сопоставлению артикулов с помощью регистра сведений

27.08.2018    4361    Lyubogradov.P    0       

Альтернатива переноса ТЗ в конвертации данных 2.1 5

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Здравствуйте уважаемые. Решил выложить альтернативный способ переноса данных в конвертации данных из источника к приемнику, с последующим сбором их в ТЗ в месте ПослеЗагрузки. Т.е.можно готовый перенесенный объект доработать либо создать что-то еще на базе данных. Метод сам разработан с учетом простого понимания Конвертации без использования всех её многочисленных тонкостей и сложностей. В примере рассматривается перенос Операции. И вот еще что. Я не привожу тут готовое решение, я всего лишь показываю концепцию того, как можно делать в КД. Без использования глобальных переменных.

20.08.2018    4088    dinopopyys    6       

Конвертация 2.0. Перенос независимого справочника в подчиненный (пример). 9

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса независимого справочника в подчиненный с помощью Конвертации 2.0.

15.08.2018    5497    Lyubogradov.P    6       

Конвертация 2.0. Перенос элементов и групп справочника, имеющих различный вид иерархии (пример). 12

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса справочника, имеющего различный вид иерархии, с помощью Конвертации 2.0.

13.08.2018    5202    Lyubogradov.P    0       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19224    olegtymko    43       

hsИнтегратор - технология онлайнового обмена данными между базами на платформе 1С:Предприятие. Использование технологии в виде расширения, без изменения конфигураций баз данных, участвующих в обмене 33

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

hsИнтегратор : Простое в использовании решение, работает в качестве клиента и сервиса (в мобильном приложении – только клиента). Не обязательно требует внесения изменений в конфигурации интегрируемых баз данных. Маленький трафик обмена между клиентом и сервером, быстрая реакция на запросы со стороны клиента. Единый сервис для обмена данными различной структуры, механизмы для обеспечения безопасности.

25.06.2018    8570    12    hobi    8       

Обмен через универсальный формат. Пример нестандартной конвертации данных 82

Статья Программист Нет файла v8 УТ11 Россия Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    22212    artkor    12       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІІ: Регистры сведений 16

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Часть III публикаций об универсальном обмен через REST интерфейс OData - обмен регистрами сведений

26.05.2018    6299    V.Stavinsky    3       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІ: Документы 30

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Продолжение статьи об универсальном обмене между идентичными конфигурации через REST интерфейс OData (https://infostart.ru/public/829356/). В части второй разберем особенности обмена документами.

19.05.2018    7636    V.Stavinsky    5       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    16168    V.Stavinsky    11       

Как написать обмен с 50 поставщиками и не сойти с ума. Техника 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

О том как из обмена с одним идеальным поставщиком сделать обмены с 50 реальными поставщиками.

16.04.2018    6866    m-rv    1       

Конвертация данных. Произвольная иерархия справочника 11

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Источник: Бухгалтерский учет ред. 4.5 платформы 7.7. Приемник: Бухгалтерия предприятия 3.0. Задача: При загрузке справочника «Номенклатура» в приемнике, все элементы поместить в папку «Товары» с сохранением имеющейся иерархии в 7.7.

10.04.2018    7246    pyrkin_vanya    3       

Перенос помеченных на удаление объектов. Конвертация 2.1 18

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Иногда при переносе данных возникает задача: не переносить помеченные на удаление документы, а те документы, которые были ранее перенесены в базу приемник и теперь в приемнике стали помеченными на удаления - переносить так, чтобы в базу приемник не тянулись связанные с объектом ссылки, но искомый объект помечался на удаление. В данной статье будет рассказано, как это можно сделать достаточно просто, используя конфигурацию "Конвертация 2.1".

02.04.2018    10109    Shmell    2       

Совместная работа БП 3.0 и ЗУП 3.1. Устранение ошибки синхронизации персональных данных физических лиц 12

Статья Системный администратор Программист Нет файла v8 БП3.0 ЗУП3.x Управление персоналом (HRM) Бесплатно (free) Перенос данных из 1C8 в 1C8

При совместной работе указанных конфигураций с использованием встроенного плана обмена «ОбменЗарплата3Бухгалтерия3» персональные данные физических лиц передаются некорректно. Это связано с ошибкой в правилах обмена (замшелой уже, с учётом того, сколько времени эта ошибка «кочует» из версии в версию правил).

31.03.2018    9839    ser73461014    11       

Обмен документами между одинаковыми конфигурациями 8

Статья Программист Нет файла v8 1cv8.cf БУ Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Простой вариант передавать созданное основание в подчиненный документ при обмене и делать обмен по произвольному алгоритму.

16.03.2018    7498    alex_bitti    0       

Выгрузка характеристик номенклатуры в бухгалтерию 6

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Эта статья может быть полезна тем, кто хочет избежать «свёртки» номенклатуры с характеристиками при выгрузке в базу бухгалтерии. В «1С Бухгалтерия» версий 2.0 и 3.0 нет понятия «характеристика номенклатуры», поэтому при выгрузке, например, из УНФ в базу бухгалтерии номенклатура с характеристиками сворачивается в одну позицию без характеристик. В статье на примере конфигураций «УНФ 1.6» и «БП 3.0» описана доработка правил обмена, которая позволяет выгружать каждую комбинацию «Номенклатура + Характеристика» в виде независимой номенклатуры в базу бухгалтерии.

22.01.2018    10123    maxim_1c    8       

Настройка обмена через универсальный формат между СВОЕЙ КОНФИГУРАЦИЕЙ и ТИПОВОЙ, не снимая типовую с поддержки (+ фишка БСП) 53

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла необходимость настроить синхронизацию между своей отраслевой конфигурацией и Бухгалтерией 3.0, основным условием было - НЕ снимать Бухгалтерию с поддержки. Предлагаю краткую инструкцию + одну "фишку" БСП, которая по умолчанию не отображается.

25.12.2017    19800    tmn72.1C    18       

Синхронизация под контролем (на примере синхронизации «1С:Зарплата и управление персоналом 3.1» и «1С:Бухгалтерия 3.0») 10

Статья Программист Нет файла v8 БП3.0 ЗУП3.x Россия БУ Зарплата Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье рассматривается возможность наглядного анализа переносимых данных при синхронизации, построенной на технологии «1С:Конвертация 2».

19.12.2017    11786    leosoft    6       

Как самому написать обмен между Бухгалтерией 2.0 и ЗУП 3.1. (Часть 1) 29

Статья Программист Нет файла v8 БП2.0 ЗУП3.x БУ Windows Зарплата Бесплатно (free) Перенос данных из 1C8 в 1C8

Речь пойдет о том, как можно осуществить переход на ЗУП 3.1 и при этом сохранить работоспособность системы обмена, написав свой обмен между конфигурациями разных поколений в Конвертации данных. В этой части речь пойдет только об документе Отражения зарплаты (перенос начислений).

15.12.2017    11299    alex_bitti    0       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137148    MaxS    251       

Обмен между базами 1С 8.3. Доработка типового плана обмена (синхронизации) между конфигурациями 1С на примере обмена 1С: Зарплата и управление персоналом 3 и 1С: Бухгалтерия предприятия 3 112

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Для чего нужно изучить данную статью и когда эти знания могут пригодиться? В первую очередь приведенная ниже информация потребуется программистам 1С, когда перед ними встанет задача доработать типовой обмен между конфигурациями, который настроен через синхронизацию данных, т.е. по плану обмена. Что же такое «План обмена»? План обмена в 1С – это объект, который входит в состав метаданных конфигурации и служит для синхронизации данных между информационными базами.

09.11.2017    49426    user858846    36       

Конвертация данных. Удобная навигация (Открыть алгоритм или запрос) v0.5 48

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Цель: выявить (зафиксировать) и реализовать удобную навигацию в КД, например: -Открытие алгоритмов в правилах конвертации объектов и правилах выгрузки данных.

27.10.2017    9102    Trise    6       

1С: Конвертация данных 2. Разработка с "нуля" на простых примерах разработки 155

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

1. Вступление 2. Что понадобится: конфигурация 1С: Конвертация данных 2. и обработки из пакета. Для примера задач возьмем конфигурации 1С: Управление торговлей 11 и 1С: БП 3.*. 3. Нам понадобятся Обработки для выгрузки структуры метаданных и обмена. 4. Выгрузка структуры метаданных конфигурации 1С: Управление торговлей 11.3 и 1С: Бухгалтерия предприятия 3.0.* 5. Загрузка структур метаданных конфигураций в базу конвертации. 6. Создание правил конвертации в 1С на конкретном примере задачи. 7. Подводим итоги: Выгрузка и загрузка данных с помощью разработанных правил обмена данными.

26.10.2017    57598    somel    21       

Основные концепции Конвертации данных (КД) для новичков 120

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

В КД очень важно понять основные принципы работы. Вроде и самой КД сто лет в обед, и понаписано уже не счесть, но все как-то не так, как мне бы хотелось. Постепенно крепло желание написать эдакое послание самому себе, начинающему изучать КД, да никак руки не доходили. Последней каплей стала очередная попавшаяся на глаза "неправильная" статья, и я решил - ничего страшного, пусть будет еще одна статья, зато гештальт закрою :) Даже если я излишне самонадеян, авось кому-то она все же поможет. Скриншотов не будет, будет только унылый текст. Но я бы в свое время за него многое отдал. Чтобы не перегружать статью, в ней не освещаются особенности вроде правил регистрации, особенностей КД 3.0 и т.п.

17.10.2017    23507    herfis    26       

Настройка автоматического обмена между конфигурациями Управление торговлей 10.3 и Управление торговлей 11. 3 при помощи механизмов планов обмена и правил обмена 54

Статья Программист Нет файла v8 УТ10 УТ11 Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье описывается методика настройки автоматического обмена между конфигурациями УТ 10 -УТ 11 3 при помощи механизмов планов обмена и правил обмена

25.09.2017    14101    The Ded    18       

Правила конвертации между регистрами сведений подчиненным регистратору и независимым 16

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Принцип настройки правил обмена в БСП между регистрами сведений, когда один из них подчинен регистратору, а второй независимый.

31.08.2017    12628    Pervuy    2       

Конвертация данных 2.* + Планы обмена - метод передачи в сообщении удаления независимых регистров 11

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Описывается метод передачи в сообщениях информации для удаления независимых регистров в узлах приемниках при использовании планов обменов в связке с конвертацией данных и обработкой "Универсальный обмен данными в формате XML" из поставки "Конвертация данных 2.x".

28.08.2017    8298    rawlik    8       

Что такое конвертация данных 1С (статья написана исключительно для новичков) 79

Статья Программист Стажер Нет файла v8 КД Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

О том, что "Конвертация данных" - мощный инструмент и прочую терминологию, вы прочтёте в любом источнике. Я хочу поделиться кратким пояснением как пользоваться данной конфигурацией. Речь пойдет о версии 2.1.

07.08.2017    29376    perepetulichka    33       

Перенос данных из базы с поврежденными таблицами 15

Статья Системный администратор Программист Нет файла v8 БП2.0 Казахстан БУ УУ Бесплатно (free) Тестирование и исправление Обмен через XML Перенос данных из 1C8 в 1C8

У клиента что-то произошло с жестким диском, что потребовало восстановления данных на нем. Базу 1С вроде бы сохранили, и она даже открылась. Однако при попытке доступа к документу "Платежный ордер, списание денежных средств" база вылетает с ошибкой. Также при получении оборотов за период в целом и по декадам выводились разные цифры. Обработка переноса данных в идентичную конфигурацию не подошла, из-за того, что так же вылетала с ошибкой БД. Ниже опишу мои действия по созданию новой конфигурации.

06.06.2017    12265    ermek6    14       

Перенос документов Установка цен номенклатуры с наполнением характеристиками в базе получателе 10

Статья Программист Нет файла v8 КД Россия УУ Windows Ценообразование, анализ цен Бесплатно (free) Перенос данных из 1C8 в 1C8

В свое время возникла у меня задача переносить документы Установка цен номенклатуры из УТ 10.2 (платформа 8.1) в розница 2.2. Задача осложнялась тем, что в УТ док установка цен создавался без характеристик. То есть в процессе переноса каждую номенклатурную позицию нужно было дополнить характеристиками. Характеристики в моем случае это размерный ряд обуви, потому характеристика не влияла на цену. В дополнение к характеристике в переносе нуждались также и штрихкоды.

16.05.2017    9740    makc2k    2       

Использование инструментов разработчика для отладки обменов КД 2.0 67

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    22530    unichkin    3       

Работа с конвертацией данных 349

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Поскольку к конвертации обращаюсь время от времени и какие-то детали забываются, хочу выделить несколько пунктов, чтобы "было где посмотреть". Статья сделана преимущественно «для себя», так что просьба не судить строго. (Примечание читающим/комментирующим: код в примерах очень сильно сокращен.)

16.03.2017    61702    perepetulichka    25