Обрезание или свертка базы (оперативный учет)

Публикация № 15011

Администрирование - Администрирование данных 1С - Свертка базы

Документ ОБРЕЗКА. Формирует при проведении фиксацию остатков на определенную дату по всем регистрам оперативного учета. Универсален - конфигурация может быть любой (стандартной или самодельной). Обрезание по полной программе - база 10 гиг. ТОРГОВЛИ обрезается за 15 мин.

Формирует при проведении фиксацию остатков на определенную дату по всем регистрам оперативного учета.
Универсален - конфигурация может быть любой (стандартной или самодельной).
Очень быстр - обрабатывает 10 гиг. базу за 5 мин.

Вообщем сам режу и другим обрезаю...

Обрезание по полной программе
Проводится только один раз - последний
Все документы до этого необходимо удалить!!!
Проведение документа необратимо
- поэтому все пробуем на копии
- в отчетах могут появиться надписи типа
страшного в этом нет
Наверное есть и недостатки

22.11.2011 г.

Порядок обрезки

- Запускаем обработку

- У меня база 20 гиг обработка отработала 30 мин. Сервер 4 ядра 8 гиг

- Далее переносим ТА на самый первый документ - Переносилось окло 20 мин

- Удаляем все доки до дакумента Обрезки - заняло 4 часа.

- Переносим ТА на документ ОБРЕЗКА. -  по времени еще 2-3 часа...

Вот и все.

 

Этот код полностью устраняет ошибку битых ссылок, но он заточен под мою конфигурацию.
 
[CODE]   //Расчитываем регистры
    СписокРег = СоздатьОбъект("СписокЗначений");
    СписокРег.ИзСтрокиСРазделителями(СокрЛП(РегистрОстатка));
    Если Проведен() = 0 Тогда
        ВремРег=СоздатьОбъект("Регистры");
        //Пробезаем по всем регистрам, которые отмечаны галочкой
        Для й=1 по СписокРег.РазмерСписка() Цикл
            РегОст = Строка(СокрЛП(СписокРег.ПолучитьЗначение(й,"")));    
            Рег=ВремРег.ПолучитьАтрибут(РегОст);
           // Рег=СоздатьОбъект("Регистр."+РегОст);
            Рег.Временныйрасчет(1);
            // РассчитатьРегистрыНа(ДатаДок);
            ВремРег.РассчитатьРегистрыНа(ТекущийДокумент());           
            //Присваеваем значений переменным
            РегистрПроведения = Метаданные.Регистр(РегОст);
            ГлавРег = Регистр.ПолучитьАтрибут(РегОст);
            КолИзмерений = РегистрПроведения.Измерение();
            КолРесурсов = РегистрПроведения.Ресурс();
            КолРеквизитов = РегистрПроведения.Реквизит();
            ТЗ = СоздатьОбъект("ТаблицаЗначений");
   Сообщить("регистр "+РегОст+" измерений "+КолИзмерений+" ресурсов "+КолРесурсов+" реквизитов "+КолРеквизитов);
            Рег.ВыгрузитьИтоги(ТЗ);
   КолСтрок = ТЗ.КоличествоСтрок();
          
   Если  КолСтрок = 0 Тогда
    Сообщить("регистр "+РегОст+" нет данных по движению - ПРОПУСКАЕМ..." );
    Продолжить;
   КонецЕсли;
   // взаиморасчеты свернем чего копить
   Если РегОст="Взаиморасчеты" Тогда
    Сообщить(""+ТекущееВремя()+" свертка взаиморасчетов "+КолСтрок);
    ТЗ.Свернуть("Клиент,Фирма","Сумма");
    ТЗ.ВставитьКолонку("КредДокумент",3,"Документ");
    КолСтрок = ТЗ.КоличествоСтрок();
   КонецЕсли;
   Если РегОст="ТП" Тогда
    Сообщить(""+ТекущееВремя()+" свертка долгов ТП "+КолСтрок);
    ТЗ.Свернуть("ТП,Клиент","Сумма");
    ТЗ.ВставитьКолонку("КредДокумент",2,"Документ");
    КолСтрок = ТЗ.КоличествоСтрок();
   КонецЕсли;
   Если РегОст="ОстаткиТоваров" Тогда
    Сообщить(""+ТекущееВремя()+" ДО свертка остатков товаров "+КолСтрок);
    ТЗ.Свернуть("Товар,Склад,Фирма","Остаток,Сумма");
    //ТЗ.ВставитьКолонку("КредДокумент",2,"Документ");
    КолСтрок = ТЗ.КоличествоСтрок();
    Сообщить(""+ТекущееВремя()+" после свертка остатков товаров "+КолСтрок);
   КонецЕсли;
   Сообщить(""+ТекущееВремя()+" начинаем обработку регистра "+РегОст+" всего  строк "+КолСтрок);
   //
   Если ИдетТест=1 Тогда
    ТЗ.ВыбратьСтроку();
    Продолжить;
   КонецЕсли;
   
   //
          // 
            //Делаем движение по этим остаткам, тем самым делаем полную копиб регистров на данное число
            Для А=1 по ТЗ.КоличествоСтрок() Цикл
                Состояние("Обрабатывается "+Строка(А)+" из "+Строка(КолСтрок));
                Для А1=1 по КолИзмерений Цикл
                    Рег=РегистрПроведения.Измерение(А1);
     Значение = ТЗ.ПолучитьЗначение(А,А1);
     Если ТипЗначения(Значение)=12 Тогда
      // документ всё равно будет удален подменяем текущим
      Значение  = ТекущийДокумент();
     КонецЕсли;
     
                    ГлавРЕГ.УстановитьАтрибут(Рег.Идентификатор,ТЗ.ПолучитьЗначение(А,А1));
                КонецЦикла;  
                Для А2=1 по КолРесурсов Цикл
                    Рег=РегистрПроведения.Ресурс(А2);
                    ГлавРЕГ.УстановитьАтрибут(Рег.Идентификатор,ТЗ.ПолучитьЗначение(А,А2+КолИзмерений));
    КонецЦикла;
    
                ГлавРЕГ.ДвижениеПриходВыполнить();
            КонецЦикла;
  КонецЦикла;
  Сообщить(""+ТекущееВремя()+" завершено");
    Иначе
        Предупреждение("Данный документ нельзя перепровести !!!");
        СтатусВозврата(0);
    КонецЕсли;[/CODE]

Скачать файлы

Наименование Файл Версия Размер
svertka_MD.rar

.1187159305 7,84Kb
2001
.1187159305 7,84Kb 2001 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 15.08.07 13:54 Сейчас в теме
> в отчетах могут появиться надписи типа <объект не найден>
страшного в этом нет
Есть! Как пример: обрезал базу. После обрезки есть документ "возврат от покупателя", который ссылался документом-основанием на уже удаленную расходную накладную. Подмену ссылок удаленных объектов ты не проводишь. В результате будешь иметь возратную партию по нулевой себестоимости = косяк в учете.
..
надо четко понимать, что делая "быстрые" обрезки базы - следует ясно представлять себе последствия таких обрезок в ОБЩИХ СЛУЧАЯХ. А не только в своем частном. Ты, судя по всему, последствия представляешь не совсем верно. Так что - выкладывая такие "универсальные" док - надо писать достаточно четко область применимости, возможные проблемы и прочее - чего в этом случае не сделано. Фраза "Наверное есть и недостатки" - таковым описанием не считается - это есть у всех программм.
По хорошему, конечно, надо вкатать минус именно за пункт
"в отчетах могут появиться надписи типа <объект не найден>
страшного в этом нет" - особенно если учесть что ПустоеЗначение(СсылканаДокКоторыйОбъектНенайден)=0 - что может привести к тяжелым поискам глюкавости алгоритмов...
22. ahmet 187 22.11.11 08:27 Сейчас в теме
имеющий руки да сотворит лучшее!
Вот вариант проц. для рукасто головастых - ну а остальные... могут купить подобное здесь есть что то продажное.

Этот код полностью устраняет ошибку битых ссылок, но он заточен под мою конфигурацию.

   //Расчитываем регистры
    СписокРег = СоздатьОбъект("СписокЗначений");
    СписокРег.ИзСтрокиСРазделителями(СокрЛП(РегистрОстатка));
    Если Проведен() = 0 Тогда
        ВремРег=СоздатьОбъект("Регистры");
        //Пробезаем по всем регистрам, которые отмечаны галочкой
        Для й=1 по СписокРег.РазмерСписка() Цикл
            РегОст = Строка(СокрЛП(СписокРег.ПолучитьЗначение(й,"")));     
            Рег=ВремРег.ПолучитьАтрибут(РегОст);
           // Рег=СоздатьОбъект("Регистр."+РегОст);
            Рег.Временныйрасчет(1);
            // РассчитатьРегистрыНа(ДатаДок);
            ВремРег.РассчитатьРегистрыНа(ТекущийДокумент());            
            //Присваеваем значений переменным
            РегистрПроведения = Метаданные.Регистр(РегОст);
            ГлавРег = Регистр.ПолучитьАтрибут(РегОст);
            КолИзмерений = РегистрПроведения.Измерение();
            КолРесурсов = РегистрПроведения.Ресурс();
            КолРеквизитов = РегистрПроведения.Реквизит();
            ТЗ = СоздатьОбъект("ТаблицаЗначений");
			Сообщить("регистр "+РегОст+" измерений "+КолИзмерений+" ресурсов "+КолРесурсов+" реквизитов "+КолРеквизитов);
            Рег.ВыгрузитьИтоги(ТЗ);
			КолСтрок = ТЗ.КоличествоСтрок();
           
			Если  КолСтрок = 0 Тогда
				Сообщить("регистр "+РегОст+" нет данных по движению - ПРОПУСКАЕМ..." );
				Продолжить;
			КонецЕсли; 
			// взаиморасчеты свернем чего копить
			Если РегОст="Взаиморасчеты" Тогда
				Сообщить(""+ТекущееВремя()+" свертка взаиморасчетов "+КолСтрок);
				ТЗ.Свернуть("Клиент,Фирма","Сумма");
				ТЗ.ВставитьКолонку("КредДокумент",3,"Документ");
				КолСтрок = ТЗ.КоличествоСтрок();
			КонецЕсли;
			Если РегОст="ТП" Тогда
				Сообщить(""+ТекущееВремя()+" свертка долгов ТП "+КолСтрок);
				ТЗ.Свернуть("ТП,Клиент","Сумма");
				ТЗ.ВставитьКолонку("КредДокумент",2,"Документ");
				КолСтрок = ТЗ.КоличествоСтрок();
			КонецЕсли;
			Если РегОст="ОстаткиТоваров" Тогда
				Сообщить(""+ТекущееВремя()+" ДО свертка остатков товаров "+КолСтрок);
				ТЗ.Свернуть("Товар,Склад,Фирма","Остаток,Сумма");
				//ТЗ.ВставитьКолонку("КредДокумент",2,"Документ");
				КолСтрок = ТЗ.КоличествоСтрок();
				Сообщить(""+ТекущееВремя()+" после свертка остатков товаров "+КолСтрок);
			КонецЕсли;
			Сообщить(""+ТекущееВремя()+" начинаем обработку регистра "+РегОст+" всего  строк "+КолСтрок);
			//
			Если ИдетТест=1 Тогда
				ТЗ.ВыбратьСтроку();
				Продолжить;
			КонецЕсли;
			
			//
          //  
            //Делаем движение по этим остаткам, тем самым делаем полную копиб регистров на данное число
            Для А=1 по ТЗ.КоличествоСтрок() Цикл
                Состояние("Обрабатывается "+Строка(А)+" из "+Строка(КолСтрок));
                Для А1=1 по КолИзмерений Цикл
                    Рег=РегистрПроведения.Измерение(А1);
					Значение = ТЗ.ПолучитьЗначение(А,А1);
					Если ТипЗначения(Значение)=12 Тогда
						// документ всё равно будет удален подменяем текущим
						Значение  = ТекущийДокумент();
					КонецЕсли;
					
                    ГлавРЕГ.УстановитьАтрибут(Рег.Идентификатор,ТЗ.ПолучитьЗначение(А,А1));
                КонецЦикла;   
                Для А2=1 по КолРесурсов Цикл
                    Рег=РегистрПроведения.Ресурс(А2);
                    ГлавРЕГ.УстановитьАтрибут(Рег.Идентификатор,ТЗ.ПолучитьЗначение(А,А2+КолИзмерений));
				КонецЦикла;
				
                ГлавРЕГ.ДвижениеПриходВыполнить();
            КонецЦикла;
		КонецЦикла;
		Сообщить(""+ТекущееВремя()+" завершено");
    Иначе
        Предупреждение("Данный документ нельзя перепровести !!!");
        СтатусВозврата(0);
    КонецЕсли;
Показать
2. Bobak 15.08.07 14:06 Сейчас в теме
Просто -1.
Это даже не плохо, это вредно. Образец того как не надо делать.
3. ahmet 187 15.08.07 14:39 Сейчас в теме
Интересно в чем это не образец!!.
4. lustin 15.08.07 14:51 Сейчас в теме
Мечта о том чтобы свернуть базу БЫСТРО рано или поздно посещает всех.
НО:
1. в релятивистских базах данных существует такое понятие как контроль ссылочной целостности.
2. появление надписи <объект не найден> - на самом деле страшно
3. чисто в прикладном смысле - в вашем случае 100% нарушится иерархия документов = например Счет в декабре - отгрузки в январе
4. как говорил один умный человек = "А Вы не подумали почему в 1С типовых сделано НЕ ТАК"
5. lustin 15.08.07 14:53 Сейчас в теме
в качестве примера:
1. советую посмотреть штатную свертку 1С Торговли
2. Разработку Вадимко http://infostart.ru/projects/1021/
6. lustin 15.08.07 14:54 Сейчас в теме
7. ahmet 187 15.08.07 14:57 Сейчас в теме
Вообщем судя по всему не обработка а ...
Тем не менее есть наверное живой интерес к проблеме и всегда существует возможность доработать. И если учесть мнения высказавшихся, то есть рациональное зерно. И если приложить усилия..
А давайте вместе доведем её до ума. А интересно узнать мнение по поводу, платной обрезки.
- И на посошок
Ну не у всех такие гигантские проблемы... Есть и те кому обработка поможет.
Всем спасибо!!!
8. Bobak 15.08.07 15:03 Сейчас в теме
>- в отчетах могут появиться надписи типа <объект не найден>
>страшного в этом нет
Страшное в этом есть :). За одну эту фразу надо -1.

Я думал документ сам удаляет все документы до свертки и порождает "надписи типа <объект не найден>". Ан нет, это предлагается сделать вручную.
Явная недоработка. Правда если убрать эту недоработку, то вся "Очеь быстр - обрабатывает 10 гиг. базу за 5 мин. " накрывается медным тазом.
А без этой обработки документ просто неработоспособен, потому как приводи просто к задвоению всех остатков и все.

>Интересно в чем это не образец!!.
Я разве сказал что это не образец?! Нет я сказал что это образец :).
Образец потому как очень неграмотно сделано.
Начиная с хранения списка регистров в виде строки в шапке документа. Кончая отсутствием процедуры удаления документов до момента свертки.
9. ahmet 187 15.08.07 15:16 Сейчас в теме
Так мне застрелиться или как...
10. lustin 15.08.07 15:18 Сейчас в теме
;-)
ну считай это публичной поркой
11. Bobak 15.08.07 15:21 Сейчас в теме
>Так мне застрелиться или как...
Ну зачем так круто :).
Просто убрать слово из описания:
>Универсален - конфигурация может быть любой (стандартной или самодельной).
>Очеь быстр - обрабатывает 10 гиг. базу за 5 мин.
>- в отчетах могут появиться надписи типа <объект не найден>
>страшного в этом нет

Собственно реакция на эти слова, а не на обработку. Сама обработка не заслуживает обсуждения :).
12. ahmet 187 15.08.07 16:11 Сейчас в теме
Ну и...
РосГосСтрах??????
Из песни слов не выкинуть. Добивайте до конца. Только по существу, желательно с уазанием строки дефекта и найденным решением...

НО согласны что обработка УНИВЕРСАЛЬНА А? +
А работает она - быстро??? +

Ну есть глюк, так мы его сообча и грохнем...
А потом ВАм всем памятник при жизни, а мне..? Мне бы день дожить, да ночь продержаться.
13. ahmet 187 15.08.07 16:13 Сейчас в теме
И потом в 10 гигаг удаление документов с проверкой целостности.. Кто пробовал откликнись
14. Bobak 15.08.07 16:22 Сейчас в теме
>Ну есть глюк, так мы его сообча и грохнем...
Глюк в самом подходе и плохом знании матчасти.
В общем РТФМ.

ЗЫ
Ну desty тебе же все разжевал и ссылки дал.
Ну може не совсем разжевал, но направление указал :).
Рой в сторону Яндекса, и скармливай ему все что написал desty.
15. ahmet 187 15.08.07 17:27 Сейчас в теме
Ну судя по комментариям хаять мастера, да и в Яндекс могут послать. А подсказать или помочь там...
для Страпот
А в подходе к решению никакого глюка нет. С матчастью тоже разберемся не боги горшки обжигают.
16. Вадимко 209 12.10.07 01:29 Сейчас в теме
Странно, у меня запрос в QA выполнялся полчаса на 10 Гигах
Это развот что ли?
"Все документы до этого необходимо удалить!!!" - а что делает выложенная свертка?
17. serguson 118 05.05.09 06:28 Сейчас в теме
Стандартная свертка предпринимателя думала над базой 6 гиг больше недели, после чего счастливо загнулась. Вашим документом свернулась за 4 часа.
Пусть не за 5 минут - все равно плюс.
18. maos 13.08.09 14:01 Сейчас в теме
Как раз то, что я искал
По поводу <объект не найден> - снова, как раз то что нужно
Мне необходимо было удалить всё-всё кроме остатков, другие обработки оставляют документы по ссылкам, а они мне тоже не нужны.
Большое спасибо!!!
19. Svetos 14.04.10 08:31 Сейчас в теме
А как ей установить? Я объединила конфигурацию, закинула компоненту DD в папку с базой, но теперь мой предприниматель стал называться сверткой 1.0 СКЛ и воще не запускается?
20. ahmet 187 14.04.10 10:15 Сейчас в теме
Думаю что Вам лучше пригласить специалиста!
21. yuraos 978 22.11.11 06:56 Сейчас в теме
Сhe Burashka пишет:
> в отчетах могут появиться надписи типа <объект не найден>
страшного в этом нет
Есть! Как пример: обрезал базу. После обрезки есть документ "возврат от покупателя", который ссылался документом-основанием на уже удаленную расходную накладную. Подмену ссылок удаленных объектов ты не проводишь. В результате будешь иметь возратную партию по нулевой себестоимости = косяк в учете.
..
надо четко понимать, что делая "быстрые" обрезки базы - следует ясно представлять себе последствия таких обрезок в ОБЩИХ СЛУЧАЯХ. А не только в своем частном. Ты, судя по всему, последствия представляешь не совсем верно. Так что - выкладывая такие "универсальные" док - надо писать достаточно четко область применимости, возможные проблемы и прочее - чего в этом случае не сделано. Фраза "Наверное есть и недостатки" - таковым описанием не считается - это есть у всех программм.
По хорошему, конечно, надо вкатать минус именно за пункт
"в отчетах могут появиться надписи типа <объект не найден>
страшного в этом нет" - особенно если учесть что ПустоеЗначение(СсылканаДокКоторыйОбъектНенайден)=0 - что может привести к тяжелым поискам глюкавости алгоритмов...

полностью согласен с Сhe Burashka!
<объект не найден> - это другими словами "битая ссылка"... и это не есть хорошо.
Это есть скорее плохо.
Для этого в конфигураторе есть тестирование-исправлении! :)))))
23. victuan 3970 30.11.11 06:50 Сейчас в теме
(0) Ты уж определись 10 Гиг у тебя сворачиваются за 5 мин или за 15 мин? Такую противоречивую информацию ты даешь в кратком и полном описании своей обработки.

(7) "А давайте вместе доведем её до ума". А с чего ты решил, что она достойна доведения до ума? Зачем это делать вообще, если есть аналогичные достойные обработки, "доведенные до ума"?
24. nkvg_a 13.12.11 19:42 Сейчас в теме
Спасибо. Мне помогла ваша обработка. Подработал и свернул комплексную.
25. vas5780 41 19.04.12 07:58 Сейчас в теме
Попробую ей потренироваться на Аспект-Ювелир
26. vas5780 41 10.05.12 11:53 Сейчас в теме
Оставьте свое сообщение

См. также

Rocket Launcher 7.7. Свертка базы 1С 7.7. Перенос справочников и документов 7.7 Промо

Свертка базы 1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

С помощью данной конфигурации возможен перенос остатков по бухгалтерским счетам и регистрам на заданную дату - «Дату свертки», вместе с документами, которые участвуют в остатках, а также всех документов и справочников после «Даты свертки». Реализован движок рекурсивного переноса данных, когда достаточно указать документ, который Вы хотите перенести, и все связанные объекты (элементы справочников, со значениями всех реквизитов, подчиненных элементов, история периодических реквизитов, документ - основание и др.) будет перенесены так же. Это даст Вам возможность создать копию существующей базы данных, но только с актуальными документами и справочниками.

24.01.2006    59701    20857    support    144    

Документ Сведения о среднем заработке

Обработка документов Свертка базы Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия Бесплатно (free)

Конфигурация для объединения с Зик, содержащая документ "Сведения о среднем заработке" для ввода начислений

13.08.2009    11627    158    Ctrl P    16    

Обработка сворачивания счетов на "00" счет.

Свертка базы v7.7 1cv7.md Беларусь БУ Бесплатно (free)

Обработка сворачивания счетов на "00" счет.

19.07.2009    7893    74    voshod    3    

Свертка 1С Зарплата 7.7

Зарплата Свертка базы Чистка базы Обработка справочников Зарплата v77::Расчет 1С7:ЗиК Бесплатно (free)

Обработка позволяет свернуть (очистить базу) от "ненужных" сотрудников.

16.01.2009    21044    1219    Омский Домовой    9    

Универсальная свертка + корректировка регистров SQL 1.0

Свертка базы v77::ОУ 1С7:ТиС Россия Бесплатно (free)

1. "Рыба" свертки с выборочным удалением документов 2. Самостоятельный документ корректировки регистров

04.07.2008    15639    769    Вадимко    21    

Перенос остатков ТМЦ из одной базы в другую

Свертка базы Учет ТМЦ Учет ТМЦ v77::ОУ 1С7:ТиС Бесплатно (free)

Наверное самый простой и быстрый способ перенести остатки из одной базы в другую (идентичную). Написал за 20 минуток, так что строго не судите :)

27.10.2007    14406    1500    nosferatu20913    10    

Быстрая пометка на удаление документов для Свертки (используется 1С++)

Свертка базы Чистка базы v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Бесплатно (free)

Методика быстрого удаления большого количества документов (для dbf-версии, компоненты: оперативный учет, бухучет). (используется 1С++)

17.09.2007    24654    2337    mihenius    14    

Подготовка для свертки ТиС 9.2x (Чистка Документов+Отчет)

Свертка базы v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Отчет + Обработка для подготовки базы ТиС 9.2x к "нештатной" свертке. Отчет предназначен для формирования списка документов, основание которых попадает в закрываемый период. Обрабатываются ВозвратыПоПокупателям - убирает ДокОснование и проставляет сведения партий, ВозвратыПоставщику - убирает ДокОснование и проставляет № и Дату входящей c/ф. У остальных документов убирается ДокОснование.

15.09.2007    12398    872    mihenius    12    

Сворачивание бух. итогов

Свертка базы v77::БУ 1С7:Бух Россия Бесплатно (free)

Обработка позоволяет: 1. Занулить итоги на конкретную дату 2. Сформировать начальные итоги на дату и очистить базу до этой даты.

10.07.2007    12092    1082    sashulyT    7    

Универсальная свертка + корректировка регистров 1.1

Свертка базы v77::ОУ 1С7:ТиС Россия Бесплатно (free)

1. "Рыба" свертки с выборочным удалением документов 2. Самостоятельный документ корректировки регистров

09.06.2007    20677    2389    Вадимко    15    

Обработка "Свертка остатков ТиС 9.хх"

Свертка базы v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Обработка предназначена для облегчения рутинной работы по свертке базы 1С. В сворачиваемой базе указанной обработкой формирует документы ввода остатков, например на 1 января, далее переносим полученные документы в подготовленную чистую базу стандартной обработкой 1С, проводим - получаем чистую базу с остатками на 1 января.

16.04.2006    23340    3049    mdzen    27