Анализ продаж и возвратов по контрагенту

Отчеты - Управленческие

13
Анализ документов  РасходнаяНакладная и ВозвратнаяНакладная и вывод отсортированных результатов в разрезе товаров (вниз) и дат операций (вправо). Используется запрос-перебор документов (без регистров).
Таблица имеет такой вид:
1-я часть - товар, единица;
2-я часть - расход товара с детализацией по датам (общий столбик);
3-я часть - возврат товара с детализацией по датам (общий столбик);
4-я часть - количественный итог по расходу и возвратам.
Цены берутся из документов.
13

Скачать файлы

Наименование Файл Версия Размер
-
.1221731213 8,48Kb
25.09.09
535
.1221731213 8,48Kb 535 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. v.l. 18.09.08 18:15 Сейчас в теме
Обновил печатную орму - сузил колонку цены, между колонками дат и группами нарисовал двойную линию.
2. sirius77 18.09.08 18:39 Сейчас в теме
Почему при открытии выдаёт ошибку?

ПечЦена = глФорматВОтчете<<?>>(тзОтчет.ПолучитьЗначение(ъъ,ъ+1));
{F:\ПЕЧ ФОРМЫ ДЛЯ 1С\АНАЛИЗ ПРОДАЖ И ВОЗВРАТОВ ПО КОНТРАГЕНТУ\АНАЛИЗ ЗАЯВОК.ERT(192)}: Функция не обнаружена (глФорматВОтчете)
3. v.l. 18.09.08 19:39 Сейчас в теме
Извиняюсь - исправил. ОБычно я глобальные процедуры дублирую во внешних отчетах как локальные, а тут пропустил.
Обработку обновил.
Добавьте в модуль строки:
Код
Функция глФорматВОтчете(чЗн,флКво=0,тКвоЗнаков="3") Экспорт
   Возврат(СокрЛП(?((чЗн=0) или (ПустоеЗначение(чЗн)=1),"",Формат(чЗн,"Ч19."+?(флКво=0,"2",тКвоЗнаков)+", "))));
КонецФункции
Показать полностью
4. v.l. 18.09.08 19:40 Сейчас в теме
Поспешил...
Код
КонецФункции
Показать полностью

и слово
Код
Экспорт
Показать полностью
тоже лишнее...
5. v.l. 18.09.08 19:42 Сейчас в теме
странно, тэги кода сожрали текст...
Добавить КонецФункции и убрать слово Экспорт
6. v.l. 19.09.08 09:10 Сейчас в теме
Обновил картинку - поставил более наглядную.
7. tele7 19.09.08 12:42 Сейчас в теме
А у меня пишет:
Если ВыбКонПериода > ПолучитьДатутА() Тогда
C:\АНАЛИЗ ЗАЯВОК.ERT(27)}: Метод ПолучитьДатуТА не может быть доступен так как компонента Оперативный учет не загружена!
что не так?...
8. v.l. 19.09.08 13:21 Сейчас в теме
Изначально отчет писал с использованием регистров, потому осталось условие проверки периода.

Если ВыбКонПериода > ПолучитьДатутА() Тогда
ВыбКонПериода=ПолучитьДатутА()
КонецЕсли; //ВыбКонПериода > ПолучитьДатутА()

Закоментируйте эти строчки - они в процедуре Сформировать сразу за определением переменной.
Исправленную версию залил.
9. experteins 19.09.08 23:58 Сейчас в теме
Трохи подгонял под свою конфигкрацию. Теперь нормально.
11. v.l. 22.09.08 10:46 Сейчас в теме
(9) и (10) - для того код и открытый
10. user72 20.09.08 00:02 Сейчас в теме
12. slavawww 25.09.08 11:19 Сейчас в теме
Хорошая штука, а для бухгалтерии нету?
13. v.l. 25.09.08 11:46 Сейчас в теме
Можно сделать - только вместо регистра обращаться к бухгалтерским счетам, нга которых хранятся остатки. Увы, я бухгалтерскую компоненту не знаю. Может, чего в учебниках найду - сделаю, или кто поможет?
Оставьте свое сообщение