Элемент управления "Дерево" штатными средствами платформы 1С:Предприятие 7.7

Публикация № 16900

Разработка - Практика программирования

В практике программиста часто возникают задачи, требующие специфической формы представления информации конечному пользователю. В качестве основных требований можно выделить следующие:
1. Информативность.
2. Наглядность.
3. Эргономичность.

Эти и многие другие задачи легко решить, представив некую информацию в структурированном древовидном виде.

Тому, как средствами платформы 1С:Предприятие 7.7 обеспечить такую возможность и посвящена данная статья.
Итак, приступим...

Для того, чтобы пользователь "увидел" дерево и смог управлять им необходимо решить следующие задачи:

1. Определить структуру хранения дерева в оперативной памяти.
2. Обеспечить механизм программного формирования дерева.
3. Реализовать алгоритм визуализации дерева.
4. Предоставить пользователю возмодность управлять деревом.

Начнем по порядку.

Структура хранения дерева в оперативной памяти и его программное формирование.

Вообще, дерево это структурированная совокупность узлов, взаимосвязанных друг с другом. Узел может быть корневым (не имеет родителя), промежуточным (подчинен другому узлу и является родителем для других), листовым (не имеет подчиненных узлов). Таким образом, структура дерева носит иерархический характер.

Задачу хранения дерева предлагается решить с помощью хорошо известного объекта платформы СписокЗначений.

Узел - это элемент списка значений, обладающий следующими атрибутами:
1. Идентификатор. Предназначен для именованного доступа к данным узла.
2. Представление. Видимое пользователю строковое представление узла.
3. Значение. Любое значение, хранимое в узле.
4. Знак. Определяет развернута или свернута ветка, определяемая данным узлом.
5. СписокУзлов. Список подчиненных узлов.
6. Родитель. Родительский узел.

Таким образом можно определить следующую функцию позволяющую максимально упростить процесс программного формирования дерева.

Функция ДобавитьУзел(Родитель,Идентификатор,Представление,Значение,Знак = "")
	Узел = СоздатьОбъект("СписокЗначений");
	
	Узел.ДобавитьЗначение(Родитель,"Родитель");
	Узел.ДобавитьЗначение(Идентификатор,"Идентификатор");
	Узел.ДобавитьЗначение(Представление,"Представление");
	Узел.ДобавитьЗначение(Значение,"Значение");
	Узел.ДобавитьЗначение(Знак,"Знак");
	
	Узел.ДобавитьЗначение(СоздатьОбъект("СписокЗначений"),"СписокУзлов");
	
	Если ПустоеЗначение(Родитель) = 0 Тогда
		СписокУзловРодителя = Родитель.Получить("СписокУзлов");
		СписокУзловРодителя.ДобавитьЗначение(Узел,Идентификатор);
		
	КонецЕсли;
		
	Возврат Узел;
КонецФункции


Функция возвращает вновь созданный узел.

Визуализация дерева.

Наибольшими изобразительными способностями среди доступных на платформе 1С:Предприятие 7.7 обладает объект Таблица. Вот с помощью данного объекта и будем визуализировать Наше дерево.

Приведем текст процедур визуализации дерева.

//Рекурсивная процедура визуализации дерева
Процедура ВывестиДерево(Знач Дерево, Уровень)
	Если Уровень > 0 Тогда
		Таблица.ВывестиСекцию("Пустая|Знак");
		
		Для СчУровней = 1 По Уровень - 1 Цикл
			Таблица.ПрисоединитьСекцию("Пустая|Знак");
		КонецЦикла;
	КонецЕсли;
	
	СписокУзлов = Дерево.Получить("СписокУзлов");
	КолУзлов = СписокУзлов.РазмерСписка();
	
	ID_Узла = ID_Узла + 1;
	СписокID.ДобавитьЗначение(Дерево,Строка(ID_Узла));
	
	ПредставлениеУзла = Дерево.Получить("Представление");
	
	Знак = Дерево.Получить("Знак");
	
	Если ПустоеЗначение(Знак) = 0 Тогда
		Если Уровень = 0 Тогда
			Таблица.ВывестиСекцию("Элемент|Знак");
		Иначе
			Таблица.ПрисоединитьСекцию("Элемент|Знак");
		КонецЕсли;
	Иначе
		Таблица.ПрисоединитьСекцию("Пустая|Знак");
	КонецЕсли;
	
	Таблица.ПрисоединитьСекцию("Элемент|Представление");
	
	Если Знак = "-" Тогда
		
		Уровень = Уровень + 1;
		
		Для Сч = 1 По КолУзлов Цикл
			Дерево = СписокУзлов.ПолучитьЗначение(Сч);
			ВывестиДерево(Дерево,Уровень);
		КонецЦикла;
		
		Уровень = Уровень - 1;
	КонецЕсли;
КонецПроцедуры

Процедура СформироватьТаблицу(Номер)
	Таблица.Очистить();
	
	СписокID.УдалитьВсе();
	ID_Узла = 0;
			
	ВывестиДерево(Дерево,0);
		
	Таблица.Показать();
КонецПроцедуры


Стоит особо отметить переменные СписокID и ID_Узла. Эти переменные должны быть глобальными по отношению к модулю обработки.

СписокID - список уникальных сквозных номеров узлов для данного состояния дерева, то есть для данной комбинации свернутых и развернутых узлов. Список номеров очищается и заполняется каждый раз при вызуализации дерева.

ID_Узла используется в качестве расшифровки ячейки, содержащей представление данного узла. Данный прием был избран потому, что использовать в качестве расшифровки непосредственно ссылку на узел невозможно - это приводит к ошибке.

ID_Узла используется для доступа к данным узла в процедуре управления деревом.

Управление деревом.

Процедура ПолучитьКомпонентыАдресаЯчейки(Адрес, НомерСтроки, НомерКолонки)
	НомерСтроки  = Число(Сред(Адрес, Найти(Адрес, "R") + 1));
	НомерКолонки = Число(Сред(Адрес, Найти(Адрес, "C") + 1));
КонецПроцедуры

Процедура ОбработкаЯчейкиТаблицы(Значение,ФлагСтандОбраб,Таблица,Адрес)
      НомерСтроки = 0;
	НомерКолонки = 0;
	ПолучитьКомпонентыАдресаЯчейки(Адрес, НомерСтроки, НомерКолонки); 
	
	Если (Значение = "+") ИЛИ (Значение = "-") Тогда
		ID = Строка(Таблица.Область(НомерСтроки,НомерКолонки + 2).Расшифровка());
		Узел = СписокID.Получить(ID);
		
		
		НовыйЗнак = ?(Значение = "+", "-","+");
			
		Узел.Установить("Знак",НовыйЗнак);
			
		СформироватьТаблицу(Дерево);
	КонецЕсли;		
КонецПроцедуры


Следует отметить, что переменная Дерево является глобальной в контексте данной обработки и представляет собой список значений, являющийся корневым узлом дерева.

В качестве примера можно посмотреть мою разработку
//infostart.ru/profile/1999/projects/442

Пользуйтесь...

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. OlegTor 166 04.09.06 17:38 Сейчас в теме
Смотрим, комментируем, высказываем пожелания и рейтинг плюсуем.
3. OlegTor 166 05.09.06 09:53 Сейчас в теме
2 Maniac.
Согласен, красивее - это звучит объективно. Но вот насчет простоты - дело субъективное. Каждый сам решает, что ему проще, а что нет. Не любой программист будет связываться с внешними компонентами. Особенно это относится к тем, кто кроме 1С никаким инструментом не владеет.
4. CheBurator 05.09.06 12:15 Сейчас в теме
Было бы замечательно, если бы автор выложил в качестве примера не свою обработку, а вариант типовой обработки в ТиС "Дерево документов" (структура подчиненности).
ЗЫ: Удалось ли решить проблему отрисовки таблицы не всей при свертке/развертке, а "сдвигом" секций?
5. OlegTor 166 05.09.06 12:37 Сейчас в теме
На "Дерево документов" пока нет времени.
По той же причине решением проблемы оптимизации визуализации дерева пока не занимался.
6. АЛьФ 05.09.06 15:28 Сейчас в теме
Пара скриншотов не помешала бы...
7. CheBurator 05.09.06 19:41 Сейчас в теме
Альф, а можно как-то считать область таблицы и вывести ее допустим на 5 строк ниже и на 2 столбца левее не поячеечно, а типа "куском"? было бы ок... допустим кликаем на роазворот узла - перед выводом всегда можно постиать сколько строк займет - всеь вывод от этого узла все что ниже сдвигаем на это кол-во строк а в свободное место выводим данные узла... типа так....
или не стоит заморачиваться?
8. CheBurator 05.09.06 19:42 Сейчас в теме
Да, +1 обработку смотрел, понравилось...
Надо xltkfnm чтоб узлы были с разворотом по горизонтали и вертикали - типа как у "новейшего отчета"
9. 06.09.06 03:39 Сейчас в теме
Для меня более привлекательным оказалось использование ТаблицыЗначений вместо списка. Отлично смотрится на форме и более производительно.

2Maniac: Избавте меня от таскания всяких-там компонент по машинам пользователей.
Мне понравилась чья-то фраза: "Ограниченноясть языка 1С - в ограниченности разроботчика".
11. orefkov 1012 07.09.06 14:11 Сейчас в теме
> Избавте меня от таскания всяких-там компонент по машинам пользователей.
КаталогИБ не напрягает таскать?
12. CheBurator 07.09.06 16:50 Сейчас в теме
13. karat60 07.09.06 19:57 Сейчас в теме
+1, на первый взгляд весьма привлекательно - дальше покажет жизнь
14. Natalia 01.05.09 22:38 Сейчас в теме
Спасибо за идею и красивую реализацию.
Пару раз уже успела позаимствовать в разных разработках.
Например, полуфабрикатное производство.
Конструкторы сначала "пищали от восторга" - потому что красиво,
а потом "схватились за головы" - потому что наглядно увидели свои недочеты ))
15. AS108 19.07.09 02:57 Сейчас в теме
Спасибо за ваши труды! Успехов!
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    73318    0    Serginio    108    

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Бухгалтерский учет Практика программирования Зарплата v7.7 1cv7.md Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    6714    0    Юджин58    35    

Маркировка лекарств - как передать код маркировки при продаже через ККТ Штрих-М

Практика программирования ККМ v7.7 Здравоохранение, медицина, стоматология Фармацевтика, аптеки Россия Бесплатно (free)

Пример программного кода для вывода чеков на ККМ Штрих-М с передачей информации о маркированных товарах (лекарства).

10.02.2020    4463    0    vovaapril    7    

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Практика программирования Адаптация типовых решений v7.7 1С7:Комплекс 1С7:ТиС УУ Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    4292    0    ksnik    14    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция Промо

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    54596    0    Serginio    33    

Заполнение реквизитов документов из предыдущего документа

Практика программирования Универсальные функции Разработка v7.7 1cv7.md Бесплатно (free)

Функция для автоматического заполнения реквизитов документов.

04.02.2019    4926    0    drevilo    1    

Проверка часового пояса

Практика программирования v7.7 Бесплатно (free)

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

16.05.2016    10683    0    kudenzov    3    

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом?

Практика программирования v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    18605    0    CheBurator    18    

1С:Предприятие 7.7. Оптимизация. Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Разгоняем 1С:Предприятие 7.7. Выжимаем последние соки.

31.01.2009    45905    0    alexk-is    110    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    30814    0    Serginio    22    

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7

Внешние источники данных Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Россия Бесплатно (free)

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    24311    0    Palmer1976    3    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    17061    0    etmarket    14    

Как уменьшить количество заблокированных объектов Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    15286    0    ShEvOvIcH    18    

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7

Практика программирования Универсальные функции v7.7 1cv7.md Бесплатно (free)

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    16995    0    Anzhey    13    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    18821    0    json    1    

Числа прописью в родительном падеже в 7.7? Легко!

Практика программирования v7.7 1cv7.md Бесплатно (free)

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    12453    0    gimalaj    3    

Технология обновления нетиповых конфигураций 1С:Предприятия 7.7 Промо

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Данная статья рассчитана на уже подготовленного пользователя, владеющего некоторыми навыками программирования и работы в конфигураторе. Статью можно использовать как поэтапное руководство к действию. Статья была написана для повышения качества работ выполняемых сотрудниками компании Информ Сервис при обновлении нетиповых конфигураций. Я надеюсь, что эта информация окажется полезной и для вас.

12.12.2008    62151    0    alexk-is    25    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    86031    0    shmellevich    38    

Отправка сообщения посредством почтового клиента Lotus Notes

Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Отправка сообщения посредством почтового клиента Lotus Notes из 1С 7,7 и 1с 8

21.08.2014    14402    0    iolko    8    

Исправление в типовой комплексной конфигурации глобальной функции глВсеРеквизитыДокументаЗаполнены()

Практика программирования v7.7 1С7:Комплекс Россия Бесплатно (free)

В типовых конфигурациях глобальная функция глВсеРеквизитыДокументаЗаполнены() не работает с реквизитами табличной части. Данная статья содержит текст исправленной функции, корректно проверяющей табличную часть.

20.08.2014    8002    0    hvv2002    0    

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7

Практика программирования v7.7 1cv7.md Бесплатно (free)

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    21712    0    tomvlad    5    

Контекстный поиск в 7.7

Инструментарий разработчика Практика программирования v7.7 1cv7.md Бесплатно (free)

Процедура контекстного поиска в журнале документов.

18.04.2014    9032    0    cushe    2    

Проверка ИНН v.7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Проверка ИНН v.7.7

08.03.2014    9459    0    kras_71    1    

Полезные функции. Склонение (должность и фамилия подписантов). Любой язык

Практика программирования v7.7 v8 Бесплатно (free)

Уехал директор в командировку, отпуск... , оставил доверенность на хозяйственные операции на другого сотрудника. Все договора и другие документы в обмороке - "подписант" теперь другой, по тексту тоже много правок... Пересмотрел много публикаций, вариантов много, не приглянулось. Сделал свой "Баян" . У меня всего-то крутится пять фигурантов ... Нет простого, наглядного и всепогодного варианта без языкового барьера. Всем процессом управляет пользователь.

03.03.2014    17637    0    kompas-dm    5    

Реализация Ctrl+Z в 1С 7.7 (ТиС)

Практика программирования v7.7 1С7:ТиС Бесплатно (free)

В семерке отсутствует возможность отменять последнее действие в формах документов. В данной статье будет рассмотрен пример реализации данной функции. Возможно, кому-нибудь пригодится.

15.07.2013    7827    0    a.o.popova    10    

Копия напечатанного документа или как спрятать документ.

Журнал регистрации Практика программирования v7.7 Бесплатно (free)

Возникла необходимость, чтобы при печати определённого документа (даже потом не сохранённого), создавалась его копия, т.е. запись всех напечатанных документов. (В результате чего возникла такая потребность, полагаюсь на вашу фантазию). В итоге получилось два варианта решения, остановился на втором.

11.04.2013    15357    0    Dima_    8    

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

Практика программирования Внешние источники данных v7.7 Бесплатно (free)

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

04.04.2013    18882    0    ivisor_fil    11    

Автосохранение документа в 1С 7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

В данной статье мы рассмотрим автосохранение документа в 1С 7.7!

22.03.2013    13207    0    aagubarev    25    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    24983    0    serg_gres    6    

Устранение проблемы при работе с полем, которое ограничено маской ввода

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для поля, у которого установлена маска ввода, перед программной инициализацией необходимо начальное значение преобразовать к значению в соответствии с маской, иначе буду потеряны символы в местах разделителях. В данной публикации приведена функция, которая универсально выполняет данное действие.

08.08.2012    16213    0    www2000    4    

Динамическая фильтрация в справочнике при вводе наименования

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    16014    0    maxpiter    62    

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    18300    0    Valerich    31    

v77. Робот

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Исполнитель Робот. Учебное пособие по программированию для детей дошкольного возраста. Без внешних компонент.

09.04.2012    12144    3    item    18    

Запуск внешней обработки по расписанию v7.7

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    43525    0    Yury1001    17    

v77. Закладки в многоуровневом справочнике аля Total Commander

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

В больших многоуровневых справочниках можно ускорить доступ пользователю к наиболее популярным группам.

09.03.2012    10770    1    item    17    

v77. Паинт

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

v77. 1С:Паинт :) Такая вот игрушка. Без внешних компонент.

06.03.2012    14358    1    item    38    

v77. Как ИспользоватьСубконто

Практика программирования Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v7.7 1cv7.md Россия БУ Бесплатно (free)

Как ИспользоватьСубконто или почему операция - "любимый" инструмент бухгалтера.

05.03.2012    12022    0    item    3    

v77. Календарь на форме.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

v77. Календарь на форме. В помощь разработчику.

05.03.2012    10914    1    item    17    

v77. Таблица символов.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

v77. Таблица символов. В помощь разработчику.

05.03.2012    15506    2    item    10    

Регистрация текста окна сообщений

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для контроля работы пользователей потребовалось записывать текст окна сообщений в файл. Получился простейший механизм регистрации лог-файла. Удержать роста папки "Temp", в качестве рекомендации, может использование bat-файла, который будет чистить или архивировать получаемые логи. Таких батников в инете полным-полно. P.S. Особо по форуму не смотрел, может, есть уже такое.

28.11.2011    7720    0    sdin101    9    

7.7.: Готовим md-файл для публикации. В картинках.

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    17189    0    Арчибальд    21