Быстро пишем форму для ТСД для «неуправляемого» интерфейса.

Публикация № 174743

Разработка - Работа с интерфейсом

39
В этой статье автор делится опытом как быстро и просто написать или изменить формы, размер которых сам подстроится под терминал сбора данных (ТСД).

Часто бывает необходимо организовать работу через терминал сбора данных (ТСД). Нередко бывает так, что организация использует терминалы с различными разрешениями экрана. Делать различные формы под каждое разрешение, конечно не сложно, но это можно не делать, если форму сделать такой, чтобы она сама подстраивалась под любое разрешение. При этом должен подстраиваться и шрифт на элементах формы.

Для начала сделаем форму под самый малый размер ТСД, а именно 235х310. Он должен быть чуть меньше реального (240 х 320) , чтобы  точно избежать дополнительных элементов прокрутки. Дело в том, что ими пользоваться в ТСД очень неудобно, т.к. нельзя прикрутить клавиши ТСД.

 

Затем на форму поместим таблицу, клавиши, поле для ввода. Способ отображения окна сделаем «Максимизированное» и поставим галку на Режим рабочего стола, чтобы окно открывалось во весь экран ТСД.

На форму добавим  4 кнопки «Вверх», «Вниз», «Ввод» и «Закрыть». К кнопкам формы «Вверх», «Вниз» (которые у нас будут перемещать выделенную строку в таблице) мы привяжем соответствующие клавиши ТСД, к кнопке «Закрыть» привяжем клавишу «ECS», а к кнопке «Ввод» - «ENTER».

Теперь о привязке кнопок. Воспользуемся нестандартным способом привязки горячих клавиш, поскольку, стандартным нельзя привязать Enter и многие другие.

Функция ВернутьСочетаниеКлавиш(Знач КодКлавиши, Alt=Ложь, Ctrl =Ложь, Shift=Ложь) Экспорт

    Если ТипЗнч(КодКлавиши)=Тип("Строка") Тогда

             КодыКлавиш =Новый Соответствие();

             КодыКлавиш.Вставить("ESC",27);

             КодыКлавиш.Вставить("TAB",9);

        КодыКлавиш.Вставить("BACKSPACE",8);

             КодыКлавиш.Вставить("ENTER",13);

             КодыКлавиш.Вставить("SHIFT",16);

             КодыКлавиш.Вставить("CTRL",17);

             КодыКлавиш.Вставить("ALT",18);

             КодыКлавиш.Вставить("CAPSLOCK",20);

        КодыКлавиш.Вставить("SPACE",20);

        КодыКлавиш.Вставить("END",35);

             КодыКлавиш.Вставить("HOME",36);

        КодыКлавиш.Вставить("LEFT",37);

             КодыКлавиш.Вставить("UP",38);

        КодыКлавиш.Вставить("RIGHT",39);

        КодыКлавиш.Вставить("DOWN",40);

        КодыКлавиш.Вставить("INS",45);

        КодыКлавиш.Вставить("DEL",46);

             КодыКлавиш.Вставить("F1",112);

             КодыКлавиш.Вставить("F2",113);

             КодыКлавиш.Вставить("F3",114);

             КодыКлавиш.Вставить("F4",115);

             КодыКлавиш.Вставить("F5",116);

             КодыКлавиш.Вставить("F6",117);

             КодыКлавиш.Вставить("F7",118);

             КодыКлавиш.Вставить("F8",119);

             КодыКлавиш.Вставить("F9",120);

             КодыКлавиш.Вставить("F10",121);

             КодыКлавиш.Вставить("F11",122);

             КодыКлавиш.Вставить("F12",123);

             текКод = КодыКлавиш.Получить(ВРЕГ(КодКлавиши));

             Если текКод=Неопределено Тогда

                    Возврат Неопределено;

             Иначе 

                 КодКлавиши = текКод;

             КонецЕсли;

       КонецЕсли;

      

      

    Модификатор = 0;

       Если Alt Тогда

             Модификатор = Модификатор + 16;

       ИначеЕсли Ctrl Тогда

             Модификатор = Модификатор + 8;

       ИначеЕсли Shift Тогда

             Модификатор = Модификатор + 4;

       КонецЕсли;

 

    стрВнутр = "{""#"",69cf4251-8759-11d5-bf7e-0050bae2bc79,1," + Символы.ПС + "{0," + КодКлавиши + "," + Модификатор + "}" + Символы.ПС + "}";

    Возврат ЗначениеИзСтрокиВнутр(стрВнутр);

КонецФункции

 

После того как мы привяжем основные клавиши, мы сможем сэкономить место на ТСД, если уберем основные под таблицу, поместив ее на передний план.

 

 

 

Теперь сделаем привязки элементов формы так, чтобы они масштабировались.

    

 

 

Когда возникает событие формы «ПередОткрытием», форма еще имеет исходные размеры. Мы запомним эти размеры. Потом уже после открытия формы и изменения ее под размер экрана мы отмасштабируем шрифты (а элементы формы изменят размер сами в соответствии с настройками привязок) следующей процедурой, в которой увеличим шрифт либо в соответствии с новыми размерами формы, либо подстроив его под размер поля ввода по формуле, что 1 пункт размера шрифта это ¾ пиксела:

 

Процедура ПриИзмененииРазмеровФормы(Форма,сткИсходныеРазмеры=0) Экспорт

       Если сткИсходныеРазмеры=0 Тогда

             сткИсходныеРазмеры = Новый Структура("Ширина,Высота",240,320);

       КонецЕсли;

 

       КоэфУвеличения =  Окр(Форма.Высота/сткИсходныеРазмеры.Высота,0);

      

       Для каждого Элемент Из Форма.ЭлементыФормы Цикл

             Если ТипЗнч(Элемент) = Тип("ПолеВвода") Тогда

                    текШрифт =  Элемент.Шрифт;

                    текРазмер =  (Элемент.Высота-2)*3/4;

                    Элемент.Шрифт = Новый Шрифт(текШрифт,,текРазмер);

             ИначеЕсли ТипЗнч(Элемент) = Тип("ТабличноеПоле") Тогда

                    текШрифт =  Элемент.Шрифт;

                    текРазмер =  текШрифт.Размер*КоэфУвеличения;

                    Элемент.Шрифт = Новый Шрифт(текШрифт,,текРазмер);

                    Элемент.ШрифтШапки =  Новый Шрифт(текШрифт,,текРазмер);

                   

                    КоэфШирины =  Форма.Ширина/сткИсходныеРазмеры.Ширина;

                    Для Каждого текКолонка Из  Элемент.Колонки Цикл

                           Если текКолонка.Видимость Тогда

                                  текКолонка.Ширина = текКолонка.Ширина*КоэфШирины;

                           КонецЕсли;

                    КонецЦикла;

 

             Иначе

                    Попытка

                           текШрифт =  Элемент.Шрифт;

                    Исключение

                        Продолжить;

                    КонецПопытки;

              текШрифт =  Элемент.Шрифт;

                    текРазмер =  текШрифт.Размер*КоэфУвеличения;

                    Элемент.Шрифт = Новый Шрифт(текШрифт,,текРазмер);

                    Если ТипЗнч(Элемент) = Тип("Кнопка") Тогда

                           Если Элемент.Имя = "КнопкаЗакрыть" Тогда

                                  Элемент.СочетаниеКлавиш =ВернутьСочетаниеКлавиш("ESC");

                           ИначеЕсли Элемент.Имя = "КнопкаВверх" Тогда

                       Элемент.СочетаниеКлавиш =ВернутьСочетаниеКлавиш("UP");

                           ИначеЕсли Элемент.Имя = "КнопкаВниз" Тогда

                       Элемент.СочетаниеКлавиш =ВернутьСочетаниеКлавиш("DOWN");

                           ИначеЕсли Элемент.Имя = "КнопкаВвод" Тогда

                       Элемент.СочетаниеКлавиш =ВернутьСочетаниеКлавиш("ENTER");

                           КонецЕсли;

                    КонецЕсли;

             КонецЕсли;         

       КонецЦикла;

       Возврат;

КонецПроцедуры

 

 События «ПослеОткрытия» нет, но есть событие, которое срабатывает сразу же После открытия формы. Это  - «ОбновлениеОтображения». Мы этим событием для определения конечных размеров формы и  установления размеров шрифтов воспользуемся только раз и вызовем от-туда функцию, которая изменит размеры шрифтов.

 

В итоге получим модуль формы:

 

Перем сткИсходныеРазмеры;

Перем ФлФормаОткрыта;

 

Процедура ОбновлениеОтображения()

       Если НЕ ФлФормаОткрыта Тогда

             ПриИзмерениеРазмеровФормы(ЭтаФорма,сткИсходныеРазмеры);

             ФлФормаОткрыта = Истина;

       КонецЕсли;

КонецПроцедуры

 

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

       ФлФормаОткрыта = Ложь;

       сткИсходныеРазмеры  = Новый Структура("Ширина,Высота",ЭтаФорма.Ширина,ЭтаФорма.Высота);

КонецПроцедуры

 

Функции «ПриИзмененииРазмеровФормы» и «ВернутьСочетаниеКлавиш» мы поместим в глобальный модуль, чтобы их можно было вызвать из других форм.

 

 

39

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Magister 133 21.02.13 01:28 Сейчас в теме
Оригинальный способ назначения горячих клавиш!
Зачет :)
2. Angeros 21.02.13 04:39 Сейчас в теме
Я что-то вообще не понял что это за функция "ВернутьСочетаниеКлавиш"?! Кто ее вызывает? Откуда взялся уид в конце функции?
3. Angeros 21.02.13 04:45 Сейчас в теме
По(2)вник походу, но непонятно откуда вы такой метод выдумали?!
5. chekonst 39 21.02.13 10:15 Сейчас в теме
(3) Angeros,
Методу назначения горячих клавиш нашел уже давно, где то в дебрях интернета. Мне ее лишь пришлось немного доработать. А основная метода по ТСД родилась после того, как в очередной раз "достали" с изменением размеров ТСД. "Задолбало" каждый раз переписывать или перенастраивать.
6. SatanClaws 127 21.02.13 10:44 Сейчас в теме
4. YuraLu 21.02.13 06:53 Сейчас в теме
Я в реале сталкивался с такой проблемой. Сяду курить методу. Если получится, то прекрасно...
7. Angeros 21.02.13 10:44 Сейчас в теме
По моему настоящий програмерский пост. То что и нужно. +
8. dyak84 21.02.13 11:04 Сейчас в теме
Спасибо очень пригодилось
9. Mell 21.02.13 12:03 Сейчас в теме
Интересный пост, имеем много ТСД, но подключали их только стандатрными способами. Узнал много нового)
10. pablo_escobar 21.02.13 16:25 Сейчас в теме
Что то не пойму как использовать эти формы на ТСД? В режиме терминального доступа?
11. chekonst 39 21.02.13 16:31 Сейчас в теме
Да, именно в терминальном режиме
12. Milanick 22.02.13 10:14 Сейчас в теме
Ребята, кто работал с ТСД и штрих кодами, подскажите , с чего начать можно. Горю желанием попробовать сие чуда техники, но не знаю как подойти к этому
13. chekonst 39 22.02.13 10:23 Сейчас в теме
С покупки ТСД. Подключение к 1С через терминальное соединение. У ТСД разрешения обычно 240*320 или 480*640. В ТСД установлена программа для передачи штрих кода непосредственно в поле ввода, она позволяет передать код через терминальное соединение в приложение.
Можно для пробы взять также телефон с разрешением 240*320 или 480*640 и операционной системой windows for mobile ну или небольшой GPS навигатор с wifi с windows CE. Считывать он штрих коды, конечно не будет, но на нем можно отладить интерфейс.
14. Светлый ум 228 22.02.13 10:27 Сейчас в теме
Респект, то чего обычно не хватает под рукой.
15. Milanick 22.02.13 10:51 Сейчас в теме
chekonst
Есть список ТСД, которые нормально интегрятся с 1С, без бубнов?
18. expert.1c8 22.02.13 21:01 Сейчас в теме
(15) Да тоже интересен такой список для склада, например, дешевый сегмент,
личный опыт - это часто и есть та самая реклама..
16. chekonst 39 22.02.13 11:03 Сейчас в теме
Выпускают разные ТСД под разные задачи, под разные температурные и влажностные режимы: складские , почтовые и прочие. Список здесь в открытом доступе опубликовать не могу, т.к. это будет либо рекламой либо антирекламой.
17. tolyan_ekb 169 22.02.13 12:31 Сейчас в теме
Есть информация на сколько хватает зарядки ТСД в режиме терминального доступа? Есть ли другая технология, например, веб-клиент, которая выигрывает по энергозатратам?
19. opus70 68 05.05.13 18:08 Сейчас в теме
подскажите как назначить кнопкам клавиши
не понятно где использовать
ВернутьСочетаниеКлавиш(...
20. CheBurator 3400 24.12.14 04:27 Сейчас в теме
Незачет
Отсутствуют скрины-примеры получившейся формы
Меня как потребителя мало интересует код
В первую очередь интересует юзабельный интерфейс

Возможно из статьи почерпну полезное
Придется видимо переписывать интерфейс промышленной wms на восьмерке
Оставьте свое сообщение

См. также

Создание асинхронных виджетов 76

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    2006    YPermitin    15       

Формы. Трудности программной работы 71

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    3533    YPermitin    21       

Лайфхаки 1С (часть 1). Настройки отчетов и печатных форм 1С 34

Статья Программист Пользователь Стажер Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Статья рассчитана на пользователей или программистов, которые только начинают работать с 1С, для максимально быстрого ознакомления с интерфейсом программы. В статье приведены лайфхаки, которые позволят вам быстро и эффективно научиться настраивать отчёты и печатные в среде программных продуктов 1С. Полученные знания значительно упростят взаимодействие с интерфейсом 1С и повысят продуктивность работы оператора.

02.10.2019    4143    VachKirp    8       

Добавляем виджет "Задачи от меня" в Документооборот 2.1 22

Статья Программист Нет файла v8 v8::Бизнес-процессы ДО Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Небольшая доработка Документооборота 2.1 для возможности добавления виджета "Задачи от меня" в обработку Текущие дела.

25.09.2019    1592    Sergey_Borisovi4    2       

[Механизм интерфейса] Часы 54

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом Практика программирования Разработка

Добавляем цифровые часы на форму, как бонус рассмотрим вариант и с аналоговыми.

26.08.2019    3133    rpgshnik    33       

Произвольная начальная страница через расширение (программно) 41

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Установка своей формы произвольному пользователю на начальную страницу.

14.08.2019    2576    nagaitseff    11       

Подходы, методы и инструменты UX/UI для разработки эффективных интерфейсов на 1С 31

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Интерфейсам в 1С обычно уделяют мало внимания. Это в итоге снижает востребованность платформы, делает ее неконкурентной, лишает большой доли рынка. Как не потерять старых клиентов и привлекать новых с помощью интерфейсов, а главное – как сделать «правильный» интерфейс, рассказал участникам конференции Infostart Event 2018 Education управляющий партнер и основатель консалтинговой группы WiseAdvice Иван Тягунов.

07.08.2019    4559    IvanAT1981    14       

Пользовательские настройки системы компоновки данных 87

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Работа с отчетами в пользовательском режиме, формы отчетов. Понятие пользовательских настроек в отчетах на СКД. Определение состава пользовательских настроек для разделов в целом и для отдельных элементов, для всего отчета и для отдельных группировок. Видимость функциональных опций в отчетах на СКД.

09.07.2019    6443    ids79    0       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 212

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    14516    YPermitin    49       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 91

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    7476    Viktor_Ermakov    6       

Свой макет оформления отчета 33

Статья Программист Нет файла v8 v8::СКД Россия Windows Бесплатно (free) Работа с интерфейсом

Пример создания и оформления и применения своего (пользовательского ) макета оформления для СКД.

24.04.2019    4572    olegpkc    5       

Динамический вывод таблицы значений на форму 35

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вывести на форму таблицу значений, а потом на её место другую, третью, четвёртую? Не вопрос.

11.01.2019    5715    Vlad1917    26       

Прикладной пример переработки стандартной формы РМК - Розница 74

Статья Программист Нет файла v8 Розница УУ Кассовые операции Розничная торговля Бесплатно (free) Работа с интерфейсом

Простой пример, как с помощью программного изменения шрифтов элементов формы достичь наилучшего результата отображения на примере формы РМК.

04.10.2018    10871    asdfgcom    56       

Cправочная информация. Картинки. 16

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Справочную информацию мало кто любит писать, но вот захотелось. И что с этим делать?

06.06.2018    6422    aspirator23    2       

Итоги в динамическом списке 47

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Предлагаю вариант, как быстро сделать итоги в динамическом списке, например в форме списка журнала документов.

28.05.2018    9019    CXY    16       

Программное управление обычными формами документов и справочников в УПП/КА 32

Статья Программист Нет файла v8 v8::УФ КА1 УПП1 Россия Бесплатно (free) Работа с интерфейсом

Если с программным изменением управляемых форм 1С все более или менее понятно, то с программированием обычных форм примеров не так уж много в сети. А уж примеров готовых решений совсем не видно. В данной статье я покажу, как можно реализовать аналог "управляемых" форм в своих конфигурациях с обычными формами и забыть о сложностях обновлений форм.

09.05.2018    8447    dima_home    7       

Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением 26

Статья Программист Нет файла v8 v8::УФ Беларусь Windows Бесплатно (free) Работа с интерфейсом

Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

06.04.2018    9798    Drak87    18       

Красивые графики. Пошаговая инструкция (Highstock) 122

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Данный подход опробован на библиотеках: Нighcharts и Highstock. Для работы будет необходима 1С и браузер Google Chrome. Чукча не писатель (первая публикация).

22.11.2017    14236    Degrement    20       

Меняем стандартную форму выбора для реквизита формы на свою форму с запросом 51

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Алгоритм действий для смены стандартной формы выбора для реквизита формы на свою форму со своей выборкой данных и возвратом нескольких параметров в вызывающую форму

30.09.2017    15821    ah7777777    24       

"Мигаем" интерфейсом, или цепочки асинхронных вызовов 71

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом

Как, не блокируя интерфейс, привлечь внимание пользователя к интерфейсным элементам. Или, попросту говоря, "мигнуть" чем-то.

06.09.2017    12658    Chrizt    13       

"Восстановить положение окна" - не помогает. Как я решил проблему. 28

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Как получилось решить проблему глюков отображения формы документа.

28.05.2017    46807    niko11s    44       

Как добавить/убрать кота в отчет? 78

Статья Программист Нет файла v8 БП3.0 Бесплатно (free) Работа с интерфейсом

Кот в отчете: кому-то нравится, кого-то жутко бесит. Как избавиться, заменить, оставить (нужное подчеркнуть)?

12.05.2017    23143    starik-2005    16       

Итоги в динамическом списке 46

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Как быстро посчитать итоги в динамическом списке

03.04.2017    21013    Восьмой    34       

Исправление проблем со встраиванием внешних отчетов в УНФ 1.6 12

Статья Программист Нет файла v8 УНФ Россия Бесплатно (free) Работа с интерфейсом

В УНФ 1.6 (тестил на версии 1.6.7.43) существуют следующие проблемы: 1. при встраивании доп. отчета в базу, он не отображается, пока не собьешь фильтр подсистемы 2. при встраивании доп. отчета в базу, отсутствует команда «Дополнительные отчеты» (по аналогии с командной «Дополнительные обработки») . В статье описывается решение перечисленных проблем.

16.11.2016    11522    TheRealStanly    3       

Как "перемотать" динамический список в начало при открытии? (или некоторые нюансы получения данных динамического списка) 57

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

В современных интерфейсах (новостях, социальных сетях и прочим) принято размещать новые данные сверху, более старые - внизу. К сожалению, в 1C сделано несколько по-другому - по умолчанию списки документов отсортированы по возрастанию даты и далее возможно два варианта: либо список при открытии проматывается в конец, либо список может запоминать "последнюю" текущую строку.

03.11.2016    19104    Fragster    25       

Программное создание графических схем (v.2): API для ГрафическойСхемы 73

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом Универсальные функции

Пример динамического создания графических схем, добавления элементов любых видов. Любые схемы без бизнес-процессов. Программная работа со схемой. Отличие от существующей статьи в том, что здесь используется объектная модель. Исправил и упростил некоторые моменты - результат соответствует схеме, созданной руками. Добавил возможность рисования произвольных форм для существующих фигур.

27.09.2016    16930    serg_infostart    15       

Автоматическое добавление новых реквизитов на форму (УФ) 38

Статья Программист Нет файла v8 v8::УФ Бесплатно (free) Работа с интерфейсом Универсальные функции

Идея такая: Программист добавил реквизит в объект. В комментарии этого реквизита прописал некое спец. слово (можно не матерное). На форму объекта новый реквизит далее попадает автоматом в спец. группу "Дополнительно".

03.08.2016    16269    Патриот    23       

Управляемые формы: Поле HTML Документа и веб-клиент 57

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Взаимодействие javascript и интерфейса 1С дает огромные возможности для реализации нестандартных функций. Раньше можно было напрямую вызывать функции JavaScript через DOM объект document Поля HTML документа. В современных браузерах эта возможность ушла. Более того, в веб-клиенте появляется тип ВнешнийОбъект, который вообще нигде не описан. На Инфостарте были предложения вызывать JavaScript через fireEvent, но это очень неудобно. Предлагаю свой вариант решения.

18.07.2016    24247    compguru    10       

Как вывести динамическое представление для пустого значения (в таблице)? 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом

Есть таблица. Часть полей в ней заполняется автоматически, а часть - должен заполнить пользователь. Нужно подсказать пользователю, что именно в какую ячейку вводить - для этого выведем серым текст подсказки внутри каждой незаполненной ячейки. На поиски решения этой задачки я потратил половину субботы. Надеюсь, моя небольшая заметка поможет кому то провести выходные более продуктивно)

29.03.2016    9756    weissfeuer    9       

Выделение документов в динамическом списке 20

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Допустим, пользователю конфигурации на управляемых формах захотелось выделять документы в списке привычным образом и производить какие-то манипуляции с выделенными документами. Например, делать на их основании какие-то документы.

01.02.2016    15833    Sardukar    7       

Три приёма, позволяющие сделать интерфейс конфигураций 1С на управляемых формах удобнее при большом шрифте 52

Статья Программист Нет файла v8 УНФ ERP2 БП3.0 Windows Бесплатно (free) Работа с интерфейсом Универсальные функции

С появлением управляемых форм вообще и БП 3.0 в частности пользователи, которые не хотят портить своё зрение рассматриванием мелкого шрифта, оказались в невыгодном положении. Многих элементов на экране в "тяжёлых" документах вообще оказалось не видно. Все попытки решить вопрос штатными средствами настройки предприятия оказались неэффективны. Вот несколько приёмов, которые буквально в два щелчка мышкой и парой строк кода помогут решить проблему.

05.11.2015    15053    H-Labs    11       

Как скрыть "пустые группы" в списке выбора справочника при отборе 46

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Когда требуется открыть список справочника с отбором, например, по определённой группе, видны также все остальные группы с пустым содержимым. Мой способ избавления от ненужных групп ниже.

29.10.2015    25671    shevelyov    25       

Открытие форм нескольких новых документов в тонком и толстом клиенте, УФ 23

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Если Вам необходимо создать несколько документов, а затем открыть их формы для пользователя.

1 стартмани

29.09.2015    18083    Wezoowy    13       

Параметры сеанса. 47

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Параметры сеанса - это объекты метаданных конфигурации. Поговорим об их назначении и принципах работы с ними.

06.09.2015    55573    niko11s    8       

Шкала в строке состояния 51

Статья Программист Нет файла v8 Windows Бесплатно (free) Работа с интерфейсом

Простая шкала, не требующая дополнительных форм и элементов управления

31.08.2015    13495    Ivon    26       

Назначение сочетания клавиш для кнопок командной панели (Обычные формы) 13

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Назначение сочетания клавиш кнопкам командной панели Формы списка/выбора для любой конфигурации (Обычные формы)

07.08.2015    15184    bld    7       

Развитие управляемого интерфейса в 1С 8.2 - 1С 8.3 55

Статья Программист Нет файла v8 Windows Бесплатно (free) Практика программирования Математика и алгоритмы Работа с интерфейсом

К управляемым формам, которые появились в 8.2, я до сих пор относился презрительно. Считал это неудачной попыткой 1С следовать модным тенденциям в разработке интерфейсов и прогибом для возможности работать через браузер. Я считал, что 1С пожертвовала простотой разработки в угоду веб-доступу. Но после курсов Арутюнова Сергея по управляемому интерфейсу в июле 2015 года в УЦ1 я поменял ненависть на любовь. Звучит парадоксально, но это так. А теперь подробнее…

27.07.2015    35090    fixin    103       

Идея или как сохранить ЦВЕТ, ШРИФТ, ОФОРМЛЕНИЕ пользователя 25

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Простой и оригинальный способ сохранять ЦВЕТОВУЮ СХЕМУ и ОФОРМЛЕНИЕ пользователей. Как сохранить ЦВЕТ

22.06.2015    21484    Tatitutu    12       

Недокументированное использование стандартных обработок из меню "Все функции". 903

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Рассмотрены возможности произвольного использования стандартных функций, вызываемых из меню платформы "Все функции" - "Стандартные" (Активные пользователи, Журнал регистрации, Поиск ссылок на объект, Проведение документов ...).

19.06.2015    100696    ekaruk    121       

Быстрый ввод строковых значений в поля составного типа 64

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Когда нужно дать пользователю возможность вводить с клавиатуры строковые значения в поле ввода составного типа

04.06.2015    17270    Cyberhawk    14       

Личный опыт эскплуатации интерфейса "Такси" 11

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Уважаемые коллеги, предлагаю вам мой личный опыт использования интерфейса "Такси"

07.02.2015    15447    Marik    30       

Как перенести форму документа (справочника, ...) из одного документа (справочника, ...) в другой похожий документ (справочник, ...) 54

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

При попытке изменить Тип Реквизита «Объект» все элементы формы теряли путь к данным, ладно бы «поля ввода» (можно было выбрать заново «путь к данным»), но с табличными частями вообще труба, при выборе в «Таблице» все колонки в этом элементе банально удалялись. Можно, конечно, потратить кучу времени и вручную продублировать все то, что есть в форме оригинала, но я нашел другой путь!

26.11.2014    14332    RomanBor    18       

Создание интерфейса со всеми блокировками прав пользователя 20

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Создание интерфейса (напр. Продавец) со всеми блокировками прав пользователя (доступ к конфигуратору, меню Операции, Все функции, правам пользователей в меню сервис и др.)

10.10.2014    12387    ~ADm!t_@vd~    8       

Свернуть с учетом уровня дерево значений на управляемой форме 11

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Работа с интерфейсом

Набор процедур, которые сворачивают дерево значений на управляемой форме до определенного уровня

03.10.2014    13058    ivashka    2