Перенос присоединенных файлов во внешние тома

Публикация № 175587

Администрирование - Администрирование данных 1С - Сервисные утилиты

41
Обработка по переносу хранимых файлов из  базы в тома (файлы на диск)

При начале учета не верно оценил интересы руководства  и пользователей в удобстве хранения файлов для объектов, таких как номенклатура, документы поступления и реализации, входящая эл.почта. При начале ведения учета настроил  хранения файлов в базе, а зря. И так получилось что за 3 месяца работы размер базы ООООчень сильно вырос. Принял решение перенести все файлы  в тома. Поискав на в сети ничего не нашел кроме обработки Перенос присоединенных файлов номенклатуры во внешние тома , но файлы номенклатуры  это только малая часть. Так что ее то я взял за основу и немного переработав сделал для себя обработку по переносу всех «присоединенных файлов» в тома.

 Возможности:

Выбор справочника присоединенных файлов .

Индикатор =)

 

 

!!!! Перед началом работы с обработкой необходимо настроить правила хранения файлов

После можно работать с обработкой.

 

После переноса файлов необходимо сжать информационную базу.

 

Обработка тестировалась на УТ 11 и документообороте.

 

Отдельное спасибо dima-1c 

 

41

Скачать файлы

Наименование Файл Версия Размер
ПеренестиПрисоединенныеФайлыНаДиск.epf
.epf 7,50Kb
26.02.13
211
.epf 7,50Kb 211 Скачать
ПеренестиПрисоединенныеФайлыНаДиск_2.epf
.epf 7,71Kb
08.07.14
431
.epf 2 7,71Kb 431 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. kapustinag 27.02.13 11:32 Сейчас в теме
Правильное решение.
К сожалению, в УПП хранение файлов в томах на диске пока приделано только к "произвольному электронному документу" и т.п. То есть для УПП, если захочется сделать так же, без доработок основной конфигурации не обойтись.
2. Рамзес 27 07.03.13 11:38 Сейчас в теме
(1) Достаточно внести изменения в модуль формы «Форма списка файлов и изображений» справочника "Хранилище дополнительной информации".
8. eugensn 05.09.13 17:38 Сейчас в теме
(2) Рамзес, Какие именно изменения в модуле формы позволят обойти данное ограничение УПП?
3. deniskot 05.04.13 09:34 Сейчас в теме
не работает на Документообороте КОРП 1,2,6,1
{Форма.Форма.Форма(59)}: Ошибка при вызове метода контекста (Выполнить)
Возврат Запрос.Выполнить().Выгрузить()[0][0];
по причине:
{(1, 71)}: Таблица не найдена "Справочник.000000001"
Выбрать Сумма(Количество) из (Выбрать Количество(*) как Количество Из <<?>>Справочник.000000001
4. damontut 8 19.04.13 09:32 Сейчас в теме
В документообороте есть штатная обработка.
5. dihlam 09.05.13 13:27 Сейчас в теме
Добрый день.

1С:Предприятие 8.2 (8.2.18.82)
Управление торговлей, редакция 11.1

Ошибка:
Метод объекта не обнаружен(ДобавитьНаДиск)
Nikovit; cupertino; dima_kystym; dmitryburykin; apvl; Lyubin.Evgeniy; ivansulla; +7 Ответить
13. banco 21.06.14 14:38 Сейчас в теме
(5) dihlam,
вместо ФайловыеФункции.ДобавитьНаДиск
написать ФайловыеФункцииСлужебный.ДобавитьНаДиск
6. kuza_87 26 14.06.13 05:52 Сейчас в теме
Спасибо тебе огромное! Классная обработка, к тому же универсальная. Я её маленько под себя ещё переделал, сделал отбор по периоду. А то у меня памяти не хватало чтобы хотя бы один справочник выгрузить
7. cowboy121 30.07.13 10:55 Сейчас в теме
Добрый день!
Не очищается база после сжатия таблиц информационной базы. В чем может быть проблема?
9. Рамзес 27 06.09.13 10:21 Сейчас в теме
Вносим изменения в три процедуры модуля формы:
Процедура КоманднаяПанельДополнительныхФайловОткрытьФайлы(Кнопка)
	
	// { Админ [14.04.2011 11:36:35]
	ВыделенныеСтроки = ЭлементыФормы.ДополнительныеФайлы.ВыделенныеСтроки;
	ОбъектФайла = ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные;
	ТипОбъекта = ТипЗнч(ОбъектФайла.Ссылка.Объект);
	
	
	// для ОСТов нельзя рушить иерархию папок на сервере, поэтому для них путь прописан в имени файла
	// для остальных все файлы находятся в одной папке на сервере (не распределены по подпапкам)
	Если ТипОбъекта = Тип("СправочникСсылка.СерииНоменклатуры") Тогда
		ИмяКаталога = "F:\Сертификаты";
	ИначеЕсли ТипОбъекта = Тип("СправочникСсылка.СпецификацииНоменклатуры") Тогда
		ИмяКаталога = "F:\папка обмена\Чертежи\Эскизы сварных кромок";
	ИначеЕсли ТипОбъекта = Тип("СправочникСсылка.ОСТ") Тогда
		ИмяКаталога = "";
	КонецЕсли;
	
	Если ВыделенныеСтроки = Неопределено Тогда
		ОткрытьФайлДополнительнойИнформации(ИмяКаталога, ОбъектФайла.ИмяФайла);
	Иначе
		Если ВыделенныеСтроки.Количество() = 0 Тогда
			Возврат;
		КонецЕсли;

		Для каждого СсылкаФайл из ВыделенныеСтроки Цикл
			ОткрытьФайлДополнительнойИнформации(ИмяКаталога, ОбъектФайла.ИмяФайла);
		КонецЦикла;
	КонецЕсли; 
	
	Возврат;
	// } Админ [14.04.2011 11:36:35]
	
	РаботаСФайлами.ОткрытьФайлы(ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные, ЭлементыФормы.ДополнительныеФайлы.ВыделенныеСтроки, Ложь);

КонецПроцедуры
Показать


Процедура ДополнительныеФайлыПередОкончаниемРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)
	
	НовоеРасширениеФайла = РаботаСФайлами.ПолучитьРасширениеФайла(ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные.ИмяФайла);

	Если Не ОтменаРедактирования
	   И РаботаСФайлами.НельзяИзменятьРасширение(мТекущееРасширениеФайла, НовоеРасширениеФайла) Тогда

		Отказ = Истина;
		ЭлементыФормы.ДополнительныеФайлы.ТекущаяКолонка = ЭлементыФормы.ДополнительныеФайлы.Колонки.ИмяФайла;
		Возврат;

	КонецЕсли;

	Если Не ОтменаРедактирования
	   И НоваяСтрока
	   И ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные.Хранилище.Получить() = Неопределено Тогда
	   
		// { Админ [14.04.2011 11:36:35]
		// ничего не проверяем - позволяем не заполнять ячейку Хранилище - комментарим код от 1с:
		
		//Отказ = Истина;
		//Предупреждение("Необходимо выбрать файл.");
		//ЭлементыФормы.ДополнительныеФайлы.ТекущаяКолонка = ЭлементыФормы.ДополнительныеФайлы.Колонки.ИмяФайла;
		//Возврат;
		
		// } Админ [14.04.2011 11:36:35]
	
	КонецЕсли;

	ПередОкончаниемРедактирования(Элемент, НоваяСтрока, Перечисления.ВидыДополнительнойИнформацииОбъектов.Файл);

КонецПроцедуры
Показать


Процедура ДополнительныеФайлыИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)

	Диалог = РаботаСФайлами.ПолучитьДиалогВыбораФайлов(Ложь);

	Если Не Диалог.Выбрать() Тогда
		Возврат;
	КонецЕсли;

	// { Админ [14.04.2011 11:36:35]
	Попытка
		ТекОбъект = ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные;
		//ТекОбъект.Хранилище = Новый ХранилищеЗначения(Новый ДвоичныеДанные(Диалог.ПолноеИмяФайла), Новый СжатиеДанных);
		
		Если ТипЗнч(ОбязательныеОтборы.Объект) = Тип("СправочникСсылка.ОСТ") Тогда
			// для ОСТов нельзя рушить иерархию папок на сервере, поэтому для них путь прописываем в имени файла
			ТекОбъект.ИмяФайла = Диалог.ПолноеИмяФайла;
		Иначе
			// для остальных все файлы находятся в одной папке на сервере (не распределены по подпапкам)
			ТекОбъект.ИмяФайла = Сред(Диалог.ПолноеИмяФайла, СтрДлина(Диалог.Каталог) + 1);
		КонецЕсли;
		
	Исключение
		Сообщить("" + ОписаниеОшибки());
	КонецПопытки;
	Возврат; 
	// } Админ [14.04.2011 11:36:35]
	
	Попытка
		ТекОбъект = ЭлементыФормы.ДополнительныеФайлы.ТекущиеДанные;
		ТекОбъект.Хранилище = Новый ХранилищеЗначения(Новый ДвоичныеДанные(Диалог.ПолноеИмяФайла), Новый СжатиеДанных);
		ТекОбъект.ИмяФайла = Сред(Диалог.ПолноеИмяФайла, СтрДлина(Диалог.Каталог) + 1);
	Исключение
		Сообщить("" + ОписаниеОшибки());
	КонецПопытки;
	
	Ответ = Вопрос("Удалить файл источник?",РежимДиалогаВопрос.ДаНетОтмена,,КодВозвратаДиалога.Нет,"Удаление файла");
	Если Ответ = КодВозвратаДиалога.Да Тогда
		УдалитьФайлы(Диалог.ПолноеИмяФайла);
	КонецЕсли;

КонецПроцедуры
Показать


и добавляем процедуру:
// { Админ [09.09.2011 11:28:42]
// Данная процедура скопирована из общего модуля РаботаСФайлами, но в отличие от нее открывает файл
// не Эксплорером, а приложением, ассоциированным с расширением файла. Причина в том, что при запуске
// Эксплорера пользователя выбрасывает на рабочий стол сервера.
//
// Открывает переданный файл на диске с учетом типа файлов. Файлы, с которыми 
// может работать 1С:Предприятие открываются в 1С:Предприятии. Остальные файлы
// пытаются открыться зарегистрированным для них в системе приложением.
//
// Параметры
//  ИмяКаталога  – Строка, содержащая путь к каталогу файла на диске.
//  ИмяФайла     – Строка, содержащая имя файла, без имени каталога.
//
Процедура ОткрытьФайлДополнительнойИнформации(ИмяКаталога, ИмяФайла)

	Если ИмяКаталога = "" Тогда 
		// это хранилище для справочника ОСТ, в имени файла прописан полный путь
		ЗапуститьПриложение(ИмяФайла);
		Возврат
	КонецЕсли;
	
	ПолноеИмяФайла = РаботаСФайлами.ПолучитьИмяФайла(ИмяКаталога, РаботаСФайлами.УдалитьЗапрещенныеСимволыИмени(ИмяФайла));
	РасширениеФайла = Врег(РаботаСФайлами.ПолучитьРасширениеФайла(ИмяФайла));

	Если РасширениеФайла = "MXL" Тогда

		ТабличныйДокумент = Новый ТабличныйДокумент;
		ТабличныйДокумент.Прочитать(ПолноеИмяФайла);
		ТабличныйДокумент.Показать(ИмяФайла, Лев(ИмяФайла, СтрДлина(ИмяФайла) - 4));

	ИначеЕсли РасширениеФайла = "TXT" Тогда

		ТекстовыйДокумент = Новый ТекстовыйДокумент;
		ТекстовыйДокумент.Прочитать(ПолноеИмяФайла);
		ТекстовыйДокумент.Показать(ИмяФайла, Лев(ИмяФайла, СтрДлина(ИмяФайла) - 4));

	Иначе

		ЗапуститьПриложение(ПолноеИмяФайла);

	КонецЕсли;

КонецПроцедуры // ОткрытьФайлДополнительнойИнформации()
Показать
ВРедная; vshish; sparklemal; Операция1Ы; iiceberg; +5 Ответить
10. DimanYa 27.01.14 13:10 Сейчас в теме
Для бухгалтерии может подойди?

Или не пойдёт, но можно немного поменять в названиях процедур?

Структура хранения одинаковая по идее должна быть и в Ут 11 и в БП 3.0
11. DimanYa 27.01.14 13:28 Сейчас в теме
Извиняюсь, нашёл типовую обработку
12. zayav 25.03.14 16:56 Сейчас в теме
как быть ?

Не удалось добавить файл: "0002.jpg". Обратитесь к администратору системы.

в журнале:
Не удалось добавить файл ни на один из томов. Список ошибок:

Ошибка при добавлении файла на том: img (\\server\g\1CImage\20140325\): {ОбщийМодуль.ФайловыеФункции.Модуль(289)}: Неверный тип данных для добавления на том
ВызватьИсключение(СтрокаИсключения);


1С:Предприятие 8.2 (8.2.14.540)
УТ 11.0 (11.0.7.8)
Прикрепленные файлы:
14. 1977 2 09.07.14 11:32 Сейчас в теме
Жалко, что версии 1с КА не будет томов.......
20. riofrost 24.04.16 19:59 Сейчас в теме
(15) yaneev, (17) dima_kystym,
чтобы работало на конфигурациях построенных на БСП 2.2.5 (это УТ 11.1 и УНФ 1.5 к примеру), надо заменить код
ФайловыеФункцииСлужебный.ДобавитьНаДиск(ДвоичныеДанные, ПрисоединенныйФайл.ПутьКФайлу, ПрисоединенныйФайл.Том, ТекущаяДата(), "",
											ПрисоединенныйФайл.Наименование, ПрисоединенныйФайл.Расширение, ПрисоединенныйФайл.Размер, ПрисоединенныйФайл.Зашифрован);

на следующий:
	СведенияОФайле = ФайловыеФункцииСлужебный.ДобавитьФайлВТом(ДвоичныеДанные, ПрисоединенныйФайл.ДатаМодификацииУниверсальная, 
	ПрисоединенныйФайл.Наименование, ПрисоединенныйФайл.Расширение, , ПрисоединенныйФайл.Зашифрован, 
	ПрисоединенныйФайл.ДатаМодификацииУниверсальная);
	ПрисоединенныйФайл.Том = СведенияОФайле.Том;
	ПрисоединенныйФайл.ПутьКФайлу = СведенияОФайле.ПутьКФайлу;
	ПрисоединенныйФайл.ФайлХранилище = Новый ХранилищеЗначения("");
	ПрисоединенныйФайл.ДополнительныеСвойства.Вставить("ЗаписьПодписанногоОбъекта", Истина);


То есть, обязательно надо обновить данные в справочнике присоединенных файлов.

Ну и еще, для правильной индикации счетчик файлов стоит внести в цикл:

	
//.....
        н = н + СтруктураПорции.РазмерПорции - СтруктураПорции.КоличествоОшибок;	
    КонецЦикла;
	
Индикатор  = н;
pihy; unichkin; +2 Ответить
16. dima_kystym 11.05.15 17:37 Сейчас в теме
1С:Предприятие 8.3 (8.3.6.1977)Управление торговлей, редакция 11.1 (11.1.10.138)
Ошибка:
Метод объекта не обнаружен(ДобавитьНаДиск)
в чем может быть ошибка
17. dima_kystym 12.05.15 10:40 Сейчас в теме
"Метод объекта не обнаружен(ДобавитьНаДиск)" эту ошибку победил сейчас ошибка слишком много фактических параметров, может по дате можно отфильтровать присрединенные файлы?
18. Rustam10 15.10.15 23:43 Сейчас в теме
(17) dima_kystym, решение у №15 смотри.
19. ben_art 12 21.12.15 15:29 Сейчас в теме
Подскажите пожалуйста , как перенести файл из базы на внешний том , но при этом чтоб сохранилась ссылкав объекте на файл
22. realEvgenius 27.07.17 23:13 Сейчас в теме
Народ, кто пользовал? в КА2.2. работает, нет? Стоит брать?
23. maXon777 100 15.02.18 17:45 Сейчас в теме
(22)
Юзал в СРМ 3.0 - с мелкими доработками из пункта 15 работает из коробки
24. user962204 13.09.19 12:40 Сейчас в теме
Добрый день!
Конфа УТ 11.4.8.92
Платформа 8.3.15.1565

Вылезает ошибка "Поле объекта не обнаружен (Присоединенные файлы)"

РегистрСведений Присоединенный 1с переименовал как УдалитьПрисоединенныеФайлы.

Надо его поменять его на что то..

Кто то сталкивался?
25. ActionBlog 24.10.19 14:44 Сейчас в теме
Спасибо за обработку!

Наткнулся на интересную ситуацию - у нас в базе все файлы называются одинаково "Pictures1". В этом случае программа начинает плодить подпапки и в них записывать файлы с одинаковыми наименованиями, плодит-плодит и в определенный момент выдает ошибку, что больше не может плодить подпапки :)

Для решения этой ситуации я рандомно переименовываю прикрепленные файлы.

Добавил в обработку функцию, которая генерит рандомное число

Функция Рандом() Экспорт
	UID=Новый УникальныйИдентификатор();
	UID = СтрЗаменить(UID,"-","");
	Значение = "";
	Для Н=1 По СтрДлина(UID) Цикл
		Симв = Сред(UID,Н,1);
		Значение = Значение+Прав(КодСимвола(Симв),1);
	КонецЦикла;
	Возврат Значение;
КонецФункции
Показать


И после строки кода
ПрисоединенныйФайл = Выборка.ПолучитьОбъект();


Добавил строку
ПрисоединенныйФайл.Наименование = Рандом();
Оставьте свое сообщение

См. также

Быстрый запрос 42

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    7560    15    mkalimulin    28       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Блин, мы забыли включить регламентные задания… 51

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Сервисные утилиты

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    8362    10    slozhenikin_com    36       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 563

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    31494    283    bonv    117       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Редактор объектов информационной базы 8.3 44

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.37 от 14.12.2019

2 стартмани

23.01.2019    12175    157    ROL32    28       

Сравнение pdf-файлов актов сверки 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Россия БУ Дебиторская и кредиторская задолженность Абонемент ($m) Универсальные обработки

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    7765    4    Torin99    2       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Централизованное управление списком доступных баз 1С у пользователей 8

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Администрирование СУБД

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    7163    8    RomikR    9       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Обнуление остатков регистров бухгалтерии и накопления 42

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    11585    186    morozov.sv    30       

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. 36

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Россия Windows Абонемент ($m) Чистка базы Сервисные утилиты Администрирование данных 1С

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    22147    309    Eugen-S    34       

Новогодние скидки на авторское ПО Промо

В преддверии праздника в Маркетплейсе на Инфостарт действует скидка на все платные авторские программы. Размер скидок начинается от 10%. Советуем не откладывать покупки, многие наши партнеры повышают цены на свои продукты именно в начале нового года.

Навигатор по конфигурации базы 1С 8.3 108

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.47 от 25.11.2019

3 стартмани

28.10.2018    18584    202    ROL32    47       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних) 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Чистка базы

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    9487    14    Alexander.Shvets    9       

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    10302    18    Vin_Tik    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Построение маршрута доставки с расчётом расстояния для любой базы УФ 57

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    21934    36    KorotkovRV    16       

Практика доступа в базу 1С через протокол oData. Чтение данных 288

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    63172    260    Dementor    44       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз 45

Инструменты и обработки Системный администратор Приложение (exe) v8 Windows Абонемент ($m) Сервисные утилиты

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    15896    85    bonv    15       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Очистка регистрации обмена 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Абонемент ($m) Чистка базы

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    10759    4    serg-lom89    0       

Инструменты бухгалтера: Виджеты рабочего стола 126

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Windows Абонемент ($m) Универсальные обработки Рабочее место

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    27729    162    Bazil    22       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Автокликер для 1С 70

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    25081    69    slava_1c    49       

Удаление помеченных объектов, замена ссылок. Обычное и управляемое приложение. Не монопольно, включая рекурсивные ссылки, с отбором по метаданным и произвольным запросом 92

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Чистка базы

Обработка удаления помеченных объектов с расширенным функционалом. Работает в обычном и управляемом приложении. Монопольный и разделенный режим работы. Отображение и отбор по структуре метаданных. Отборы данных произвольными запросами. Копирование и сохранение отборов. Удаление циклических ссылок (рекурсия). Представление циклических в виде дерева с отображением ключевых ссылок, не позволяющих удалить текущий объект информационной базы. Удаление записей связанных независимых регистров сведений. Групповая замена ссылок. Индикатор прогресса при поиске и контроле ссылочности.

10 стартмани

31.10.2016    41680    539    m..adm    186       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Поиск и отключение зависших сеансов на сервере 1С: Предприятия 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Обработка предназначена для мониторинга и отключения спящих (зависших) сеансов на сервере 1С: Предприятия.

1 стартмани

14.09.2016    23976    67    wowchik_85    9       

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора. 24

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    30789    150    Aphanas    4       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID) 8

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Поиск данных Универсальные обработки

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    25107    101    Dzenn    8       

Оптимальный способ расчета контрольной суммы объекта/записи регистра (CRC32, MD5, SHA1, SHA256) 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки

Была задача сравнить документы в распределенных базах и пометить на выгрузку измененные. Но сравнение изменений документов методом перебора реквизитов - долгоиграющий процесс, особенно если общее количество сравниваемых данных переваливает за миллион. Был найден выход, который ускоряет процесс сравнения - расчет контрольной суммы объекта и сравнение ее с другой контрольной суммой. Скорость сравнения увеличивается во много раз.

1 стартмани

01.08.2016    23275    5    hakerxp    9