Обработка изображений 1С средствами .Net framework

Публикация № 183782

Программирование - Внешние компоненты

7
1С:Предприятие не предоставляет штатных средств работы с изображениями по изменению размеров и наложению водяных знаков. Данный функционал часто востребован, например, в Интернет-магазинах, когда из 1С происходит экспорт товаров с фотографиями. Раньше для этого использовали выгрузку фотографий на диск и вызов утилит через командную строку. Понятно, что гибкостью и скоростью такой вариант не обладает, плюс еще могут возникнуть проблемы с безопасностью и учетом временных файлов.

Обработка изображений 1С средствами .Net framework

1С:Предприятие не предоставляет штатных средств работы с изображениями по изменению размеров и наложению водяных знаков. Данный функционал часто востребован, например, в Интернет-магазинах, когда из 1С происходит экспорт товаров с фотографиями. Раньше для этого использовали выгрузку фотографий на диск и вызов утилит через командную строку. Понятно, что гибкостью и скоростью такой вариант не обладает, плюс еще могут возникнуть проблемы с безопасностью и учетом временных файлов.

В предложенном варианте через .Net framework обработка ведется в памяти без создания промежуточных файлов. При обработке доступны все классы System.Drawing, что добавляет способу гибкости, потому что при желании можно достичь любых эффектов штатными методами. При этом используется .Net framework 4.0 и средство его сопряжения с 1С .Net bridge 4.

Инициализация

Код инициализации создает объект внутри 1С, отвечающий за работу с .Net Framework и загружает сборку System.Drawing 4й версии:

ПодключитьВнешнююКомпоненту("Elisy.NetBridge4");
AddIn = New("AddIn.ElisyNetBridge4");
net = AddIn.GetNet();
net.LoadAssembly("System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a");

Конвертация между форматами

Внутри .Net Framework работа с изображениями ведется через объект класса Bitmap, а внутри 1C за изображения отвечает тип Картинка. Необходимо организовать преобразование типа Картинка в объект Bitmap.

На стороне 1С вызывается метод ДвоичныеДанные() для типа Картинка. Для конфигурации Управление Торговлей 10.3 код может быть таким:

Функция ПолучитьКартинку(Номенклатура) Экспорт
Если ЗначениеЗаполнено(Номенклатура.ОсновноеИзображение) Тогда
    Возврат Номенклатура.ОсновноеИзображение.Хранилище.Получить().ПолучитьДвоичныеДанные();
Иначе
    Картинка = Новый Картинка();
    Возврат Картинка.ПолучитьДвоичныеДанные();
КонецЕсли;
КонецФункции

Функция ПолучитьКартинку вернет 1С-тип ДвоичныеДанные. Его можно преобразовать в .Net-тип следующим кодом:

bytes = net.CallStatic("System.Convert", "FromBase64String", Base64String(картинка));
bitmap = net.New("System.Drawing.Bitmap", net.New("System.IO.MemoryStream", bytes));

Изменение размера изображения

Если известны размеры конечного изображения width, height и есть исходное изображение Bitmap, то в 1С код по изменению размера будет примерно следующим:

outputBitmap = net.New("System.Drawing.Bitmap", width, height);
g = net.CallStatic("System.Drawing.Graphics", "FromImage", outputBitmap);
g.CompositingQuality = net.New("System.Drawing.Drawing2D.CompositingQuality").HighQuality;
g.SmoothingMode = net.New("System.Drawing.Drawing2D.SmoothingMode").HighQuality;
g.InterpolationMode = net.New("System.Drawing.Drawing2D.InterpolationMode").HighQualityBicubic;
g.Clear(net.GetStatic("System.Drawing.Color", "WhiteSmoke"));

sx = width / Bitmap.Width;
sy = height / Bitmap.Height;
scale = Мин(sx, sy);
g.DrawImage(bitmap, Окр((outputBitmap.Width - scale * bitmap.Width) / 2, 0), Окр((outputBitmap.Height - scale * bitmap.Height) / 2, 0), Окр(scale * bitmap.Width, 0), Окр(scale * bitmap.Height, 0));

Если width >= 100 ИЛИ height >= 100 Тогда
    ДобавитьВодянойЗнак(net, g, watermark, width, height);
КонецЕсли;

Код создает объект g типа Graphics, позволяющий производить операции с графикой, на основе конечного изображения outputBitmap с размерами width и height. Вызов g.Clear заполнит фон рисунка определенным цветом (в данном случае WhiteSmoke). Заполнение цветом нужно, если исходное изображение полностью не заполнит заданные размеры. На основе пропорции параметров ширины и высоты и ширины и высоты исходного изображения на результирующее изображение накладывается исходное изображение.

Чтобы как можно оптимальнее использовать ресурсоемкий объект g происходит вызов процедуры ДобавитьВодянойЗнак здесь же, где в качестве параметра передается текстовая строка watermark. Желательно вызвать явно в конце обработки:

g.Dispose();

Метод Dispose лучше явно вызывать для всех IDisposable объектов, надобность в которых отпала: Bitmap, outputBitmap, объектов типа MemoryStream.

Наложение водяного знака

Водяной знак накладывается средствами System.Drawing. Два способа, о которых пойдет речь, основаны на методе g. MeasureString, позволяющей вернуть размер строки, которую планируется нанести на изображение.

Способ 1

Первый способ наносит водяной знак внизу изображения. Перебираются размеры шрифта, начиная с 72 и ниже, пока заданная строка водяного знака не войдет в границы изображения. Строка выведется два раза: полупрозрачной черной кистью и полупрозрачной белой кистью с небольшим смещением.

Образец для www.1cretail.com

Образец водяного знака, полученного по способу 1

sizes = net.New("System.Collections.Generic.List", net.T("System.Int32"));
sizes.Add(72);
sizes.Add(36);
sizes.Add(24);
sizes.Add(16);
sizes.Add(14);
sizes.Add(12);
sizes.Add(10);
sizes.Add(8);
sizes.Add(6);
sizes.Add(4);

crFont = null;
crSize = net.New("System.Drawing.SizeF");
Для i = 0 по 8 цикл
    crFont = net.New("System.Drawing.Font", "arial", sizes.get_Item(i), net.New("System.Drawing.FontStyle").Bold);
    crSize = g.MeasureString(Watermark, crFont);

    Если crSize.Width < width тогда
        Прервать;
    КонецЕсли;
КонецЦикла;

yPixlesFromBottom = Окр(height * 0.05, 0);
yPosFromBottom = ((height - yPixlesFromBottom) - (crSize.Height / 2));
xCenterOfImg = width / 2;

StrFormat = net.New("System.Drawing.StringFormat");
StrFormat.Alignment = net.New("System.Drawing.StringAlignment").Center;

semiTransBrush2 = net.New("System.Drawing.SolidBrush", net.CallStatic("System.Drawing.Color", "FromArgb", 153, 0, 0, 0));

g.DrawString(watermark,
    crFont,
    semiTransBrush2,
    net.New("System.Drawing.PointF", Окр(xCenterOfImg + 1, 0), Окр(yPosFromBottom + 1, 0)),
    StrFormat);

semiTransBrush = net.New("System.Drawing.SolidBrush", net.CallStatic("System.Drawing.Color", "FromArgb", 153, 255, 255, 255));

g.DrawString(watermark,
    crFont,
    semiTransBrush,
    net.New("System.Drawing.PointF", Окр(xCenterOfImg, 0), Окр(yPosFromBottom, 0)),
    StrFormat);

Способо 2

Второй способ выведет водяной знак по диагонали исходного изображения. С сотого размера шрифта вниз происходит попытка вместить строку в изображение. Если попытка удачная, то найденным шрифтом с найденным углом рисуется строка чуть видимой белой кистью.

font = net.New("System.Drawing.Font", "Tahoma", 40);
color = net.CallStatic("System.Drawing.Color", "FromArgb", 25, 255, 255, 255);
tangent = height / width;
angle = ATan(tangent) * (180 / 3.1415);
halfHypotenuse = Sqrt((Height * Height) + (Width * Width)) / 2;
Для i2 = 0 по 99 цикл
    i = 100 - i2;

    font = net.New("System.Drawing.Font", "Tahoma", i, net.New("System.Drawing.FontStyle").Bold);
    sizef = g.MeasureString(watermark, font, net.GetStatic("System.Int32", "MaxValue"));

    sin = Sin(angle * (3.1415 / 180));
    cos = Cos(angle * (3.1415 / 180));
    opp1 = sin * sizef.Width;
    adj1 = cos * sizef.Height;
    opp2 = sin * sizef.Height;
    adj2 = cos * sizef.Width;

    Если opp1 + adj1 < height И opp2 + adj2 < width тогда
        Прервать;
    КонецЕсли;

КонецЦикла;

stringFormat = net.New("System.Drawing.StringFormat");
stringFormat.Alignment = net.New("System.Drawing.StringAlignment").Center;
stringFormat.LineAlignment = net.New("System.Drawing.StringAlignment").Center;
g.SmoothingMode = net.New("System.Drawing.Drawing2D.SmoothingMode").AntiAlias;
g.RotateTransform(Окр(angle, 0));
g.DrawString(watermark,
    font,
    net.New("System.Drawing.SolidBrush", color),
    net.New("System.Drawing.PointF", Окр(halfHypotenuse, 0), 0),
    stringFormat);

Пример изображения для 2го способа www.dordoi.net:

Образец водяного знака, полученного по способу 2

Метод встроен в обработку: 

Новостная лента: наглядное представление данных и отправка по E-mail

// //
7

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Evil Beaver 6075 19.04.13 11:12 Сейчас в теме
Здорово. А не лучше ли предоставить удобный API к наложению знаков? Довольно муторно одинэсникам (по крайней мере мне) фтыкать в GDI и в разные синусо-косинусы. Функционал-то полезный, вынести метод вроде Совместить(ИсходноеИзображение,ИзображениеЗнака) было бы отлично!
2. Elisy 930 19.04.13 13:12 Сейчас в теме
(1) Evil Beaver,
Мне кажется сделать 3 функции из набора вызовов - это дело техники. Можете скопировать функции
Функция ПолучитьКартинку(Номенклатура) Экспорт
Функция ПреобразоватьКартинку(net, картинка, width, height, resolution, watermark)
Процедура ДобавитьВодянойЗнак(net, grPhoto, watermark, width, height)
Процедура ДобавитьВодянойЗнак2(net, gr, watermark, width, height)

из модуля обработки
http://infostart.ru/public/180863/
Это и будет API. Главное, что есть гибкость и действия программиста не ограничены этим API - любой может расширить функционал на свое усмотрение.
3. Evil Beaver 6075 19.04.13 13:27 Сейчас в теме
(2) да это понятно ) Просто без Вашей статьи (с кодом) это сделать намного сложнее.
4. salexdv 1573 19.04.13 13:46 Сейчас в теме
(1) тут есть наложение вызовом одного метода
5. CheBurator 3389 19.04.13 18:50 Сейчас в теме
А есть что-то типа crop для картинки (обрезка изображения от несущественных частей). т.е. есть картинка - на ней обозначаю фрейм, который могу раздвигать и двигать сам фрейм по картинке. жмак! получили картинку а границах фрейма. ясен пень, что это обрезка д.б. без ухудшения качества картинки (т.е. джпеги обрезаютсс с сохранением исходного качества)
???
6. cool.vlad4 44 19.04.13 19:07 Сейчас в теме
(5) в dotnet-е, конечно, есть. google: c# gdi crop -> например http://stackoverflow.com/questions/1030278/c-sharp-gdi-image-cropping , ну а дальше перевести это все по типу (0)
(0) предложение: сделать некий кодогенератор - пишешь код на c# в IDE -> потом переводищь в код для работы в 1С.
Потому как писать код как в публикации, очень непросто. В нем разобраться-то непросто из-за смешения. И потом никакой поддержки C# кода, ни автокомплита, ни проверки типов.
9. Elisy 930 23.04.13 08:48 Сейчас в теме
(6) cool.vlad4,
(0) предложение: сделать некий кодогенератор - пишешь код на c# в IDE -> потом переводищь в код для работы в 1С.
Потому как писать код как в публикации, очень непросто. В нем разобраться-то непросто из-за смешения. И потом никакой поддержки C# кода, ни автокомплита, ни проверки типов.

Кодогенератор пока сложно написать. По куску C# кода сложно выходить на полные типы объектов с учетом пространства имен, сложно отличать статические члены от нестатических. Есть только черновик методики перевода.
Как альтернатива - можно писать на C# или другом .Net-языке и компилировать в 1С "на лету". Хранить исходные коды в макете.
7. Elisy 930 20.04.13 07:58 Сейчас в теме
(5) CheBurator,
А есть что-то типа crop для картинки (обрезка изображения от несущественных частей). т.е. есть картинка - на ней обозначаю фрейм, который могу раздвигать и двигать сам фрейм по картинке. жмак! получили картинку а границах фрейма. ясен пень, что это обрезка д.б. без ухудшения качества картинки (т.е. джпеги обрезаютсс с сохранением исходного качества) ???

Можно посмотреть код в обработке
http://infostart.ru/public/78946/
Там как раз решается задача обрезки
8. CheBurator 3389 20.04.13 16:23 Сейчас в теме
10. roadman 05.05.14 08:27 Сейчас в теме
Подскажите для тех, кто в танке:
Как это изображение ВЫВЕСТИ, желательно на доп монитор, подключенный к тому же компу, где запущена 1С???
11. Elisy 930 05.05.14 09:30 Сейчас в теме
(10)
"Как это изображение ВЫВЕСТИ, желательно на доп монитор, подключенный к тому же компу, где запущена 1С???"
Если делать через .Net, я бы разбил эту задачу на подзадачи:
1. Создание отдельного от 1С окна-формы средствами XAML
2. Позиционирование окна в отдельном мониторе
3. Показ на окне-форме изображения
12. tuman777 40 29.03.19 13:27 Сейчас в теме
А как обратно перевести Net Bitmap в картинку?
13. Elisy 930 29.03.19 14:12 Сейчас в теме
(12)
Можно через промежуточный файл
bitmap.Save("file name");
Картинка = Новый Картинка("file name");

Есть еще более сложный способ через массив байт
Оставьте свое сообщение