Обработка изображений 1С средствами .Net framework

Публикация № 183782

Разработка - Разработка внешних компонент

1С:Предприятие не предоставляет штатных средств работы с изображениями по изменению размеров и наложению водяных знаков. Данный функционал часто востребован, например, в Интернет-магазинах, когда из 1С происходит экспорт товаров с фотографиями. Раньше для этого использовали выгрузку фотографий на диск и вызов утилит через командную строку. Понятно, что гибкостью и скоростью такой вариант не обладает, плюс еще могут возникнуть проблемы с безопасностью и учетом временных файлов.

Обработка изображений 1С средствами .Net framework

1С:Предприятие не предоставляет штатных средств работы с изображениями по изменению размеров и наложению водяных знаков. Данный функционал часто востребован, например, в Интернет-магазинах, когда из 1С происходит экспорт товаров с фотографиями. Раньше для этого использовали выгрузку фотографий на диск и вызов утилит через командную строку. Понятно, что гибкостью и скоростью такой вариант не обладает, плюс еще могут возникнуть проблемы с безопасностью и учетом временных файлов.

В предложенном варианте через .Net framework обработка ведется в памяти без создания промежуточных файлов. При обработке доступны все классы System.Drawing, что добавляет способу гибкости, потому что при желании можно достичь любых эффектов штатными методами. При этом используется .Net framework 4.0 и средство его сопряжения с 1С .Net bridge 4.

Инициализация

Код инициализации создает объект внутри 1С, отвечающий за работу с .Net Framework и загружает сборку System.Drawing 4й версии:

ПодключитьВнешнююКомпоненту("Elisy.NetBridge4");
AddIn = New("AddIn.ElisyNetBridge4");
net = AddIn.GetNet();
net.LoadAssembly("System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a");

Конвертация между форматами

Внутри .Net Framework работа с изображениями ведется через объект класса Bitmap, а внутри 1C за изображения отвечает тип Картинка. Необходимо организовать преобразование типа Картинка в объект Bitmap.

На стороне 1С вызывается метод ДвоичныеДанные() для типа Картинка. Для конфигурации Управление Торговлей 10.3 код может быть таким:

Функция ПолучитьКартинку(Номенклатура) Экспорт
Если ЗначениеЗаполнено(Номенклатура.ОсновноеИзображение) Тогда
    Возврат Номенклатура.ОсновноеИзображение.Хранилище.Получить().ПолучитьДвоичныеДанные();
Иначе
    Картинка = Новый Картинка();
    Возврат Картинка.ПолучитьДвоичныеДанные();
КонецЕсли;
КонецФункции

Функция ПолучитьКартинку вернет 1С-тип ДвоичныеДанные. Его можно преобразовать в .Net-тип следующим кодом:

bytes = net.CallStatic("System.Convert", "FromBase64String", Base64String(картинка));
bitmap = net.New("System.Drawing.Bitmap", net.New("System.IO.MemoryStream", bytes));

Изменение размера изображения

Если известны размеры конечного изображения width, height и есть исходное изображение Bitmap, то в 1С код по изменению размера будет примерно следующим:

outputBitmap = net.New("System.Drawing.Bitmap", width, height);
g = net.CallStatic("System.Drawing.Graphics", "FromImage", outputBitmap);
g.CompositingQuality = net.New("System.Drawing.Drawing2D.CompositingQuality").HighQuality;
g.SmoothingMode = net.New("System.Drawing.Drawing2D.SmoothingMode").HighQuality;
g.InterpolationMode = net.New("System.Drawing.Drawing2D.InterpolationMode").HighQualityBicubic;
g.Clear(net.GetStatic("System.Drawing.Color", "WhiteSmoke"));

sx = width / Bitmap.Width;
sy = height / Bitmap.Height;
scale = Мин(sx, sy);
g.DrawImage(bitmap, Окр((outputBitmap.Width - scale * bitmap.Width) / 2, 0), Окр((outputBitmap.Height - scale * bitmap.Height) / 2, 0), Окр(scale * bitmap.Width, 0), Окр(scale * bitmap.Height, 0));

Если width >= 100 ИЛИ height >= 100 Тогда
    ДобавитьВодянойЗнак(net, g, watermark, width, height);
КонецЕсли;

Код создает объект g типа Graphics, позволяющий производить операции с графикой, на основе конечного изображения outputBitmap с размерами width и height. Вызов g.Clear заполнит фон рисунка определенным цветом (в данном случае WhiteSmoke). Заполнение цветом нужно, если исходное изображение полностью не заполнит заданные размеры. На основе пропорции параметров ширины и высоты и ширины и высоты исходного изображения на результирующее изображение накладывается исходное изображение.

Чтобы как можно оптимальнее использовать ресурсоемкий объект g происходит вызов процедуры ДобавитьВодянойЗнак здесь же, где в качестве параметра передается текстовая строка watermark. Желательно вызвать явно в конце обработки:

g.Dispose();

Метод Dispose лучше явно вызывать для всех IDisposable объектов, надобность в которых отпала: Bitmap, outputBitmap, объектов типа MemoryStream.

Наложение водяного знака

Водяной знак накладывается средствами System.Drawing. Два способа, о которых пойдет речь, основаны на методе g. MeasureString, позволяющей вернуть размер строки, которую планируется нанести на изображение.

Способ 1

Первый способ наносит водяной знак внизу изображения. Перебираются размеры шрифта, начиная с 72 и ниже, пока заданная строка водяного знака не войдет в границы изображения. Строка выведется два раза: полупрозрачной черной кистью и полупрозрачной белой кистью с небольшим смещением.

Образец для www.1cretail.com

Образец водяного знака, полученного по способу 1

sizes = net.New("System.Collections.Generic.List", net.T("System.Int32"));
sizes.Add(72);
sizes.Add(36);
sizes.Add(24);
sizes.Add(16);
sizes.Add(14);
sizes.Add(12);
sizes.Add(10);
sizes.Add(8);
sizes.Add(6);
sizes.Add(4);

crFont = null;
crSize = net.New("System.Drawing.SizeF");
Для i = 0 по 8 цикл
    crFont = net.New("System.Drawing.Font", "arial", sizes.get_Item(i), net.New("System.Drawing.FontStyle").Bold);
    crSize = g.MeasureString(Watermark, crFont);

    Если crSize.Width < width тогда
        Прервать;
    КонецЕсли;
КонецЦикла;

yPixlesFromBottom = Окр(height * 0.05, 0);
yPosFromBottom = ((height - yPixlesFromBottom) - (crSize.Height / 2));
xCenterOfImg = width / 2;

StrFormat = net.New("System.Drawing.StringFormat");
StrFormat.Alignment = net.New("System.Drawing.StringAlignment").Center;

semiTransBrush2 = net.New("System.Drawing.SolidBrush", net.CallStatic("System.Drawing.Color", "FromArgb", 153, 0, 0, 0));

g.DrawString(watermark,
    crFont,
    semiTransBrush2,
    net.New("System.Drawing.PointF", Окр(xCenterOfImg + 1, 0), Окр(yPosFromBottom + 1, 0)),
    StrFormat);

semiTransBrush = net.New("System.Drawing.SolidBrush", net.CallStatic("System.Drawing.Color", "FromArgb", 153, 255, 255, 255));

g.DrawString(watermark,
    crFont,
    semiTransBrush,
    net.New("System.Drawing.PointF", Окр(xCenterOfImg, 0), Окр(yPosFromBottom, 0)),
    StrFormat);

Способо 2

Второй способ выведет водяной знак по диагонали исходного изображения. С сотого размера шрифта вниз происходит попытка вместить строку в изображение. Если попытка удачная, то найденным шрифтом с найденным углом рисуется строка чуть видимой белой кистью.

font = net.New("System.Drawing.Font", "Tahoma", 40);
color = net.CallStatic("System.Drawing.Color", "FromArgb", 25, 255, 255, 255);
tangent = height / width;
angle = ATan(tangent) * (180 / 3.1415);
halfHypotenuse = Sqrt((Height * Height) + (Width * Width)) / 2;
Для i2 = 0 по 99 цикл
    i = 100 - i2;

    font = net.New("System.Drawing.Font", "Tahoma", i, net.New("System.Drawing.FontStyle").Bold);
    sizef = g.MeasureString(watermark, font, net.GetStatic("System.Int32", "MaxValue"));

    sin = Sin(angle * (3.1415 / 180));
    cos = Cos(angle * (3.1415 / 180));
    opp1 = sin * sizef.Width;
    adj1 = cos * sizef.Height;
    opp2 = sin * sizef.Height;
    adj2 = cos * sizef.Width;

    Если opp1 + adj1 < height И opp2 + adj2 < width тогда
        Прервать;
    КонецЕсли;

КонецЦикла;

stringFormat = net.New("System.Drawing.StringFormat");
stringFormat.Alignment = net.New("System.Drawing.StringAlignment").Center;
stringFormat.LineAlignment = net.New("System.Drawing.StringAlignment").Center;
g.SmoothingMode = net.New("System.Drawing.Drawing2D.SmoothingMode").AntiAlias;
g.RotateTransform(Окр(angle, 0));
g.DrawString(watermark,
    font,
    net.New("System.Drawing.SolidBrush", color),
    net.New("System.Drawing.PointF", Окр(halfHypotenuse, 0), 0),
    stringFormat);

Пример изображения для 2го способа www.dordoi.net:

Образец водяного знака, полученного по способу 2

Метод встроен в обработку: 

Новостная лента: наглядное представление данных и отправка по E-mail

// //

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Evil Beaver 6824 19.04.13 11:12 Сейчас в теме
Здорово. А не лучше ли предоставить удобный API к наложению знаков? Довольно муторно одинэсникам (по крайней мере мне) фтыкать в GDI и в разные синусо-косинусы. Функционал-то полезный, вынести метод вроде Совместить(ИсходноеИзображение,ИзображениеЗнака) было бы отлично!
2. Elisy 932 19.04.13 13:12 Сейчас в теме
(1) Evil Beaver,
Мне кажется сделать 3 функции из набора вызовов - это дело техники. Можете скопировать функции
Функция ПолучитьКартинку(Номенклатура) Экспорт
Функция ПреобразоватьКартинку(net, картинка, width, height, resolution, watermark)
Процедура ДобавитьВодянойЗнак(net, grPhoto, watermark, width, height)
Процедура ДобавитьВодянойЗнак2(net, gr, watermark, width, height)

из модуля обработки
http://infostart.ru/public/180863/
Это и будет API. Главное, что есть гибкость и действия программиста не ограничены этим API - любой может расширить функционал на свое усмотрение.
3. Evil Beaver 6824 19.04.13 13:27 Сейчас в теме
(2) да это понятно ) Просто без Вашей статьи (с кодом) это сделать намного сложнее.
4. salexdv 1871 19.04.13 13:46 Сейчас в теме
(1) тут есть наложение вызовом одного метода
5. CheBurator 3426 19.04.13 18:50 Сейчас в теме
А есть что-то типа crop для картинки (обрезка изображения от несущественных частей). т.е. есть картинка - на ней обозначаю фрейм, который могу раздвигать и двигать сам фрейм по картинке. жмак! получили картинку а границах фрейма. ясен пень, что это обрезка д.б. без ухудшения качества картинки (т.е. джпеги обрезаютсс с сохранением исходного качества)
???
6. cool.vlad4 45 19.04.13 19:07 Сейчас в теме
(5) в dotnet-е, конечно, есть. google: c# gdi crop -> например http://stackoverflow.com/questions/1030278/c-sharp-gdi-image-cropping , ну а дальше перевести это все по типу (0)
(0) предложение: сделать некий кодогенератор - пишешь код на c# в IDE -> потом переводищь в код для работы в 1С.
Потому как писать код как в публикации, очень непросто. В нем разобраться-то непросто из-за смешения. И потом никакой поддержки C# кода, ни автокомплита, ни проверки типов.
9. Elisy 932 23.04.13 08:48 Сейчас в теме
(6) cool.vlad4,
(0) предложение: сделать некий кодогенератор - пишешь код на c# в IDE -> потом переводищь в код для работы в 1С.
Потому как писать код как в публикации, очень непросто. В нем разобраться-то непросто из-за смешения. И потом никакой поддержки C# кода, ни автокомплита, ни проверки типов.

Кодогенератор пока сложно написать. По куску C# кода сложно выходить на полные типы объектов с учетом пространства имен, сложно отличать статические члены от нестатических. Есть только черновик методики перевода.
Как альтернатива - можно писать на C# или другом .Net-языке и компилировать в 1С "на лету". Хранить исходные коды в макете.
7. Elisy 932 20.04.13 07:58 Сейчас в теме
(5) CheBurator,
А есть что-то типа crop для картинки (обрезка изображения от несущественных частей). т.е. есть картинка - на ней обозначаю фрейм, который могу раздвигать и двигать сам фрейм по картинке. жмак! получили картинку а границах фрейма. ясен пень, что это обрезка д.б. без ухудшения качества картинки (т.е. джпеги обрезаютсс с сохранением исходного качества) ???

Можно посмотреть код в обработке
http://infostart.ru/public/78946/
Там как раз решается задача обрезки
8. CheBurator 3426 20.04.13 16:23 Сейчас в теме
10. roadman 05.05.14 08:27 Сейчас в теме
Подскажите для тех, кто в танке:
Как это изображение ВЫВЕСТИ, желательно на доп монитор, подключенный к тому же компу, где запущена 1С???
11. Elisy 932 05.05.14 09:30 Сейчас в теме
(10)
"Как это изображение ВЫВЕСТИ, желательно на доп монитор, подключенный к тому же компу, где запущена 1С???"
Если делать через .Net, я бы разбил эту задачу на подзадачи:
1. Создание отдельного от 1С окна-формы средствами XAML
2. Позиционирование окна в отдельном мониторе
3. Показ на окне-форме изображения
12. tuman777 41 29.03.19 13:27 Сейчас в теме
А как обратно перевести Net Bitmap в картинку?
13. Elisy 932 29.03.19 14:12 Сейчас в теме
(12)
Можно через промежуточный файл
bitmap.Save("file name");
Картинка = Новый Картинка("file name");

Есть еще более сложный способ через массив байт
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76205    Serginio    108    

.Net Core, обмен с 1C по TCP/IP между различными устройствами

Разработка внешних компонент v8 Бесплатно (free)

Часто нужно обмениваться данными с клиентом 1С из различных устройств, между клиентами 1С, а также при виртуализации между разными ОС на компьютере. Это кроссплатформенная ВК, позволяющая обмениваться сообщениями по TCP/IP между различными устройствами по определенному протоколу.

28.09.2016    21216    Serginio    8    

Net Core. Динамическая компиляция класса обертки для получения событий .Net объекта в 1С

Разработка внешних компонент v8 Бесплатно (free)

Часто нужно использовать события объектов .Net. Например событие от COM порта, поступление сообщений по WhatsAp, сообщение об изменение в директории итд. Напрямую этого сделать нельзя, но можно сделать класс обертку и через него получать ВнешнееСобытие

14.09.2016    16022    Serginio    1    

.Net Core, 1C, динамическая компиляция, Scripting API

Разработка внешних компонент Практика программирования v8 Бесплатно (free)

Очень часто приходится использовать динамический код в 1С, используя Выполнить или Вычислить. Аналогичная задача и для использования скриптов на .Net. Я постарался показать, как можно скрестить ежа с ужом и получить удобный код. В этой статье много вражеского кода для чистого одноэсника, но все когда-то бывает впервые.

07.09.2016    18957    Serginio    7    

1С, Linux, Excel, Word, OpenXML, ADO, Net Core

Разработка внешних компонент v8 Бесплатно (free)

В данной статье показаны примеры кроссплатформенной работы с файлами Excel и Word (xlsx,docx) с помощью библиотеки OpenXML и Net Core

22.08.2016    21071    Serginio    14    

Асинхронное программирование в 1С через использование классов .Net из Native ВК

Разработка внешних компонент v8 Бесплатно (free)

Это продолжение статьи Кроссплатформенное использование классов .Net в 1С через Native ВК. Или замена COM на Linux II http://infostart.ru/public/541518/ В этой статье покажу, как можно асинхронно вызывать асинхронные методы и вызывать ВнешнееСобытие в 1С из сборки .Net

09.08.2016    17598    Serginio    3    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31643    Serginio    22    

Быстрое создание Внешних Компонент на C#. Примеры использования Глобального Контекста, IAsyncEvent, IExtWndsSupport, WinForms и WPF

Практика программирования Разработка внешних компонент v8 Бесплатно (free)

В большинстве случаев хватает и обычного COM объекта, учитывая, что в 8.х можно использовать события. Но иногда нужно использовать Глобальный Контекст для вызова глобальных функций, таких как Сообщить, NewObject и т.д. Кроме того, для использования форм нужен дескриптор окна 1С. Это продолжение статей Использование сборок .NET в 1С 7.x b 8.x. Создание внешних Компонент. http://infostart.ru/public/238584/ Там же лежат и исходники .NET(C#) для 1С. Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия http://infostart.ru/public/417830/ 1C Messenger для отправки сообщений, файлов и обмена данными между пользователями 1С, вэб страницы, мобильными приложениями а ля Skype, WhatsApp http://infostart.ru/public/434771/ Использование классов .Net в 1С для новичков http://infostart.ru/public/448668/

15.02.2016    29426    Serginio    13    

Подсветка синтаксиса 1С в текстовых редакторах Atom, Sublime Text, VS Code

Инструментарий разработчика Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Пакеты, добавляющие поддержку синтаксиса языка 1С:Предприятие 8 в текстовые редакторы Atom, Sublime Text и VS Code. И не только.

02.02.2016    27443    nixel    38    

.NET(C#) для 1С. Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия

Разработка внешних компонент Математика и алгоритмы v7.7 v8 Бесплатно (free)

Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия, а так же генерация модулей на C# и 1С для подключения к событиям. Использование DynamicMethod и ILGenerator. Представлены примеры для использовании событий System.IO.FileSystemWatcher (Ожидает уведомления файловой системы об изменениях и инициирует события при изменениях каталога или файла в каталоге.) и SerialPort (обработка сканера штрих кода подключенного к COM порту). Обертка позволяет использовать классы .Net только на языке 1С. Реализация 1C Messenger описанного здесь http://infostart.ru/public/434771/

12.11.2015    46568    Serginio    36    

1С с "плюсами"

Разработка внешних компонент Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

- Разработана методика подключения внешней компоненты, снимающая ограничения на типы данных аргументов и возвращаемого значения. - Проведено документирование основных типов данных (объектов, интерфейсов) платформы. - Разработан объект «Делегат» для реализации функциональных объектов (указатель-на-функцию). - Разработана концепция итератора произвольного доступа для основных контейнеров платформы с целью сопряжения со стандартной C++ библиотекой. - В процессе разработки механизм 1С классов (наследование, интерфейсы) для возможности использования парадигм объектно-ориентированного программирования на уровне кода.

14.10.2015    23072    IntelInside    48    

Генерация штрих-кода для вставки его в 1С при работе в Linux

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В Linux есть отличная команда barcode, которая генерирует штрих-коды в векторном формате ps. Но 1С не понимает такие форматы. Более того, barcode генерирует штрих-код на размер листа А4 или Letter. Установка пользовательского размера листа не увенчалась успехом. Но не будем же мы вставлять изображение штрих-кода размером с лист А4… Однако есть способ, как решить данные проблемы.

01.07.2015    16562    rudjuk    4    

Простейший способ создания штрих-кода в формате PNG из командной строки в Linux Ubuntu

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В Linux есть огромное количество способов создания линейного штрих-кода. В данной статье мы рассмотрим, как сгенерировать графическое изображение штрих-кода прямо из командной строки. При этом, решение будет совершенно бесплатным и очень простым как в установке, так и в использовании.

29.06.2015    12227    rudjuk    15    

Компилирование внешней компоненты AddInNative в ОС Linux

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В статье отражены некоторые моменты, которые нужно учесть, чтобы скомпилировать пример 1С-вской внешней компоненты AddInNative в ОС Linux.

14.01.2015    20686    q_i    22    

Использование внешних COM-компонент (.dll) или любых клиентских методов в регламентных заданиях серверной базы.

Практика программирования Разработка внешних компонент Математика и алгоритмы v8 1cv8.cf Бесплатно (free)

Для расширения возможностей платформы 1С существует огромное количество внешних компонент (дополнительные функции, взаимодействие с софтом и железом других производителей, ключи защиты). К сожалению, большинство из них написано на технологии .COM и не могут использоваться на сервере. Для использования в регламентных заданиях серверной базы их приходится переписывать на Native API. Однако, иногда нет возможности переписать компоненту на новую технологию, но нужно вызвать ее в регламентном задании на сервере.

10.12.2014    45736    ekaruk    51    

Подсистема "COMExchange": ускорение выгрузки запросов ADO или «игра с огнём».

Практика программирования Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Описана поддержка подсистемой "COMExchange"работы с ВК GameWhithFire.dll и в частности ускоренная выгрузка результата запроса ADO средствами ВК.

11.03.2013    19961    yuraos    4    

Простой пример создания ActiveX-control на Qt

Практика программирования Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Мне была поставлена задача разработать некий ActiveX-control. Так как основным языком программирования для разработки у нас используется C++, то C# не рассматривался. Я решил выбрать Qt, так как он мне интересен. Создание ActiveX объектов на Qt достаточно простой процесс, в примерах к QtCreator есть несколько вариантов, показывающих как можно использовать ActiveQt (например этот). При написании компонента пришлось много времени потратить на поиск ответов на казалось бы простые вопросы, по крупицам их собирать. В результате я получил, что требовалось и решил написать простой пример, чтобы ускорить процесс старта разработки ActiveX-control другим. Сразу обращу внимание, что не описываю всю технологию ActiveQt, подробную информацию можно получить в документации Qt Assistant и в интернете (например здесь), это пример и пара интересных на мой взгляд моментов.

25.02.2013    9188    theshadowco    3    

Finger-биометрия в 1С

Разработка внешних компонент v8 Россия Бесплатно (free)

О различных методиках использования сканеров отпечатков пальцев в 1С.

02.07.2012    27289    fixin    22    

Решение проблем с регистрацией внешних компонент в терминале

Разработка внешних компонент Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 УТ10 Россия УУ Бесплатно (free)

Зачастую у программистов возникают проблемы с подключением внешних компонент (например, драйверов торгового оборудования), когда пользователи работают с 1С, подключаясь к серверу через терминал. Это связано с некоторыми особенностями работы функции глобального контекста ПодключитьВнешнююКомпоненту().

22.09.2011    68179    Spacer    41    

Новая версия 1С:Предприятие 8.2 конфликтует с C# и .Net framework

Практика программирования Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Суть конфликта 1С 8.2 с C# и .Net framework в следующем. В версии 8.2 1С анонсировала новый способ написания внешних компонент 1С с использованием так называемого Native API. Самое интересное, что на C# предложенный подход реализовать невозможно, а реализация Native API на VC++/CLI теоретически возможна, но при попытке подключения DLL, скомпилированных с опцией /CLR, происходит зависание 1С (версия 8.2.13.202). Еще один конфликт – в новой версии 1С нет поддержки технологии ActiveX, на основе которой многие разработчики вставляли в формы 1С свои WinForms-приложения.

15.12.2010    21350    Elisy    128    

Учим внешнюю компоненту правильному склонению не только ФИО, но и должностей, и подразделений (ЗУП 2.5)

Разработка внешних компонент Практика программирования v8 ЗУП2.5 Россия Бесплатно (free)

Многие из нас сталкивались с проблемой неверного склонения должностей и подразделений внешней компонентой склонения ФИО. Результат при этом может напоминать следующее: 1.Именительный "Главный специалист" 2.Родительный "Главныя специалиста" 3.Дательный "Главныю специалисту " 4.Винительный "Главныя специалиста " 5.Творительный "Главныем специалистом " 6.Предложный "Главные специалисте " Метод борьбы с данным недугом предлагаю ниже.

21.11.2010    61241    director04    64