Что такое буквы в 1С

Публикация № 186774

Разработка - Практика программирования

Некоторые особенности и неочевидные моменты использования символов в 1С.

Что такое буквы в 1С.

Скрипт приведенный ниже демонстрирует следующие особенности работы с символами в 1С:

  • Символ/КодСимвола работают в диапазоне -1..65535, причем Символ(-1) - строка без символов
  • Скрипт ищет все символы "пустые строки". Некоторые из этих строк отображаются как непустые.
  • Скрипт показывает, какие символы являются "буквами" для языка 1С - это полезно для написания обфускаторов и для проверок самописных парсеров языка 1С (собственно для проверки лексического генератора и написан этот скрипт).
  • Скрипт показывает допустимость символов для XML. Это важно, потому что сервер и клиент 1С в управляемых формах общаются через XML, поэтому при попытке передать недопустимый символ возникнет ошибка времени выполнения. Если при загрузке данных из внешних источников это не учитывать, то может возникнуть ситуация, когда 1С будет всегда падать при открытии, например, справочника.
  • Демонстрируется, что строка в 1С не является null-terminated. В скрипте не демонстрируется, но упомянуто, что ТекстовыйДокумент не умеет корректно работать со строками, содержащими Символ(0)

Сам скрипт проверялся в управляемых формах:


&НаКлиенте
Процедура ВыполнитьТест(Команда)

   
РезультатТеста = Новый Массив;
   
СтруктураДляПроверкиБукв = Новый Структура;
   
Начало = -2;
   
Конец = 65540;

    Для
Сч = Начало По Конец Цикл

        Если
Сч % 1024 = 0 Тогда
           
Состояние("Символ № " + Строка(Сч));
           
ОбработкаПрерыванияПользователя();
        КонецЕсли;

       
СимволПоКоду = Символ(Сч);
       
СтруктураРезультат = Новый Структура(
           
"Номер, Символ, ЭтоСимвол, ПустаяСтрока, ЭтоБуква, ДопустимыйСимволыXML, КорректнаяКонкатенация");
       
РезультатТеста.Добавить(СтруктураРезультат);
       
СтруктураРезультат.Номер = Сч;
       
СтруктураРезультат.Символ = СимволПоКоду;

       
//Проверка 1 - Это символ?
        //Демонстрируется, что Символ/КодСимвола работают в диапазоне -1..65535, причем Символ(-1) - строка без символов
       
КодПоСимволу = КодСимвола(СимволПоКоду);
        Если
КодПоСимволу<>Сч Тогда
           
СтруктураРезультат.ЭтоСимвол = Ложь;
            Продолжить;
        Иначе
           
СтруктураРезультат.ЭтоСимвол = Истина;
        КонецЕсли;

       
//Проверка 2 - Это пустая строка?
        //Неочевидный момент - некоторые "пустые строки" вполне имеют графическое непустое отображение
       
СтруктураРезультат.ПустаяСтрока = ПустаяСтрока(СимволПоКоду);

       
//Проверка 3 - Это буква?
        //Буквой считаем символ, который может быть именем поля в структуре. Таких букв достаточно много.
       
ТекущееЗначение = "";
        Попытка
            Если
СтруктураДляПроверкиБукв.Свойство(СимволПоКоду, ТекущееЗначение) Тогда
               
//Заодно сохраняем все "одинаковые" буквы, максимальное количество - 4:Θθϑe2;
               
СтруктураДляПроверкиБукв[СимволПоКоду] = ТекущееЗначение + СимволПоКоду;
            Иначе
               
СтруктураДляПроверкиБукв.Вставить(СимволПоКоду, СимволПоКоду);
            КонецЕсли;
           
СтруктураРезультат.ЭтоБуква = Истина;
        Исключение
           
СтруктураРезультат.ЭтоБуква = Ложь;
        КонецПопытки;

       
//Проверка 4 - Допустимые символы XML. Строки с недопустимыми символами нельзя передать с сервера или на сервер.
        //При получении данных из любых сторонних источников, перез записью их в БД крайне желательно их проверять на то,
        //что они смогут потом быть прочитанными. 
       
СтруктураРезультат.ДопустимыйСимволыXML = (НайтиНедопустимыеСимволыXML(СимволПоКоду) = 0);

       
//Проверка 5 - корректность конкатенации
        //- очевидно, что для символа с кодом -1 конкатенация не работает (это пустая строка длины 0)
        //- менее очевидно, что символы кода 0 успешно конкатенируются. Только ТекстовыйДокумент об этом, к сожалению, не знает
       
ДлиннаяСтрока = СимволПоКоду + СимволПоКоду + СимволПоКоду + СимволПоКоду + СимволПоКоду;
       
СтруктураРезультат.КорректнаяКонкатенация = (СтрДлина(ДлиннаяСтрока) = 5);

    КонецЦикла;

   
//1. в текстовый документ нельзя вывести "нулевой символ"
    //2. Выводим "честно" - последовательно по строкам и колонкам, чтобы не привлекать дополнительные механизмы
   
ТабличныйДокумент = Новый ТабличныйДокумент;
   
СчКолонок = 1;
    Для каждого
КлючИЗначениеСтруктураРезультат Из СтруктураРезультат Цикл
       
ТабличныйДокумент.Область(1, СчКолонок, 1, СчКолонок).Текст = КлючИЗначениеСтруктураРезультат.Ключ;
       
СчКолонок = СчКолонок + 1;
    КонецЦикла;
   
ТабличныйДокумент.Область(1, СчКолонок, 1, СчКолонок).Текст = "АналогичныеСимволы";
   
ТабличныйДокумент.Область(1, СчКолонок + 1, 1, СчКолонок + 1).Текст = "КоличествоАналогов";
   
СчСтрок = 2;
    Для каждого
СтруктураРезультат Из РезультатТеста Цикл

        Если
СчСтрок % 1024 = 0 Тогда
           
Состояние("Строка № " + Строка(СчСтрок));
           
ОбработкаПрерыванияПользователя();
        КонецЕсли;

       
СчКолонок = 1;
        Для каждого
КлючИЗначениеСтруктураРезультат Из СтруктураРезультат Цикл
           
ТабличныйДокумент.Область(СчСтрок, СчКолонок, СчСтрок, СчКолонок).Текст КлючИЗначениеСтруктураРезультат.Значение;
           
СчКолонок = СчКолонок + 1;
        КонецЦикла;
        Если
СтруктураРезультат.ЭтоБуква = Истина Тогда
           
ТабличныйДокумент.Область(СчСтрок, СчКолонок, СчСтрок, СчКолонок).Текст = СтруктураДляПроверкиБукв[СтруктураРезультат.Символ];
           
ТабличныйДокумент.Область(СчСтрок, СчКолонок + 1, СчСтрок, СчКолонок + 1).Текст = СтрДлина(СтруктураДляПроверкиБукв[СтруктураРезультат.Символ]);
        КонецЕсли;
       
СчСтрок = СчСтрок + 1;

    КонецЦикла;
   
ТабличныйДокумент.Показать();

КонецПроцедуры

Скрипт пробегает по всем символам и просто выводит на экран табличный документ с результатами.

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. TrinitronHome 20.05.13 20:07 Сейчас в теме
спасибо большое за статью, очень полезный материал для меня
2. Virikus 52 22.05.13 12:32 Сейчас в теме
Для проверки обмена через XML будет полезно. Спасибо.
3. dr.vatson 27.05.13 19:51 Сейчас в теме
Скрипт пробегает по всем символам и просто выводит на экран табличный документ с результатами

выводит ошибки или вносит исправления?
5. speshuric 1149 27.05.13 21:26 Сейчас в теме
(3) Не понял. Куда вносить исправления? Просто тупо выводит сформированную табличку с колонками. И всё.
4. KillHunter 7 27.05.13 20:03 Сейчас в теме
Отличная статья. Спасибо!
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    5311    ids79    25       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    7278    John_d    21       

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    9251    YPermitin    72       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    23934    ids79    45       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    15559    YPermitin    75       

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    18195    ids79    16       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    32975    ids79    36       

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    18277    avalakh    21       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    26972    ids79    9       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    19512    ids79    27       

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    14774    YPermitin    12       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    12052    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    31628    ids79    17       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    16871    dmurk    144       

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    27152    YPermitin    27       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    17212    Eret1k    23       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    9271    m-rv    2       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    12395    m-rv    16       

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    23332    ellavs    125       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    18506    ellavs    83       

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    20357    YPermitin    53