Красивая временная блокировка (7.7+Formex)

Публикация № 19714

Администрирование - Информационная безопасность

Просто красивая блокировка сеанса

Можно просто добавить на панель инструментов или

заменить стандартную блокировку с помощью //infostart.ru/projects/602/

 

Скачать файлы

Наименование Файл Версия Размер
fn_lock.ert

.1240304255 36,50Kb
472
.1240304255 36,50Kb 472 Скачать
fn_lock + Formex

.1240390985 246,17Kb
264
.1240390985 246,17Kb 264 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. sys_adminus 21.04.09 14:25 Сейчас в теме
это конечно прикольная штука- но ввожу пароль, а он не впускает обратно :-(
2. Noy 1067 21.04.09 14:29 Сейчас в теме
(1) Странно, я тестировал на 20 пользователях - вроде все ОК.
3. sys_adminus 21.04.09 14:36 Сейчас в теме
к стати у меня терминал - щас покапаюсь
4. artbear 1308 21.04.09 14:38 Сейчас в теме
5. vip 21.04.09 14:52 Сейчас в теме
6. Noy 1067 21.04.09 14:56 Сейчас в теме
(1,3) Как вариант - обработку можно запустить со "своим" паролем - передать в Форма.Параметр строку. (Например ОткрытьФормуМодально("Отчет","777","C:\... .\fn_lock.ert") - пароль будет "777" ).
7. ded00786 347 22.04.09 09:54 Сейчас в теме
8. Bezborodoff 22.04.09 10:02 Сейчас в теме
9. kery 22.04.09 10:42 Сейчас в теме
А я красоты не увидела.
{C:\2009\ZIK2009\FN_LOCK.ERT(57)}: Неудачная попытка создания объекта (Окна)
11. Noy 1067 22.04.09 10:57 Сейчас в теме
(9) Скачайте http://www.dorex.ru/files/?formex_t.zip Затем из архива достаньте файлик FormEx.dll и положите его в каталог с обработкой...
10. andrewalexk 22.04.09 10:47 Сейчас в теме
:)
..а у мадемуазель формекс стоит?
12. kiyaas 22.04.09 12:39 Сейчас в теме
Здравствуйте!! Я начинающий 1с программсит! не подскжете как это добавиьт????
13. Noy 1067 22.04.09 12:42 Сейчас в теме
(12) Зайти в конфигуратор - Открыть Конфигурацию - Интерфейсы - нужный интерфес - панели инструментов - там добавляешь пункт "Отчеты - Отчеты.ВнешнийОткрыть" на вкладке дополнительно указываешь путь к файлу (лучше положить его в ExtForms), назначеашь иконку/комбинацию клавиш
14. kiyaas 22.04.09 12:52 Сейчас в теме
(13)
Окна=СоздатьОбъект("Окна");
{D:\NSS-OFFICE\EXTFORMS\FN_LOCK.ERT(57)}: Неудачная попытка создания объекта (Окна)
15. Noy 1067 22.04.09 13:00 Сейчас в теме
16. Noy 1067 22.04.09 13:04 Сейчас в теме
Добавил архив вместе с компонентой Альфа и обработкой.
Для тех, у кого еще нет єтой прекрасной компоненты
(14) и (9) Это для вас...
17. Джиневра 22.04.09 13:06 Сейчас в теме
Вау :) Какая красивая задумка.
19. kiyaas 22.04.09 13:30 Сейчас в теме
все равно такая же ошибка!!!
21. Noy 1067 22.04.09 13:31 Сейчас в теме
(19) Возьми обработку из архива (!!!) и длл-ку и все положи в ExtForms
23. kery 22.04.09 13:53 Сейчас в теме
(21) Выражаю признательность за донесение искусства 1С до всяких, не особо умелых пользователей. Мерси.
20. pata 22.04.09 13:30 Сейчас в теме
22. ТипТопыч 22.04.09 13:42 Сейчас в теме
dahanago попробуй капслок нажать и большими символами набери пароль.
27. sarius 24 22.04.09 17:09 Сейчас в теме
24. chsm 22.04.09 16:02 Сейчас в теме
Вхожу в 1С без пароля, заставку каким паролем убрать?
25. Душелов 3927 22.04.09 16:04 Сейчас в теме
(24) Отправь SMS на короткий номер ХХХХ со словом пароль и в ответ пришлют смс с паролем снятия блокировки. :))
26. Noy 1067 22.04.09 16:07 Сейчас в теме
(25) :) :) :)
(24) по-логике пустым...
но там немного мутно все с пользователями, у которых пароль "неопределён"...
я думал что поборол проблемку, оказывается не совсем.
28. Андроид 198 22.04.09 17:19 Сейчас в теме
У меня ошибка такая.. У меня не прописан католог пользователя..
FN_LOCK.ERT(76)}: Поле агрегатного объекта не обнаружено (ПолучитьХэшПароляПользователя)
ХешПравильногоПароля=Сервис.ПолучитьХэшПароляПользователя(ИмяПользователя(), КаталогИБ());
29. АЛьФ 22.04.09 17:48 Сейчас в теме
2(28) Наверное, надо обновить FormEx.
30. sarius 24 23.04.09 09:30 Сейчас в теме
Кстати, насчет пароля - может взять пароль в ВРЕГ() в самой проверке пароля?
31. Noy 1067 23.04.09 10:11 Сейчас в теме
(30) А есть проблемы с паролем? У меня все пароли цифровые - там проблем нет.
Если есть ошибка - пишите - я поправлю.
32. sarius 24 23.04.09 15:41 Сейчас в теме
(31) Да, такая проблема есть - ввод большими буквами ее решает. У себя в обработке поднял регистр - проблемы нет.
33. Noy 1067 23.04.09 16:21 Сейчас в теме
(32) Исправил, обновил.
34. demaoleg 24.04.09 00:16 Сейчас в теме
В ExtForms базы - создать папку FormEx.grp вложить оба файла (ert и dll) все работает на ура.
35. vip 24.04.09 00:31 Сейчас в теме
(34) А без этого не работает? ;))
36. napala@ 102 27.04.09 16:28 Сейчас в теме
Красота какая! даже не хочется включать обратно ))
37. simply1 6 29.04.09 10:36 Сейчас в теме
Красиво. Только размеры нужно подправить. Красота должна быть красивой до конца. :))
Идея - супер! Автору - уважуха и респект!

Провел несколько экспериментов и сделал для себя открытие. Оказывается, пароль в 1С 7.7 регистронезависимый! :((((
Столько лет я верил что регистр имеет значение ...

Исходя из этого, при проверке можно оставить только переменные: <ХешПравильногоПароля> и <ХешПароля2>. И условие упростить:

Если ХешПравильногоПароля=ХешПароля2 Тогда
... снять блокировку ...
КонецЕсли;
38. Noy 1067 29.04.09 10:48 Сейчас в теме
(37) Размеры как раз и подбирал что бы покрасивше (но это уже дело вкуса).
по поводу регистронезависимого пароля - для меня тоже открытие (sarius подсказал), но так как я лично тестов не проводил, то просто добавил еще одну проверку.
39. simply1 6 29.04.09 11:05 Сейчас в теме
Список контролируемых клавиш - хороший ход.
Но не понятно, зачем он здесь?
Разве не достаточно перехватывать только клавишу <Esc>?
40. Noy 1067 29.04.09 11:46 Сейчас в теме
(39) Нет, нужно перехватывать еще и хоткеи...
У меня используется обработка http://infostart.ru/projects/3800/ - так если вызывать с помощью хоткея какой-нибудь журнал - то он открывается под "экраном блокировки", что есть не очень-то красиво...
то же самое относиться к хоткеям на кнопках и пунктах меню...
43. simply1 6 29.04.09 15:10 Сейчас в теме
(40) я комбинации горячих клавиш сам нигде не назначал, кроме тех, что по умолчанию заложены в конигурацию. Поэтому, у меня ни один хоткей под блокировкой не срабатывает.
Но уж сильно большой список нужных клавиш у тебя получился.
Я бы пошел по принципу "чего меньше". Меньше перечислений нужных или НЕ нужных. Проследил бы закономерность всех хоткеев, например, они все используют сочетание Контр+Шифт, или везде используются функциональные (F?) и т.д.
Но не подумай что я тебя учу? Тем более, что обработка уже написана и работает!
Хочу отметить - написана хорошо даже для не опытных или начинающих - только скачай и запускай! Это признак профессионализма!
45. Noy 1067 29.04.09 15:43 Сейчас в теме
(43) мерси за коплимант! (с) За двома Зайцами
:)

А по сути я и пошел по принципу "чего меньше" - просто у меня уже есть несколько обработок, которые содержат в себе списки "отфильтрованных" клавиш и я банально сделал копи-паст ;)
41. Yashazz 3756 29.04.09 11:49 Сейчас в теме
Красиво, но идейно не вполне верно - отсутствующий сотрудник может оставить на экране важные сведения, каковые всё равно видно, а это уязвимость. Лучше, если занавеска будет совсем сплошная, чтоб изображение рабочего окна 1С стало нечитабельным.
42. Noy 1067 29.04.09 11:59 Сейчас в теме
(41) там легко поправить в коде ищи строки:
Для х=1 по 220 Цикл
х=х+14;
Форм.Прозрачность=х;
КонецЦикла;

Меняй на

Для х=1 по 250 Цикл
х=х+14;
Форм.Прозрачность=х;
КонецЦикла;
Форм.Прозрачность=255;

P.S. у нас в компании важные данные вообще запрещено оставлять на экране даже при блокировке, в остальных случаях - наоборот присутствует определенная открытость - сотрудник временно отошел, но он работает и даже видно над чем.
44. simply1 6 29.04.09 15:13 Сейчас в теме
(42) - поддерживаю полностью!
А я изменил прозрачность до 190.
46. simply1 6 30.04.09 10:21 Сейчас в теме
Предлагаю при включении блокировки в цикл вставить задержку на 500 миллисекунд. Или другое число, кому как нравится :)

"...
Для х=1 по 190 Цикл
х=х+14;
Форм.Прозрачность=х;
ВыполнитьЗадержку(500);
КонецЦикла;
..."

Когда экран затемняется постепенно, то очень красиво получается.
А для разблокировки задержка не нужна. Работать надо ведь быстро, правильно? :)

Вот код функции:

//-----------------------------------------------
Функция ВыполнитьЗадержку(мс=1000) Экспорт
// Устанавливает задержку в указанных миллисекундах
Попытка
TextScript="
|Function pause(ms)
| WScript.Sleep ms
|End Function
|";
ScrptCtrl=CreateObject("MSScriptControl.ScriptControl");
ScrptCtrl.Language = "vbscript";
ScrptCtrl.AddCode(TextScript);
ScrptCtrl.Run("pause",1000);
ScrptCtrl=Пусто;
Возврат 1;
Исключение
Возврат 0;
КонецПопытки;
КонецФункции // ВыполнитьЗадержку
47. Noy 1067 30.04.09 10:29 Сейчас в теме
(46) Хорошая идея, только сильно зависит от скорости компа. Например у меня и так плавно затухает...
48. simply1 6 30.04.09 10:32 Сейчас в теме
(46) что-то в цикле задержка не срабатывает ... :(
Надо еще покопаться.
49. Noy 1067 30.04.09 10:41 Сейчас в теме
(48) Попробуй "обычную" задержку:
ТекВремя=ТекущееВремя(); Пока ТекВремя=ТекущееВремя() Цикл Состояние ("Пауза");КонецЦикла;
51. simply1 6 30.04.09 14:39 Сейчас в теме
(46) функция не рабочая, прошу никого не копировать. Объект WScript с 1С-ом не подружен. Подружу, перевыложу.

(49) - задержка на 1 секунду. Это слишком много, миллисекунд 100 - с головой.

59. simply1 6 30.04.09 17:49 Сейчас в теме
(46) и (51) - туфта все это!

Есть метод Sleep у объекта "Система" внешней компоненты 1С++.
При мощном ПК затухание смотрится красиво только при задержке 12 миллисекунд, не больше.
50. .S.e.R.e.G.a. 30.04.09 13:12 Сейчас в теме
52. antz 30.04.09 14:58 Сейчас в теме
54. GSoft 2858 30.04.09 15:29 Сейчас в теме
а у меня сделано так

-==Глобальный модуль==-

//ЛОКАЛЬНЫЕ ПЕРЕМЕННЫЕ
Перем ЕстьАктивность; //нужна для определения активности пользователя


//глобальная процедура внешней компоненты FormEx

//__________________________________________________________­___________________
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКл, кнАльт, кнШифт, кнКонтрол, Символ)
ЕстьАктивность = 1;
КонецПроцедуры


//__________________________________________________________­___________________
Процедура ЗаблокироватьПрограмму()
//проверка активности пользователя
//в конце каждой минуты флаг активности выставляем в ноль
//если за минуту активность была то время неактивности обнуляем
//иначе время неактивности накапливаем
//как только время неактивности достигает значения переменной
//КолвоМинутДоБлокировки - блокируем программу.

Если ПустоеЗначение(глПользователь.КолвоМинутДоБлокировки) = 1 Тогда
Возврат;
КонецЕсли;

Если ЕстьАктивность = 0 Тогда
ВремяНеактивностиПользователя = 1 + ВремяНеактивностиПользователя;
Иначе
ВремяНеактивностиПользователя = 1;
КонецЕсли;

Если ВремяНеактивностиПользователя = глПользователь.КолвоМинутДоБлокировки Тогда //КолвоМинутДоБлокировки Тогда
Если глПрограммаЗаблокирована = 0 Тогда
глПрограммаЗаблокирована = 1;
ОткрытьФормуМодально("Обработка.ПроверкаПароля", "Блокировка");
КонецЕсли;
КонецЕсли;

ЕстьАктивность = 0;
КонецПроцедуры // ЗаблокироватьПрограмму



//__________________________________________________________­___________________
Процедура парамОбработкаОжидания()
ЗаблокироватьПрограмму();
КонецПроцедуры // парамОбработкаОжидания


//__________________________________________________________­___________________
Процедура ПриНачалеРаботыСистемы()
Если ЗагрузитьВнешниеКомпоненты() = 0 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;

Если глПриНачалеРаботыСистемы() <> 1 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;

//вызов процедуры парамОбработкаОжидания каждые 60 секунд (60000мС)
глСервис.ОбработкаОжидания("парамОбработкаОжидания", 60000);
КонецПроцедуры // ПриНачалеРаботыСистемы
55. Noy 1067 30.04.09 15:33 Сейчас в теме
(54) Завидую...
а вот у меня есть несколько пользователей, работающих исключительно с мышей...

А каждый чих мышки ловить - накладно выходит.
56. GSoft 2858 30.04.09 15:52 Сейчас в теме
(55)

повесь на обработку нажатия кнопки мыши. В формексе есть на правую и левую, сингл и дабл клик
58. artbear 1308 30.04.09 17:25 Сейчас в теме
(54) Ага, решение из (57) я делал как раз для подобных задач
57. JohnyDeath 299 30.04.09 16:03 Сейчас в теме
60. simply1 6 30.04.09 17:52 Сейчас в теме
(57) - мы с тобой в обоих форумах одновременно! :)))
61. Abadonna 3891 01.05.09 06:24 Сейчас в теме
54.>ЗаблокироватьПрограмму();
при нективности. Посмешил. У меня стоит ЗавершитьРаботуСистемыНах() ибо не фиг там неактивному торчать. И бокировать у менеджера только 1С не вижу смысла.
Боликровать надо комп, решается скрин-сейвером с паролем. А тех манагеров, у которых он не стоит, у нас на первый раз предупреждают, на второй - выгоняют
62. GSoft 2858 04.05.09 11:03 Сейчас в теме
и такое есть:
у каждого пользователя в настройках есть реквизит - колво минут до блокировки,но это значение не может превышать значение константы, достигнув которого система пользователя выкидывает
63. GSoft 2858 06.05.09 02:24 Сейчас в теме
собстно там просто надо в процедуре ЗаблокироватьПрограмму() убрать первое условие вначале и добавить добавить условие на проверку времени неактивности со значением константы


//__________________________________________________________­___________________
Процедура ЗаблокироватьПрограмму()
//проверка активности пользователя
//в конце каждой минуты флаг активности выставляем в ноль
//если за минуту активность была то время неактивности обнуляем
//иначе время неактивности накапливаем
//как только время неактивности достигает значения переменной
//КолвоМинутДоБлокировки - блокируем программу.

Если ЕстьАктивность = 0 Тогда
ВремяНеактивностиПользователя = 1 + ВремяНеактивностиПользователя;
Иначе
ВремяНеактивностиПользователя = 1;
КонецЕсли;

Если ВремяНеактивностиПользователя = глПользователь.КолвоМинутДоБлокировки Тогда
Если глПрограммаЗаблокирована = 0 Тогда
глПрограммаЗаблокирована = 1;
ОткрытьФормуМодально("Обработка.ПроверкаПароля", "Блокировка");
КонецЕсли;
КонецЕсли;

Если ВремяНеактивностиПользователя > Константа.КолвоМинутДоВыходаПриНеактивности Тогда
ЗавершитьРаботуСистемы(0);
КонецЕсли;


ЕстьАктивность = 0;
КонецПроцедуры // ЗаблокироватьПрограмму

64. Paully 06.05.09 16:17 Сейчас в теме
Меня так и не пускает обратно:
ХешПравильногоПароля=Сервис.ПолучитьХэшПароляПользователя(ИмяПользователя(), КаталогИБ());
{C:\DOCUMENTS AND SETTINGS\NEVASILEVSKIY\МОИ ДОКУМЕНТЫ\1С БАЗЫ\BASE КУРГАН\BASE\EXTFORMS\FORMEX.GRP\FN_LOCK.ERT(106)}: Поле агрегатного объекта не обнаружено (Полу
И чего не так? Скачал отдельно длл-ку, с офф.сайта - ни к черту. Все описанные рекомендации - делал.
65. Noy 1067 06.05.09 16:28 Сейчас в теме
(64) У тебя загружается старая версия длл. Найди по поиску formex.dll на всех локальных дисках и все длл замени на новую версию.
66. Paully 06.05.09 16:59 Сейчас в теме
не помогло... че делать - как быть?
67. Noy 1067 06.05.09 17:26 Сейчас в теме
в 1С - Помощь - О программе - Закладка Formex - там есть путь к внешней компоненте...
в твоем случае должен быть
C:\DOCUMENTS AND SETTINGS\NEVASILEVSKIY\МОИ ДОКУМЕНТЫ\1С БАЗЫ\BASE КУРГАН\BASE\EXTFORMS\FORMEX.GRP\FORMEX.DLL
71. Paully 07.05.09 08:43 Сейчас в теме
(67)
Не нахожу таковой закладки. 1C++ - есть. На этом - все.
72. Noy 1067 07.05.09 09:32 Сейчас в теме
(71) Значит формекс не обновлен. Запусти на "чистой" машине!
73. Paully 07.05.09 09:37 Сейчас в теме
(72)
Ничего не понимаю - что значит, что я не нахожу вкладки с ФормЕкс? И, я все скачивал с твоего топика. Зачем еще что-то обновлять?
74. Noy 1067 07.05.09 09:41 Сейчас в теме
(73) разберись со своими внешними компонентами. У тебя либо старый формекс подгружается, либо старый 1С++ (тот который содержит в себе формекс)
68. GSoft 2858 06.05.09 18:40 Сейчас в теме
69. Paully 07.05.09 08:29 Сейчас в теме
да, все так и есть - по поиску же ВСЕХ локальных дисков - все нашел и позаменял...
70. Paully 07.05.09 08:30 Сейчас в теме
но ничего не изменяется...
75. Paully 07.05.09 11:07 Сейчас в теме
Все нормально - обновил 1cpp.dll на 2.5.0.7-версию. Спасибо!
76. Noy 1067 07.05.09 12:15 Сейчас в теме
(75) Тут принято оценивать обработку: "+" или "-"...
а то куча усилий по запуску и ноль реакции - непонятно.
77. vip 07.05.09 12:36 Сейчас в теме
78. Paully 07.05.09 12:57 Сейчас в теме
79. vip 07.05.09 13:04 Сейчас в теме
(78) http://www.1cpp.ru/images/3/32/Icpp-latest.rar

Опасаться не надо. Нормальная, стабильная сборка.
И возможностей гораздо больше, чем в 2.5
2.5 больше развиваться не будет.
80. Paully 07.05.09 13:13 Сейчас в теме
(79) Спасибо за информацию!
81. artbear 1308 07.05.09 15:13 Сейчас в теме
(80) Добавлю к (79)
Не просто стабильная сборка, но в результате простого запуска 1С++ вся система 1С начнет работать быстрее :)
Например, СоздатьОбъект() будет работать намного быстрее, чем без 1С++ или даже со старыми версиями 1С++, где уже было ускорение.
И т.д. и т.п.
82. Paully 07.05.09 15:25 Сейчас в теме
понятно, спасибо, что учите меня, коллеги!
83. Paully 20.05.09 10:33 Сейчас в теме
Привет. Простите за офф-топ. Почему одни журналы (к примеру) в 1С 7.7 "захлопываются" клавишей Esc, а другие нет. (в режиме Предприятие, естесственно).
84. vip 20.05.09 10:43 Сейчас в теме
85. Noy 1067 20.05.09 10:50 Сейчас в теме
(83) По Esc закрываются только отчеты, обработки, документы, формы элементов справочника. Журналы и формы списка справочников закрываются по Esc только если они открыты в режиме выбора/подбора.
86. vip 20.05.09 10:53 Сейчас в теме
(85) Все правильно рассказал.
87. Paully 20.05.09 10:58 Сейчас в теме
Общий журнал документов в ТиС'е закрывается, остальные журналы - нет.
88. Abadonna 3891 20.05.09 12:03 Сейчас в теме
(87) У тебя там формекс случаем не висит на журнале? Или в глобальнике на
ПриНажатииКнопкиКлавиатуры()? Не могёт он стандартно закрываться по Esc
89. Paully 20.05.09 13:54 Сейчас в теме
на журнале - no formex.dll detected;
в глобальном - ничего подобного нет;
-------------------------------------
в чем же дело?
90. dumal 26.10.11 18:37 Сейчас в теме
Поставил в одной организации и забыл. Работают уже год, наверное. Это - самая лучшая рекомендация
Оставьте свое сообщение

См. также

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    88066    284    Serginio    74    

Внешняя компонента для преобразования файлов из/в кодировку Base64 в 1С 7.7

Разработка внешних компонент WEB v7.7 1cv7.md Абонемент ($m)

Эта внешняя компонента Base64.dll предназначена для платформы 1С версии 7.7. Используется для преобразования файлов из/в кодировку Base64 из встроенного языка 1С Предприятие. Компонента тестировалась на базе конфигурации Бухгалтерский учет для Казахстана, редакции 7.70.257.

1 стартмани

06.04.2021    799    1    softmaker    2    

Криптография: внешняя компонента для 1С 7.7

Разработка внешних компонент Защита и шифрование v7.7 Абонемент ($m)

Цифровые подписи, шифрование, просмотр сертификатов ключей ЭЦП, работа с различными криптопровайдерами (в т.ч. КриптоПРО ГОСТ 2012) в 1С 7.7.

1 стартмани

08.06.2020    3240    5    mdbruyfn    5    

Протокол UDP: внешняя компонента для 1С 7.7

Разработка внешних компонент v7.7 Абонемент ($m)

Обмен сообщениями и небольшими файлами по протоколу UDP с 1С и внешними приложениями в локальной сети или сети VPN.

1 стартмани

23.05.2020    2705    1    mdbruyfn    0    

Компоненты распознавания и печати штрих-кодов Промо

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    73326    88    igorberezhnov    101    

Клиент HTTP(S): внешняя компонента для 1С 7.7

Разработка внешних компонент WEB v7.7 Абонемент ($m)

Компонента позволит использовать различные веб-сервисы интернет-ресурсов, например работать с онлайн-кассой через API, предоставленное ее разработчиком. Тестировалась только на платформе 1С релиза 7.70.027.

1 стартмани

14.11.2019    7360    24    mdbruyfn    27    

ФФД 1.05 с драйверами Атол v10

Разработка внешних компонент Розничная торговля Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение кассы / фискального регистратора к 1С 7.7 через драйвер Атола v10.

1 стартмани

02.08.2019    12333    28    phsin    26    

Внешняя компонента Game.dll (таймер, ГСЧ, захват клавиатуры)

Разработка внешних компонент v7.7 Абонемент ($m)

Внешняя компонента для 1С 7.7 для работы с таймером, генератором случайных чисел и для захвата клавиатуры.

1 стартмани

29.04.2019    6362    1    Palmer1976    0    

Обработка для формирования классов для прямого доступа к файлам 1С через курсоры BDE. И многого другого Промо

Разработка внешних компонент v7.7 1cv7.md Абонемент ($m)

Обработка формирует классы для прямого доступа к файлам 1С через курсоры BDE. Исходник ВК, которая загружает Объект Автоматизации, поддерживающий ITypeInfo и выполняет все его свойства и методы через IlanguageExtender. Обработка для формирования диспинтерфейсов к объектам 1С (таблицаЗначений, справочники, документы, перечисления). Обработки для группировки данных Таблицы Значений в виде ТЗ, где колонками являются ключи и ТзПоГруппе вида ТЗ с детальными записями. Вывод иерархии из ТЗ элементов, поиск дублей, сравнение 2 ТЗ

1 стартмани

14.04.2015    21065    2    Serginio    1    

Поддержка выгрузки в Excel 2007 для 1С 7.7 в одну строку

Разработка внешних компонент Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Внешняя компонента 1С 7.7. для сохранения таблиц в формате Excel 2007.

1 стартмани

21.03.2019    13552    26    MadDAD    111    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    10279    1    pakko    7    

Разработка игр на языке 1С с использованием Active-X компоненты (собственная разработка)

Разработка внешних компонент v7.7 v8 Россия Абонемент ($m)

Написанная Active-X компонента встраивается на форму обработки 1С (тестировалось на 1С 8.0, 8.1, 8.2, 8.3 не управляемые формы, 1С 7.7.). Компонента предназначена для моделирования игрового поля (вывод, движение спрайтов - фреймов, обработка коллизий, управление спрайтами-фреймами и т.д.) при разработки логики игры на встроенном языке 1С. Приложен пример обработки в которой реализована игра "Бита".

5 стартмани

04.01.2018    16993    2    protexprotex    34    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    42475    320    asdfghgghjdhg    120    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    26969    79    crimeait    2    

1sqlite reborn

Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Обновленная версия внешней компоненты для работы с базами данных SQLite и прямыми запросы в ДБФ-базах 1С.

1 стартмани

07.11.2016    26973    21    Djelf    39    

Полноценное использование Drag&Drop в 1С 7.7

Работа с интерфейсом Разработка внешних компонент v7.7 1cv7.md Абонемент ($m)

Несмотря на то, что кое-какие функции Drag&Drop были заложены авторами 1cpp, моё дополнение позволяет сделать этот функционал законченным. Дело в том, что средствами 1cpp можно было таскать файлы ТОЛЬКО в 1С, а из 1С - невозможно. Теперь Вы можете сделать работу с файлами на порядок удобнее и эффективнее.

1 стартмани

19.09.2016    15668    14    DasIsFantastich    4    

Злоумышленник зашифровал базы 1С и другие файлы

Информационная безопасность Защита и шифрование v7.7 1cv7.md Абонемент ($m)

Звонит пользователь, на экране сообщение ваши данные зашифрованы, введите пароль, пишите письма и т.д.

1 стартмани

08.11.2014    35906    44    aleksch21    85    

Шаблон внешней компоненты для Lazarus (FreePascal)

Инструментарий разработчика Разработка внешних компонент v7.7 v8 Абонемент ($m)

Шаблон внешней компоненты COM для Lazarus (FreePascal)

1 стартмани

16.05.2014    17780    29    v77    5    

Отчет по правам пользователей для любой конфигурации "1С:Предприятия 7.7"

Информационная безопасность v7.7 1cv7.md Абонемент ($m)

Инструмент для наглядного анализа и сравнения наборов прав доступа в 1С 7.7 Работает в любых конфигурациях. В одной из обслуживаемых мной баз 40 наборов прав пользователей (120 пользователей). Этим отчетом очень наглядно выходит анализировать разницу в правах и просто описывать права пользователей в документации. Обновлено: - В новой версии отчета добавил сравнение двух разных баз и анализ внешней БД. - объекты метаданных представлены в виде дерева (объект "Дерево-Таблица значений" FormEx)

1 стартмани

11.02.2014    21511    139    Amel2010    15    

Tray Informer

Инструментарий разработчика Разработка внешних компонент Работа с интерфейсом v7.7 v8 Россия Абонемент ($m)

Согласитесь, что окно стандартное сообщений в 1С иногда приносит больше неудобств, чем пользы. И тем более разные "Предупредить"... Что с этим окном только не делают! Его отцепают от формы, делают маленьким, умудряются спрятать за границы экрана. А потом звонят программистам с претензией, что документ почему-то не проводится, отя ничего и не пишет. У вас такого не было? А вот у нас было и не раз )))

1 стартмани

04.09.2013    27469    60    O-Planet    78    

Работа с POS терминалом банка "Аваль" через компоненту POSAPI v 1.8 (7.7)

Разработка внешних компонент Розничная торговля POS терминал Розничная торговля v7.7 Розничная и сетевая торговля (FMCG) Украина Абонемент ($m)

При работе с COM-объектом POS терминала важно получать информацию о его состоянии для отображения пользователю и/или принятия решений. Но 1С 7.7 не воспринимает тип данных "С-строка". Выход был найден через компоненту-посредника (обертку) WSC.

1 стартмани

11.07.2013    20071    27    simply1    24    

Внешняя компонента для работы с ККМ Искра "Прим-07К"

Разработка внешних компонент Кассовые операции ККМ Фискальный регистратор Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    24219    64    sandyanf    3    

Проверка прав доступа текущего пользователя. 1с 7.7

Информационная безопасность v7.7 1cv7.md Украина Абонемент ($m)

Показывает права доступа текущего пользователя в базе 1с 7.7 .

1 стартмани

10.06.2013    17468    47    demon_sw    11    

Расширенные права пользователей для Торговля и Склад 7.7 (из режима "Предприятие" с детализацией по всем видам документов, справочников, отчетов и обработок)

Информационная безопасность v77::ОУ 1С7:ТиС Абонемент ($m)

Если вы обслуживаете Торговлю и Склад 7.7 и устали менять права на документы и справочники по заданию руководства и список Наборов прав стал просто нечитаемым, то вам сюда.

1 стартмани

05.02.2013    16920    43    malinko.vasiliy    5    

Индивидуальная установка даты запрета редактирования документов в торговле 1С 7.7

Информационная безопасность Закрытие периода Закрытие периода v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Установка даты запрета редактирования документов индивидуально для каждого пользователя,а также предоставление в индивидуальном порядке разрешения изменения конкретных документов в определенные периоды или в конкретные дни.Срок действия установок устанавливается вами. Вы можете спокойно настроить и уехать в отпуск.

1 стартмани

17.01.2013    25640    46    agent007_1    10    

Управление правами в 7.7 - "на лету" до каждой кнопочки!

Информационная безопасность v7.7 1cv7.md Абонемент ($m)

Система управления правами доступа "на лету" для конфигураций на платформе 1С:Предприятие 7.7. - Онлайн :: Не требует выхода пользователей. - Умная :: Позволяет управлять доступом хоть к каждой кнопке на форме. - Универсальная :: Встраивается в любую конфигурацию за 1 минуту! - Преемственная :: Сохраняет настройки существующих наборов прав.

1 стартмани

22.11.2012    27972    166    gavlexx    48    

Сканер штрих-кода клавиатурный 7.7 (внешняя компонента)

Разработка внешних компонент Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v77::ОУ 1С7:Комплекс 1С7:ТиС Россия БУ Абонемент ($m)

Работа с COM портом (ввод/вывод), генерация внешнего события. Перехват мыши и клавиатуры для отслеживания времени простоя 1С. Перехват цифрового ряда, генерируемого сканером ШК или ридером карт, подключенных как клавиатура (генерация внешнего события вместо ввода цифр в окно 1С)

1 стартмани

10.11.2012    9406    48    e-rogov    4    

Блокиратор запуска Информационной Базы

Администрирование данных 1С Информационная безопасность v7.7 1cv7.md Абонемент ($m)

Блокирует запуск Информационной базы при входе пользователя

1 стартмани

25.10.2012    11322    14    sam-soft    9    

Пример работы с Web камерой (WIA)

Разработка внешних компонент v7.7 Абонемент ($m)

Делаем фото с веб камеры. Используем стандартную библиотеку Windows Image Acquisition Automation Library. Библиотеку wiaaut.dll качаем (из инета, бесплатно), регистрируем командой regsvr32.

1 стартмани

23.10.2012    33168    151    via    19    

Список баз 1С 7

Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Скрипт на VBS Подключает базы клиенту на основании вхождения данного пользователя в нужную группу Active Directory. Может использоваться в групповых политиках, либо в качестве стартера 1С7

1 стартмани

17.08.2012    11540    7    zebr    1    

Beep

Разработка внешних компонент v7.7 openconf 1cv7.md Россия Абонемент ($m)

Программа Бипер. Простенький скрипт с простенькой командой.

1 стартмани

18.04.2012    9653    11    l2d808    1    

Внешняя компонента для подключения к 1С охранного оборудования производства фирмы Bolid

Внешние источники данных Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Компонента для считывания ID магнитного ключа посредством охранного оборудованием производства фирмы Bolid (http://www.bolid.ru) через 1С

1 стартмани

04.04.2012    14918    26    andy_zhav    1    

Температура в 1С

Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Внешняя компонента (для 7.7 и 8.хх) позволяющая работать с сетью microLAN и устройствами с интерфейсом 1-Wire а именно получать значения температуры от датчиков DS18B20 и DS18S20 непосредственно в 1С.

1 стартмани

01.04.2012    13110    26    pophmail    14    

Батник обновления КЛАДР для 1С версии 7.7

Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Скрипт обновления файлов КЛАДР. Wget качает, а 7zip извлекает.

1 стартмани

23.03.2012    9276    21    voler    5    

"License HDD" v1.0.1.0

Администрирование данных 1С Информационная безопасность Практика программирования v7.7 1cv7.md Россия Абонемент ($m)

Предназначена для привязки базы данных к жесткому диску.

1 стартмани

10.02.2012    11343    20    iSezam    7    

Права доступа текущего пользователя

Информационная безопасность openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Печать прав доступа текущего пользователя

1 стартмани

25.01.2012    15368    62    Ягг    9    

Блокировка клавиши Esc ("Прервать выполнение...?") в "1С:Предприятие 7.7"

Практика программирования Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Способ блокировки мне рассказал Аркадий (Abadonna), а я только записал его рассказ на С++.

5 стартмани

07.01.2012    19585    52    hogik    23    

Редактирование набора прав в Универсальном конструкторе отчетов (Новейший отчет) для 1C 7.7

Информационная безопасность v7.7 openconf 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Россия Абонемент ($m)

Редактирование набора прав в Универсальном конструкторе отчетов (Новейший отчет) для 1C 7.7( далее УКО ) Данная обработка помогает в выставлении прав на тот или иной отчет, запускаемый из "УКО".

1 стартмани

09.12.2011    15520    18    serpent    1