Функция получения даты из текста по форматной строке

Публикация № 200111

Разработка - Инструментарий разработчика

11
Преобразует текст в дату при условии наличия форматной строки

Несколько громоздская, но полезная функция.

Добавил распознование строковых месяцев, но только на русском языке.

Очень красивое решение предоставил ildarovich, советую использовать сразу его код:

Функция СтрокаВДату(Знач ФорматДаты, Знач Дано, Ошибка = Ложь) Экспорт 
	Попытка 
		ё = Формат('00010101', "ДФ=" + ФорматДаты) // - необязательная проверка первого правильности параметра 
	Исключение 
		Ошибка = Истина; 
		Возврат '00010101' 
	КонецПопытки; 
	Ч = Новый Соответствие; 
	Для ё = 1 По СтрДлина(ФорматДаты) + 7 Цикл 
		Ч[Сред(ФорматДаты + "dMyHhms", ё, 1)] = 0	// - инициализация частей даты 
	КонецЦикла; 
	Для ё = 1 По 12 Цикл 
		Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами 
		Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMМ" ), Формат(ё, "ЧЦ=3; ЧВН=")) 
	КонецЦикла; 
	Для ё = 1 По СтрДлина(ФорматДаты) Цикл 
		Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Дано, ё, 1)); // - накопление частей даты 
		Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, ё, 1)) И НЕ Найти("0123456789", Сред(Дано, ё, 1)) // - необязательная проверка на цифры 
	КонецЦикла; 
	Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех 
	Попытка 
		Возврат Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"]) 
	Исключение 
		Ошибка = Истина; 
		Возврат '00010101' 
	КонецПопытки 
КонецФункции

Моя функция:

Функция ПолучитьДатуИзТекста(Текст,ФорматнаяСтрока) Экспорт
	Перем Значение;
	
	ПустаяДата = '00010101';
	Год = 1; Месяц=1; День = 1; час = 0; Мин=0; Сек=0;
	тмпТекст = Текст;
	ЗначащиеСимволы = "dMyHhms";
	СтрокаПараметра = "";
	ФорматнаяСтрока = СокрЛП(ФорматнаяСтрока)+" ";
	ПредСимв = Лев(ФорматнаяСтрока,1);
	Для к=1 по СтрДлина(ФорматнаяСтрока) Цикл
		Симв = Сред(ФорматнаяСтрока,к,1);
		Если ПредСимв<>Симв Тогда
			Если Найти(ЗначащиеСимволы,ПредСимв)>0 Тогда
				//ЭтоПараметр
				Если СтрДлина(СтрокаПараметра)=2 Тогда
					Попытка
						Значение = Число(Лев(тмпТекст,2));
					Исключение
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецПопытки;
					
					тмпТекст = Сред(тмпТекст,3);
				ИначеЕсли СтрокаПараметра="yyyy" Тогда
					Попытка
						Значение = Число(Лев(тмпТекст,4));
					Исключение
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецПопытки;
					тмпТекст = Сред(тмпТекст,5);
				ИначеЕсли СтрДлина(СтрокаПараметра)=1 Тогда
					дл = "";
					Попытка
						Значение = Число(Лев(тмпТекст,2));
					Исключение
						Попытка
							Значение = Число(Лев(тмпТекст,1));
							дл=1;
						Исключение
							#Если Клиент Тогда
								Предупреждение("Не удалось выполнить преобразование!");
							#КонецЕсли
							Возврат ПустаяДата;
						КонецПопытки;
					КонецПопытки;
					
					Если дл="" Тогда
						Если (СтрокаПараметра = "d" и Значение>31)ИЛИ(СтрокаПараметра = "M" и Значение>12)ИЛИ(СтрокаПараметра = "H" и Значение>23)
							ИЛИ(СтрокаПараметра = "h" и Значение>12)ИЛИ(СтрокаПараметра = "m" и Значение>59)ИЛИ(СтрокаПараметра = "s" и Значение>59) Тогда
							Попытка
								Значение = Число(Лев(тмпТекст,2));
								дл=2;
							Исключение
								#Если Клиент Тогда
									Предупреждение("Не удалось выполнить преобразование!");
								#КонецЕсли
								Возврат ПустаяДата;
							КонецПопытки;
						Иначе
							Попытка
								Значение = Число(Лев(тмпТекст,1));
								дл=1;
							Исключение
								#Если Клиент Тогда
									Предупреждение("Не удалось выполнить преобразование!");
								#КонецЕсли
								Возврат ПустаяДата;
							КонецПопытки;
						КонецЕсли;	
					КонецЕсли;	
					
					тмпТекст = Сред(тмпТекст,дл+1);
				ИначеЕсли СтрокаПараметра="MMM" или СтрокаПараметра="MMMM" Тогда
					Значение = 0;
					Для м=1 по 12 Цикл
						ТекстМесяца = Сред(Формат(Дата(2000,м,1),"ДФ=d."+СтрокаПараметра),3);
						Если Найти(тмпТекст,ТекстМесяца)>0 Тогда
							Значение = м;
							Прервать;
						КонецЕсли;
					КонецЦикла;
					Если Значение = 0 Тогда
						#Если Клиент Тогда
							Предупреждение("Не удалось выполнить преобразование!");
						#КонецЕсли
						Возврат ПустаяДата;
					КонецЕсли;
					тмпТекст = Сред(тмпТекст,СтрДлина(ТекстМесяца)+1);
				Иначе
					#Если Клиент Тогда
						Предупреждение("Не верный формат даты или форматной строки!");
					#КонецЕсли
					Возврат ПустаяДата;
				КонецЕсли;
				
				//Установим параметры
				Если ПредСимв = "d" Тогда
					День = Значение;
				ИначеЕсли ПредСимв = "M" Тогда
					Месяц = Значение;
				ИначеЕсли ПредСимв = "y" Тогда
					Если СтрокаПараметра = "yy" Тогда
						ТекВек = 100*Цел(Год(ТекущаяДата())/100);
						год = ?(Значение>=Год(ТекущаяДата())-текВек+50,ТекВек-100,ТекВек)+Значение;
					Иначе
						Год = Значение;
					КонецЕсли;
				ИначеЕсли ПредСимв = "H" Тогда
					час = Значение;
				ИначеЕсли ПредСимв = "h" Тогда
					час = Значение;
					#Если Клиент Тогда
						Сообщить("Вычисление часа не гарантировано.");
					#КонецЕсли
				ИначеЕсли ПредСимв = "m" Тогда
					Мин = Значение;
				ИначеЕсли ПредСимв = "s" Тогда
					Сек = Значение;
				КонецЕсли;
				
			Иначе
				//Это Разделитель
				тмпТекст = Сред(тмпТекст,СтрДлина(СтрокаПараметра)+1);
			КонецЕсли;
			СтрокаПараметра = Симв;
		Иначе
			СтрокаПараметра=СтрокаПараметра+Симв;
		КонецЕсли;
		ПредСимв = Симв;
	КонецЦикла;
	Возврат Дата(Год,Месяц,День,час,Мин,Сек);
КонецФункции		
11

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Поручик 4333 09.09.13 01:35 Сейчас в теме
(0) Вместо Предупреждение() лучше использовать Сообщить().
2. kapustinag 09.09.13 08:36 Сейчас в теме
(0) Вот в этом месте нужно более интеллектуально:
Если СтрокаПараметра = "yy" Тогда
Год = 2000+Значение;

Если Значение="99", то год должен быть 1999, а если ="13", то год 2013. Часто применяют сравнение с 50. Если значение меньше 50, то считаем нынешний век, а если больше - двадцатый век. Впрочем, это уже зависит от смысла ожидаемых данных. Может быть, на Ваших данных именно Ваше условие правильное.
6. Crazy Professor 19 24.09.13 08:58 Сейчас в теме
(2) kapustinag,
Кстати да, но я не знаю по какому принципу 1с сама это дело конвертирует у меня переключает на прошлый век с 30 включительно, но я не уверен, что это как-то зависит от текущей даты.

Сделал так:

ТекВек = 100*Цел(Год(ТекущаяДата())/100);
год = ?(Значение>=Год(ТекущаяДата())-текВек+50,ТекВек-100,ТекВек)+Значение;
3. ildarovich 6741 09.09.13 17:19 Сейчас в теме
В статье Выразить строку как число и строку как дату в запросе показано, как тоже самое можно сделать в запросе. Ну а данное решение нужно сократить раз в десять - объем кода не соответствует сложности решаемой задачи.
7. Crazy Professor 19 24.09.13 09:07 Сейчас в теме
(3) ildarovich,
Предложите готовое решение, пожалуйста - я с радостью его применю для своих целей.
Статья занятная, но не уверен, что универсальное решение будет менее громоздким чем обычный код. Однако, для больших объемов данных применение запроса может увеличить производительность.
11. ildarovich 6741 25.09.13 00:42 Сейчас в теме
(7) Вот готовое решение
//
Функция СтрокаВДату(Знач ФорматДаты, Знач Дано, Ошибка = Ложь) Экспорт
    Попытка 
        ё = Формат('00010101', "ДФ=" + ФорматДаты) // - необязательная проверка первого правильности параметра
    Исключение
        Ошибка = Истина;
        Возврат '00010101'
    КонецПопытки;
    Ч = Новый Соответствие;
    Для ё = 1 По СтрДлина(ФорматДаты) + 7 Цикл
        Ч[Сред(ФорматДаты + "dMyHhms", ё, 1)] = 0	// - инициализация частей даты
    КонецЦикла;
    Для ё = 1 По 12 Цикл
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН=")); // - замена названий месяцев числами
        Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMМ" ), Формат(ё, "ЧЦ=3; ЧВН="))
    КонецЦикла;
    Для ё = 1 По СтрДлина(ФорматДаты) Цикл
        Ч[Сред(ФорматДаты, ё, 1)] = 10 * Ч[Сред(ФорматДаты, ё, 1)] + Найти("123456789", Сред(Дано, ё, 1)); // - накопление частей даты
        Ошибка = Ошибка ИЛИ Найти("dMyHhms", Сред(ФорматДаты, ё, 1)) И НЕ Найти("0123456789", Сред(Дано, ё, 1)) // - необязательная проверка на цифры
    КонецЦикла;
    Ч["y"] = Ч["y"] + ?(Ч["y"] < 50, 2000, ?(Ч["y"] < 100, 1900, 0)); // - дополнение двух цифр года до четырех
    Попытка  
        Возврат Дата(Ч["y"], Ч["M"], Ч["d"], Ч["H"] + Ч["h"], Ч["m"], Ч["s"])
    Исключение
        Ошибка = Истина;
        Возврат '00010101'
    КонецПопытки
КонецФункции
//
Показать
rise; Valkiriyaaaa; Crazy Professor; bulpi; +4 Ответить
12. Crazy Professor 19 02.10.13 10:02 Сейчас в теме
(11) ildarovich,
Ну да, я ламмер, очень изящно - преклоняю колено.
15. kuzyara 809 30.08.16 06:24 Сейчас в теме
(12) код (11) с ошибками.
Январь прописью не проходит, зачем-то "h" парсит и т.д.
13. Crazy Professor 19 02.10.13 10:03 Сейчас в теме
(11) ildarovich,
Можно вынести в шапку с указанием авторства? Вдруг кому нужно будет.
14. ildarovich 6741 02.10.13 11:05 Сейчас в теме
(13) Да, конечно, пожалуйста. Только просьба стандартные отступы восстановить (они пропали при вставке кода в комментарий).
25. rise 12.07.19 10:56 Сейчас в теме
(11) Круто, но к сожалению некорректно обрабатывает форматы "d" и "M", когда число знаков переменное. d.M.yyyy дает 12.7.2019

И в этой строке кажется надо в формат числа добавить ЧГ=0
Дано = СтрЗаменить(Дано, Формат(Дата(1, ё, 1), "ДФ=MMММ"), Формат(ё, "ЧЦ=4; ЧВН="));
4. spetzpozh 10.09.13 14:35 Сейчас в теме
Сообщить(), если учитывать рекомендации 1С, использовать не стоит вообще никогда :) СообщениеПользователю есть.
5. diver.sun 21 11.09.13 11:13 Сейчас в теме
Почитал, подумал, написал свой вариант, жутко не экономично, но зато абсолютно универсально
Процедура КнопкаВыполнитьНажатие(Кнопка)
	лФорматнаяСтрока = "Л=en; ДФ='yyyy МММ dd HH/mm/s'";
	лСтрокаДаты = "2013 Sep 11 09/58/5";
	
	
	лМассивДатНачальный = Новый Массив;
	лМассивДатНачальный.Добавить(1900);
	лМассивДатНачальный.Добавить(1);
	лМассивДатНачальный.Добавить(1);
	лМассивДатНачальный.Добавить(0);
	лМассивДатНачальный.Добавить(0);
	лМассивДатНачальный.Добавить(0);

	
	лДиапазонГода = ВернутьДиапазонЗначимыхЗначений(0,1999,2001,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,0,1900,2100,лФорматнаяСтрока,лДиапазонГода,лСтрокаДаты);
	
	лДиапазонМесяца = ВернутьДиапазонЗначимыхЗначений(1,1,12,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,1,1,12,лФорматнаяСтрока,лДиапазонМесяца,лСтрокаДаты);
	
	лДиапазонДаты = ВернутьДиапазонЗначимыхЗначений(2,1,31,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,2,1,31,лФорматнаяСтрока,лДиапазонДаты,лСтрокаДаты);
	
	лДиапазонЧаса = ВернутьДиапазонЗначимыхЗначений(3,0,23,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,3,0,23,лФорматнаяСтрока,лДиапазонЧаса,лСтрокаДаты);
	
	лДиапазонМинуты = ВернутьДиапазонЗначимыхЗначений(4,0,59,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,4,0,59,лФорматнаяСтрока,лДиапазонМинуты,лСтрокаДаты);
	
	лДиапазонСекунды = ВернутьДиапазонЗначимыхЗначений(5,0,59,лФорматнаяСтрока);
	ПодобратьЗначение(лМассивДатНачальный,5,0,59,лФорматнаяСтрока,лДиапазонСекунды,лСтрокаДаты);
	
	РезДата = Дата(лМассивДатНачальный[0],лМассивДатНачальный[1],лМассивДатНачальный[2],лМассивДатНачальный[3],лМассивДатНачальный[4],лМассивДатНачальный[5]);	
КонецПроцедуры

Процедура ПодобратьЗначение(пМассивПараметровДаты,лНомерПараметра,пСтарт,пСтоп,пФорматнаяСтрока,пСтрПоложения,пРазбираемаяСтрока)
	Если пСтрПоложения.С = -1 Тогда
		Возврат;
	КонецЕсли;
	Для Ном = пСтарт по пСтоп Цикл
		пМассивПараметровДаты[лНомерПараметра] = Ном;
		лДата = Дата(пМассивПараметровДаты[0],пМассивПараметровДаты[1],пМассивПараметровДаты[2],пМассивПараметровДаты[3],пМассивПараметровДаты[4],пМассивПараметровДаты[5]);
		лСтрПредставленияДаты = Формат(лДата,пФорматнаяСтрока);
		Если Сред(пРазбираемаяСтрока,пСтрПоложения.С,пСтрПоложения.По-пСтрПоложения.С+1) = Сред(лСтрПредставленияДаты,пСтрПоложения.С,пСтрПоложения.По-пСтрПоложения.С+1) Тогда
			Прервать;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Функция ВернутьДиапазонЗначимыхЗначений(лНомерПараметра,пСтарт,пСтоп,пФорматнаяСтрока)
	лМассивПараметров = Новый Массив;
	лМассивПараметров.Добавить(1900);
	лМассивПараметров.Добавить(1);
	лМассивПараметров.Добавить(1);
	лМассивПараметров.Добавить(0);
	лМассивПараметров.Добавить(0);
	лМассивПараметров.Добавить(0);
	лДатаНачальная = Дата(лМассивПараметров[0],лМассивПараметров[1],лМассивПараметров[2],лМассивПараметров[3],лМассивПараметров[4],лМассивПараметров[5]);
	лСтрПредставление = Формат(лДатаНачальная,пФорматнаяСтрока);
	
	лСтрРазностная = Новый Структура("С,ПО",10000,-1);
	
	Для лНом = пСтарт по пСтоп Цикл
		лМассивПараметров[лНомерПараметра] = лНом;
		лСтрНовая = Формат(Дата(лМассивПараметров[0],лМассивПараметров[1],лМассивПараметров[2],лМассивПараметров[3],лМассивПараметров[4],лМассивПараметров[5]),пФорматнаяСтрока);
		Если лСтрПредставление <> лСтрНовая Тогда
			СтрРазличий = ВернутьСтрРазличияВСтроках(лСтрПредставление,лСтрНовая);
			лСтрРазностная.С = Мин(лСтрРазностная.С,СтрРазличий.С);
			лСтрРазностная.ПО = Макс(лСтрРазностная.ПО,СтрРазличий.ПО);
		КонецЕсли;
	КонецЦикла;
	Если лСтрРазностная.С = 10000 Тогда
		лСтрРазностная.С = -1;
	КонецЕсли;
	Возврат лСтрРазностная; 
КонецФункции

Функция ВернутьСтрРазличияВСтроках(пСтрока1,пСтрока2)
	пПервыйРазличныйСимвол = -1;
	пПоследнийРазличныйСимвол = -1;
	Для Ном = 1 по СтрДлина(пСтрока1) Цикл
		Если Сред(пСтрока1,Ном,1) =  Сред(пСтрока2,Ном,1) И пПервыйРазличныйСимвол <> -1 Тогда
			пПоследнийРазличныйСимвол = Ном - 1;
			Прервать;
		ИначеЕсли Сред(пСтрока1,Ном,1) <>  Сред(пСтрока2,Ном,1) И пПервыйРазличныйСимвол = -1 Тогда
			пПервыйРазличныйСимвол = Ном;
		КонецЕсли;
	КонецЦикла;
	Если пПоследнийРазличныйСимвол = -1 Тогда
		пПоследнийРазличныйСимвол = СтрДлина(пСтрока1);
	КонецЕсли;
	Возврат Новый Структура("С,ПО",пПервыйРазличныйСимвол,пПоследнийРазличныйСимвол);
	
КонецФункции
Показать
8. Crazy Professor 19 24.09.13 09:37 Сейчас в теме
(5) diver.sun,
Чего-то я не понял как эта обработка должна отрабатывать при изменении порядка элементов форматной строки или вообще при исчезновении некоторых (например такой "yyMMdd", из данных с которыми я работаю). Но идея занятная - от обратного. В упрощенном варианте можно было перебирать все значения с точностью до секунды от -50 до +50 лет от текущей даты и искать подходящее через запрос :).
9. diver.sun 21 24.09.13 10:43 Сейчас в теме
Тогда она не находит позиции старта стопа изменяемого значения.
10. Crazy Professor 19 24.09.13 10:58 Сейчас в теме
(9) diver.sun, твой метод дал идею по распознаванию месяцев строкового формата.
16. Xershi 734 20.04.18 16:46 Сейчас в теме
Кому интересно повозиться сервер вернул дату формата: "Tue, 10 Oct 2017 15:25:00 +0300".
Форматная строка выходит "Л=en; ДФ='ddd, dd MMM yyyy HH:mm:ss'" плюс часовой пояс.
17. smaharbA 08.11.18 17:14 Сейчас в теме
(16)
"Tue, 10 Oct 2017 15:25:00 +0300"


Пока СтрНайти(Стр,"  ")>0 Цикл
	Стр=СтрЗаменить(Стр,"  ","");
КонецЦикла;
МассивДаты=СтрРазделить(Стр," ");
Для ч=1 По 12 Цикл
	Стр=Прав("0"+ч,2);
	Если ВРег(МассивДаты[2])=ВРег(Формат(Дата("2018"+Стр+"01000000"),"Л=en; ДФ='MMM'")) Тогда
		Сообщить(Дата(МассивДаты[3]+Стр+МассивДаты[1]+СтрЗаменить(МассивДаты[4],":",""))+(60*60*5));
		Возврат;
	КонецЕсли;
КонецЦикла;
Показать
18. spacecraft 08.11.18 17:18 Сейчас в теме
(17)
Пока СтрНайти(Стр," ")>0 Цикл
Стр=СтрЗаменить(Стр," ","");
КонецЦикла;
МассивДаты=СтрРазделить(Стр," ");

Вот это можно описать одной строкой:
МассивДаты=СтрРазделить(Стр," ", Ложь);
19. smaharbA 14.11.18 15:57 Сейчас в теме
Можно, но лучче заменять все двойные пробелы на один.
20. spacecraft 14.11.18 16:40 Сейчас в теме
21. dobrynin.i.s 93 19.11.18 02:42 Сейчас в теме
функцию привожу из https://infostart.ru/public/886103/

Функция ПолучитьДатуВремяИзСтроки(ДатаВремя) Экспорт
	
	Результат = Неопределено;
	ДатаВремя = СтрЗаменить(ДатаВремя, "-", "");
	ДатаВремя = СтрЗаменить(ДатаВремя, ":", "");
	Если СтрДлина(ДатаВремя) - Найти(ДатаВремя, " ") = 5 Тогда // время в формате Ч:ММ:СС
		ДатаВремя = СтрЗаменить(ДатаВремя, " ", "0");
	ИначеЕсли Найти(ДатаВремя, "T") > 0 Тогда //время в формате ГГГГММДДTЧЧММСС
		ДатаВремя = СтрЗаменить(ДатаВремя, "T", "");
	Иначе // время в формате ЧЧ:ММ:СС
		ДатаВремя = СтрЗаменить(ДатаВремя, " ", "");
	КонецЕсли;
	
	ОписаниеТипа = Новый ОписаниеТипов("Дата");
	Результат = ОписаниеТипа.ПривестиЗначение(ДатаВремя);  // дата и время в виде "ГГГГММДДЧЧММСС"
	Если Не ЗначениеЗаполнено(Результат) Тогда
		Результат = ОписаниеТипа.ПривестиЗначение(Лев(ДатаВремя, 8));  // только дата "ГГГГММДД"
	КонецЕсли;

	Возврат Результат;
	
КонецФункции
Показать
22. user1040271 23.11.18 11:50 Сейчас в теме
(21)
Что-то не уверен, что эта функция универсальна, поскольку не задается ожидаемый формат.
Как он интерпретирует 11.11.11? Или 11.11 или 11?
Думаю, что она работает только с фиксированными форматами, используемыми в конкретно той задаче для работы с http
23. dobrynin.i.s 93 25.11.18 03:00 Сейчас в теме
(22)
в коде есть пояснения

11.11 или 11 - это вообще не даты.
11.11 ещё можно догадатся что 11.11.2018 - текущий год (2018), а
11 - что такое год , месяц, день или секунда
24. user1040271 26.11.18 10:25 Сейчас в теме
(23)
Об этом и речь - только по данным не всегда можно точно определить формат, особенно по единичному элементу этих данных.
Если есть ограниченный набор вариантов - то тут, конечно, не проблема: в коде отработать исключения (убрать "Т", например). Уверен, что большинство тут решало такие задачи в ходе своей практики.
Но универсальные методы на то и универсальные, что бы не привязываться к конкретным случаям.
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 135

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    8415    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 338

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    12429    ids79    44       

Отслеживание выполнения фонового задания 139

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    10011    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 250

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    13205    ids79    30       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 129

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    11973    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 139

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    10357    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 181

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    7359    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 208

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    20273    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 178

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12538    dmurk    134       

Регистры накопления. Структура хранения в базе данных 175

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    18525    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    10879    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    5598    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    8296    m-rv    16       

О расширениях замолвите слово... 193

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    17583    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    13557    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    13917    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 165

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    16992    ids79    9       

Git + 1С. Часть 2. Реализация Git workflow в 1С-разработке по шагам 129

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

В этой части мы рассмотрим наиболее распространённую схему workflow при групповой разработке с использованием Git. Как приступить к доработке по поставленной задаче; исправить ошибку, обнаруженную на этапе тестирования; отправить свой код на слияние в предстоящий релиз; и т.д. Постараемся охватить большинство задач, составляющих основной цикл разработки

28.01.2019    10412    stas_ganiev    18       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    22776    ids79    72       

[8.3] Анализ планов запросов (Управляемая консоль отчетов) 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Консоль запросов

Новый инструмент! Позволяет удобно работать с планами запросов, анализ планов в файловой базе.

19.11.2018    14502    Evg-Lylyk    6       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    21663    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22024    ids79    40       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 277

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    36263    stas_ganiev    72       

Вспомогательные инструкции в коде 1С 105

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21344    tormozit    100       

Произвольный код в фоновом режиме 165

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    15433    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    22557    Rain88    42       

Практика применения инструментов продвинутого разработчика 1С 155

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Статья адресована разработчикам. Будет чуть-чуть теории, будут воспоминания, и потом пойдет практика.

23.07.2018    20162    artbear    22       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19912    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 155

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25366    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21905    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    17719    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11878    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 129

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    26050    avfed@rambler.ru    19       

Минимализмы 3 354

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    36816    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26366    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21854    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 731

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    141914    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    23479    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21775    unichkin    18       

Разбираемся с настройками компоновки данных 160

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24843    json    9       

Легкий способ обновления измененной конфигурации 41

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Легкий способ обновления измененной конфигурации. Сервис подготовки расширения конфигурации

25.10.2017    18964    avk72    63       

Работа с Excel 297

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    26606    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    48440    bugtester    43       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 127

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    34970    tormozit    72