IE2017

Проверка по схеме XML-файла (валидация по XSD)

Обработки - Универсальные обработки

Обработка позволяет проводить проверку по схеме (валидацию) XML-файлов в среде Windows

Довольно часто возникает необходимость проверки соответствия XML-файлов представленной схеме (XSD), но под рукой не оказывается программы, обладающей этим функционалом. Представляемая Вашему вниманию обработка очень компактна, не требует установки, и позволяет справиться с этой задачей в среде 1С:Предприятие 8.2 и выше под Windows.

Системные требования: необходимо наличие служб MSXML 6.0. Во всех современных версиях Windows (начиная с Vista и позже) они присутствуют после установки. Если же версии Windows старые (XP/2003), тогда может понадобиться их установка (взять можно здесь), но, скорее всего, даже на этих версиях Windows они уже установлены, если система периодически обновляется. Так что рекомендую сначала попробовать обработку, и только в случае неудачи устанавливать службы MSXML 6.0.

Скачать файлы

Наименование Файл Версия Размер
ВалидацияXML.epf
.epf 13,57Kb
02.10.13
138
.epf 1.00 13,57Kb 138 Скачать

См. также

Комментарии
1. Яков Коган (Yashazz) 2103 03.10.13 12:22 Сейчас в теме
Абсолютно бесполезная вещь.
Открою страшный секрет: валидность с точки зрения утилит msxml и с точки зрения 1С - совершенно разные вещи. Будьте готовы к тому, что файл, признанный валидным, не сработает, вызовет вылетание платформы, просто никак не прочитается и прочая. Аналогично, валидность xsd-схемы как таковой для большинства нормальных приложений и для 1С - разная. Многие схемы просто не грузятся, причём 1С ничего вообще не сообщает - тихо игнорит и всё. Фабрика может не скушать xsd, xml может "не подойти", хоть его 100% подгоняй, и прочее.
Например, полезнейшая штука построения xsd по имеющемуся файлу xml выдаёт схему, которую легко читают и понимают все, кроме 1С.

Это я к чему - имея дело с xml-механикой 1С, не полагайтесь на НЕ-1Сные фичи.
2. andrewks 1202 03.10.13 12:43 Сейчас в теме
(1) Yashazz, собственно, я и не позиционировал обработку как проверялку для закачки файлов парсером 1С.

обработка делает ровно то, что и заявлено - проверяет файл на соответствие стандарту XML и приложенной схеме XSD.
лично я очень часто использую этот функционал при:
1. написании и отладки кода по формированию/выгрузке xml-файлов для сторонних приложений/сервисов, когда структура оговорена схемой
2. после отладки - внедряю в код для выгрузки автоматическую проверку выгруженного файла по схеме. позволяет сэкономить время, укорачивая цепочку - многие ошибки сразу показываются при выгрузке, а не после закачки на какой-нибудь портал.

P.S. открою секрет - абсолютно бесполезных вещей не бывает! бывают бесполезные для кого-то
Светлый ум; +1 Ответить 1
3. andrewks 1202 03.10.13 13:10 Сейчас в теме
(1) Yashazz, поскольку форум проглючил, и сообщение не сохранилось, повторю кратко:

а сторонний функционал (msxml) был выбран именно потому, что я довольно пообщался с функционалом 1С касательно xml/xsd, чтобы опасаться его использовать в этом вопросе
starik-2005; +1 Ответить 1
4. Яков Коган (Yashazz) 2103 03.10.13 13:21 Сейчас в теме
(2),(3) А, ну "тады да". Тогда вопросов больше не имею. Если 1С-ные грабли известны, и сторонний функционал взят нарочно, то, может, это и правда best practice.
5. Данила Елистратов (CagoBHuK) 27 09.10.13 14:33 Сейчас в теме
Всем: пользуйтесь Altova XML Spy.
6. andrewks 1202 09.10.13 14:40 Сейчас в теме
(5) CagoBHuK, ничего, что он платный?
7. Данила Елистратов (CagoBHuK) 27 09.10.13 14:46 Сейчас в теме
(6) При желании можно найти и бесплатный аналог, и лекарство от жадности. А вообще нормальный программист найдет денег для того, чтобы купить себе хороший инструмент.
8. andrewks 1202 09.10.13 15:02 Сейчас в теме
(7) CagoBHuK,
А вообще нормальный программист найдет денег для того, чтобы купить себе хороший инструмент.

нормальный программист может также найти время на написание инструмента самому, не так ли?
starik-2005; +1 Ответить 1
9. Данила Елистратов (CagoBHuK) 27 09.10.13 15:31 Сейчас в теме
(8) Да, но сначала он задастся следующими вопросами:
  • Зачем изобретать велосипед?
  • Будет ли потраченное время стоить тех денег, которые придется заплатить за уже существующий инструмент?
10. andrewks 1202 09.10.13 16:42 Сейчас в теме
(9) CagoBHuK, я оценил, и решил, что быстрее и дешевле написать самому обработочку, юзающую msxml, и пользоваться. тем более, что больше от альтовы мне ничего не надо (кроме валидации). и даже решил поделиться с общественностью

раз в винде заложен данный функционал - почему бы им не воспользоваться? ну, а у кого есть лишние деньги - пусть покупают хоть альтову, хоть другое ПО - я ж не против.

только не пойму, какой смысл агитировать за покупку коммерческого ПО в камментах к бесплатному продукту
11. Данила Елистратов (CagoBHuK) 27 09.10.13 16:46 Сейчас в теме
(10) Я никого ни к чему не агитирую. Я специально сделал приписку, что при желании можно найти бесплатный продукт.
12. Ёпрст (Ёпрст) 1021 09.10.13 16:47 Сейчас в теме
Эээ.. а в штатном снеговике разве нет валидации по схеме ?
..
13. andrewks 1202 09.10.13 17:06 Сейчас в теме
(12) Ёпрст, лично у меня не получилось это сделать со штатным функционалом. если есть реально рабочий пример - милости просим
14. Ёпрст (Ёпрст) 1021 09.10.13 18:09 Сейчас в теме
Я не проверял, мне лень, как то валидацию, в своих поделках повыкидывал, за ненадобностью.
starik-2005; +1 Ответить
15. Сергей Кудашкин (sikuda) 497 17.03.15 14:16 Сейчас в теме
Да чего-то Microsoft Validator это конечно лучше, чем от 1С но тоже есть непонятки. Altova тоже советую...
16. Юрий Зайцев (Yury1001) 1429 31.03.15 16:31 Сейчас в теме
Спасибо, огромное, искал аж с ног сбился - декларант-алко не запускается, а файлы перед отправкой проверить хочется.
+1
17. Роман Зиновьев (Широкий) 694 16.12.15 14:15 Сейчас в теме
Пытался проверить файл по схеме ЕГАИС:

==================================================================
16.12.2015 14:14:18: Начата проверка по схеме файла: C:\111.xml
Не удалось подключить схему: C:\ЕГАИС\xsd\WB_DOC_SINGLE_01.xsd
16.12.2015 14:14:18: Проверка завершена
============================================================­======
18. andrewks 1202 22.12.15 23:00 Сейчас в теме
(17) и что именно непонятно? написано же, что не смог подключить схему. значит, нужно проверить наличие файла схемы, а также его корректность
19. Максим (nikulin76) 122 25.02.16 16:17 Сейчас в теме
На схемы от ЦБ тоже ругается
... Не удалось подключить схему: ...
RomanUzmov; +1 Ответить 2
20. Роман Узьмов (RomanUzmov) 42 15.03.16 19:19 Сейчас в теме
(19) nikulin76, Аналогичная ситуация
21. andrewks 1202 16.03.16 23:40 Сейчас в теме
(19) nikulin76, попробуйте такой вариант
Прикрепленные файлы:
ВалидацияXML_1.01.epf
22. Евгений Кольев (EvgKo) 31.10.16 21:57 Сейчас в теме
Добрый день!
При валидации ХМЛ-файла с помощью данной обработки выдается сообщение:

"Обнаружена ошибка:
Смещение = 612, строка = 8, позиция = 17, код ошибки: -1072898035
Описание ошибки: Элемент ''{http://fsrar.ru/WEGAIS/TTNSingle_v2}Identity'' используется, но не был объявлен в DTD и схеме."

В самой схеме "TTNSingle_v2" объявление "Identity" есть. Подскажите, в чем может быть проблема?
23. Дмитрий Рудаков (Дмитрий Рудаков) 164 28.11.16 12:59 Сейчас в теме
У меня тоже выдала ошибку

28.11.2016 16:39:42: Начата проверка по схеме файла: D:\val\v8_D76D_7b.xml
Не удалось подключить схему: D:\val\TTNSingle_v2.XSD
28.11.2016 16:39:43: Проверка завершена
24. Александр (NAlex) 3 18.01.17 17:49 Сейчас в теме
Собственно, опять же ошибка:
============================================================­======
18.01.2017 17:39:26: Начата проверка по схеме файла: C:\Users\abc\Desktop\0d13381f-79d8-430f-953d-fd4608fbc97e.xml
Не удалось подключить схему: W:\for_files\PledgeRegistry.xsd
18.01.2017 17:42:41: Проверка завершена
============================================================­======
несмотря на то, что Altova XMLSpy 2011 Enterprise Edition успешно валидировала этой файл Xml этой схеме Xsd.
В чем может быть проблема?
25. Sergei (kauksi) 195 30.05.17 13:54 Сейчас в теме
работающий вариант: кусок кода процедуры Проверка по схеме клиент

//Прочитаем схему
	Попытка
		xmldoc=Новый COMОбъект("MSXML2.DOMDocument.6.0");
	Исключение
		ВывестиСообщение("Не удалось создать объект DOM1Document (возможно, не установлен MSXML 6)",2);
		Схема=Неопределено;
		Возврат РезПроверки;
	КонецПопытки;
	
	xmldoc.async = false;  
	xmldoc.load(ИмяФайлаСхемы);

	Если (xmldoc.parseError.errorCode<>0) Тогда
       	// ошибки при проверке правильности
		ВывестиСообщение("При проверке по схеме выявлены ошибки!",Куда,Форматировать);
		Если ВыводитьВсеОшибки Тогда
			Для каждого parseError из xmldoc.parseError.AllErrors  Цикл
				ВывестиОшибкуРазбораХМЛ(parseError.reason,Куда,Форматировать);
			КонецЦикла;
		Иначе
			ВывестиОшибкуРазбораХМЛ(xmldoc.parseError.reason,Куда,Форматировать);
		КонецЕсли;
	КонецЕсли;

	
	// Подключим ее
	Попытка
		Схема=Новый COMОбъект("MSXML2.XMLSchemaCache.6.0");
	Исключение
		ВывестиСообщение("Не удалось создать объект XMLSchemaCache (возможно, не установлен MSXML 6)",2);
		Возврат РезПроверки;
	КонецПопытки;
	
	Попытка
		Схема.addCollection(xmldoc.namespaces);
		//Схема.add(,ИмяФайлаСхемы);
	Исключение
		ВывестиСообщение("Не удалось подключить схему: "+ИмяФайлаСхемы,2);
		Схема=Неопределено;
		Возврат РезПроверки;
	КонецПопытки;
...Показать Скрыть
Прикрепленные файлы:
ВалидацияXML_1.01.epf
26. Sergei (kauksi) 195 30.05.17 13:59 Сейчас в теме
однако выводимая ошибка не очень информативна

Обнаружена ошибка:
Смещение = 215, строка = 2, позиция = 193, код ошибки: -1072897676
Описание ошибки: Значение не может быть пустым

понятно что какой то элемент не заполнен, а вот какой не говорит, собака
27. anton448 garcov (anton448) 30 20.07.17 11:56 Сейчас в теме
Добрый день, andrewks

Помогите пжл. разобраться в такой проблеме.

Скачал последнюю вашу обработку с рабочим кодом, файл проверяется по схеме, но при этом всегда сообщается, что "Файл успешно прошёл проверку по схеме!", хотя я файл специально "ломаю", чтобы получить ошибку при проверке....

Т.е.в коде система почему то не проваливается в условие

Если (ДОМ.parseError.errorCode<>0) Тогда
		// ошибки при проверке правильности
		ВывестиСообщение("При проверке по схеме выявлены ошибки!",Куда,Форматировать);
		Если ВыводитьВсеОшибки Тогда
			Для каждого parseError из ДОМ.parseError.AllErrors  Цикл
				ВывестиОшибкуРазбораХМЛ(parseError,Куда,Форматировать);
			КонецЦикла;
		Иначе
			ВывестиОшибкуРазбораХМЛ(ДОМ.parseError,Куда,Форматировать);
		КонецЕсли;
	Иначе
		ВывестиСообщение("Файл успешно прошёл проверку по схеме!",Куда,Форматировать);
		РезПроверки=Истина;
	КонецЕсли;
...Показать Скрыть


Получается, что "ДОМ.parseError.errorCode" всегда равно 0, хотя ошибки есть 100%

Во вложении сама обработка, файл, который нужно проверить и схема (для наглядности)

Спасибо.
Прикрепленные файлы:
ВалидацияXML_1.01_2 (рабочий вариант).epf
2017-07-19-18-58-00 WayBill-1-2017-07-19.xml
v8_2108_779 - это ТТН версия 2.xsd
Оставьте свое сообщение