Отслеживание изменений каталога в REAL-TIME: Native ВК для 8.х

Публикация № 203225

Разработка - Разработка внешних компонент

Давно у меня была задумка отследить, например, появление определенного файла в каталоге базы данных без использования различных таймеров и обработчиков ожидания. Настоящая ВК отслеживает изменения в выбранном каталоге в реальном времени и генерирует в 1С соответствующие внешние события. Выбранный каталог может быть как папкой, так и целым диском.

Настоящая ВК появилась как побочный продукт при выполнении проекта по отслеживанию "нежелательных" файлов на компьютерах корпоративной сети. Текущая версия позволяет поддерживать отслеживание изменений одновременно в двух папках (на двух дисках). Выполнена по технологии Native, не требует регистрации в реестре.

Подключение ВК:

ПодключитьВнешнююКомпоненту(ПолноеИмяФайлаВК,"DirSpy",AddInType.Native);

Создание экземпляра класса:

Шпион = Новый("AddIn.DirSpy.V8DirSpy"); // слева любая глобальная переменная.

ВНИМАНИЕ: не проводите никакие эксперименты по использованию локальной переменной класса (например, обработкой), получите дамп.

Методы ВК:

Каталог1(ИмяКаталога,фл_Добавлен,фл_Удален,фл_Модифицирован,фл_Переименован) - устанавливает отслеживание изменений в выбранном каталоге.

ИмяКаталога - строка

фл_Добавлен,фл_Удален,фл_Модифицирован,фл_Переименован - флаги генерации внешнего события, если Истина - генерируется событие:

Источник="DIR_SPY";

Событие- одно из:"FILE_ADDED","FILE_REMOVED","FILE_MODIFIED","FILE_RENAMED_OLD_NAME", "FILE_RENAMED_NEW_NAME".

Данные - полное имя файла.

Флажки - тип булево, необязательные, по умолчанию фл_Добавлен=Истина, остальные Ложь

Метод выполняется в отдельном потоке, возвращаемое значение - идентификатор потока. Если ноль - ошибка создания потока.

Каталог2(ИмяКаталога,фл_Добавлен,фл_Удален,фл_Модифицирован,фл_Переименован) - полностью идентичен методу Каталог1

ОтключитьПоток(ИдентификаторПотока) - отключает слежение и удаляет поток с указанным идентификатором

//--- модуль обычного приложения---
Перем Шпион Экспорт;
Функция КаталогИБ() Экспорт
    КаталогИБ = СтрокаСоединенияИнформационнойБазы();
    КаталогИБ = Сред(КаталогИБ,7,СтрДлина(КаталогИБ)-8) + "\";
    Возврат КаталогИБ;
КонецФункции
Процедура ПриНачалеРаботыСистемы()
    ФайлВК=КаталогИБ()+"DirSpy.dll";
    Файл= Новый Файл(ФайлВК);
    Если Файл.Существует() Тогда
        //-- подключение компоненты--
        ПодключитьВнешнююКомпоненту(ФайлВК,"DirSpy",AddInType.Native);
        //-- создание экземпляра класса--
        Шпион =    Новый("AddIn.DirSpy.V8DirSpy");
        Каталог="c:\";   // весь диск С
        //                            ADD     DEL  CHANGE RENAME
        Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
        Если Хендл1=0 Тогда
            Сообщить("Не удалось создать поток");
        КонецЕсли;

        Каталог="d:\";  // весь диск D
        //                            ADD     DEL  CHANGE RENAME
        Хендл2=Шпион.Каталог2(Каталог,Истина,Истина,Истина,Истина);
        Если Хендл2=0 Тогда
            Сообщить("Не удалось создать поток");
        КонецЕсли;

        Иначе
        Сообщить("Не обнаружен файл ВК, скопируйте ""DirSpy.dll"" в КаталогИБ "
        +ФайлВК,СтатусСообщения.Информация);
    КонецЕсли;
КонецПроцедуры

Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
    Если Источник="DIR_SPY" Тогда
        Сообщить("Событие: "+Событие+"; Данные: "+Данные);
    КонецЕсли;
КонецПроцедуры


Примечание для продвинуто-любопытных: используется API ReadDirectoryChangesW

В архиве находится папка с тестовой базой+DirSpy.dll

Скачать файлы

Наименование Файл Версия Размер
Версия 1.0.0.1

.zip 314,95Kb
122
.zip 314,95Kb 122 Скачать бесплатно
DirSpy1002.zip

.zip 289,18Kb
130
.zip 289,18Kb 130 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Alex1Cnic 129 10.10.13 10:22 Сейчас в теме
Интересно, а для 1С-ки как применить? а так плюс конечно за труды
2. Abadonna 3889 10.10.13 10:32 Сейчас в теме
(1) Alex1Cnic,
а для 1С-ки как применить?

Самое первое, что приходит в голову:
Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
	Если Источник="DIR_SPY" Тогда
		Если Событие="FILE_ADDED" Тогда
			ИмяФайла=Данные;
			Если Найти(ИмяФайла,"GoNah")>0 Тогда
				ЗавершитьРаботуСистемы(Ложь,Ложь);
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

Показать
16. Abadonna 3889 11.10.13 07:24 Сейчас в теме
(3) Eugeneer,
Работает на управляемых формах? в клиент-сервере.

Не поленился проверить на базе "Работа с клиентами", построенной на основе БП 3.0. Уэфнее и сервер-клиентнее не бывает:))
&НаКлиенте
Процедура ЗапуститьШпиона(Команда)
	Если Шпион=Неопределено Тогда  // Шпион - ГЛОБАЛЬНАЯ!
		Возврат;
	КонецЕсли;
	
	Каталог="c:\";   // весь диск С
	Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
	Если Хендл1=0 Тогда
		Сообщить("Не удалось создать поток");
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Если Источник="DIR_SPY" Тогда
		Сообщить("Событие: "+Событие+"; Данные: "+Данные);
	КонецЕсли;
КонецПроцедуры

Показать


Прикрепленные файлы:
4. Abadonna 3889 10.10.13 10:42 Сейчас в теме
Да ВЕЗДЕ мои работают ;) Эту конкретно не проверял
5. Ёпрст 1048 10.10.13 10:54 Сейчас в теме
6. Ёпрст 1048 10.10.13 10:55 Сейчас в теме
Это... файло_ренайм пасёт ? Ну или просто изменение файла, атрибутов там его ?..
7. Abadonna 3889 10.10.13 10:56 Сейчас в теме
(6) Ёпрст, это... а почитать не катит? ;)
8. Ёпрст 1048 10.10.13 11:03 Сейчас в теме
Ээ.. че почитать ?
На картинке вижу токма аддед и ремувед..
10. Abadonna 3889 10.10.13 11:10 Сейчас в теме
(8)
Ээ.. че почитать ?

Подозреваю, что описание :)))
Каталог1(ИмяКаталога,фл_Добавлен,фл_Удален,фл_Модифицирован,фл_Переименован) - устанавливает отслеживание изменений в выбранном каталоге.

ИмяКаталога - строка

фл_Добавлен,фл_Удален,фл_Модифицирован,фл_Переименован - флаги генерации внешнего события, если Истина - генерируется событие:

Источник="DIR_SPY";

Событие- одно из:"FILE_ADDED","FILE_REMOVED","FILE_MODIFIED","FILE_RENAMED_OLD_NAME", "FILE_RENAMED_NEW_NAME".


На картинке:
Прикрепленные файлы:
11. Ёпрст 1048 10.10.13 11:23 Сейчас в теме
9. Ёпрст 1048 10.10.13 11:08 Сейчас в теме
аа... вижу ненэйм..
Ну молоток.
12. mptt 16 10.10.13 11:55 Сейчас в теме
Плюс одназначно.. Еще бы на исходники DirSpy взглянуть..
13. hogik 437 10.10.13 15:52 Сейчас в теме
Аркадий.
Извини, не в тему напишу.
Нажимаю звёздочку. Вхожу в список "одобряющих". Я в списке есть. Возвращаюсь на страницу разработки. Нажимаю звёздочку. Смотрю список - меня там нетУ. И так многократно можно повторить...
14. Abadonna 3889 10.10.13 17:00 Сейчас в теме
(13)
Не дай Бог жить с эпоху перестройки сайтов. (с) Древняя мудрость

Фиг его знает, я три раза попробовал - три раза тебя в списке вижу
15. hogik 437 10.10.13 17:19 Сейчас в теме
(14)
Дык. ;-) Я же плюс тебе ставлю нажатием звёздочки, а ты просто на меня смотришь.
Т.е. если я тебе ставлю плюс настойчиво (многократным нажатием), то я его могу в результате и не поставить. Блеск... :-(
P.S.
Написал ещё в теме про новый "дизайн" сайта. Может разберутся...
K_A_O; cleaner_it; +2 Ответить
17. kirillkr 28 11.10.13 12:10 Сейчас в теме
(0) А для параноиков исходник библиотеки идет?
18. Abadonna 3889 11.10.13 12:16 Сейчас в теме
(17) kirillkr,
А для параноиков исходник библиотеки идет?

Параноикам могу порекомендовать погуглить строчку "ReadDirectoryChangesW Дельфи", например ;)
19. kirillkr 28 11.10.13 12:22 Сейчас в теме
(18) и писать свою ВК? Зачем? Или там все-таки есть секретная отправка данных в АНБ?
20. Abadonna 3889 11.10.13 12:26 Сейчас в теме
(19) kirillkr, я на ГРУ работаю ;)
Прошли те времена, когда я исходники дарил.
wunderland; kirillkr; yandextesting; +3 Ответить
21. kirillkr 28 11.10.13 18:01 Сейчас в теме
(20) вот так вот "Большой Брат" следит в России.
23. Abadonna 3889 12.10.13 06:02 Сейчас в теме
(22) slimper, is evil for crooked-hands arseholes
24. Evil Beaver 6996 14.10.13 17:17 Сейчас в теме
Вещь полезная, API простой, всегда можно сделать при желании, но когда есть готовый вариант, лучше его использовать. Посему, исходники для параноиков все-таки не помешают. Но хозяин-барин, разумеется :)
25. Abadonna 3889 14.10.13 21:48 Сейчас в теме
(24) Evil Beaver,
API простой

Ну, именно эту API я бы никак к простой не отнес, это не какой-нибудь FindWindow.
но когда есть готовый вариант, лучше его использовать.

Вот он, лежит готовый вариант - используйте :)))
Evil Beaver; hogik; +2 Ответить
26. Evil Beaver 6996 14.10.13 23:43 Сейчас в теме
(25) дык, спасибо, как понадобится, так воспользуюсь. Но мой внутренний параноик хнычет:)
27. vladon 22 26.10.13 15:16 Сейчас в теме
Если не секрет, как в Native API генерировать внешние события?
28. Abadonna 3889 26.10.13 21:10 Сейчас в теме
(27) vladon, см.ВК Native API
type
  TV8AddInDefBase = class //IAddInDefBase см. документацию от 1С
  public
    procedure Destroy1; virtual; abstract;
    function AddError(wcode: word; const source: PWideChar;
      const descr: PWideChar;
      scode: integer): boolean; virtual; stdcall; abstract;
    function Read(wszPropName: PWideChar;
      pVal: PV8Variant;
      pErrCode: PInteger;
      errDescriptor: PPWideChar): boolean; virtual; stdcall; abstract;
    function Write(wszPropName: PWideChar;
      pVar: PV8Variant): boolean; virtual; stdcall; abstract;
    function RegisterProfileAs(wszProfileName: PWideChar): boolean; virtual; stdcall; abstract;
    function SetEventBufferDepth(lDepth: integer): boolean; virtual; stdcall; abstract;
    function GetEventBufferDepth: integer; virtual; stdcall; abstract;
    function ExternalEvent(wszSource, wszMessage, wszData: PWideChar): boolean; virtual; stdcall; abstract;
    procedure CleanEventBuffer; virtual; stdcall; abstract;
    function SetStatusLine(wszStatusLine: PWideChar): boolean; virtual; stdcall; abstract;
    procedure ResetStatusLine; virtual; stdcall; abstract;
  end;
Показать
29. kentavr27 95 16.11.13 21:35 Сейчас в теме
Хотелось бы уточнить... Один экземпляр класса одновременно может отслеживать не более двух каталогов? Потому как при попытке второй раз использовать метод Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь) 1с-ка молча валится. Так и должно быть?
30. Abadonna 3889 17.11.13 02:13 Сейчас в теме
(29) kentavr27, Мне даже в голову не приходило проверить на повторное использование, ибо - а на фиг?
Проверил, да - валится. Пока считай, что так и должно быть. Посмотрю...
Подправил, вот аж так теперь работает:
Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
		Если Хендл1=0 Тогда
			Сообщить("Не удалось создать поток");
		КонецЕсли;
		Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
		Если Хендл1=0 Тогда
			Сообщить("Не удалось создать поток");
		КонецЕсли;
		Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
		Если Хендл1=0 Тогда
			Сообщить("Не удалось создать поток");
		КонецЕсли;
		Хендл1=Шпион.Каталог1(Каталог,Истина,Истина,Ложь,Ложь);
		Если Хендл1=0 Тогда
			Сообщить("Не удалось создать поток");
		КонецЕсли;

Показать

Будет новая, очень расширенная версия, там будет без косяка
31. Abadonna 3889 17.11.13 03:29 Сейчас в теме
(29) Залил подправленную 1.0.0.2
32. Kalam 105 20.11.13 11:46 Сейчас в теме
А зачем это к 1С цеплять?
А если в 1С, то почему не сделать через ОбработчикОжидания?
В чем сила, брат?
33. Abadonna 3889 20.11.13 14:27 Сейчас в теме
(32) Kalam,
то почему не сделать через ОбработчикОжидания?

Кто не дает? Делай. А мне надо было секунда в секунду - я для себя и сделал. А вот зачем мне это надо было - я сам знаю ;)
И вообще у меня привычка дурная: чем через задницу в 1С выеживаться, мне проще ВК написать
kentavr27; +1 Ответить
34. Свой 164 25.11.13 02:03 Сейчас в теме
в 1С 7.7 компонента будет работать ?
35. Abadonna 3889 25.11.13 04:21 Сейчас в теме
(34) Свой, нет, конечно. Native для 7.7 не предусмотрен. Кстати, еще один резон завязать с 7.7 ;)
36. script 230 21.03.15 00:29 Сейчас в теме
Бeдет ли отслеживать компонента изменения файлов в ситевом каталоге или виртуальном, подключенном через RDP ?
38. Al777 12.10.16 13:53 Сейчас в теме
Заметил следующее. Платформа 8.2. Конфигурация: Комплексная автоматизация 1.1.76 + CRM 1.4.10. Подключение ВК производится при начале работы системы. Она хорошо работает, претензий нет, но пользователь, допустим, вынес какие-то отчёты в виде картинок или картинок с надписью на свою панель различных значков и закрыл 1С Предприятие. Когда опять открыл 1С Предприятие, то там нет последних сохранённых отчётов в виде картинок. Без использования этой ВК всё замечательно сохраняется и не слетает. Кто-нибудь с этим сталкивался? Как решили проблему?
39. Alias 162 04.04.18 12:18 Сейчас в теме
Событие "FILE_RENAMED_NEW_NAME" не приходит, есть только "FILE_RENAMED_OLD_NAME".
Почему так может быть? С added, removed, modified проблем нет.
Win 7 pro х64; 1С 8.3.10.

P.S. к сожалению, понимаю, что вопрос не к автору ВК... :( может у кого-то есть мысли или другая аналогичная ВК.
Оставьте свое сообщение

См. также

GraphViz1С: внешняя компонента 1С Native API для построения графов Промо

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Внешняя компонента Native API для Windows с исходными кодами на C++ для построения графов посредством библиотеки GraphViz. Граф строится на основании текстового описания в формате dot. Реализован экспорт в большинство графических форматов. Поддерживаются версии платформы от 8.3.14 и выше до 8.3.18.

22.12.2020    3275    100    kandr    8    

PinkRabbitMQ - Native API компонента 1С с открытым исходным кодом, для обмена сообщениями через RabbitMQ

Разработка внешних компонент v8 Бесплатно (free)

PinkRabbitMQ представляет собой Native API компоненту для 1С Предприятия 8 (Windows 32bit и 64bit) с открытым исходным кодом на с++ (можно собрать компоненту самостоятельно). PinkRabbitMQ это низкоуровневая компонента которая реализует обмен по протоколу AMQP с брокером сообщений RabbitMQ. Для организации высокоуровнего обмена между информационными базами предназначен Адаптер. Компонента разрабатывается в рамках проекта Адаптер.

29.07.2019    20766    980    Begemoth80    169    

Внешняя компонента для ping (под win)

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Цель: выполнение ping из 1С без использования команд системы. Может быть полезна разработчикам для проверки доступности компьютеров.

05.01.2019    6821    31    milut    4    

Мини-Эверест: Native ВК для 8.х

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Список и свойства HDD, список и свойства ОЗУ, список запущенных процессов (для терминала - всех пользователей с указанием номера сессии), список запущенных сервисов, характеристики BIOS

20.08.2014    17410    44    Abadonna    7    

Miracle Native - ВК для V8 Промо

Разработка внешних компонент v8 Россия Бесплатно (free)

Настоящая ВК написана по технологии 1С-Native. По методам и свойствам является наследницей MIracveV8 с планируемым развитием функционала. Версия 1.2.1.1 Не триальная, подправлена некорректная работа под х64

23.04.2012    33967    649    Abadonna    81    

ВК для работы с файлами FilesNative.dll

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Компонента реализует некоторые методы работы с файлами (архивами). Поддерживаемые форматы распаковки архивов: ZIP, JAR, XPI, BZ2, BZIP2, TBZ2,TBZ,RAR, R00, ARJ, Z, TAZ, LZH, LHA, 7Z, CAB, LZMA, LZMA86, ISO, XAR, MSI,RPM, TAR, GZ, TGZ, TPZ

18.06.2014    18361    89    Abadonna    9    

NetNative: ВК для работы с сетью

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Прослушивание UDP-портов, посылка UDP-сообщений, возможность организации UDP-чата, некоторые сетевые команды. Написана по технологии Native

23.02.2014    20522    159    Abadonna    10    

Трей-мессенджер: Native ВK для 8.х

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Иконка 1С в трее с popup-mеnu, баллуны, оповещения, обратная связь. Выполнена по технологии Native, не требует регистрации в реестре и особых прав пользователя. Имеет обратную связь с 1С через генерацию внешних событий. Имеет popup-menu на иконке в трее для управления окном 1С (закрыть, скрыть, показать+ 2 пункта генерации событий). Есть возможность убрать кнопку главного окна из панели задач.

23.09.2013    27396    406    Abadonna    121    

Внешняя компонента для работы со строками

Разработка внешних компонент v8 Россия Бесплатно (free)

ВК по технологии Native для работы со строками: хеши по различным алгоритмам, крутое шифрование, вычисление релевантности (схожести) строк. Событие переключения подсистем.

20.03.2013    26927    485    Abadonna    105    

ВК для 1С:Предприятие 8.2 NativeAPI на Delphi (запуск приложений, раскладка клавиатуры, события и др.)

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Внешняя компонента на основе разработки Крипича http://infostart.ru/public/81644/ - NativeAPI на Delphi реализует запуск процесса с заданным приоритетом и видимостью окна, переключение раскладки клавиатуры, всплывающие сообщения в трее, паузу sleep без загрузки процессора и внешние события.

01.08.2011    47831    1273    romix    57    

Драйвер клавиатурного сканера

Разработка внешних компонент v8 Россия Бесплатно (free)

Драйвер сканеров USB-HID (эмуляция клавиатуры) для 1С Предприятие 8.2. Дополнительно может отсылать текст на дисплей покупателя Posiflex PD2601.

13.07.2011    11432    412    Ma_X_X    12    

Thermal Print Library - ActiveX библиотека для печати на термопринтерах Godex BZB2/EZ2/EZ4, C.Itoh EZ2/EZ4, Citizen CLP-521/621

Разработка внешних компонент v8 1cv8.cf 1cv7.md Россия Бесплатно (free)

Библиотека Thermal Print Library является COM сервером и предназначается для использования в любых средах, которые в состоянии выступить в роли OLE-клиента (MS Office, 1С Предприятие, VB, VBScript, и т.д.). Допускается применение со следующими моделями термопринтеров : Godex BZB2/EZ2/EZ4, C.Itoh EZ2/EZ4, Citizen CLP-521/621.

20.09.2010    23116    262    GreenLab    23    

[BackgroundWorker] - Фоновые задания в файловом режиме 1С 8.x

Практика программирования Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

ActiveX-компонента позволяет выполнять задачи в фоне с индикацией прогресса и возможностью прерывания выполнения. Также работает и клиент/серверном варианте, в качестве альтернативы типовым фоновым заданиям

04.03.2010    24374    417    Душелов    15    

Архивация базы 1С-Предприятие

Разработка внешних компонент Архивирование (backup) v8 1cv8.cf Россия Бесплатно (free)

Используем стандартный планировщик Windows и файл Visual Basic Script с файлом настроек, для плановой выгрузки базы данных.

29.12.2009    11635    271    alves    4    

ActiveX - плейер для 1С

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Для тех, кто любит всё внутри 1С ;) Форматы: mp3 и wav

01.12.2009    18550    203    Abadonna    39    

Использование визуальных (ActiveX) компонент в тонком клиенте 1С 8.2

Разработка внешних компонент Администрирование данных 1С v8 1cv8.cf Россия Бесплатно (free)

В данной статье рассматривается вопрос использования визуальных компонент (ActiveX) на форме тонкого клиента 1С 8.2 и веб-клиента на базе MS Internet Explorer.

19.11.2009    42375    600    Душелов    59    

Хранитель COM - объектов

Разработка внешних компонент Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Позволяет сохранять COM - объект между серверными вызовами в 8.2. Сохраняет и получает ссылку на объект в ROT (Running Object Table). БЕТА!

18.11.2009    13339    77    Hadgehogs    14    

[SendGoogleSMS] Отправка SMS уведомлений через сервис Google Calendar

WEB SMS рассылки Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента генерирует события в Google Calendar с извещением по SMS. В архивах ВК для 7.7 (работает и в 8-ке) и ActiveX - для работы в контексте сервера 1С 8.х

07.08.2009    30659    555    Душелов    37    

[PDF Viewer] - Просмотр PDF в 1С

Разработка внешних компонент Работа с интерфейсом v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

ActiveX-компонента для просмотра PDF. Позволяет сохранить в виде текста, картинки и PostScript. Реализованы механизмы поиска текста и печати.

15.07.2009    36485    891    Душелов    57    

Подпись к полю ввода в самом поле

Работа с интерфейсом Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Все чаще в интерфейсе программных продуктов используется новый способ подписи или комментирования полей ввода. Выглядит это так: пока поле пустое - в нем отображается подпись серого цвета, если в поле что то начинают вводить, подпись исчезает.

30.04.2009    17442    310    Stepa86    22    

[IFilter] Поиск в содержании файлов из 1С (ВК, .NET)

Разработка внешних компонент Поиск данных v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента для работы с фильтрами поисковых систем. Получает текст из файла по установленном в системе фильтрам. Индексирует и ищет файлы по их содержанию (аналог Desktop Search) Поддерживает *.doc, *.xls, *.txt, *.ppt. Дополнительные фильтры можно скачать с http://www.ifilter.org/Links.htm

24.03.2009    33791    142    Душелов    44    

[Сервер событий] Клиент + Сервер + Внешние события

Разработка внешних компонент Перенос данных из 1C8 в 1C8 1С7.7<->1C7.7 v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Средство для генерирования событий между разными сеансами, базами и платформами 1С

17.03.2009    21926    145    Душелов    32    

[RClassMngr] ООП для V8. Добавляем наследование v.1.1

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Посвящается 1С++. Добавляем в V8 наследование свойств и методов объектов.

15.03.2009    18976    324    Robert    94    

[Генератор внешних событий] Внешняя компонента для 1С

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента генерирует внешние события с заданным интервалом и с заданными значениями.

06.03.2009    40075    1076    Душелов    82    

[Мониторинг изменения файлов] - ActiveX-компонента для 1С 8.х + ВК для 7.7

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента следит за изменениями файлов в заданных каталогах, без таймеров и опросов файловой системы. Использует события Windows.

05.03.2009    25785    515    Душелов    53    

[Проверка правописания] - ActiveX-компонента для 1С

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента проверяет правописание текста. Основана на технологии OpenOffice MySpell. Не требует установленного офиса. В комплекте словари для 5 языков, включая русский (с "ё").

09.02.2009    30334    1076    Душелов    66    

[ExcelEditor] Чтение/запись файла Excel напрямую из 1С без Excel (формат 97/2003)

Загрузка и выгрузка в Excel Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Чтение и запись файла Excel напрямую из 1С Компонента читает и редактирует напрямую файл Excel без загрузки самого Excel (формат Microsoft Office 97/2003)

08.01.2009    48647    1195    Душелов    92    

Защита информации при обмене данными между информационными базами "Управление производственным предприятием"

Защита и шифрование Разработка внешних компонент Обмен через XML v8 УПП1 Бесплатно (free)

Защита информации при обмене с распределенной базой данных. В крупной фирме имеется одна центральная информационная база 1С:Предприятие 8.1 "Управление производственным предприятием" и несколько периферийных баз, обмен данными происходит через файлы XML. После выявления многочисленных случаев несанкционированного доступа к конфиденциальной информации, а именно кассовым и банковским документам при обмене данными, руководством было решено защитить данные при обмене информацией между центральной базой и периферийными базами. Перемещение данных между базами происходит через файлы XML, по нескольким каналам связи FTP, HTTP, POP, SMTP, а также на сменных носителях (типа USB Flash Drive). В связи с этим решено использовать внешнюю компоненту для шифрования файлов XML и небольшой доработки конфигурации баз данных.

25.11.2008    15454    143    astracrypt    13    

"Захват окон" - ActiveX-компонента для 1С

Разработка внешних компонент Работа с интерфейсом v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Захватывает открытые окна и помещает их в 1С, так же получает скриншот выбранного окна. Хотите играть в пасьянс в 1С, смотреть кино или просматривать секретные документы ;) и не светить эти окна на рабочем столе, тогда эта компонента для Вас :)

20.11.2008    24854    232    Душелов    64    

"WebCam" - ActiveX-компонента для 1С

WEB Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента работает с устройствами, поддерживающими Twain32 драйвер (вебкамеры, фотоаппараты и др.)

28.09.2008    43420    1091    Душелов    77    

COM-объект, реализующий метод Sleep

Разработка внешних компонент Универсальные функции v8 1cv8.cf Бесплатно (free)

COM-объект, реализующий метод Sleep. Может использоваться на сервере 1С, в win x86 и x64

13.08.2008    20738    249    ValeriVP    26    

1С: Предприятие 8, не работает прерывание по Ctrl+Break

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

В 1С: Предприятии 8 для прерывания выполнения операций используется комбинация клавиш <Ctrl>+<Break>. На практике, на некоторых компьютерах эта комбинация не работатет, что вызывает некоторые неудобства (нет возможности прервать длительную операцию).

31.07.2008    20567    309    vovk_v    3    

"Аналоговые часы" - ActiveX-компонента для 1С

Разработка внешних компонент Работа с интерфейсом v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

"Аналоговые часы" - ActiveX-компонента для 1С 8.х Небольшое "украшательство" для форм 1С.

20.05.2008    22449    206    Душелов    23    

НЕТЛЕНКА

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Многообъектная внешняя компонента дополнительного функционала.

06.03.2008    51355    4744    Hadgehogs    153    

ВК дополнительного функционала

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Дополнительный функционал для 1С. Работа с окнами, событиями Windows, звуком, и.т.д.

26.12.2007    57351    1541    Hadgehogs    30    

Перехватчик нажатий клавиш (ActiveX)

Разработка внешних компонент Сканер штрих-кода Розничная торговля Розничная торговля v8 1cv8.cf 1cv7.md Россия Бесплатно (free)

Примитивная компонента ActiveX, перехватывающая нажатия клавиш и принудительно возвращающая фокус компоненте при его потере. Искал в свое время для внедрения в интерфейс кассира. Может, кому еще пригодится.

14.12.2007    21490    921    MRAK    18    

Плагин TotalCommander-а просмотра файлов 1C v8

Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

lister-plugin для TotalCommander-а для просмотра содержимого файлов 1С 8-й версии. v1.0.0.14

04.12.2007    33269    5475    MMF    112    

Внешняя компонента Симплекс-метод

Математика и алгоритмы Разработка внешних компонент v8 1cv8.cf 1cv7.md Бесплатно (free)

Внешняя компонента 1С для решения задач оптимизации (задачи линейного программирования) с помощью симплекс-метода.

17.01.2007    10052    859    lavrik    12    

EventProxy - внешняя компонента для асинхронной обработки событий COM-объектов (работает в 7.7 и 8.0)

Внешние источники данных Разработка внешних компонент v8 1cv8.cf 1cv7.md Бесплатно (free)

EventProxy - внешняя компонента для асинхронной обработки событий COM-объектов. Работает в 7.7 и в 8.0

09.11.2006    16165    246    steban    9