Шаблон отчета на СКД (обычные и управляемые формы)

Программирование - Инструментарий

133
Выкладываю шаблон отчета на СКД для обычных и управляемых форм, который я использую для создания новых отчетов. Обычную форму шаблона постарался сделать максимально похожей на типовой отчет. Но в отличии от типового, шаблон отчета работает в любых конфигурациях "сам по себе". Весь функционал реализован как для обычных, так и для управляемых форм.

Также этот шаблон будет полезен начинающим разработчикам для примера реализации следующих ситуаций (как для обычных, так и для управляемых форм):

  1. Программное выполнение отчета на СКД.
  2. Программная установка отборов в СКД.
  3. Программная установка параметров в СКД.
  4. Программное изменение параметров вывода в СКД.
  5. Привязка своего макета оформления в отчет на СКД.
  6. Расшифровка ячейки отчета и получения значений группировки выбранной ячейки результата отчета.
  7. Обработка расшифровки в очете на СКД, в виде отдельного отчета со своей компоновкой данных.
  8. Удобное меню для выбора периода.
  9. Удобная функция сохранения в Excel.
  10. Установка параметров документа Excel при сохранении (границы, ориентация и пр.)
  11. Сохранение в Excel из WEB-Клиента
  12. ...

Смотрите также: Шаблон обработки (обычные и управляемые формы)

133

Скачать файлы

Наименование Файл Версия Размер
ШаблонОтчета_СКД
.erf 77,33Kb
19.07.16
832
.erf 1.8.3 77,33Kb 832 Скачать

См. также

Вознаграждение за ответ
Показать полностью
Комментарии
Сортировка: Древо
1. PrinzOfMunchen 77 25.12.13 07:01 Сейчас в теме
А чем он лучше типового шаблона?
4. Tavalik 1532 14.01.14 06:11 Сейчас в теме
(1) PrinzOfMunchen,
Старался его сделать очень похожим на типовой. А лучше тем, что не зависит от конфигурации и не требует дополнительных модулей, работая "сам по себе".

(3) DAnry,
А какие еще нужны скрины? Весь описанный функционал в коде.
2. Alex1Cnic 124 25.12.13 08:29 Сейчас в теме
3. DAnry 6 26.12.13 01:21 Сейчас в теме
Скрины в студию! На представленных иллюстрировано лишь пункт 7. Удобное меню для выбора периода. Хотелось бы больше ...
5. mikl79 103 17.01.14 14:48 Сейчас в теме
хотел плюсануть, но как?
6. Tavalik 1532 17.01.14 15:05 Сейчас в теме
(5) mikl79,
Авторизируетесь на сайте и нажимаете кнопку в виде оранжевой звездочки чуть ниже таблички "Файлы". :)
7. mikhailovaew 127 12.03.14 16:42 Сейчас в теме
Плюсану авансом, может пригодится )
8. higs 25.03.14 21:46 Сейчас в теме
Забрал, спасибо. Очень не люблю расписывать всякие интерфейсные плюшки. Почему-то достаются отчеты со сложными выборками данных. Поэтому готовые шаблоны забираю;)
9. dyak84 15.04.14 12:39 Сейчас в теме
Автору спасибо за проделаный труд. Обязательно скачаю как появятся деньги. отчет написать ето одно но зделать его юзабилика как говорят ето совсем другое. Поетому людям которые решились на ето вызывают у меня уважение. СПАСИБО та к держать
10. sergiobargio1 115 14.05.14 12:10 Сейчас в теме
Tavalik, добрый день. Подскажите, пожалуйста, в Вашей разработке есть ли возможность задавать имена листам
(не название сохраняемого файла) сохраняемым в xls или xlsx ? Решается ли проблема "съедания" ведущих нолей в текстовых полях "Код" ? Спасибо.
11. Tavalik 1532 15.05.14 08:32 Сейчас в теме
(10) sergiobargio1,
Доброго времени суток.
К сожалению на данный момент нет возможности задавать имена, проблема пропадания ведущих нулей также не решена.
Сохранение в Excel вынесено в отдельную процедуру, пока только могу предложить Вам доработать ее самостоятельно.
12. CITRUM 19.05.14 16:37 Сейчас в теме
проблема пропадания ведущих нулей также не решена

Эта проблема решается, например, добавлением пользовательского поля X такого вида "'" + [Код]. В итоге все значения будут иметь вид "'0000000001", что при сохранении в Excel штатными методами даст нормальную текстовую ячейку со всеми нулями, символ апострофа же при обработках формулами и т.д. игнорируется.
Об этом уже писали на Инфостарте и это абсолютно штатная фича как Excel так и Open(Libre)Office.
13. Константин С. 540 11.06.14 13:04 Сейчас в теме
Есть два вопросика:
1. нет дает открыть два отчет(внешних) разработанных используя шаблон
2. нажимаю сформировать отчет, слетает схема, обычная форма.
17. Tavalik 1532 14.08.14 12:55 Сейчас в теме
(13) Константин С.,
Скопируйте основную форму отчета, назначьте ее основой, а старую удалите.
Тогда новый отчет будет открываться с новым идентификатором формы.
14. master_yoda 27 16.06.14 15:45 Сейчас в теме
Огромное спасибо автору за труды, обязательно качну как только появится бабосы....
15. Tangram 140 05.08.14 13:32 Сейчас в теме
Отлично подходит для нетиповых конфигураций, спасибо. Работа с вариантами отчетов не реализована или я не увидел?
16. Tavalik 1532 05.08.14 10:50 Сейчас в теме
(15) Tangram,

Нет, работу с вариантами я не делал, т. к. для обычных форм на практике почти всегда используем механизм сохранения настроек типовых конфигураций. Если конфигурация нетиповая, то как мне кажется, проще допилить ее, добавив один регистр сведений и один общий модуль.
18. BlackStar 03.09.14 18:41 Сейчас в теме
Отличный шаблон, аккуратно сделан, порадовала панель с периодом! Попробую в работе и буду использовать для внешних отчетов, вместо текущего шаблона.
Спасибо за работу!

Есть предложения по развитию, все касаются управляемых форм:

1. Можно использовать механизм работы с длительными операциями, потому что сейчас, если формировать длительный отчет, программа зависает. К стати, при расшифровке отчета этот механизм работает, а при нажатии "Сформировать" - нет

2. При нажатии на кнопки выбора периода постоянно появляется сообщение "Использование модальных окон в данном режиме запрещено!", не критично, но отвлекает. К стати в выборе периода с.. по можно использовать стандартный диалог выбора периода (в виде календаря, который например в БП 3.0 в стандартных отчетах)

3. В отчет можно сразу добавить код для подключения его в качестве внешнего
AzagTot; klaus38; +2 Ответить
31. AzagTot 36 16.11.15 17:41 Сейчас в теме
(18) BlackStar, Чтобы не появлялось сообщение "Использование модальных окон в данном режиме запрещено!" замените ВыбратьИзМеню на ПоказатьВыборИзМеню:

Оповещение = Новый ОписаниеОповещения("ПослеВыбораИзМеню", ЭтотОбъект);
ПоказатьВыборИзМеню(Оповещение, СписокИнтервалов);

&НаКлиенте
Процедура ПослеВыбораИзМеню(Интервал, Параметры = Неопределено) Экспорт

Если Интервал <> Неопределено Тогда
Отчет.Период = Интервал.Значение;
Элементы.ПериодУстановка.Заголовок = Отчет.Период;
ПериодУстановка(Неопределено);
КонецЕсли;

КонецПроцедуры
19. Константин С. 540 25.09.14 17:57 Сейчас в теме
предложение:
добавить Функция СведенияОВнешнейОбработке() Экспорт
для автоматической регистрации в типовых конфигурациях)))
klaus38; BlackStar; +2 Ответить
20. BlackStar 10.10.14 14:09 Сейчас в теме
В последней версии исправили обновление дат, это здорово, а вариант отчета не обновляется, если выбрать другой вариант.
Надо к событию формы ПриЗагрузкеВариантаНаСервере привязать код

&НаСервере
Процедура ПриЗагрузкеВариантаНаСервере(Настройки)
	//Обновляем заголовок
	ЭтаФорма.Заголовок = ВернутьСинонимОтчета() + " (" + НаименованиеТекущегоВарианта + ")";

КонецПроцедуры
21. Константин С. 540 22.10.14 13:50 Сейчас в теме
Пожелание к оформлению публикации. Можно указывать номер текущей версии шаблона.)))
22. klaus38 22.11.14 16:39 Сейчас в теме
Замечательно, забираю. Спасибо автору
23. lisrws 74 04.12.14 16:15 Сейчас в теме
Добрый день. Подскажите, если отчет строится для остатков, то есть нужна одна конкретная дата, а не диапозон, то как ему это задать?
24. dyak84 15.12.14 10:56 Сейчас в теме
Автор если планируется развитие даной обработки можно ли добавить. Кнопку для отправки отчета на електроную почту.
25. aikosyapr 25 02.06.15 22:24 Сейчас в теме
Спасибо. Красиво и аккуратно. Небольшой косячок: установка видимости заголовка отчета через УстановитьВидимостьЗаголовкаОтчета() глючит. Например, с отчетом в виде таблицы с двумя группировками в строках затираются заголовки столбцов:) Не страшно, но я вот не сразу понял, что происходит, думал всё, допрограммировался)
26. NGPhoenix 8 04.09.15 16:14 Сейчас в теме
Посмотрел, действительно работает без всяких модулей, только при каждом закрытии требует сохранения варианта отчета. Надоедает страшно. Теперь голову ломаю, как это убрать. Сообщение "Вариант "Имя варианта" был изменен. Сохранить измененный вариант?" обыскался, в обработке такого сообщения нет и события при закрытии тоже, откуда ноги не понятно.
27. NGPhoenix 8 04.09.15 16:56 Сейчас в теме
Поборол, убрав свойство модальности варианта отчета
&НаКлиенте
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
Если ЭтаФорма.ВариантМодифицирован=Истина тогда
ЭтаФорма.ВариантМодифицирован = ложь;
КонецЕсли;
КонецПроцедуры
38. levran 198 27.09.17 10:57 Сейчас в теме
Что-то у меня в УТ 11 (11.2.3.189) ошибка при открытии настроек выходит ...

{ОбщаяФорма.ФормаНастроекОтчета.Форма(27)}: Не передан служебный параметр "НастройкиОтчета".
ВызватьИсключение НСтр("ru = 'Не передан служебный параметр ""НастройкиОтчета"".'");
40. Tavalik 1532 11.11.17 14:41 Сейчас в теме
(38)
в УТ 11 по умолчанию используется форма настроек отчетов из БСП. Если нужна именно эта форма, то рекомендую и основную форму отчета брать из БСП.

Добавил в отчет управляемую форму настроек отчета.
28. pbabincev 10.09.15 10:45 Сейчас в теме
Очень хорошо!
Еще можно добавить автосуммирование по выделенным ячейкам.
Спасибо!
29. konstruktiv 10.09.15 12:57 Сейчас в теме
А объясните кто-нибудь, пожалуйста, что за вопрос, за решение которого дается вознаграждение, я что-то запутался
30. HobbitT 23.10.15 16:33 Сейчас в теме
Спасибо за хороший шаблон. Неоднократно успешно им пользовалась. Безумно нравится что он реально самостоятельный и нет ограничения в программе. Мелочи типа установки видимости заголовка не в счет (легко подпиливаются).
32. mad_maksim 88 21.11.15 11:18 Сейчас в теме
Проблема с периодом обнаружилась. Делаем отчёт для УТ 11.0. При загрузке отчёт показывает один период, а формируется совершенно за другой. Как будто при формировании берётся период из какого-то кэша от прошлого запуска отчёта. Тоже самое происходит при выборе вариант отчёта. Пробовал ПередЗагрузкойВариантаНаСервере очищать период, но всё равно формируется он по прошлому заданному периоду. Никак не могу найти ошибку. А без этого отчёт не удобен в использовании.
39. Exit_in 60 08.11.17 12:59 Сейчас в теме
(38)
Что-то у меня в УТ 11 (11.2.3.189) ошибка при открытии настроек выходит ...

{ОбщаяФорма.ФормаНастроекОтчета.Форма(27)}: Не передан служебный параметр "НастройкиОтчета".
ВызватьИсключение НСтр("ru = 'Не передан служебный параметр ""НастройкиОтчета"".'");


(32)
Делаем отчёт для УТ 11.0.


Когда сделаете?
42. Tavalik 1532 11.11.17 14:42 Сейчас в теме
(39)
Добавлена форма настроек в отчет.
41. Tavalik 1532 11.11.17 14:42 Сейчас в теме
(32)
Здравствуйте. К сожалению (или к счастью) не могу повторить описанную вами ошибку.
33. mad_maksim 88 21.11.15 11:52 Сейчас в теме
Нашёл работающий вариант исправления. В процедуру СформироватьОтчет добавил обновление представления даты:

Процедура СформироватьОтчет(Команда)

//добавлено для работы с выбором вариант отчета
Элементы.ПредставлениеДаты.Заголовок = ОбновитьПредставлениеДатыНаСервере();
//добавлено для работы с выбором вариант отчета

//Получаем схему из макета
СформироватьОтчетНаСервере();

//Состояние отчета
Элементы.Результат.ОтображениеСостояния.Видимость = Ложь;
Элементы.Результат.ОтображениеСостояния.ДополнительныйРежимОтображения = ДополнительныйРежимОтображения.НеИспользовать;

КонецПроцедуры
34. DedMoroz1983 13.10.16 10:56 Сейчас в теме
35. Светлый ум 218 05.11.16 14:34 Сейчас в теме
Крутой шаблон - использовал раньше и другие - этот лучше и навороченный по функционалу БСП
+1
37. Светлый ум 218 31.08.17 15:23 Сейчас в теме
(35)

Применял при создании:
Отчет по проводкам (плоский) для УПП 1.3, КА 1.1

https://infostart.ru/public/434760/
36. GlebHappy 109 08.12.16 19:59 Сейчас в теме
С удовольствием использую.
Но есть два пожелания:

1. Желательно добавить значение Истина четвертым параметром в ПроцессорКомпоновкиДанных.Инициализировать(...), иначе нельзя использовать функции общих модулей в вычисляемых полях
2. ОткрытьЗначение(...) в форме отчета и расшифровки в веб-клиенте не работает, надо менять на ПоказатьЗначение(...)
edyardg; user774630; Seankinho; +3 Ответить
43. unichkin 1008 20.12.17 22:55 Сейчас в теме
Хороший шаблон. Рекомендую доработать:
- добавить программный интерфейс регистрации для доп. отчетов и обработок БСП, номер версии вести соотв. там
- заголовок формы возвращать из экспортного метода модуля объекта
- структуры модулей оформить по ИТС https://its.1c.ru/db/v8std#content:2149184104:hdoc
- в обычной форме отказаться от "СохранитьЗначение" \ "ВосстановитьЗначение", использовать штатный функционал управления настройками. Кстати, флаг в обычной форме включен, но значения для сохранения не выбраны
- формы переименовать) Я забывал пару раз удалять форму, из-за чего получал "двойников": если есть два отчета, реализованные на одном и том же шаблоне и с одной и той-же формой, то если открывать отчет №2 при открытом отчете№1 - открытия не произойдет, а просто активируется отчет №1. Поэтому у себя в шаблоне форму именую так: "ФормаОтчета_НЕ_ИСПОЛЬЗОВАТЬ_СКОПИРОВАТЬ_ЭТУ_УДАЛИТЬ".

У меня сейчас так (в конфе устаревшая версия БСП):
Функция СведенияОВнешнейОбработке() Экспорт
	
	МетаОбъект = ЭтотОбъект.Метаданные();
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид","ДополнительнаяОбработка");
	ПараметрыРегистрации.Вставить("Наименование", МетаОбъект.Синоним);
	ПараметрыРегистрации.Вставить("Версия", "1.1");
	ПараметрыРегистрации.Вставить("БезопасныйРежим",Ложь);
	ПараметрыРегистрации.Вставить("Информация", МетаОбъект.Комментарий);
	ПараметрыРегистрации.Вставить("ВерсияБСП", "2.1.1.12");
	ТаблицаКоманд = ТаблицаКоманд();
	
	ДобавитьКоманду(ТаблицаКоманд, МетаОбъект.Синоним, МетаОбъект.Имя, "ОткрытиеФормы");
	
	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
	Возврат ПараметрыРегистрации;
КонецФункции

Функция ЗаголовокФормы() Экспорт
	
	СтруктураПараметрыРегистрации= СведенияОВнешнейОбработке();
	Возврат СтруктураПараметрыРегистрации.Наименование + " v." + СтруктураПараметрыРегистрации.Версия;
	
КонецФункции 
Показать
Оставьте свое сообщение