INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Кучма Дмитрий | Руководитель сектора программирования | Консорциум "Беркат"

«Автоматизация сети магазинов, централизация. Методика, приёмы, обучение персонала, решение проблем.»

- Причины необходимости автоматизации сети супермаркетов (ввиду децентрализации - большие затраты на персонал, снижение эффективности, отсутствие инструментов у руководителей служб и учредителей влиять на ситуацию в магазинах, плохой контроль распределения финансовых потоков и состояние фирмы в целом). - Выбор подходящего программного обеспечения, торгового оборудования, максимально эффективные и малозатратные сопряжения имеющегося оборудования и бизнес-процессов магазина с новой программой. - Определение сроков, команды внедрения, цели и задачи, средние и глобальные. - Подготовка к проекту, закуп оборудования (возможно, перетяжка сетей и замена оборудования), выбор оборудования с расчетом многолетней эксплуатации, достаточного запаса прочности. - Непосредственное внедрение, инвентаризация, ввод остатков, введение карточек товара, работа с операторами и обучение персонала. - Работа с бухгалтерской службой, настройка планов обмена, обучение персонала. - Работа с коммерческим отделом, установки цен, акции, ценники, закуп у поставщиков, категорийный менеджмент, взаимодействие с поставщиками, система лояльности покупателей. - Работа со службами магазина, по приемке товара, этикетированию, фасовкой, электронными весами, обучение кассиров и старшего кассира. -Сопровождение программы в течение первых месяцев, отладка взаимодействия служб, разбор проблем и задач. Заключение.

Загрузка данных из табличного документа в справочники, документы, в движения документов, поточная загрузка документов (EXCEL, управляемые формы, универсальная)

Обработки - Обработка документов

306
Обладает уникальным функционалом. Позволяет загружать в справочники, табличные части, регистры сведения, движения документа, поточно загружать документы, а также одновременно загружать в справочники, являющиеся реквизитами загружаемых объектов, с полноценной настройкой. Обработка на управляемых формах, работает на всех версиях 1С предприятия 8.2 и 8.3

Обработка имеет логику настройки, сходную с логикой обработки "Загрузка данных из табличного документа" с диска ИТС (на мой взгляд, она очень удобна).

Позволяет загружать:

  1. В справочники (в том числе и подчиненные, например, при загрузке номенклатуры можно сразу загружать и характеристики).
  2. В табличную часть документа (можно сразу в несколько).
  3. В не подчиненные регистратору регистры сведений.
  4. В движения документа (с поддержкой вида движения для регистров накопления, можно загружать сразу в несколько движений документа).
  5. Поточно загружать документы и справочники (как с табличными частями, так и без, можно сразу загружать в несколько табличных частей документа).
  6. Одновременно загружать в справочники, являющиеся реквизитами загружаемых объектов, с полноценной настройкой.

Подключается к конфигурациям с БСП в двух режимах (на форме есть кнопка, облегчающая регистрацию): 

  1. Как универсальная загрузка из табличного документа.
  2. Как обработка заполнения табличной части (Обработка будет открыта в режиме: Загрузка в табличную часть и ссылкой на объект откуда она была вызвана (без возможности изменения данных настроек).

Как происходит загрузка:

  1. Выбираете режим загрузки
  2. Выбираете объект загрузки (табличную часть/регистр при необходимости)
  3. Настраиваете правила загрузки на закладке "Настройка" (и на закладке "Настройка шапки" при поточной загрузке в табличные части. При поточной загрузке новые элементы создаются, при изменении полей поиска)
  4. Выбираете табличный документ (в настройках обработки можно указать, что требуется предпросмотр табличного документа, в этом случае на форму будет выведо поле табличного документа).
  5. Нажимаете кнопку "Получить таблицу данных". При этом будет создана таблица значений, в которой согласно настройкам будет преобразован в данные 1С "табличный документ". Эту таблицу значений можно откорректировать, или вернуться к настройкам.
  6. Нажать кнопку "Загрузить", после чего данные будут загружены в 1С.

 Плюсы данной обработки:

  1. Можно настроить загрузку любой сложности.
  2. Позволяет загружать в справочники, являющиеся реквизитами объекта.
  3. Загружает в движения документов.
  4. Обладает уникальным функционалом поточной загрузки.

Минусы:

  1. Не загружает изображения
  2. Не работает с группировками в табличных документах.

Известные особенности:

  • По умолчанию существующие объекты не перезаписываются. Если вам это требуется то включите настройку "Замещать существующие записи".
  • Если у вас выходит ошибка индекса при получении таблицы данных, значить у вас настроенных колонок для загрузки больше, чем колонок с данными в табличном документе, или для какой то настройки указан номер колонки за пределами колонок табличного документа.
  • В событиях и в режиме "Вычислять" при обращение в строке текущих данных к реквизитам дополнительных настроек требуется добавлять префикс: "ДополнительнаяНастройка_" плюс номер настройки.
  • "<Новый>" в колонках "Объект", в полученной "Таблице подготовленных данных", означает, что загружаемое значение, не найдено в текущей базе. При загрузке оно будет добавленно в базу.
  • Если значение загружается с помощью дополнительной настройки, то режим должен быть: "Устанавливать", и нужно в столбце "Значение по умолчанию" выбрать "По настройке: X: Название настройки". .
  • Если в описании типов реквизита несколько значений, то обработка пытается получить значение по первому типу, исключением является получение данных для реквизта, для которого настроена связь по типу, но при этом, если у плана видов характеристик несколько типов, то будет попытка привести значение к первому типу из плана видов характеристики.
  • После изменения настроек (при включеннной автонумерации колонок), номера колонок могут измениться, поэтому требуется обновить табличный документ, что бы понять, из каких именно колонок будут браться значения.
  • Если не заполнены ключевые реквизиты для объекта, то объект не будет создаваться.

 

UPD v 3.0.4.1 (22.06.2018):

  1. Добавлена возможность искать объекты по нескольким вариантам поиска. Для этого на каждой странице настройки добавлена кнопка "Настройки поиска и создания объектов".
  2. Для ссылочных объектов дана возможность искать по уникальному идентификатору.
  3. Исправление ошибок.

 

UPD v 3.0.3.6 (01.06.2018):

  1. Добавлена возможность добавить дополнительную настройку загрузки в независимый регистр сведений.
  2. Добавлена возможность загрузки в общие реквизиты.
  3. Вместо режима "Загрузка в справочник" рекомендуется использовать "Поточная загрузка справочников и документов", как более функциональный. Режим оставлен для совместимости с сохраненными настройками предыдущих версий. Будет удален в будущем.

 

UPD v 3.0.3.5 (06.04.2017):

  1. Возвращена возможность в режиме загрузки "В табличную часть документа" добавлять дополнительные настройки вида "Табличная часть".
  2. Исправлена ошибка невозможности открытия настроек предыдущих версий обработки.
  3. Исправлена ошибка при добавление дополнительной настройки регистра движений документа.
  4. Исправлена ошибка в результате которой перед загрузкой не очищались табличные части и движения добавленные дополнительными настройками.
  5. Исправлена ошибка в результате которой не записывались движения загружаемого документа.
  6. Исправлена ошибка когда при открытии неверно заполнялись настройки у обработки подключенной как "дополнительная обработка заполнения объекта" механизма БСП.
  7. Исправлена ошибка не позволяющая восстановить настройки в режиме "Загрузка в табличную часть документа".
  8. Добавлен фильтр для предопределенных настроек. Теперь отображаются только настройки соответствующие конфигурации базы.

 

UPD v 3.0.3.4 (21.03.2017):

  1. Добавленна возможность загруки групп для иерархических справочников.
  2. Изменена логика работы ключевых настроек. В новой версии объект создается только если заполнены все ключевые настройки (в прошлых версиях объект не создавался только если не заполнены все ключевые настройки).
  3. Исправлена ошибка, когда при использовании отборов в таблице данных массив текстов ячеек не соответствовал загружаемой строке.
  4. Исправлена ошибка, когда для платформы 8.3.6 и выше использовался старый спобоб чтения табличных файлов.
  5. Убрана обязательность для стандартных реквизитов при поточной загрузке.
  6. Добавлена обрезка пробелов при чтении файлов .dbf
  7. В обработку встроены формы "Особенности настройки" и "Примеры настройки".

 

UPD v 3.0.3.3 (23.05.2016):

  1.  Для справочника добавлен стандартный реквизит "Ссылка" для возможности устанавливать его через настройки поиска по справочникам и регистрам сведений.
  2. Добавлена возможно давать название дополнительной настройки при добавлении.
  3. Исправление ошибок.

 

UPD v 3.0.3.2 (31.03.2016):

  1. Исправлена ошибка, Для регистров расчета добавлены все требуемые стандартные реквизиты.

 

UPD v 3.0.3.1 (12.02.2016):

  1. Добавлен новый режим добавляемой настройки: "Поиск через справочник".  Функционал аналогичен режиму: "Поиск через регистр". Позволяет искать элемент справочника по его реквизатам, и выбрать один из его реквизитов для подставления в соответствующий реквизит другой настройки.

 

UPD v 3.0.2.12 (28.01.2016):

  1. Исправлена ошибка поиска объектов по реквизитам объекта с типом "строка" и имеющим фиксированную длину строки.

 

UPD v 3.0.2.11 (26.12.2015):

  1. Исправление ошибок получения настроек в режимах загрузки: "Загрузка в регистр сведений", "Загрузка в движения документа".

 

UPD v 3.0.2.10 (18.12.2015):

  1. Исправлена ошибка поиска загружаемых объектов.

 

UPD v 3.0.2.9 (17.12.2015):

  1. Исправлена ошибка не позволявшая сохранять настройки.

 

UPD v 3.0.2.8 (15.12.2015):

  1. Реализован поиск данных в базе без учета начальных и конечных пробелов в строковых реквизитах полей поиска.
  2. Исправлена ошибка связи по типу при поиске реквизита.

 

UPD v 3.0.2.7 (24.10.2015):

  1. Исправлена ошибка: "Значение не является значением объектного типа (Представление)".

 

UPD v 3.0.2.6 (07.10.2015):

  1. Исправление ошибки индекса возникающей при ручной нумерации колонок.

 

UPD v 3.0.2.5 (10.09.2015):

  1. Изменена логика формирования колонок в таблице данных для дополнительных настроек. Вместо префикса "ПодчиненныйСправочник_", теперь используется префикс: "ДополнительнаяНастройка_" плюс номер настройки.
  2. Изменено поведение видимости объекта загрузки. После загрузки он становиться видимым.
  3. Исправлена ошибка при загрузки нулевого количества строк.

 

UPD v 3.0.2.4 (02.09.2015):

  1. Исправлены ошибки в предопределенных настройках для загрузки данных.
  2. Исправлена ошибка с добавлением дополнительной настройки в режиме "Загрузка в справочник".
  3. Добавлена проверка является ли обработка внешней (упрощает встраивание в конфигурацию).
  4. Добавлена возможность ввода в ручную вида справочника/документа в режиме "Поточная загрузка справочников/документов".
  5. Добавил вопрос при закрытии обработки.

 

UPD v 3.0.2.3 (01.08.2015):

  1. Исправлена ошибка поиска по коду, когда код содержит меньше знаков чем максимальная длина кода.
  2. Исправлена ошибка выбора значения по умолчанию когда добавлены дополнительные настройки вида "Движения по регистрам".

 

UPD v 3.0.2.2 (29.06.2015):

  1. Исправлена ошибка при который в варианте загрузки: "Из внешнего файла", при повторном получении таблицы данных сбивались настройки колонок.

 

UPD v 3.0.2.1 (8.06.2015):

  1. Реализована проверка на дублирование однотипных объектов загрузки при получении таблицы данных. Дубли проверяются по идентичности полей поиска (в настройках должны быть заданы одинаковые поля поиска). В качестве примера в обработку добавлена предопределенная настройка загрузки спецификаций с составом для УНФ.
  2. В таблицу настройки добавлена новая колонка: "Ключевой". Если все реквизиты помеченные как ключевые не будут заполнены, то объект не будет загружен.//infostart.ru/upload/iblock/da5/%D0%9A%D0%BB%D1%8E%D1%87%D0%B5%D0%B2%D1%8B%D0%B5%D0%9F%D0%B0%D1%80%D0%B0%D0%BC%D0%B5%D1%82%D1%80%D1%8B.jpg

 

UPD v 3.0.1.5 (27.05.2015):

  1. Добавлена принудительная установка нового кода для загружаемых элементов справочника.
  2. Исправлена ошибка при чтении табличного документа из .xls при которой число читалось с неразрыным пробелом.

 

UPD v 3.0.1.4 (20.05.2015):

  1. Добавлен новый режим добавляемой настройки: "Поиск по регистру сведений".
  2. Добавлена предопределенная настройка: "Поступление товаров с поиском по штрихкоду (УТ 11)". Демонстрирует использование режима "Поиск по регистру сведений".

 

UPD v 3.0.1.3 (05.05.2015):

  1. В таблице подготовленных данных, представление не найденных объектов имеет вид: "<Новый>".
  2. На главную панель выведена кнопка варианта загрузки (из файла или заполнением таблицы).
  3. Исправление ошибок.

 

UPD v 3.0.1.2 (23.04.2015):

  1. Изменена логика добавления дополнительных настроек. Все настройки добавляютя, через кнопку: "Добавить настройку".
  2. Добавлены две предопределенные настройки загрузки для УТ 11, на их примере можно изучить общие принципы настройки обработки:
    • Номенклатура с характеристиками (УТ 11)
    • Установка цен номенклатуры (УТ 11)
     //infostart.ru/upload/iblock/4f4/%D0%9F%D1%80%D0%B5%D0%B4%D0%BE%D0%BF%D1%80%D0%B5%D0%B4%D0%B5%D0%BB%D0%B5%D0%BD%D0%BD%D1%8B%D0%B5.jpg
  3. Исправление ошибок.

 

UPD v 3.0.1.1 (23.04.2015):

  1. Добавлен упрощенный вариант открытия табличного документа. Если Вы хотите, как прежде, видеть табличный документ после открытия, то включите настройку: "Предварительный просмотр табличного документа, после открытия". 
    //infostart.ru/upload/iblock/0a1/%D0%A3%D0%BF%D1%80%D0%BE%D1%89%D0%B5%D0%BD%D0%BD%D1%8B%D0%B9%D0%A0%D0%B5%D0%B6%D0%B8%D0%BC.jpg
  2. Добавлено обновление представления загруженныех объектов в таблице подготовленных реквизитов.
  3. Дополнительные настройки загрузок в справочники, теперь загружаются в режиме "ОбменДанными.Загрузка = Истина".
  4. В Режиме "Загрузка в Справочник" убрана кнопка "Загрузка в подчиненный справочник".
  5. В режимах загрузки "Загрузка в справочник" и "Поточная загрузка документов/справочников" если основной объект загрузки является справочником, то теперь он доступен в выборе значения по умолчанию.
  6. Исправление ошибок.

 

UPD v 3.0.0.8 (20.04.2015):

  1. Добавлена возможность отбора на таблице подготовленных данных.  При этом загружаеются только отобранные строки.
    //infostart.ru/upload/iblock/2a5/%D0%BE%D1%82%D0%B1%D0%BE%D1%80.jpeg

 

UPD v 3.0.0.7 (15.04.2015):

  1. Добавлена возможность удалять дополнительные таблицы настроек.
  2. Кнопка "Нумерация колонок" оставленна только на основной странице настроек загрузки данных.
  3. При восстановлении настроек в режиме загрузки "Загрузка в табличную часть документа", теперь не восстанавливается докумен.

 

UPD v 3.0.0.6 (06.04.2015):

  1. Добавлен поиск документов по представлению.
  2. При поточной загрузке добавлена возможность проведения при записи.
  3. Исправлена критическая ошибка: при поточной загрузке загружалась только последняя строка в табличную часть.

 

UPD v 3.0.0.5 (26.03.2015):

  1. Исправление ошибки загрузки реквизитов в режиме "Вычислить".
  2. Исправление ошибки отсутствия данных "ТекстыЯчеек" в событиях: "При записи объекта", "Перед записью объекта".
  3. Исправление ошибки загрузки справочников без владельцев.

 

UPD v 3.0.0.4 (24.03.2015):

  1. Механизм поиска объектов при получени таблицы данных теперь применяется для всех режимов загрузки.
  2. При обнаружение новой версии, обработка теперь сразу предлаает ее скачать.
  3. Исправлены ошибки.

 

UPD v 3.0.0.3 (17.02.2015):

  1. Исправлена ошибка: "При поточной загрузки в документ с движениями по регистру бухгалтерии не заполняются субконто".

 

UPD v 3.0.0.2 (13.02.2015):

  1. Исправлена ошибка невозможности получить таблицу подготовленных данных, если настройка "Первая строка данных табличного документа" была равна 1.
  2. Для платформы 1С Предприятие 8.3.6 добавлена возможность открытия документов *.xls; *.xlsx; *.ods средствами платформы.

 

UPD (12.02.2015):

  1. Исправление ошибки неверного поиска элементов в режиме "Загрузка в справочник".

 

UPD v 3.0.0.1 (08.02.2015):

  1. В режиме загрузки "Загрузка в справочник" добавлено условное оформление для Таблицы подготовленных данных. Теперь можно подсвечивать найденные/не найденными объекты разными цветами. Настройку цветов можно выполнить на форме настройки.

 

UPD v 3.0 (07.02.2015):

  1. Изменена схема загрузки в режиме "Загрузка в справочник". Теперь поиск объектов осуществляется при подготовке таблицы данных:
    • Это позволяет как сразу увидеть какие элементы справочника нашлись, а какие нет.
    • Реализовать поиск реквизитов загружаемоего объекта для которых этот объект является владельцем (замечание от Rebelx). Для этого в поле выбора связи по владельцу надо выбрать: "< Загружаемый объект >".
  2. Исправлена ошибка "Переменная не определена (ЭтотОбъект) " появляющаяся когда обработка открывалась в конфигурациях для 1С Предприятия 8.2 открытых в режиме совместимости в 1С Предприятии 8.3.

 

UPD v 2.9 (24.12.2014):

  1. Исправлена критическая ошибка: при наличии пустых заголовков колонок в табличном документе не верно получалась таблица данных.

 

UPD v 2.8 (10.12.2014):

  1. Был переписан с нуля блок получения таблицы данных, что позволило значительно ускорить данную операцию.
  2. Ошибки при получении таблицы данных и лог загрузки теперь выводятся в отдельных закладках.
  3. В режиме "Поточная загрузка" создание нового объекта теперь происходит при изменении полей основной таблицы для которых установлено, что они являются полями поиска.

 

UPD (04.12.2014):

  1. Исправление ошибки, при поточной загрузки документов.

 

UPD (26.11.2014):

  1. Исправление ошибки, при загрузке дополнительных значений справочника.

 

UPD (20.10.2014):

  1. Исправлены ошибки

 

UPD v 2.7 (01.10.2014):

  1. Добавлена поддержка конфигураций в которых свойство "Режим использования модальности" установлено в положение "Не использовать".


UPD (v 2.6):

  1. Добавлена возможность во всех режимах загрузки добавить настройку загрузки в справочник, а в настройка загрузки реквизитов загружаемого объекта  ее выбрать, указав что реквизит загружается по расширенной настройке (производится в поле выбора значения по умолчанию). Объекты загружаются в порядке очередности, и в каждом следующем можно выбрать предыдущий (например на скрине видно, что добавлены настройки справочников: Партнеры (1) и Контрагенты (2), и в настройке Контрагенты, выбрано, что Партнер загружается по расширенной настройке.

 

UPD (v 2.5):

  1. В режиме "Поточная загрузка" добавлена возможность загружать в движения документа.
  2. Добавлены "красивые" заголовки для таблицы настроек.
  3. Условное оформление теперь устанавливается на все таблицы настроек.
  4. Исправление ошибок.

 

UPD (v 2.4):

  1. Добавлена возможность загружать сразу в несколько табличных частей (движений по регистрам документа) для режимов загрузки: Загрузка в табличную часть, загрузка в движения документа, поточная загрузка документов.
  2. Добавлено новое событие "После записи объекта", доступно при режиме загрузки "Загрузка в справочник". В него передается основной объект загрузки и список значений с ссылками на загруженные подчиненные справочники. 
  3. Выведение всего кода связанного с Дополнительными отчетами и обработками в оператор Выполнить, для обеспечения совместимости с конфигурациями без БСП, или с БСП старых версий.
  4. Исправление ошибок.

 

UPD (v 2.3):

  1. Добавлена возможность сохранять настройки в базе, с возможностью восстанавливать настройки при открытии обработки.
  2. Исправление ошибок.

 

UPD (v 2.2):

  1. Добавлена возможность при загрузке в справочник, одновременно загружать данные в справочники, для которых загружаемый справочник, является владельцем.
  2. Изменена система сохранения настроек во внешний файл. !! ВНИМАНИЕ!! Версии настроек от предыдущей обработки не поддерживаются!
  3. Убрана возможность сохранять настройке в базе.
  4. Общие настройки вынесены в отдельную форму.
  5. Добавлена возможность отключить проверку обновлений.

 

UPD (v 2.1): Исправлена ошибка: после загрузки сохраненных настроек из файла, поля "Вид документа" и "Табличная часть", не восстанавливались из настроек.

306

Скачать файлы

Наименование Файл Версия Размер
ЗагрузкаДанныхИзТабличногоДокумента_Q(Управляемые формы) v3.0.3.3
.epf 307,67Kb
04.06.18
3044
.epf 3.0.3.3 307,67Kb 3044 Скачать
ЗагрузкаДанныхИзТабличногоДокумента_Q(Управляемые формы) v3.0.4.1
.epf 603,94Kb
22.06.18
80
.epf 3.0.4.1 603,94Kb 80 Скачать

См. также

Комментарии
Сортировка: Древо
1. ben_art 12 30.05.14 13:15 Сейчас в теме
Зачем же плодить одно и тоже , хоть бы кто сделал возможность сохранения и восстановления настроек настроек ?
370. andt 16.03.16 12:24 Сейчас в теме
Спасибо! Обработка уже не раз помогла.
Но загрузить настройки опять не получается, хотя ошибка в последней версии стала другой.
Настройка для загрузки в "Движения документа" в "Операцию" :
Платформа: 1С:Предприятие 8.3 (8.3.6.2100)
Конфигурация: Бухгалтерия предприятия, редакция 3.0 (3.0.43.123)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Россия), Сеанс: русский (Россия)
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
16.03.2016 16:24:13
{(1)}: Значение не является значением объектного типа (Метаданные)
Для каждого Движение Из СсылкаДокумента.Метаданные().Движения Цикл Если Движение.Имя = "Хозрасчетный" Тогда МетаданныеОбъекта = Движение КонецЕсли КонецЦикла;
372. vat-74 176 16.03.16 12:47 Сейчас в теме
(370) Такое бывает, если ссылка пустая.
2. ben_art 12 30.05.14 13:36 Сейчас в теме
Хотя то что получает ссылку на документ сама . уже хорошо. Но придётся допиливать.
3. qwinter 506 30.05.14 13:38 Сейчас в теме
(2) ben_art, так оно там и так есть? или нужно конкретно, что бы в базе сохранялись настройки?
4. ben_art 12 30.05.14 13:42 Сейчас в теме
(3) Уже разобрался прошу прощения за первый коммент , меня смутила запись о не возможности сохранения настроек , а она оказывается есть и в список и в файл )
5. Yashazz 2264 03.06.14 16:14 Сейчас в теме
Баян. Автор, как насчёт загрузки картинок, работы с объединёнными ячейками, формулами, иерархией строк? Как насчёт скрытых разным образом строк?
6. qwinter 506 03.06.14 16:30 Сейчас в теме
(5) Yashazz, может вам еще ключи от квартиры где деньги лежат?
7. hzhz 12 06.06.14 10:13 Сейчас в теме
После загрузки сохраненных настроек, поля ВИД ДОКУМЕНТА и ТАБЛИЧНАЯ ЧАСТЬ не устанавливаются из настроек.(у себя исправил)
8. qwinter 506 06.06.14 11:35 Сейчас в теме
(7) hzhz, исправил, спасибо за замечание)
9. marinasnsd 10.06.14 17:20 Сейчас в теме
Уважаемый qwinter!
Можно ли с помощью вашей обработки формировать номенклатуру с характеристиками с определенными свойствами (все свойства характеристики номенклатуры задаются в соответствующих полях файла загрузки)?
10. qwinter 506 10.06.14 17:53 Сейчас в теме
(9) marinasnsd, с помощью этой обработки настроить загрузку номенклатуры сразу с характеристиками, можно только зная программирование 1С (так как например в УТ11 характеристики это отдельный справочник).
17. qwinter 506 18.06.14 15:51 Сейчас в теме
(9) marinasnsd, а вот теперь можно)))
11. ben_art 12 16.06.14 16:36 Сейчас в теме
Подскажите пожалуйста как восстанавливать параметры при открытии формы ?
12. qwinter 506 16.06.14 20:20 Сейчас в теме
(11) ben_art, не совсем понял, что вы именно хотите?
13. ben_art 12 16.06.14 20:33 Сейчас в теме
Ну в 8.2 на обычных формах , настройки сохранялись с возможностью восстанавливать их при открытии формы. чтоб не нажимать кнопку "восстановить настройки" а они сами востанавливались
14. qwinter 506 16.06.14 21:04 Сейчас в теме
(13) ben_art, для управляемых форм такого в пользовательском интерфейсе нет. Откройте обработку в конфигураторе, и в свойствах формы поставьте: автоматически сохранять значения.
15. ben_art 12 16.06.14 21:09 Сейчас в теме
да с этим понятно , я знаю что сохранение и восстановление происходит только в форме на клиенте (не как в 8.2) , вот и спрашиваю может есть способы вызывать команду восстановления без нажатия кнопки. (
16. qwinter 506 16.06.14 21:18 Сейчас в теме
(15) ben_art, чтобы была кнопка восстанавливать автоматически или нет? Можно сделать реквизит, и при открытии присваивать его свойству формы.
18. qwinter 506 19.06.14 16:09 Сейчас в теме
(15) ben_art, добавил и такую возможность)))
19. ben_art 12 19.06.14 16:52 Сейчас в теме
Ого , спасибо огроменное )
20. ben_art 12 20.06.14 12:38 Сейчас в теме
только теперь ещё и ссылку на объект сохраняет , а надо чтоб был тот из которого вызвана
21. qwinter 506 20.06.14 14:27 Сейчас в теме
22. qwinter 506 20.06.14 14:38 Сейчас в теме
(20) ben_art, в процедуре ВосстановитьНастройкиИзСостоянияВыполнения
	ТипОбъектаСправочника	= Неопределено;
	СсылкаИсточника			= Неопределено;
	ИмяВидаРегистра			= Неопределено;
	ТабличнаяЧастьИсточника	= Неопределено;
	СсылкаДокумента 		= Неопределено;
	РегистрДокумента		= Неопределено;
	
	ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);	
	ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);
	
	ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);	
	УстановитьИсточник();	
	
	ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
Показать

заменить, на:
	ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);	
	ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);
	
	Если НЕ ВыполняетсяЗаполнениеТЧОбъекта Тогда
		ТипОбъектаСправочника	= Неопределено;
		СсылкаИсточника			= Неопределено;
		ИмяВидаРегистра			= Неопределено;
		ТабличнаяЧастьИсточника	= Неопределено;
		СсылкаДокумента 		= Неопределено;
		РегистрДокумента		= Неопределено;
		
		ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);	
		УстановитьИсточник();	
		ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
	КонецЕсли;
Показать


обработку, обновил.
23. ben_art 12 20.06.14 15:13 Сейчас в теме
24. onyx 22 23.06.14 18:15 Сейчас в теме
В модуле формы (Строка 894) ошибка:
Если ОбъектНайден  Тогда

25. qwinter 506 23.06.14 18:52 Сейчас в теме
(24) onyx, я так понял, это по поводу обновления данных найденных элементов справочников? Это поведение стандартной типовой загрузки, а не ошибка, она не обновляет данные. Как показали вы, ни в коем случае нельзя делать. Это нарушит логику загрузок всего остального, кроме справочников.
Если вы хотите обновлять данные справочников, то надо чуть выше после:
		Если РежимЗагрузки = 0 Тогда
			
			ЗагружаемыйОбъект = Неопределено;
			Если Не Запрос = Неопределено Тогда
				СтрокаОшибок = "";
				Для каждого СтрокаПоиска Из СтрокиПоиска Цикл
					
					ЗначениеРеквизита = Неопределено;
					
					ТекущаяСтрока.Свойство(СтрокаПоиска.ИмяРеквизита,ЗначениеРеквизита);
					Если ПустаяСтрока(ЗначениеРеквизита) Тогда
						СтрокаОшибок = ?(ПустаяСтрока(СтрокаОшибок),"",СтрокаОшибок + ", ") + СтрокаПоиска.ПредставлениеРеквизита;
					Иначе
						Запрос.УстановитьПараметр(СтрокаПоиска.ИмяРеквизита,ТекущаяСтрока[СтрокаПоиска.ИмяРеквизита]);
					КонецЕсли;
					
				КонецЦикла;
				
				Если Не ПустаяСтрока(СтрокаОшибок) Тогда
					Сообщить("Строка " + НомерТекущейСтроки + " не может быть записана.Не указано значение ключевых реквизитов: " + СтрокаОшибок,СтатусСообщения.Важное);
					Продолжить;
				КонецЕсли;
				
				Выборка = Запрос.Выполнить().Выбрать();
				Если Выборка.Следующий() Тогда
					ЗагружаемыйОбъект = Выборка.Ссылка.ПолучитьОбъект();
				КонецЕсли;
				
			КонецЕсли;
			
			ОбъектНайден = Не ЗагружаемыйОбъект = Неопределено;
			Если Не ОбъектНайден Тогда
				Если НеСоздаватьНовыхЭлементов Тогда
					Продолжить;
				Иначе
					ЗагружаемыйОбъект = Справочники[МетаданныеИсточника.Имя].СоздатьЭлемент();
				КонецЕсли;
				
			КонецЕсли;
Показать
добавить:
			Если ОбъектНайден и ЗамещатьСуществующиеЗаписи Тогда 	
				ОбъектНайден = Ложь;
			КонецЕсли;

То же самое сделать в процедуре: ЗагрузитьПодчиненныеСправочники
И воспользоваться соответствующей настройкой
26. NE_ZNAIY 23.06.14 19:25 Сейчас в теме
qwinter (Павел) могли бы вы дать ваши контактные данные (почта) для связи?
мой kidus@yandex.ru
27. BlackStar 02.07.14 10:27 Сейчас в теме
Отличная обработка! Спасибо!
28. RakovskiyK 22.07.14 14:05 Сейчас в теме
Отличная обработка! Спасибо, большое.
Не смотря на то, что я использовал ее в самописной конфигурации и пришлось чуть-чуть допилить - работает идеально. Позволила сэкономить действительно много времени на ввод первичной информации.
Автору респект и плюс в карму!
29. qwinter 506 22.07.14 14:44 Сейчас в теме
(28) RakovskiyK, а что если не секрет допиливали? Она вроде должна и так работать в самописных конфигурациях.
30. xten 39 29.07.14 22:29 Сейчас в теме
Подскажите, пожалуйста, возможно ли с помощью Вашей обработки выгрузить данные из таблицы Excel (6-10 столбцов )в документ Взаимозачеты задолженности в УТ 11. Позволяет ли Ваша обработка непосредственно после загрузки в табличную часть обработки данных из excel выбрать нужный документ и загрузить туда предварительно отображенные данные ? Спасибо.
31. qwinter 506 29.07.14 22:55 Сейчас в теме
(30) xten, Вы немного сумбурно построили вопрос, и я немного его не понимаю. Вам требуется после открытия документа эксель и получения дынных выбрать друго отличный от первоначального документ? Обработка работает по принципу, Вы выбираете документ (принадобности табличную часть или движение по регистру) и настраиваете загрузку, потом открываете документ эксель, и затем загружаете данные.
32. xten 39 30.07.14 10:15 Сейчас в теме
Извиняюсь, возможно некоректно вопрос поставил, два дня только с УТ 11 работаю )) Значит, как я понимаю, органичений по конкретному типу документов нет? Загружаить из ексель можно в табличную часть любого документа?
33. qwinter 506 30.07.14 10:20 Сейчас в теме
(32) xten, Вы все поняли правильно, нет никаких ограничений, можно загружать в любую табличную часть, любого документа или справочника.
34. xten 39 30.07.14 11:28 Сейчас в теме
Супер, ОГРОМНОЕ СПАСИБО ВАМ !!! )))
35. wolverine87 04.08.14 16:31 Сейчас в теме
Отличная обработка! Спасибо!
36. luic 25.08.14 12:51 Сейчас в теме
37. Гость 31.08.14 22:32
У меня версия:

1С:Предприятие 8.2 (8.2.17.153)
Управление торговлей, редакция 10.3.13.2 (10.3.13.2.2)

При открытие файла ЗагрузкаДанныхИзТабличногоДокумента_Q(Управляемые формы).epf
выдает ошибку:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента_УФ.МодульОбъекта(40,21)}: Переменная не определена (СтроковыеФункцииКлиентСервер)
ВызватьИсключение <<?>>СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(

Подскажите, что не так.
38. qwinter 506 01.09.14 13:24 Сейчас в теме
(37) Гость, замените:
ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ЭлементОписаниеКоманды.Представление);

на
Выполнить("ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ЭлементОписаниеКоманды.Представление);");

И
ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтрока,
			КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));

на
Выполнить("	ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтрока,
					|	КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));");
39. yaguarrr 70 18.09.14 09:15 Сейчас в теме
При загрузке в ПТУ (либо регистр сведений Штрихкоды НМКЛ), поиск по характеристикам общим для вида номенклатуры не идет по наименованию для вида номенклатуры. А так обработка очень хорошая, съэкономила достаточно личного времени
40. qwinter 506 18.09.14 10:35 Сейчас в теме
(39) yaguarrr, немного подправил обработку. Теперь такую настройку можно сделать, вот таким образом:
Устанавливаете режим загрузки: Загрузка в регистр сведений. Затем добавляете справочник: Виды номенклатуры, настраиваете загрузку их. Затем добавляете справочник: Характеристики номенклатуры, и в нем в поле владелец ставите устанавливать по настройке Вид номенклатуры и настраиваете поиск по требуемым элементам. А затем в настройке загрузки в регистр в поле характеристики ставите устанавливать по настройке Характеристики номенклатуры.
yaguarrr; +1 Ответить
41. yaguarrr 70 18.09.14 11:46 Сейчас в теме
(40)
Все взлетело - и для регистра сведений и для документа ПТУ, полет нормальный. Благодарю за сверхоперативность.
Неплохо бы добавить данный пример в описание обработки, не каждый сам с первого раза сделает
42. dvsidelnikov 4 27.09.14 22:23 Сейчас в теме
Автор выручай ;)

Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.51.1)

При открытии говорит:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента_УФ.МодульОбъекта(40,21)}: Переменная не определена (СтроковыеФункцииКлиентСервер)
ВызватьИсключение <<?>>СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
44. qwinter 506 28.09.14 13:34 Сейчас в теме
(42) dvsidelnikov, чуть выше уже было описано, как исправить. Запихните код в оператор Выполнить.
dvsidelnikov; +1 Ответить
43. dvsidelnikov 4 28.09.14 08:08 Сейчас в теме
Люди добрые, подскажите, а как бы заставить обработку не вставлять строку в табличную часть документа, если не было найдено значение в справочнике 1С по коду для одного из полей текущей строки табличного документа

Допустим: бежит обработка по табличному документу, считывает значение артикула из табличного документа, пытается найти номенклатуру в 1С по данному артикулу, не находит и как следствие не создаёт строку в вводе остатков, плавно переходя к обработке следующей строки табличного документа.
45. qwinter 506 28.09.14 13:46 Сейчас в теме
(43) dvsidelnikov, в событии "После добавления строки":
Если не ЗначениеЗаполнено(ТекущиеДанные.РеквизитСтроки) Тогда
 Объект.ТЗ.Удалить(ТекущиеДанные);
КонецЕсли;
plus1s_a; dvsidelnikov; +2 Ответить
46. zzzhen 14 01.10.14 12:24 Сейчас в теме
Здравствуйте!
При нажатии "Загрузить"
Конфигурация "Розница", платформа 8.3
Сообщение - "Использование модальных окон в данном режиме запрещено"
что делать?
спасибо
47. qwinter 506 01.10.14 15:14 Сейчас в теме
(46) zzzhen,
Всю процедуру "КомандаЗагрузить" заменить на:
&НаКлиенте
Процедура КомандаЗагрузить(Команда)
	
	СтруктураТекстВопроса = ПолучитьТекстВопросаИсточника();
	КоличествоЭлементов = ТаблицаПодготовленныхДанных.Количество();
	
	Если НЕ ПустаяСтрока(СтруктураТекстВопроса.Ошибка) Тогда
		
		ТекстПредупреждения = СтруктураТекстВопроса.Ошибка;
		
		Если ВерсияПлатформы83 Тогда
			Выполнить("
			|	ПоказатьПредупреждение(, ТекстПредупреждения);
		    |");
		Иначе
				Предупреждение(ТекстПредупреждения);
		КонецЕсли;
			
	Иначе
		
		нПараметры = Новый Структура;	
		ТекстВопроса = "Загрузить "+КоличествоЭлементов  + СтруктураТекстВопроса.ТекстВопроса;
		Если ВерсияПлатформы83 Тогда
			Выполнить("
			|	ОписаниеОповещения = Новый ОписаниеОповещения(""ВопросНачатьЗагрузкуДанных"", ЭтотОбъект, нПараметры);
			|	ПоказатьВопрос(ОписаниеОповещения, ТекстВопроса, РежимДиалогаВопрос.ДаНет, 60);
			|");
		Иначе
			ОтветНаВопрос = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);
			ВопросНачатьЗагрузкуДанных(ОтветНаВопрос, нПараметры);
		КонецЕсли;
			
	КонецЕсли;	
		
КонецПроцедуры

&НаКлиенте
Процедура ВопросНачатьЗагрузкуДанных(РезультатВопроса, ДополнительныеПараметры) Экспорт
	
	Если РезультатВопроса = КодВозвратаДиалога.Да Тогда 
		ОчиститьСообщения();
		ЗагрузитьДанныеСервер();
		
		Если ВыполняетсяЗаполнениеТЧОбъекта Тогда
			ПараметрыКоманды = Новый Структура("ДополнительнаяОбработкаСсылка, ОбъектыНазначения, СопровождающийТекст");
			ПараметрыКоманды.ДополнительнаяОбработкаСсылка = ОбъектСсылка;
			ПараметрыКоманды.СопровождающийТекст = "";
			
			Состояние(ПараметрыКоманды.СопровождающийТекст);
			
			РезультатВыполнения = ВыполнитьКомандуНапрямую(ИдентификаторКоманды, ПараметрыКоманды);
			ЗагрузитьРезультат(РезультатВыполнения);	
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры
Показать
48. MarkTven 05.10.14 14:25 Сейчас в теме
в УТ для Украины редакция 3
не работает регистрация обработки в базе:
{Форма.Форма.Форма(4652)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
Выполнить("
по причине:
{(2,95)}: Переменная не определена (ЭтотОбъект)
ОписаниеОповещения = Новый ОписаниеОповещения("ЗарегистрироватьвИБПослеПомещенияВХранилище", <<?>>ЭтотОбъект);
49. dvsidelnikov 4 24.10.14 13:25 Сейчас в теме
Люди добрые, а загрузка в табличную часть справочника имеет место быть? что-то я не нашёл.
50. qwinter 506 24.10.14 13:32 Сейчас в теме
(49) dvsidelnikov, в режиме "Поточная загрузка".
dvsidelnikov; +1 Ответить
51. an.azarova 4 06.11.14 12:36 Сейчас в теме
Работало, после обновления сломалась :(
52. qwinter 506 06.11.14 12:53 Сейчас в теме
(51) an.azarova, здравсвуйте. Какую ошибку пишет? Какая конфигурация?
53. an.azarova 4 06.11.14 18:00 Сейчас в теме
{Форма.Форма.Форма(473)}: Значение не является значением объектного типа (Свойство)
СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);
УНФ 1,5,20
54. qwinter 506 06.11.14 20:31 Сейчас в теме
(53) an.azarova, у меня не воспроизводится. Что именно произошло когда перестало работать? У Вас, что то произошло с сохраненными настройками.
Как вариант замените:
	ВосстановленнаяТекущаяВерсия = Неопределено;
	СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);

на:
	Если ТипЗнч(СостояниеВыполнения) <> Тип("Структура") Тогда 
		Возврат;
	КонецЕсли;
	
	ВосстановленнаяТекущаяВерсия = Неопределено;
	СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);
338. oxana1 17.12.15 16:00 Сейчас в теме
здравствуйте!
скачала обработку, пытаюсь разобраться

пытаюсь сохранить настройку - выдает ошибку "Поле объекта не обнаружено (Текущая версия)"

до этого каким-то волшебным образом сохранила настройку и поставила галку Открывать, и выдавало ошибку, как в (54), заменила в коде обработки - саму обработку открывает... но дальше сохранить настройки все равно не дает...
339. qwinter 506 17.12.15 16:22 Сейчас в теме
(338) oxana1, добавьте у формы реквизит: "ТекущаяВерсия", тип Строка(10). А так же в процедуре "ВосстановитьНастройкиИзСостоянияВыполнения" замените
ТЗ = РеквизитФормыВЗначение(СтрокаНастроек.КлючСтраницыНастроек);
		ВосстановитьЗначенияНастроекИзТаблицыРеквизитов(ТЗ, ВосстановленнаяТаблицаЗагружаемыхРеквизитов);
		ЗначениеВРеквизитФормы(ТЗ, СтрокаНастроек.КлючСтраницыНастроек)
на
ТЗ = РеквизитФормыВЗначение(СтрокаНастроек.КлючСтраницыНастроек.КлючСтраницы);
		ВосстановитьЗначенияНастроекИзТаблицыРеквизитов(ТЗ, ВосстановленнаяТаблицаЗагружаемыхРеквизитов);
		ЗначениеВРеквизитФормы(ТЗ, СтрокаНастроек.КлючСтраницыНастроек.КлючСтраницы)
342. oxana1 19.12.15 12:27 Сейчас в теме
(339) попробую, спасибо!
пока сложно, хоть и с типовой обработкой с ИТС знакома и грузила ею
55. an.azarova 4 07.11.14 16:09 Сейчас в теме
56. plus1s_a 17.11.14 10:12 Сейчас в теме
Скачал. Попробую на ERP 2.0 при подготовке НСИ базы.
57. BodunOff 24.11.14 17:26 Сейчас в теме
Павел, прошу прощения за вопрос дилетанта, не могу разобраться с настройкой. Задача такая, есть дополнительные реквизиты вида номенклатуры "Для характеристик" (например, Размер и Цвет) со списком значений. Имеется ли возможность данной обработкой произвести сопоставление при загрузке характеристик с уже имеющимися в списке значением? Пробую пакетную загрузку характеристик, выбираю ТЧ Дополнительные реквизиты и получаю ошибку на выходе:
{Форма.Форма.Форма(2162)}: Поле объекта не обнаружено (Дополнительные значения)


Буду очень признателен за помощь!

P.S. Сорри за такое отображение кода, не могу понять что это, оригинал вот:
{Форма.Форма.Форма(2162)}: Поле объекта не обнаружено (Дополнительные значения)
58. qwinter 506 24.11.14 21:08 Сейчас в теме
(57) BodunOff, а какая конфигурация? Ошибка происходит сразу после выбора ТЧ? Я попробовал в УТ 11.1 у меня все грузится.

Принцип работы Вами выбран правильно. Выбираете поточную загрузку справочника, добавляете табличную часть. Не забывайте по возможности ограничивать типы получаемых значений, например в УТ11 в реквизит Значение в табличной части "дополнительные реквизиты" имеет очень много типов, лучше ограничить его до одного нужного.
59. BodunOff 24.11.14 22:10 Сейчас в теме
Конфигурация УТ 11.1.9.56. Ошибка происходит на этапе проверки внесенных данных. Выбираю следующие значения, см. скрины.


Прикрепленные файлы:
60. BodunOff 24.11.14 22:44 Сейчас в теме
...например в УТ11 в реквизит Значение в табличной части "дополнительные реквизиты" имеет очень много типов, лучше ограничить его до одного нужного...

Так и выбираю один тип "Дополнительное значение" чтобы оно к табличной части пробилось
61. qwinter 506 26.11.14 21:47 Сейчас в теме
(60) BodunOff, это ошибка в функции: "ПолучитьВозможныеЗначения":
замените:
				Если ЭтоСправочник  И ТипЗнч(Справочники[Строка(МетаданныеТипа)].ПустаяСсылка()[ИскатьПо]) = Тип("Число") Тогда
					Попытка
						Представление = Число(Представление);	
					Исключение
						//ОписаниеОшибки()
					КонецПопытки;
				КонецЕсли;
на
				Если ЭтоСправочник  Тогда
					Если ТипЗнч(Справочники[Строка(МетаданныеТипа.Имя)].ПустаяСсылка()[ИскатьПо]) = Тип("Число") Тогда
						Попытка
							Представление = Число(Представление);	
						Исключение
							//ОписаниеОшибки()
						КонецПопытки;
					КонецЕсли;
				КонецЕсли;
Показать

или скачайте обновленный файл.
62. qwinter 506 26.11.14 21:51 Сейчас в теме
(60) BodunOff, однако для загрузки дополнительных значений, надо еще создать дополнительную настройку для справочника "Дополнительные значения" и установить ее как используемую для значения дополнительных значений. Пример во вложении.
Прикрепленные файлы:
Характеристика.qxlz
63. BodunOff 26.11.14 22:19 Сейчас в теме
Спасибо огромное! Всё получилось как надо!!! Если бы можно было поставить ещё пару звёзд они все были бы ваши, я искал эту обработку с момента перехода на управляемые формы)))
64. Гость 03.12.14 14:18
БГУ 8.2
обработка не запускается
65. qwinter 506 03.12.14 15:30 Сейчас в теме
(64) Гость, откройте БГУ в режиме "управляемое приложение".
66. Гость 04.12.14 15:26
(65) Спасибо открылась , но теперь при загрузке таблицы данных дает ошибку (в прикрепл.файле) БГУ 8.2.18.96 Конфигурация 1.0.25.9
Прикрепленные файлы:
ошибка.doc
67. qwinter 506 04.12.14 15:45 Сейчас в теме
(66) Гость, ошибку исправил, скачайте обновленную обработку, или в модуле формы:
			Если ЭтоДокумент Тогда
			ТекстЗапроса =
				"Выбрать Первые 1
				|Объект.Ссылка КАК Ссылка
				|Из Документ."+МетаданныеИсточника.Имя+" КАК Документ
				|Где";
заменить на:
			Если ЭтоДокумент Тогда
			ТекстЗапроса =
				"Выбрать Первые 1
				|Объект.Ссылка КАК Ссылка
				|Из Документ."+МетаданныеИсточника.Имя+" КАК Объект
				|Где";
68. BodunOff 06.12.14 14:16 Сейчас в теме
Павел, возникла проблема загрузки характеристик номенклатуры (с доп. реквизитами) в одну из баз УТ 11. Не могу ни объяснить толком ни отловить самостоятельно ошибку. По-возможности напишите мне в скайп pavel.bodunov в любое удобное для Вас время для настройки на возмездной основе.
69. NOVOPRO 11.12.14 07:35 Сейчас в теме
Д.д.
Ну выполнил нижеуказанную процедуру, как до этого не работало так и сейчас не работает:

в процедуре ВосстановитьНастройкиИзСостоянияВыполнения
ТипОбъектаСправочника = Неопределено;
СсылкаИсточника = Неопределено;
ИмяВидаРегистра = Неопределено;
ТабличнаяЧастьИсточника = Неопределено;
СсылкаДокумента = Неопределено;
РегистрДокумента = Неопределено;

ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);

ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);
УстановитьИсточник();

ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);

...Показать
заменить, на:
ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);

Если НЕ ВыполняетсяЗаполнениеТЧОбъекта Тогда
ТипОбъектаСправочника = Неопределено;
СсылкаИсточника = Неопределено;
ИмяВидаРегистра = Неопределено;
ТабличнаяЧастьИсточника = Неопределено;
СсылкаДокумента = Неопределено;
РегистрДокумента = Неопределено;

ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);
УстановитьИсточник();
ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
КонецЕсли;

70. qwinter 506 11.12.14 09:39 Сейчас в теме
Ну выполнил нижеуказанную процедуру, как до этого не работало так и сейчас не работает:
не работает что?
71. rez222 03.01.15 09:23 Сейчас в теме

Добрый день,

1С:Предприятие 8.3 (8.3.5.1231)
Управление торговлей, редакция 11.1 (11.1.9.44)

пытаюсь загрузить реквизиты как дополнительные значения. Во вложении настройки.
Во время загрузки получаю ошибку, хотя предварительная загрузка в таблицу данных проходит успешно
{Форма.Форма.Форма(1570)}: Значение не является значением объектного типа (Ссылка)
Возврат ЗагружаемыйОбъект.Ссылка;

Не могу понять - это я что-то делаю неверно?

Спасибо.
Прикрепленные файлы:
дп.qxlz
72. qwinter 506 03.01.15 13:56 Сейчас в теме
(71) rez222, ошибка на последней версии воспроизводится?
73. rez222 03.01.15 20:43 Сейчас в теме
Разобрался. Дело было в используемой версии обработки.
Павел, спасибо!


Возник другой вопрос -

возможно ли настроить загрузку начальных остатков по контрагентам в табличную часть по типу расчетного документа - договор, счет, реализация и т.п.с подстановкой в "номер" ссылки на документ соответсвующего типа?
74. qwinter 506 04.01.15 11:25 Сейчас в теме
(73) rez222, честно говоря не понял вопроса. Опишите подробнее.
75. isteroid 01.02.15 12:53 Сейчас в теме
Обработка позволяет считать данные и произвести настройки, но при попытке загрузки данных в базу выдает ошибку:
{(2,78)} Переменная не определена (ЭтотОбъект)
помогите - бухгалтера плачут, говорят, что ждать не могут
76. qwinter 506 01.02.15 15:18 Сейчас в теме
(75) isteroid, какая у вас конфигурация? Какая версия конфигурации? И какая версия платформы?
78. qwinter 506 07.02.15 21:06 Сейчас в теме
(75) isteroid, исправил.
(77) Rebelx, добавил в обработку функционал для подобных загрузок данных.
77. Rebelx 953 05.02.15 20:39 Сейчас в теме
Не получается загрузить данные :(
Ругается еще на этапе проверки заполнения

Задача - установить для номенклатуры единицы измерения.

ут10

Таблица:
Артикул Единица_Наименование

Единицы - подчинены номенклатуре, созданы
Искать - по наименованию и владельцу (<Создаваемый объект>?), который задан артикулом. Настройка такая есть, но она не работает :(((

Пока выход видимо использовать "Вычислять", но как-то это не кошерно.
79. Litvin2015 08.02.15 13:41 Сейчас в теме
как восстанавливать старые данные при открытии новой формы?
80. qwinter 506 08.02.15 14:08 Сейчас в теме
(79) Litvin2015, какие старые данные?
81. intersoft_1c 10.02.15 18:46 Сейчас в теме
Как с помощью обработки создавать новые элементы справочника. Я создаю заказ поставщику. Данные в табличное поле документа все заполняются. Надо чтобы если нет номенклатуры, то номенклатура сама создавалась.
82. qwinter 506 10.02.15 18:56 Сейчас в теме
(81) intersoft_1c, после настройки основной таблицы добавляете настройку загрузки номенклатуры кнопкой "Добавить справочник", а в настройке табличной части документа у номенклатуры ставите режим "Устанавливать" и в значение по умолчанию выбираете настройку загрузки "1: Номенклатура".
83. intersoft_1c 10.02.15 19:11 Сейчас в теме
(82)
А как надо настраивать справочник Номенклатуру, чтобы он искал по артикулу, если не нашел, то создать номенклатуру.
84. qwinter 506 10.02.15 19:16 Сейчас в теме
(83) intersoft_1c, устанавливаете в настройке номенклатуры реквизиту "Артикул" настройку что он "Поле поиска"
85. intersoft_1c 10.02.15 19:28 Сейчас в теме
П(84) Поставил галочку, что он поле поиска, Режим загрузки установил Искать, указал колонку поиска. Номенклатура не ищется а в поле артикул в таблице данных в таблице 1.Номенклатура выходит просто Артикул, а в таблице Настройка Номенклатура вообще пустая
86. qwinter 506 10.02.15 19:42 Сейчас в теме
(85) intersoft_1c, загрузку данных непосредственно делали? При получении таблицы данных так и должно быть.
87. intersoft_1c 10.02.15 21:42 Сейчас в теме
(86) Все получилось,Спасибо. Еще вопрос. Можно сделать так, чтобы поиск по артикулу происходило только в одной группе.
88. qwinter 506 10.02.15 22:07 Сейчас в теме
(87) intersoft_1c, реквизиту "Родитель" поставьте, что оно является полем поиска и режим устанавливать, и выберете требуемую группу. При не нахождении номенклатуры, новые будут создавать в этой же папке.
89. intersoft_1c 11.02.15 10:09 Сейчас в теме

(88) Если так сделать, то он перестает искать по артикулу, сразу создает всю номенклатуру в этой папке.
90. qwinter 506 11.02.15 14:03 Сейчас в теме
(89) intersoft_1c, а вы при этом случайно с реквизита артику поле поиска не сняли?
91. intersoft_1c 11.02.15 15:40 Сейчас в теме
(90) Нет не снимал. Такая задача уже не стоит, поиск сказали нужен по всей номенклатуре. Обработка хорошая, но только нет описания по настройке.
92. qwinter 506 11.02.15 20:29 Сейчас в теме
(91) intersoft_1c, сейчас даже на добавление в нее нового функционала времени особенно нет, так что описание на данный момент точно не в приоритете. Может кто то из пользователей захочет сделать такое доброе дело, думаю было бы востребовано. Можно даже сделать отдельную статью.
93. alisaguzel 13.02.15 15:54 Сейчас в теме
Прошу помощи!!! Я ни чего не могу поделать с загрузкой бух. проводок... ВидСубконто проставила. Но все равно не получается. Может делаю настройки неверно? Счета учета встают на место, сумма отображается корректно, но субконто пустое. Маюсь уже вторую неделю. Результат ноль. Буду очень признательна за помощь.
Прикрепленные файлы:
94. qwinter 506 13.02.15 16:41 Сейчас в теме
(93) alisaguzel, ограничьте искомые типы (колонка "Описание типов") оставьте там только справочник номенклатуры. Режим загрузки "Искать". Если не получится то прикрепите саму настройку и пример файла.
Оставьте свое сообщение