Реализация обмена по организации в УТ

Публикация № 286505

Разработка - Обмен данными 1С - Распределенная БД (УРИБ, УРБД)

обмен обмен по организации ут управление торговлей

10
В связи с открытием филиала в другом городе возникла необходимость организации учета в конфигурации "Управление торговлей для Казахстана, ред. 3" (адаптированный аналог "Управление торговлей, ред. 11"). Как оказалось встроенного обмена по организации не оказалось, есть только "Полный". Пришлось реализовывать самому. Конечно был вариант работы через терминальное подключение и тонкий клиент, но в связи во-первых неустойчивыми каналами связи и с заделкой на будущее (большие объемы данных) решил сделать РИБ. И вот об этом моя первая статья, может поможет кому нибудь.  

Имеем следующее: Работающая информационная база на основе конфигурации "Управление торговлей для Казахстана, ред. 3", в основном используемая для торговых операций в городе А. Решили открыть филиал в городе Б. Выбирали между 3 вариантами:

1. работа в режиме управляемого приложения (тонкий клиент) (отпал из-за неустойчивого канала связи)

2. работа в терминальном режиме (отпал из-за возможного постоянного конфликта блокировок, проблемы с обновлением)

3. РИБ

Выбрали РИБ (по нашему мнению самый отлаженный и надёжный способ работы при больших нагрузках). Реализацию возложили на меня.

Требования вкратце: документы, регистры должны кочевать с региональной привязкой по организации, справочники, константы, планы видов характеристик общие

Описываю алгоритм:

1) Работа в режиме конфигуратор. Скопировал план обмена "Полный" (так как есть объекты которые должны быть только в региональных базах). Переименовал в "План обмена". Добавил реквизит "организация" с типом справочникссылка. организация

2) Откорректировал состав обмениваемых данных. В общих объектах (справочники, константы, планы видов характеристик) поставил авторегистрация=разрешить. В остальных поставил авторегистрация=запретить.

3) В общих модулях создал глобальный общий модуль "ОбменПоОрганизации" . Текст модуля в файле "Общий модуль".  Для выкладывания текст большой.

Процедура обРегистрацияИзменений(Объект) Экспорт 
	ГлавныйУзел = ПланыОбмена.ГлавныйУзел();
	Если ГлавныйУзел=Неопределено Тогда    //это центральная база
		ПланОбмена = ПланыОбмена.ПланОбмена.Выбрать();
		Пока ПланОбмена.Следующий() Цикл
			//В сам себя не отправляем
			Если ПланОбмена = ПланыОбмена.ПланОбмена.ЭтотУзел() тогда
				Продолжить;
			КонецЕсли;    
			Если ПланОбмена.НомерОтправленного = 0 и ПланОбмена.НомерПринятого = 0 Тогда
				// Похоже на главный. Хотя не факт.
				Продолжить;
			КонецЕсли;
			//Некое хитрое условие
			Если обОтправлятьОбъектВУзел(Объект, ПланОбмена) Тогда
				//Объект.ОбменДанными.Получатели.Добавить(ПланОбмена.Ссылка);
				Попытка
					Объект.ОбменДанными.Получатели.Добавить(ПланОбмена.Ссылка);
					//ПланыОбмена.ЗарегистрироватьИзменения(ПланОбмена.Ссылка,Объект);
				Исключение      
					Сообщить(ОписаниеОшибки());				
				КонецПопытки;
			КонецЕсли;
		КонецЦикла;
		попытка
			Объект.ОбменДанными.Получатели.Добавить(ПланыОбмена.ПланОбмена.ЭтотУзел());
		исключение
		конецпопытки;
	Иначе
		//изменен периферийный объект в базе создания
		
		Объект.ОбменДанными.Получатели.Добавить(ГлавныйУзел);
		//ПланыОбмена.ЗарегистрироватьИзменения(ГлавныйУзел,Объект);
	КонецЕсли;
КонецПроцедуры

Функция обОтправлятьОбъектВУзел(Объект, ПланОбмена)
	Если Метаданные.Справочники.Найти(Метаданные.НайтиПОТипу(ТипЗнч(Объект)).Имя) <> Неопределено Тогда
		// Это справочник. Поэтому отправляем.
		Возврат Истина;
	ИначеЕсли Метаданные.РегистрыНакопления.Найти(Метаданные.НайтиПоТипу(ТипЗнч(Объект)).Имя) <> Неопределено Тогда
		// Это регистр накопления. Посмотрим какая организация у него в регистраторе. И есть ли она вообще.
		Рег = Объект.Отбор.Регистратор.Значение.ПолучитьОбъект();
		Если Рег = Неопределено Тогда
			//Если регистратор неопределен, то не отправляем никуда
			Возврат ложь
		КонецЕсли;	
		Если Метаданные.НайтиПоТипу(ТипЗнч(Объект)).Имя =  "ТоварыВПути" Тогда
			Если ТипЗнч(Рег) = Тип("ДокументОбъект.Транзит") Тогда
				Если Рег.ОрганизацияПолучатель = ПланОбмена.Организация или планыобмена.ГлавныйУзел()=ПланОбмена  Тогда
					Возврат Истина;
				Иначе
					Возврат Ложь;
				КонецЕсли;
			Иначе
				Если Рег.Организация = ПланОбмена.Организация или планыобмена.ГлавныйУзел()=ПланОбмена Тогда
					Возврат Истина;
				Иначе
					Возврат Ложь;
				КонецЕсли;
			КонецЕсли;
		Иначе	
			Если ЕстьРеквизитДокумента("Организация", Объект) Тогда
				Если Рег.Организация = ПланОбмена.Организация Тогда
					Возврат Истина;
				Иначе
					Возврат Ложь;
				КонецЕсли;
			Иначе
				// Нет реквизита организация значит уходит однозначно.
				Возврат Истина;
			КонецЕсли;
		КонецЕсли;	
	ИначеЕсли Метаданные.РегистрыСведений.Найти(Метаданные.НайтиПоТипу(ТипЗнч(Объект)).Имя) <> Неопределено Тогда
		// Это регистр сведений. Посмотрим какая организация у него в регистраторе. И есть ли она вообще.
		Попытка
			Рег = Объект.Отбор.Регистратор.Значение.ПолучитьОбъект();
		Исключение
		Конецпопытки;
		
		Если Рег = Неопределено Тогда
			//Если регистратор неопределен, то не отправляем никуда
			Если ЕстьРеквизитДокумента("Организация", Объект) Тогда
				Если Объект.Отбор.Организация.Значение = ПланОбмена.Организация Тогда
					Возврат Истина;
				Иначе
					Возврат Ложь;
				КонецЕсли;
			Иначе
				// Нет реквизита организация значит уходит однозначно.
				Возврат Истина;
			КонецЕсли;
		Иначе 
			Если ЕстьРеквизитДокумента("Организация", Объект) Тогда
				Если Рег.Организация = ПланОбмена.Организация Тогда
					Возврат Истина;
				Иначе
					Возврат Ложь;
				КонецЕсли;
			Иначе
				// Нет реквизита организация значит уходит однозначно.
				Возврат Истина;
			КонецЕсли;
			
			
		КонецЕсли;	
		
		
	Иначе
		// Это документ. Его мы проверяем на организацию.
		Если ЕстьРеквизитДокумента("Организация", Объект) тогда
			Если Объект.Организация = ПланОбмена.Организация или планыобмена.ГлавныйУзел()=ПланОбмена Тогда
				Возврат Истина;
			Иначе
				Если ЕстьРеквизитДокумента("ОрганизацияПолучатель", Объект) Тогда
					Если Объект.ОрганизацияПолучатель = ПланОбмена.Организация или планыобмена.ГлавныйУзел()=ПланОбмена Тогда
						Возврат Истина;
					Иначе
						Возврат Ложь;	
					КонецЕсли;
				Иначе	
					Возврат Ложь;
				КонецЕсли;	
			КонецЕсли;
		Иначе
			// Нет реквизита организация значит уходит однозначно.
			Возврат Истина;
		КонецЕсли;
		
	КонецЕсли;
	
КонецФункции

// Позволяет определить есть ли среди реквизитов шапки документа
// реквизит с переданным именем.
//
// Параметры: 
//  ИмяРеквизита - строковое имя искомого реквизита, 
//  МетаданныеДокумента - объект описания метаданных документа, среди реквизитов которого производится поиск.
//
// Возвращаемое значение:
//  Истина - нашли реквизит с таким именем, Ложь - не нашли.
//
Функция ЕстьРеквизитДокумента(ИмяРеквизита, Объект) Экспорт
	
	ТипОбъекта = ОпределитьТипОбъекта(Объект);
	МетаданныеДокумента = Объект.Метаданные();
	
	Если ТипОбъекта="Документ" тогда
		Если МетаданныеДокумента.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
			Возврат Ложь;
		Иначе
			Возврат Истина;
		КонецЕсли; 
	ИначеЕсли ТипОбъекта="РегистрСведений" тогда
		Если МетаданныеДокумента.Измерения.Найти(ИмяРеквизита) = Неопределено Тогда
			Если МетаданныеДокумента.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
				Возврат Ложь;
			Иначе
				Возврат Истина;
			КонецЕсли; 
		Иначе
			Возврат Истина;
		КонецЕсли; 
		
	ИначеЕсли ТипОбъекта="РегистрНакопления" тогда
		Если МетаданныеДокумента.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
			Возврат Ложь;
		Иначе
			Возврат Истина;
		КонецЕсли; 
		
	Иначе
		Возврат Ложь;
		
	КонецЕсли;
	
	
КонецФункции // ЕстьРеквизитДокумента()

Функция ОпределитьТипОбъекта(Объект)
	
	Класс = Объект.Метаданные().ПолноеИмя();
	Класс = Лев(Класс, Найти(Класс, ".")-1);	
	
	Возврат Класс;
	
КонецФункции

4) Затем в объектах, где данные нужно фильтровать и объект включен в состав обмена (документы, регистры) необходимо в модулях объектов в процедуре приЗаписи добавить вызов процедуры обРегистрацияИзменений().

Если ЭтотОбъект.ОбменДанными.Получатели.АвтоЗаполнение и не ЭтотОбъект.ОбменДанными.Загрузка Тогда
        обРегистрацияИзменений(ЭтотОбъект) ;
КонецЕсли;

5) Подчиненный узел создал копированием оригинала и удалением документов, юзеров. Затем сделал рокировку планов обмена (подмена кодов узла). Установил главный узел.
6) Почистил регистрацию изменений на всякий случай. Нужно учитывать если объект хоть где-то удаляется, то он удаляется и в остальных узлах!!!
7) Затем при первоначальном начале работы подчиненного узла убрал вызов помощника настройки обмена.

И все в принципе. Думаю можно это можно использовать в любых конфигурациях, надо немного дописать для регистров бухгалтерии и расчетов. А так для торговых уже готово.

10

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Bor_ka 84 28.08.14 14:55 Сейчас в теме
Понравился подход, можно подробнее о пунктах 5,6,7?
2. Bajo 69 29.08.14 06:51 Сейчас в теме
(1) Bor_ka, по пункту 5. В оригинале базы создал подчиненные узлы. Сделал копию выгрузив базу в *.DT. Загрузил в чистую базу. В планах обмена в новой базе удалил лишние узлы осталось только 2. Поменял коды узлов местами. Откорректировал реквизит "Организация" в соответствии с реальностью.
пункт 6. Все объекты имеют уникальный идентификатор. Если в филиале №1 в справочнике контрагенты произойдет непосредственное удаление элемента, то после обмена с центром этот объект удалится в центральной базе. Затем когда центральная база сделает обмен с филиалом №2, то объект удалится и в этой базе.
пункт 7. при развертке РИБ в типовой конфигурации при первом запуске базы автоматически запускается помощник настройки обмена. он работает косячно. я не стал разбираться, просто отключил его.

базы работают уже полгода никаких проблем с обменом.
3. kumga99 20 18.06.15 14:59 Сейчас в теме
Калайсын,Айтуар? красавчик, буны сен енгизип един эпл ситиде?
4. Bajo 69 30.06.15 14:39 Сейчас в теме
(3) kumga99, Жаксы. Сам как? Да эпл март кой. Кайда жумыс истеп журсин?
Оставьте свое сообщение

См. также

И снова "Конфигурация узла распределенной ИБ не соответствует ожидаемой" 13

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Распределенная БД (УРИБ, УРБД) Обмен данными 1С

Конфигурация узла распределенной ИБ не соответствует ожидаемой. Приведен очередной способ устранения этой ошибки, возникший не в результате сбоев в работе оборудования или при обмене, а в результате обновления платформы 1С.

05.11.2019    786    Kobra_RU    5       

Как отвязать информационную базу от РИБа -1

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Краткая инструкция для новичков о том, как в 2 клика отвязать информационную базу от РИБа.

03.05.2018    9646    user861285    10       

Расширения конфигурации и РИБ, друзья или враги? Или как мы передаем расширения подчиненным РИБ узлам 44

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Читая комментарии к курсу касательно новых возможностей расширений конфигурации, которые привнес релиз 8.3.11, на одном из известных сайтов с курсами, я обратил внимание, что коллегам приходится отказываться от расширений из-за решения перейти на РИБ. Мы сами относительно недавно начали переходить на РИБ, и мы также активно пользуемся расширениями и в этой статье я хотел бы рассказать, как мы решили эту проблему.

24.11.2017    14441    markers    8       

Восстановление обмена в РИБ. Запущенный случай 17

Статья Системный администратор Программист Нет файла v8 Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Удачная попытка восстановить обмен в РИБ при большом количестве объектов обмена и ошибках при обмене.

03.04.2017    11931    peterxx    13       

Что делать, если параметр запуска /resetmasternode приводит к вылету с дампом 10

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Для тех, кто столкнулся с проблемой отключения узловой базы от главного узла через параметр запуска /ResetMasterNode.

01.04.2017    12959    therva    4       

Проблема с обновлением типовой конфигурации УТП 1.2 (Украина) в дочернем узле 2

Статья Системный администратор Нет файла v8 1cv8.cf Украина Бесплатно (free) Распределенная БД (УРИБ, УРБД)

При обновлении конфигурации в дочернем узле РБД , в случае, если обновление добавляет предопределенные элементы справочников, невозможно загрузить файл обмена стандартными средствами

15.02.2017    10633    bulpi    4       

Конфигурация узла распределенной ИБ не соответствует ожидаемой 12

Статья Системный администратор Нет файла v8 Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Есть куча материалов, где описано решение возникающей ошибки при обмене с РИБ, но ни одно не помогло. Пришлось включить мозг, и, о чудо, было найдено простое решение.

26.01.2017    18459    virtmon    29       

Планы обмена. Управляемый режим блокировок 133

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Статья о том, как устроен объект конфигурации 1С:Предприятие 8 "План обмена", в том числе на уровне СУБД SQL Server. Анализируются особенности его использования при управляемом режиме блокировок.

28.11.2016    35427    zhichkin    16       

Highload обмен данными: постановка задачи 3

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Производительность и оптимизация (HighLoad) Распределенная БД (УРИБ, УРБД)

Цели статьи: определить, что такое "highload обмен", описать типовой сценарий обмена, сформулировать основные требования к обменам такого типа и предложить методику оценки производительности (пропускной способности).

04.11.2016    12210    zhichkin    3       

РИБ 200 узлов. Середина пути 116

Статья Системный администратор Программист Нет файла v8 Розница Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    34669    comol    215       

Корректное отключение от главного узла РИБ и создание самостоятельной БД. Быстрое создание/восстановление узла РИБ без выгрузки начального образа для конфигураций на основе БСП 53

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

В публикации описан один из способов создания тестовой БД для разработки с актуальными данными, быстрого восстановления работоспособности РИБ при "падении" одного из узлов, или "быстрого" создания/восстановления узла РИБ без выгрузки начального образа для конфигураций на основе БСП.

16.02.2016    86618    asg.aleks    12       

Автоматическое обновление конфигурации в узлах РИБ 22

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Вариант автоматического обновления конфигурации (без участия пользователей) периферийной базы РИБ. Очень простой способ без необходимости внесения кода в конфигурацию 1С. В дополнение к публикации http://infostart.ru/public/143517/. Спасибо автору, навел на эту идею!

22.01.2016    21229    Kitri    4       

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.) 49

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    32427    NittenRenegade    16       

Как я восстанавливал разрушенную базу 45

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Архивирование (backup) Распределенная БД (УРИБ, УРБД) Тестирование и исправление

УТ10.3 на Платформе 8.2 на базе MSSQL была разрушена после попытки её восстановить после неудачного динамического обновления. Таблица Config целевой базы была заменена на содержимое таблицы Config от другой рабочей базы. Но на самом деле конфигурации у них существенно отличались, поэтому после таких действий целевая база рухнула окончательно. Что же делать?

21.08.2015    24511    METAL    25       

"Распил" базы "БП 3.0 ПРОФ" с дальнейшим переносом в "БП 3.0 Базовая" ОДНОЙ организации 8

Статья Системный администратор Программист Нет файла v8 Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Условия: Есть "БП 3.0 ПРОФ", в которой ведется учет по трем (неважно, скольким) Организациям. Необходимо оставить учет только по одной (к примеру) организации, и при этом перенести все данные по ней в "БП 3.0. Базовая"

14.08.2015    14517    Viktor_Ermakov    10       

Автоматическое обновление конфигурации периферийного узла РИБ при обмене 31

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

При большом количестве периферийных узлов в РИБ достаточно проблематично производить обновление конфигурации. В данной статье опишу свой опыт решения данной проблемы.

24.03.2015    25648    kondrat1C    20       

Выделение одной организации из Бухгалтерии редакция 3 через РИБ 21

Статья Системный администратор Нет файла v8 БП2.0 Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Выделение одной организации из Бухгалтерии редакция 3 через РИБ (например, 3.0.36.16) может привести к большим проблемам с последующими обновлением.

16.02.2015    12528    shevelyov    4       

Обмен с помощью WMI 8

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Полный контроль над процессом, осуществляемый из единого центра.

10.11.2014    8732    loekyn    7       

Обмены данными и РИБ с использованием облачных сервисов 11

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Проверенный на практике, простой и доступный способ настройки обменов данными без использования FTP и встроенного почтового клиента.

22.10.2014    16468    rarename    14       

РИБ для УНФ 28

Статья Программист Нет файла v8 УНФ Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Штатного механизма типового полного обмена (РИБ) нет. Добавляем этот функционал. Данный способ подойдет для типового релиза УНФ начиная с версии 1.4.7.37 или для конфигураций на основе БСП.

10.01.2014    26619    ZhAmAn    28       

Интерактивный счетчик объектов обмена 7

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

При обменах на периферийных базах счетчик обмена сделан не очень красиво – он зависает на 10% и вся загрузка не отображается на счетчике. Предлагаю методику, чтобы визуализировать прогресс загрузки/выгрузки.

16.08.2013    15333    fixin    3       

Параллельность выгрузок 87

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Рассказываю свой опыт, как добился параллельности выгрузки из центральной базы РИБ сразу в 70 узлов.

15.08.2013    22507    fixin    41       

Из главного узла не загружены изменения справочника "Идентификаторы объектов метаданных" 10

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД) Администрирование данных 1С

Данная проблема появляется регулярно на Периферийной Базе, после проведения обновления релиза ЦБ. Всем кому данная проблема неожиданно обновила вкус жизни, посвящается. Пошаговая инструкция, 100 % гарантия, никакого программирования.

09.05.2013    38206    motorkuzbassa.it    39       

МиниКейс "Закрытие месяца в УПП без остановки работы системы (Партионный учёт)" 18

Статья Системный администратор Программист Бухгалтер Нет файла v8 1cv8.cf БУ Windows Закрытие периода Бесплатно (free) Распределенная БД (УРИБ, УРБД) Закрытие периода

Предлагается схема закрытия месяца на предприятии с круглосуточной работой в 1С. Используются обработки, которые доступны на infostart.ru.

24.02.2013    21775    axxell    7       

Настройка филиальных баз данных 31

Статья Системный администратор Программист Нет файла v8 БП2.0 ЗУП2.5 УТ10 Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Клиент поставил задачу реализации работы филиалов в конфигурациях "Бухгалтерия предприятия" и "Зарплата и Управление Персоналом", в которых уже давно работает центральное отделение. Главная загвоздка в том, что, несмотря на автономную работу филиалов, отчетность нужно было продолжать сдавать от юридического лица в центральном филиале. Начали продумывать варианты реализации...

29.01.2013    16021    evgant    6       

Особенности обмена данными с использованием "ручной" регистрации 18

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

14.01.2013    30668    logarifm    6       

Обмен данными в распределенной базе через e-mail. 42

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД) WEB

Если у вас нет финансов для покупки отдельного сервера под 1С или вы просто не хотите пока вкладывать денежные средства для развития этого программного продукта, но у вас есть острая необходимость в обмене данными между двумя удаленно расположенными пользователями, то в данной статье я расскажу как настроить обмен данными без финансовых вложений по средствам e-mail.

13.01.2013    44649    Klim Bassenger    34       

УНФ РИБ 35

Статья Системный администратор Программист Нет файла v8 УНФ Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД) Перенос данных из 1С7.7 в 1C8.X

В типовой УНФ нет РИБа. Исправляем этот недостаток, используя УТ 11 и ИТС. Статья подойдет для настойки распределенки в любой конфе на базе БСП.

16.10.2012    37080    ptkrzy    23       

Исправление ошибки в РИБ (некорректные данные в базе) 50

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Если у вас выгрузились в одну из периферийных баз данные из другой – эта инструкция для вас. :) Пример из реальной практики.

27.09.2012    16168    Korolev    11       

Обмен данными по планам обмена 39

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

В этой статье я постараюсь рассказать, как перенести механизм обмен данными из типовой конфигурации в нетиповую и создать свои планы обмена.

19.07.2012    46039    kereo    17       

Автоматическое обновление конфигурации в узлах РИБ 101

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

При поднятии РИБ одна из существенных проблем – как автоматически обновлять конфигурацию на периферийных узлах? Научить простых пользователей заходить в конфигуратор довольно проблематично. Предлагаю довольно простое, на мой взгляд решение с минимальными доработками в конфигурацию.

14.07.2012    49495    fixin    75       

Обмен по расписанию типовыми средствами. 82

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД) Обмен через XML Перенос данных из 1C8 в 1C8

Часто перед интеграторами стоит задача организовать автообмен (по расписанию или при наступлении какого-либо события) данными между различными конфигурациями. В этой статье я попробую изложить простую инструкцию, как это можно сделать средствами, заложенными в типовые конфигурации 1С (ЗУП, БП, УПП и т.д.). Для обмена используется подсистема "Обмен данными" из БСП

20.06.2012    95409    kser87    52       

Скрипт для обмена между двумя базами УРБД на Java-Script 19

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Я создал копию базы, чтобы на работе и дома работать с одной и той же базой. Делать обмены мне быстро надоело, поэтому я потрудился, и за 2 часа написал скрипт на языке java-script для обмена между этими базами. Он даже обновляет конфигурацию периферийной базы! Для работы нужно, чтобы в конфигурации не было ошибок при компиляции модулей для внешнего соединения, т.к. используется внешнее соединение. Программа сделана для файловой версии, вы можете переделать ее для серверной версии.

27.03.2012    14742    fixin    7       

Обновление УТ РИБ 44

Статья Системный администратор Нет файла v8 УТ10 Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Простой пошаговый способ обновления РИБ на примере УТ 10.3 - 1С 8.2

10.02.2012    47223    alitvin    21       

Базы данных 1С8 для сетевых структур 22

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

В статье собран опыт применения распределенных баз данных в организациях, состоящих из головного офиса и множества однотипных простых подразделений (точек).

18.12.2011    15141    fixin    6       

Дата последнего обмена данными между узлами РИБ 1С: 8 ЗУП 1

Статья Программист Нет файла v8 ЗУП2.5 Россия Бесплатно (free) Практика программирования Распределенная БД (УРИБ, УРБД)

При настройке РИБ и проведении обменов в РС "Параметры обмена данными" не записывалась дата выполнения обмена данными между узлами РИБ и соответственно не отображалась в Сервис - Настройка обмена данными.

19.10.2011    6087    flybread    1       

Настройка одностороннего обмена в РИБ 8.1, 8.2 БЕЗ ИЗМЕНЕНИЯ КОНФИГУРАЦИИ 49

Статья Системный администратор Нет файла v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Статья описывает простой универсальный алгоритм настройки одностороннего обмена в РИБ 8.1 и 8.2 для любых конфигураций, имеющих план обмена, БЕЗ ИЗМЕНЕНИЯ КОДА.

22.09.2011    41015    monster6666    37       

Обработка по сохранению/восстановлению настроек обмена. 1

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Обработка позволяет сохранить в файл или восстановить из файла ранее сохраненные настройки обмена.

18.11.2010    4523    42    IgorMgn    2       

Популярные ошибки РИБ и способы их исправления. Часть 1. Конфигурация узла распределенной ИБ не соответствует ожидаемой 385

Статья Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Распределенная БД (УРИБ, УРБД) Тестирование и исправление Перенос данных из 1C8 в 1C8

Конфигурация узла распределенной ИБ не соответствует ожидаемой. Одна из самых популярных ошибок РИБ. Приведены стандартная методика устранения (уже публиковалась ранее) и расширенная (для сложных случаев).

09.02.2010    178560    5806    mbreaker    166       

Распределенные базы данных 15

Статья Системный администратор Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free) Распределенная БД (УРИБ, УРБД)

При росте предприятия, рано или поздно встает вопрос, о консолидации данных. И тут главное правильно сделать выбор в пользу той или иной схемы. Надеюсь, что данная статья поможет вам в этом не простом выборе.

20.01.2010    22997    awk    32       

Пример настройки РИБ 8.1 112

Статья Системный администратор Архив с данными v8 1cv8.cf Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Имеется центральный офис и очень удаленный филиал. Между собой территории связаны медленным каналом. В центральном офисе хотят иметь актуальную копию базы данных филиала. Реализовано с помощью механизма РИБ.

10.11.2009    47946    1153    daulberg    61       

Групповая обработка документов и справочников с возможностью регистрации объектов для обмена 16

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Работая над одним из проектов я часто встречался с необходимостью регистрация объектов для выгрузки. Для решения этой задачи доработал типовую обработку документов и справочников.

29.07.2009    10716    183    Pim    5       

УРИБ автообмен данными/конфигурацией 48

Инструменты и обработки Системный администратор Приложение (exe) v8 1cv8.cf Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Программа написана на VC6.0 автоматизирует автообмен конфигурацией и данными. Привожу исходные тексты модулей.

07.10.2008    10799    654    kick    8