Печать в Word без COM объектов или печать в Word под Linux

Публикация № 286533

Разработка - Печать - Универсальные печатные формы

Word RTF Linux Печать без com объектов

Решается задача печати по шаблону в Word под Linux (можно и под Win). Главное - это без использования COM Objects. Word'a под Linux нет, но зато есть Open Office. Основная идея это использование старого формата RTF, который читается любой версией Word, Open Office и даже WordPad. Статья состоит из: 1) Теория и общее описание алгоритма. 2) Описание использования 3) Код методов 4) Рабочая обработка - пример использования под 8.2 (обычные формы)

Моя первая публикация (чего-то полезного) не только на инфостарте, но вообще в интернете, так что особо сильно не пинайте Cool

Тем, кому не интересна теория, предлагаю сразу перейти ко 2-му пункту, быстро прочесть как пользоваться и скопировать код методов из 3-го пункта. Некоторое время после написания публикации я буду находиться на поддержке, отвечать на вопросы (возможно исправлять баги).

 Исправил редкий баг, всем кто пользовался до "10.06.2014 13:03:56" рекомендую обновить метод  РаспарситьСтроку(Стр, ХешКодировки)

1. Теория и общее описание алгоритма.

Сразу хочу заметить, что не претендую на самое красивое, лучшее и оптимальное решение этой задачи, все ниже описанное можно и нужно оптимизировать и я даже знаю как, но только руки не доходят. Формат RTF очень старый и имеет много надстроек и дополнений, всю его спецификацию я разумеется не изучал. Если простыми словами, то основа формата блоки заключенные в фигурные скобки, вот такие "{ }". Внутри блока расположены команды-маркеры, которые начинаются с символа "\" и описывают шрифт, цвет фона текста и т.д. т.п. и текст (если блок текстовый). Таблицы в RTF легко склеиваются между собой достаточно просто в тексте удалить все символы, разделяющие таблицы. Честно говоря, иметь счастье разбиаться со спецификацией таблиц у меня не было ни какого желанию, по этому решено было использовть свойство склейки, просто повторяющуюся многократно строку необходимо заключить в секцию и многократно вывести. О секциях расскажу ниже. На этом рассмотрение теории по RTF можно закончить. Вы и сами можете по исследовать этот вопрос, создав файл *.rtf и открыв его хоть блокнотом, хоть Hex редактором. Алгоримтм на самом деле банален и прост. Читаем файл, превращаем в текст. Далее работаем с текстом. В первом приближении это всего два метода. Первый - это построить дерево из блоков, команд и текста. Второй - это превратить дерево в текст классическим рекурсивным обходом. Вот текст методов:

Функция РаспарситьСтрокуПерваяВерсия(Стр)
	
	Перем Дерево, Стек, Мас, Анализ, Секции, Параметры;
	Стек = Новый Массив;
	Дерево = Новый Массив;
	Мас = Дерево;
	НачатоСлово = Ложь;
	БылСлеш = ложь;
	Темп = "";
	Блок = Новый Структура("Дерево, Родитель");
	ХешКодировки = ПолучитьХешКодировки();
	Для х = 1 по СтрДлина(Стр) Цикл
		Символ = Сред(Стр, х, 1);
		Если НачатоСлово Тогда
			Если Символ = " " Тогда
				НачатоСлово = Ложь;
				Темп = Темп + Символ;
				Анализ = АнализСлова(Блок, Темп, ХешКодировки);
				Темп = "";
				Мас.Добавить(Анализ);
				Продолжить;
			КонецЕсли;
			Если Символ = "{" Тогда
				Если БылСлеш Тогда
					Темп = Темп + Символ;
				Иначе
					Анализ = АнализСлова(Блок, Темп, ХешКодировки);
					Мас.Добавить(Анализ);
					Темп = "";
					НачатоСлово = Ложь;
					БылСлеш = Ложь;
					Блок = Новый Структура("Тип, Дерево, Родитель", "Блок", Новый Массив, ?(Стек.Количество() = 0, Неопределено, Стек[Стек.ВГраница()]));
					Стек.Добавить(Блок);
					Мас.Добавить(Блок);
					Мас = Блок.Дерево;
					Продолжить;
				КонецЕсли;
			КонецЕсли;
			Если Символ = "}" Тогда
				Если БылСлеш Тогда
					Темп = Темп + Символ;
				Иначе
					Анализ = АнализСлова(Блок, Темп, ХешКодировки);
					Мас.Добавить(Анализ);
					Темп = "";
					НачатоСлово = Ложь;
					БылСлеш = Ложь;
					Стек.Удалить(Стек.ВГраница());
					Если Стек.Количество() = 0 Тогда
						Мас = Дерево;
					Иначе
						Мас = Стек[Стек.ВГраница()].Дерево;
					КонецЕсли;
					Продолжить;
				КонецЕсли;
			КонецЕсли;
			Если Символ = "\" Тогда
				Если БылСлеш Тогда
					БылСлеш = Ложь;
				Иначе
					БылСлеш = Истина;
				КонецЕсли;
			Иначе
				БылСлеш = Ложь;
			КонецЕсли;
			Темп = Темп + Символ;
		Иначе
			Если Символ = "{" Тогда
				Блок = Новый Структура("Тип, Дерево, Родитель", "Блок", Новый Массив, ?(Стек.Количество() = 0, Неопределено, Стек[Стек.ВГраница()]));
				Стек.Добавить(Блок);
				Мас.Добавить(Блок);
				Мас = Блок.Дерево;
				Продолжить;
			КонецЕсли;
			Если Символ = "}" Тогда
				Стек.Удалить(Стек.ВГраница());
				Если Стек.Количество() = 0 Тогда
					Мас = Дерево;
				Иначе
					Мас = Стек[Стек.ВГраница()].Дерево;
				КонецЕсли;
				Продолжить;
			КонецЕсли;
			Если Символ <> " " Тогда
				Темп = Символ;
				НачатоСлово = Истина;
				Если Символ = "\" Тогда
					БылСлеш = Истина;
				Иначе
					БылСлеш = Ложь;
				КонецЕсли;
				Продолжить;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	Возврат Дерево;
	
КонецФункции

и метод преобразования дерева в строку, совсем уж маленький Laughing

Функция СформироватьСтроку(Дерево) Экспорт
	
	Перем рет, Элем;
	рет = ""; Стек = Новый Массив;
	Для каждого Элем из Дерево Цикл
		Если Элем.Тип = "Блок" Тогда
			рет = рет + "{" + СформироватьСтроку(Элем.Дерево) + "}";
		Иначе
			рет = рет + Элем.Текст;
		КонецЕсли;
	КонецЦикла;
	Возврат рет;
	
КонецФункции

Далее все усложняется тем, что необходимо помимо обычного текста отслеживать секции и параметры, запоминать их засосвывать в какую-нибудь структуру. В какую только ? Размумеется в такую, что бы было максимально просто и удобно работать как проффесионалу, так и новичку (ну что бы мозг не напрягался). В начале я думал построить такое же дерево, но это не удобано. в результате пришел к тому, что проще всего сделать Хеш (но 1С Соотвестсвие), в котром можно обратиться к нужному элементу (секции или параметру) по имени. Причем элемент Хеша это массив, на случай если в макете будут встречаться параметры или секции несколько раз. В результате, 1 раз заполнив параметр, он автоматический заполниться по всему документу, аналогично и относительно секции. Далее еще 2 метода, первый - это копирование секции, зная где ее начало и где конец, и второй - это заполнение параметра (просто подмена текста).  Секции при копировании пропускают все управляющие блоки, т.е. теги секций и параметров. Все эти операции происходят прямо в дереве значений. Дерево по сути - это структура с большим количеством коротких строк, работать с которыми 1С-ке гораздо проще (я правда не знаю какой алгоритм для работы со строками использует фирма 1С, но в любом случае оперировать строками порядка 1-го мегобайта это не по феншую). В результате на пентиуме 4, шаблон размером под 1 мегобайт (почти 40 страниц) заполняется всего за 1 минуту. Для тех кто разберется со спецификацией RTF бонус в том, что уже все разложено по полочкам и можно менять шрифт, цвет и прочие параметры текста прямо на лету в самом шаблоне, хотя это можно делать и на уровне секций, например создать чередующуюся цветами таблицу.

2. Описание использования.

Описание использования состоит из 2-х частей:  правила составления макетов (для пользователей)  и правила вывода макетов (для программистов)

правила составления макетов (для пользователей) 

  1. Секции оформляются 2-мя тегами: откытием секции и закрытием секции (Пример:...).
  2. Параметры оформляются одним тегом через квадратные скобки (Пример: [Параметр1]).
  3. Любой текст за пределами секции принадлежит документу и будет выводиться в любом случае (Пример: Этот текст выведется в любом случаеЭтот текст выведется только если будет выведена секция "ШапкаДокумента" значение параметра "тестовый" = [тестовый])
  4. Секции могут быть вложенными. (Пример:Шапка:Шапка:) 
  5. Макет может состоять из произвольного количества секций и параметров. Правило составления секции аналогично правило расставлению скобок в обычно тексте. Нельзя что бы в любом месте количество закрывающих скобок было больше открывающих. На параметры нет никаких ограничений.
  6. Можно создавать параметры с одинаковым именем. При этом все параметры с одинаковым именем будут заполнены одним значением (Пример: Дата документа = [ДатаДокумента], и тут тоже быдет выведена такая же дата документа [ДатаДокумента]).
  7. Можно создавать секции с одинаковым именем, даже вложенные одна в другую. При этом они будут выведен столько раз, сколько задано в алгоритме. (Для примера предположим, что секция "Тестовая" выведена будет 2 раза и текст макета следующий: "1. Текст секции2. Текст вложенной". При таких условиях результатом будет текст: "1. Текст секции  2. Текст вложенной  2. Текст вложенной 1. Текст секции  2. Текст вложенной  2. Текст вложенной ")
  8. Правила составления имени секции или параметра. Можно использовать пробелы в имени (но не рекомендуется). Имена регистрозависимы ([ИмяПараметра] и [имяпараметра] это 2 разных параметра). Можно смело использовать цифры и спец символы, кроме "<", ">", "[", "]" или последовательности "
  9. Таблицы. Таблица формируется внутри секции. Телом секции является одна строка таблицы с параметрами. После объявления начала секции не должно быть ни текста ни пробелов, только перевод на новую строку. Аналогично для строки таблицы с параметрами и следующим за ней объявлением конца секции.
  10. Возможные ошибки. Не обязательно, но крайне рекомендуется обрамлять пробелами все теги секций и параметров (Пример: "Пробел""Пробел" текст секции "пробел"[Параметр]"пробел" конец текста секции "пробел""Пробел"

правила вывода макетов (для программистов)

  1. Работа начинается с получения Хеша кодировки (Соответствия) функцией ПолучитьХешКодировки(). Все остальные функции используют этот Хеш.
  2. Далее используется функция РаспарситьСтроку(Стр, ХешКодировки), Стр - это обычная строка (полученная считыванием файла-шаблона RTF). В результате возвтращается структура с 2-мя параметрами "Дерево" и  "Секции". Дерево - это макет RTF в виде древовидной структуры. Секции - структура секций и параметров макета.
  3. Далее вызывая методы ЗаполнитьПараметр(СтруктураСекций, ИмяПараметра, ЗначениеЗаполнения, ХешКодировки) и ВывестиСекцию(Запись, ИмяСекции, ЭтоТаблица = ложь, х_раз = 1) формируем результирующий документ (Это происходит очень быстро в памяти в структуре "Дерево"). В методе ВывестиСекцию параметр ЭтоТаблица уточняет обычная это секция или секция формирующая таблицу.
  4. Правила вывода секций. Перед выводом секции необходимо заполнить параметры внутри ее тела (если это после, то вместо параметров будут пробелы). Сначала необходимо выводить вложенную секцию, после уровнем выше и т.д. до корневой.
  5. После формирования документа нужно вызвать метод УдалитьСекции(Запись), Запись - это структура (с 2-мя параметрами "Дерево" и  "Секции") возвтращаемая методом РаспарситьСтроку(Стр, ХешКодировки).
  6. Последний шаг - функция СформироватьСтроку(Дерево). Возвращает результирующий документ в виде строки. Запиав строку в фаил RTF получим документ RTF. 

Еще один момент. В зависимости от того в каком редакторе вы создавали RTF-фаил, внутренний текст может сильно различаться. Я писал код, тестировал и отлаживался на MS Word 2010-м. Правда я не думаю это на что-то может повлиять, но все же решил вас предупредить.

3. Код методов

Почему-то весь текст не влазит, разделил на 3 части.

Код методов из общего модуля:

Первая часть:

Процедура Печать(Элем, Данные)  Экспорт
	
	Перем Обработка, Спр, Двоичка, Темп;
	Если ТипЗнч(Элем) = Тип("Строка") Тогда
		Спр = Справочники.R_ПечатьМакетовRTF.НайтиПоНаименованию(Элем);
		Если НЕ ЗначениеЗаполнено(Спр) Тогда
			ВызватьИсключение "Элемент справочника " + Элем + " не найден";
		КонецЕсли;
	Иначе
		Спр = Элем;
	КонецЕсли;
	Двоичка = Спр.Обработка.Получить();
	Макет = Спр.Макет.Получить();
	Если НЕ ЗначениеЗаполнено(Двоичка) Тогда
		ВызватьИсключение "Обработка не выбрана";
	КонецЕсли;
	Темп = ПолучитьИмяВременногоФайла();
	Двоичка.Записать(Темп);
	Обработка = ВнешниеОбработки.Создать(Темп);
	Обработка.Печать(Макет, Данные);
	УдалитьФайлы(Темп);
	
КонецПроцедуры

Функция СформироватьСтроку(Дерево) Экспорт
	
	Перем рет, Элем;
	рет = ""; Стек = Новый Массив;
	Для каждого Элем из Дерево Цикл
		Если Элем.Тип = "Блок" Тогда
			рет = рет + "{" + СформироватьСтроку(Элем.Дерево) + "}";
		Иначе
			рет = рет + Элем.Текст;
		КонецЕсли;
	КонецЦикла;
	Возврат рет;
	
КонецФункции

Функция РаспарситьСтроку(Стр, ХешКодировки) Экспорт
	
	Перем Дерево, Стек, Мас, Анализ, Секции, НачатоСлово, БылСлеш, Параметр, Секция, Темп, Блок, СтруктураСекций;
	Секции = Новый Массив;
	Стек = Новый Массив;
	Дерево = Новый Массив;
	Мас = Дерево;
	НачатоСлово = Ложь;
	БылСлеш = Ложь;
	Параметр = Неопределено;
	Секция = Неопределено;
	Темп = "";
	Блок = Новый Структура("Дерево, Родитель");
	Для х = 1 по СтрДлина(Стр) Цикл
		Символ = Сред(Стр, х, 1);
		Если НачатоСлово Тогда
			Если Символ = " " Тогда
				НачатоСлово = Ложь;
				Темп = Темп + Символ;
				Анализ = АнализСлова(Блок, Темп, ХешКодировки);
				Темп = "";
				Если КомпоновкаКлючевыхСлов(Секции, Анализ, Секция, Параметр) Тогда
					Мас.Добавить(Анализ);
				КонецЕсли;
				ПоискКлючевыхСлов(Секции, Анализ, Секция, Параметр);
				Продолжить;
			КонецЕсли;
			Если Символ = "{" Тогда
				Если БылСлеш Тогда
					Темп = Темп + Символ;
				Иначе
					Анализ = АнализСлова(Блок, Темп, ХешКодировки);
					Если КомпоновкаКлючевыхСлов(Секции, Анализ, Секция, Параметр) Тогда
						Мас.Добавить(Анализ);
					КонецЕсли;
					ПоискКлючевыхСлов(Секции, Анализ, Секция, Параметр);
					Темп = "";
					НачатоСлово = Ложь;
					БылСлеш = Ложь;
					Блок = Новый Структура("Тип, Дерево, Родитель", "Блок", Новый Массив, ?(Стек.Количество() = 0, Неопределено, Стек[Стек.ВГраница()]));
					Если КомпоновкаКлючевыхСлов(Секции, Блок, Секция, Параметр) Тогда
						Стек.Добавить(Блок);
						Мас.Добавить(Блок);
						Мас = Блок.Дерево;
					КонецЕсли;
					Продолжить;
				КонецЕсли;
			КонецЕсли;
			Если Символ = "}" Тогда
				Если БылСлеш Тогда
					Темп = Темп + Символ;
				Иначе
					Анализ = АнализСлова(Блок, Темп, ХешКодировки);
					Если КомпоновкаКлючевыхСлов(Секции, Анализ, Секция, Параметр) Тогда
						Мас.Добавить(Анализ);
					КонецЕсли;
					ПоискКлючевыхСлов(Секции, Анализ, Секция, Параметр);
					Темп = "";
					НачатоСлово = Ложь;
					БылСлеш = Ложь;
					Если КомпоновкаКлючевыхСлов(Секции, Блок, Секция, Параметр) Тогда
						Стек.Удалить(Стек.ВГраница());
						Если Стек.Количество() = 0 Тогда
							Мас = Дерево;
						Иначе
							Мас = Стек[Стек.ВГраница()].Дерево;
						КонецЕсли;
					КонецЕсли;
					Продолжить;
				КонецЕсли;
			КонецЕсли;
			Если Символ = "\" Тогда
				Если БылСлеш Тогда
					БылСлеш = Ложь;
				Иначе
					БылСлеш = Истина;
				КонецЕсли;
			Иначе
				Если БылСлеш и Символ <> "u" и Символ <> "'" Тогда
					Если Лев(Темп, 2) = "\'" или Лев(Темп, 2) = "\u" или Лев(Темп, 1) <> "\" Тогда
						Анализ = АнализСлова(Блок, Лев(Темп, СтрДлина(Темп) - 1), ХешКодировки);
						Темп = "\";
						Если КомпоновкаКлючевыхСлов(Секции, Анализ, Секция, Параметр) Тогда
							Мас.Добавить(Анализ);
						КонецЕсли;
						ПоискКлючевыхСлов(Секции, Анализ, Секция, Параметр);
					КонецЕсли;
				КонецЕсли;
				БылСлеш = Ложь;
			КонецЕсли;
			Темп = Темп + Символ;
		Иначе
			Если Символ = "{" Тогда
				Блок = Новый Структура("Тип, Дерево, Родитель", "Блок", Новый Массив, ?(Стек.Количество() = 0, Неопределено, Стек[Стек.ВГраница()]));
				Если КомпоновкаКлючевыхСлов(Секции, Блок, Секция, Параметр) Тогда
					Стек.Добавить(Блок);
					Мас.Добавить(Блок);
					Мас = Блок.Дерево;
				КонецЕсли;
				Продолжить;
			КонецЕсли;
			Если Символ = "}" Тогда
				Если КомпоновкаКлючевыхСлов(Секции, Блок, Секция, Параметр) Тогда
					Стек.Удалить(Стек.ВГраница());
					Если Стек.Количество() = 0 Тогда
						Мас = Дерево;
					Иначе
						Мас = Стек[Стек.ВГраница()].Дерево;
					КонецЕсли;
				КонецЕсли;
				Продолжить;
			КонецЕсли;
			Темп = Символ;
			НачатоСлово = Истина;
			Если Символ = "\" Тогда
				БылСлеш = Истина;
			Иначе
				БылСлеш = Ложь;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	СтруктураСекций = СформироватьСтруктуруСекций(Дерево, Секции);
	Возврат Новый Структура("Дерево, Секции", Дерево, СтруктураСекций);
	
КонецФункции

Функция ПолучитьХешКодировки() Экспорт
	
	Перем Хеш;
	Хеш = Новый Соответствие;
	Хеш["\'c0"] = "А";
	Хеш["\'c1"] = "Б";
	Хеш["\'c2"] = "В";
	Хеш["\'c3"] = "Г";
	Хеш["\'c4"] = "Д";
	Хеш["\'c5"] = "Е";
	Хеш["\'c6"] = "Ж";
	Хеш["\'c7"] = "З";
	Хеш["\'c8"] = "И";
	Хеш["\'c9"] = "Й";
	Хеш["\'ca"] = "К";
	Хеш["\'cb"] = "Л";
	Хеш["\'cc"] = "М";
	Хеш["\'cd"] = "Н";
	Хеш["\'ce"] = "О";
	Хеш["\'cf"] = "П";
	Хеш["\'d0"] = "Р";
	Хеш["\'d1"] = "С";
	Хеш["\'d2"] = "Т";
	Хеш["\'d3"] = "У";
	Хеш["\'d4"] = "Ф";
	Хеш["\'d5"] = "Х";
	Хеш["\'d6"] = "Ц";
	Хеш["\'d7"] = "Ч";
	Хеш["\'d8"] = "Ш";
	Хеш["\'d9"] = "Щ";
	Хеш["\'da"] = "Ъ";
	Хеш["\'db"] = "Ы";
	Хеш["\'dc"] = "Ь";
	Хеш["\'dd"] = "Э";
	Хеш["\'de"] = "Ю";
	Хеш["\'df"] = "Я";
	Хеш["\'e0"] = "а";
	Хеш["\'e1"] = "б";
	Хеш["\'e2"] = "в";
	Хеш["\'e3"] = "г";
	Хеш["\'e4"] = "д";
	Хеш["\'e5"] = "е";
	Хеш["\'e6"] = "ж";
	Хеш["\'e7"] = "з";
	Хеш["\'e8"] = "и";
	Хеш["\'e9"] = "й";
	Хеш["\'ea"] = "к";
	Хеш["\'eb"] = "л";
	Хеш["\'ec"] = "м";
	Хеш["\'ed"] = "н";
	Хеш["\'ee"] = "о";
	Хеш["\'ef"] = "п";
	Хеш["\'f0"] = "р";
	Хеш["\'f1"] = "с";
	Хеш["\'f2"] = "т";
	Хеш["\'f3"] = "у";
	Хеш["\'f4"] = "ф";
	Хеш["\'f5"] = "х";
	Хеш["\'f6"] = "ц";
	Хеш["\'f7"] = "ч";
	Хеш["\'f8"] = "ш";
	Хеш["\'f9"] = "щ";
	Хеш["\'fa"] = "ъ";
	Хеш["\'fb"] = "ы";
	Хеш["\'fc"] = "ь";
	Хеш["\'fd"] = "э";
	Хеш["\'fe"] = "ю";
	Хеш["\'ff"] = "я";
	Хеш["\u1040"] = "А";
	Хеш["\u1041"] = "Б";
	Хеш["\u1042"] = "В";
	Хеш["\u1043"] = "Г";
	Хеш["\u1044"] = "Д";
	Хеш["\u1045"] = "Е";
	Хеш["\u1046"] = "Ж";
	Хеш["\u1047"] = "З";
	Хеш["\u1048"] = "И";
	Хеш["\u1049"] = "Й";
	Хеш["\u1050"] = "К";
	Хеш["\u1051"] = "Л";
	Хеш["\u1052"] = "М";
	Хеш["\u1053"] = "Н";
	Хеш["\u1054"] = "О";
	Хеш["\u1055"] = "П";
	Хеш["\u1056"] = "Р";
	Хеш["\u1057"] = "С";
	Хеш["\u1058"] = "Т";
	Хеш["\u1059"] = "У";
	Хеш["\u1060"] = "Ф";
	Хеш["\u1061"] = "Х";
	Хеш["\u1062"] = "Ц";
	Хеш["\u1063"] = "Ч";
	Хеш["\u1064"] = "Ш";
	Хеш["\u1065"] = "Щ";
	Хеш["\u1066"] = "Ъ";
	Хеш["\u1067"] = "Ы";
	Хеш["\u1068"] = "Ь";
	Хеш["\u1069"] = "Э";
	Хеш["\u1070"] = "Ю";
	Хеш["\u1071"] = "Я";
	Хеш["\u1072"] = "а";
	Хеш["\u1073"] = "б";
	Хеш["\u1074"] = "в";
	Хеш["\u1075"] = "г";
	Хеш["\u1076"] = "д";
	Хеш["\u1077"] = "е";
	Хеш["\u1078"] = "ж";
	Хеш["\u1079"] = "з";
	Хеш["\u1080"] = "и";
	Хеш["\u1081"] = "й";
	Хеш["\u1082"] = "к";
	Хеш["\u1083"] = "л";
	Хеш["\u1084"] = "м";
	Хеш["\u1085"] = "н";
	Хеш["\u1086"] = "о";
	Хеш["\u1087"] = "п";
	Хеш["\u1088"] = "р";
	Хеш["\u1089"] = "с";
	Хеш["\u1090"] = "т";
	Хеш["\u1091"] = "у";
	Хеш["\u1092"] = "ф";
	Хеш["\u1093"] = "х";
	Хеш["\u1094"] = "ц";
	Хеш["\u1095"] = "ч";
	Хеш["\u1096"] = "ш";
	Хеш["\u1097"] = "щ";
	Хеш["\u1098"] = "ъ";
	Хеш["\u1099"] = "ы";
	Хеш["\u1100"] = "ь";
	Хеш["\u1101"] = "э";
	Хеш["\u1102"] = "ю";
	Хеш["\u1103"] = "я";
	Хеш["А"] = "\'c0";
	Хеш["Б"] = "\'c1";
	Хеш["В"] = "\'c2";
	Хеш["Г"] = "\'c3";
	Хеш["Д"] = "\'c4";
	Хеш["Е"] = "\'c5";
	Хеш["Ж"] = "\'c6";
	Хеш["З"] = "\'c7";
	Хеш["И"] = "\'c8";
	Хеш["Й"] = "\'c9";
	Хеш["К"] = "\'ca";
	Хеш["Л"] = "\'cb";
	Хеш["М"] = "\'cc";
	Хеш["Н"] = "\'cd";
	Хеш["О"] = "\'ce";
	Хеш["П"] = "\'cf";
	Хеш["Р"] = "\'d0";
	Хеш["С"] = "\'d1";
	Хеш["Т"] = "\'d2";
	Хеш["У"] = "\'d3";
	Хеш["Ф"] = "\'d4";
	Хеш["Х"] = "\'d5";
	Хеш["Ц"] = "\'d6";
	Хеш["Ч"] = "\'d7";
	Хеш["Ш"] = "\'d8";
	Хеш["Щ"] = "\'d9";
	Хеш["Ъ"] = "\'da";
	Хеш["Ы"] = "\'db";
	Хеш["Ь"] = "\'dc";
	Хеш["Э"] = "\'dd";
	Хеш["Ю"] = "\'de";
	Хеш["Я"] = "\'df";
	Хеш["а"] = "\'e0";
	Хеш["б"] = "\'e1";
	Хеш["в"] = "\'e2";
	Хеш["г"] = "\'e3";
	Хеш["д"] = "\'e4";
	Хеш["е"] = "\'e5";
	Хеш["ж"] = "\'e6";
	Хеш["з"] = "\'e7";
	Хеш["и"] = "\'e8";
	Хеш["й"] = "\'e9";
	Хеш["к"] = "\'ea";
	Хеш["л"] = "\'eb";
	Хеш["м"] = "\'ec";
	Хеш["н"] = "\'ed";
	Хеш["о"] = "\'ee";
	Хеш["п"] = "\'ef";
	Хеш["р"] = "\'f0";
	Хеш["с"] = "\'f1";
	Хеш["т"] = "\'f2";
	Хеш["у"] = "\'f3";
	Хеш["ф"] = "\'f4";
	Хеш["х"] = "\'f5";
	Хеш["ц"] = "\'f6";
	Хеш["ч"] = "\'f7";
	Хеш["ш"] = "\'f8";
	Хеш["щ"] = "\'f9";
	Хеш["ъ"] = "\'fa";
	Хеш["ы"] = "\'fb";
	Хеш["ь"] = "\'fc";
	Хеш["э"] = "\'fd";
	Хеш["ю"] = "\'fe";
	Хеш["я"] = "\'ff";
	Возврат Хеш;
	
КонецФункции

Процедура ЗаполнитьПараметр(СтруктураСекций, ИмяПараметра, ЗначениеЗаполнения, ХешКодировки) Экспорт
	
	Перем х, Темп, Символ, Элем, Параметр, Значение;
	Параметр = СтруктураСекций.Параметры[ИмяПараметра];
	Если НЕ ЗначениеЗаполнено(Параметр) Тогда
		ВызватьИсключение "Не существует параметра с именем " + ИмяПараметра;
	КонецЕсли;
	Значение = Строка(ЗначениеЗаполнения);
	Темп = "";
	Для х = 1 по СтрДлина(Значение) Цикл
		Символ = Сред(Значение, х, 1);
		Если Символ = "\" Тогда
			Темп = Темп + "\\";
			Продолжить;
		КонецЕсли;
		Если Символ = "{" Тогда
			Темп = Темп + "\{";
			Продолжить;
		КонецЕсли;
		Если Символ = "}" Тогда
			Темп = Темп + "\}";
			Продолжить;
		КонецЕсли;
		ХешСимвол = ХешКодировки[Символ];
		Темп = ?(ЗначениеЗаполнено(ХешСимвол), Темп + ХешСимвол, Темп + Символ);
	КонецЦикла;
	Для каждого Элем из Параметр Цикл
		Элем.Текст = Темп;
	КонецЦикла;
	
КонецПроцедуры

Вторая часть:

Процедура ВывестиСекцию(Запись, ИмяСекции, ЭтоТаблица = ложь, х_раз = 1) Экспорт
	//Можно конечно в цикле вызывать метод ВывестиСекцию(Дерево, МасСекций)
	//Но лучше использовать параметр "х_раз", это ускорит работу
	Перем у, х, Мас, ИндексНачала, ИндексКонца, Элем, Секция, ТемпМас, раз, ХешСекций, МасСекций;
	Перем Дерево, СтруктураСекций, НачалоСекции;
	Дерево = Запись.Дерево;
	СтруктураСекций = Запись.Секции;
	ХешСекций = СтруктураСекций.ХешСекций;
	МасСекций = СтруктураСекций.Секции[ИмяСекции];
	Если НЕ ЗначениеЗаполнено(МасСекций) Тогда
		ВызватьИсключение "Не найдена секция с именем " + ИмяСекции;
	КонецЕсли;
	у = МасСекций.Вграница();
	Пока у >= 0 Цикл
		Секция = МасСекций[у];
		ИндексНачала = -1;
		ИндексКонца = -1;
		Мас = ?(ЗначениеЗаполнено(Секция.БлокНачала.Родитель), Секция.БлокНачала.Родитель.Дерево, Дерево);
		Для х = 0 по Мас.Вграница() Цикл
			Если Мас[х] = Секция.БлокНачала Тогда
				ИндексНачала = х;
				Для х = ИндексНачала по Мас.Вграница() Цикл
					Если Мас[х] = Секция.БлокКонца Тогда
						ИндексКонца = х;
						Прервать;
					КонецЕсли;
				КонецЦикла;
				Прервать;
			КонецЕсли;
		КонецЦикла;
		ТемпМас = Новый Массив;
		НачалоСекции = Ложь;
		Для х = ИндексНачала + 1 + ?(ЭтоТаблица, 1, 0) по ИндексКонца - 1 Цикл
			Если НачалоСекции Тогда
				Если ХешСекций[Мас[х]] = "Конец" Тогда
					НачалоСекции = Ложь;
					Продолжить;
				КонецЕсли;
			Иначе
				Если ХешСекций[Мас[х]] = "Начало" Тогда
					НачалоСекции = Истина;
					Продолжить;
				Иначе
					ТемпМас.Добавить(Мас[х]);
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
		Для раз = 1 по х_раз Цикл
			х = ТемпМас.ВГраница();
			Пока х >= 0 Цикл
				Элем = СкопироватьЭлементДерева(ТемпМас[х], ТемпМас[х].Родитель);
				Мас.Вставить(ИндексНачала, Элем);
				х = х - 1;
			КонецЦикла;
		КонецЦикла;
		у = у - 1;
	КонецЦикла;
		
КонецПроцедуры

Процедура УдалитьСекции(Запись) Экспорт
	
	Перем Мас, Секция, НачатоУдаление, х, Элем, МасСекций, Дерево, СтруктураСекций;
	Дерево = Запись.Дерево;
	СтруктураСекций = Запись.Секции;
	Для Каждого Элем из СтруктураСекций.Секции Цикл
		МасСекций = Элем.Значение;
		у = МасСекций.Вграница();
		Пока у >= 0 Цикл
			Секция = МасСекций[у];
			Мас = ?(ЗначениеЗаполнено(Секция.БлокНачала.Родитель), Секция.БлокНачала.Родитель.Дерево, Дерево);
			х = 0;
			НачатоУдаление = Ложь;
			Пока х  0 Тогда
					Если Найти(Элем.Текст, ">") > 0 Тогда
						ДобавлениеСекции(Секции, Элем, "Секция");
					Иначе
						Секция = Элем;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(Секция) Тогда
			Если (Элем.Тип = "Текст") Тогда
				Если Найти(Элем.Текст, "[") > 0 Тогда
					Если Найти(Элем.Текст, "]") > 0 Тогда
						ДобавлениеСекции(Секции, Элем, "Параметр");
					Иначе
						Параметр = Элем;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Функция КомпоновкаКлючевыхСлов(Секции, Элем, Секция, Параметр)
	
	Перем рет;
	рет = Истина;
	Если ЗначениеЗаполнено(Секция) Тогда
		рет = Ложь;
		Если Элем.Тип = "Текст" Тогда
			Секция.Текст = Секция.Текст + Элем.Текст;
			Секция.Значение = Секция.Значение + Элем.Значение;
			Если Найти(Элем.Текст, ">") > 0 Тогда
				ДобавлениеСекции(Секции, Секция, "Секция");
				Секция = Неопределено;
			КонецЕсли;
		КонецЕсли;
	Иначе
		Если ЗначениеЗаполнено(Параметр) Тогда
			рет = Ложь;
			Если Элем.Тип = "Текст" Тогда
				Параметр.Текст = Параметр.Текст + Элем.Текст;
				Параметр.Значение = Параметр.Значение + Элем.Значение;
				Если Найти(Элем.Текст, "]") > 0 Тогда
					ДобавлениеСекции(Секции, Параметр, "Параметр");
					Параметр = Неопределено;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	Возврат рет;
	
КонецФункции

Процедура ДобавлениеСекции(Секции, Секция, Тип = "Параметр")
	
	Секции.Добавить(Новый Структура("Секция, Тип", Секция, Тип));
	
КонецПроцедуры

Функция АнализСлова(Блок, Стр, ХешКодировки)
	
	Перем рет, х, Символ, БылСлеш, у, Значение, Темп, ЗначениеКодировки;
	ЭтоТекст = Ложь;
	Символ = Сред(Стр, 1, 1);
	Если КодСимвола(Символ, 1) = 13 Тогда
		Символ = Сред(Стр, 2, 1);
		Если Символ = "\" Тогда
			Символ = Сред(Стр, 3, 1);
			Если Символ = "'" или Символ = "u" Тогда
				ЭтоТекст = Истина;
			КонецЕсли;
		Иначе
			Если КодСимвола(Символ, 1) = 10 Тогда
				Символ = Сред(Стр, 3, 1);
				Если Символ = "\" Тогда
					Символ = Сред(Стр, 4, 1);
					Если Символ = "'" или Символ = "u" Тогда
						ЭтоТекст = Истина;
					КонецЕсли;
				Иначе
					ЭтоТекст = Истина;
				КонецЕсли;
			Иначе
				Если Символ = "\" Тогда
					Символ = Сред(Стр, 2, 1);
					Если Символ = "'" или Символ = "u" Тогда
						ЭтоТекст = Истина;
					КонецЕсли;
				Иначе
					ЭтоТекст = Истина;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	Иначе
		Если Символ = "\" Тогда
			Символ = Сред(Стр, 2, 1);
			Если Символ = "'" или Символ = "u" Тогда
				ЭтоТекст = Истина;
			КонецЕсли;
		Иначе
			ЭтоТекст = Истина;
		КонецЕсли;
	КонецЕсли;
	Если ЭтоТекст Тогда
		у = 0; Темп = ""; БылСлеш = Ложь; Значение = "";
		Для х = 1 по СтрДлина(Стр) Цикл
			Символ = Сред(Стр, х, 1);
			Если БылСлеш Тогда
				Если Символ = "\" или Символ = "{" или Символ = "}" Тогда
					Значение = Значение + Символ;
					БылСлеш = Ложь;
					Продолжить;
				КонецЕсли;
				Если Символ = "'" Тогда
					Темп = "\'";
					у = 2;
					БылСлеш = Ложь;
					Продолжить;
				КонецЕсли;
				Если Символ = "u" Тогда
					Темп = "\u";
					у = 4;
					БылСлеш = Ложь;
					Продолжить;
				КонецЕсли;
			Иначе
				Если у > 0 Тогда
					у = у - 1;
					Темп = Темп + Символ;
					Если у = 0 Тогда
						ЗначениеКодировки = ХешКодировки[Темп];
						Если ЗначениеЗаполнено(ЗначениеКодировки) Тогда
							Значение = Значение + ЗначениеКодировки;
						КонецЕсли;
					КонецЕсли;
					Продолжить;
				КонецЕсли;
				Если Символ = "\" Тогда
					БылСлеш = Истина;
					Продолжить;
				КонецЕсли;
				Значение = Значение + Символ;
			КонецЕсли;
		КонецЦикла;
		рет = Новый Структура("Тип, Текст, Значение, Родитель", "Текст", Стр, Значение, Блок);
	Иначе
		рет = Новый Структура("Тип, Текст, Родитель", "Команда", Стр, Блок);
	КонецЕсли;
	Возврат рет;
	
КонецФункции

Третья часть:

Функция СформироватьСтруктуруСекций(Дерево, Секции)
	
	Перем рет, Темп, Запись, Мас, ТемпМас;
	рет = новый Структура("Секции, Параметры, ХешСекций");
	рет.Секции = Новый Соответствие;
	рет.Параметры = Новый Соответствие;
	рет.ХешСекций = Новый Соответствие;
	Для каждого Элем из Секции Цикл
		Если Элем.Тип = "Параметр" Тогда
			Темп = Элем.Секция.Значение;
			Темп = ОчиститьНазвание(Темп);
			Если рет.Параметры[Темп] = Неопределено Тогда
				ТемпМас = Новый Массив;
				ТемпМас.Добавить(Элем.Секция);
				рет.Параметры[Темп] = ТемпМас;
			Иначе
				рет.Параметры[Темп].Добавить(Элем.Секция);
			КонецЕсли;
			Элем.Секция.Текст = "";
			Продолжить;
		КонецЕсли;
		Если Элем.Тип = "Секция" Тогда
			Запись = ОчиститьСекцию(Дерево, Элем);
			Если рет.Секции[Запись.Название] = Неопределено Тогда
				Если Запись.ТипСекции = "Конец" Тогда
					ВызватьИсключение "Конец секции не может располагаться до ее начала";
				КонецЕсли;
				Темп = Новый Структура("Дерево, БлокНачала, БлокКонца", Запись.Дерево, Запись.БлокСекции, Неопределено);
				ТемпМас = Новый Массив;
				ТемпМас.Добавить(Темп);
				рет.Секции[Запись.Название] = ТемпМас;
			Иначе
				Если Запись.ТипСекции = "Начало" Тогда
					Темп = Новый Структура("Дерево, БлокНачала, БлокКонца", Запись.Дерево, Запись.БлокСекции, Неопределено);
					рет.Секции[Запись.Название].Добавить(Темп);
				Иначе
					Темп = рет.Секции[Запись.Название];
					х = Темп.Вграница();
					Пока х >= 0 Цикл
						Если Темп[х].БлокКонца = Неопределено Тогда
							ПоискКонцаСекции(Дерево, Запись, Темп[х]);
							Прервать;
						КонецЕсли;
						х = х - 1;
					КонецЦикла;
				КонецЕсли;
			КонецЕсли;
			рет.ХешСекций[Запись.БлокСекции] = Запись.ТипСекции;
		КонецЕсли;
	КонецЦикла;
	Возврат рет;
	
КонецФункции

Процедура ПоискКонцаСекции(Дерево, ЗаготовкаСекции, ЭлементСекции)
	
	Перем Блок, Элем, ПоследнийБлок;
	Блок = ЗаготовкаСекции.БлокСекции;
	Пока ЗначениеЗаполнено(Блок) Цикл
		Если ЗаготовкаСекции.Дерево = ЭлементСекции.Дерево Тогда
			ЭлементСекции.БлокКонца = ЗаготовкаСекции.БлокСекции;
			Прервать;
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(Блок.Родитель) Тогда
			БлокСекции = Блок;
		КонецЕсли;
		Блок = Блок.Родитель;
	КонецЦикла;
	Если НЕ ЗначениеЗаполнено(ЭлементСекции.БлокКонца) Тогда
		Если ЗаготовкаСекции.Дерево = Дерево Тогда
			Для каждого Элем из Дерево Цикл
				Если Элем = БлокСекции Тогда
					ЭлементСекции.БлокКонца = Элем;
					Прервать;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
		Если НЕ ЗначениеЗаполнено(ЭлементСекции.БлокКонца) Тогда
			ЭлементСекции.БлокКонца = ЭлементСекции.БлокНачала;
		КонецЕсли;
	КонецЕсли;
		
КонецПроцедуры

Функция ОчиститьНазвание(ОчищаемоеНазвание)
	
	Перем рет, х, Символ, Название;
	рет = ""; Название = СокрЛП(ОчищаемоеНазвание);
	Для х = 1 по СтрДлина(Название) Цикл
		Символ = Сред(Название, х, 1);
		Если Символ = "]" Тогда
			Прервать;
		Иначе
			Если НЕ (КодСимвола(Символ, 1) = 13 или КодСимвола(Символ, 1) = 10 или Символ = "[") Тогда
				рет = рет + Символ;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	Возврат рет;
	
КонецФункции

Функция СкопироватьЭлементДерева(Элем, Родитель)
	
	Перем х, рет, НовЭлем;
	Если Элем.Тип = "Блок" Тогда
		рет = Новый Структура("Тип, Дерево, Родитель", "Блок", Новый Массив, Родитель);
		Для х = 0 по Элем.Дерево.ВГраница() Цикл
			НовЭлем = СкопироватьЭлементДерева(Элем.Дерево[х], рет);
			рет.Дерево.Добавить(НовЭлем);
		КонецЦикла;
	ИначеЕсли Элем.Тип = "Текст" Тогда
		рет = Новый Структура("Тип, Текст, Значение, Родитель", "Текст", Элем.Текст, Элем.Значение, Элем.Родитель);
	ИначеЕсли Элем.Тип = "Команда" Тогда
		рет = Новый Структура("Тип, Текст, Родитель", "Команда", Элем.Текст, Элем.Родитель);
	Иначе
		ВызватьИсключение "Не ожиданный элемент тип = " + Элем.Тип;
	КонецЕсли;
	Возврат рет;
	
КонецФункции

Функция ОчиститьСекцию(Дерево, Секция)

Перем рет, Темп, х;
рет = Новый Структура("Дерево, БлокСекции, Название, ТипСекции");
Темп = ОчиститьНазвание(СокрЛП(Секция.Секция.Значение));
Если Лев(Темп, 2) = "</" Тогда
рет.ТипСекции = "Конец";
рет.Название = Сред(Темп, 3, СтрДлина(Темп) - 3);
ИначеЕсли Лев(Темп, 1) = "<" Тогда
рет.ТипСекции = "Начало";
рет.Название = Сред(Темп, 2, СтрДлина(Темп) - 2);
Иначе
ВызватьИсключение "Невозможно определить тип секции";
КонецЕсли;
рет.Название = ОчиститьНазвание(рет.Название);
Секция.Секция.Текст = "";
Темп = Секция.Секция.Родитель.Родитель;
рет.БлокСекции = Секция.Секция.Родитель;
рет.Дерево = ?(ЗначениеЗаполнено(Темп), Темп.Дерево, Дерево);
Возврат рет;

КонецФункции

Скачать файлы

Наименование Файл Версия Размер
Пример.epf

.epf 26,65Kb
17.04.17
15
.epf 2 26,65Kb 15 Скачать
Макет.rtf

.rtf 39,03Kb
17.04.17
12
.rtf 39,03Kb 12 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Yashazz 3579 10.06.14 18:52 Сейчас в теме
Автор, пожалей читателей, исправь ошибки, читать же невозможно!

Кстати, а никто не баловался xslt-преобразованием в rtf-формат? Так, чтобы ррраз - и по прописанному готовенькое?
2. kroitoru.g.g 13 11.06.14 10:44 Сейчас в теме
3. kroitoru.g.g 13 11.06.14 12:16 Сейчас в теме
К несчастью метод
Функция ОчиститьСекцию(Дерево, Секция)
нормально не оформляется из-за текста = "< / "
Поэтому добавил его в виде обычного текста.
4. K_A_O 529 17.06.14 09:12 Сейчас в теме
Понимаю, что смотреть что-то чужое, когда свое работает - не хочется. Но я вот вот с разбором rtf тоже проходил, и вроде достаточно сложные отчеты строились.
http://infostart.ru/public/71345/
5. kroitoru.g.g 13 17.06.14 10:14 Сейчас в теме
(4) K_A_O, А вы COM объекты используете ?
Я специально не использовал, что бы под Linux работало.
6. K_A_O 529 18.06.14 15:10 Сейчас в теме
(5) Разбирается rtf файл как строка, правда с помощью регулярных выражений, но если использовать нативную компоненту, то будет работать везде. Разбор ведется так же через соответствие представления "\u1040 = А" и т.д.
7. It-developer 20 01.08.16 12:07 Сейчас в теме
А что аналога ЗапуститьПриложение нет для Линукс?
8. vkuznecov 25.11.18 20:42 Сейчас в теме
Добрый день ! Есть ли у вас вариант для управляемого приложения ?
Оставьте свое сообщение

См. также

Управляемая консоль запросов, отчетов 3.8.9 (расширение, внешняя обработка) Промо

Консоль запросов v8 v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Работа с запросом и СКД, Полная поддержка пакетных запросов, временных таблиц, Сравнение результатов, текстов, Разбор структуры запроса в виде дерева, Анализ плана запроса, Групповая обработка

5 стартмани

14.08.2018    94231    2375    Evg-Lylyk    673    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    21083    5    m-rv    88    

Модель объекта

Инструментарий разработчика v8 Абонемент ($m)

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    12856    0    vadim1980    5    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    45600    253    informa1555    232    

Установка предопределенных элементов: просмотр, исправление и поиск ошибок (задвоенных и отсутствующих) Промо

Инструментарий разработчика Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простая обработка для просмотра и установки значений предопределенных элементов. Позволяет заменить значение предопределенного элемента с одного элемента справочника на другой, удалить предопределенный элемент (снять пометку предопределенности), установить пометку переопределенного элемента. Проверяет предопределенные данные на наличие задвоений и отсутствующих. Работает со справочниками, планами счетов, планами видов характеристик, планами видов расчетов.

2 стартмани

06.10.2014    152832    2008    ekaruk    165    

Навигатор по конфигурации базы 1С 8.3

Инструментарий разработчика Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Платформа 8.3, управляемые формы. Версия 1.1.0.69 от 27.09.2020

3 стартмани

28.10.2018    34792    309    ROL32    69    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22063    13    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28560    26    informa1555    26    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    47592    156    ekaruk    32    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    48760    17    kalyaka    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30822    86    m-rv    57    

Регистры правил [Расширение]

Инструментарий разработчика Информационная безопасность v8 v8::Права УТ11 Абонемент ($m)

Регистры правил - права доступа, запрет редактирования, автоподстановка реквизитов и т.д.

10 стартмани

15.03.2018    18206    10    33lab    1    

Faster - многофункциональный ускоритель работы программиста 1С и других языков программирования Промо

Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Программа Faster 9.4 позволяет ускорить процесс работы программиста (работает в любом текстовом редакторе). Подсказка при вводе текста на основе ранее введенного текста и настроенных шаблонов. Программа Faster позволяет делится кодом с другими программистами в два клика или передать ссылку через QR Код. Исправление введенных фраз двойным Shift (с помощью speller.yandex). Переводчик текста. Переворачивает текст случайно набранный на другой раскладке. Полезная утилита для тех, кто печатает много однотипного текста, кодирует в среде Windows на разных языках программирования. Через некоторое время работы с программой у вас соберется своя база часто используемых словосочетаний и кусков кода. Настройка любых шорткатов под себя с помощью скриптов. Никаких установок и лицензий, все бесплатно.

1 стартмани

24.05.2012    78445    212    moolex    147    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28651    19    mvxyz    17    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27367    54    kwazi    6    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    32807    36    bonv    10    

Консоль запросов + ТЗ как параметры Промо

Консоль запросов v8 1cv8.cf Украина Абонемент ($m)

Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

2 стартмани

12.11.2010    36244    64    Kashemir    24    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    132043    13    signum2009    48    

Набор подсистем "Умные таблицы"

Инструментарий разработчика v8 Беларусь Россия Казахстан Абонемент ($m)

Данный набор подсистем – прикладная библиотека, призванная помочь программисту 1С быстрее решать ряд типовых задач бизнес-логики, таких как: ведение статусов объектов, отправка почтовых сообщений в определенное время, ведение произвольных таблиц с возможностью редактирования, сохранения и группировки, ориентированные на расчет бюджетных таблиц (план продаж, ретробонусы B2C, проценты по договорам B2B и договорные условия по КАМ), расчет коммерческой политики для бюджетных таблиц, исполнение произвольных алгоритмов с хранением кода в информационной базе, определение рабочих баз, хранение файлов во внешних СУБД (Postgre SQL, MS SQL и MongoDB) и выполнение произвольного кода после изменений ссылочного объекта вне транзакции изменения.

1 стартмани

22.05.2017    33468    96    Silenser    34    

Конструктор-тестер http запросов в 1С

WEB Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    42811    298    hlopik    17    

[x1c.ru] 1CDBin: Работа с файлами *.1CD на низком уровне средствами языка 1С с возможностью чтения таблиц (поддерживается формат 8.3.8.0) Промо

Тестирование и исправление Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Обработка позволяет просматривать файловые базы 1CD на низком уровне средствами встроенного языка. Реализована часть функциональности Tool_1CD, но на языке 1С Предприятия. Показываются таблицы, параметры таблиц, поля таблиц, записи таблиц, значения полей BLOB, есть 16-ричный просмотр страниц базы и консоль кода. Можно использовать для изучения структуры файлов 1CD, просмотра баз 1CD для выявления повреждений, создания своих обработок для выгрузки данных без открытия исследуемой базы в 1С:Предприятии.

1 стартмани

07.10.2014    54032    217    GusevNA    76    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48514    36    Demanoidos    60    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    34006    19    c1nil    4    

Навигатор по структуре и данным баз 1С 8

Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Просмотр структуры и данных информационных баз 1С:Предприятие 8.2, 8.3. Состав, типы объектов, табличных частей, движений. Размер, структура хранения объекта. Для администраторов и разработчиков. Версия 1 - на обычных формах, версия 2 - на управляемых.

1 стартмани

11.07.2016    29352    131    o.nikolaev    17    

Мастер печатных форм v 3.1 Промо

Универсальные печатные формы v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Создание печатных форм "с нуля" за несколько минут. Моментальная отладка. Не требует знания встроенного языка 1С.

8 стартмани

07.03.2014    93288    402    kser87    221    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    58094    10    wowik    32    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    59647    19    arakelyan    19    

Консоль запросов "Запросник" для управляемых форм с подсветкой синтаксиса

Консоль запросов v8 1cv8.cf Абонемент ($m)

Вот уже много лет я использую замечательный инструмент для работы с запросами - Запросник. Однако, с переходом на управляемые формы для его использования пришлось запускать базы в устаревшем толстом клиенте, да еще и разрешать в свойствах конфигурации использование обычных форм. В 2014 году появился запросник на управляемых формах, который, к сожалению, оказался несовершенен из за ограничений платформы. Самое неприятное из них - отсутствие подсветки синтаксиса. Мне кажется, что я нашел решение этой проблемы.

1 стартмани

19.04.2016    38083    256    1С_Мастер    42    

Разбираемся со структурой правил конвертации данных Промо

Инструментарий разработчика v8 КД Абонемент ($m)

При переносе данных между различающимися данными частенько приходится смотреть в правила. И часто, чтобы выяснить, к примеру, каким документом формируются остатки по конкретному ПВД, нужно заглядывать в него и искать, какое ПКО в нем вызывается. А может вызываться и алгоритм, в котором вызывается ПКО ;-) А если правил много? Чтобы не мучить себя утомительными поисками, предлагаю воспользоваться этой обработкой.

1 стартмани

14.10.2011    22924    29    Meta    17    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    81971    160    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18535    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    50539    53    yuraos    17    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23589    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37282    20    milkers    4    

Нечеткий поиск одним запросом

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    28149    71    vasvl123    9    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    57485    48    YPermitin    19    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена)

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    40198    135    catsam    8    

Exec - Выполнение кода, консоль запросов и не только!

Консоль запросов v8 1cv8.cf Абонемент ($m)

Незаменимый инструмент администратора БД и программиста: Выполняйте произвольный код из режима 1С Предприятие; сохраняйте/загружайте часто используемые скрипты; выполняйте запросы с замером производительности запроса в целом и каждой из временных таблиц в частности, а также с просмотром содержимого временных таблиц; произвольным образом изменяйте любые объекты БД, редактируя даже не вынесенные на формы реквизиты и записывая изменения в режиме "ОбменДанными.Загрузка = Истина"; легко узнавайте ИД объектов БД; выполняйте прямые запросы к SQL с замером производительности и не только!

5 стартмани

10.11.2015    41409    75    catsam    11    

Быстрое определение интервалов в запросе

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    52063    35    ildarovich    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    203392    445    Zerocl    70    

Code First и Linq to EF на примере 1С версии 7.7 и 8.3 часть I

Практика программирования v8 Абонемент ($m)

Данный проект является чисто исследовательским примером использования Code First и Linq to EF на примере 1С версии 7.7. Так как сам я программист 1С, то мне всегда было интересно, как можно перенести модель объектов 1С на компилируемые языки, и использовать мощь Linq to EF. С появлением Code First давно хотел прикрутить, но все как-то руки не доходили, и вот, наконец ..

1 стартмани

28.08.2015    23040    3    Serginio    2    

Работа с push сервисами только средствами 1С 8.2

Сервисные утилиты Инструментарий разработчика Универсальные обработки v8 Абонемент ($m)

Обработка для настройки, тестирования и использования с предустановками для 3-х сервисов. Текст модуля для внедрения в конфигурацию или другие обработки. Уведомления на телефон, компьютер, браузер.

1 стартмани

18.08.2015    31137    43    anig99    1    

Универсальная учетная система с конструктором документов и справочников в режиме 1С: Предприятие

Инструментарий разработчика Практика программирования v8 1cv8.cf УУ Абонемент ($m)

Заголовок статьи звучит фантастично, но это не шутка. Занимаясь внедрениями, я часто сталкивался с ситуацией, когда надо было к типовой конфе приделать простенький модуль учета чего-нибудь, не специфичного для самой конфы. Например в УТ учет материалов в эксплуатации. Модуль обычно состоял из пары справочников (2-3), 3-х документов и регистра или пары регистров. Однажды подобные пристройки понадобились одновременно на 3 проектах. Скучно делать одинаковую работу, и я подумал, а что, если сделать универсальный инструмент, в котором пользователь сам сможет нарисовать себе справочники, реквизиты к ним, документы и движения. Т.е. конструктор полноценных документов в пользовательском режиме. Это оказалось не так сложно - все дело в подходящей архитектуре данных.

1 стартмани

29.07.2015    31996    88    informa1555    41    

Конвертация данных. Найдется все! И еще немного...

Поиск данных Инструментарий разработчика v8 КД Абонемент ($m)

Каждый разработчик, применяющий конфигурацию «1С:Конвертация данных», когда-нибудь обязательно сталкивается с проблемой поиска данных в правилах обмена и (или) регистрации данных.

2 стартмани

25.06.2015    28598    32    tomvlad    7    

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7

Универсальные функции Практика программирования v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    28375    3    Serginio    1    

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    30595    43    Tatitutu    10