Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7

Публикация № 371762

Разработка - Практика программирования

Группировка данных

Я очень часто использую группировку данных по полю и  полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ.
  Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию.
Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны.
Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.
///================ Группировка Данных ===============================================
Функция ПолучитьМассивСтрок(Тз,нач,кон)
    Массив= новый Массив(Кон-Нач+1);
    инд=0;
    Для сч=Нач по Кон Цикл
        Массив[инд]=Тз[сч];
        инд=инд+1;
    КонецЦикла;
    возврат Массив
КонецФункции

Функция глСгруппироватьТзПоПолю(Тз,Поле,ПоляСортировкиТзПоГруппе="") Экспорт
     перем Тип,Длина,Точность,ЕстьСпр,ЕстьДок;
     ЕстьСпр=0; ЕстьДок=0;

     Колонка=Тз.Колонки.Найти(Поле);
     // Для того что бы правильно сртировались элементы с одинаковыми представление
     // Сначала отсортируем по внутреннему значению
     //а после группирования по представлению по возрастанию
     Сравнение=Новый СравнениеЗначений;

   ПоляСортировки=Поле;
   Если не пустаяСтрока(ПоляСортировкиТзПоГруппе) Тогда
       ПоляСортировки=ПоляСортировки+","+ПоляСортировкиТзПоГруппе
   КонецЕсли;
   Тз.Сортировать(ПоляСортировки,Сравнение);
     ТзФ=новый ТаблицаЗначений;
     ТзФ.Колонки.Добавить(Колонка.Имя,Колонка.типЗначения);
     ТзФ.Колонки.Добавить("ТзПоГруппе",Новый ОписаниеТипов("ТаблицаЗначений"));
     ТекСтр=0;
     Заявка=0;
     НачСтр=-1;
     СтрТзф="";
     Если Тз.Количество()>0 Тогда

         Для сч=0 По Тз.Количество()-1 Цикл
             строка=тз[сч];
               ТекЗаявка=Строка[Поле];

               Если (Сч=0) или ( Заявка<>ТекЗаявка) Тогда
                    Если НачСтр>-1 Тогда
                        ТекТз=Тз.Скопировать(ПолучитьМассивСтрок(Тз,НачСтр,сч-1));
                         СтрТзф.ТзПоГруппе=ТекТз;
                    КонецЕсли;

                   СтрТзф= ТзФ.Добавить();
                    Заявка=ТекЗаявка;
                   СтрТзф[Поле]=ТекЗаявка;
                    НачСтр=сч;
               КонецЕсли;
                       КонецЦикла;

          Если НачСтр>-1 Тогда
               ТекТз=Тз.Скопировать(ПолучитьМассивСтрок(Тз,НачСтр,Тз.Количество()-1));
               СтрТзф.ТзПоГруппе=ТекТз;
          КонецЕсли;
     КонецЕсли;
        Возврат ТзФ;
 КонецФункции

 Функция СравнитьПоля(Структ,Строка)
    Для каждого стр из Структ Цикл
        Если Стр.Значение<>Строка[Стр.Ключ] Тогда
            возврат ложь
        КонецЕсли;
    КонецЦикла;
        возврат истина
    КонецФункции

    Процедура ДобавитьПоля(Тз,ТзОриг,Поля) Экспорт
        если ПустаяСтрока(Поля) Тогда
            возврат
        КонецЕсли;

        МассивПолей=ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Поля,",");
        Для каждого Поле из МассивПолей Цикл
     Колонка=ТзОриг.Колонки.Найти(Поле);
     Тз.Колонки.Добавить(Колонка.Имя,Колонка.типЗначения);
     КонецЦикла;

 КонецПроцедуры

 Процедура ПроссумироватьПоля(Тз,ТзСтрок,МассивСуммируемыхПолей)
     Для Каждого Стр из МассивСуммируемыхПолей Цикл
        Тз[стр] = ТзСтрок.Итог(Стр);
     КонецЦикла;

 КонецПроцедуры

Функция глСгруппироватьТзПоПолям(Тз,Поля,СуммируемыеПоля,ПоляСортировкиТзПоГруппе="") Экспорт
     перем Тип,Длина,Точность,ЕстьСпр,ЕстьДок;
     ЕстьСпр=0; ЕстьДок=0;

     если ПустаяСтрока(СуммируемыеПоля) Тогда
         МассивСуммируемыхПолей=Новый массив;
         Иначе
     МассивСуммируемыхПолей=ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(СуммируемыеПоля,",");
     КонецЕсли;
     Структ=Новый Структура(Поля);

     // Для того что бы правильно сртировались элементы с одинаковыми представление
     // Сначала отсортируем по внутреннему значению
     //а после группирования по представлению по возрастанию
     Сравнение=Новый СравнениеЗначений;


   ПоляСортировки=Поля;
   Если не пустаяСтрока(ПоляСортировкиТзПоГруппе) Тогда
       ПоляСортировки=ПоляСортировки+","+ПоляСортировкиТзПоГруппе
   КонецЕсли;
   Тз.Сортировать(ПоляСортировки,Сравнение);

     ТзФ=новый ТаблицаЗначений;
      ДобавитьПоля(ТзФ,Тз,Поля);
      ДобавитьПоля(ТзФ,Тз,СуммируемыеПоля);

      ТзФ.Колонки.Добавить("ТзПоГруппе",Новый ОписаниеТипов("ТаблицаЗначений"));

     ТекСтр=0;
     Заявка=0;
     НачСтр=-1;
     СтрТзф="";
     Если Тз.Количество()>0 Тогда

         Для сч=0 По Тз.Количество()-1 Цикл
             строка=тз[сч];

               Если (Сч=0) или не СравнитьПоля(Структ,Строка) Тогда
                    Если НачСтр>-1 Тогда
                         ТекТз=Тз.Скопировать(ПолучитьМассивСтрок(Тз,НачСтр,сч-1));
                         СтрТзф.ТзПоГруппе=ТекТз;
                         ПроссумироватьПоля(СтрТзф,ТекТз,МассивСуммируемыхПолей);
                    КонецЕсли;

                   СтрТзф= ТзФ.Добавить();
                   Для каждого стр из Структ Цикл
                     Поле=Стр.Ключ;
                     Значение=Строка[поле];
                     Структ[Поле]=Значение;
                     СтрТзф[Поле]=Значение;

                   КонецЦикла;

                    НачСтр=сч;
               КонецЕсли;

          КонецЦикла;

          Если НачСтр>-1 Тогда
               ТекТз=Тз.Скопировать(ПолучитьМассивСтрок(Тз,НачСтр,Тз.Количество()-1));
               СтрТзф.ТзПоГруппе=ТекТз;
               ПроссумироватьПоля(СтрТзф,ТекТз,МассивСуммируемыхПолей);
          КонецЕсли;
     КонецЕсли;

     Возврат ТзФ;
 КонецФункции

 В итоге получаем ТаблицуЗначений с Полями группировки данных и поля типа ТаблицаЗначений с именем ТзПоГруппе содержащая детальные записи.

Пример использования.

// Создаем запрос целью которого является соединение данных по документу и остатков ПартииТоваровНаСкладах
// Добавляем элемент для сортровки. Сначала идут элементы партий у которых совпадают Заказ и Заявка покупалеля, затем где поле заказ пустое
// Затем где заявкаи не совпадают. Можно их не учитывать


Процедура СписатьПартию(Тз,ДокСсылка)
Запрос=новый Запрос;
Запрос.Текст="ВЫБРАТЬ
             |  Таблица.Номенклатура,
             |  Таблица.ХарактеристикаНоменклатуры,
             |  Таблица.ЗаказПокупателя,
             |  Таблица.СерияНоменклатуры,
             |  Таблица.Склад,
             |  Таблица.КодОперации,
             |  Таблица.Количество
             |ПОМЕСТИТЬ Таблица
             |ИЗ
             |  &Тз КАК Таблица
             |;
             |
             |////////////////////////////////////////////////////////////////////////////////
             |ВЫБРАТЬ
             |  Таблица.Номенклатура КАК Номенклатура,
             |  Таблица.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
             |  Таблица.ЗаказПокупателя,
             |  Таблица.СерияНоменклатуры КАК СерияНоменклатуры,
             |  Таблица.Склад КАК Склад,
             |  Таблица.Количество КАК КоличествоСписания,
             |  ПартииТоваровНаСкладахОстатки.ДокументОприходования,
             |  ПартииТоваровНаСкладахОстатки.СтатусПартии,
             |  ПартииТоваровНаСкладахОстатки.Заказ,
             |  ПартииТоваровНаСкладахОстатки.Качество,
             |  ПартииТоваровНаСкладахОстатки.Организация,
             |  ЕСТЬNULL(ПартииТоваровНаСкладахОстатки.КоличествоОстаток, 0) КАК Количество,
             |  ЕСТЬNULL(ПартииТоваровНаСкладахОстатки.СтоимостьОстаток, 0) КАК Стоимость,
             |  ВЫБОР
             |      КОГДА Таблица.ЗаказПокупателя = ПартииТоваровНаСкладахОстатки.Заказ
             |          ТОГДА 0
             |      КОГДА ПартииТоваровНаСкладахОстатки.Заказ = ЗНАЧЕНИЕ(Документ.ЗаказПокупателя.ПустаяСсылка)
             |          ТОГДА 2
             |      ИНАЧЕ 3
             |  КОНЕЦ КАК СортировакаПоЗаказу,
             |  ПартииТоваровНаСкладахОстатки.ДокументОприходования.МоментВремени КАК МоментВремени,
             |  Таблица.КодОперации
             |ИЗ
             |  Таблица КАК Таблица
             |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ПартииТоваровНаСкладах.Остатки(
             |              &МоментВремени,
             |              (Номенклатура, Склад, ХарактеристикаНоменклатуры, СерияНоменклатуры) В
             |                  (ВЫБРАТЬ
             |                      тз.Номенклатура,
             |                      тз.Склад,
             |                      тз.ХарактеристикаНоменклатуры,
             |                      тз.СерияНоменклатуры
             |                  ИЗ
             |                      Таблица КАК тз)) КАК ПартииТоваровНаСкладахОстатки
             |      ПО Таблица.Номенклатура = ПартииТоваровНаСкладахОстатки.Номенклатура
             |          И Таблица.Склад = ПартииТоваровНаСкладахОстатки.Склад
             |          И Таблица.ХарактеристикаНоменклатуры = ПартииТоваровНаСкладахОстатки.ХарактеристикаНоменклатуры
             |          И Таблица.СерияНоменклатуры = ПартииТоваровНаСкладахОстатки.СерияНоменклатуры
             |
             |УПОРЯДОЧИТЬ ПО
             |  Номенклатура,
             |  Склад,
             |  ХарактеристикаНоменклатуры,
             |  СерияНоменклатуры,
             |  СортировакаПоЗаказу,
             |  МоментВремени";

             Запрос.УстановитьПараметр("Тз",ТЗ);
             Запрос.УстановитьПараметр("МоментВремени",ДокСсылка.МоментВремени());
             ТзЗапрс=Запрос.Выполнить().выгрузить();
             ТзЗапрс.ВыбратьСтроку();
             Рез=глСгруппироватьТзПоПолям(ТзЗапрс,"Номенклатура,Склад,ХарактеристикаНоменклатуры,СерияНоменклатуры","Количество","СортировакаПоЗаказу,МоментВремени");
            Отказ=ложь;
            Регистр=РегистрыНакопления.ПартииТоваровНаСкладах;

            // Здесь можно не указывать поля для сортровки, так как в глСгруппироватьТзПоПолям уже их указали
            ТзРезулт=ПолучитьТзСписаний(рез,Регистр,"КоличествоСписания","Количество","Стоимость",Отказ,"СортировакаПоЗаказу,МоментВремени");

            Если Отказ Тогда
                Предупреждение("Движения не запианы");
            Иначе
                ЗаписатьДвижения(ТзРезулт,ДокСсылка,Регистр)

            КонецЕсли;
         КонецПроцедуры

 Ну и на закуску

 

// Функция НайтиПоУсловию для отбора строк в ТЗ по различным условиям
//К сожалению в 1С нет ни лямбд ни делегатов
//но есть функция вычислить, которая выполняет текст

// Примеры использования
//тз=НайтиПоУсловию(тз,"Стр.Колонка1<20 и Стр.Колонка2>500");
//  или
//Список=ОбщегоНазначение.РазложитьСтрокуВМассивПодстрок("Иванов,Сидоров,Петров");

//Рез=НайтиПоУсловию(тз,"Список.Найти(стр.ФизЛицо)<>Неопределено");

//Или

//Рез=НайтиПоУсловию(тз,"Найти(Врег(стр.Значение),Врег(""акф""))>0");

//Рез=НайтиПоУсловию(тз,"Модуль.ФункцияСравнения(Стр,Список)",МассивСтруктур,ЭтотОбъект);

//То есть в модуле обработки должна быть функция
//  Функция ФункцияСравнения(стр,МассивСтруктур) Экспорт

Функция НайтиПоУсловию(Тз,Условие,Список="",Модуль="") Экспорт
Массив = новый массив;
 Для каждого Стр из Тз Цикл
   Если Вычислить(Условие) Тогда
     массив.Добавить(стр)
   КонецЕсли
 КонецЦикла;
возврат Тз.Скопировать(массив)
КонецФункции



Скачать файлы

Наименование Файл Версия Размер
ErtОбщегоНазначения.zip

.zip 65,86Kb
24.07.15
4
.zip 65,86Kb 4 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    47262    156    ekaruk    32    

Работа с журналом регистрации. Выходим за границы платформы

Журнал регистрации Бесплатно (free)

Работа с журналом регистрации нестандартными средствами. А также немного про использование платформы .NET в экосистеме 1С.

12.05.2020    6130    YPermitin    24    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    24661    22    Stepa86    45    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    20556    4    m-rv    86    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30451    86    m-rv    57    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    24534    17    stvorl    0    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21743    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    37470    54    dsdred    15    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28291    19    mvxyz    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28142    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    47499    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    30916    11    SITR-utyos    13    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    27763    70    vasvl123    9    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27057    53    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    45442    12    swimdog    42    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    32544    132    PLAstic    59    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    51528    35    ildarovich    41    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    22787    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    129510    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31439    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    29198    125    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22269    105    Alxby    23    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    36686    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    26791    135    Stepa86    15    

1С, Linux, Excel, Word, OpenXML, ADO, Net Core

Разработка внешних компонент v8 Бесплатно (free)

В данной статье показаны примеры кроссплатформенной работы с файлами Excel и Word (xlsx,docx) с помощью библиотеки OpenXML и Net Core

22.08.2016    21244    Serginio    14    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48158    36    Demanoidos    60    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28255    77    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    57417    10    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    61535    181    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    58586    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    34557    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    81059    158    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18277    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    49934    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    55066    179    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23294    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    48206    173    TuneSoft    30    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37050    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    56895    48    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    93050    459    Luchik    205    

Автоматическая подстановка уничтожений временных таблиц в текст запроса

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция, которая сама подставляет в текст запроса "УНИЧТОЖИТЬ" в местах последнего использования ВТ.

1 стартмани

14.11.2015    20274    0    SeiOkami    3