Исправление ошибок в типовых релизах 1С: УТ 10.3 и Розница 1.0 при отражении продаж в ЕГАИС

Публикация № 529033

Разработка - Адаптация типовых решений

ЕГАИС продажа ошибка ошибки розничная продажа алкогольной продукции ут 10.3 релиз 36.1 Розница

7
При продаже алкогольной продукции в программах Управление торговлей и Розница возникают ошибки. В статье разберем причины ошибок и способ их решения.

В программе УТ 10.3 на релизе 36.1, а так же в Рознице 1.0.19.16, которые на данный момент являеются последними при попытке продажи алкогольной продукции с отправкой данных в ЕГАИС, возникает ошибка "java.lang.IllegalArgumentException: org.xml.sax.SAXParseException; cvc-pattern-valid: Value '0' is not facet-valid with respect to pattern '[1-9][0-9]{0,9}' for type 'COUNT'". В процесе анализа ошибки выяснилось, что данная ошибка возникает из-за незаполненых полей в формируемом пакете, который и отправляется в ЕГАИС. Поле номер смены и номер чека ККМ, в программе выгружаются как значение '0'. В ЕГАИС по этим данным формируется информация о чеке, они должны быть заполнены обязательно.  Проблема в том, что в общем модуле ИнтеграцияЕГАИСКлиентПредопределенный  в функцию ПодготовитьВходящиеДанныеДляПодписиЧека не передаестя номер чека и смены. Номер смены особого значения не имеет, можно смело ставить 1, просто при загрузке в ЕГАИС нулевое значение не принимается. Так же важно указать номер чека, для этого в модуле функции Чека ККМ в функции ПараметрыЧекаДляПодписиВЕГАИС в параметр чека можно передать и его номер. 

Для исправления текущей ошибки можно исправить две функции, которые я описал выше следующим образом:

1.Функция ПараметрыЧекаДляПодписиВЕГАИС в модуле Чека ККМ. 

Функция ПараметрыЧекаДляПодписиВЕГАИС(ТаблицаТоваров, СуммаНал, СуммаБезНал, ТранспортныйМодуль = Неопределено)
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Ссылка", Ссылка);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЧекККМ.Организация.ИНН 		  КАК ИНН,
	|	ЧекККМ.Организация.КПП 		  КАК КПП,
	|	"""" 						  КАК АдресМагазина,
	|	ЧекККМ.Склад.Наименование 	  КАК НаименованиеМагазина,
	|	0							  КАК ЗаводскойНомерККМ,
	|	ВЫБОР
	|		КОГДА ЧекККМ.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЧекККМ.Возврат)
	|			ТОГДА ИСТИНА
	|		ИНАЧЕ ЛОЖЬ
	|	КОНЕЦ 					      КАК Возврат,
	|	ЧекККМ.Организация   		  КАК Организация,
	|	ЧекККМ.Склад 				  КАК Склад
	|ИЗ
	|	Документ.ЧекККМ КАК ЧекККМ		
	|ГДЕ
	|	ЧекККМ.Ссылка = &Ссылка";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Выборка.Следующий();
	
	ПараметрыЧека = Новый Массив;
	ПараметрыЧека.Добавить(ТаблицаТоваров);
	ПараметрыЧека.Добавить(СуммаНал);
	ПараметрыЧека.Добавить(СуммаБезНал);
	ПараметрыЧека.Добавить(Выборка.Возврат);
	ПараметрыЧека.Добавить(Выборка.ИНН);
	ПараметрыЧека.Добавить(Выборка.КПП);
	ПараметрыЧека.Добавить(Выборка.АдресМагазина);
	ПараметрыЧека.Добавить(Выборка.НаименованиеМагазина);
	ПараметрыЧека.Добавить(Выборка.ЗаводскойНомерККМ);
	
	ТранспортныйМодуль = ИнтеграцияЕГАИСПереопределяемый.ИспользуемыйТранспортныйМодуль(Выборка.Склад, Выборка.Организация);
	ПараметрыЧека[6] = ТранспортныйМодуль.Адрес;
	ПараметрыЧека[9] = Прав(Ссылка.Номер,5);

	Возврат ПараметрыЧека;
КонецФункции

Прав(Ссылка.Номер,5) - применяется для того, чтобы исбавиться от префикса в номере чека. Если у Вас в программе установлен префикс в номере документов, то это не позволит использовать номер при передачи в ЕГАИС, так как в стандарте обмена прописано, что номер чека является числовым значением.

2. Функция ПодготовитьВходящиеДанныеДляПодписиЧека в общем модуле ИнтеграцияЕГАИСКлиентПредопределенный.

Функция ПодготовитьВходящиеДанныеДляПодписиЧека(ПараметрыЧека, НомерЧека = 0, НомерСмены = 1, РезультатПодготовки = Неопределено) Экспорт

	РезультатПодготовки = Новый Структура("Результат, ОписаниеОшибки", Ложь, "");
	
	ВходящиеДанные = СтруктураДанныхЧекаККМ();
	
	ТаблицаТоваров = ПараметрыЧека[0];
	
	Если ТаблицаТоваров.Колонки.Найти("ПараметрыАлкогольнойПродукции") = Неопределено Тогда
		РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
		Возврат ВходящиеДанные;
	КонецЕсли;
	
	ВыгружатьНемаркируемуюПродукцию = ИнтеграцияЕГАИСКлиентПовтИсп.ВыгружатьПродажиНемаркируемойПродукцииВЕГАИС();
	
	ВходящиеДанные.ИНН                  = ПараметрыЧека[4];
	ВходящиеДанные.КПП                  = ПараметрыЧека[5];
	ВходящиеДанные.АдресМагазина        = ПараметрыЧека[6];
	ВходящиеДанные.НаименованиеМагазина = ПараметрыЧека[7];
	ВходящиеДанные.ЗаводскойНомерККМ    = ПараметрыЧека[8];
	ВходящиеДанные.НомерСменыККМ        = НомерСмены;
	ВходящиеДанные.НомерЧекаККМ         = ПараметрыЧека[9];
	ВходящиеДанные.ДатаВремяЧека        = ТекущаяДата();
	ВходящиеДанные.Возврат              = ПараметрыЧека[3];
	
	Для Каждого СтрокаТаблицы Из ТаблицаТоваров Цикл
		
		ПараметрыАлкогольнойПродукции = СтрокаТаблицы.ПараметрыАлкогольнойПродукции;
		
		Если ТипЗнч(ПараметрыАлкогольнойПродукции) <> Тип("Структура") Тогда
			РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
			Возврат ВходящиеДанные;
		КонецЕсли;
		
		Если НЕ ПараметрыАлкогольнойПродукции.Свойство("АлкогольнаяПродукция")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Маркируемая")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Штрихкод")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Объем") Тогда
			РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
			Возврат ВходящиеДанные;
		КонецЕсли;
		
		Если НЕ ПараметрыАлкогольнойПродукции.АлкогольнаяПродукция Тогда
			Продолжить;
		КонецЕсли;
		
		Если ПараметрыАлкогольнойПродукции.Маркируемая Тогда
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("ШтрихкодМарки") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Штрихкод марки"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
		Иначе
			
			Если НЕ ВыгружатьНемаркируемуюПродукцию Тогда
				Продолжить;
			КонецЕсли;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("Крепость") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Крепость"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("КодВидаПродукции") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Код вида алкогольной продукции"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
		КонецЕсли;
		
		КоличествоСтрок = ?(ПараметрыАлкогольнойПродукции.Маркируемая, СтрокаТаблицы.Количество, 1);
		
		Для Сч = 1 По КоличествоСтрок Цикл
			СтрокаЧека = СтруктураДанныхСтрокиЧекаККМ();
			СтрокаЧека.Наименование   = СтрокаТаблицы.Наименование;
			СтрокаЧека.Количество     = ?(ПараметрыАлкогольнойПродукции.Маркируемая, 1, СтрокаТаблицы.Количество);
			
			Если СтрокаТаблицы.Количество = 0 ИЛИ СтрокаТаблицы.Скидка = 0 Тогда
				СтрокаЧека.Цена = СтрокаТаблицы.Цена;
			Иначе
				СтрокаЧека.Цена = Окр(СтрокаТаблицы.Цена * СтрокаТаблицы.Скидка * 0.01, 2);
			КонецЕсли;
			
			СтрокаЧека.ШтрихкодТовара = ПараметрыАлкогольнойПродукции.Штрихкод;
			СтрокаЧека.Объем          = ПараметрыАлкогольнойПродукции.Объем;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Маркируемая Тогда
				СтрокаЧека.Крепость = ПараметрыАлкогольнойПродукции.Крепость;
				СтрокаЧека.КодВидаПродукции = ПараметрыАлкогольнойПродукции.КодВидаПродукции;
				ВходящиеДанные.ТаблицаТоваровБезМарки.Добавить(СтрокаЧека);
			Иначе
				Если ТипЗнч(ПараметрыАлкогольнойПродукции.ШтрихкодМарки) = Тип("Массив") Тогда
					СтрокаЧека.ШтрихкодМарки = ?(ПараметрыАлкогольнойПродукции.ШтрихкодМарки.ВГраница() < Сч - 1, "", ПараметрыАлкогольнойПродукции.ШтрихкодМарки[Сч - 1]);
				ИначеЕсли ТипЗнч(ПараметрыАлкогольнойПродукции.ШтрихкодМарки) = Тип("Строка") И Сч = 1 Тогда
					СтрокаЧека.ШтрихкодМарки = ПараметрыАлкогольнойПродукции.ШтрихкодМарки;
				КонецЕсли;
				
				ВходящиеДанные.ТаблицаТоваров.Добавить(СтрокаЧека);
			КонецЕсли;
		КонецЦикла;
		
	КонецЦикла;
	
	РезультатПодготовки.Результат = Истина;
	
	Возврат ВходящиеДанные;

КонецФункции // ПодготовитьВходящиеДанныеДляПодписиЧека()

 

Еще в рознице может возникать ошибка:

java.lang.IllegalArgumentException: org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '\S{1,128}' for type 'NOEMPTY'

Как и с предыдущей ошибкой из текста ясно лишь одно, что какое-то поле из передаваемых данных не заполнено или заполнено не корректно. Как оказалось после анализа отправляеммых данных, что проблема в незаполненных данных кассы. В рознице в кассе проставляются данные "Серийный номер" и "Регистрационный номер" кассового аппарата. Данные эти не выжны, но не должны быть пустыми, можно поставить просто 1, после этого ошибка исчезнет и данные будут отправляться нормально. В управлении торговлей данная ошибка не возникает, т.к. в настройках кассы нет серийного номера и 1с передает в ЕГАИС значение по умолчанию "0", а это удовлетворяет требованиям выгрузки.


Публикации конфигураций с возможностью подключать к одному рабочему месту двух кассовых аппаратов уже не содержат данных ошибок и могут отправлять данные о продажах в ЕГАИС.


P.S. Если у Вас есть еще какие-либо ошибки, с которыми Вы столкнулись в момент начала продаж алкогольной продукции через систему ЕГАИС, пишите в комментариях, с радостью добавлю описание и решение их в статью.

7

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. ejique 09.06.16 14:38 Сейчас в теме
ПараметрыЧека[9] = Прав(Ссылка.Номер,5);

Даст индекс за пределами массива, т.к. нумерация элементов массива начинается с 0.

Предлагаю заменить на
ПараметрыЧека.Добавить(Прав(Ссылка.Номер,5));
2. @lexandr 158 10.06.16 00:40 Сейчас в теме
(1) ejique,
Даст индекс за пределами массива, т.к. нумерация элементов массива начинается с 0.
Не даст, рекомендацию, которую я предлагаю я опробывал уже и в УТ 10.3 и в Рознице 1.0, это работает именно так как я описал, так что замечание не обоснованное.
3. ejique 10.06.16 11:28 Сейчас в теме
(2) я вчера тоже внес изменения в код и две проблемы.
Одна это та которую я описал выше, а вторая что сохранилась ошибка:

Не удалось сформировать электронную подпись чека в ЕГАИС!

Не удалось отправить чек в УТМ.
Ошибка при выполнении POST-запроса по адресу /xml
java.lang.IllegalArgumentException: org.xml.sax.SAXParseException; cvc-pattern-valid: Value '0' is not facet-valid with respect to pattern '[1-9][0-9]{0,9}' for type 'COUNT'.
Не удалось отправить чек в УТМ.
Ошибка при выполнении POST-запроса по адресу /xml
java.lang.IllegalArgumentException: org.xml.sax.SAXParseException; cvc-pattern-valid: Value '0' is not facet-valid with respect to pattern '[1-9][0-9]{0,9}' for type 'COUNT'.


Подскажите какой версией транспортного модуля вы пользуетесь?
5. @lexandr 158 10.06.16 22:34 Сейчас в теме
(3) ejique, и на 2.0.2 и на 2.0.3 проверял данную ошибку
4. brrart 24 10.06.16 16:13 Сейчас в теме
Методом проб и ошибок пришли в выводу что УТМ требует все заполненные реквизиты ... и НомерСмены и ЗаводскойНомерККМ и НомерЧека ... посему в нашем случае приведенные в сабже функции выглядят вот так:

В модуле ЧекаККМ:
Функция ПараметрыЧекаДляПодписиВЕГАИС(ТаблицаТоваров, СуммаНал, СуммаБезНал, ТранспортныйМодуль = Неопределено)
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Ссылка", Ссылка);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЧекККМ.Организация.ИНН КАК ИНН,
	|	ЧекККМ.Организация.КПП КАК КПП,
	|	"""" КАК АдресМагазина,
	|	ЧекККМ.Склад.Наименование КАК НаименованиеМагазина,
	|	1 КАК ЗаводскойНомерККМ,
	|	1 КАК НомерСмены,
	|	ВЫБОР
	|		КОГДА ЧекККМ.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЧекККМ.Возврат)
	|			ТОГДА ИСТИНА
	|		ИНАЧЕ ЛОЖЬ
	|	КОНЕЦ КАК Возврат,
	|	ЧекККМ.Организация КАК Организация,
	|	ЧекККМ.Склад КАК Склад,
	|	ЧекККМ.Номер КАК Номер
	|ИЗ
	|	Документ.ЧекККМ КАК ЧекККМ
	|ГДЕ
	|	ЧекККМ.Ссылка = &Ссылка";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Выборка.Следующий();
	
	ПараметрыЧека = Новый Массив;
	ПараметрыЧека.Добавить(ТаблицаТоваров);
	ПараметрыЧека.Добавить(СуммаНал);
	ПараметрыЧека.Добавить(СуммаБезНал);
	ПараметрыЧека.Добавить(Выборка.Возврат);
	ПараметрыЧека.Добавить(Выборка.ИНН);
	ПараметрыЧека.Добавить(Выборка.КПП);
	ПараметрыЧека.Добавить(Выборка.АдресМагазина);
	ПараметрыЧека.Добавить(Выборка.НаименованиеМагазина);
	ПараметрыЧека.Добавить(Выборка.ЗаводскойНомерККМ); //НомерСменыККМ
	ПараметрыЧека.Добавить(Число(Сред(Выборка.Номер,3)));
	ПараметрыЧека.Добавить(Выборка.НомерСмены); //НомерСменыККМ
	
	
	ТранспортныйМодуль = ИнтеграцияЕГАИСПереопределяемый.ИспользуемыйТранспортныйМодуль(Выборка.Склад, Выборка.Организация);
	ПараметрыЧека[6] = ТранспортныйМодуль.Адрес;
	
	Возврат ПараметрыЧека;
	
КонецФункции
Показать


В общем модуле ИнтеграцияЕГАИСКлиентПереопределяемый

Функция ПодготовитьВходящиеДанныеДляПодписиЧека(ПараметрыЧека, НомерЧека = 0, НомерСмены = 0, РезультатПодготовки = Неопределено) Экспорт

	РезультатПодготовки = Новый Структура("Результат, ОписаниеОшибки", Ложь, "");
	
	ВходящиеДанные = СтруктураДанныхЧекаККМ();
	
	ТаблицаТоваров = ПараметрыЧека[0];
	
	Если ТаблицаТоваров.Колонки.Найти("ПараметрыАлкогольнойПродукции") = Неопределено Тогда
		РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
		Возврат ВходящиеДанные;
	КонецЕсли;
	
	ВыгружатьНемаркируемуюПродукцию = ИнтеграцияЕГАИСКлиентПовтИсп.ВыгружатьПродажиНемаркируемойПродукцииВЕГАИС();
	
	ВходящиеДанные.ИНН                  = ПараметрыЧека[4];
	ВходящиеДанные.КПП                  = ПараметрыЧека[5];
	ВходящиеДанные.АдресМагазина        = ПараметрыЧека[6];
	ВходящиеДанные.НаименованиеМагазина = ПараметрыЧека[7];
	ВходящиеДанные.ЗаводскойНомерККМ    = ПараметрыЧека[8];
	ВходящиеДанные.НомерСменыККМ        = ПараметрыЧека[10];
	ВходящиеДанные.НомерЧекаККМ         = ПараметрыЧека[9];
	ВходящиеДанные.ДатаВремяЧека        = ТекущаяДата();        
	ВходящиеДанные.Возврат              = ПараметрыЧека[3];
	
	Для Каждого СтрокаТаблицы Из ТаблицаТоваров Цикл
		
		ПараметрыАлкогольнойПродукции = СтрокаТаблицы.ПараметрыАлкогольнойПродукции;
		
		Если ТипЗнч(ПараметрыАлкогольнойПродукции) <> Тип("Структура") Тогда
			РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
			Возврат ВходящиеДанные;
		КонецЕсли;
		
		Если НЕ ПараметрыАлкогольнойПродукции.Свойство("АлкогольнаяПродукция")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Маркируемая")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Штрихкод")
			ИЛИ НЕ ПараметрыАлкогольнойПродукции.Свойство("Объем") Тогда
			РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'В процедуру подготовки входящих данных передана некорректная структура параметров.'");
			Возврат ВходящиеДанные;
		КонецЕсли;
		
		Если НЕ ПараметрыАлкогольнойПродукции.АлкогольнаяПродукция Тогда
			Продолжить;
		КонецЕсли;
		
		Если ПараметрыАлкогольнойПродукции.Маркируемая Тогда
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("ШтрихкодМарки") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Штрихкод марки"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
		Иначе
			
			Если НЕ ВыгружатьНемаркируемуюПродукцию Тогда
				Продолжить;
			КонецЕсли;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("Крепость") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Крепость"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Свойство("КодВидаПродукции") Тогда
				РезультатПодготовки.ОписаниеОшибки = НСтр("ru = 'Отсутствует обязательное поле ""Код вида алкогольной продукции"".'");
				Возврат ВходящиеДанные;
			КонецЕсли;
			
		КонецЕсли;
		
		КоличествоСтрок = ?(ПараметрыАлкогольнойПродукции.Маркируемая, СтрокаТаблицы.Количество, 1);
		
		Для Сч = 1 По КоличествоСтрок Цикл
			СтрокаЧека = СтруктураДанныхСтрокиЧекаККМ();
			СтрокаЧека.Наименование   = СтрокаТаблицы.Наименование;
			СтрокаЧека.Количество     = ?(ПараметрыАлкогольнойПродукции.Маркируемая, 1, СтрокаТаблицы.Количество);
			
			Если СтрокаТаблицы.Количество = 0 ИЛИ СтрокаТаблицы.Скидка = 0 Тогда
				СтрокаЧека.Цена = СтрокаТаблицы.Цена;
			Иначе
				СтрокаЧека.Цена = Окр(СтрокаТаблицы.Цена * СтрокаТаблицы.Скидка * 0.01, 2);
			КонецЕсли;
			
			СтрокаЧека.ШтрихкодТовара = ПараметрыАлкогольнойПродукции.Штрихкод;
			СтрокаЧека.Объем          = ПараметрыАлкогольнойПродукции.Объем;
			
			Если НЕ ПараметрыАлкогольнойПродукции.Маркируемая Тогда
				СтрокаЧека.Крепость = ПараметрыАлкогольнойПродукции.Крепость;
				СтрокаЧека.КодВидаПродукции = ПараметрыАлкогольнойПродукции.КодВидаПродукции;
				ВходящиеДанные.ТаблицаТоваровБезМарки.Добавить(СтрокаЧека);
			Иначе
				Если ТипЗнч(ПараметрыАлкогольнойПродукции.ШтрихкодМарки) = Тип("Массив") Тогда
					СтрокаЧека.ШтрихкодМарки = ?(ПараметрыАлкогольнойПродукции.ШтрихкодМарки.ВГраница() < Сч - 1, "", ПараметрыАлкогольнойПродукции.ШтрихкодМарки[Сч - 1]);
				ИначеЕсли ТипЗнч(ПараметрыАлкогольнойПродукции.ШтрихкодМарки) = Тип("Строка") И Сч = 1 Тогда
					СтрокаЧека.ШтрихкодМарки = ПараметрыАлкогольнойПродукции.ШтрихкодМарки;
				КонецЕсли;
				
				ВходящиеДанные.ТаблицаТоваров.Добавить(СтрокаЧека);
			КонецЕсли;
		КонецЦикла;
		
	КонецЦикла;
	
	РезультатПодготовки.Результат = Истина;
	
	Возврат ВходящиеДанные;

КонецФункции // ПодготовитьВходящиеДанныеДляПодписиЧека()
Показать
6. @lexandr 158 10.06.16 22:37 Сейчас в теме
(4) brrart, ЗаводскойНомерККМ по умолчанию в УТ 10.3 стоит 0, на это утм не ругается, проверку проходит и данные отправляются, а вот в рознице, там если в кассе не заполнен номер кассового аппарата, то выгружается пустое значение и тогда контроль правильности составленного запроса не проходи и выходит ошика.
7. ejique 11.06.16 10:45 Сейчас в теме
(6) а в рознице в базе вводится номере ККМ или получается и драйвера ККМ при регистрации продажи?
8. @lexandr 158 11.06.16 11:34 Сейчас в теме
(7) ejique, В рознице номер ККМ указывается в настройка кассы, как видно на картинке в публикации.
9. Dwiss 159 21.06.16 17:19 Сейчас в теме
Не совсем правильное решение, номер чека - это не 1С номер, а номер который дает ФР и эти поля есть в документе Чек , я вышел по-другому в запросе добавил НомерСмены и НомерЧека и добавил 2 параметра (9,10) и их передаю и там подставляю.
10. lexme 24.06.16 08:49 Сейчас в теме
на релизе 37.1 ут 10.3 при попытке пробить чек именно любого пива вылезает ошибка на чеке "не удалось сформировать подпись ЕГАИС некорректный код алкогольной продукции" с указанием кода, при этом на такой же базе в другом магазине всё проходит нормально. куда копать? уже очищал значения свойств объектов "коды алкогольной продукции" не помогает
11. @lexandr 158 24.06.16 11:37 Сейчас в теме
(10) lexme, Пока в константах убери галочку выгружать немаркируемую продукцию на закладке настройки обмена с ЕГАИС, он пиво просто выгружать не будет. Пока в 2016 году нет обязаности выгружать в егаис пиво и сидр. Поэтому пока галку можно снять с выходом следующих релизов 1с скорее всего данную ошибку поправит. Что косательно маркируемого алкоголя, то продажа его в 37.1 релизе идет нормально.
12. lexme 24.06.16 14:49 Сейчас в теме
(11) т..е вот таким образом списание проводить : В соответствии с Федеральным законом от 22.11.1995 N 171-ФЗ "О государственном регулировании производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции и об ограничении потребления (распития) алкогольной продукции" розничная продажа пива, пивных напитков, сидра, пуаре и медовухи не подлежит учету в системе ЕГАИС.

При этом, заполнение журнала учета розничных продаж в отношении пива, пивных напитков, сидра, пуаре и медовухи в электронном виде с использованием программных средств ЕГАИС производится следующим образом:
остатки продукции переводятся во второй регистр;
ежедневно в ЕГАИС фиксируется акт списания реализованной продукции с указанием причины списания: «Розничная реализация продукции, не подлежащая фиксации в ЕГАИС».
http://egais.ru/news/view?id=1473
13. ElenaBu 19.07.16 14:07 Сейчас в теме
А никого не смущает строка кода:

СтрокаЧека.Цена = Окр(СтрокаТаблицы.Цена * СтрокаТаблицы.Скидка * 0.01, 2);


если цена 150р и скидка 10, то получается по этой формуле, что в Егаис уйдет 15?
14. Tarlich 81 28.07.16 23:44 Сейчас в теме
15. user598309_varenichka89 01.09.16 04:09 Сейчас в теме
Здравствуйте! Помогите пожалуйста. При продаже продукции программа выдает ошибку. Скрин прилагаю в файле. Заранее благодарю
Прикрепленные файлы:
16. @lexandr 158 01.09.16 12:22 Сейчас в теме
(15) user598309_varenichka89, Не знаю от куда это, поэтому сложно точно сказать в чем причина, но судя из того что он ругается на превышение время, похоже что утм более 3 дней не может связаться с сервером по причине отсутсвия интернета или что-то мешает ему в передачи данных в интернет на сервер егаиса. По закону прописано, что утм в течении 3-х дней должен скинуть эти данные в егаис, если это не происходит, то продажа алкоголя будет заблакирована. Из картинки сложно судить, но похоже что дело именно в этом.
17. vcspektr 04.09.16 14:40 Сейчас в теме
Кто-нибудь может поделиться готовым cf-ником от розницы 1,0,9,16, я замучался уже, ничего не выходит....
18. @lexandr 158 04.09.16 23:18 Сейчас в теме
(17) vcspektr, Публикации конфигураций с возможностью подключать к одному рабочему месту двух кассовых аппаратов уже не содержат данных ошибок и могут отправлять данные о продажах в ЕГАИС. http://infostart.ru/public/404411/
19. vcspektr 05.09.16 10:25 Сейчас в теме
(18) Спасибо, к сожалению платная... Попробую пока сам
20. user1240289 18.06.19 17:46 Сейчас в теме
Добрый день! С помощью данного модуля можно подключить в УТ 10.3.18.5 (1С 8.3.8.2442) на один комп 2 он-лайн кассы для двух разных организаций, которые прописаны в одной базе 1С на SQL-сервере?
Оставьте свое сообщение

См. также

Локализация интерфейсов конфигураций. Практика и инструментарий 1Ci 10

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом Локализация решений

В последнее время компания 1С International все увереннее заявляет о себе на международном рынке. Но для успешного продвижения в этом направлении необходима локализация интерфейсов конфигураций 1С. О том, как выглядит процесс перевода, какие инструменты для этого есть, где брать переводчиков и как проверять их работу, на конференции Infostart Event 2018 Education рассказал руководитель группы локализации компании 1Ci Сергей Поликарпов.

05.11.2019    1306    user1069006    0       

"Прелести" БСП. Часть 1 - Дополнительные реквизиты / сведения 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Адаптация типовых решений

История небольшого расследования - сломались дополнительные реквизиты, или как НЕ НАДО использовать УИД в программном коде.

04.07.2019    6272    Enigma    15       

Итеративная ошибка почтового сервиса в 1С "Комплексная автоматизация" 2.4.8 0

Статья Системный администратор Программист Пользователь Нет файла v8 КА2 Россия Бесплатно (free) Адаптация типовых решений

После обновления на релиз 2.4.8.79 возникла конфликтная ситуация на уровне генерального директора, а именно: клиенты, которым отправлялись письма из 1С, начали регулярно получать одни и те же письма, то есть что-то вроде вирусной атаки (многократная отправка одного и того же письма).

02.07.2019    1676    pas    4       

Не открывается оборотно-сальдовая ведомость или "variable not found in subplan target lists" 0

Статья Программист Нет файла v8 v8::БУ УПП1 БУ Оборотно-сальдовая ведомость, Анализ счета Бесплатно (free) Адаптация типовых решений

При попытке открыть Оборотно-сальдовую ведомость программа выдает ошибку "Ошибка СУБД: ERROR: variable not found in subplan target lists" и либо закрывается, либо ее нужно перезапускать. Описан частный случай решения проблемы.

02.04.2019    2667    Max777    4       

Подключение дополнительных обработок - Розница для Украины 1

Статья Программист Нет файла v8 1cv8.cf Украина Бесплатно (free) Адаптация типовых решений

Внешние подключаемые обработки - замечательный механизм! Но почему же он не работает для простых пользователей?

22.03.2019    2203    kalyuzhny    9       

Неверный расчет СЗВ-СТАЖ. ЗУП 3.1 8

Статья Программист Нет файла v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

При заполнении отчета СЗВ-СТАЖ на последних релизах ЗУП (ошибка не исправлена и в релизе 3.1.9.107) выявлены ошибки при расчете периодов, а также неверное выделение стажа ДЛОТПУСК.

01.03.2019    3594    dbachinsky    2       

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов 65

Статья Программист Нет файла v8 v8::УФ ERP2 УТ11 КА2 УУ Учет ТМЦ Бесплатно (free) Практика программирования Адаптация типовых решений

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    14879    ids79    25       

Пропал фокус (активность) элемента формы, ошибка при переходе на платформу 1С:Предприятие 8.3 (8.3.12.1790) 3

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Адаптация типовых решений

После перехода на платформу 8.3.12.1790 обнаружилась проблема. При подборе товара в форме подбора номенклатуры на поле ввода количество пропал фокус (активность).

09.01.2019    4754    rhtr    20       

Некорректно заполняются значения по умолчанию при создании документа. 1С: УТ 9

Статья Программист Нет файла v8 v8::ОУ УТ11 Россия Бесплатно (free) Адаптация типовых решений

Столкнулся у клиента с такой проблемой: при смене банковского счета организации, 1С настойчиво подставляет в документы, при их создании, старый счет.

21.11.2018    3998    yupi71    11       

ЗУП 3.1: долгое открытие ряда документов (больничный, отпуск, командировка), начиная с релиза 3.1.6.6 - исправление ошибки с кодом 30161250 7

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Россия БУ УУ Зарплата Бесплатно (free) Адаптация типовых решений

В релизе 3.1.6.6 разработчиками была допущена ошибка, заключающаяся в написании крайне неоптимального запроса к базе данных. Конкретно на моей базе, где учет ведется всего пару месяцев, запрос выполнялся около 10 секунд, что уже напрягало. В данной публикации я укажу на расположение данного запроса и выложу текст нового запроса, опубликованного разработчиками в версии для тестирования 3.1.7.67.

21.06.2018    6345    Bene_Valete    12       

Ошибка печати чека на ККМ Атол FPrint22. ПоследующаяОплата (Кредит) вместо Электронными. Розница 2 7

Статья Системный администратор Программист Нет файла v8 Розница Россия Кассовые операции Розничная торговля Бесплатно (free) Адаптация типовых решений ККМ

При печати чека на FPrint22 неожиданно выяснилось, что вместо Электронными (пробивали по платежной карте) в чеке вставало на вид оплат ПоследущаяОплата (Кредит).

22.01.2018    23644    ah7777777    15       

Ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись" в Альфа-Авто 5 и методы ее устранения 3

Статья Системный администратор Программист Нет файла v8 1cv8.cf Автомобили, автосервисы Россия PostgreSQL Бесплатно (free) Адаптация типовых решений

Сегодня посреди рабочего дня база отказалась впускать пользователей. При попытке запуска вываливалась ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись". При этом активные сеансы работали без проблем. Саму ошибку можно было увидеть не всегда, чаще всего она пряталась за баннером с машинками.

28.12.2017    9998    MrsMastersan    6       

Исправление ошибки типового релиза ЗУП 2.5.118.1 в регламентированном отчёте "Расчет по страховым взносам" 22

Статья Программист Нет файла v8::СПР ЗУП2.5 Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования Адаптация типовых решений

В ЗУП 2.5.118.1 ошибка в регламентированном отчёте "Расчет по страховым взносам" за 1 квартал 2017. Коротко об ошибке: В отчёт не попадают сотрудники, уволенные до 2017 года, а попадать они обязаны,т.к. начисления по ним очень часто встречаются, например "Сохраняемый заработок на время трудоустройства" - это как раз выплата уже после увольнения сотрудника.

21.04.2017    16553    human_new    12       

Ошибка при заполнении строки 070 раздела 1 формы 6-НДФЛ 4

Статья Программист Нет файла v8::БУ КА1 Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования Адаптация типовых решений

Комплексная автоматизация, редакция 1.1 (1.1.82.1). Возможно, в ЗУП 2.5.114.1 присутствует также. После очередного обновления КА, бухгалтер по заработной плате пожаловался на неправильное заполнение 070 строки раздела 1 отчета 6-НДФЛ.

08.02.2017    13186    dima_home    3       

Ошибка 2-НДФЛ ЗУП (3.0.25.150) {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива 6

Статья Программист Нет файла v8 ЗУП3.x Россия БУ Зарплата НДФЛ Бесплатно (free) Практика программирования Адаптация типовых решений

Ошибка при выполнении обработчика - 'ПриЗаписи' по причине: {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива ИмяПоля = УзелФормата.ДочерниеУзлы[3].ТекстовоеСодержимое;

01.02.2017    16997    sergey512    3       

Ошибка при загрузке курсов валют. Комплексная автоматизация 2.2 (ошибка в типовой) 2

Статья Программист Нет файла v8::ОУ КА2 Россия Бесплатно (free) Практика программирования Адаптация типовых решений

При вызове обработки "Загрузить курсы валют" в конфигурации "Комплексная автоматизация 2.2" рел. 2.2.2.157 программа выдавала ошибку

17.01.2017    14347    serg1c    7       

Проблемы web-клиента 1С: Предприятие. Исправляем ошибку в 1С: Договорчики 8 6

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Адаптация типовых решений

Описывается способ обхода ошибки, возникающей в web-клиенте при программном изменении видимости элементов формы в процессе записи и закрытия. Ошибка была выявлена в типовой конфигурации 1С: Договорчики 8, но, вполне вероятно, может встречаться и в иных ситуациях. Предложен способ обхода с использованием механизма расширений 1С: Предприятие 8.3, что позволяет не вносить изменения в типовую конфигурацию.

06.07.2016    15477    Sergey1CSpb    3       

Розница 8. Аптека, поиск номенклатуры по штрихкоду 0

Статья Программист Нет файла v8 Розница Фармацевтика, аптеки Windows Бесплатно (free) Практика программирования Адаптация типовых решений

В конфигурации Розница 8. Аптека, редакция 2.1 (2.1.9.12) возникает ситуация, когда при чтении штрихкода выводится вся номенклатура, у которой совпадает прочтенный штрихкод независимо от остатков на текущем складе рабочего места, что при недостаточном контроле со стороны кассира приводит к списанию номенклатуры с другого склада. Для избежания данной ситуации предлагается в запрос типовой конфигурации добавлять условия по складу и положительным остаткам с изменением типовой конфигурации.

30.06.2016    12527    its_33    3       

Ошибка в выгрузке из УТ 11 в БП 3.0, правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4) 1

Статья Системный администратор Программист Нет файла v8 КД БП3.0 УТ11 Бесплатно (free) Перенос данных из 1C8 в 1C8 Адаптация типовых решений

Переливка Заказа клиента из УТ (правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4)) происходит вместе со свойствами ГлавныйБухгалтер, Руководитель.

05.11.2015    23000    oleg21592    6       

Две кассы на одном рабочем месте 28

Инструменты и обработки Системный администратор Конфигурация (md, cf) v8 УТ10 Розница Windows Кассовые операции Розничная торговля Платные (руб) ККМ

Настройка для конфигураций Розница 1.0 и Управление торговлей 10.3, позволяющая использовать два кассовых аппарата на одном рабочем месте продавца.

2500 руб.

02.10.2015    31635    98    4       

Признание отложенного налогового обязательства по налогу на прибыль 11

Статья Программист Бухгалтер Нет файла v8 УПП1 Россия БУ НУ Налог на прибыль Бесплатно (free) Бухгалтерский учет Адаптация типовых решений

В статье рассмотрена ошибка, возникающая при исчислении отложенного налогового обязательства документом «Расчеты по налогу на прибыль»

21.04.2015    19074    el-le    4       

Отказ от модальности. Баг в типовых конфигурациях 18

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Адаптация типовых решений

Не буду расписывать про сам отказ от модальности. Думаю если Вы это читаете, то уже знаете о чем речь. Дело в том, что при рефакторинге некоторых обработок я столкнулся с багом, который, как мне кажется есть почти во всех типовых конфигурациях.

25.09.2014    14869    taurus_    19       

После обновления Бухгалтерии предприятия 3.0 возникает ошибка "Ошибка преобразования данных XDTO:" 5

Статья Системный администратор Программист Бухгалтер Нет файла v8 БП2.0 Windows Бесплатно (free) Адаптация типовых решений

После обновления Бухгалтерия предприятия 3.0 возникает ошибка: {ОбщийМодуль.СтандартныеПодсистемыКлиентПовтИсп.Модуль(56)}: Ошибка при вызове метода контекста (ПараметрыРаботыКлиентаПриЗапуске) ПараметрыКлиента = СтандартныеПодсистемыВызовСервера.ПараметрыРаботыКлиентаПриЗапуске(Параметры); по причине: Ошибка при вызове серверного метода. по причине: Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа. по причине: Ошибка преобразования данных XDTO: НачалоСвойства: {http://v8.1c.ru/8.2/managed-application/modules}cli Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/core}FixedStructure Способы решения проблемы.

16.07.2014    52894    bird21    9       

Контроль уникальности счетов фактур выданных в УТ 11.0.9.8 0

Статья Программист Нет файла v8 УТ10 БУ Windows Розничная торговля Бесплатно (free) Адаптация типовых решений

Работая с управленческим учетом часто приходится заниматься обменом данными с регламентированным учетом. Данная ошибка возникла по воле производителя типовой конфигурации УТ 11.0.9.8. А именно отсутствует контроль уникальности номеров документа "Счет-фактура выданный".

20.06.2014    15233    zekrus    4       

Ошибка в документе "Отражение зарплаты в управленческом учете" 3

Статья Программист Нет файла v8 УПП1 Россия Windows Зарплата Бесплатно (free) Бухгалтерский учет Адаптация типовых решений

Имеем: типовая Управление производственным предприятием, редакция 1.3 (1.3.31.1). При заполнении неверно заполнились данные по страховым взносам.

05.04.2013    8760    pss1985    0       

Очень долгое обновление типовой БП с релиза 2.0.41.х. Простой способ лечения. 152

Статья Программист Нет файла v8 БП2.0 Аудит и бухгалтерские услуги, юриспруденция Россия БУ Windows Бесплатно (free) Администрирование данных 1С Адаптация типовых решений

При обновлении типовой бухгалтерии с релиза 2.0.41.x до предпоследнего на сей день релиза 2.0.42.6 запускается обработка «ОбновлениеИнформационнойБазы» и происходит обработка документов...и в зависимости от разного рода причин, длиться она может достаточно долго (от минут - до часов)

19.12.2012    27474    Новиков    51