Автоматический расчет стажа для ЗУП 3.0 на основании таблицы Места работы

Публикация № 529459

Разработка - Практика программирования

18
Часто кадровики просят сделать доработку - рассчитывать данные о стаже на основании данных таблицы "Места работы" раздела Трудовая деятельность. Создание такой доработки описано в данной статье.
В результате в форме ввода стажа появится кнопка "Заполнить по данным Места работы", которая рассчитает стаж из таблицы мест работы автоматически на дату приема или на дату, которую введет пользователь.

Для реализации этой доработки нужно всего-навсего добавить несколько процедур в модуль общей формы, итак:

Общая форма "Ввод стажа сотрудников", модуль формы.

1 Изменяем процедуру:


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
..................
ДополнитьФорму();
//АВТО РАСЧЕТ СТАЖА + 
РазместитьДополнительныеЭлементыНаФорму();
//АВТО РАСЧЕТ СТАЖА -
ЗаполнитьДанныеОСтаже(Параметры.ДанныеСтажей);
..............................
КонецПроцедуры 

2 Добавляем процедуры

//АВТО РАСЧЕТ СТАЖА +
&НаСервере     
Процедура РазместитьДополнительныеЭлементыНаФорму()
	
	Кнопка = Элементы.Добавить("АвтоРасчетСтажа", Тип("КнопкаФормы"), Элементы.ФормаКоманднаяПанель);
	Кнопка.Вид = ВидКнопкиФормы.КнопкаКоманднойПанели;	
	Команда = Команды.Добавить("РассчитатьСтажПоДаннымПредМестРаботы");
	Команда.Действие = "РассчитатьСтажПоДаннымПредМестРаботы";
	Команда.Отображение = ОтображениеКнопки.Текст;
	Команда.Заголовок = "Заполнить по данным Места работы"; 
	Кнопка.ИмяКоманды = "РассчитатьСтажПоДаннымПредМестРаботы";	
	
	МассивДобавляемыхРеквизитов = Новый Массив;
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ТаблицаСведенийОСтаже", новый ОписаниеТипов("таблицаЗначений")));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ДатаНачала", новый ОписаниеТипов("Дата"),"ТаблицаСведенийОСтаже"));
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ДатаОкончания", новый ОписаниеТипов("Дата"),"ТаблицаСведенийОСтаже"));  	
	ИзменитьРеквизиты(МассивДобавляемыхРеквизитов); 
	
	УстановитьДействие("ПриОткрытии","ПриОткрытии");
	
КонецПроцедуры
&НаКлиенте
Процедура РассчитатьСтажПоДаннымПредМестРаботы(Команда)
	
	Если ЭтаФорма.ТаблицаСведенийОСтаже.Количество() = 0 Тогда
		Сообщить("Данные о трудовой деятельности не заполнены");
		Возврат;
	КонецЕсли;
	
	ЭтаФорма.СпособИсчисленияСтажа1  = 0;
	
	Если ЭтаФорма.ДатаОтсчета1 = Дата(1,1,1) Тогда
		Если ЭтаФорма.ДатаПриема1 = Дата(1,1,1) Тогда
			ЭтаФорма.ДатаОтсчета1 = ТекущаяДата();
		Иначе
			ЭтаФорма.ДатаОтсчета1 = ЭтаФорма.ДатаПриема1;
		КонецЕсли;
	КонецЕсли; 
	
	ИтогСтажДатаОтсчёта = ЭтаФорма.ДатаОтсчета1;
		
	РассчитатьСтажПоДаннымПредМестРаботыНаСервере(ИтогСтажДатаОтсчёта);    
	
	Модифицированность = Истина;
	
КонецПроцедуры

&НаСервере 
Процедура РассчитатьСтажПоДаннымПредМестРаботыНаСервере(ИтогСтажДатаОтсчёта) 
	
	//ТаблицаЗаписейОСтажеПоСотруднику = ТаблицаЗаписейРегистра("ТрудоваяДеятельностьФизическихЛиц", ЭтаФорма.ФизическоеЛицо);
	ТаблицаЗаписейОСтажеПоСотруднику = ЭтаФорма.ТаблицаСведенийОСтаже.Выгрузить();
	
	ИтогСтажЛет				=	0;
	ИтогСтажМесяцев			=	0;
	ИтогСтажДней			=	0;
	
	ПолучитьТаблицуИтоговСтажаПоСотруднику(ТаблицаЗаписейОСтажеПоСотруднику, ИтогСтажДатаОтсчёта, ИтогСтажЛет, ИтогСтажМесяцев, ИтогСтажДней);
		
КонецПроцедуры

Процедура ПолучитьТаблицуИтоговСтажаПоСотруднику(ЗаписиОСтаже, РасчётСтажДатаОтсчёта, РасчётЛет=0, РасчётМесяцев=0, РасчётДней =0);
    ДлинаСуток = 86400;
	
	ТаблицаЗаписейОСтаже = ЗаписиОСтаже.Скопировать();
    //РАСЧЕТ ОБЩЕГО ТРУДОВОГО СТАЖА С УЧЕТОМ ПЕРЕСЕЧЕНИЯ ПЕРИОДОВ

	//Выполним календарное поглащение:
	ВсегоЗаписей = ТаблицаЗаписейОСтаже.Количество(); 
	Для Н = 0 по ВсегоЗаписей - 1 Цикл
		Запись = ТаблицаЗаписейОСтаже[Н];

		Для К = 0 по ВсегоЗаписей - 1 Цикл
			Запись2 = ТаблицаЗаписейОСтаже[К];

			Если Запись = Запись2 Тогда//Запись не может поглатить саму себя
				Продолжить;
			КонецЕсли;	 
			
			Если (Запись2.ДатаНачала > Запись.ДатаОкончания) или
				(Запись2.ДатаОкончания < Запись.ДатаНачала)Тогда
				//Периоды не пересекаются
				Продолжить;
			Иначе	
				Если (Запись2.ДатаНачала >= Запись.ДатаНачала) Тогда
					Если (Запись2.ДатаОкончания <= Запись.ДатаОкончания) Тогда
						//Полное поглощение периода - удаляем запись2 с помощью задания отрицательного интервала
						Запись2.ДатаНачала = Дата('00010102');
						Запись2.ДатаОкончания = Дата('00010101');
					Иначе//Запись 2 начинается позднее и оканчивается позднее записи 1 - обрежем голову
						Запись2.ДатаНачала = Запись.ДатаОкончания + ДлинаСуток;
					КонецЕсли;	
				Иначе
					Если (Запись2.ДатаОкончания <= Запись.ДатаОкончания) Тогда
						//Запись2 начинается раньше и оканчивается раньше Записи1 - обрежем хвост
						Запись2.ДатаОкончания = Запись.ДатаНачала - ДлинаСуток;
					Иначе//Запись 2 начинается раньше и оканчивается позднее записи 1 - разбиение интервала на 2 части
						//породим вторую часть копирование исходной записи
						НоваяСтрока = ТаблицаЗаписейОСтаже.Добавить();
						ЗаполнитьЗначенияСвойств(НоваяСтрока, Запись2);
						//обрежем хвост у первой части
						Запись2.ДатаОкончания = Запись.ДатаНачала - ДлинаСуток;
						//обрежем голову у второй части
						НоваяСтрока.ДатаНачала = Запись.ДатаОкончания + ДлинаСуток;
					КонецЕсли;	
				КонецЕсли;	 
			КонецЕсли;	 
		КонецЦикла;	  
	КонецЦикла;	
	
	//если дата отсчета меньше даты окончания данных о стаже - скорректируем таблицу
	УдалитьПоследующиеЗаписи = Ложь;
	МассивКУдалению = Новый Массив;
	Для Каждого Запись из ТаблицаЗаписейОСтаже Цикл
		Если УдалитьПоследующиеЗаписи Тогда
			МассивКУдалению.Добавить(Запись);
		Иначе		
			Если Запись.ДатаНачала >= РасчётСтажДатаОтсчёта Тогда
				МассивКУдалению.Добавить(Запись);
				УдалитьПоследующиеЗаписи = Истина;
			ИначеЕсли Запись.ДатаОкончания >= РасчётСтажДатаОтсчёта Тогда
				Запись.ДатаОкончания = РасчётСтажДатаОтсчёта - 24*60*60;
				УдалитьПоследующиеЗаписи = Истина;
			КонецЕсли;    				
		КонецЕсли;
	КонецЦикла;	  	
	Для Каждого Элемент Из МассивКУдалению Цикл
		ТаблицаЗаписейОСтаже.Удалить(Элемент);
	КонецЦикла;   		
	
	//Расчет общего стажа по оставшимся записям
	ОбщийСтажДатаОтсчёта		=	Дата('00010101');
	ОбщийСтажЛет				=	0;
	ОбщийСтажМесяцев			=	0;
	ОбщийСтажДней				=	0;

	Для Каждого Запись из ТаблицаЗаписейОСтаже Цикл

		//Пропустим поглощенные и дополнительные записи
		Если  Запись.ДатаОкончания = Дата('00010101') Тогда
			Продолжить;
		КонецЕсли;	
		
		ЛетПоПериоду = 0;
		МесяцевПоПериоду = 0;
		ДнейПоПериоду = 0;
		ПерсонифицированныйУчет.ПолучитьСтажЗаПериод(Запись.ДатаОкончания,	Запись.ДатаНачала, ЛетПоПериоду,	МесяцевПоПериоду, ДнейПоПериоду);

		ОбщийСтажДатаОтсчёта	= Запись.ДатаОкончания; 
		ОбщийСтажЛет			=	ОбщийСтажЛет		+	ЛетПоПериоду;
		ОбщийСтажМесяцев		=	ОбщийСтажМесяцев	+	МесяцевПоПериоду;
		ОбщийСтажДней			=	ОбщийСтажДней		+	ДнейПоПериоду;
	КонецЦикла;	
	
	//Заносим в таблицу итогового стажа данные об общем стаже

	ПерсонифицированныйУчет.ПолучитьПриведенныйСтаж(ОбщийСтажЛет,ОбщийСтажМесяцев,ОбщийСтажДней);
	Если ОбщийСтажЛет + ОбщийСтажМесяцев + ОбщийСтажДней <> 0 Тогда
		
		//Получаем дату приёма
		ПараметрыПолученияСотрудников = КадровыйУчет.ПараметрыПолученияСотрудниковОрганизацийПоСпискуФизическихЛиц();
		ПараметрыПолученияСотрудников.СписокФизическихЛиц = ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(ЭтаФорма.ФизическоеЛицо);
		ПараметрыПолученияСотрудников.НачалоПериода = ТекущаяДатаСеанса();	
		ПараметрыПолученияСотрудников.ОкончаниеПериода = ТекущаяДатаСеанса();
		ПараметрыПолученияСотрудников.КадровыеДанные = "ДатаПриема";
		
		СотрудникиОрганизации = КадровыйУчет.СотрудникиОрганизации(Истина, ПараметрыПолученияСотрудников);
		
		ДатаПриема = Неопределено;
		Для Каждого ДанныеСотрудника Из СотрудникиОрганизации Цикл
			Если ЗначениеЗаполнено(ДанныеСотрудника.ДатаПриема) Тогда 
				Если ДатаПриема = Неопределено Тогда 
					ДатаПриема = ДанныеСотрудника.ДатаПриема;
				Иначе 
					ДатаПриема = Мин(ДатаПриема, ДанныеСотрудника.ДатаПриема);
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
		
		Если Не ЗначениеЗаполнено(ДатаПриема) Тогда 
			ДатаПриема = ТекущаяДатаСеанса();
		КонецЕсли; 		
		
		ЭтаФорма.Лет1				= ОбщийСтажЛет;
		ЭтаФорма.Месяцев1			= ОбщийСтажМесяцев;
		ЭтаФорма.Дней1				= ОбщийСтажДней;
	КонецЕсли;	 
КонецПроцедуры 


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	Если СтрНайти(ВладелецФормы.ИмяФормы,"ТрудоваяДеятельность") <> 0 Тогда
		Для Каждого СтрокаДанных Из ВладелецФормы.ТрудоваяДеятельностьФизическихЛиц Цикл
			Строка = ЭтаФорма.ТаблицаСведенийОСтаже.Добавить();
			Строка.ДатаНачала = СтрокаДанных.ДатаНачала;	
			Строка.ДатаОкончания = СтрокаДанных.ДатаОкончания;
		КонецЦикла;
	Иначе
		ЗаполнитьСведенияОТрудовойДеятельностиНаСервере();
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьСведенияОТрудовойДеятельностиНаСервере() 
	
	НаборЗаписей = РегистрыСведений["ТрудоваяДеятельностьФизическихЛиц"].СоздатьНаборЗаписей();
	НаборЗаписей.Отбор.ФизическоеЛицо.Значение = ЭтаФорма.ФизическоеЛицо;
	НаборЗаписей.Отбор.ФизическоеЛицо.Использование = Истина;
	
	НаборЗаписей.Прочитать();
	
	Для Каждого Запись Из НаборЗаписей Цикл
		Строка = ЭтаФорма.ТаблицаСведенийОСтаже.Добавить();
		Строка.ДатаНачала = Запись.ДатаНачала;	
		Строка.ДатаОкончания = Запись.ДатаОкончания; 		
	КонецЦикла;     
	
КонецПроцедуры
 //АВТО РАСЧЕТ СТАЖА -
 

3. PROFIT! Проверяем рекультат.

18

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. Michael0507 07.07.16 14:49 Сейчас в теме
3. pentanom 20 07.07.16 15:19 Сейчас в теме
4. Shefer 04.10.16 15:15 Сейчас в теме
mangy, спасибо, пригодилось. Единственное, кадровики попросили: для того, что бы у них сошлось с программкой, по которой они считают стаж, вычитать из получившегося стажа количество дней, равное количеству строк в таблице Места работы. И вручную проверяли - именно на это количество и разница.
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных 231

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    2618    John_d    14       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Специальная оценка условий труда по штатному расписанию в УПП 3

Статья Программист Нет файла v8 v8::СПР КА1 ЗУП2.5 УПП1 Россия БУ Бесплатно (free) Зарплата Практика программирования

В типовой конфигурации УПП специальная оценка условий труда (СОУТ) устанавливается для должности. В статье описаны доработки, необходимые для установки СОУТ на запись штатного расписания, т. е. по должности и подразделению (с периодичностью). Для нашей организации эти доработки оказались востребованы. Проверялось на версиях УПП 1.3.121.1 - 1.3.127.1, аналогичные доработки можно применить и к ЗУП 2.5.

27.12.2019    597    sailor-cat    5       

Налогообложение сотрудников, работающих по ГПХ (доработка 1С:Зарплата и управление персоналом КОРП, редакция 3.1) 4

Статья Программист Нет файла v8::СПР v8::Запросы ЗУП3.x Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Цель этой статьи - быстро доработать ЗУП для налогообложения сотрудников, работающих по ГПХ. Эта статья решает задачи, связанные с отсутствием в ЗУП функционала по обложению налогом работников ГПХ. На вопросы ниже вы найдете ответ в статье и решите эту задачу. Как настроить ЗУП 3, чтобы по договору ГПХ начислялись страховые взносы? У нас ситуация: есть договор ГПХ с одним человеком, который носит систематический характер и надо по нему начислять взносы, но ЗУП 3 не начисляет.

26.11.2019    1269    Lupeykin    7       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Простой пример кода для работы с переносом данных (ЗУП) 6

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Россия Бесплатно (free) Практика программирования

Задача: необходимо выделить сумму районного коэффициента для выставления проводок, приходящегося на "Премию к празднику".

13.11.2019    1299    aaguselnikova    2       

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1 10

Статья Программист Нет файла v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free) Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    2797    Neti    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

СКД. Отчеты с картинками 212

Статья Программист Нет файла v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Решение популярных кейсов с картинками в отчетах на СКД.

25.09.2019    8704    YPermitin    27       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Агрегатные функции СКД, о которых мало кто знает 391

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    20232    ids79    45       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Отчеты ЗУП. Решения всех отчетов из сборника задач для подготовки к Специалист-консультант ЗУП с картинками 48

Статья Бухгалтер Стажер Нет файла v8 v8::СПР ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Решение задач на 1С:Специалист

Когда готовился к сдаче экзамена на Специалист консультант по ЗУП, в процессе решения задач из сборника обнаружил, что те решения отчетов, которые есть в сети и на Инфостарте, недостаточно проиллюстрированы, и для новичка это может быть довольно тяжело и затратно по времени - разобраться, что к чему, с "нуля". Делал как шпаргалку для себя. Экзамен сдал на отлично. Рекомендую тем, кто готовится - прорешать все отчеты.

26.08.2019    5872    user1024932    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 291

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    25413    ids79    34       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Как проводятся документы в типовых конфигурациях от 1С 167

Статья Программист Нет файла v8::ОУ ERP2 УТ11 Россия УУ Windows Бесплатно (free) Математика и алгоритмы Практика программирования Разработка

В свое время, когда только начинал шаги в 1С и изучал, как проводятся документы в конфигурациях на платформе 1С по книге "Разработка управляемого интерфейса" (Хрусталева Е.Ю.), и там были представлены примеры совсем далекие от того, как сейчас проводятся документы в современных конфигурациях от 1С.

24.07.2019    19468    skv_79    35       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 160

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    16736    ids79    27       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

"Меньше копипаста!", или как Вася универсальную процедуру писал 185

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11326    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 226

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    28118    ids79    17       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 180

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    15550    dmurk    144       

Регистры накопления. Структура хранения в базе данных 180

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    24474    YPermitin    27       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    8722    m-rv    2       

Проблема с начислением за первую половину месяца 2

Статья Бухгалтер Нет файла v8 v8::СПР ЗУП3.x Россия БУ Зарплата Бесплатно (free) Бухгалтерский учет

Решение проблемы с доначислением зарплаты сотруднику за первую половину месяца, если уже есть документ начисления за первую половину этого месяца (пусть и не за всю).

23.04.2019    2764    Power_0N    0       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11615    m-rv    16       

О расширениях замолвите слово... 199

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    21103    ellavs    125       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 206

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    17200    ellavs    83       

Трюки с внешними источниками данных 169

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    18711    YPermitin    53       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Добавление отчетов в типовые конфигурации 1С 215

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    33031    ids79    45       

Неверный расчет СЗВ-СТАЖ. ЗУП 3.1 8

Статья Программист Нет файла v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

При заполнении отчета СЗВ-СТАЖ на последних релизах ЗУП (ошибка не исправлена и в релизе 3.1.9.107) выявлены ошибки при расчете периодов, а также неверное выделение стажа ДЛОТПУСК.

01.03.2019    4335    dbachinsky    2