Вывод Таблицы Значений или Дерева Значений на экран управляемой формы без объявления колонок в реквизитах формы

Публикация № 547849

Разработка - Практика программирования

Таблица значений Дерево значений Управляемые формы

Примеры взаимных преобразований Таблицы значения в Дерево значений или Табличный документ с использованием универсальных функций и макетов Системы компоновки данных. Примеры представлены в форме удобной для копирования в разработку.

Переход с обычного на управляемое приложение обязывает программиста изменить уже ставшие привычными приёмы написания программного кода.

В этой статье предложены шаблоны программного кода, которые позволяют выполнять различные операции с Таблицой Значений или Деревом Значений в управляемой форме.

В 1С:классификации Таблица Значений и Дерево Значений (ТЗ и ДЗ) представляют собой не сохраняемый в базе объект. В связи с этим, описание коллекций значений для программирования выполняется оперативно в момент обращения к ним.

Для сокращения трудозатрат программиста, в статье предложена универсальная процедура вывода ТаблицыЗначений или ДереваЗначений на экран. Эта процедура программно заполняет колонки реквизита управляемой формы, что весьма удобно при отладке.

На примерах показаны различия работы с КоллекциямиЗначений в толстом и тонком клиентах управляемой формы.

Из примеров следуют общие правила:

А) для толстого клиента ограничений нет. Примеры 1 и 4.

Б) для тонкого клиента – обработку коллекции необходимо выполнять на сервере, там же следует обеспечить вывод результата на экран.

Предложенная универсальная процедура СоздатьКолонкиУпр() программно добавляет колонки в реквизиты формы и преобразовывает коллекциюЗначений в ДанныеФормы.

Универсальную процедуру СоздатьКолонкиУпр() рекомендуется размещать в общем модуле конфигурации. Если это невозможно, то процедура успешно работает в модуле внешнего отчета.

В обычном приложение аналогом является процедура СоздатьКолонки(), которая удаляет старые колонки и загружает новые колонки из источника данных в табличное поле.

Примечание.

Существуют аналоги рассматриваемой теме:  Программный вывод таблицы значений на управляемую форму 8.2   ,     Создание произвольной таблицы значений на форме в управляемом приложении программным способом  ,  Управляемая форма 1С 8.2 (8.3) – работа с деревом значений и таблицей значений. Часть I (Основы)   ,  Пример преобразования дерева значений в таблицу значений и обратно в 1Cv8    Конструктор программиста – набор шаблонов программного кода для конструирования результата СКД и поддержки баз как типовых    и т.д.  Ссылки на другие сайты не приводятся согласно правилам публикации на Infostart. 

Разница между обычным и управляемым приложениями уже была изложена в аналогах.

Эта статья систематизирует методы работы с коллекциями значений и предлагает удобные для копирования варианты программного кода. Цель статьи – сократить трудозатраты программиста при выборе между толстым и тонким клиентами для использования таблицы (ТЗ) или дерева значений (ДЗ) в качестве источника данных для СистемыКомпоновкиДанных (СКД).

Блок-схема подготовки источника внешних данных для СКД на основании не сохраняемых в базе объектов приведена на прилагаемом рисунке.

Третья группа примеров на Видео демонстрирует реализацию всех веток блок – схемы.

Текст озвучки видео.

Сейчас будут показаны варианты программирования работы с таблицей и деревом значений в тонком и толстом клиентах управляемого приложения.

Откроем 1С:Предприятие в Тонком и Толстом клиентах.

Во всех примерах состав колонок Таблицы Значений или Дерева Значений произвольный, то есть заранее не известен. Программное заполнение реквизитов управляемой формы будет выполнено функцией СоздатьКолонкиУпр().

1)  В толстом клиенте никаких ограничений нет. Пример №1 выводит на экран новую таблицу. Пример №4 редактирует существующую таблицу. Все операции можно выполнять на клиенте.

Толстый клиент закрываем.

Остальные примеры рассмотрим в тонком клиенте.

2)  В тонком клиенте (пример №2) дерево создается на сервере. Пример №5 редактирует существующее дерево на сервере.

  1. Пример №6 преобразовывает ДеревоЗначений в таблицу. Это действие востребовано при передаче внешних данных в СКД.

3)  Если программист вынужден передать в обработку КоллекциюЗначений через клиента, то это можно выполнить с помощью временного хранилища. Смотрим пример №3.

  1. Пример №7 показывает как таблицу преобразовать в дерево, используя макет ОсновнаяСхемаКомпоновкиДанных.

4)  Заполним ТаблицуЗначений заново и в примере №8 преобразуем её в табличный документ. Теперь можно напечатать результат.

5)  Далее отключим конфигуратор и демонстрируем, что ручной ввод с экрана новых строк не нарушает алгоритмов преобразования. (Примечание. Работа с добавлением колонок была показано ранее.)

  1. Создаём таблицу значений (Пример.3)
    1.  и добавляем строку вручную.
  2. Преобразовываем таблицу в дерево (Пример.7)
    1.  и добавляем строки в последний уровень и первый,  
  3. Преобразовываем скорректированное дерево в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных. (Пример.9).
    1.  Меняем значение первой колонки
  4. Повторяем преобразование в ТабДок. (Пример.9) и наглядно видим, что ТабличныйДокумент ожидаемый.
  5. Преобразовываем скорректированное дерево в таблицу. (Пример.6)
  6. Скорректированную таблицу преобразовываем в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных.(Пример.8)
  7. На этом заканчиваем демонстрацию приемов программирования КоллекцийЗначений в управляемом приложении.

6)  Третья группа примеров посвящена применению Системы Компоновки Данных (СКД). Здесь будет продемонстрировано практическое использование ранее изложенных приемов для ввода данных в СКД.

  1. Примеры третьей группы полезны программисту в случаях, когда возникает необходимость применить методы обработки данных не доступные в СКД.
  2. Пример 10.1. Получаем табличный документ типовой работой СКД со справочником на основании макетаДЗ.Обращаем внимание, что макетДЗ не имеет настроек на ввод данных из внешнего набора, т.е макетДЗ можно построить конструктором.
  3. Пример 10.2. Получаем тоже самое в форме ДереваЗначений. Добавляем строку и меняем ей родителя на «Блузу».
  4.  Пример 10.3. Возвращает изменённое ДеревоЗначений в формат ТабличногоДокумента по структуре, заданной в макетеДЗ. Такое преобразование востребовано, например, для печати результата типовыми методами.
  5. Видим, что в сложных для программиста случаях, данные табличного документа можно скорректировать либо вручную, либо программно, используя промежуточное дерево значений.
  6. Предварительно преобразуем ДЗ в ТЗ. (Пример.6)
  7. Пример 10.4. Повторяет то же самое для ТаблицыЗначений.   
  8. Техническое решение примеров 10.3 и 10.4 обеспечивает функция ВернутьТабДокСервер(), которая:
    1. В пустой макет «СКДТонкийКлиент» программно устанавливает НаборДанныхОбъект, который заполняем внешними данными из отредактированной ТЗ.
    2. Настройки копируем из макетаДЗ.
    3. Результатом будет требуемый ТабличныйДокумент, учитывающий внесенные изменения в таблицу значений ТЗ.  

7)  Заключение. Демонстрация показала:

  1.  Процедура  СоздатьКолонкиУпр() выполняет такие же функции как процедура. СоздатьКолонки() обычного приложения.
  2. Если исходная коллекция и результат её преобразования размещены в одной управляемой форме, то необходимо очищать колонки источника во избежание дублирования наименований в приёмнике. (Процедура ОчиститьКоллекциюЗначенийНаСервере()).
  3. В тонком клиенте модули управления коллекцией значений обязательно следует размещать на сервере.
  4. Для преобразования коллекции значений в табличной документ с независимым макетомСКД можно применить функцию Скд_ВнешниеДанные().
  5. Независимый макетСКД можно создать на основании другого макета, например, макетДЗ. Для решения этой задачи можно применить функцию ВернутьТабДокСервер(). 
  6. Примечание. Программный код представлен способом, повышающим удобство копирования в разработку. Размеры базовых блоков программного кода, назначенных к копированию в разработку, не превышают четырёх строк.

Желаю успехов всем и каждому.

////////////////////////////////////////////////////////

Описание Процедуры     СоздатьКолонкиУпр()

Синтаксис:

СоздатьКолонкиУпр(<ФормаЭта>, <ИмяРеквизита>, <КоллекцияЗначений>)

Параметры:

<ФормаЭта> (обязательный)

Тип:УправляемаяФорма. Форма, в реквизите которой требуется программно определить состав колонок.

<ИмяРеквизита> (обязательный)

Тип:Строка. Имя реквизита как указано в управляемой форме.  Этому реквизиту следует определить состав колонок. Тип реквизита должен быть либо ТаблицаЗначений, либо ДеревоЗначений.

<КоллекцияЗначений> (обязательный)

Тип:ТаблицаЗначений, ДеревоЗначений, АдресВременногоХранилища. Источник данных, который следует вывести на экран. Тип источника данных должен быть либо ТаблицаЗначений, либо ДеревоЗначений. Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым.

Описание:

Для любого прикладного объекта типа таблицаЗначений или деревоЗначений, программно создаётся состав колонок реквизита управляемой формы. Затем прикладной объект преобразовывается в данные формы и выводится на экран.

Процедура применяется в случаях, когда состав колонок коллекцииЗначений заранее не определён.

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции ВернутьТабДокСервер()

Синтаксис:

ВернутьТабДокСервер (<ТЗисточник >, < АдресМакетаСКД >, < НастройкиСКД_1>)

Параметры:

< ТЗисточник > (обязательный)

Тип:ТаблицаЗначений. Источник данных для формирования результата СКД.

< АдресМакетаСКД > (обязательный)

Тип:Строка. Адрес временного хранилища, в которое помещен макет схемы компоновки данных (Тип:СхемаКомпоновкиДанных).   

< НастройкиСКД _1> (обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает ТабличныйДокумент с данными из ТаблицыЗначений (ТЗисточник) преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции скд_ВнешниеДанные ()

Синтаксис:

Скд_ВнешниеДанные (<ТЗ_внешниеДанные>, <ТипРезультата="ТабДок">, <АдресМакетаСКД="">, <НастройкиСКД=Неопределено>)

Параметры:

< ТЗ_внешниеДанные > (обязательный)

Тип:ТаблицаЗначений. ДанныеФормыКоллекция. Источник данных для формирования результата СКД.

< ТипРезультата > (не обязательный)

Тип:Строка. Допустимые значения: «ТабДок», «ТабличныйДокумент», «ДЗ», «ДеревоЗначений», «ТЗ», «ТаблицаЗначений».

< АдресМакетаСКД > (не обязательный)

 (Тип:Строка).   

< НастройкиСКД > (не обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает результат СКД заданного типа с данными из ТаблицыЗначений преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта,ИмяРеквизита, ДеревоТаблицаЗначенийАдрес) Экспорт 
	
	#Если ТолстыйКлиент Тогда
		цЭто="ЭтоТолстыйКлиент";//Отладка
	#ИначеЕсли ТонкийКлиент Тогда
		цЭто="ЭтоТонкийКлиент";//Отладка
	#ИначеЕсли Клиент Тогда
		цЭто="ЭтоКлиент";//Отладка|ОбычноеПриложение
	#ИначеЕсли Сервер Тогда
		цЭто="ЭтоСервер";//Отладка
	#Иначе
		цЭто="ЭтоНеКлиентНеСервер";//Отладка
	#КонецЕсли
	
	
	Вариант=3;
	Если Вариант=2 Тогда
		////Вариант=2;
		
	ИначеЕсли Вариант=3 тогда
		Если ЭтоАдресВременногоХранилища(ДеревоТаблицаЗначенийАдрес) Тогда
			цДеревоТаблицаЗначений = ПолучитьИзВременногоХранилища(ДеревоТаблицаЗначенийАдрес);
		Иначе 	
			цДеревоТаблицаЗначений = ДеревоТаблицаЗначенийАдрес ;
		КонецЕсли;
		//ФормаЭта = РеквизитФормыВЗначение(,Тип("УправляемаяФорма"));		
		
		фрмЭлементы =  ФормаЭта.Элементы;
		цРодитель =  ФормаЭта.Элементы[имяРеквизита];
		цТипЭлемента = Тип("ПолеФормы");
		
		
		мсУдаляемыеКолонкиРеквизита= Новый Массив;
		цРодПодч = цРодитель.ПодчиненныеЭлементы ;
		Для каждого кол Из цРодПодч Цикл
			кол_имя = кол.Имя;
			СтараяКолонкаРеквизита =  кол.ПутьКДанным;
			мсУдаляемыеКолонкиРеквизита.Добавить(СтараяКолонкаРеквизита);
		КонецЦикла;
		
		мсДобавляемыеКолонкиРеквизита = Новый Массив;
		для Каждого кол Из цДеревоТаблицаЗначений.Колонки Цикл
			кол_имя = кол.Имя;
			//ОписаниеТиповДляРеквизита = Новый ОписаниеТипов(ТипыРеквизита);
			ОписаниеТиповДляРеквизита = кол.ТипЗначения;
			
			Если ОписаниеТиповДляРеквизита.СодержитТип(Тип("ХранилищеЗначения")) Тогда
				Продолжить;
			КонецЕсли;				
			
			НоваяКолонка = Новый РеквизитФормы(кол_имя,       // имя
			ОписаниеТиповДляРеквизита,   // тип
			имяРеквизита,              // путь
			кол.Заголовок,             // заголовок
			Ложь);                     // сохраняемые данные
			
			мсДобавляемыеКолонкиРеквизита.Добавить(НоваяКолонка);
		КонецЦикла;	
		//
		
		
		#Если НаСервере Тогда           
			ФормаЭта.ИзменитьРеквизиты(мсДобавляемыеКолонкиРеквизита,мсУдаляемыеКолонкиРеквизита);            
		#Иначе            
			ц="ЭтоБлин";	
		#КонецЕсли		
		
		Для каждого новКолонка Из мсДобавляемыеКолонкиРеквизита Цикл
			этаКолонкаЕсть = ФормаЭта.Элементы.Найти(новКолонка.Имя);
			Если этаКолонкаЕсть<>Неопределено Тогда
				//Продолжить;
				ФормаЭта.Элементы.Удалить(этаКолонкаЕсть);
			КонецЕсли;
			
			Попытка
				кол_имя =новКолонка.Имя;
				новЭлем = ФормаЭта.Элементы.Добавить(кол_имя, цТипЭлемента, цРодитель); 
				новЭлем.Вид = ВидПоляФормы.ПолеВвода;
				новЭлем.ПутьКДанным = имяРеквизита+"."+кол_имя;
			Исключение
				//Если ФлагЭтоЯ Тогда
				цОш = ОписаниеОшибки();
				сооб = Новый СообщениеПользователю;
				сооб.Текст = кол_имя+" : "+цОш;
				сооб.Поле = кол_имя;
				сооб.Сообщить();
				//Продолжить;
				//КонецЕсли;  
			КонецПопытки;	
			
		КонецЦикла;    
		
		#Если не ТонкийКлиент Тогда           
			ЗначениеВДанныеФормы(цДеревоТаблицаЗначений,ФормаЭта[ИмяРеквизита]);
		#КонецЕсли
		
	КонецЕсли; 
	
	
КонецПроцедуры
R03;
Функция ВернутьТабДокСервер(цРезультатСКД1, цАдресМакетаСКД1, цНастройкиИсточник1) Экспорт 
	Перем  ТабДок2;
	
	цСхемаКомпоновкиДанныхИсточник1 = ПолучитьИзВременногоХранилища(цАдресМакетаСКД1);
	цНаборыДанныхИсточник1 = цСхемаКомпоновкиДанныхИсточник1.НаборыДанных ;
	
	цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьОбщийМакет("СКДтонкийКлиент");
	//цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьМакет("СКДтонкийКлиент"); //внешнйОтчет
	
	цНаборыДанныхИсточникТабДок2 = цСхемаКомпоновкиДанныхИсточникТабДок2.НаборыДанных ;
	цНаборыДанныхИсточникТабДок2.Очистить();
	цНаборДанныхТабДок2 = цНаборыДанныхИсточникТабДок2.Добавить(Тип("НаборДанныхОбъектСхемыКомпоновкиДанных"));
	цТемпИмяТЗ_2 = "тзИмяТемп";
	цНаборДанныхТабДок2.имя = цТемпИмяТЗ_2;
	цИмяОбъекта_2 = "тзОбъектТемп";
	//цИмяОбъекта_2 = "тзИсточник";
	цНаборДанныхТабДок2.имяОбъекта = цИмяОбъекта_2;
	цНаборДанныхТабДок2.ИсточникДанных = "ИсточникДанных1";
	
	Для каждого текНаборИсточник1 Из цНаборыДанныхИсточник1 Цикл
		
		Для каждого поле_1 Из текНаборИсточник1.Поля  Цикл
			Попытка
				Если  ТипЗнч(поле_1)= тип("ПолеНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,"ТипЗначения");
					
					цтип =  новый ОписаниеТипов(  поле_1.ТипЗначения) ;
					поле_2.ТипЗначения = цтип;
				ИначеЕсли   ТипЗнч(поле_1)= тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,);
					УбратьИзПутьКДаннымИмяПапки(цРезультатСКД1, поле_1.ПутьКДанным );//ППМ						
				Иначе 
					Сообщение = Новый СообщениеПользователю;
					Сообщение.Текст = "Отказ, поле_1="+поле_1;
					//Сообщение.Поле = "";
					//Сообщение.УстановитьДанные(ЭтотОбъект);
					Сообщение.Сообщить();						
				КонецЕсли;
			Исключение
				цОш= ОписаниеОшибки();
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = цОш+", поле_1="+поле_1;
				//Сообщение.Поле = "";
				//Сообщение.УстановитьДанные(ЭтотОбъект);
				Сообщение.Сообщить();	
			КонецПопытки;
			
		КонецЦикла			                   
	КонецЦикла;
	
	Для каждого текПолеИтога1 Из цСхемаКомпоновкиДанныхИсточник1.ПоляИтога  Цикл
		Попытка
			полеИтога_2 = цСхемаКомпоновкиДанныхИсточникТабДок2.ПоляИтога.Добавить();
			ЗаполнитьЗначенияСвойств(полеИтога_2, текПолеИтога1 );
			
		Исключение
			цОш= ОписаниеОшибки();
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = цОш+", полеИтога_1="+текПолеИтога1;
			//Сообщение.Поле = "";
			//Сообщение.УстановитьДанные(ЭтотОбъект);
			Сообщение.Сообщить();	
		КонецПопытки;
		
	КонецЦикла;
	
	ТабДок2 = скд_ВнешниеДанные(цРезультатСКД1,"ТабДок" , цСхемаКомпоновкиДанныхИсточникТабДок2, цНастройкиИсточник1);
	
	Возврат  ТабДок2;
КонецФункции




R03;

/////////////////////////////////////////////////////////

R03;
Функция  скд_ВнешниеДанные(цТЗ_внешниеДанные, цТипРезультата="ТабДок", цАдресМакетаСКД="", цНастройкиСКД=Неопределено)Экспорт  //Преобразовать коллекциюЗначений в табличный документ
	Перем ВнешниеДанныеСКД;	
	
	Если ВРег(цТипРезультата)="ТАБДОК"  
		ИЛИ ВРег(цТипРезультата)="ТАБЛИЧНЫЙДОКУМЕНТ" 
		Тогда
		цОбъектСКД=Новый ТабличныйДокумент;
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанных");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.УстановитьДокумент(цОбъектСКД);
	Иначе
		Если ВРег(цТипРезультата)="ДЗ"
			ИЛИ  ВРег(цТипРезультата)="ДЕРЕВОЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ДеревоЗначений;
		ИначеЕсли ВРег(цТипРезультата)="ТЗ" 
			ИЛИ  ВРег(цТипРезультата)="ТАБЛИЦАЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ТаблицаЗначений;
		Иначе 
			цОбъектСКД=Новый ДеревоЗначений;
		КонецЕсли;
		
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
		ПроцессорВывода.УстановитьОбъект(цОбъектСКД);
	КонецЕсли;
	
	Если ТипЗнч(цТЗ_внешниеДанные)=Тип("ТаблицаЗначений") Тогда
		ТЗ = цТЗ_внешниеДанные;
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	ИначеЕсли ТипЗнч(цТЗ_внешниеДанные)=Тип("ДанныеФормыКоллекция") Тогда
		ТЗ = ДанныеФормыВЗначение(цТЗ_внешниеДанные,Тип("ТаблицаЗначений"));
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	Иначе
		// это ТабличныйДокумент
	КонецЕсли;
	
	Если ЭтоАдресВременногоХранилища(цАдресМакетаСКД) Тогда
		СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(цАдресМакетаСКД) ;
	ИначеЕсли ТипЗнч(цАдресМакетаСКД)= Тип("СхемаКомпоновкиДанных") Тогда
		СхемаКомпоновкиДанных = цАдресМакетаСКД ;
		
	Иначе
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "нет макета СКД";
		//Сообщение.Поле = "";
		//Сообщение.УстановитьДанные(ЭтотОбъект);
		Сообщение.Сообщить();
		Возврат цОбъектСКД;
	КонецЕсли;
	
	
	Если цНастройкиСКД=Неопределено Тогда
		Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;		
	Иначе
		Настройки = цНастройкиСКД;
	КонецЕсли;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, , ,типГенератораСКД, ,);
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеДанныеСКД  );
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);   	
	
	Возврат цОбъектСКД;
КонецФункции




R03;

Состав zip.

1.       База данных c примерами для копирования - dt и cf.

2.       Внешняя обработка.

Скачать файлы

Наименование Файл Версия Размер
ПримерыВыводаКоллекцииЗначенийНаЭкранУпрФормы

.7z 159,93Kb
51
.7z 159,93Kb 51 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. json 14.09.16 02:55 Сейчас в теме
Очень хорошо, что ваши процедуры универсальны (это редкость на ИС)

НО есть несколько моментов, которые [лично мне] могут помешать применить ваши процедуры
1. Самодокументируемое название методов - из названия методов должно быть однозначно понятно, что данный метод делает (например, СоздатьКолонкиТаблицыНаУправляемойФорме() ). Без необходимости изучения кода самого метода. Иначе возникают сложности с читаемостью и пониманием при а) вызове метода, б) при понимании кода, из которого вызывается данный метод.
2. Неиспользуемые переменные (например, цЭто и Вариант), а также невыполняемые ветки в операторах Если
3. Большое количество закомментированного кода - лучше удалить, чтобы он не сбивал с толку тех, кто будет использовать ваши методы. Если в коде много подобных закомментированных участков - у других разработчиков возникает опасение, что он еще пока на стадии отладки и работа над ним не закончена. А незаконченные чужие процедуры никто использовать не будет.
4. Большое количество цифр в именах переменных - является моветоном (например, цСхемаКомпоновкиДанныхИсточникТабДок2), вызывает недоверие.

Высказал только самые критичные на мой взгляд недочеты.

Несмотря на мою критику, хочу отметить, что заметна большая проделанная работа (и по написанию процедур, и по подготовке статьи)
Плюс однозначно.
Патриот; kuzyara; awk; vasiliy_b; dj_serega; mihey; aexeel; Irwin; +8 Ответить
2. fancy 12 15.09.16 07:07 Сейчас в теме
Спасибо за статью, вчера как раз воспользовался, правда пришлось побиться с добавлением колонок реквизита формы ДеревоЗначений - смог добавить лишь только тогда, когда само дерево добавляю в реквизиты формы программно, если же дерево создать в конфигураторе, то колонки никак не хотели добавляться
3. json 15.09.16 08:49 Сейчас в теме
(2) fancy, да, я тоже сталкивался с этим. Проблема в том, что если колонка добавлена из конфигуратора, то ни колонку реквизита, ни колонку табличного поля на форме удалить программно нельзя. И это все осложняется тем, что в коде нельзя определить, добавлялась колонка программно или через конфигуратор. Единственный костыль, который я тут нашел - использование попытки. Колонки из реквизита на таблицы нужно удалять по одной в попытке (а не сразу всем массивом), и перед добавлением проверять наличие. При обновлении колонок табличного поля - тоже нужно удалять колонки в попытке и перед добавлением - проверять наличие.
5. pavley2002 192 17.09.16 15:37 Сейчас в теме
(3) yurii_host,
Доступ к элементу формы осуществляется по имени, поэтому дублирование имён внутри элементов сделает управляемую форму не работоспособной. В этой статье защита от дублирования имён выполнена упрощённо через очистку всех элементов перед любым значимым действием. Для этой цели используется процедура ОчиститьКоллекциюЗначенийНаСервере(). При таком алгоритме не возникает необходимость проверять наличие дублирования имен по штучно.
Однако, сама проблема дублирования имён при программном заполнении колонок следующей коллекции значений существует и требует методологической постановки задачи с последующем решением.
Алгоритм близкий к по элементной проверке предложен в http://infostart.ru/public/536800/ . Без функции ПроверитьДублиИменКолонок() в указанной статье невозможно решить поставленную там задачу.
6. json 17.09.16 17:38 Сейчас в теме
(5) не понимаю, зачем проверять дубли. Сначала удаляем все колонки, которые можем удалить. Затем добавляем колонки в цикле. Перед добавлением проверяем, присутствует ли колонка с таким именем в коллекции колонок. Если присутствует, то переходим к следующей итерации цикла.

Прикладываю работающий пример. Данный набор процедур использую уже года два. Проверено в продуктиве много раз
Попытка используется два раза, что некрасиво. Но других решений пока не нашел.

Отмечу, что в приведенном примере колонка Склад - добавлена через конфигуратор, а остальные колонки - добавляются программно.

Подход универсальный и не требует какой-то специальной методологической постановки задачи

Вот тут в моей публикации рассматривается другой вопрос, но создание колонок выполняется программно, хотя на этом не заостряется внимание. В примере к публикации для управляемых форм используются этот же блок процедур
Прикрепленные файлы:
ВнешняяОбработка1.epf
4. pavley2002 192 15.09.16 18:31 Сейчас в теме
(2) fancy, Процедуру СоздатьКолонкиУпр() можно применять только для программно добавленных колонок. Это обусловлено применением метода ВсеЭлементыФормы.Удалить(), в 1С:описании которого непосредственно указано:- «Доступно удаление только ранее программно добавленного элемента».
Для устранения возникшей не ясности, в описание процедуры СоздатьКолонкиУпр() добавлена строка - «Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым». Спасибо за указание на неточность.
7. kuzyara 1152 19.09.16 09:03 Сейчас в теме
&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта
...

Клинический случай. Дальше читать не стал.
8. pavley2002 192 26.09.16 08:47 Сейчас в теме
(7) kuzyara,
Отсутствует конструктивное предложение, хотя бы какое-нибудь. На мой взгляд, накопленный личный медицинский опыт здесь не уместен.
paybaseme; kuzyara; +2 Ответить
11. vpaoli 29 16.04.20 09:57 Сейчас в теме
(8) я тоже думаю так. Ведь форму на сервер передать нельзя . НЕ правильно размещать процедуры в отрыве от контекста их использования.
9. almas 201 30.10.16 13:12 Сейчас в теме
Скачал, посмотрел. Несмотря на значимость обработки ощущение отвратное. Черт нельзя было малость в удобоваримый читаемый порядок все привести???
10. pavley2002 192 01.11.16 09:25 Сейчас в теме
(9) almas,
Не обработка, а универсальная функция представлена в форме, не требующей скачивания файла, я предполагаю, что это заметно. Кроме того, Вам позволено не принуждать себя скачивать файл, который оказывает дурное влияние на настроение, бесполезен или любое другое.

paybaseme; +1 Ответить
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    5966    21    huxuxuya    11    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    11861    69    sapervodichka    43    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    32409    27    Stepa86    46    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    25258    7    m-rv    91    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    51581    169    ekaruk    32    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    28519    22    stvorl    0    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    25535    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    48423    66    dsdred    17    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    34253    92    m-rv    58    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    33303    29    informa1555    30    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    60421    24    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    37234    11    SITR-utyos    13    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    32293    20    mvxyz    17    

Универсальная функция - Сформировать результат СКД

Универсальные функции v8::СКД 1cv8.cf Россия Абонемент ($m)

Предлагаемая функция СформироватьРезультатСКД позволяет программисту комфортно применять систему компоновки данных для обработки информации текущей или внешней базы. Функцию целесообразно размещать в общем модуле или в расширении конфигурации на управляемых формах.

1 стартмани

19.05.2018    9524    9    pavley2002    1    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    30785    56    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    60678    17    swimdog    47    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    32030    72    vasvl123    9    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    39115    143    PLAstic    68    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    26196    21    sasha777666    64    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    154734    13    signum2009    48    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    57637    35    ildarovich    41    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    36316    120    romasna    52    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    35333    141    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    27030    118    Alxby    23    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    40262    98    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    31271    147    Stepa86    15    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    52464    36    Demanoidos    60    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    31993    95    ZhokhovM    65    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    64181    11    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    70115    207    rozer    67    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    70860    20    arakelyan    24    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    38640    52    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    90817    170    igo1    58    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    21297    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    56004    56    yuraos    18    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    64456    209    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    26423    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    52886    180    TuneSoft    30    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    44049    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    62660    54    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    106888    496    Luchik    216    

Автоматическая подстановка уничтожений временных таблиц в текст запроса

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция, которая сама подставляет в текст запроса "УНИЧТОЖИТЬ" в местах последнего использования ВТ.

1 стартмани

14.11.2015    21813    0    SeiOkami    3