Вывод Таблицы Значений или Дерева Значений на экран управляемой формы без объявления колонок в реквизитах формы

Публикация № 547849

Разработка - Практика программирования

Таблица значений Дерево значений Управляемые формы

Примеры взаимных преобразований Таблицы значения в Дерево значений или Табличный документ с использованием универсальных функций и макетов Системы компоновки данных. Примеры представлены в форме удобной для копирования в разработку.

Переход с обычного на управляемое приложение обязывает программиста изменить уже ставшие привычными приёмы написания программного кода.

В этой статье предложены шаблоны программного кода, которые позволяют выполнять различные операции с Таблицой Значений или Деревом Значений в управляемой форме.

В 1С:классификации Таблица Значений и Дерево Значений (ТЗ и ДЗ) представляют собой не сохраняемый в базе объект. В связи с этим, описание коллекций значений для программирования выполняется оперативно в момент обращения к ним.

Для сокращения трудозатрат программиста, в статье предложена универсальная процедура вывода ТаблицыЗначений или ДереваЗначений на экран. Эта процедура программно заполняет колонки реквизита управляемой формы, что весьма удобно при отладке.

На примерах показаны различия работы с КоллекциямиЗначений в толстом и тонком клиентах управляемой формы.

Из примеров следуют общие правила:

А) для толстого клиента ограничений нет. Примеры 1 и 4.

Б) для тонкого клиента – обработку коллекции необходимо выполнять на сервере, там же следует обеспечить вывод результата на экран.

Предложенная универсальная процедура СоздатьКолонкиУпр() программно добавляет колонки в реквизиты формы и преобразовывает коллекциюЗначений в ДанныеФормы.

Универсальную процедуру СоздатьКолонкиУпр() рекомендуется размещать в общем модуле конфигурации. Если это невозможно, то процедура успешно работает в модуле внешнего отчета.

В обычном приложение аналогом является процедура СоздатьКолонки(), которая удаляет старые колонки и загружает новые колонки из источника данных в табличное поле.

Примечание.

Существуют аналоги рассматриваемой теме:  Программный вывод таблицы значений на управляемую форму 8.2   ,     Создание произвольной таблицы значений на форме в управляемом приложении программным способом  ,  Управляемая форма 1С 8.2 (8.3) – работа с деревом значений и таблицей значений. Часть I (Основы)   ,  Пример преобразования дерева значений в таблицу значений и обратно в 1Cv8    Конструктор программиста – набор шаблонов программного кода для конструирования результата СКД и поддержки баз как типовых    и т.д.  Ссылки на другие сайты не приводятся согласно правилам публикации на Infostart. 

Разница между обычным и управляемым приложениями уже была изложена в аналогах.

Эта статья систематизирует методы работы с коллекциями значений и предлагает удобные для копирования варианты программного кода. Цель статьи – сократить трудозатраты программиста при выборе между толстым и тонким клиентами для использования таблицы (ТЗ) или дерева значений (ДЗ) в качестве источника данных для СистемыКомпоновкиДанных (СКД).

Блок-схема подготовки источника внешних данных для СКД на основании не сохраняемых в базе объектов приведена на прилагаемом рисунке.

Третья группа примеров на Видео демонстрирует реализацию всех веток блок – схемы.

Текст озвучки видео.

Сейчас будут показаны варианты программирования работы с таблицей и деревом значений в тонком и толстом клиентах управляемого приложения.

Откроем 1С:Предприятие в Тонком и Толстом клиентах.

Во всех примерах состав колонок Таблицы Значений или Дерева Значений произвольный, то есть заранее не известен. Программное заполнение реквизитов управляемой формы будет выполнено функцией СоздатьКолонкиУпр().

1)  В толстом клиенте никаких ограничений нет. Пример №1 выводит на экран новую таблицу. Пример №4 редактирует существующую таблицу. Все операции можно выполнять на клиенте.

Толстый клиент закрываем.

Остальные примеры рассмотрим в тонком клиенте.

2)  В тонком клиенте (пример №2) дерево создается на сервере. Пример №5 редактирует существующее дерево на сервере.

  1. Пример №6 преобразовывает ДеревоЗначений в таблицу. Это действие востребовано при передаче внешних данных в СКД.

3)  Если программист вынужден передать в обработку КоллекциюЗначений через клиента, то это можно выполнить с помощью временного хранилища. Смотрим пример №3.

  1. Пример №7 показывает как таблицу преобразовать в дерево, используя макет ОсновнаяСхемаКомпоновкиДанных.

4)  Заполним ТаблицуЗначений заново и в примере №8 преобразуем её в табличный документ. Теперь можно напечатать результат.

5)  Далее отключим конфигуратор и демонстрируем, что ручной ввод с экрана новых строк не нарушает алгоритмов преобразования. (Примечание. Работа с добавлением колонок была показано ранее.)

  1. Создаём таблицу значений (Пример.3)
    1.  и добавляем строку вручную.
  2. Преобразовываем таблицу в дерево (Пример.7)
    1.  и добавляем строки в последний уровень и первый,  
  3. Преобразовываем скорректированное дерево в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных. (Пример.9).
    1.  Меняем значение первой колонки
  4. Повторяем преобразование в ТабДок. (Пример.9) и наглядно видим, что ТабличныйДокумент ожидаемый.
  5. Преобразовываем скорректированное дерево в таблицу. (Пример.6)
  6. Скорректированную таблицу преобразовываем в табличный документ по макету ОсновнаяСхемаКомпоновкиДанных.(Пример.8)
  7. На этом заканчиваем демонстрацию приемов программирования КоллекцийЗначений в управляемом приложении.

6)  Третья группа примеров посвящена применению Системы Компоновки Данных (СКД). Здесь будет продемонстрировано практическое использование ранее изложенных приемов для ввода данных в СКД.

  1. Примеры третьей группы полезны программисту в случаях, когда возникает необходимость применить методы обработки данных не доступные в СКД.
  2. Пример 10.1. Получаем табличный документ типовой работой СКД со справочником на основании макетаДЗ.Обращаем внимание, что макетДЗ не имеет настроек на ввод данных из внешнего набора, т.е макетДЗ можно построить конструктором.
  3. Пример 10.2. Получаем тоже самое в форме ДереваЗначений. Добавляем строку и меняем ей родителя на «Блузу».
  4.  Пример 10.3. Возвращает изменённое ДеревоЗначений в формат ТабличногоДокумента по структуре, заданной в макетеДЗ. Такое преобразование востребовано, например, для печати результата типовыми методами.
  5. Видим, что в сложных для программиста случаях, данные табличного документа можно скорректировать либо вручную, либо программно, используя промежуточное дерево значений.
  6. Предварительно преобразуем ДЗ в ТЗ. (Пример.6)
  7. Пример 10.4. Повторяет то же самое для ТаблицыЗначений.   
  8. Техническое решение примеров 10.3 и 10.4 обеспечивает функция ВернутьТабДокСервер(), которая:
    1. В пустой макет «СКДТонкийКлиент» программно устанавливает НаборДанныхОбъект, который заполняем внешними данными из отредактированной ТЗ.
    2. Настройки копируем из макетаДЗ.
    3. Результатом будет требуемый ТабличныйДокумент, учитывающий внесенные изменения в таблицу значений ТЗ.  

7)  Заключение. Демонстрация показала:

  1.  Процедура  СоздатьКолонкиУпр() выполняет такие же функции как процедура. СоздатьКолонки() обычного приложения.
  2. Если исходная коллекция и результат её преобразования размещены в одной управляемой форме, то необходимо очищать колонки источника во избежание дублирования наименований в приёмнике. (Процедура ОчиститьКоллекциюЗначенийНаСервере()).
  3. В тонком клиенте модули управления коллекцией значений обязательно следует размещать на сервере.
  4. Для преобразования коллекции значений в табличной документ с независимым макетомСКД можно применить функцию Скд_ВнешниеДанные().
  5. Независимый макетСКД можно создать на основании другого макета, например, макетДЗ. Для решения этой задачи можно применить функцию ВернутьТабДокСервер(). 
  6. Примечание. Программный код представлен способом, повышающим удобство копирования в разработку. Размеры базовых блоков программного кода, назначенных к копированию в разработку, не превышают четырёх строк.

Желаю успехов всем и каждому.

////////////////////////////////////////////////////////

Описание Процедуры     СоздатьКолонкиУпр()

Синтаксис:

СоздатьКолонкиУпр(<ФормаЭта>, <ИмяРеквизита>, <КоллекцияЗначений>)

Параметры:

<ФормаЭта> (обязательный)

Тип:УправляемаяФорма. Форма, в реквизите которой требуется программно определить состав колонок.

<ИмяРеквизита> (обязательный)

Тип:Строка. Имя реквизита как указано в управляемой форме.  Этому реквизиту следует определить состав колонок. Тип реквизита должен быть либо ТаблицаЗначений, либо ДеревоЗначений.

<КоллекцияЗначений> (обязательный)

Тип:ТаблицаЗначений, ДеревоЗначений, АдресВременногоХранилища. Источник данных, который следует вывести на экран. Тип источника данных должен быть либо ТаблицаЗначений, либо ДеревоЗначений. Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым.

Описание:

Для любого прикладного объекта типа таблицаЗначений или деревоЗначений, программно создаётся состав колонок реквизита управляемой формы. Затем прикладной объект преобразовывается в данные формы и выводится на экран.

Процедура применяется в случаях, когда состав колонок коллекцииЗначений заранее не определён.

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции ВернутьТабДокСервер()

Синтаксис:

ВернутьТабДокСервер (<ТЗисточник >, < АдресМакетаСКД >, < НастройкиСКД_1>)

Параметры:

< ТЗисточник > (обязательный)

Тип:ТаблицаЗначений. Источник данных для формирования результата СКД.

< АдресМакетаСКД > (обязательный)

Тип:Строка. Адрес временного хранилища, в которое помещен макет схемы компоновки данных (Тип:СхемаКомпоновкиДанных).   

< НастройкиСКД _1> (обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает ТабличныйДокумент с данными из ТаблицыЗначений (ТЗисточник) преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

Описание Функции скд_ВнешниеДанные ()

Синтаксис:

Скд_ВнешниеДанные (<ТЗ_внешниеДанные>, <ТипРезультата="ТабДок">, <АдресМакетаСКД="">, <НастройкиСКД=Неопределено>)

Параметры:

< ТЗ_внешниеДанные > (обязательный)

Тип:ТаблицаЗначений. ДанныеФормыКоллекция. Источник данных для формирования результата СКД.

< ТипРезультата > (не обязательный)

Тип:Строка. Допустимые значения: «ТабДок», «ТабличныйДокумент», «ДЗ», «ДеревоЗначений», «ТЗ», «ТаблицаЗначений».

< АдресМакетаСКД > (не обязательный)

 (Тип:Строка).   

< НастройкиСКД > (не обязательный)

Тип:НастройкиКомпоновкиДанных. Текущие настройки макета СКД.

Описание:

Возвращает результат СКД заданного типа с данными из ТаблицыЗначений преобразованными по структуре МакетаСКД

Доступность:

Сервер, ТолстыйКлиент

Примечание:

////////////////////////////////////////////////////////

&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта,ИмяРеквизита, ДеревоТаблицаЗначенийАдрес) Экспорт 
	
	#Если ТолстыйКлиент Тогда
		цЭто="ЭтоТолстыйКлиент";//Отладка
	#ИначеЕсли ТонкийКлиент Тогда
		цЭто="ЭтоТонкийКлиент";//Отладка
	#ИначеЕсли Клиент Тогда
		цЭто="ЭтоКлиент";//Отладка|ОбычноеПриложение
	#ИначеЕсли Сервер Тогда
		цЭто="ЭтоСервер";//Отладка
	#Иначе
		цЭто="ЭтоНеКлиентНеСервер";//Отладка
	#КонецЕсли
	
	
	Вариант=3;
	Если Вариант=2 Тогда
		////Вариант=2;
		
	ИначеЕсли Вариант=3 тогда
		Если ЭтоАдресВременногоХранилища(ДеревоТаблицаЗначенийАдрес) Тогда
			цДеревоТаблицаЗначений = ПолучитьИзВременногоХранилища(ДеревоТаблицаЗначенийАдрес);
		Иначе 	
			цДеревоТаблицаЗначений = ДеревоТаблицаЗначенийАдрес ;
		КонецЕсли;
		//ФормаЭта = РеквизитФормыВЗначение(,Тип("УправляемаяФорма"));		
		
		фрмЭлементы =  ФормаЭта.Элементы;
		цРодитель =  ФормаЭта.Элементы[имяРеквизита];
		цТипЭлемента = Тип("ПолеФормы");
		
		
		мсУдаляемыеКолонкиРеквизита= Новый Массив;
		цРодПодч = цРодитель.ПодчиненныеЭлементы ;
		Для каждого кол Из цРодПодч Цикл
			кол_имя = кол.Имя;
			СтараяКолонкаРеквизита =  кол.ПутьКДанным;
			мсУдаляемыеКолонкиРеквизита.Добавить(СтараяКолонкаРеквизита);
		КонецЦикла;
		
		мсДобавляемыеКолонкиРеквизита = Новый Массив;
		для Каждого кол Из цДеревоТаблицаЗначений.Колонки Цикл
			кол_имя = кол.Имя;
			//ОписаниеТиповДляРеквизита = Новый ОписаниеТипов(ТипыРеквизита);
			ОписаниеТиповДляРеквизита = кол.ТипЗначения;
			
			Если ОписаниеТиповДляРеквизита.СодержитТип(Тип("ХранилищеЗначения")) Тогда
				Продолжить;
			КонецЕсли;				
			
			НоваяКолонка = Новый РеквизитФормы(кол_имя,       // имя
			ОписаниеТиповДляРеквизита,   // тип
			имяРеквизита,              // путь
			кол.Заголовок,             // заголовок
			Ложь);                     // сохраняемые данные
			
			мсДобавляемыеКолонкиРеквизита.Добавить(НоваяКолонка);
		КонецЦикла;	
		//
		
		
		#Если НаСервере Тогда           
			ФормаЭта.ИзменитьРеквизиты(мсДобавляемыеКолонкиРеквизита,мсУдаляемыеКолонкиРеквизита);            
		#Иначе            
			ц="ЭтоБлин";	
		#КонецЕсли		
		
		Для каждого новКолонка Из мсДобавляемыеКолонкиРеквизита Цикл
			этаКолонкаЕсть = ФормаЭта.Элементы.Найти(новКолонка.Имя);
			Если этаКолонкаЕсть<>Неопределено Тогда
				//Продолжить;
				ФормаЭта.Элементы.Удалить(этаКолонкаЕсть);
			КонецЕсли;
			
			Попытка
				кол_имя =новКолонка.Имя;
				новЭлем = ФормаЭта.Элементы.Добавить(кол_имя, цТипЭлемента, цРодитель); 
				новЭлем.Вид = ВидПоляФормы.ПолеВвода;
				новЭлем.ПутьКДанным = имяРеквизита+"."+кол_имя;
			Исключение
				//Если ФлагЭтоЯ Тогда
				цОш = ОписаниеОшибки();
				сооб = Новый СообщениеПользователю;
				сооб.Текст = кол_имя+" : "+цОш;
				сооб.Поле = кол_имя;
				сооб.Сообщить();
				//Продолжить;
				//КонецЕсли;  
			КонецПопытки;	
			
		КонецЦикла;    
		
		#Если не ТонкийКлиент Тогда           
			ЗначениеВДанныеФормы(цДеревоТаблицаЗначений,ФормаЭта[ИмяРеквизита]);
		#КонецЕсли
		
	КонецЕсли; 
	
	
КонецПроцедуры
R03;
Функция ВернутьТабДокСервер(цРезультатСКД1, цАдресМакетаСКД1, цНастройкиИсточник1) Экспорт 
	Перем  ТабДок2;
	
	цСхемаКомпоновкиДанныхИсточник1 = ПолучитьИзВременногоХранилища(цАдресМакетаСКД1);
	цНаборыДанныхИсточник1 = цСхемаКомпоновкиДанныхИсточник1.НаборыДанных ;
	
	цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьОбщийМакет("СКДтонкийКлиент");
	//цСхемаКомпоновкиДанныхИсточникТабДок2  =  ПолучитьМакет("СКДтонкийКлиент"); //внешнйОтчет
	
	цНаборыДанныхИсточникТабДок2 = цСхемаКомпоновкиДанныхИсточникТабДок2.НаборыДанных ;
	цНаборыДанныхИсточникТабДок2.Очистить();
	цНаборДанныхТабДок2 = цНаборыДанныхИсточникТабДок2.Добавить(Тип("НаборДанныхОбъектСхемыКомпоновкиДанных"));
	цТемпИмяТЗ_2 = "тзИмяТемп";
	цНаборДанныхТабДок2.имя = цТемпИмяТЗ_2;
	цИмяОбъекта_2 = "тзОбъектТемп";
	//цИмяОбъекта_2 = "тзИсточник";
	цНаборДанныхТабДок2.имяОбъекта = цИмяОбъекта_2;
	цНаборДанныхТабДок2.ИсточникДанных = "ИсточникДанных1";
	
	Для каждого текНаборИсточник1 Из цНаборыДанныхИсточник1 Цикл
		
		Для каждого поле_1 Из текНаборИсточник1.Поля  Цикл
			Попытка
				Если  ТипЗнч(поле_1)= тип("ПолеНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПолеНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,"ТипЗначения");
					
					цтип =  новый ОписаниеТипов(  поле_1.ТипЗначения) ;
					поле_2.ТипЗначения = цтип;
				ИначеЕсли   ТипЗнч(поле_1)= тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных") Тогда
					
					поле_2 = цНаборДанныхТабДок2.поля.Добавить(тип("ПапкаПолейНабораДанныхСхемыКомпоновкиДанных"));
					ЗаполнитьЗначенияСвойств(поле_2,поле_1, ,);
					УбратьИзПутьКДаннымИмяПапки(цРезультатСКД1, поле_1.ПутьКДанным );//ППМ						
				Иначе 
					Сообщение = Новый СообщениеПользователю;
					Сообщение.Текст = "Отказ, поле_1="+поле_1;
					//Сообщение.Поле = "";
					//Сообщение.УстановитьДанные(ЭтотОбъект);
					Сообщение.Сообщить();						
				КонецЕсли;
			Исключение
				цОш= ОписаниеОшибки();
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = цОш+", поле_1="+поле_1;
				//Сообщение.Поле = "";
				//Сообщение.УстановитьДанные(ЭтотОбъект);
				Сообщение.Сообщить();	
			КонецПопытки;
			
		КонецЦикла			                   
	КонецЦикла;
	
	Для каждого текПолеИтога1 Из цСхемаКомпоновкиДанныхИсточник1.ПоляИтога  Цикл
		Попытка
			полеИтога_2 = цСхемаКомпоновкиДанныхИсточникТабДок2.ПоляИтога.Добавить();
			ЗаполнитьЗначенияСвойств(полеИтога_2, текПолеИтога1 );
			
		Исключение
			цОш= ОписаниеОшибки();
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = цОш+", полеИтога_1="+текПолеИтога1;
			//Сообщение.Поле = "";
			//Сообщение.УстановитьДанные(ЭтотОбъект);
			Сообщение.Сообщить();	
		КонецПопытки;
		
	КонецЦикла;
	
	ТабДок2 = скд_ВнешниеДанные(цРезультатСКД1,"ТабДок" , цСхемаКомпоновкиДанныхИсточникТабДок2, цНастройкиИсточник1);
	
	Возврат  ТабДок2;
КонецФункции




R03;

/////////////////////////////////////////////////////////

R03;
Функция  скд_ВнешниеДанные(цТЗ_внешниеДанные, цТипРезультата="ТабДок", цАдресМакетаСКД="", цНастройкиСКД=Неопределено)Экспорт  //Преобразовать коллекциюЗначений в табличный документ
	Перем ВнешниеДанныеСКД;	
	
	Если ВРег(цТипРезультата)="ТАБДОК"  
		ИЛИ ВРег(цТипРезультата)="ТАБЛИЧНЫЙДОКУМЕНТ" 
		Тогда
		цОбъектСКД=Новый ТабличныйДокумент;
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанных");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.УстановитьДокумент(цОбъектСКД);
	Иначе
		Если ВРег(цТипРезультата)="ДЗ"
			ИЛИ  ВРег(цТипРезультата)="ДЕРЕВОЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ДеревоЗначений;
		ИначеЕсли ВРег(цТипРезультата)="ТЗ" 
			ИЛИ  ВРег(цТипРезультата)="ТАБЛИЦАЗНАЧЕНИЙ"
			Тогда
			цОбъектСКД=Новый ТаблицаЗначений;
		Иначе 
			цОбъектСКД=Новый ДеревоЗначений;
		КонецЕсли;
		
		типГенератораСКД = Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений");
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
		ПроцессорВывода.УстановитьОбъект(цОбъектСКД);
	КонецЕсли;
	
	Если ТипЗнч(цТЗ_внешниеДанные)=Тип("ТаблицаЗначений") Тогда
		ТЗ = цТЗ_внешниеДанные;
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	ИначеЕсли ТипЗнч(цТЗ_внешниеДанные)=Тип("ДанныеФормыКоллекция") Тогда
		ТЗ = ДанныеФормыВЗначение(цТЗ_внешниеДанные,Тип("ТаблицаЗначений"));
		ВнешниеДанныеСКД = Новый Структура("тзОбъектТемп", ТЗ);
		//ВнешниеДанныеСКД = Новый Структура("ТЗисточник", ТЗ);
	Иначе
		// это ТабличныйДокумент
	КонецЕсли;
	
	Если ЭтоАдресВременногоХранилища(цАдресМакетаСКД) Тогда
		СхемаКомпоновкиДанных = ПолучитьИзВременногоХранилища(цАдресМакетаСКД) ;
	ИначеЕсли ТипЗнч(цАдресМакетаСКД)= Тип("СхемаКомпоновкиДанных") Тогда
		СхемаКомпоновкиДанных = цАдресМакетаСКД ;
		
	Иначе
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "нет макета СКД";
		//Сообщение.Поле = "";
		//Сообщение.УстановитьДанные(ЭтотОбъект);
		Сообщение.Сообщить();
		Возврат цОбъектСКД;
	КонецЕсли;
	
	
	Если цНастройкиСКД=Неопределено Тогда
		Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;		
	Иначе
		Настройки = цНастройкиСКД;
	КонецЕсли;
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, , ,типГенератораСКД, ,);
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешниеДанныеСКД  );
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);   	
	
	Возврат цОбъектСКД;
КонецФункции




R03;

Состав zip.

1.       База данных c примерами для копирования - dt и cf.

2.       Внешняя обработка.

Скачать файлы

Наименование Файл Версия Размер
ПримерыВыводаКоллекцииЗначенийНаЭкранУпрФормы

.7z 159,93Kb
13.09.16
49
.7z 159,93Kb 49 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. json 14.09.16 02:55 Сейчас в теме
Очень хорошо, что ваши процедуры универсальны (это редкость на ИС)

НО есть несколько моментов, которые [лично мне] могут помешать применить ваши процедуры
1. Самодокументируемое название методов - из названия методов должно быть однозначно понятно, что данный метод делает (например, СоздатьКолонкиТаблицыНаУправляемойФорме() ). Без необходимости изучения кода самого метода. Иначе возникают сложности с читаемостью и пониманием при а) вызове метода, б) при понимании кода, из которого вызывается данный метод.
2. Неиспользуемые переменные (например, цЭто и Вариант), а также невыполняемые ветки в операторах Если
3. Большое количество закомментированного кода - лучше удалить, чтобы он не сбивал с толку тех, кто будет использовать ваши методы. Если в коде много подобных закомментированных участков - у других разработчиков возникает опасение, что он еще пока на стадии отладки и работа над ним не закончена. А незаконченные чужие процедуры никто использовать не будет.
4. Большое количество цифр в именах переменных - является моветоном (например, цСхемаКомпоновкиДанныхИсточникТабДок2), вызывает недоверие.

Высказал только самые критичные на мой взгляд недочеты.

Несмотря на мою критику, хочу отметить, что заметна большая проделанная работа (и по написанию процедур, и по подготовке статьи)
Плюс однозначно.
Патриот; kuzyara; awk; vasiliy_b; dj_serega; mihey; aexeel; Irwin; +8 Ответить
2. fancy 3 15.09.16 07:07 Сейчас в теме
Спасибо за статью, вчера как раз воспользовался, правда пришлось побиться с добавлением колонок реквизита формы ДеревоЗначений - смог добавить лишь только тогда, когда само дерево добавляю в реквизиты формы программно, если же дерево создать в конфигураторе, то колонки никак не хотели добавляться
3. json 15.09.16 08:49 Сейчас в теме
(2) fancy, да, я тоже сталкивался с этим. Проблема в том, что если колонка добавлена из конфигуратора, то ни колонку реквизита, ни колонку табличного поля на форме удалить программно нельзя. И это все осложняется тем, что в коде нельзя определить, добавлялась колонка программно или через конфигуратор. Единственный костыль, который я тут нашел - использование попытки. Колонки из реквизита на таблицы нужно удалять по одной в попытке (а не сразу всем массивом), и перед добавлением проверять наличие. При обновлении колонок табличного поля - тоже нужно удалять колонки в попытке и перед добавлением - проверять наличие.
5. pavley2002 190 17.09.16 15:37 Сейчас в теме
(3) yurii_host,
Доступ к элементу формы осуществляется по имени, поэтому дублирование имён внутри элементов сделает управляемую форму не работоспособной. В этой статье защита от дублирования имён выполнена упрощённо через очистку всех элементов перед любым значимым действием. Для этой цели используется процедура ОчиститьКоллекциюЗначенийНаСервере(). При таком алгоритме не возникает необходимость проверять наличие дублирования имен по штучно.
Однако, сама проблема дублирования имён при программном заполнении колонок следующей коллекции значений существует и требует методологической постановки задачи с последующем решением.
Алгоритм близкий к по элементной проверке предложен в http://infostart.ru/public/536800/ . Без функции ПроверитьДублиИменКолонок() в указанной статье невозможно решить поставленную там задачу.
6. json 17.09.16 17:38 Сейчас в теме
(5) не понимаю, зачем проверять дубли. Сначала удаляем все колонки, которые можем удалить. Затем добавляем колонки в цикле. Перед добавлением проверяем, присутствует ли колонка с таким именем в коллекции колонок. Если присутствует, то переходим к следующей итерации цикла.

Прикладываю работающий пример. Данный набор процедур использую уже года два. Проверено в продуктиве много раз
Попытка используется два раза, что некрасиво. Но других решений пока не нашел.

Отмечу, что в приведенном примере колонка Склад - добавлена через конфигуратор, а остальные колонки - добавляются программно.

Подход универсальный и не требует какой-то специальной методологической постановки задачи

Вот тут в моей публикации рассматривается другой вопрос, но создание колонок выполняется программно, хотя на этом не заостряется внимание. В примере к публикации для управляемых форм используются этот же блок процедур
Прикрепленные файлы:
ВнешняяОбработка1.epf
4. pavley2002 190 15.09.16 18:31 Сейчас в теме
(2) fancy, Процедуру СоздатьКолонкиУпр() можно применять только для программно добавленных колонок. Это обусловлено применением метода ВсеЭлементыФормы.Удалить(), в 1С:описании которого непосредственно указано:- «Доступно удаление только ранее программно добавленного элемента».
Для устранения возникшей не ясности, в описание процедуры СоздатьКолонкиУпр() добавлена строка - «Причем, для этого реквизита состав колонок указанный в управляемой форме должен быть пустым». Спасибо за указание на неточность.
7. kuzyara 1027 19.09.16 09:03 Сейчас в теме
&НаСервере
Процедура СоздатьКолонкиУпр(ФормаЭта
...

Клинический случай. Дальше читать не стал.
8. pavley2002 190 26.09.16 08:47 Сейчас в теме
(7) kuzyara,
Отсутствует конструктивное предложение, хотя бы какое-нибудь. На мой взгляд, накопленный личный медицинский опыт здесь не уместен.
paybaseme; kuzyara; +2 Ответить
11. vpaoli 29 16.04.20 09:57 Сейчас в теме
(8) я тоже думаю так. Ведь форму на сервер передать нельзя . НЕ правильно размещать процедуры в отрыве от контекста их использования.
9. almas 198 30.10.16 13:12 Сейчас в теме
Скачал, посмотрел. Несмотря на значимость обработки ощущение отвратное. Черт нельзя было малость в удобоваримый читаемый порядок все привести???
10. pavley2002 190 01.11.16 09:25 Сейчас в теме
(9) almas,
Не обработка, а универсальная функция представлена в форме, не требующей скачивания файла, я предполагаю, что это заметно. Кроме того, Вам позволено не принуждать себя скачивать файл, который оказывает дурное влияние на настроение, бесполезен или любое другое.

paybaseme; +1 Ответить
Оставьте свое сообщение

См. также

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    44836    155    ekaruk    31    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    14388    17    sapervodichka    41    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    26646    14    HostHost    40    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    17041    11    Dementor    30    

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    30344    10    tormozit    44    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    31812    13    vasilev2015    63    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17286    4    m-rv    86    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    26347    76    Evil Beaver    119    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27595    86    m-rv    57    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    26815    19    Hatson    22    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    21261    13    stvorl    0    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18831    12    RocKeR_13    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25482    19    mvxyz    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25405    25    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    39303    17    kalyaka    16    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    73860    23    dsdred    24    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    25103    66    vasvl123    9    

Универсальная функция - Сформировать результат СКД

Универсальные функции v8::СКД 1cv8.cf Россия Абонемент ($m)

Предлагаемая функция СформироватьРезультатСКД позволяет программисту комфортно применять систему компоновки данных для обработки информации текущей или внешней базы. Функцию целесообразно размещать в общем модуле или в расширении конфигурации на управляемых формах.

1 стартмани

19.05.2018    7845    7    pavley2002    1    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    41146    33    dsdred    36    

Как выполнить отчет на СКД через COM и получить данные отчета?

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25694    8    wowik    3    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    68753    206    ildarovich    117    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    40995    85    kalyaka    34    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    33143    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36585    27    agent00mouse    0    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    87459    300    Dementor    48    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24832    49    kwazi    6    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    51766    63    dewersia    32    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    90955    122    json    27    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    116551    13    signum2009    46    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47327    15    DarkAn    86    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    140641    954    json    66    

Простой способ индексирования интервалов

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38127    38    ildarovich    22    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44706    36    Demanoidos    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    53158    7    wowik    31    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    51781    19    arakelyan    18    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    74512    150    igo1    52    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    16538    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    46042    49    yuraos    17    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    21581    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    45025    169    TuneSoft    26    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    35422    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    53204    47    YPermitin    19