Справка HTML в формах и обработках 1С (альтернатива 1С-ой)

Публикация № 58130

Сообщество - Пользователю системы

Привожу пример использования собственной справочной информации в формах документов и обработок 1С 8.1. Это пример из действующей конфигурации, правда реализация её там сложнее , но основной принцип остался. Справочную информацию необходимо подготовить самим. Для этого можно воспользоваться сторонними программами, которые правда платные, но есть задумка сделать свою в 1С, если это понравится большинству.

Для того, чтобы меньше обращались пользователи ко мне с вопросами "как создать...", "...а почему не получается...", "...как с ним работать...", " покажи как ..."  и т.д., решил сделать справочное руководство с примерами, скриншотамии и внедрить его в конфигурацию. Вопросов у пользователей почти не осталось. Из любой формы документа или обработки можно вызвать справку по данной теме. где все расписано и все показано, а некоторых случаях можно посмотреть видео пример , где можно посмотреть все операции по созданию...

Для просмотра распаковать архив в папку bin 1С. ("C:\Program Files\1cv81\bin") или в другую, с заменой адресов в коде обработки.

Скачать файлы

Наименование Файл Версия Размер
help.cab

.cab 9,15Mb
12.10.09
124
.cab 9,15Mb 124 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. aipnnov 164 06.10.09 13:30 Сейчас в теме
Выкладываю, может кому и пригодится.
Реализация в 1С, как говорится, на собственное усмотрение. Здесь же, только пример "как".
Данная справка намного нагляднее и лучше, чем в самой 1С.
Оценивайте, ругайте и т.п., т.к. хочу знать ваше мнение, нужно это или нет.
2. vladnet 361 06.10.09 13:54 Сейчас в теме
В самом файле лучше поправить на вот это:

Функция ФайлПолучитьКаталог(пИмяФайлаПолное) Экспорт
лПозицияСлэша=Макс(СтрНайтиПоследнееВхождение(пИмяФайлаПолное, "\"), СтрНайтиПоследнееВхождение(пИмяФайлаПолное, "/"));
Возврат Лев(пИмяФайлаПолное, лПозицияСлэша);
КонецФункции

url = ?(url="", "file:\\"+ФайлПолучитьКаталог(ИспользуемоеИмяФайла)+ "index.htm", url);

Тогда будет запускаться хоть откуда.
5. rasswet 82 07.10.09 10:23 Сейчас в теме
(2) СтрНайтиПоследнееВхождение не находит. пробую ваш вариант.
6. vladnet 361 07.10.09 10:25 Сейчас в теме
(5) Вот добавь еще эту функцию.

Функция СтрНайтиПоследнееВхождение(Знач пСтрока, пПодстрока) Экспорт
лДлинаПодстроки=СтрДлина(пПодстрока);
лПозицияВозвращаемая=0;
Пока Истина Цикл
лПозиция=Найти(пСтрока, пПодстрока);
Если лПозиция=0 Тогда Возврат лПозицияВозвращаемая; КонецЕсли;
Если лПозицияВозвращаемая<>0 Тогда лПозицияВозвращаемая=лПозицияВозвращаемая+лДлинаПодстроки-1; КонецЕсли;
лПозицияВозвращаемая=лПозицияВозвращаемая+лПозиция;
пСтрока=Сред(пСтрока, лПозиция+лДлинаПодстроки);
КонецЦикла;
КонецФункции


Кстати да поддерживаю вопрос raaswet чем пользуешься чтобы сам хелп делать.
7. rasswet 82 07.10.09 11:29 Сейчас в теме
(6) теперь {Форма.Форма(21)}: Преобразование значения к типу Число не может быть выполнено
АдресURL = Адрес + "index.htm#page=Часть31.html";
вобщем не получается.
написал
Адрес = ?(Адрес="", "file:\\"+ФайлПолучитьКаталог(ИспользуемоеИмяФайла)+ "index.htm", Адрес);
и две твои функции.
8. vladnet 361 07.10.09 12:55 Сейчас в теме
(7) Сложно сказать в чем там дело, попробуй отладчиком посмотреть.
9. rasswet 82 07.10.09 12:59 Сейчас в теме
(8) у тебя есть готовый вариант, где ты добавил то что советуешь? так делись же скорее)))
3. vladnet 361 06.10.09 14:02 Сейчас в теме
У меня в собственном решении справка лежит в виде chm, но уже думаю переходить на внутреннюю, пока не знаю как буду делать. Но за данный вариант спасибо, приму к сведению.

Сам же пока думаю реализовывать поиск и фильтрацию с помощью стандартных механизмов 1с. А саму справку хранить в html в справочнике.
4. rasswet 82 07.10.09 10:09 Сейчас в теме
"Для этого можно воспользоваться сторонними программами" а ты какими именно пользовался?
10. vladnet 361 07.10.09 13:04 Сейчас в теме
Вот так у меня работает:

Процедура ПолеHTMLДокументаДокументСформирован(Элемент)
	Если url <> "" Тогда 
        Док = ЭлементыФормы.ПолеHTMLДокумента.Документ;
	Иначе
		Предупреждение("Адрес страницы справки не найден.",, "Ошибка.");
		Возврат;
	КонецЕсли;
КонецПроцедуры

Процедура ПриОткрытии()
	ЭлементыФормы.ПолеHTMLДокумента.Перейти(url); 
КонецПроцедуры


Функция СтрНайтиПоследнееВхождение(Знач пСтрока, пПодстрока) Экспорт 
	лДлинаПодстроки=СтрДлина(пПодстрока); 
	лПозицияВозвращаемая=0; 
	Пока Истина Цикл 
		лПозиция=Найти(пСтрока, пПодстрока); 
		Если лПозиция=0 Тогда Возврат лПозицияВозвращаемая; КонецЕсли; 
		Если лПозицияВозвращаемая<>0 Тогда лПозицияВозвращаемая=лПозицияВозвращаемая+лДлинаПодстроки-1; КонецЕсли; 
		лПозицияВозвращаемая=лПозицияВозвращаемая+лПозиция; 
		пСтрока=Сред(пСтрока, лПозиция+лДлинаПодстроки); 
	КонецЦикла; 
КонецФункции 


Функция ФайлПолучитьКаталог(пИмяФайлаПолное) Экспорт 
	лПозицияСлэша=Макс(СтрНайтиПоследнееВхождение(пИмяФайлаПолное, "\"), СтрНайтиПоследнееВхождение(пИмяФайлаПолное, "/")); 
	Возврат Лев(пИмяФайлаПолное, лПозицияСлэша); 
КонецФункции 

url = ?(url="", "file:\\" + ФайлПолучитьКаталог(ИспользуемоеИмяФайла)+ "index.htm", url);
Показать
11. aipnnov 164 08.10.09 08:45 Сейчас в теме
Для составления "справки" можно использовать WinCHM, которая сохраняет файлы, по моему, в 3-х форматах .chm, .hlp и .htm (для инета). Есть еще ряд разных программ, надо искать в инете.
Ещё раз повторяю, это пример как можно использовать свое справочное руководство в 1С, а не скудный help, который предоставляет нам 1С. Реализация ее в своих конфигурациях может быть выполнена, как угодно вашей фантазии и как вам удобнее.
Можно сделать справочное руководство, точно такое же как у меня, используя файлы моего справочного руководства, там открыт весь код и если разобраться, то будет все понятно. Я делал сам руками, но использовал файлы 7-10 летней давности, которые в свою очередь "содрал" с какого-то обучающего java программированию сайта (сейчас уже не помню), доработав их до того состояния, которое вы видите.
12. aipnnov 164 08.10.09 09:38 Сейчас в теме
Нашел программу WinCHM http://www.izone.ru/text/utilities/winchm.htm, использует те же java скрипты, что и уменя, но платная.

Кстати файл data.js в для справки не нужен, он служит для фиксации изменений в структуре справки, его можно вообще удалить. Остальное все элементарно, для изготовления страниц справки можно использовать б/п редакторы html, а остальные файлы в гл. директории изменить под свои страницы.

Решил написать собственную программу, для создания таких справок. Как сделаю, выложу. Может быть еще какие-нибудь мыслишки посетят мое "чело" за это время.
13. Путин 25 08.10.09 10:15 Сейчас в теме
У меня тоже вся справка в htm до сих пор была оформлена кое как. Прикрутил всё к твоей обработке.
Спасибо.
14. Путин 25 10.10.09 07:41 Сейчас в теме
Я только сейчас до видео добрался. Добавь в описание. Прикольная фича.
15. aipnnov 164 12.10.09 11:20 Сейчас в теме
16. Yasen 490 15.04.10 07:17 Сейчас в теме
Спасибо, отличная штука.
А почему именно WinCHM если есть бесплатные утилиты?
17. aipnnov 164 15.04.10 08:24 Сейчас в теме
(16) Без разницы, какую утилиту использовать, ее я привел для примера. :D
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы Промо

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    11843    19    bmk74    4    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    6492    30    sapervodichka    33    

Визуальный html WYSIWYG редактор без сторонних библиотек на управляемых формах

Прочие инструменты разработчика Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и удобный html редактор без сторонних библиотек.

1 стартмани

31.08.2020    3499    7    ivanov660    10    

Делаем из СКД Excel (ну, почти)

Работа с интерфейсом v8 Абонемент ($m)

Несложный в использовании способ внедрить в обычный отчет СКД возможность редактировать значения ресурсов отчета (а-ля Excel) и получать отредактированные значения для дальнейшей обработки.

1 стартмани

26.01.2020    9427    13    herfis    16    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    32979    150    tormozit    25    

Индикация прогресса выполнения фонового задания на управляемой форме внешней обработки

БСП (Библиотека стандартных подсистем) Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП >= 2.3 без изменения конфигурации и встраивания обработки в "Дополнительные отчеты и обработки".

1 стартмани

27.12.2019    11025    15    1sig    14    

Декомпиляция условного оформления

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Обработка автоматически генерирует полный код создания условного оформления формы любой сложности. Достаточно настроить для формы в конфигураторе условное оформление, а затем выбрать данную форму в обработке. В результате будет сгенерирован программный код создания условного оформления.

2 стартмани

23.12.2019    7862    37    XilDen    6    

Многоуровневые списки выбора с оформлением элементов

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Данная статья - попытка решить один маленький кусочек большой проблемы платформы 1С, а именно - бедные и невыразительные пользовательские интерфейсы. Поскольку 1С в режиме управляемого приложения позволяет задействовать веб-клиент, то хочется реализовывать интерфейсы как у взрослых веб-приложений - красивые, дружелюбные для пользователя и, желательно, с положительным UX. Возможно, кто-то со мной не согласится и скажет, что учетные системы должны быть строгие и линейные. Но мы все знаем, что 1С - это уже не только про бухгалтерию. Небольшое отступление для разработчиков, работающих с типовыми конфигурациями. Я не знаю, использует ли фирма 1С что-то похожее в своих разработках. Если да, то данная статья навряд ли будет вам полезна.

1 стартмани

17.12.2019    8704    2    azhilichev    5    

Открывашка ячеек таблиц Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    17275    12    tormozit    31    

Удобный выбор из таблицы/дерева в УФ

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    13755    7    Yashazz    18    

[Механизм интерфейса] Свой флажок (чекбокс)

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    16270    18    rpgshnik    43    

Отбор на управляемой форме из списка значений

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    18724    21    nagaitseff    6    

Лучший подарок для бухгалтера - счёты 8.2 (со звуком) Промо

Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

(Толстый клиент) Подарите бухгалтеру счеты, и он(а) Вас никогда не забудет.

1 стартмани

13.05.2011    40657    24    Tatitutu    45    

Инструктор. Прототип инструмента создания быстрых пользовательских инструкций

Пользователю системы Инструментарий разработчика v8 v8::УФ Россия Абонемент ($m)

Прототип дружелюбного и эффективного инструмента для написания пользовательских экспресс-инструкций. Задействована штатная утилита Windows, о существовании которой многие не знают и которая умеет делать огромную работу по логированию действий и снятию скриншотов на всех ПК с Windows (начиная с версии Win7). "Инструктор" не требует никакой установки и дополнительных библиотек! Это означает, что инструмент будет работать и на домашнем ПК и на "чужом ноутбуке" и на терминальном win-сервере у заказчика, где ваши права сильно ограничены. Вы просто подключаете легкую файловую базу 1С и получаете инструмент по снятию скриншотов с интересной функциональностью...

1 стартмани

15.02.2019    13621    42    ROM_NN    8    

Управление задачами в 1С - готовая подсистема с открытым кодом и широким базовым функционалом. Версия 1.0.6

Инструментарий разработчика Управление бизнес-процессами (BPM) Управление проектом v8 Абонемент ($m)

Конфигурация-подсистема для управления задачами с базовым функционалом, который, однако, может удовлетворить довольно широкий спектр запросов. Есть статусы и приоритеты, учёт трудозатрат по исполнителям и даже базовые разграничения по правам. А открытый исходный код позволит на базе данной конфигурации развить систему до любого уровня сложности.

2 стартмани

17.12.2018    20811    105    for_sale    38    

Рисуем и распознаем нарисованное при помощи нейросети

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Используем нейронную сеть для распознавания нарисованных объектов.

1 стартмани

03.10.2018    14721    44    DO_WHILE_LOOP    28    

Визуализация событий на временной шкале средствами "Поле HTML документа" Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    24074    139    Plotks2017    27    

Рисуем диаграммы в metadata.js

Инструментарий разработчика Работа с интерфейсом v8 v8::СКД 1cv8.cf Абонемент ($m)

Не одной же литературой заниматься?

1 стартмани

20.09.2018    17234    3    1c-intelligence    77    

Продвинутое рисование в табличном документе (стрелок и не только)

Практика программирования Работа с интерфейсом v8 Абонемент ($m)

Вспоминаем геометрию и основы компьютерной графики. Матрицы и аффинные преобразования на плоскости.

1 стартмани

24.07.2018    16060    18    WalterMort    29    

Иерархическая диаграмма

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Концепция диаграммы по иерархической структуре данных, например по номенклатуре (продажи или остатки на складах).

2 стартмани

17.06.2018    14148    16    DrAku1a    6    

Работа с данными выбора Промо

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    48769    17    kalyaka    16    

Рисуем стрелки в табличном документе

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуем стрелки средствами 1С .

1 стартмани

01.06.2018    15683    9    pm74    9    

Программная работа с графическими схемами. Готовое решение

Инструментарий разработчика Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Работоспособное, проверенное на практике, простое и удобное программное управление графическими схемами.

1 стартмани

18.02.2018    18927    20    Yashazz    13    

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    29968    5    kraynev-navi    41    

Интерактивный интерфейс Промо

Рабочее место Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Обработка (отдельная панель меню), позволяющая настраивать интерфейс пользователя интерактивно (права не настраивает). Мне очень пригодилось, так как приходится прописывать индивидуальный интерфейс, каждому пользователю (а их уже сотни). Выложил 2 версии одна в виде таблицы, вторая в виде выпадающего меню

1 стартмани

29.10.2011    18377    2    Vin_Tik    9    

Программное создание элементов графической схемы (через XSLT)

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Встала как-то передо мной задача визуализировать определенный прикладной процесс, лучше всего для этого подходит графическая схема. Так уж вышло, что 1С по не понятным мне причинам не предоставила возможность программно работать с элементами графической схемы. Пришлось импровизировать.....

1 стартмани

20.07.2017    21377    62    lazarenko    18    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    21396    96    igel9780    22    

Система учета задач

Управление проектом Личная эффективность Учет рабочего времени Учет рабочего времени v8 УУ Абонемент ($m)

Конфигурация для учета задач небольшой команды разработчиков. Поскольку основной причиной того, что в учете задач наступает хаос, являются затраты на актуализацию всего этого дела, я попытался сделать так, чтобы делать это было просто. Тут еще можно написать про скрум, аджайл и прочее. В общем, получилась канбан доска с плюшками. Конечно, тут далеко до того, чем пользуются silverbulleters, но для "непромышленной" разработки командой из 1-5 человек - пойдет. Ну и главное - это теплый, ламповый, родной 1C (с его плюсами и минусами).

1 стартмани

20.10.2016    42435    228    Fragster    118    

Программное формирование форматированной строки в стиле html+inline CSS Промо

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    32809    36    bonv    10    

Настройка начальной страницы (Рабочего стола)

Работа с интерфейсом Рабочее место Универсальные обработки v8 1cv8.cf Абонемент ($m)

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    38066    220    Erne100    24    

[Расширение] Стартовые страницы. Автозапуск форм при старте 1С. (8.3.9+, без доработки конфигурации)

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Уверен, что в большинстве случаев список справочников, отчетов, обработок (объектов 1С в целом), к которому обращаются пользователи после запуска конфигурации 1С, раз от раза меняется не сильно. Так почему бы немного не упростить процесс открытия часто используемых форм? Данное расширение позволяет настроить автоматическое открытие различных форм объектов сразу после запуска 1С. Список форм настраивается индивидуально для каждого пользователя. Работает на платформе 8.3.9, без доработки конфигурации.

1 стартмани

03.10.2016    21812    83    Artem-B    20    

Конструктор условного оформления

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Иногда требуется сделать отчет, который бы содержал в себе множество показателей. В таком случае в получившейся "портянке" показатели сливаются. Как один из вариантов решения (ну, кроме упрощения отчета) можно рассматривать раскраску показателей в индивидуальные цвета. После нескольких подобных случаев (особенно, когда в уже готовый отчет добавляются или убираются поля) сделал обработку, которая позволяет в режиме предприятия быстро подготовить болванку условного оформления для подобных отчетов.

1 стартмани

27.09.2016    17420    16    Fragster    7    

Цветовые схемы для конфигуратора 1С (Популярные цветовые схемы для C# - теперь и для 1С) (Теперь 8.2 - 8.3) Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Тёмные цветовые схемы кода. То, что было доступно всем передовым средствам разработки, теперь доступно и на 1С. 13.12.17 UPD: Теперь работает с платформой 8.3

3 стартмани

07.10.2013    35958    86    Chernov_Dmitriy    82    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    27192    137    Stepa86    15    

Механизм доп. реквизитов и сведений

Практика программирования Работа с интерфейсом v8 БП2.0 Абонемент ($m)

Как к новому справочнику подключить механизм дополнительных реквизитов и сведений

2 стартмани

23.06.2016    26738    30    piffoff    17    

Блокировка баннеров при помощи расширения

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Примеры использования расширений

1 стартмани

09.06.2016    14256    12    oslokot    16    

Gant 1C 2.* - диаграмма Ганта с таблицей + Планировщик + Отчет (8.1, на управляемой форме/Такси 8.2, 8.3) Промо

Рабочее место Универсальные обработки Управление проектом Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени v8 1cv8.cf УУ Абонемент ($m)

Внешняя обработка, аналог MS Project в 1Се для работы с задачами: параллельный ввод данных по задачам и график Ганта, дополнительный режим в виде календаря (планировщик), связывание задач и пересчет длительности и дат с учетом выходных, видов связей и запаздываний, расчет затрат, сохранение/открытие проектов в файл на диск или файл ИБ, импорт/экспорт документов Microsoft Project.

1 стартмани

02.12.2011    142066    1090    rare-avis    210    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    50540    53    yuraos    17    

Визуальный редактор цветовых схем подсветки синтаксиса 1С + импорт схем Visual Studio

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Данная обработка призвана облегчить настройку рабочего места программиста 1С, а именно улучшить визуальное восприятие кода, уменьшить утомляемость, и, как следствие, увеличить общую производительность труда!

1 стартмани

29.01.2016    15962    79    ram3    27    

Передача реквизитов объекта из основной формы в дополнительную и обратно на управляемых формах

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Наверное, многие сталкивались с ситуацией, когда у некоего редактируемого объекта (справочник, документ, внешняя обработка) кроме основной формы нужно сделать парочку дополнительных, чтобы часть реквизитов заполнять в них, а потом возвращать заполненные значения в основную форму и в сам объект. И если бы речь шла об обычных формах, то проблемы бы и не было. Но в управляемых формах с этим возникает проблема, а в случае отказа от модальности она становится немного больше.

1 стартмани

02.11.2015    34838    13    Wolex    30    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    47591    428    ПерваяСистема    147    

Инструмент для создания веб приложений на основе 1С REST сервиса

Инструментарий разработчика WEB Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Обзор платформы-конструктора для создания веб-приложений, использующих в качестве источника базы данных 1С

1 стартмани

13.10.2015    27054    77    dmzubr    23    

Асинхронная загрузка данных на Управляемую Форму. Прогресс бар (УФ 8.3). Индикация состояния процесса

Работа с интерфейсом Универсальные функции Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Часто бывает, что возникает необходимость загрузить множество данных из разнообразных источников в определенную форму или рабочее место. В процессе загрузки пользователь в неведении — информация готовится или нет. Прием позволяет загружать данные из нескольких источников асинхронно, не блокируя форму\интерфейс, а также отображать ошибки и состояние прогресса. По мере готовности данных, они будут отображены на форме

1 стартмани

09.10.2015    36454    128    pbazeliuk    6    

Визуальный html редактор на управляемых формах

Работа с интерфейсом WEB v8 1cv8.cf Абонемент ($m)

Мы рассмотрим некоторые особенности и возможности подключения сторонних визуальных html редакторов на javascript - TinyMCE, CK Editor. С помощью приложенной обработки Вы сможете попробовать в действии полноценный и удобный визуальный html редактор, а при желании перенести подобный функционал к себе.

1 стартмани

30.09.2015    29634    209    ivanov660    41    

V8Reader (с расширенным анализом форм) Upd. Промо

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Обработка, позволяющая анализировать и сравнивать файлы отчетов, обработок, конфигураций и обновлений. Имеет мощные инструменты по анализу форм, ролей и ограничений доступа.

1 стартмани

27.01.2012    75914    574    bambr1975    303    

Кнопки управления группировками табличного документа для управляемых форм Промо

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    26693    23    unichkin    9