Восстановление бухгалтерских проводок из резервной базы данных в 1С: 7.7

Публикация № 603770 29.03.17

Администрирование - Администрирование данных 1С - Обработка документов

Пример обработки, позволяющей восстановить (и не только) проводки из резервной базы данных после неосторожного массового изменения и проведения документов за (весьма) длительный период времени. Используется механизм OLE Automation.

Использование механизма OLE очень широко освещалось на этом ресурсе. Есть немало различных примеров его приложений. В частности, своей публикацией я не открою Америки. Но я решил по горячим следам выложить здесь обработку, избавившую от нервенной болезни нескольких уважаемых людей на уважаемом предприятии. Ибо... в своем неуемном стремлении достичь совершенства в учете, некоторые главные бухгалтеры иногда теряют осторожность и с попустительства таких же неосторожных программистов открывают документы за весьма длительный период времени на изменение. Что при этом случается, - не мне вам рассказывать. Все бухгалтерские итоги по плану счетов за годы (десятилетия) летят в тар-та-ра-ры.

Именно с такой ситуацией мне и пришлось недавно столкнуться. И речи не было о том, чтобы пытаться пригладить модули проведения документов за 15лет, чтобы они давали ожидаемые проводки (в различных периодах - отличающиеся). Предлагаемая здесь обработка довольно универсальна. Но решает весьма узкую задачу: из резервной базы данных извлекаются проводки документов и записываются в рабочую базу данных. На этом универсальность заканчивается. В процессе, - перед записью, - вы можете внести изменения в сами проводки. Кому-что требуется. Я только обозначил место в обработке, куда нужно втискивать эти дополнительные алгоритмы, удалив оттуда свой конкретный случай в массе не интересный.

Конфигурация, в которой мне пришлось решать эту задачу, эксплуатируется уже около 15 лет. Ее правили многие программисты, вносили множество изменений. И в ней осталось уже мало общего с типовой конфигурацией. Но я попытался аккуратно выделить все необходимые для обработки процедуры и функции. Часть из них должна быть размещена в глобальном модуле рабочей и резервной баз данных. Некоторые включил в состав внешней обработки. А есть и такие, которые (по моим ожиданиям) уже имеются и весьма давно в глобальном модуле конфигураций для бухгалтерского учета. Если я что-то упустил и у вас возникнут затруднения на сей счет (обработка не сработает), - пишите в комментариях. Я постараюсь выложить дополнительные алгоритмы.

Глобальный модуль показать/скрыть
Функция ПолучитьРеквизитыПроводок () Экспорт

	Сп = СоздатьОбъект("СписокЗначений")	;
	Для Инд = 1 По Метаданные.РеквизитПроводки() Цикл
		сп.ДобавитьЗначение(Метаданные.РеквизитПроводки(Инд).Идентификатор);
	КонецЦикла;
	Возврат сп;
	
КонецФункции



Функция ПолучитьПроводки (Док, СДополнением=0) Экспорт

	тбПроводки = СоздатьОбъект ("ТаблицаЗначений");
	тбПроводки.НоваяКолонка("ДтСчет", "Счет");
	тбПроводки.НоваяКолонка("ДтСубконто1");
	тбПроводки.НоваяКолонка("ДтСубконто2");
	тбПроводки.НоваяКолонка("ДтСубконто3");
	тбПроводки.НоваяКолонка("КтСчет", "Счет");
	тбПроводки.НоваяКолонка("КтСубконто1");
	тбПроводки.НоваяКолонка("КтСубконто2");
	тбПроводки.НоваяКолонка("КтСубконто3");
	тбПроводки.НоваяКолонка("Сумма");
	тбПроводки.НоваяКолонка("Валюта");
	тбПроводки.НоваяКолонка("ВалСумма");
	тбПроводки.НоваяКолонка("Количество");
	Если СДополнением = 1
	Тогда
		сп = ПолучитьРеквизитыПроводок ();
		КвоРеквизитов = сп.РазмерСписка();
		Если КвоРеквизитов <> 0
		Тогда
			Для Инд = 1 По КвоРеквизитов Цикл
				тбПроводки.НоваяКолонка(сп.ПолучитьЗначение(Инд));
			КонецЦикла;
		КонецЕсли;
		тбПроводки.НоваяКолонка("Пометка");
	КонецЕсли;

    Если (Док.Проведен() = 0) И (Док.Вид()<> "Операция")
    Тогда
		Возврат тбПроводки;
    КонецЕсли;

	
	Опер = Док.Операция;
	Опер.ВыбратьПроводки ();
	Пока Опер.ПолучитьПроводку () = 1 Цикл

		тбПроводки.НоваяСтрока();
		тбПроводки.ДтСчет = Опер.Дебет.Счет;
		тбПроводки.ДтСубконто1 = Опер.Дебет.Субконто(1);
		тбПроводки.ДтСубконто2 = Опер.Дебет.Субконто(2);
		тбПроводки.ДтСубконто3 = Опер.Дебет.Субконто(3);
		тбПроводки.КтСчет = Опер.Кредит.Счет;
		тбПроводки.КтСубконто1 = Опер.Кредит.Субконто(1);
		тбПроводки.КтСубконто2 = Опер.Кредит.Субконто(2);
		тбПроводки.КтСубконто3 = Опер.Кредит.Субконто(3);
		тбПроводки.Сумма = Опер.Сумма;
		тбПроводки.Валюта = Опер.Валюта;
		тбПроводки.ВалСумма = Опер.ВалСумма;
		тбПроводки.Количество = Опер.Количество;
		
		Если СДополнением = 1
		Тогда
			Если КвоРеквизитов <> 0
			Тогда
				Для Инд = 1 По КвоРеквизитов Цикл
					ИмяРеквизита = сп.ПолучитьЗначение(Инд);
					тбПроводки.УстановитьЗначение(тбПроводки.КоличествоСтрок(), ИмяРеквизита, Опер.ПолучитьАтрибут(ИмяРеквизита));
				КонецЦикла;
			КонецЕсли;
			тбПроводки.Пометка = 0;
		КонецЕсли;
	КонецЦикла;

	Возврат тбПроводки;

КонецФункции



Функция  ПроводкиВФайл (НомерДок, ДатаДок, ВидДок, ИмяФайла) Экспорт
	
	Док = СоздатьОбъект("Документ");
	Если Док.НайтиПоНомеру(НомерДок, ДатаДок, ВидДок) = 0
	Тогда
		Возврат 0;
	КонецЕсли;
	
	тб = ПолучитьПроводки(Док, 1);
	
	ЗначениеВФайл(ИмяФайла, тб);
	Возврат 1;
	
КонецФункции



Функция  СводныеПроводкиВФайл (НомерДок, ДатаДок, ВидДок, ИмяФайла) Экспорт
	
	Док = СоздатьОбъект("Документ");
	Если Док.НайтиПоНомеру(НомерДок, ДатаДок, ВидДок) = 0
	Тогда
		Возврат 0;
	КонецЕсли;
	
	тб = ПолучитьПроводки(Док);
	
	тб.Свернуть("ДтСчет,КтСчет","Количество,Сумма");
	
	ЗначениеВФайл(ИмяФайла, тб);
	Возврат 1;
	
КонецФункции



Функция  СводныеПроводки (Док) Экспорт
	
	тб = ПолучитьПроводки(Док);
	тб.Свернуть("ДтСчет,КтСчет","Количество,Сумма");
	
	Возврат тб;
	
КонецФункции



//	Возвращает список объектов метаданных указанного типа
Функция глПолучитьСписокОбъектовМетаданных (ТипОбъекта) Экспорт
	сп = СоздатьОбъект("СписокЗначений");

	Если ТипОбъекта = "Константа"
	Тогда
		Для Инд = 1 По Метаданные.Константа() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Константа(Инд).ПолныйИдентификатор()), 
								Метаданные.Константа(Инд).Идентификатор);
		КонецЦикла;

	ИначеЕсли ТипОбъекта = "Справочник"
	Тогда
		Для Инд = 1 По Метаданные.Справочник() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Справочник(Инд).ПолныйИдентификатор()), 
								Метаданные.Справочник(Инд).Идентификатор);
		КонецЦикла;
		
	ИначеЕсли ТипОбъекта = "Документ"
	Тогда
		Для Инд = 1 По Метаданные.Документ() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Документ(Инд).ПолныйИдентификатор()), 
								Метаданные.Документ(Инд).Идентификатор);
		КонецЦикла;
		
	ИначеЕсли ТипОбъекта = "Перечисление"
	Тогда
		Для Инд = 1 По Метаданные.Перечисление() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Перечисление(Инд).ПолныйИдентификатор()), 
								Метаданные.Перечисление(Инд).Идентификатор);
		КонецЦикла;
		
	ИначеЕсли ТипОбъекта = "Отчет"
	Тогда
		Для Инд = 1 По Метаданные.Отчет() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Отчет(Инд).ПолныйИдентификатор()), 
								Метаданные.Отчет(Инд).Идентификатор);
		КонецЦикла;
		
	ИначеЕсли ТипОбъекта = "Обработка"
	Тогда
		Для Инд = 1 По Метаданные.Обработка() Цикл
			сп.ДобавитьЗначение(Нрег (Метаданные.Обработка(Инд).ПолныйИдентификатор()), 
								Метаданные.Обработка(Инд).Идентификатор);
		КонецЦикла;
		
	КонецЕсли;
	
	Возврат сп;
КонецФункции



Функция ПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
	// функция для формирования значения цвета из составляющих (RGB)
	Возврат Макс(0,Синий)*65536+Макс(0,Зеленый)*256+Макс(0,Красный);
КонецФункции


Функция глНЕ (Оп) Экспорт
	Если Оп = 0
	Тогда
	    Возврат 1;
	Иначе
	    Возврат 0;
	КонецЕсли;
КонецФункции



//	Устанавливает пометки элеметов списка
//  Если Пометка = -1 - инверсия текущих пометок
Процедура ПометитьСписокЗначений (сп, Пометка=1) Экспорт
	Для Инд = 1 По сп.РазмерСписка() Цикл
	    Если Пометка < 0
	    Тогда
			сп.Пометка(Инд, глНЕ(сп.Пометка(Инд)));
	    Иначе
			сп.Пометка(Инд, Пометка);
	    КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Во внешней обработке, проводки документа из резервной базы данных помещаются в таблицу значений ПроводкиДляВосстановления. Перед тем, как записать их в рабочую базу данных, можете подвергнуть их изменениям в процедуре ОбработатьПроводкиДокументаПередВосстановлением. Это если хочется. Для простого восстановления проводок никакие дополнительные действия не требуются.

Сравнить - по нажатию этой кнопки сравниваются проводки документов в рабочей и в резервной базах данных. Можно ограничиться сравнением сводных проводок, когда количество и сумма  сворачиваются по счетам Дт и Кт. В таком случае, показывается  результат этого сравнения  для несовпадающих документов. Но далеко не всегда сравнение сводных проводок извлекает полный перечень документов, требующих восстановления. В процессе, можно сформировать список "кривых" документов.

Перепровести - перепроведение документов согласно полученного списка в рабочей базе данных.

Восстановить - восстановление проводок документов согласно полученного списка из резервной базы данных. Если флажок "Модифицировать проводки..." включен и вы прописали алгоритмы модификаций в процедуре ОбработатьПроводкиДокументаПередВосстановлением, - изменения будут выполнены перед записью.

Три маленьких кнопки над списками: первая устанавливает все флажки, вторая - сбрасывает, третья - инвертирует. Не думаю, что картинки у вас будут такие же, если вообще будут.

Скачать файлы

Наименование Файл Версия Размер
Восстановление бухгалтерских проводок из резервной базы данных в 1С7.7:

.ert 237,00Kb
10
.ert 237,00Kb 10 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. bullet030 3 30.03.17 10:37 Сейчас в теме
Бухгалтерский учет, редакция 4.5 (7,70,615)
Секция.Ячейка.ЦветФона (ПолучитьЦвет<<?>>(192, 255, 192));
Функция не обнаружена (ПолучитьЦвет)
Секция.Ячейка.ЦветФона (ПолучитьЦвет(192, 255, 192)<<?>>);
Неопознанный оператор
Секция.Ячейка.ЦветФона (ПолучитьЦвет(192, 255, 192))<<?>>;
Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
Секция<<?>>.Ячейка.Текст = "НомерСтр";
Переменная не определена (Секция)
Секция<<?>>.Ячейка.РамкаОбвести (3, 3, 3, 3);
Переменная не определена (Секция)
Таб<<?>>.ВывестиСекцию (Секция);
Переменная не определена (Таб)
Для НК=1 по тб<<?>>.КоличествоКолонок() Цикл
Переменная не определена (тб)
тб<<?>>.ПолучитьПараметрыКолонки(НК, , Дл, , Назв);
Переменная не определена (тб)
Секция<<?>>.Ячейка.Текст = Назв;
Переменная не определена (Секция)
Секция<<?>>.Ячейка.РамкаОбвести (3, 3, 3, 3);
Переменная не определена (Секция)
Таб<<?>>.ПрисоединитьСекцию (Секция);
Переменная не определена (Таб)
Для НС = 1 По тб<<?>>.КоличествоСтрок() Цикл
Переменная не определена (тб)
Секция = Таб<<?>>.ПолучитьСекцию("Ячейка|Значение");
Переменная не определена (Таб)
Если ИмеетсяПометка <<?>>= 1
Переменная не определена (ИмеетсяПометка)
Пометка = Число (тб<<?>>.ПолучитьЗначение(НС, "Пометка"));
Переменная не определена (тб)
Секция.Ячейка.ЦветФона (ПолучитьЦвет<<?>>(255, 192, 192));
Функция не обнаружена (ПолучитьЦвет)
Секция.Ячейка.ЦветФона (ПолучитьЦвет(255, 192, 192)<<?>>);
Неопознанный оператор
<<?>>КонецЕсли;
Ожидается ключевое слово 'КонецЦикла' ('EndDo')
КонецЕсли<<?>>;
Ожидается ключевое слово 'КонецЦикла' ('EndDo')
При проверке модуля обнаружены синтаксические ошибки!
Показать
2. romasna 267 30.03.17 10:45 Сейчас в теме
(1)Позволь узнать, ты не забыл добавить процедуры/функции в глобальный модуль? В их перечне есть функция ПолучитьЦвет(...).
3. bullet030 3 30.03.17 11:05 Сейчас в теме
(2)
ы не забыл добавить процедуры/функции в глобальный модуль
- зачем? где их взять?
Разве нельзя добавить все процедуры/функции в модуль обработки?
4. romasna 267 30.03.17 11:13 Сейчас в теме
Нет, все процедуры и функции я не могу включить в состав обработки. Есть жесткие ограничения (OLE). Часть из них все-равно будет в глобальном модуле (должна быть!). А их перечень я указал в статье. Нужно раскрыть ссылку в статье "Глобальный модуль показать/скрыть" и все процедуры/функции из открывшейся области перенести в глобальный модуль твоей конфигурации (рабочей и резервной баз данных). Естественно, если ты сам не программист, рекомендую эксперименты проводить на копиях БД.
5. bullet030 3 30.03.17 11:25 Сейчас в теме
Хорошо.
- Функция не обнаружена (глНЕ)
6. romasna 267 30.03.17 11:29 Сейчас в теме
(5)Спасибо за замечание. Добавил в конец глобального модуля в статье.
7. bullet030 3 30.03.17 16:17 Сейчас в теме
Ещё
по нажатию кнопки "Сравнить"
тбПроводки.НашаФирма = Опер.НашаФирма;
Поле агрегатного объекта не обнаружено (НашаФирма) Объект (Опер)
8. romasna 267 30.03.17 16:33 Сейчас в теме
(7)Моя обработка работает в комплексной конфигурации, в плане счетов есть разделитель учета. Судя по сообщению, у тебя разделителя учета нет. Везде, где найдешь "НашаФирма", - забей строки комментариями //. Например:
//тбПроводки.НашаФирма = Опер.НашаФирма;
Это касается и модуля обработки, и процедур глобального модуля.
9. romasna 267 30.03.17 17:17 Сейчас в теме
(7)Строго говоря, стоило бы посмотреть в конфигурации, есть ли разделитель учета. Потому что, если он все-таки имеется, но под другим именем, то "НашаФирма" следовало бы заменить на "ТвойРазделительУчета". Его можно найти в дереве конфигурации. Щелкни дважды мышаком в дереве по "Планы Счетов" и на выпавшей панели справа внизу реквизит "Разделитель учета". Значение его - это и есть ТвойРазделительУчета. Если разделитель не назначен, то достаточно ограничиться комментариями, как я писал в предыдущем сообщении.
10. romasna 267 31.03.17 13:53 Сейчас в теме
(7)Я допустил оплошность, не приняв во внимание, что состав доп.реквизитов проводок отличается в различных конфигурациях. Взвалил эту проблему на твою голову. Скачай обновленный файл обработки, замени процедуру глобального модуля ПолучитьПроводки. Не забудь перед ней вставить новую функцию ПолучитьРеквизитыПроводок.
Теперь можно использовать обработку в любой конфигурации без необходимости внесения изменений..
11. Afanasenkovv 17.07.18 18:46 Сейчас в теме
Испытал вашу обработку! релиз Бух7.7 644 релиз. Добавил все что надо в глмодуль, однако при сравнении не отражает сами проводки, при восстановлении выдает ошибку (в файле)
Прикрепленные файлы:
12. romasna 267 17.07.18 20:46 Сейчас в теме
(11)Сожалею об этом. Но чтобы выразить еще что-то , кроме сожаления, мне требовалось бы рассмотреть обе Ваши базы данных. К тому же, более чем за год, прошедший со времени написания обработки, я уже все подзабыл и требуется детальное рассмотрение самой обработки. Возможно, проблема с какой-то ручной операцией (при восстановлении из резервной БД). Можно попытаться восстановление проводить выборочно, шаг-за-шагом, по видам документов для выявления места, в котором глюк. Небольшими периодами. Выключить некоторые документы в списке "Кривые документы", - в сообщениях видно место затыка. В любом случае, разбираться с этим придется программисту. Прошу меня извинить, не понял Ваш статус...
Я не гарантирую восстановление проводок документов из резервной БД для ЛЮБЫХ, не ограниченных фантазией бухгалтеров, внесенных изменений. По крайней мере, состав документов и ручных операций не должен был измениться. В свое время, я восстанавливал с ее помощью проводки, изменившиеся после неосторожного пере-проведения документов в прошлых периодах, пять-десять лет назад. Они стали другие, итоги посыпались. Но сам набор документов и операций не менялся.
13. Afanasenkovv 17.07.18 22:53 Сейчас в теме
Спасибо за ответ! Начал разбираться с кодом, возникла необходимость)
14. user1240798 19.06.19 15:32 Сейчас в теме
Ищу бухгалтера для восстановления отчетности за 1-2 квартал 2019 на базе 1С 7.7. niko6607@mail.ru
Оставьте свое сообщение

См. также

Универсальный перенос объектов между базами с одинаковыми конфигурациями Промо

1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Универсальный перенос объектов между базами одинаковыми конфигурациями Обработка предназначена для переноса объектов из одной копии базы в другую. Структуры конфигураций должны быть идентичными. Обмен осуществляется через текстовый файл.

1 стартмани

29.11.2011    32458    315    Ivan4    23    

Деноминация оборотов и остатков в 1С7.7 (Беларусь)

Обработка документов Обработка справочников v77::БУ 1С7:Бух 1С7:ББУ Беларусь БУ Абонемент ($m)

Обработка проводит деноминацию оборотов, сумма каждой проводки делится на 10000. После этого остатки по счетам и субконто корректируются до эталонных значений. Также деноминируются реквизиты справочников.

1 стартмани

12.06.2016    30867    62    aselik    17    

Работа с 62 счетом в бухгалтерии

Обработка документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Сортировка 62 счета по субсчетам Обработка сама закрывает авансы, при этом она позволяет работать с кореспонденцией любого типа по 62 счету, например схлопнуть 62,4 на 62,1 , а затем 62,1 на 62,2 или сразу 62,2 на 62,1 ,т.е. сколько раз хотите столько и запустите с различными вариациями.

1 стартмани

18.10.2013    24985    30    zavsom    3    

Модификация стандартного механизма УРБД в 1С 7.7

Распределенная БД (УРИБ, УРБД) 1С7.7<->1C7.7 v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет реализовать нестандартную схему обмена данными между распределенными базами в 1С 7.7, когда нужен обмен между группами периферийных баз. Такая ситуация может сложиться, когда у предприятия есть филиалы в разных городах, а в пределах филиала-города должно работать несколько офисов и складов (группа периферийных баз). Между периферийными базами одного города должен быть обмен всеми данными, в центральную базу должны попадать данные из всех городов. Причем, разные города не должны видеть данные другого города.

7 стартмани

15.12.2012    24076    16    axxell    3    

Универсальная загрузка данных : Прыг-Скок...или из MS EXCEL в 1С (7.7) или как "забить товар" Промо

Загрузка и выгрузка в Excel Обработка документов v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Предыстория: постоянно на форуме спрашивают - "как загрузить из EXCEL в 1С нужную информацию?" и начинается... Готовый пример КАК...

1 стартмани

19.04.2010    57989    1738    Tatitutu    97    

Групмейкер для таблицы значений.

Инструментарий разработчика Практика программирования Универсальные обработки v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Универсальная функция и обработка для свертки и группировки таблицы значений. Очень простой способ подвести итоги по призвольным группам в произвольном порядке любой таблицы значений для быстрого вывода на печать нужной пользователю последовательности и детализации группировок.

1 стартмани

20.11.2012    25844    58    dusha0020    15    

Acc77: Зачет авансов по счету 76.АВ для «1С: Бухгалтерия 7.7 редакция 4.5»

Обработка документов Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Внешняя обработка "Зачет авансов по счету 76.АВ" для «1С: Бухгалтерия 7.7 редакция 4.5». Отличительной особенностью данной разработки является полностью автоматизированное программное создание комплекта документов "Запись книги покупок" и "Счет-фактура выданный (на аванс)" за произвольный период по данным бухгалтерского учета с возможностью неоднократной обработки рабочего периода. Таким образом, после проверки корректности взаиморасчетов с покупателями для закрытия периода по разделу "НДС с авансов полученных" бухгалтеру будет достаточно самостоятельно запустить обработку нужного периода.

3 стартмани

29.07.2012    34783    49    Chastiser    12    

Перенос данных об уплаченных страховых взносах из программ бухгалтерского учета в программу расчета заработной платы Промо

Зарплата 1С7.7<->1C7.7 Зарплата v77::БУ v77::Расчет 1cv7.md 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ПУБ Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Перенос данных об уплаченных страховых взносах из программ бухгалтерского учета семейства "1С:Предприятие 7.7" в программу расчета заработной платы "1С:Зарплата и кадры 7.7"

1 стартмани

06.10.2010    31676    268    bb1962    18    

Загрузки для УСН и Бухгалтерии из ТиС

1С7.7<->1C7.7 Обработка документов v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Абонемент ($m)

Используется OLE-соединение.

1 стартмани

03.07.2012    14921    64    aianitro    11    

Расчет Страховых Взносов 2012 (РСВ-1 для ПФР) (Выгрузка из ЗиК - Загрузка в Бухгалтерию)

1С7.7<->1C7.7 Зарплата Зарплата v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ НУ ФОМС, ПФ, ФСС Абонемент ($m)

Выгрузка данных по РСВ-1 из ЗиК 323 релиза в комплект отчетности Бух 7.7 за 2012 год

1 стартмани

03.05.2012    28172    298    b-dm    42    

Расчет компенсации за неиспользованный отпуск: Теперь и для 1С Бухгалтерии 7.7 c возможностью расчета среднего заработка Промо

Обработка документов Зарплата Зарплата v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Расчет компенсации за неиспользованный отпуск - теперь и для 1С Бухгалтерии 7.7 с расчетом среднего заработка

3 стартмани

26.04.2012    32028    207    Krasnyj    44    

Доработанный универсальный подбор объектов UChoice

Универсальные обработки Сервисные утилиты Инструментарий разработчика v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Основные изменения - поддержка выражений на встроенном языке при замене значений, обработка табличных частей документов.

2 стартмани

27.04.2012    21510    168    wenzor    4    

1С7 - подготовка базы данных к переносу в 1С8 (БГУ)

Сервисные утилиты Универсальные обработки Перенос данных из 1С7.7 в 1C8.X v77::БУ 1С7:ББУ Россия Госбюджет Абонемент ($m)

В помощь людям, конвертирующим БД 1СV7 (Бюджет) в БД 1С8 (БГУ). Инструмент, помог на десятках "плохих" Гиго-образных БД. Включен универсальный Прогресс-индикатор (отлажен), и кое-что еще. Прошу относиться как к рабочему инструменту (без глянца). Исправления, тем более дополнения, принимаются с благодарностью.

1 стартмани

10.04.2012    18282    124    newold2    11    

Исправление документов в 1С 7.7

Инструментарий разработчика Администрирование данных 1С Обработка документов v77::ОУ v77::БУ 1cv7.md Россия Абонемент ($m)

Утилита для оперативного внесения изменений в любой документ базы данных, включая невидимые на форме реквизиты.

1 стартмани

29.03.2012    21256    96    alf2006x    5    

Добавляем проводки в документы Промо

Обработка документов v77::БУ 1С7:Бух 1С7:ПУБ 1С7:ББУ Россия БУ Абонемент ($m)

Добавляем проводки в документы

1 стартмани

22.09.2011    19358    68    Михаська    4    

Перенумератор документов

Обработка документов v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Обработка позволяет автоматизировать перенумерацию документов любого вида в любой конфигурации 1с v 7.7 за определенный период

1 стартмани

27.03.2012    10003    173    PiterPrg    4    

Правила переноса документов Заявка на кассовый расход, Доверенность и Платежное поручение из 7.7 в 8.2 от 02.04.2012 (правила проверены на Бухгалтерия бюджетного учреждения 7.70.646 в Бухгалтерия государственного учреждения 1.0.10.2)

Перенос данных из 1С7.7 в 1C8.X Обработка документов Обмен через XML Банковские операции Кассовые операции Банковские операции Кассовые операции v77::БУ 1С7:ББУ БГУ Россия Госбюджет Абонемент ($m)

Правила переноса документов Заявка на кассовый расход, Доверенность и Платежное поручение из 7.7 в 8.2 от 02.04.2012 (правила проверены при переносе из Бухгалтерия бюджетного учреждения 7.70.646 в Бухгалтерия государственного учреждения 1.0.10.2), доработанные из правил переноса в ББУ 1.0.22.1 из http://infostart.ru/public/85835/

1 стартмани

15.03.2012    22897    278    Anthon    63    

Загрузка данных : Прыг-Скок...или из MS EXCEL в 1С (7.7) или как "забить материал или товар"

Обработка документов Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ 1С7:ББУ Абонемент ($m)

На основании публикации Tatitutu (http://infostart.ru/public/69253/) сделана попытка получить работающую загрузку экселевских счетов-фактур только для двух документов: "Поступление материалов" и "Поступление товаров".

1 стартмани

06.03.2012    19736    106    jack19    7    

Заменяем сумму в выбранной проводке документа Промо

Обработка документов v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ 1С7:ББУ Россия БУ Абонемент ($m)

Заменяем сумму в выбранной проводке документа

1 стартмани

22.09.2011    17439    36    Михаська    8    

Автоматическое создание документов "Перечисление НДФЛ в бюджет" для ЗиК 7.7

Обработка документов Зарплата Зарплата v77::ОУ v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ТиС Россия БУ НДФЛ Абонемент ($m)

Уж недалек отчет, а документы распределения НДФЛ по работникам за 2011 год не введены. Можно ввести их вручную, а можно воспользоваться обработкой, выгрузить их в MS Excel и сформировать автоматически. Для этого подготовлен данный комплекс обработок.

1 стартмани

05.03.2012    26550    95    Krasnyj    43    

Автозаполнение документов "Перечисление НДФЛ в бюджет РФ"

Обработка документов Зарплата Зарплата v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ НДФЛ Абонемент ($m)

Универсальная загрузка документов "Перечисление НДФЛ в бюджет РФ". Вызывается и из ЗиК, и из бух.конфигураций. Загрузка на основе данных бухгалтерского учета.

1 стартмани

27.02.2012    19173    87    Pin    22    

Универсальный обмен данными UNIDATA 1с77

Загрузка и выгрузка в Excel Обмен через XML 1С7.7<->1C7.7 v77::ОУ v77::БУ 1cv7.md Абонемент ($m)

Моя авторская обработка для обмена данными для 1с77

1 стартмани

07.02.2012    27457    261    fixin    19    

Объединить 2 операции в одну Промо

Обработка документов v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ 1С7:ББУ БУ Абонемент ($m)

Объединить 2 операции в одну (проводки пишутся в последнюю)

1 стартмани

22.09.2011    18633    35    Михаська    1    

Подготовка документов для сдачи отчетов по зарплате 2011-2012 г.

Обработка документов Зарплата Зарплата v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ НДФЛ Абонемент ($m)

Для распределения уплаченных сумм налога по сотрудникам организации и отражения перечисленного налога с 2011г требуется вводить 2 новых вида документа. Данная обработка создана для упрощения этого процесса

1 стартмани

31.01.2012    13075    112    MegaMouse    16    

Экспорт налоговых накладных в M.E.Doc (медок, medoc) в формате XML для Украины

Обработка документов Обмен через XML v77::БУ 1С7:Бух Украина БУ НУ НДС Абонемент ($m)

Экспорт налоговых накладных в M.E.Doc (медок, medoc) в формате XML для Украины

1 стартмани

18.01.2012    23191    37    Batchir    14    

Экспорт налоговых накладных в XML (Украина). Импорт даты внесения в реестр ДПА из системы документооборота М.E.Doc

Обмен через XML Обработка документов v77::ОУ v77::БУ 1cv7.md Украина БУ НУ НДС Абонемент ($m)

Обработка (для 1С 7.7. АБТ 3.5.5 и выше) позволяет сделать экспорт проведенных налоговых накладных указанной Организации за выбранный период по указанному пути с последующим импортом в OPZ или М.E.Doc. Также выполняется импорт результатов внесения в реестр ДПА (даты занесения в реестр) из М.E.Doc в 1С.

1 стартмани

06.01.2012    164827    81    Sykoku    58    

Сравнение 2х однотипных баз Промо

Анализ учета 1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет определить какие данные были внесены в 2 ОДНОТИПНЫХ базах, например, архивах за разные числа (проверка объектов в целом, не по реквизитам) Обновил: Добавил возможность выборочного сравнения :)

1 стартмани

19.08.2009    28632    341    DarkAn    24    

Обработка выборки документов и выборочное перепроведение по видам движений для 1С-Предприятие-7.7

Обработка документов Сервисные утилиты v7.7 openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет выполнить над подобранным списком документов следующие действия: 1) "Провести"; 2) "Отменить проведение"; 3) "Пометить на удаление"; 4) "Снять пометку на удаление"; 5) "Удалить непосредственно"; 6) "Сменить фирму" (если есть общий реквизит 'Фирма'). Имеются удобные инструменты для подбора выборки документов (Подбор в обработках 'ПодборUChoice' и 'Консоль1CQA'). Реализованы различные опции обработки документов (в том числе 'выборочное проведение по видам движений'). Описана технология выборочного проведения документов по видам движений.

1 стартмани

04.01.2012    37967    289    yuraos    26    

Групповая выгрузка налоговых накладных в XML (1С:Бухгалтерия 7.7 для Украины)

Обмен через XML Обработка документов v77::БУ 1С7:Бух Украина БУ НУ НДС Абонемент ($m)

Автоматическая выгрузка пакета налоговых накладных в XML.

1 стартмани

30.12.2011    33626    98    OrfeyZP    23    

Создание Счет-фактур на авансы

Обработка документов Оптовая торговля Оптовая торговля v77::БУ 1С7:Бух Россия БУ НУ НДС Абонемент ($m)

Авансовые Счета-фактуры за указанный период

1 стартмани

19.12.2011    6458    49    rom-yura    7    

Универсальная обработка по переносу документов. Промо

1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Универсальная обработка по переносу документов (через текст), сделанная на основе Универсальной обработки по переносу справочников фирмы 1С "tranref", позволяет переносить документы из любой конфигурации в любую. Перенос осуществляется только по КОДАМ.

1 стартмани

17.10.2007    34443    7252    idw    67    

Инвентаризация по счетам МЦ.02, МЦ.03, МЦ.04

Обработка документов Печатные формы документов Бухгалтерские Учет ТМЦ Учет ТМЦ v77::БУ 1С7:Бух Абонемент ($m)

Документ инвентаризации по счетам МЦ.02, МЦ.03, МЦ.04 с суммовым учетом + печатная форма ИНВ-3 + возможность смены материально ответственного лица.

1 стартмани

08.12.2011    12198    99    fedorova_tv    10    

Перепроведение документов и перестановка их по времени

Обработка документов Сервисные утилиты v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка для перестановки по времени документов в течении дня. Можно использовать для того, чтобы определенный вид документов переместить в начало дня (с определенного времени) например "Поступление товаров", затем "Реализацию товаров" и т.д.

1 стартмани

30.11.2011    12753    121    sanyav    6    

Групповая обработка объектов

Универсальные обработки Обработка документов Обработка справочников v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Обработка предназначена для группового изменения реквизитов (в том числе системных) объектов одного вида, а также формирования простейшей выборки оригинальных или модифицированных значений реквизитов для печати

1 стартмани

28.11.2011    19892    302    VGHOST    16    

Обработки документов и справочников

Обработка документов Обработка справочников v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Три простые обработки, которые, надеюсь, помогут в работе. 1. Сдвиг разрядов номера документа влево. 2. Редактирование наименований справочников. 3. Изменение реквизитов справочников.

1 стартмани

27.11.2011    16098    82    BorisBelov    5    

Автоматический подбор ГТД в счете-фактуре выданном

Обработка документов Оптовая торговля Оптовая торговля v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Реализована функция автоматического подбора номеров ГТД в документе "Счет-фактура выданный".

1 стартмани

25.11.2011    13864    49    severchukov    10    

Обработка «Изменение времени документа» для 1С:Предприятие 7.7

Обработка документов v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет из одного диалога сразу изменить дату-время документа, как не проведенного, ТАК И ПРОВЕДЕННОГО. В остальном она полностью имитирует действия системной обработки. Обработка может использоваться как самостоятельно, так и открываться для изменения документа при исполнении кода, например, в обработчике расшифровки значения ячейки табличного документа.

1 стартмани

09.11.2011    50233    165    yuraos    43    

Обмен данными через DBF-файлы для 1С 7.7 - методика и практика (версия 3)

Файловые протоколы обмена, FTP Обработка документов 1С7.7<->1C7.7 v8 v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС 1С7:ПУБ Абонемент ($m)

Предлагается методика обмена данными через DBF-файлы между практически любыми конфигурациями 1С 7.7, а также (в определенных случаях) между конфигурациями 1С 8.х, между 7.7 и 8.х и даже между 1С и не-1С системами...

1 стартмани

02.11.2011    51825    571    vkr    107    

Точный перенос данных по OLE (Импорт по OLE) 7.7 + Точная замена объектов

1С7.7<->1C7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Точный перенос данных по OLE (подключение к другой базе) с возможностью переноса не только справочников и документов, но и счетов, значений констант, проводок, периодических значений справочников, как с привязкой документов, так и без нее, ДВИЖЕНИЙ ПО РЕГИСТРАМ И ЗАПИСЕЙ ЖУРНАЛОВ РАСЧЕТА и другими дополнительными возможностями. Замена объектов в регистрах, периодических реквизитах и записях журнала расчетов.

1 стартмани

31.10.2011    27632    506    Anthon    73    

Переход с упрощенной системы налогообложения на общую (или наоборот) (1c v7.x)

Свертка базы 1С7.7<->1C7.7 Обработка документов v77::БУ 1С7:Бух Россия БУ НУ Налог на прибыль УСН Абонемент ($m)

Предлагаю опробованную методику перехода с УСН на ОСН (или наоборот) и инструментарий для её реализации. Переход можно выполнить на любую дату (актуально при вынужденной смене системы налогообложения из за превышения лимита выручки или численного состава (как правило это выясняется, когда очередной квартал уже завершён...)). Конфигурации могут быть не типовыми, более того предлагаемые обработки пригодны для переноса справочников и документов между любыми конфигурациями 1C v7.Х.

1 стартмани

31.10.2011    22581    393    БоНН    17    

Ошибки в объекте - первоисточнике: найти и уничтожить!

Универсальные обработки Поиск данных v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка изначально создавалась для выбора объектов, форма списка которых запрещает интерактивный выбор. Позднее она "обросла" множеством фильтров и отборов и получила возможность вызывать универсальные редакторы для корректировки объектов.

1 стартмани

18.10.2011    12150    49    warenic    10    

Загрузить данные в документы поступлений из Excel

Загрузка и выгрузка в Excel Обработка документов v77::БУ 1С7:Бух 1С7:Комплекс БУ Абонемент ($m)

Пример простой загрузки данных в документы поступлений из файла Excel (для Комплексной конфигурации)

1 стартмани

17.10.2011    9791    57    t_yuri    7    

Выгрузка формы 4-ФСС из Зарплаты 7.7 в Бухгалтерию 7.7

Зарплата 1С7.7<->1C7.7 Регламентированная отчетность Зарплата v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ НУ ФОМС, ПФ, ФСС Абонемент ($m)

Выгрузка отчета по ФСС из Зарплаты и загрузка для Бухгалтерии 7.7 с 2011 года

1 стартмани

14.10.2011    19969    110    b-dm    31    

Замена элемента справочника для Предприятия 7.7

Обработка документов v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Заменть один элемент справочника другим. Во всех документах, справочниках и субконто операций. Отредактировать периодические реквизиты, ссылающиеся на заменяемый элемент. Независимо от конфигурации и за произвольный период.

1 стартмани

06.10.2011    17470    164    dusha0020    26